Wednesday, November 25, 2009

MPLS L3 VPN with PE-CE as ISIS and OSPF LAB


Configuration Guidelines::VRF Used "CEA"RD Used "64513:1"RT Used "64513:100"AS Used "64513"PE-CE Routing Used "ISIS" between CE1A-PE1 & “OSPF” between CE2A-PE2IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1
********************************************************************************

CE2A#sh running-config
Building configuration...

Current configuration : 1187 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.40.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 172.16.20.2 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.20.0 0.0.0.3 area 0
!
ip classless
!
ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

CE2A#

CE1A#sh running-config
Building configuration...

Current configuration : 1201 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.30.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 172.16.10.2 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
router isis
net 49.0002.6666.5555.4444.00
redistribute connected route-map Local level-1
!
ip classless
!
ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

CE1A#
CE1A#

PE1#sh running-config
Building configuration...

Current configuration : 2322 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 172.16.10.1 255.255.255.252
ip router isis CEA
serial restart-delay 0
isis circuit-type level-1
!
interface Serial1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router isis CEA
vrf CEA
net 49.0002.1111.2222.3333.00
redistribute bgp 64513 level-1
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute isis CEA level-1-2
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

PE1#

P#sh running-config
Building configuration...

Current configuration : 1623 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.2222.3333.1111.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

P#

PE2#sh running-config
Building configuration...

Current configuration : 2312 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip vrf forwarding CEA
ip address 172.16.20.1 255.255.255.252
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.20.0 0.0.0.3 area 0
!
router isis
net 49.0001.3333.1111.2222.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

PE2#

OUPUT
********************************************************************
PE1#show ip route vrf CEA

Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 2 subnets
i L1 10.0.1.1 [115/10] via 172.16.10.2, Serial1/0
B 10.0.5.1 [200/20] via 10.0.4.1, 00:03:37
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C 172.16.10.0/30 is directly connected, Serial1/0
L 172.16.10.1/32 is directly connected, Serial1/0
B 172.16.20.0/30 [200/0] via 10.0.4.1, 00:06:37
i L1 172.16.30.0/24 [115/10] via 172.16.10.2, Serial1/0
B 172.16.40.0/24 [200/20] via 10.0.4.1, 00:03:37
PE1#sho
PE1#show is
PE1#show isis CEA nei
PE1#show isis CEA neighbors

Tag CEA:
System Id Type Interface IP Address State Holdtime Circuit Id
CE1A L1 Se1/0 172.16.10.2 UP 21 00
PE1#

PE2#show ip route vrf CEA

Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 2 subnets
B 10.0.1.1 [200/10] via 10.0.2.1, 00:09:18
O E2 10.0.5.1 [110/20] via 172.16.20.2, 00:08:51, Serial1/1
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
B 172.16.10.0/30 [200/0] via 10.0.2.1, 00:09:18
C 172.16.20.0/30 is directly connected, Serial1/1
L 172.16.20.1/32 is directly connected, Serial1/1
B 172.16.30.0/24 [200/10] via 10.0.2.1, 00:09:18
O E2 172.16.40.0/24 [110/20] via 172.16.20.2, 00:08:51, Serial1/1
PE2#sho
PE2#show ip os
PE2#show ip ospf nei
PE2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.0.5.1 0 FULL/ - 00:00:30 172.16.20.2 Serial1/1
PE2#

CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.40.0/24 is directly connected, FastEthernet0/0
O E2 172.16.30.0/24 [110/10] via 172.16.20.1, 00:09:04, Serial0/0
C 172.16.20.0/30 is directly connected, Serial0/0
O E2 172.16.10.0/30 [110/1] via 172.16.20.1, 00:09:04, Serial0/0
10.0.0.0/32 is subnetted, 2 subnets
O E2 10.0.1.1 [110/10] via 172.16.20.1, 00:09:04, Serial0/0
C 10.0.5.1 is directly connected, Loopback0
CE2A#sho
CE2A#show ip os
CE2A#show ip ospf nei
CE2A#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.16.20.1 0 FULL/ - 00:00:34 172.16.20.1 Serial0/0
CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/74/136 ms
CE2A#ping 172.16.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/89/140 ms
CE2A#

CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
i L1 172.16.40.0/24 [115/10] via 172.16.10.1, Serial0/0
C 172.16.30.0/24 is directly connected, FastEthernet0/0
i L1 172.16.20.0/30 [115/10] via 172.16.10.1, Serial0/0
C 172.16.10.0/30 is directly connected, Serial0/0
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.1.1 is directly connected, Loopback0
i L1 10.0.5.1 [115/10] via 172.16.10.1, Serial0/0
CE1A#sho
CE1A#show isi
CE1A#show isis nei
CE1A#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
PE1 L1 Se0/0 172.16.10.1 UP 20 00
CE1A#ping 10.0.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/66/140 ms
CE1A#ping 172.16.40.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.40.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/90/152 ms
CE1A#

No comments:

Post a Comment