Friday, July 9, 2010

Implementing NGN HSI/IPTV with IPoE using RSVP TE P2MP LAB

















Configuration Guidelines
***********************************************************
Scenario: An ISP wants to transtion to Next Generation Networks
Architecture thereby to offer High Speed Internet Access
and IPTV Services by leveraging its existing MPLS Core Network
and not running native Multicast in its Core.Also ISP wants to
use IPoE at the Access/Aggregation Layet towards Customer Handoff
for IP Assignment

Design Consideration and Solution:

There are two possinle solutions for offering Multicast Services
to Customers witout running native Multicast in SP Core.
1. Using P2MP RSVP-TE Tunnels
2. using NGN MVPN over m-LDP

Here we are focussing on 1st solution to provide IPTV services by
creating point-to-multipoint TE across SP Core with the help of RSVP
TE Extensions.The Head of the P2MP RSVP TE is rooted at the PE peering
to IPTV and we need to join the IPTV Channels on the P2MP TE Headend
Tunnel.The P2MP RSVP TE creates LSP Virtual Interfaces on the Tail Ends
for the Multicast Communication back to the head end and also so that
the RPF does not fails as the tail ends are for the individual P2P
sub-LSPs for the P2MP RSVP TE.

Access Link to EUs are normal Internet Links and using PIM SSM between
PE-CE and on the Edge PEs Customers can Switch to their desire of channel
and STBs can receive the interested Multicast Streamm for the Channel
The SP Core is free from Native Multicast and the Multicast Communication
happens over the LSP Virtual Interfaces.


Challenges: Static mroutes are needed on PEs connecting to Customers
Since we are using LSP Virtual Interfaces We will also need to define
static mroutes at the PEs connecting to Customers pointing back to
P2MP TE Headend for rpf sanity.

ISP IGP used OSPF Area 0
Primary Onehop Auto-Tunnels and Primary nhop-only Backup Tunnels used in
SP Core.
PE-CE ROuting Protocol used EBGP
PIM SSM Used for PE-CE
IGMP Group used for Testing 232.1.1.1;232.2.2.2


ISP is using IPoE across its Access/Aggregation Layer to connect
the Customers to the SP Network Gateway for HSI/IPTV
IPoE/Static IPs.



HSI can be delivered over DHCP IPoE by using a VRF for Internet Services
across SP Core and IPTV can be delivered over IPoE as well utilising DHCP.
IPTV and Internet can be clubbed together by manipulating Routing Information
across SP Core.

ISP AS used 64513
IGP used OSPF Area0 both in MPLS Core and Aggregation
VRF used in Core N/W
Internet
rd 64513:1
rt 64513:100
IPTV IGMP Group used 232.17.17.17


Static Pool used 10.0.110.0/24
DHCP Pool used 10.0.110.0/24 for VRF Internet
DHCP Pool used 10.0.120.0/24 for IPTV+Internet



VlANS used at Aggregation
Service VLAN 10 used for Internet Services
Service VLAN 20 used for IPTV+Internet Services
Service VLAN 30 used for Management Network


PIM SSM used for IPTV

CE

cus1.pop2 is an Internet Customer

cus1.pop3 is an IPTV+Internet Customer with Static IP

IGMP Group used 232.17.17.17for IPTV
Source 192.168.101.0/24 & 192.168.201.0/24

Internet Dummy Networks used 172.16.101.0/24
& 172.16.201.0/24
**********************************************************

Internet+IPTV#sh running-config
Building configuration...

Current configuration : 2578 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet+IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.255
!
interface Loopback1
ip address 172.16.201.1 255.255.255.0
!
interface Loopback2
ip address 192.168.101.1 255.255.255.0
ip pim sparse-mode
!
interface Loopback3
ip address 192.168.201.1 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description ISP
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
frame-relay lmi-type cisco
!
interface Serial1/0.102 point-to-point
description ISP-Internet
ip address 172.16.1.2 255.255.255.252
no snmp trap link-status
frame-relay interface-dlci 102
!
interface Serial1/0.103 point-to-point
description ISP-IPTV
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
frame-relay interface-dlci 103
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.0.0
network 192.168.0.0 mask 255.255.0.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description ISP-Internet
neighbor 172.16.1.1 soft-reconfiguration inbound
neighbor 172.16.1.1 route-map Internet out
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 route-map IPTV out
no auto-summary
!
ip http server
ip classless
ip route 172.16.0.0 255.255.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim ssm default
!
!
ip prefix-list IPTV seq 5 permit 192.168.0.0/16
ip prefix-list IPTV seq 10 permit 172.16.0.0/16
!
ip prefix-list Internet seq 5 permit 172.16.0.0/16
!
route-map IPTV permit 10
match ip address prefix-list IPTV
!
route-map Internet permit 10
match ip address prefix-list Internet
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

Internet+IPTV#

cus1.pop3#sh running-config
Building configuration...

Current configuration : 1017 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
no ip route-cache
ip igmp join-group 232.14.14.14 source 192.168.101.1
ip igmp join-group 232.14.14.14 source 192.168.201.1
!
interface FastEthernet0/0
description access.pop3
ip address dhcp
no ip route-cache
ip igmp join-group 232.17.17.17 source 192.168.101.1
ip igmp join-group 232.17.17.17 source 192.168.201.1
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
duplex auto
speed auto
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop3#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 817 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
no ip route-cache
!
interface FastEthernet0/0
description edge1.pop2
ip address dhcp
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

cus1.pop2#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 4800 bytes
!
! Last configuration change at 15:08:01 UTC Thu Jul 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
no ip domain lookup
ip multicast-routing
ip multicast mpls traffic-eng
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
!
mpls traffic-eng destination list name P2MP
ip 10.0.3.1 path-option 1 explicit name edge1.pop2
ip 10.0.4.1 path-option 1 explicit name edge1.pop3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface Tunnel100
description P2MP
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.17.17.17 source 192.168.101.1
ip igmp static-group 232.17.17.17 source 192.168.201.1
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng fast-reroute
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-L1
ip address 10.0.10.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface Serial2/0
description Internet-IPTV
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface Serial2/0.102 point-to-point
description Internet
ip vrf forwarding Internet
ip address 172.16.1.1 255.255.255.252
frame-relay interface-dlci 102
!
interface Serial2/0.103 point-to-point
description IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
frame-relay interface-dlci 103
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.3.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description Internet
neighbor 192.168.1.2 remote-as 64514
neighbor 192.168.1.2 description IPTV
!
address-family ipv4
no synchronization
network 10.0.0.0
neighbor iBGP send-community
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
neighbor 172.16.1.2 route-map eBGP in
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
neighbor 192.168.1.2 route-map IPTV in
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description Internet
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
exit-address-family
!
no ip http server
no ip http secure-server
!
ip bgp-community new-format
!
ip pim ssm default
ip route 10.0.0.0 255.0.0.0 Null0
!
ip explicit-path name edge1.pop2 enable
next-address 10.0.10.2
next-address 10.0.20.1
!
ip explicit-path name edge1.pop3 enable
next-address 10.0.10.2
next-address 10.0.30.1
!
!
route-map IPTV permit 10
set community 64513:999
!
route-map eBGP permit 10
set community 64513:199
!
route-map Local permit 10
match interface Serial2/0.102 Serial2/0.103
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop1#

core1.pop1#sh running-config
Building configuration...

Current configuration : 1634 bytes
!
! Last configuration change at 15:10:54 UTC Thu Jul 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description edge1.pop3
ip address 10.0.30.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

core1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 3119 bytes
!
! Last configuration change at 14:06:54 UTC Thu Jul 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
ip dhcp pool Internet
vrf Internet
network 10.0.110.0 255.255.255.0
!
!
no ip domain lookup
ip multicast-routing
ip multicast mpls traffic-eng
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description cus1.pop1
ip vrf forwarding Internet
ip address 10.0.110.1 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.3.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 172.16.2.2 remote-as 64515
neighbor 172.16.2.2 description cus1.pop2
!
address-family ipv4
no synchronization
neighbor iBGP send-community
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 soft-reconfiguration inbound
neighbor 172.16.2.2 route-map cus_standard_hsi out
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor 10.0.1.1 activate
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
ip bgp-community new-format
ip community-list standard IPTV permit 64513:999
ip community-list standard eBGP permit 64513:199
!
ip pim ssm default
ip mroute 192.168.101.0 255.255.255.0 10.0.1.1
ip mroute 192.168.201.0 255.255.255.0 10.0.1.1
ip mroute 192.168.1.0 255.255.255.252 10.0.1.1
!
!
route-map cus_standard_hsi deny 10
match community IPTV
!
route-map cus_standard_hsi permit 20
match community eBGP
!
route-map Local permit 10
match interface FastEthernet2/0
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop2#

edge1.pop3#sh running-config
Building configuration...

Current configuration : 2889 bytes
!
! Last configuration change at 14:53:32 UTC Thu Jul 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
no ip domain lookup
ip multicast-routing
ip multicast mpls traffic-eng
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.30.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description agggregator.pop3
ip address 10.0.40.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
mpls ip
mpls label protocol ldp
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute bgp 64513 subnets route-map ebgp-to-ospf
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.4.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
!
address-family ipv4
no synchronization
bgp redistribute-internal
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor 10.0.1.1 activate
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
ip bgp-community new-format
ip community-list standard eBGP permit 64513:199
ip community-list standard IPTV permit 64513:999
!
ip pim ssm default
ip mroute 192.168.101.0 255.255.255.0 10.0.1.1
ip mroute 192.168.201.0 255.255.255.0 10.0.1.1
ip mroute 192.168.1.0 255.255.255.252 10.0.1.1
!
!
route-map ebgp-to-ospf permit 10
match community eBGP
!
route-map ebgp-to-ospf permit 20
match community IPTV
!
route-map Local permit 10
match interface FastEthernet2/0
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop3#

aggregator.pop3#sh running-config
Building configuration...

Current configuration : 2031 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname aggregator.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
ip dhcp pool Internet+IPTV
network 10.0.120.0 255.255.255.0
!
!
ip multicast-routing
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.5.1 255.255.255.255
!
interface FastEthernet0/0
description edge1.pop3
ip address 10.0.40.2 255.255.255.252
ip pim sparse-mode
ip igmp join-group 232.4.4.4 source 192.168.101.1
ip igmp join-group 232.4.4.4 source 192.168.201.1
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
description acccess.pop3
switchport trunk allowed vlan 1,2,10,20,30,1002-1005
switchport mode trunk
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan20
description Internet+IPTV
ip address 10.0.120.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.17.17.17 source 192.168.101.1
ip igmp join-group 232.17.17.17 source 192.168.201.1
!
interface Vlan30
description MGT
ip address 10.0.130.1 255.255.255.0
!
router ospf 1
router-id 10.0.5.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

aggregator.pop3#

access.pop3#sh running-config
Building configuration...

Current configuration : 1491 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname access.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
description aggregator.pop3
switchport trunk allowed vlan 1,2,10,20,30,1002-1005
switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
switchport access vlan 10
!
interface FastEthernet2/14
!
interface FastEthernet2/15
description cus1.pop3
switchport access vlan 20
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan30
description MGT
ip address 10.0.130.2 255.255.255.0
!
ip default-gateway 10.0.130.1
ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

access.pop3#

****************************
OUTPUT
****************************
UNICAST TRAFFIC
****************************
cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.110.1 88 msec 96 msec 288 msec
2 10.0.20.2 360 msec 632 msec 384 msec
3 172.16.1.1 368 msec 1048 msec 240 msec
4 172.16.1.2 1024 msec * 844 msec
cus1.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 10.0.110.1 404 msec 72 msec 480 msec
2 10.0.110.1 !H * !H
cus1.pop2#

cus1.pop3#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 10.0.120.1 200 msec 48 msec 24 msec
2 10.0.40.1 456 msec 504 msec 384 msec
3 10.0.30.2 344 msec 464 msec 328 msec
4 10.0.10.1 488 msec 712 msec 528 msec
5 192.168.1.2 808 msec 616 msec 328 msec
cus1.pop3#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.120.1 64 msec 72 msec 96 msec
2 10.0.40.1 336 msec 312 msec 360 msec
3 10.0.30.2 288 msec 456 msec 480 msec
4 10.0.10.1 368 msec 672 msec 648 msec
5 192.168.1.2 1080 msec 384 msec 640 msec
cus1.pop3#

aggregator.pop3#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.0.120.2 0063.6973.636f.2d63. Mar 02 2002 12:55 AM Automatic
6330.372e.3065.3230.
2e30.3030.302d.4661.
302f.30
aggregator.pop3#


edge1.pop2#sh ip dhcp binding vrf Internet

Bindings from VRF pool Internet:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.0.110.2 0063.6973.636f.2d63. Jul 09 2010 02:52 PM Automatic
6330.342e.3065.3230.
2e30.3030.302d.4661.
302f.30
edge1.pop2#

****************************
MULTICAST TRAFFIC
****************************

Internet+IPTV#ping 232.17.17.17 source lo2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.17.17.17, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 10.0.40.2, 596 ms
Reply to request 0 from 10.0.120.2, 884 ms
Reply to request 0 from 10.0.120.2, 884 ms
Reply to request 0 from 10.0.40.2, 812 ms
Internet+IPTV#ping 232.17.17.17 source lo3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.17.17.17, timeout is 2 seconds:
Packet sent with a source address of 192.168.201.1

Reply to request 0 from 10.0.40.2, 580 ms
Reply to request 0 from 10.0.120.2, 868 ms
Reply to request 0 from 10.0.120.2, 772 ms
Reply to request 0 from 10.0.40.2, 628 ms
Internet+IPTV#

access.pop3#sh mac-address-table
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
cc06.0e20.0000 Self 1 Vlan1
cc06.0e20.0000 Self 30 Vlan30
cc05.0e20.0000 Dynamic 20 FastEthernet2/0
cc05.0e20.0000 Dynamic 30 FastEthernet2/0
cc07.0e20.0000 Dynamic 20 FastEthernet2/15

access.pop3#

aggregator.pop3#sh mac-address-table
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
cc05.0e20.0000 Self 1 Vlan1
cc05.0e20.0000 Self 30 Vlan30
cc05.0e20.0000 Self 20 Vlan20
cc07.0e20.0000 Dynamic 20 FastEthernet1/0

aggregator.pop3#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.40.2 - cc05.0e20.0000 ARPA FastEthernet0/0
Internet 10.0.40.1 103 ca03.1048.0038 ARPA FastEthernet0/0
Internet 10.0.120.2 18 cc07.0e20.0000 ARPA Vlan20
Internet 10.0.120.1 - cc05.0e20.0000 ARPA Vlan20
Internet 10.0.130.1 - cc05.0e20.0000 ARPA Vlan30
Internet 10.0.130.2 100 cc06.0e20.0000 ARPA Vlan30
aggregator.pop3#

************************
MULTICAST ROUTING
***********************
Internet+IPTV#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.17.17.17), 00:13:55/00:03:22, flags: sT
Incoming interface: Loopback2, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.103, Forward/Sparse, 00:13:55/00:03:22

(192.168.201.1, 232.17.17.17), 00:13:55/00:03:23, flags: sT
Incoming interface: Loopback3, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.103, Forward/Sparse, 00:13:55/00:03:23

(*, 224.0.1.40), 00:14:47/00:02:33, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback2, Forward/Sparse, 00:12:37/00:02:33

Internet+IPTV#

Internet+IPTV#sh ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.1 Serial1/0.103 00:20:25/00:01:32 v2 1 / S
Internet+IPTV#

cus1.pop3#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
232.14.14.14 Loopback0 01:01:41 stopped 0.0.0.0
232.17.17.17 FastEthernet0/0 00:27:16 stopped 10.0.120.2
cus1.pop3#sh ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
cus1.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

cus1.pop3#



edge1.pop1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.1.2, 232.17.17.17), 00:00:47/00:02:12, flags: sPT
Incoming interface: Serial2/0.103, RPF nbr 192.168.1.2
Outgoing interface list: Null

(192.168.201.1, 232.17.17.17), 00:15:25/stopped, flags: sTI
Incoming interface: Serial2/0.103, RPF nbr 192.168.1.2
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:15:25/00:02:34

(192.168.101.1, 232.17.17.17), 00:15:25/stopped, flags: sTI
Incoming interface: Serial2/0.103, RPF nbr 192.168.1.2
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:15:25/00:02:34

(*, 224.0.1.40), 00:15:25/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial2/0.103, Forward/Sparse, 00:15:25/00:02:34

edge1.pop1#
edge1.pop1#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 Serial2/0.103 00:20:50/00:01:33 v2 1 / S G
edge1.pop1#

core1.pop1#sh ip mroute
IP Multicast Forwarding is not enabled.
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

core1.pop1#


edge1.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.201.1, 232.17.17.17), 00:23:23/00:02:40, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:23:23/00:02:40

(192.168.101.1, 232.17.17.17), 00:23:25/00:02:36, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:23:25/00:02:36

(*, 224.0.1.40), 02:00:27/00:02:26, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop3#

edge1.pop3#sh ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: Lspvif0
RPF neighbor: ? (10.0.1.1)
RPF route/mask: 192.168.101.0/24
RPF type: multicast (static)
Doing distance-preferred lookups across tables
RPF topology: ipv4 multicast base, originated from ipv4 unicast base
edge1.pop3#

edge1.pop3#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.40.2 FastEthernet2/0 00:28:51/00:01:18 v2 1 / DR S G
edge1.pop3#

aggregator.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.17.17.17), 00:25:14/stopped, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 10.0.40.1
Outgoing interface list:
Vlan20, Forward/Sparse, 00:25:14/00:01:52

(192.168.201.1, 232.17.17.17), 00:25:12/stopped, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 10.0.40.1
Outgoing interface list:
Vlan20, Forward/Sparse, 00:25:12/00:01:54

(*, 224.0.1.40), 00:26:22/00:02:40, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:26:22/00:02:40

aggregator.pop3#sh ip pim nei
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.40.1 FastEthernet0/0 01:33:47/00:01:42 v2 1 / S
aggregator.pop3#

******************************
TE and RSVP P2MP TE
******************************
edge1.pop1#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

Tunnel100 (p2mp), Admin: up, Oper: up
Name: P2MP

Tunnel100 Destinations Information:

Destination State SLSP UpTime
10.0.3.1 Up 00:16:54
10.0.4.1 Up 00:19:42

Summary: Destinations: 2 [Up: 2, Proceeding: 0, Down: 0 ]
[destination list name: P2MP]

History:
Tunnel:
Time since created: 2 hours, 18 minutes
Time since path change: 19 minutes, 39 seconds
Number of LSP IDs (Tun_Instances) used: 78
Current LSP: [ID: 78]
Uptime: 19 minutes, 42 seconds
Selection: reoptimization
Prior LSP: [ID: 70]
Removal Trigger: re-route path verification failed

Tunnel100 LSP Information:
Configured LSP Parameters:
Bandwidth: 0 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)

Session Information
Source: 10.0.1.1, TunID: 100

LSPs
ID: 78 (Current), Path-Set ID: 0xF7000008
Sub-LSPs: 2, Up: 2, Proceeding: 0, Down: 0

Total LSPs: 1

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 78
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: head
Path-Set ID: 0xF7000008
OutLabel : GigabitEthernet1/0, 24
Next Hop : 10.0.10.2
Explicit Route: 10.0.10.2 10.0.30.2 10.0.30.1 10.0.4.1
Record Route (Path): NONE
Record Route (Resv): 10.0.2.1(24) 10.0.4.1(28)

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 12, Role: head
Path-Set ID: 0xF7000008
OutLabel : GigabitEthernet1/0, 24
Next Hop : 10.0.10.2
Explicit Route: 10.0.10.2 10.0.20.2 10.0.20.1 10.0.3.1
Record Route (Path): NONE
Record Route (Resv): 10.0.2.1(24) 10.0.3.1(24)
edge1.pop1#

edge1.pop2#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 78
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 12, Role: tail
Path-Set ID: 0x76000006
InLabel : GigabitEthernet1/0, 24
Prev Hop : 10.0.20.2
OutLabel : -
Explicit Route: NONE
Record Route (Path): NONE
Record Route (Resv): NONE
edge1.pop2#

edge1.pop3#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 78
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: tail
Path-Set ID: 0x2A000008
InLabel : GigabitEthernet1/0, 28
Prev Hop : 10.0.30.2
OutLabel : -
Explicit Route: NONE
Record Route (Path): NONE
Record Route (Resv): NONE
edge1.pop3#

core1.pop1#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 78
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: midpoint
Path-Set ID: 0x4B000007
InLabel : GigabitEthernet1/0, 24
Prev Hop : 10.0.10.1
OutLabel : GigabitEthernet3/0, 28
Next Hop : 10.0.30.1
Explicit Route: 10.0.30.1 10.0.4.1
Record Route (Path): NONE
Record Route (Resv): 10.0.4.1(28)

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 12, Role: midpoint
Path-Set ID: 0x4B000007
InLabel : GigabitEthernet1/0, 24
Prev Hop : 10.0.10.1
OutLabel : GigabitEthernet2/0, 24
Next Hop : 10.0.20.1
Explicit Route: 10.0.20.1 10.0.3.1
Record Route (Path): NONE
Record Route (Resv): 10.0.3.1(24)
core1.pop1#

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2312 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 4 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 212 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65336 10.0.2.1 - Gi1/0 up/up
core1.pop1_t65336 10.0.1.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
DEST CURRENT
INTERFACE STATE/PROT UP/CFG TUNID LSPID
Tunnel100 up/up 2/2 100 78
Displayed 1 (of 1) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 78 10.0.4.1 2 Up head Gi1/0
10.0.1.1 100 78 10.0.3.1 12 Up head Gi1/0
Displayed 2 P2MP sub-LSPs:
2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2158 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 1 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 58 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.2.1 - Gi1/0 up/up
core1.pop1_t65337 10.0.3.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 78 10.0.3.1 12 Up Gi1/0 tail
Displayed 1 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 1 (of 1) tails
edge1.pop2#
edge1.pop2#

edge1.pop3#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3103 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 103 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop3_t65336 10.0.2.1 - Gi1/0 up/up
core1.pop1_t65338 10.0.4.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 78 10.0.4.1 2 Up Gi1/0 tail
Displayed 1 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 1 (of 1) tails
edge1.pop3#

core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (3 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2637 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 237 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65337 10.0.3.1 - Gi2/0 up/up
core1.pop1_t65338 10.0.4.1 - Gi3/0 up/up
edge1.pop1_t65336 10.0.2.1 Gi1/0 - up/up

edge1.pop2_t65336 10.0.2.1 Gi2/0 - up/up

edge1.pop3_t65336 10.0.2.1 Gi3/0 - up/up

Displayed 3 (of 3) heads, 0 (of 0) midpoints, 3 (of 3) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 78 10.0.4.1 2 Up Gi1/0 Gi3/0
10.0.1.1 100 78 10.0.3.1 12 Up Gi1/0 Gi2/0
Displayed 2 P2MP sub-LSPs:
0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails
core1.pop1#

*************************
MPLS FORWARDING
************************
edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
17 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
18 [T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
19 No Label 172.16.1.0/30[V] 828 aggregate/Internet
21 [T] 17 10.0.3.1/32 0 Tu65336 point2point
23 [T] 28 10.0.4.1/32 0 Tu65336 point2point
25 No Label 172.16.0.0/16[V] 1248 Se2/0.102 point2point
28 [T] 30 10.0.40.0/30 0 Tu65336 point2point
29 [T] 19 10.0.5.1/32 0 Tu65336 point2point
30 [T] 23 10.0.130.0/24 0 Tu65336 point2point
31 [T] 18 10.0.120.0/24 0 Tu65336 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop1#

edge1.pop2#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] 18 10.0.120.0/24 0 Tu65336 point2point
17 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
18 [T] 16 10.0.1.1/32 0 Tu65336 point2point
19 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
20 [T] Pop Label 10.0.10.0/30 0 Tu65336 point2point
21 [T] 19 10.0.5.1/32 0 Tu65336 point2point
22 No Label 10.0.110.0/24[V] 9474 aggregate/Internet
23 [T] 22 192.168.1.0/30 0 Tu65336 point2point
24 [T] No Label 10.0.1.1 100 [78] \
0 aggregate
25 [T] 28 10.0.4.1/32 0 Tu65336 point2point
26 [T] 27 172.16.0.0/16 0 Tu65336 point2point
29 [T] 23 10.0.130.0/24 0 Tu65336 point2point
31 [T] 30 10.0.40.0/30 0 Tu65336 point2point
32 [T] 21 192.168.0.0/16 0 Tu65336 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop2#

edge1.pop3#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] 17 10.0.3.1/32 0 Tu65336 point2point
17 Pop Label 10.0.5.1/32 0 Fa2/0 10.0.40.2
18 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
19 [T] 16 10.0.1.1/32 26328 Tu65336 point2point
20 [T] Pop Label 10.0.10.0/30 0 Tu65336 point2point
21 [T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
22 Pop Label 10.0.130.0/24 0 Fa2/0 10.0.40.2
23 [T] 22 192.168.1.0/30 854 Tu65336 point2point
25 [T] No Label 192.168.0.0/16 0 Tu65336 point2point
26 [T] No Label 172.16.0.0/16 0 Tu65336 point2point
28 [T] No Label 10.0.1.1 100 [78] \
912 aggregate
31 Pop Label 10.0.120.0/24 8206 Fa2/0 10.0.40.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop3#

core1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.1.1/32 129444 Tu65336 point2point
17 [T] Pop Label 10.0.3.1/32 10469 Tu65337 point2point
18 [T] 31 10.0.120.0/24 5264 Tu65338 point2point
19 [T] 17 10.0.5.1/32 0 Tu65338 point2point
21 [T] 25 192.168.0.0/16 0 Tu65338 point2point
22 [T] Pop Label 192.168.1.0/30 1372 Tu65336 point2point
23 [T] 22 10.0.130.0/24 0 Tu65338 point2point
24 28 10.0.1.1 100 [78] \
944 Gi3/0 10.0.30.1
24 10.0.1.1 100 [78] \
472 Gi2/0 10.0.20.1
27 [T] 26 172.16.0.0/16 0 Tu65338 point2point
28 [T] Pop Label 10.0.4.1/32 21556 Tu65338 point2point
30 [T] Pop Label 10.0.40.0/30 0 Tu65338 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#

**********************
UNICAST ROUTING
************************

Internet+IPTV#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 4 masks
C 172.16.201.0/24 is directly connected, Loopback1
S 172.16.0.0/16 is directly connected, Null0
C 172.16.1.0/30 is directly connected, Serial1/0.102
C 172.16.101.1/32 is directly connected, Loopback0
C 192.168.201.0/24 is directly connected, Loopback3
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.0.0.0/8 [20/0] via 192.168.1.1, 00:30:57
B 10.0.110.0/24 [20/0] via 172.16.1.1, 00:25:18
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/0.103
C 192.168.101.0/24 is directly connected, Loopback2
S 192.168.0.0/16 is directly connected, Null0
Internet+IPTV#

edge1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 4 masks
S 10.0.0.0/8 is directly connected, Null0
C 10.0.1.1/32 is directly connected, Loopback0
O 10.0.2.1/32 [110/2] via 10.0.2.1, 02:22:02, Tunnel65336
O 10.0.3.1/32 [110/3] via 10.0.2.1, 00:26:02, Tunnel65336
O 10.0.4.1/32 [110/3] via 10.0.2.1, 01:31:21, Tunnel65336
O 10.0.5.1/32 [110/4] via 10.0.2.1, 00:40:22, Tunnel65336
C 10.0.10.0/30 is directly connected, GigabitEthernet1/0
L 10.0.10.1/32 is directly connected, GigabitEthernet1/0
O 10.0.20.0/30 [110/2] via 10.0.2.1, 00:26:02, Tunnel65336
O 10.0.30.0/30 [110/2] via 10.0.2.1, 01:31:21, Tunnel65336
O 10.0.40.0/30 [110/3] via 10.0.2.1, 00:40:32, Tunnel65336
O 10.0.120.0/24 [110/4] via 10.0.2.1, 00:40:22, Tunnel65336
O 10.0.130.0/24 [110/4] via 10.0.2.1, 00:40:22, Tunnel65336
B 172.16.0.0/16 [20/0] via 192.168.1.2, 00:31:16
B 192.168.0.0/16 [20/0] via 192.168.1.2, 00:31:16
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial2/0.103
L 192.168.1.1/32 is directly connected, Serial2/0.103
edge1.pop1#sh ip route vrf Internet

Routing Table: Internet
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 1 subnets
B 10.0.110.0 [200/0] via 10.0.3.1, 00:25:45
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
B 172.16.0.0/16 [20/0] via 172.16.1.2, 00:31:21
C 172.16.1.0/30 is directly connected, Serial2/0.102
L 172.16.1.1/32 is directly connected, Serial2/0.102
edge1.pop1#

edge1.pop2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 13 subnets, 4 masks
B 10.0.0.0/8 [200/0] via 10.0.1.1, 00:25:50
O 10.0.1.1/32 [110/3] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.2.1/32 [110/2] via 10.0.2.1, 00:26:12, Tunnel65336
C 10.0.3.1/32 is directly connected, Loopback0
O 10.0.4.1/32 [110/3] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.5.1/32 [110/4] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.10.0/30 [110/2] via 10.0.2.1, 00:26:12, Tunnel65336
C 10.0.20.0/30 is directly connected, GigabitEthernet1/0
L 10.0.20.1/32 is directly connected, GigabitEthernet1/0
O 10.0.30.0/30 [110/2] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.40.0/30 [110/3] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.120.0/24 [110/4] via 10.0.2.1, 00:26:12, Tunnel65336
O 10.0.130.0/24 [110/4] via 10.0.2.1, 00:26:12, Tunnel65336
O E2 172.16.0.0/16 [110/1] via 10.0.2.1, 00:26:12, Tunnel65336
O E2 192.168.0.0/16 [110/1] via 10.0.2.1, 00:26:12, Tunnel65336
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.2.1, 00:26:12, Tunnel65336
edge1.pop2#
edge1.pop2#

edge1.pop3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 14 subnets, 4 masks
B 10.0.0.0/8 [200/0] via 10.0.1.1, 01:08:30
O 10.0.1.1/32 [110/3] via 10.0.2.1, 01:31:21, Tunnel65336
O 10.0.2.1/32 [110/2] via 10.0.2.1, 01:31:21, Tunnel65336
O 10.0.3.1/32 [110/3] via 10.0.2.1, 00:26:43, Tunnel65336
C 10.0.4.1/32 is directly connected, Loopback0
O 10.0.5.1/32 [110/2] via 10.0.40.2, 00:40:58, FastEthernet2/0
O 10.0.10.0/30 [110/2] via 10.0.2.1, 01:31:21, Tunnel65336
O 10.0.20.0/30 [110/2] via 10.0.2.1, 00:26:43, Tunnel65336
C 10.0.30.0/30 is directly connected, GigabitEthernet1/0
L 10.0.30.1/32 is directly connected, GigabitEthernet1/0
C 10.0.40.0/30 is directly connected, FastEthernet2/0
L 10.0.40.1/32 is directly connected, FastEthernet2/0
O 10.0.120.0/24 [110/2] via 10.0.40.2, 00:40:58, FastEthernet2/0
O 10.0.130.0/24 [110/2] via 10.0.40.2, 00:40:58, FastEthernet2/0
B 172.16.0.0/16 [200/0] via 10.0.1.1, 00:31:56
B 192.168.0.0/16 [200/0] via 10.0.1.1, 00:31:56
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.2.1, 00:31:59, Tunnel65336
edge1.pop3#

core1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 14 subnets, 3 masks
O 10.0.1.1/32 [110/2] via 10.0.1.1, 00:22:18, Tunnel65336
C 10.0.2.1/32 is directly connected, Loopback0
O 10.0.3.1/32 [110/2] via 10.0.3.1, 00:22:18, Tunnel65337
O 10.0.4.1/32 [110/2] via 10.0.4.1, 00:22:18, Tunnel65338
O 10.0.5.1/32 [110/3] via 10.0.4.1, 00:22:18, Tunnel65338
C 10.0.10.0/30 is directly connected, GigabitEthernet1/0
L 10.0.10.2/32 is directly connected, GigabitEthernet1/0
C 10.0.20.0/30 is directly connected, GigabitEthernet2/0
L 10.0.20.2/32 is directly connected, GigabitEthernet2/0
C 10.0.30.0/30 is directly connected, GigabitEthernet3/0
L 10.0.30.2/32 is directly connected, GigabitEthernet3/0
O 10.0.40.0/30 [110/2] via 10.0.4.1, 00:22:18, Tunnel65338
O 10.0.120.0/24 [110/3] via 10.0.4.1, 00:22:18, Tunnel65338
O 10.0.130.0/24 [110/3] via 10.0.4.1, 00:22:18, Tunnel65338
O E2 172.16.0.0/16 [110/1] via 10.0.4.1, 00:22:18, Tunnel65338
O E2 192.168.0.0/16 [110/1] via 10.0.4.1, 00:22:18, Tunnel65338
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.1.1, 00:22:18, Tunnel65336
core1.pop1#
core1.pop1#

aggregator.pop3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O E2 172.16.0.0/16 [110/1] via 10.0.40.1, 00:27:26, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
O 10.0.10.0/30 [110/3] via 10.0.40.1, 00:27:26, FastEthernet0/0
O 10.0.3.1/32 [110/4] via 10.0.40.1, 00:27:26, FastEthernet0/0
O 10.0.2.1/32 [110/3] via 10.0.40.1, 00:27:26, FastEthernet0/0
O 10.0.1.1/32 [110/4] via 10.0.40.1, 00:27:26, FastEthernet0/0
C 10.0.5.1/32 is directly connected, Loopback0
O 10.0.4.1/32 [110/2] via 10.0.40.1, 00:27:26, FastEthernet0/0
O 10.0.30.0/30 [110/2] via 10.0.40.1, 00:27:26, FastEthernet0/0
O 10.0.20.0/30 [110/3] via 10.0.40.1, 00:27:26, FastEthernet0/0
C 10.0.40.0/30 is directly connected, FastEthernet0/0
C 10.0.120.0/24 is directly connected, Vlan20
C 10.0.130.0/24 is directly connected, Vlan30
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.40.1, 00:27:26, FastEthernet0/0
O E2 192.168.0.0/16 [110/1] via 10.0.40.1, 00:27:26, FastEthernet0/0
aggregator.pop3#

access.pop3#sh ip route
Default gateway is 10.0.130.1

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
access.pop3#

cus1.pop3#sh ip route
Default gateway is not set

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
cus1.pop3#

cus1.pop2#sh ip route
Default gateway is not set

Host Gateway Last Use Total Uses Interface
ICMP redirect cache is empty
cus1.pop2#

Thursday, July 8, 2010

Implementing NGN Broadband Networks for HSI/IPTV using VLAN based VPWS LAB

















Configuration Guidelines
***********************************************************
Scenario: An ISP wants to transtion to Next Generation Networks
Architecture thereby to offer High Speed Internet Access
and IPTV Services by leveraging its existing MPLS Core Network
and not running native Multicast in its Core.Also ISP wants to
use Vlan Based VPWS at the Ethernet Aggregation Layer

Design Consideration and Solution:

ISP is using Vlan Based VPWS across its Aggregation Layer and using
L2TPv3 L2 Transport in the aggregation Layer to connection
the Access Nodes to the Broadband Network Gateway over
IPoE/Static IPs.

ISP can use mLDP across its MPLS Core to deliver the IPTV
Services using NGN MPVPN over mLDP. Internet Access
can be provided in another MPLS L3 VPN Context
therby providing separation the the Data Plane for both
Services.

HSI can be delivered over regular PPPoE/Static IP and IPTV can be
delivered over IPoE utilising DHCP.
IPTV and Internet can be clubbed together by utilizing Extranet VPN
using 2 diff export RTs for Internet VRF (one for Internet Customers
and one for Internet+IPTV Customers)

ISP AS used 64513
IGP used OSPF Area0 both in MPLS Core and L2TPv3 Aggregation
VRF used in Core N/W
Internet
rd 64513:1
rt 64513:100
IPTV
rd 64513:2
rt 64513:101
vpn id 200:1
root-address 10.0.4.1

Static Pool used 10.0.110.0/24
DHCP Pool used 192.168.151.0/24

L2TPv3 Psuedowire used in Aggregation N/W
VCID 10 for Internet
VCID 20 for IPTV+Internet
VCID 30 for MGT

Service VLAN 10 used for Internet Services
Service VLAN 20 used for IPTV Services
Service VLAN 30 used for Management Network


PIM SDM used for IPTV with RP at IPTV

CE

cus2.pop2 is an IPTV+Internet Customer

cus1.pop2 is an Internet Customer with Static IP

IGMP Group used 232.1.1.1 for IPTV
Source 192.168.101.0/24 & 192.168.201.0/24

Internet Dummy Networks used 172.16.101.0/24
& 172.16.201.0/24
**********************************************************


cus2.pop2#sh running-config
Building configuration...

Current configuration : 802 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus2.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
description dslam.pop2
ip address dhcp
no ip route-cache
ip igmp join-group 232.1.1.1
duplex auto
speed auto
!
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

cus2.pop2#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 754 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
description dslam2.pop2
ip address 10.0.110.2 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.110.1
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

cus1.pop2#

dslam.pop2#sh running-config
Building configuration...

Current configuration : 1772 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname dslam.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$tGxA$n5iXFht.kJeLGgxw8mZ04.
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username bdsl password 7 1307130107
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
description core2.pop2
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
description cus1.pop2
switchport access vlan 10
!
interface FastEthernet2/15
description cus2.pop2
switchport access vlan 20
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan20
description test
ip address 10.0.102.254 255.255.255.0
shutdown
!
interface Vlan30
description MGT
ip address 10.0.101.2 255.255.255.0
!
!
ip default-gateway 10.0.101.1
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password 7 04590F1503
login local
!
end

dslam.pop2#

core2.pop2#sh running-config
Building configuration...

Current configuration : 1838 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core2.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
pseudowire-class dsl
encapsulation l2tpv3
ip local interface Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
description core1.pop2
ip address 10.0.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
description dslam.pop2
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
xconnect 10.0.1.1 10 pw-class dsl
!
interface Vlan20
no ip address
xconnect 10.0.1.1 20 pw-class dsl
!
interface Vlan30
no ip address
xconnect 10.0.1.1 30 pw-class dsl
!
interface Vlan40
no ip address
xconnect 10.0.1.1 40 pw-class dsl
!
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

core2.pop2#

core1.pop2#sh running-config
Building configuration...

Current configuration : 1836 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
pseudowire-class dsl
encapsulation l2tpv3
ip local interface Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
description core2.pop2
ip address 10.0.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
description BNG.pop1
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
xconnect 10.0.2.1 10 pw-class dsl
!
interface Vlan20
no ip address
xconnect 10.0.2.1 20 pw-class dsl
!
interface Vlan30
no ip address
xconnect 10.0.2.1 30 pw-class dsl
!
interface Vlan40
no ip address
xconnect 10.0.2.1 40 pw-class dsl
!
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

core1.pop2#

BNG.pop1#sh running-config
Building configuration...

Current configuration : 3068 bytes
!
! Last configuration change at 15:09:52 UTC Tue Jul 6 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BNG.pop1
!
boot-start-marker
boot-end-marker
!
security passwords min-length 1
!
aaa new-model
aaa local authentication attempts max-fail 2
!
!
aaa authorization network default local
!
!
!
!
!
aaa session-id common
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:101
route-target export 64513:100
route-target import 64513:101
route-target import 64513:102
mdt preference mldp
mdt default mpls mldp 10.0.4.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:102
!
!
ip dhcp pool IPTV
vrf IPTV
network 192.168.151.0 255.255.255.0
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
username cisco password 0 sisco
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge2.pop1
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description core1.pop2
no ip address
negotiation auto
!
interface GigabitEthernet2/0.10
description STC
encapsulation dot1Q 10
ip vrf forwarding Internet
ip address 10.0.110.1 255.255.255.0
!
interface GigabitEthernet2/0.20
description DYN
encapsulation dot1Q 20
ip vrf forwarding IPTV
ip address 192.168.151.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp v3lite
!
interface GigabitEthernet2/0.30
description MGT
encapsulation dot1Q 30
ip address 10.0.101.1 255.255.255.0
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description iBGP
neighbor 10.0.4.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
neighbor 10.0.4.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

BNG.pop1#

edge2.pop1#sh running-config
Building configuration...

Current configuration : 2879 bytes
!
! Last configuration change at 14:23:04 UTC Tue Jul 6 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge2.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:101
route-target import 64513:101
mdt preference mldp
mdt default mpls mldp 10.0.4.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target export 64513:102
route-target import 64513:100
!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description BNG.pop1
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description Internet
ip vrf forwarding Internet
ip address 172.16.1.1 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet2/1
description IPTV
ip vrf forwarding IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description iBGP
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
neighbor 192.168.1.2 remote-as 64515
neighbor 192.168.1.2 description IPTV
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description Internet
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge2.pop1#

IPTV#sh running-config
Building configuration...

Current configuration : 1389 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.0
ip pim sparse-dense-mode
!
interface Loopback1
ip address 192.168.201.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
description edge2.pop1
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64515
no synchronization
bgp router-id 192.168.101.1
bgp log-neighbor-changes
network 192.168.0.0 mask 255.255.0.0
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 description edge2.pop1
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

IPTV#

Internet#sh running-config
Building configuration...

Current configuration : 1166 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
!
interface Loopback1
ip address 172.16.201.1 255.255.255.0
!
interface FastEthernet0/0
description edge2.pop1
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.0.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description edge2.pop1
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 172.16.0.0 255.255.0.0 Null0
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Internet#

********************************
OUTPUT
**********************************
UNICAST TRAFFIC
***********************************

cus2.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 192.168.151.1 372 msec 328 msec 304 msec
2 192.168.1.1 444 msec 368 msec 432 msec
3 192.168.1.2 536 msec * 556 msec
cus2.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 192.168.151.1 488 msec 348 msec 276 msec
2 172.16.1.1 1060 msec 768 msec 652 msec
3 172.16.1.2 396 msec 344 msec *
cus2.pop2#

cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.110.1 352 msec 396 msec 216 msec
2 172.16.1.1 224 msec 476 msec 588 msec
3 172.16.1.2 412 msec * 264 msec
cus1.pop2#

IPTV#traceroute 192.168.151.3

Type escape sequence to abort.
Tracing the route to 192.168.151.3

1 192.168.1.1 120 msec 232 msec 224 msec
2 192.168.151.1 [AS 64513] 208 msec 180 msec 196 msec
3 192.168.151.3 [AS 64513] 272 msec * 236 msec
IPTV#

Internet#traceroute 192.168.151.3

Type escape sequence to abort.
Tracing the route to 192.168.151.3

1 172.16.1.1 64 msec 116 msec 84 msec
2 192.168.151.1 [AS 64513] 344 msec 276 msec 244 msec
3 192.168.151.3 [AS 64513] 544 msec * 312 msec
Internet#traceroute 10.0.110.2

Type escape sequence to abort.
Tracing the route to 10.0.110.2

1 172.16.1.1 60 msec 124 msec 144 msec
2 10.0.110.1 [AS 64513] 200 msec 284 msec 280 msec
3 10.0.110.2 [AS 64513] 436 msec * 364 msec
Internet#


***********************************
Multicast Traffic
***********************************

IPTV#ping 232.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 192.168.151.3, 492 ms
IPTV#ping 232.1.1.1 source lo1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.201.1

Reply to request 0 from 192.168.151.3, 404 ms
IPTV#

IPTV#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.1.2, 232.1.1.1), 00:01:24/00:02:40, flags: sPT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.101.1, 232.1.1.1), 00:01:24/00:02:50, flags: sPT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.201.1, 232.1.1.1), 00:01:24/00:02:50, flags: sPT
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list: Null

(*, 224.0.1.39), 00:34:34/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:34:34/00:00:00
Loopback0, Forward/Sparse-Dense, 00:34:34/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:34:34/00:00:00

(192.168.101.1, 224.0.1.39), 00:34:28/00:02:31, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:34:28/00:00:00
Loopback1, Forward/Sparse-Dense, 00:34:28/00:00:00

(*, 224.0.1.40), 00:34:34/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:34:34/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:34:34/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:28/00:02:17, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:34:28/00:00:00

IPTV#

edge2.pop1#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.1.1.1), 00:34:42/00:02:33, RP 192.168.101.1, flags: S
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:34:42/00:02:33

(192.168.1.2, 232.1.1.1), 00:01:50/00:01:09, flags: T
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:01:50/00:02:43

(*, 224.0.1.39), 00:35:44/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:35:44/00:00:00
FastEthernet2/1, Forward/Sparse-Dense, 00:35:44/00:00:00

(192.168.101.1, 224.0.1.39), 00:35:44/00:01:54, flags: T
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:00:53/00:00:00

(*, 224.0.1.40), 01:25:50/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 01:10:27/00:00:00
FastEthernet2/1, Forward/Sparse-Dense, 00:53:40/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:44/00:02:50, flags: LT
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:34:44/00:00:00

edge2.pop1#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet2/1 01:23:34/00:01:31 v2 1 / DR S G
10.0.3.1 Lspvif0 01:22:43/00:01:30 v2 1 / S P G
edge2.pop1#

BNG.pop1#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.1.1.1), 00:36:30/stopped, RP 192.168.101.1, flags: SJC
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list:
GigabitEthernet2/0.20, Forward/Sparse-Dense, 00:36:30/00:02:26

(192.168.1.2, 232.1.1.1), 00:02:08/00:00:51, flags: JT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list:
GigabitEthernet2/0.20, Forward/Sparse-Dense, 00:02:08/00:02:26

(*, 224.0.1.39), 00:35:47/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:35:47/00:00:00

(192.168.101.1, 224.0.1.39), 00:00:18/00:02:41, flags: PT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list: Null

(*, 224.0.1.40), 02:17:36/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:55:26/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:47/00:02:27, flags: PLT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list: Null

BNG.pop1#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.4.1 Lspvif0 01:03:07/00:01:20 v2 1 / DR S P G
BNG.pop1#

******************************
MLDP-CORE NETWORK
******************************
BNG.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.4.1:0, uptime 01:03:56 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 1
Branch count : 0
Path count : 2
Path(s) : 10.0.4.1 No LDP Tunnel65336
: 10.0.20.2 LDP GigabitEthernet1/0
Nhop count : 2
Nhop list : 10.0.4.1 10.0.20.2
BNG.pop1#show mpls mldp bindings
System ID: 68000001
Type: MP2MP, Root Node: 10.0.4.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.4.1:0, remote binding[U]: 20, local binding[D]: 20 active

BNG.pop1#

edge2.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.3.1:0, uptime 01:04:39 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.3.1 No LDP Tunnel65336
: 10.0.20.1 LDP GigabitEthernet1/0
Nhop count : 0
edge2.pop1#show mpls mldp bindings
System ID: 33000001
Type: MP2MP, Root Node: 10.0.4.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.3.1:0, local binding[U]: 20, remote binding[D]: 20

edge2.pop1#

*************************************
L2TPv3 XCONNECT-AGGREGATION NETWORK
****************************************
core1.pop2#sh l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
48862 64352 23023 10, Vl10 est 02:11:37 1
48863 64353 23023 20, Vl20 est 02:11:34 2
48864 64354 23023 30, Vl30 est 02:11:31 3

%No active PPTP tunnels
core1.pop2#sh l2tun session packet

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
48862 64352 23023 75 271 7589 25088
48863 64353 23023 367 433 51794 37754
48864 64354 23023 130 940 10221 82839

%No active PPTP tunnels
core1.pop2#

core2.pop2#show l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
64352 48862 30059 10, Vl10 est 02:11:33 4
64353 48863 30059 20, Vl20 est 02:11:30 5
64354 48864 30059 30, Vl30 est 02:11:26 6

%No active PPTP tunnels
core2.pop2#show l2tun session packet

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
64352 48862 30059 271 75 25088 7589
64353 48863 30059 435 368 37886 51854
64354 48864 30059 943 130 83109 10221

%No active PPTP tunnels
core2.pop2#

***********************************************
MAC and ARP TABLE-ACCESS/AGGREGATION NETWORK
***********************************************
dslam.pop2#show mac-address-table
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
c400.1268.0000 Self 1 Vlan1
ca05.13e4.0038 Dynamic 30 FastEthernet2/0
c400.1268.0000 Self 20 Vlan20
c400.1268.0000 Self 30 Vlan30
c403.1268.0001 Dynamic 20 FastEthernet2/15
c402.1268.0000 Dynamic 10 FastEthernet2/14

dslam.pop2#

BNG.pop1#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.20.1 - ca05.13e4.001c ARPA GigabitEthernet1/0
Internet 10.0.20.2 137 ca06.13f0.001c ARPA GigabitEthernet1/0
Internet 10.0.101.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
30
Internet 10.0.101.2 93 c400.1268.0000 ARPA GigabitEthernet2/0.
30
BNG.pop1#show arp vrf IPTV
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.151.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
20
Internet 192.168.151.3 21 c403.1268.0001 ARPA GigabitEthernet2/0.
20
BNG.pop1#show arp vrf Internet
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.110.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
10
Internet 10.0.110.2 69 c402.1268.0000 ARPA GigabitEthernet2/0.
10
BNG.pop1#

****************************
MPLS TE
****************************
BNG.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1972 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 172 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
BNG.pop1_t65336 10.0.4.1 - Gi1/0 up/up
edge2.pop1_t65336 10.0.3.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
BNG.pop1#

BNG.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.4.1/32 0 Tu65336 point2point
18 No Label 10.0.110.0/24[V] 5440 aggregate/Internet
19 No Label 192.168.151.0/24[V] \
13934 aggregate/IPTV
20 [T] No Label [mdt 200:1 0][V] 11250 aggregate/IPTV

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
BNG.pop1#

edge2.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1528 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 6 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 28 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge2.pop1_t65336 10.0.3.1 - Gi1/0 up/up
BNG.pop1_t65336 10.0.4.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge2.pop1#show mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 No Label 192.168.1.0/30[V] \
1832 aggregate/IPTV
17 No Label 172.16.1.0/30[V] 2866 aggregate/Internet
18 No Label 192.168.0.0/16[V] \
5322 Fa2/1 192.168.1.2
19 [T] Pop Label 10.0.3.1/32 0 Tu65336 point2point
21 [T] No Label [mdt 200:1 0][V] 19950 aggregate/IPTV
22 No Label 172.16.0.0/16[V] 7662 Fa2/0 172.16.1.2
23 [T] Pop Label 10.0.101.0/24 0 Tu65336 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge2.pop1#