Thursday, July 8, 2010

Implementing NGN Broadband Networks for HSI/IPTV using VLAN based VPWS LAB

















Configuration Guidelines
***********************************************************
Scenario: An ISP wants to transtion to Next Generation Networks
Architecture thereby to offer High Speed Internet Access
and IPTV Services by leveraging its existing MPLS Core Network
and not running native Multicast in its Core.Also ISP wants to
use Vlan Based VPWS at the Ethernet Aggregation Layer

Design Consideration and Solution:

ISP is using Vlan Based VPWS across its Aggregation Layer and using
L2TPv3 L2 Transport in the aggregation Layer to connection
the Access Nodes to the Broadband Network Gateway over
IPoE/Static IPs.

ISP can use mLDP across its MPLS Core to deliver the IPTV
Services using NGN MPVPN over mLDP. Internet Access
can be provided in another MPLS L3 VPN Context
therby providing separation the the Data Plane for both
Services.

HSI can be delivered over regular PPPoE/Static IP and IPTV can be
delivered over IPoE utilising DHCP.
IPTV and Internet can be clubbed together by utilizing Extranet VPN
using 2 diff export RTs for Internet VRF (one for Internet Customers
and one for Internet+IPTV Customers)

ISP AS used 64513
IGP used OSPF Area0 both in MPLS Core and L2TPv3 Aggregation
VRF used in Core N/W
Internet
rd 64513:1
rt 64513:100
IPTV
rd 64513:2
rt 64513:101
vpn id 200:1
root-address 10.0.4.1

Static Pool used 10.0.110.0/24
DHCP Pool used 192.168.151.0/24

L2TPv3 Psuedowire used in Aggregation N/W
VCID 10 for Internet
VCID 20 for IPTV+Internet
VCID 30 for MGT

Service VLAN 10 used for Internet Services
Service VLAN 20 used for IPTV Services
Service VLAN 30 used for Management Network


PIM SDM used for IPTV with RP at IPTV

CE

cus2.pop2 is an IPTV+Internet Customer

cus1.pop2 is an Internet Customer with Static IP

IGMP Group used 232.1.1.1 for IPTV
Source 192.168.101.0/24 & 192.168.201.0/24

Internet Dummy Networks used 172.16.101.0/24
& 172.16.201.0/24
**********************************************************


cus2.pop2#sh running-config
Building configuration...

Current configuration : 802 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus2.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
description dslam.pop2
ip address dhcp
no ip route-cache
ip igmp join-group 232.1.1.1
duplex auto
speed auto
!
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

cus2.pop2#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 754 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
description dslam2.pop2
ip address 10.0.110.2 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.110.1
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

cus1.pop2#

dslam.pop2#sh running-config
Building configuration...

Current configuration : 1772 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname dslam.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$tGxA$n5iXFht.kJeLGgxw8mZ04.
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username bdsl password 7 1307130107
!
!
no crypto isakmp ccm
!
!
!
!
interface FastEthernet0/0
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
description core2.pop2
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
description cus1.pop2
switchport access vlan 10
!
interface FastEthernet2/15
description cus2.pop2
switchport access vlan 20
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan20
description test
ip address 10.0.102.254 255.255.255.0
shutdown
!
interface Vlan30
description MGT
ip address 10.0.101.2 255.255.255.0
!
!
ip default-gateway 10.0.101.1
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password 7 04590F1503
login local
!
end

dslam.pop2#

core2.pop2#sh running-config
Building configuration...

Current configuration : 1838 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core2.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
pseudowire-class dsl
encapsulation l2tpv3
ip local interface Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
description core1.pop2
ip address 10.0.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
description dslam.pop2
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
interface FastEthernet2/5
!
interface FastEthernet2/6
!
interface FastEthernet2/7
!
interface FastEthernet2/8
!
interface FastEthernet2/9
!
interface FastEthernet2/10
!
interface FastEthernet2/11
!
interface FastEthernet2/12
!
interface FastEthernet2/13
!
interface FastEthernet2/14
!
interface FastEthernet2/15
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
xconnect 10.0.1.1 10 pw-class dsl
!
interface Vlan20
no ip address
xconnect 10.0.1.1 20 pw-class dsl
!
interface Vlan30
no ip address
xconnect 10.0.1.1 30 pw-class dsl
!
interface Vlan40
no ip address
xconnect 10.0.1.1 40 pw-class dsl
!
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

core2.pop2#

core1.pop2#sh running-config
Building configuration...

Current configuration : 1836 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
pseudowire-class dsl
encapsulation l2tpv3
ip local interface Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
description core2.pop2
ip address 10.0.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet3/0
description BNG.pop1
switchport trunk allowed vlan 1,2,10,20,30,40,1002-1005
switchport mode trunk
!
interface FastEthernet3/1
!
interface FastEthernet3/2
!
interface FastEthernet3/3
!
interface FastEthernet3/4
!
interface FastEthernet3/5
!
interface FastEthernet3/6
!
interface FastEthernet3/7
!
interface FastEthernet3/8
!
interface FastEthernet3/9
!
interface FastEthernet3/10
!
interface FastEthernet3/11
!
interface FastEthernet3/12
!
interface FastEthernet3/13
!
interface FastEthernet3/14
!
interface FastEthernet3/15
!
interface Vlan1
no ip address
!
interface Vlan10
no ip address
xconnect 10.0.2.1 10 pw-class dsl
!
interface Vlan20
no ip address
xconnect 10.0.2.1 20 pw-class dsl
!
interface Vlan30
no ip address
xconnect 10.0.2.1 30 pw-class dsl
!
interface Vlan40
no ip address
xconnect 10.0.2.1 40 pw-class dsl
!
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

core1.pop2#

BNG.pop1#sh running-config
Building configuration...

Current configuration : 3068 bytes
!
! Last configuration change at 15:09:52 UTC Tue Jul 6 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BNG.pop1
!
boot-start-marker
boot-end-marker
!
security passwords min-length 1
!
aaa new-model
aaa local authentication attempts max-fail 2
!
!
aaa authorization network default local
!
!
!
!
!
aaa session-id common
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:101
route-target export 64513:100
route-target import 64513:101
route-target import 64513:102
mdt preference mldp
mdt default mpls mldp 10.0.4.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:102
!
!
ip dhcp pool IPTV
vrf IPTV
network 192.168.151.0 255.255.255.0
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
username cisco password 0 sisco
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge2.pop1
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description core1.pop2
no ip address
negotiation auto
!
interface GigabitEthernet2/0.10
description STC
encapsulation dot1Q 10
ip vrf forwarding Internet
ip address 10.0.110.1 255.255.255.0
!
interface GigabitEthernet2/0.20
description DYN
encapsulation dot1Q 20
ip vrf forwarding IPTV
ip address 192.168.151.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp v3lite
!
interface GigabitEthernet2/0.30
description MGT
encapsulation dot1Q 30
ip address 10.0.101.1 255.255.255.0
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description iBGP
neighbor 10.0.4.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
neighbor 10.0.4.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

BNG.pop1#

edge2.pop1#sh running-config
Building configuration...

Current configuration : 2879 bytes
!
! Last configuration change at 14:23:04 UTC Tue Jul 6 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge2.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:101
route-target import 64513:101
mdt preference mldp
mdt default mpls mldp 10.0.4.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target export 64513:102
route-target import 64513:100
!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description BNG.pop1
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description Internet
ip vrf forwarding Internet
ip address 172.16.1.1 255.255.255.252
speed auto
duplex auto
!
interface FastEthernet2/1
description IPTV
ip vrf forwarding IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description iBGP
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
neighbor 192.168.1.2 remote-as 64515
neighbor 192.168.1.2 description IPTV
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description Internet
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge2.pop1#

IPTV#sh running-config
Building configuration...

Current configuration : 1389 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.0
ip pim sparse-dense-mode
!
interface Loopback1
ip address 192.168.201.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
description edge2.pop1
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64515
no synchronization
bgp router-id 192.168.101.1
bgp log-neighbor-changes
network 192.168.0.0 mask 255.255.0.0
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 description edge2.pop1
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

IPTV#

Internet#sh running-config
Building configuration...

Current configuration : 1166 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
!
interface Loopback1
ip address 172.16.201.1 255.255.255.0
!
interface FastEthernet0/0
description edge2.pop1
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.0.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description edge2.pop1
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 172.16.0.0 255.255.0.0 Null0
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Internet#

********************************
OUTPUT
**********************************
UNICAST TRAFFIC
***********************************

cus2.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 192.168.151.1 372 msec 328 msec 304 msec
2 192.168.1.1 444 msec 368 msec 432 msec
3 192.168.1.2 536 msec * 556 msec
cus2.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 192.168.151.1 488 msec 348 msec 276 msec
2 172.16.1.1 1060 msec 768 msec 652 msec
3 172.16.1.2 396 msec 344 msec *
cus2.pop2#

cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.110.1 352 msec 396 msec 216 msec
2 172.16.1.1 224 msec 476 msec 588 msec
3 172.16.1.2 412 msec * 264 msec
cus1.pop2#

IPTV#traceroute 192.168.151.3

Type escape sequence to abort.
Tracing the route to 192.168.151.3

1 192.168.1.1 120 msec 232 msec 224 msec
2 192.168.151.1 [AS 64513] 208 msec 180 msec 196 msec
3 192.168.151.3 [AS 64513] 272 msec * 236 msec
IPTV#

Internet#traceroute 192.168.151.3

Type escape sequence to abort.
Tracing the route to 192.168.151.3

1 172.16.1.1 64 msec 116 msec 84 msec
2 192.168.151.1 [AS 64513] 344 msec 276 msec 244 msec
3 192.168.151.3 [AS 64513] 544 msec * 312 msec
Internet#traceroute 10.0.110.2

Type escape sequence to abort.
Tracing the route to 10.0.110.2

1 172.16.1.1 60 msec 124 msec 144 msec
2 10.0.110.1 [AS 64513] 200 msec 284 msec 280 msec
3 10.0.110.2 [AS 64513] 436 msec * 364 msec
Internet#


***********************************
Multicast Traffic
***********************************

IPTV#ping 232.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 192.168.151.3, 492 ms
IPTV#ping 232.1.1.1 source lo1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.201.1

Reply to request 0 from 192.168.151.3, 404 ms
IPTV#

IPTV#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.1.2, 232.1.1.1), 00:01:24/00:02:40, flags: sPT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.101.1, 232.1.1.1), 00:01:24/00:02:50, flags: sPT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.201.1, 232.1.1.1), 00:01:24/00:02:50, flags: sPT
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list: Null

(*, 224.0.1.39), 00:34:34/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:34:34/00:00:00
Loopback0, Forward/Sparse-Dense, 00:34:34/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:34:34/00:00:00

(192.168.101.1, 224.0.1.39), 00:34:28/00:02:31, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:34:28/00:00:00
Loopback1, Forward/Sparse-Dense, 00:34:28/00:00:00

(*, 224.0.1.40), 00:34:34/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:34:34/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:34:34/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:28/00:02:17, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:34:28/00:00:00

IPTV#

edge2.pop1#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.1.1.1), 00:34:42/00:02:33, RP 192.168.101.1, flags: S
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:34:42/00:02:33

(192.168.1.2, 232.1.1.1), 00:01:50/00:01:09, flags: T
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:01:50/00:02:43

(*, 224.0.1.39), 00:35:44/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:35:44/00:00:00
FastEthernet2/1, Forward/Sparse-Dense, 00:35:44/00:00:00

(192.168.101.1, 224.0.1.39), 00:35:44/00:01:54, flags: T
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:00:53/00:00:00

(*, 224.0.1.40), 01:25:50/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 01:10:27/00:00:00
FastEthernet2/1, Forward/Sparse-Dense, 00:53:40/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:44/00:02:50, flags: LT
Incoming interface: FastEthernet2/1, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:34:44/00:00:00

edge2.pop1#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet2/1 01:23:34/00:01:31 v2 1 / DR S G
10.0.3.1 Lspvif0 01:22:43/00:01:30 v2 1 / S P G
edge2.pop1#

BNG.pop1#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 232.1.1.1), 00:36:30/stopped, RP 192.168.101.1, flags: SJC
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list:
GigabitEthernet2/0.20, Forward/Sparse-Dense, 00:36:30/00:02:26

(192.168.1.2, 232.1.1.1), 00:02:08/00:00:51, flags: JT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list:
GigabitEthernet2/0.20, Forward/Sparse-Dense, 00:02:08/00:02:26

(*, 224.0.1.39), 00:35:47/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:35:47/00:00:00

(192.168.101.1, 224.0.1.39), 00:00:18/00:02:41, flags: PT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list: Null

(*, 224.0.1.40), 02:17:36/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse-Dense, 00:55:26/00:00:00

(192.168.101.1, 224.0.1.40), 00:34:47/00:02:27, flags: PLT
Incoming interface: Lspvif0, RPF nbr 10.0.4.1
Outgoing interface list: Null

BNG.pop1#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.4.1 Lspvif0 01:03:07/00:01:20 v2 1 / DR S P G
BNG.pop1#

******************************
MLDP-CORE NETWORK
******************************
BNG.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.4.1:0, uptime 01:03:56 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 1
Branch count : 0
Path count : 2
Path(s) : 10.0.4.1 No LDP Tunnel65336
: 10.0.20.2 LDP GigabitEthernet1/0
Nhop count : 2
Nhop list : 10.0.4.1 10.0.20.2
BNG.pop1#show mpls mldp bindings
System ID: 68000001
Type: MP2MP, Root Node: 10.0.4.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.4.1:0, remote binding[U]: 20, local binding[D]: 20 active

BNG.pop1#

edge2.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.3.1:0, uptime 01:04:39 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.3.1 No LDP Tunnel65336
: 10.0.20.1 LDP GigabitEthernet1/0
Nhop count : 0
edge2.pop1#show mpls mldp bindings
System ID: 33000001
Type: MP2MP, Root Node: 10.0.4.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.3.1:0, local binding[U]: 20, remote binding[D]: 20

edge2.pop1#

*************************************
L2TPv3 XCONNECT-AGGREGATION NETWORK
****************************************
core1.pop2#sh l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
48862 64352 23023 10, Vl10 est 02:11:37 1
48863 64353 23023 20, Vl20 est 02:11:34 2
48864 64354 23023 30, Vl30 est 02:11:31 3

%No active PPTP tunnels
core1.pop2#sh l2tun session packet

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
48862 64352 23023 75 271 7589 25088
48863 64353 23023 367 433 51794 37754
48864 64354 23023 130 940 10221 82839

%No active PPTP tunnels
core1.pop2#

core2.pop2#show l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
64352 48862 30059 10, Vl10 est 02:11:33 4
64353 48863 30059 20, Vl20 est 02:11:30 5
64354 48864 30059 30, Vl30 est 02:11:26 6

%No active PPTP tunnels
core2.pop2#show l2tun session packet

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 3

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
64352 48862 30059 271 75 25088 7589
64353 48863 30059 435 368 37886 51854
64354 48864 30059 943 130 83109 10221

%No active PPTP tunnels
core2.pop2#

***********************************************
MAC and ARP TABLE-ACCESS/AGGREGATION NETWORK
***********************************************
dslam.pop2#show mac-address-table
Destination Address Address Type VLAN Destination Port
------------------- ------------ ---- --------------------
c400.1268.0000 Self 1 Vlan1
ca05.13e4.0038 Dynamic 30 FastEthernet2/0
c400.1268.0000 Self 20 Vlan20
c400.1268.0000 Self 30 Vlan30
c403.1268.0001 Dynamic 20 FastEthernet2/15
c402.1268.0000 Dynamic 10 FastEthernet2/14

dslam.pop2#

BNG.pop1#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.20.1 - ca05.13e4.001c ARPA GigabitEthernet1/0
Internet 10.0.20.2 137 ca06.13f0.001c ARPA GigabitEthernet1/0
Internet 10.0.101.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
30
Internet 10.0.101.2 93 c400.1268.0000 ARPA GigabitEthernet2/0.
30
BNG.pop1#show arp vrf IPTV
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.151.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
20
Internet 192.168.151.3 21 c403.1268.0001 ARPA GigabitEthernet2/0.
20
BNG.pop1#show arp vrf Internet
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.110.1 - ca05.13e4.0038 ARPA GigabitEthernet2/0.
10
Internet 10.0.110.2 69 c402.1268.0000 ARPA GigabitEthernet2/0.
10
BNG.pop1#

****************************
MPLS TE
****************************
BNG.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1972 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 172 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
BNG.pop1_t65336 10.0.4.1 - Gi1/0 up/up
edge2.pop1_t65336 10.0.3.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
BNG.pop1#

BNG.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.4.1/32 0 Tu65336 point2point
18 No Label 10.0.110.0/24[V] 5440 aggregate/Internet
19 No Label 192.168.151.0/24[V] \
13934 aggregate/IPTV
20 [T] No Label [mdt 200:1 0][V] 11250 aggregate/IPTV

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
BNG.pop1#

edge2.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1528 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 6 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 28 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge2.pop1_t65336 10.0.3.1 - Gi1/0 up/up
BNG.pop1_t65336 10.0.4.1 Gi1/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge2.pop1#show mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 No Label 192.168.1.0/30[V] \
1832 aggregate/IPTV
17 No Label 172.16.1.0/30[V] 2866 aggregate/Internet
18 No Label 192.168.0.0/16[V] \
5322 Fa2/1 192.168.1.2
19 [T] Pop Label 10.0.3.1/32 0 Tu65336 point2point
21 [T] No Label [mdt 200:1 0][V] 19950 aggregate/IPTV
22 No Label 172.16.0.0/16[V] 7662 Fa2/0 172.16.1.2
23 [T] Pop Label 10.0.101.0/24 0 Tu65336 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge2.pop1#

No comments:

Post a Comment