Saturday, January 2, 2010

Implementing Inter-AS SP Multicast and SP Security for Smurf Attack via Blackholing LAB



COnfig Gudelines
***************************************************************************************************
Scenario - Providing Inter-AS Multicast Services Providing Multicast Traffic between Multicast Server
in AS 64513 and Multicast Client in AS 64514 and vice-versa.
Also preventing RFP Failure for the Multicast Source with the Help of Multicast BGP when the
Multicast Traffic Flow Path is different from the Unicast IPv4 Path fir the Sources.
Also using Source based Blackholing for Smurf Attacks at PE ROuter and BGP Trigered Remote
Blackholing on PE Routers to Prevent Smurf Attacks
Design Cconsiderations and Soultions: Can use PIM Dense or Sparse Mode. Dense Mode causes Traffic Flooding
whereas Sparse Mode is via Shared Tree where RP is needed
To Provide Inter-AS Multicast the ASBRs peering via Unicast IPv4 should run
MSDP between them to join the Register Messages with the IGMP-Join messages in respective ASes.
Also to have no interference between RPs in the diferent ASes using the Multicast Boundary at the
ASBR Peerings denying 224.0.1.39/40 and allowing rest
There should be Separate RPs in the different Autonomous Systems and independent of each other.Can use
either Static RP,Auto-RP or Bootstrap Router
To Prevent RPF Failure on Multicast source when the Multicast Tree Path and IPv4 Unicast path are different
Using Multicast BGP in individual ASes and between ASBRs. Announcing the Multicast Source under the Multicast IPv4
Family peering using Network Statement and Propagating it further to different AS
The Multicast BGP ROute will be preferred over IPv4 Unicast ROute for RPF Check
For Preventing Smurf Attacks via SOurce based Blackholing ,creating Static Routes for the Sources to Next Hop pointing
to Null 0and redistributing it to Peers inside AS via IBGP
For Preventing Smurf Attach via BGP Trigered Remote Blackholing making the Customer tag and send packets
with the Community which can be matched at ISP PE and set to next hop as a Null ROute.
ISP 1 AS used 64513
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces
ISP 1 AS used 64514
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces
EBGP used within ASes
Customer Routers have default route to ISP PEs.
PIM Sparse-Mode used between PE-CE , On ISP Backbone Links and Peering between ISP 1 & 2
via PE12 and PE22
RP Selected via Bootstrap Router on PE12 and PE22 and propogated in the AS
No PIM used between ISP1 and ISP 2 Peering between P1 and P2 (IPv4 Unicast Peering)
IGMP Join-group used to simulate Mutlicast Traffic
224.22.22.22 on CE2A and 224.33.33.33 on CE1A
224.66.66.66 on PE12 Lo0 to Simulate traffic inside AS 64513
224.55.555.55 on PE22 Lo0 to Simulate traffic inside AS 64514
On CE1A used Lo0 and Lo1 to generate Smurf Trafic Source.
For Lo0 used BGP Trigered Blackholing by Tagging Lo0 IP Block with Commuity 64513:999
which is matched and accpeted by PE11 and Set the Next hop as 192.168.1.254. The Route for 192.168.1.254 is a Host Null Route
Thus causing blockholing and propagating this Information to other PEs via IBGP
For Lo1 used Source Based Blackholing by creating Static Route for Lo1 IP Block on PE11 pointing to 192.168.1.254.The Route for
192.168.1.254 is a Host Null Route Thus causing blockholing and propagating this Information to other PEs via IBGP
Done Extended Ping on CE1A and CE2A to Multicast Groups with Source Interface as Peering with ISP and
Source Address as the Interface Address
***************************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1442 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.100.1 255.255.255.0
!
interface Loopback1
ip address 192.168.200.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip pim sparse-mode
ip igmp join-group 224.33.33.33
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.9 remote-as 64513
neighbor 192.168.1.9 send-community
neighbor 192.168.1.9 soft-reconfiguration inbound
neighbor 192.168.1.9 route-map Out out
no auto-summary
!
ip http server
ip route 0.0.0.0 0.0.0.0 192.168.1.9
!
!
ip bgp-community new-format
!
!
ip prefix-list Out seq 10 permit 192.168.100.0/24
!
route-map Local permit 10
match interface Loopback0
!
route-map Out permit 10
match ip address prefix-list Out
set community 64513:999
!
route-map Out permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1357 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description <>
ip address 172.16.1.10 255.255.255.252
ip pim sparse-mode
ip igmp join-group 224.22.22.22
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.9 remote-as 64513
neighbor 192.168.1.9 send-community
neighbor 192.168.1.9 soft-reconfiguration inbound
neighbor 192.168.1.9 route-map Out out
no auto-summary
!
ip http server
ip route 0.0.0.0 0.0.0.0 172.16.1.9
!
!!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE2A#
PE11#sh running-config
Building configuration...
Current configuration : 2315 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 192.168.1.9 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
description <>
ip address 192.168.1.6 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/1
network 10.0.1.1 0.0.0.0 area 0
network 192.168.1.4 0.0.0.3 area 0
network 192.168.1.0 0.0.0.7 area 0
network 192.168.1.8 0.0.0.3 area 0
!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
neighbor 192.168.1.10 remote-as 64514
!
address-family ipv4
redistribute static route-map Smurf
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
neighbor 192.168.1.10 activate
neighbor 192.168.1.10 soft-reconfiguration inbound
neighbor 192.168.1.10 route-map In in
no auto-summary
no synchronization
network 192.168.1.8 mask 255.255.255.252
exit-address-family
!
address-family ipv4 multicast
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
no auto-summary
no synchronization
network 192.168.1.8 mask 255.255.255.252
exit-address-family
!
ip http server
ip route 192.168.1.254 255.255.255.255 Null0
ip route 192.168.200.0 255.255.255.0 192.168.1.254
!
!
ip bgp-community new-format
ip community-list 10 permit 64513:999
ip community-list 14 permit 64513:999
!
!
ip prefix-list Smurf seq 10 permit 192.168.200.0/24
!
route-map In permit 10
match community 10
set ip next-hop 192.168.1.254
!
route-map In permit 20
!
route-map Smurf permit 10
match ip address prefix-list Smurf
set ip next-hop 192.168.1.254
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
PE11#
P1#sh running-config
Building configuration...
Current configuration : 2704 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ip multicast-routing
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description <>
ip address 192.168.1.5 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/1
description <>
ip address 10.0.20.1 255.255.255.252
shutdown
speed auto
duplex auto
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
no passive-interface FastEthernet2/0
network 10.0.2.1 0.0.0.0 area 0
network 10.0.20.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.3 area 1
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64513
no synchronization
bgp cluster-id 1.1.1.1
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 route-reflector-client
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 route-reflector-client
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.20.2 remote-as 64514
neighbor 10.0.20.2 soft-reconfiguration inbound
no auto-summary
!
!
address-family ipv4 multicast
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 route-reflector-client
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 route-reflector-client
neighbor 10.0.3.1 next-hop-self
no auto-summary
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
P1#
PE12#sh running-config
Building configuration...
Current configuration : 2559 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ip multicast-routing
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip pim sparse-mode
ip igmp join-group 224.66.66.66
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description <>
ip address 10.0.10.1 255.255.255.252
ip pim sparse-mode
ip multicast boundary 1
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.0.3.1 0.0.0.0 area 1
network 10.0.10.0 0.0.0.3 area 1
network 192.168.1.0 0.0.0.3 area 1
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
neighbor 10.0.10.2 remote-as 64514
neighbor 10.0.10.2 soft-reconfiguration inbound
no auto-summary
!
!
address-family ipv4 multicast
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.10.2 activate
no auto-summary
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 10.0.10.2
ip msdp cache-sa-state
!
access-list 1 deny 224.0.1.39
access-list 1 deny 224.0.1.40
access-list 1 permit any
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE12#
PE22#sh running-config
Building configuration...
Current configuration : 2550 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ip multicast-routing
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip pim sparse-mode
ip igmp join-group 224.55.55.55
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 172.16.1.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 172.16.1.2 405 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description <>
ip address 10.0.10.2 255.255.255.252
ip pim bsr-border
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.0.4.1 0.0.0.0 area 1
network 10.0.10.0 0.0.0.3 area 1
network 172.16.1.0 0.0.0.3 area 1
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 10.0.5.1 remote-as 64514
neighbor 10.0.5.1 update-source Loopback0
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.5.1 soft-reconfiguration inbound
neighbor 10.0.10.1 remote-as 64513
neighbor 10.0.10.1 soft-reconfiguration inbound
no auto-summary
!
!
address-family ipv4 multicast
neighbor 10.0.5.1 activate
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.10.1 activate
no auto-summary
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 10.0.10.1
ip msdp cache-sa-state
!
access-list 1 deny 244.0.1.39
access-list 1 deny 244.0.1.40
access-list 1 permit any
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE22#
P2#sh running-config
Building configuration...
Current configuration : 2680 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ip multicast-routing
!
!
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 172.16.1.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 172.16.1.1 504 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description <>
ip address 172.16.1.5 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet2/1
description <>
ip address 10.0.20.2 255.255.255.252
shutdown
speed auto
duplex auto
mpls label protocol ldp
mpls ip
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
no passive-interface FastEthernet2/0
network 10.0.5.1 0.0.0.0 area 0
network 10.0.20.0 0.0.0.3 area 0
network 172.16.1.0 0.0.0.3 area 1
network 172.16.1.4 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp cluster-id 2.2.2.2
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64514
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 route-reflector-client
neighbor 10.0.4.1 next-hop-self
neighbor 10.0.4.1 soft-reconfiguration inbound
neighbor 10.0.6.1 remote-as 64514
neighbor 10.0.6.1 update-source Loopback0
neighbor 10.0.6.1 route-reflector-client
neighbor 10.0.6.1 next-hop-self
neighbor 10.0.6.1 soft-reconfiguration inbound
neighbor 10.0.20.1 remote-as 64513
neighbor 10.0.20.1 next-hop-self
neighbor 10.0.20.1 soft-reconfiguration inbound
no auto-summary
!
!
address-family ipv4 multicast
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 route-reflector-client
neighbor 10.0.4.1 next-hop-self
neighbor 10.0.6.1 activate
neighbor 10.0.6.1 route-reflector-client
neighbor 10.0.6.1 next-hop-self
no auto-summary
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
P2#
PE21#sh running-config
Building configuration...
Current configuration : 1376 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.6.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.1.9 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 172.16.1.6 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/1
network 10.0.6.1 0.0.0.0 area 0
network 172.16.1.4 0.0.0.3 area 0
network 172.16.1.8 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.16.1.8 mask 255.255.255.252
neighbor 10.0.5.1 remote-as 64514
neighbor 10.0.5.1 update-source Loopback0
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.5.1 soft-reconfiguration inbound
no auto-summary
!
!
address-family ipv4 multicast
neighbor 10.0.5.1 activate
neighbor 10.0.5.1 next-hop-self
no auto-summary
no synchronization
network 172.16.1.8 mask 255.255.255.252
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
PE21#
***********************************************************************************************
OUTPUT
********************************************************************************************
Multicast Traffic Test between ASes along with RP Information inside ASes and mroute table
when P1-P2 Peering was Off and no RPF Failure
*******************************************************************************************
CE1A#ping
Protocol [ip]:
Target IP address: 224.22.22.22
Repeat count [1]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: Fastethernet0/0
Time to live [255]:
Source address: 192.168.1.10
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.22.22.22, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.10
Reply to request 0 from 192.168.1.10, 4 ms
Reply to request 0 from 172.16.1.10, 588 ms
Reply to request 1 from 192.168.1.10, 4 ms
Reply to request 1 from 172.16.1.10, 1080 ms
Reply to request 2 from 192.168.1.10, 4 ms
Reply to request 2 from 172.16.1.10, 868 ms
Reply to request 3 from 192.168.1.10, 4 ms
Reply to request 3 from 172.16.1.10, 880 ms
Reply to request 4 from 192.168.1.10, 4 ms
Reply to request 4 from 172.16.1.10, 1472 ms
Reply to request 5 from 192.168.1.10, 4 ms
Reply to request 5 from 172.16.1.10, 848 ms
CE1A#
PE11#show ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:28:47/00:02:55, RP 10.0.3.1, flags: SJC
Incoming interface: FastEthernet0/1, RPF nbr 192.168.1.5
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:11:46/00:02:55
(192.168.1.10, 224.22.22.22), 00:01:38/00:03:19, flags: T
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:01:37/00:02:52
PE11#
P1#show ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:12:24/00:02:53, RP 10.0.3.1, flags: S
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:12:24/00:02:53
(192.168.1.10, 224.22.22.22), 00:02:15/00:03:10, flags: T
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.6
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:02:15/00:03:10
P1#
PE12#sh ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:23:56/00:02:35, RP 10.0.3.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:12:44/00:02:35
(192.168.1.10, 224.22.22.22), 00:02:36/00:03:19, flags: TA
Incoming interface: Serial1/0, RPF nbr 192.168.1.2
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:02:35/00:02:51
PE12#
PE22#sh ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:05:21/00:03:03, RP 10.0.4.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:05:21/00:03:03
(192.168.1.10, 224.22.22.22), 00:02:59/00:03:24, flags: MT
Incoming interface: FastEthernet2/0, RPF nbr 10.0.10.1
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:02:59/00:03:29
PE22#
P2#sh ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:05:41/00:02:44, RP 10.0.4.1, flags: S
Incoming interface: Serial1/0, RPF nbr 172.16.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:05:41/00:02:44
(192.168.1.10, 224.22.22.22), 00:03:17/00:03:05, flags: T
Incoming interface: Serial1/0, RPF nbr 172.16.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:03:17/00:03:10
P2#
PE21#sh ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:06:06/00:03:18, RP 10.0.4.1, flags: SJC
Incoming interface: FastEthernet0/1, RPF nbr 172.16.1.5
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:06:06/00:03:18
(192.168.1.10, 224.22.22.22), 00:03:42/00:03:10, flags: T
Incoming interface: FastEthernet0/1, RPF nbr 172.16.1.5
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:03:42/00:03:18
PE21#
CE2A#ping
Protocol [ip]:
Target IP address: 224.33.33.33
Repeat count [1]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: Fastethernet0/0
Time to live [255]:
Source address: 172.16.1.10
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.33.33.33, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.10
Reply to request 0 from 192.168.1.10, 1140 ms
Reply to request 1 from 192.168.1.10, 1092 ms
Reply to request 2 from 192.168.1.10, 796 ms
Reply to request 3 from 192.168.1.10, 892 ms
Reply to request 4 from 192.168.1.10, 1476 ms
Reply to request 5 from 192.168.1.10, 980 ms
Reply to request 6 from 192.168.1.10, 1536 ms
Reply to request 7 from 192.168.1.10, 1060 ms
CE2A#
PE21#sh ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:00:56/stopped, RP 10.0.4.1, flags: SP
Incoming interface: FastEthernet0/1, RPF nbr 172.16.1.5
Outgoing interface list: Null
(172.16.1.10, 224.33.33.33), 00:00:56/00:03:18, flags: T
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:00:56/00:02:34
PE21#
P2#sh ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:01:23/stopped, RP 10.0.4.1, flags: SP
Incoming interface: Serial1/0, RPF nbr 172.16.1.1
Outgoing interface list: Null
(172.16.1.10, 224.33.33.33), 00:01:23/00:03:20, flags: T
Incoming interface: FastEthernet2/0, RPF nbr 172.16.1.6
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:01:23/00:03:04
P2#
PE22#sh ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:01:40/stopped, RP 10.0.4.1, flags: SP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
(172.16.1.10, 224.33.33.33), 00:01:40/00:03:14, flags: TA
Incoming interface: Serial1/0, RPF nbr 172.16.1.2
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:01:39/00:02:49
PE22#
PE12#sh ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:02:14/00:03:13, RP 10.0.3.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:02:14/00:03:13
(172.16.1.10, 224.33.33.33), 00:01:56/00:03:18, flags: MT
Incoming interface: FastEthernet2/0, RPF nbr 10.0.10.2
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:01:57/00:03:12
PE12#
P1#show ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:02:29/00:02:58, RP 10.0.3.1, flags: S
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:02:29/00:02:58
(172.16.1.10, 224.33.33.33), 00:02:09/00:03:25, flags: T
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:02:09/00:03:20
P1#
PE11#show ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:02:52/00:02:37, RP 10.0.3.1, flags: SJC
Incoming interface: FastEthernet0/1, RPF nbr 192.168.1.5
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:02:52/00:02:37
(172.16.1.10, 224.33.33.33), 00:02:33/00:03:14, flags: T
Incoming interface: FastEthernet0/1, RPF nbr 192.168.1.5
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:02:33/00:02:56
PE11#
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
CE2A#ping
Protocol [ip]:
Target IP address: 224.55.55.55
Repeat count [1]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: F0/0
% Invalid interface
Interface [All]: ?
% Invalid interface
Interface [All]: fastethernet0/0
Time to live [255]:
Source address: 172.16.1.10
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 224.55.55.55, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.10
Reply to request 0 from 172.16.1.1, 912 ms
Reply to request 1 from 172.16.1.1, 688 ms
Reply to request 2 from 172.16.1.1, 664 ms
Reply to request 3 from 172.16.1.1, 496 ms
Reply to request 4 from 172.16.1.1, 388 ms
CE2A#
PE21#show ip mroute 224.55.55.55
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.55.55.55), 00:01:02/stopped, RP 10.0.4.1, flags: SP
Incoming interface: FastEthernet0/1, RPF nbr 172.16.1.5
Outgoing interface list: Null
(172.16.1.10, 224.55.55.55), 00:01:02/00:03:19, flags: T
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:01:01/00:03:27
PE21#
P2#show ip mroute 224.55.55.55
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.55.55.55), 00:00:36/stopped, RP 10.0.4.1, flags: SP
Incoming interface: Serial1/0, RPF nbr 172.16.1.1
Outgoing interface list: Null
(172.16.1.10, 224.55.55.55), 00:00:36/00:03:27, flags: T
Incoming interface: FastEthernet2/0, RPF nbr 172.16.1.6
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:00:36/00:02:53
P2#
PE22#show ip mroute 224.55.55.55
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.55.55.55), 00:01:23/stopped, RP 10.0.4.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:01:23/00:02:12
(172.16.1.10, 224.55.55.55), 00:00:21/00:02:55, flags: LTA
Incoming interface: Serial1/0, RPF nbr 172.16.1.2
Outgoing interface list:
Loopback0, Forward/Sparse, 00:00:21/00:02:38
PE22#
PE21#show ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 10.0.4.1 (?), v2
Info source: 10.0.4.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:12:58, expires: 00:02:24
P2#show ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 10.0.4.1 (?), v2
Info source: 10.0.4.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:13:29, expires: 00:02:11
P2#
PE22#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)
Group(s) 224.0.0.0/4
RP 10.0.4.1 (?), v2
Info source: 10.0.4.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:14:15, expires: 00:02:12
PE22#
P2#show ip rpf 192.168.1.10
RPF information for ? (192.168.1.10)
RPF interface: Serial1/0
RPF neighbor: ? (172.16.1.1)
RPF route/mask: 192.168.1.8/30
RPF type: unicast (bgp 64514)
Doing distance-preferred lookups across tables
P2#
PE22#sh ip msdp peer
MSDP Peer 10.0.10.1 (?), AS 64513
Connection status:
State: Up, Resets: 0, Connection source: none configured
Uptime(Downtime): 01:24:34, Messages sent/received: 92/94
Output messages discarded: 0
Connection and counters cleared 01:24:50 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
PE22#
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
CE1A#ping
Protocol [ip]:
Target IP address: 224.66.66.66
Repeat count [1]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: Fastethernet0/0
Time to live [255]:
Source address: 192.168.1.10
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.66.66.66, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.10
Reply to request 0 from 192.168.1.1, 472 ms
Reply to request 0 from 192.168.1.1, 472 ms
Reply to request 1 from 192.168.1.1, 484 ms
Reply to request 2 from 192.168.1.1, 556 ms
Reply to request 3 from 192.168.1.1, 468 ms
CE1A#
PE11#sh ip mroute 224.66.66.66
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.66.66.66), 00:02:47/stopped, RP 10.0.3.1, flags: SP
Incoming interface: FastEthernet0/1, RPF nbr 192.168.1.5
Outgoing interface list: Null
(192.168.1.10, 224.66.66.66), 00:02:47/00:02:26, flags: T
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:02:47/00:02:34
PE11#
P1#sh ip mroute 224.66.66.66
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.66.66.66), 00:03:21/stopped, RP 10.0.3.1, flags: SP
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list: Null
(192.168.1.10, 224.66.66.66), 00:03:21/00:01:54, flags: T
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.6
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:03:21/00:02:51
P1#
PE12#sh ip mroute 224.66.66.66
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.66.66.66), 00:04:20/stopped, RP 10.0.3.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:04:20/00:02:49
(192.168.1.10, 224.66.66.66), 00:03:43/00:01:04, flags: LTA
Incoming interface: Serial1/0, RPF nbr 192.168.1.2
Outgoing interface list:
Loopback0, Forward/Sparse, 00:03:43/00:02:49
PE12#
PE11#sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 10.0.3.1 (?), v2
Info source: 10.0.3.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:00:38, expires: 00:02:21
PE11#
P1#sh ip pim rp mapping
PIM Group-to-RP Mappings
P1#sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 10.0.3.1 (?), v2
Info source: 10.0.3.1 (?), via bootstrap, priority 0, holdtime 181
Uptime: 00:00:08, expires: 00:02:47
P1#
PE11#sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 10.0.3.1 (?), v2
Info source: 10.0.3.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:00:17, expires: 00:02:10
PE12#sh ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)
Group(s) 224.0.0.0/4
RP 10.0.3.1 (?), v2
Info source: 10.0.3.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:02:53, expires: 00:01:33
PE12#
P1#sh ip rpf 172.16.1.10
RPF information for ? (172.16.1.10)
RPF interface: Serial1/0
RPF neighbor: ? (192.168.1.1)
RPF route/mask: 172.16.1.8/30
RPF type: unicast (bgp 64513)
Doing distance-preferred lookups across tables
P1#
PE12#sh ip msdp peer
MSDP Peer 10.0.10.2 (?), AS 64514
Connection status:
State: Up, Resets: 0, Connection source: none configured
Uptime(Downtime): 01:24:23, Messages sent/received: 94/92
Output messages discarded: 0
Connection and counters cleared 01:25:23 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 1
Input queue size: 0, Output queue size: 0
*******************
^^^^^^^^^^^
P1#show ip mroute count
IP Multicast Statistics
3 routes using 2048 bytes of memory
3 groups, 0.00 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
Group: 224.22.22.22, Source count: 0, Packets forwarded: 1, Packets received: 1
RP-tree: Forwarding: 1/0/100/0, Other: 1/0/0
Group: 224.33.33.33, Source count: 0, Packets forwarded: 1, Packets received: 1
RP-tree: Forwarding: 1/0/100/0, Other: 1/0/0
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
P1#
P2#sh ip mroute count
IP Multicast Statistics
4 routes using 2560 bytes of memory
4 groups, 0.00 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
Group: 224.88.88.88, Source count: 0, Packets forwarded: 0, Packets received: 0
Group: 224.22.22.22, Source count: 0, Packets forwarded: 1, Packets received: 1
RP-tree: Forwarding: 1/0/100/0, Other: 1/0/0
Group: 224.33.33.33, Source count: 0, Packets forwarded: 0, Packets received: 0
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
P2#
********************************************************************************************
when P1-P2 Peering was On and RPF Failure Until Multicast BGP Turned On
*******************************************************************************************
**************
P1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 192.168.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Serial1/4 unassigned YES unset administratively down down
Serial1/5 unassigned YES unset administratively down down
Serial1/6 unassigned YES unset administratively down down
Serial1/7 unassigned YES unset administratively down down
FastEthernet2/0 192.168.1.5 YES manual up up
FastEthernet2/1 10.0.20.1 YES manual administratively down down
Loopback0 10.0.2.1 YES manual up up
P1#
P2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 172.16.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Serial1/4 unassigned YES unset administratively down down
Serial1/5 unassigned YES unset administratively down down
Serial1/6 unassigned YES unset administratively down down
Serial1/7 unassigned YES unset administratively down down
FastEthernet2/0 172.16.1.5 YES manual up up
FastEthernet2/1 10.0.20.2 YES manual administratively down down
Loopback0 10.0.5.1 YES manual up up
P2#
P1#sh ip bgp
BGP table version is 17, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i172.16.1.8/30 10.0.3.1 0 100 0 64514 i
r>i192.168.1.8/30 10.0.1.1 0 100 0 i
P1#
P2#sh ip bgp
BGP table version is 6, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r>i172.16.1.8/30 10.0.6.1 0 100 0 i
*>i192.168.1.8/30 10.0.4.1 0 100 0 64513 i
P2#
P1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 192.168.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Serial1/4 unassigned YES unset administratively down down
Serial1/5 unassigned YES unset administratively down down
Serial1/6 unassigned YES unset administratively down down
Serial1/7 unassigned YES unset administratively down down
FastEthernet2/0 192.168.1.5 YES manual up up
FastEthernet2/1 10.0.20.1 YES manual up up
Loopback0 10.0.2.1 YES manual up up
P1#
P2#traceroute 192.168.1.10
Type escape sequence to abort.
Tracing the route to 192.168.1.10
1 10.0.20.1 172 msec 88 msec 100 msec
2 192.168.1.6 444 msec 564 msec 896 msec
3 192.168.1.10 [AS 64513] 1192 msec 216 msec *
P2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
Serial1/0 172.16.1.2 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Serial1/4 unassigned YES unset administratively down down
Serial1/5 unassigned YES unset administratively down down
Serial1/6 unassigned YES unset administratively down down
Serial1/7 unassigned YES unset administratively down down
FastEthernet2/0 172.16.1.5 YES manual up up
FastEthernet2/1 10.0.20.2 YES manual up up
Loopback0 10.0.5.1 YES manual up up
P2#
P2#show ip rpf 192.168.1.10
failed, no route exists
P1#sh ip rpf 172.16.1.10
failed, no route exists
P2#sh ip bgp
BGP table version is 7, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r>i172.16.1.8/30 10.0.6.1 0 100 0 i
*> 192.168.1.8/30 10.0.20.1 0 64513 i
* i 10.0.4.1 0 100 0 64513 i
P2#sh ip rou
P2#sh ip route 192.168.1.8
Routing entry for 192.168.1.8/30
Known via "bgp 64514", distance 20, metric 0
Tag 64513, type external
Last update from 10.0.20.1 00:00:51 ago
Routing Descriptor Blocks:
* 10.0.20.1, from 10.0.20.1, 00:00:51 ago
Route metric is 0, traffic share count is 1
AS Hops 1
Route tag 64513
P2#ping 192.168.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 288/1064/1720 ms
P2#tra
P2#traceroute 192.168.1.10
Type escape sequence to abort.
Tracing the route to 192.168.1.10
1 10.0.20.1 172 msec 88 msec 100 msec
2 192.168.1.6 444 msec 564 msec 896 msec
3 192.168.1.10 [AS 64513] 1192 msec 216 msec *
P2#
P1#sh ip bgp
BGP table version is 18, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.8/30 10.0.20.2 0 64514 i
* i 10.0.3.1 0 100 0 64514 i
r>i192.168.1.8/30 10.0.1.1 0 100 0 i
P1#sh ip rou
P1#sh ip route 172.16.1.8
Routing entry for 172.16.1.8/30
Known via "bgp 64513", distance 20, metric 0
Tag 64514, type external
Last update from 10.0.20.2 00:00:18 ago
Routing Descriptor Blocks:
* 10.0.20.2, from 10.0.20.2, 00:00:18 ago
Route metric is 0, traffic share count is 1
AS Hops 1
Route tag 64514
P1#ping 172.16.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/1004/1692 ms
P1#traceroute 172.16.1.10
Type escape sequence to abort.
Tracing the route to 172.16.1.10
1 10.0.20.2 280 msec 208 msec 256 msec
2 172.16.1.6 620 msec 444 msec 316 msec
3 172.16.1.10 [AS 64514] 688 msec 1044 msec 1924 msec
P1#
P2#show ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 00:33:57/00:02:55, RP 10.0.4.1, flags: S
Incoming interface: Serial1/0, RPF nbr 172.16.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:33:57/00:02:55
(192.168.1.10, 224.22.22.22), 00:00:37/00:02:52, flags:
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:00:37/00:02:55
P2#
P1#sh ip mroute 224.33.33.33
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.33.33.33), 00:29:34/00:03:28, RP 10.0.3.1, flags: S
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:29:34/00:03:28
(172.16.1.10, 224.33.33.33), 00:00:14/00:03:15, flags:
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:00:14/00:03:28
P1#
P1#sh ip mroute 224.22.22.22
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.22.22.22), 01:08:03/00:03:07, RP 10.0.3.1, flags: S
Incoming interface: Serial1/0, RPF nbr 192.168.1.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 01:08:03/00:03:07
(192.168.1.10, 224.22.22.22), 00:00:25/00:03:04, flags:
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.6
Outgoing interface list:
Serial1/0, Forward/Sparse, 00:00:25/00:03:04
P1#
********************************************************************************************
when P1-P2 Peering was On and no RPF Failure After Multicast BGP Turned On
*******************************************************************************************
P1#sh ip bgp ipv4 multicast summary
BGP router identifier 10.0.2.1, local AS number 64513
BGP table version is 10, main routing table version 10
2 network entries using 242 bytes of memory
2 path entries using 96 bytes of memory
4/2 BGP path/bestpath attribute entries using 304 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 666 total bytes of memory
BGP activity 8/4 prefixes, 17/12 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 20 23 10 0 0 00:13:06 1
10.0.3.1 4 64513 17 19 10 0 0 00:13:05 1
P1#sh ip bgp ipv4 multicast
BGP table version is 10, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i172.16.1.8/30 10.0.3.1 0 100 0 64514 i
r>i192.168.1.8/30 10.0.1.1 0 100 0 i
P1#
P1#sh ip bgp ipv4 multicast 172.16.1.8
BGP routing table entry for 172.16.1.8/30, version 7
Paths: (1 available, best #1, table 8000)
Flag: 0x820
Advertised to update-groups:
1
64514, (Received from a RR-client)
10.0.3.1 (metric 65) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
P1#sh ip rpf 172.16.1.10
RPF information for ? (172.16.1.10)
RPF interface: Serial1/0
RPF neighbor: ? (192.168.1.1)
RPF route/mask: 172.16.1.8/30
RPF type: multicast (bgp 64513)
Doing distance-preferred lookups across tables
P1#
P2#sh ip bgp ipv4 multicast summary
BGP router identifier 10.0.5.1, local AS number 64514
BGP table version is 11, main routing table version 11
2 network entries using 242 bytes of memory
2 path entries using 96 bytes of memory
4/2 BGP path/bestpath attribute entries using 304 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 666 total bytes of memory
BGP activity 8/4 prefixes, 30/25 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.4.1 4 64514 18 20 11 0 0 00:12:26 1
10.0.6.1 4 64514 18 23 11 0 0 00:12:19 1
P2#sh ip bgp ipv4 multicast
BGP table version is 11, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r>i172.16.1.8/30 10.0.6.1 0 100 0 i
*>i192.168.1.8/30 10.0.4.1 0 100 0 64513 i
P2#
P2#sh ip bgp ipv4 multicast 192.168.1.8
BGP routing table entry for 192.168.1.8/30, version 11
Paths: (1 available, best #1, table 8000)
Flag: 0x820
Advertised to update-groups:
1
64513, (Received from a RR-client)
10.0.4.1 (metric 65) from 10.0.4.1 (10.0.4.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
P2#sh ip rpf
P2#sh ip rpf 192.168.1.8
RPF information for ? (192.168.1.8)
RPF interface: Serial1/0
RPF neighbor: ? (172.16.1.1)
RPF route/mask: 192.168.1.8/30
RPF type: multicast (bgp 64514)
Doing distance-preferred lookups across tables
P2#
&&&&&&&&&
******************************************************************
SMurf Attack Prevention via BGP Triggered Blackholing
*******************************************************************
PE12#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
!!!..
Success rate is 60 percent (3/5), round-trip min/avg/max = 408/1405/1984 ms
CE1A#sh ip bgp neighbors 192.168.1.9 advertised-routes
BGP table version is 4, local router ID is 192.168.100.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 192.168.100.0 0.0.0.0 0 32768 i
Total number of prefixes 1
CE1A#
PE11#sh ip bgp
BGP table version is 36, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i172.16.1.8/30 10.0.2.1 0 100 0 64514 i
*> 192.168.1.8/30 0.0.0.0 0 32768 i
* 192.168.100.0 192.168.1.254 0 0 64514 i
PE11#sh ip bgp 192.168.100.0
BGP routing table entry for 192.168.100.0/24, version 36
Paths: (2 available, no best path)
Not advertised to any peer
64514
192.168.1.254 (inaccessible) from 192.168.1.10 (192.168.100.1)
Origin IGP, metric 0, localpref 100, valid, external
Community: 64513:999
64514, (received-only)
192.168.1.10 from 192.168.1.10 (192.168.100.1)
Origin IGP, metric 0, localpref 100, valid, external
Community: 64513:999
PE11#
PE12#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
PE12#
******************************************************************
SMurf Attack Prevention via Source Based Blackholing
*******************************************************************
PE12#ping 192.168.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
!.!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 196/913/1532 ms
PE12#
PE11#sh ip bgp
BGP table version is 44, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i172.16.1.8/30 10.0.2.1 0 100 0 64514 i
*> 192.168.1.8/30 0.0.0.0 0 32768 i
*> 192.168.100.0 192.168.1.254 0 0 64514 i
*> 192.168.200.0 192.168.1.254 0 32768 ?
* 192.168.1.10 0 0 64514 i
PE11#
PE12#ping 192.168.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.200.1, timeout is 2 seconds:
U...U
Success rate is 0 percent (0/5)
PE12#
PE11#

No comments:

Post a Comment