Sunday, January 3, 2010

Implementing Multicast In MPLS Layer 3 VPNS and VPN QoS LAB



Config Guide Lines
**************************************************************************
Scenario- ISP 64513 Needs to Provide Multicast Services to his MPLS
VPN Customer CEB and also to implement VPN Qos thereby providing transit
BW of 256Kbps for VOIP and 128 Kbps for Data.
Design COnsiderations and Solution:
ISP 64513 Implements PIM Sparse Mode for the Custmer and Own AS.
Implements RP Selection via Bootstrap Router inside VRF at PE11 and Own AS
at PE12
For Transporting Multicast Traffic Over MPLS L3 VPN ISP Implements Source
Specific Multicast (SSM) and Multicast Distributio Tree (MDT) feature
thereby carrying Multicast Traffic over auto GRET Tunnels between PEs (PE11
and PE14)
For Implementing Qos ISP mathces VOIP as IP DSCP ef and DATA as IP DSCP af31
and transforms them to MPLS EXP 4 and MPLS 3 respectively with the required
BW Guarantee in its Core. ISP uses IP DSCP-MPLS EXP translation by setting both
The MPLS Transport Label and VPN LAbel with these EXPs so that the PHP feature
does not cause issues for the IP Prec Value sent to Customers at the Other END
ISP AS used 64513
IGP Used OSPF in Area 0 in the Core
PE-CE Routing Protocol Used RIP
VRF Used CEB
rd 64513:2
rt 64513:200
RP Selected for VRF CEB Via BSR
IGMP Group 224.11.11.11 Used at CE4A to Simulate Multicast Traffic
IGMP Group 224.22.22.22 Used at CE4A to Simulate Multicast Traffic
Extended Pings done at CE4A and CE3A with ToS Set to af31(0x68) and
ef (oxB8) for Testing Qos Prorpgaton end to end
*************************************************************************
CE4A#sh running-config
Building configuration...
Current configuration : 1559 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE4A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all VOIP
match ip dscp ef
class-map match-all DATA
match ip dscp af31
!
!
policy-map To_PE11
class VOIP
bandwidth 256
class DATA
bandwidth 128
class class-default
policy-map From_PE11
class VOIP
set ip dscp cs3
class DATA
set ip dscp af31
class class-default
!
!
!
!
!
interface Loopback0
ip address 192.168.254.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.1.38 255.255.255.252
ip pim sparse-mode
ip igmp join-group 224.88.88.88
serial restart-delay 0
no dce-terminal-timing-enable
service-policy input From_PE11
service-policy output To_PE11
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router rip
network 192.168.1.0
network 192.168.254.0
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE4A#
CE4A#
CE4A#
CE3A#sh running-config
Building configuration...
Current configuration : 1559 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all VOIP
match ip dscp ef
class-map match-all DATA
match ip dscp af31
!
!
policy-map To_PE14
class VOIP
bandwidth 256
class DATA
bandwidth 128
class class-default
policy-map From_PE14
class VOIP
set ip dscp cs3
class DATA
set ip dscp af31
class class-default
!
!
!
!
!
interface Loopback0
ip address 192.168.250.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.1.34 255.255.255.252
ip pim sparse-mode
ip igmp join-group 224.77.77.77
serial restart-delay 0
no dce-terminal-timing-enable
service-policy input From_PE14
service-policy output To_PE14
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router rip
network 192.168.1.0
network 192.168.250.0
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE3A#
PE11#sh running-config
Building configuration...
Current configuration : 5393 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
clock timezone GMT 5 30
!
!
ip cef
!
!
ip vrf CEB
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64513:100
mdt default 239.2.2.2
!
ip multicast-routing
ip multicast-routing vrf CEB
mpls label protocol ldp
no mpls ip propagate-ttl
mpls ldp explicit-null
mpls traffic-eng tunnels
mpls traffic-eng logging lsp setups
mpls traffic-eng logging lsp teardowns
!
!
key chain CEA
key 1
key-string 7 06252A00
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all VOIP
match ip dscp ef
class-map match-all QoS_3
match mpls experimental topmost 3
class-map match-all QoS_4
match mpls experimental topmost 4
class-map match-all DATA
match ip dscp af31
class-map match-all EXP_3
match qos-group 3
class-map match-all EXP_4
match qos-group 4
class-map match-all In_EXP_3
match mpls experimental topmost 3
class-map match-all In_EXP_4
match mpls experimental topmost 4
!
!
policy-map To_CE4A
class EXP_4
set ip dscp ef
class EXP_3
set ip dscp af31
class class-default
policy-map From_CE4A
class VOIP
set mpls experimental imposition 4
class DATA
set mpls experimental imposition 3
class class-default
policy-map Core_Out
class In_EXP_4
bandwidth 256
class In_EXP_3
bandwidth 128
class class-default
policy-map Core_In
class QoS_4
set qos-group 4
class QoS_3
set qos-group 3
class class-default
!
!
!
!
!
interface Tunnel10
ip unnumbered Loopback0
tunnel destination 10.0.4.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 1000
tunnel mpls traffic-eng path-option 1 explicit name Secondary
tunnel mpls traffic-eng path-option 2 explicit name Primary
no routing dynamic
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip pim sparse-mode
ip igmp join-group 224.55.55.55
!
interface Loopback1
no ip address
!
interface Loopback2
ip vrf forwarding CEB
ip address 192.168.128.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
ip address 192.168.1.17 255.255.255.252
shutdown
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial1/0
no ip address
ip pim bsr-border
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip vrf forwarding CEB
ip address 192.168.1.37 255.255.255.252
ip pim sparse-mode
serial restart-delay 0
no dce-terminal-timing-enable
service-policy input From_CE4A
service-policy output To_CE4A
!
interface Serial1/2
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 192.168.1.2 201 broadcast
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 10.0.1.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Serial1/0
no passive-interface Serial1/2
no passive-interface Loopback1
network 10.0.1.1 0.0.0.0 area 0
network 10.0.2.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.3 area 0
network 192.168.1.16 0.0.0.3 area 0
!
router rip
version 2
!
address-family ipv4 vrf CEB
redistribute bgp 64513 metric 10
network 192.168.1.0
network 192.168.128.0
no auto-summary
exit-address-family
!
router bgp 64513
bgp router-id 10.0.1.1
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.4.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEB
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip http server
ip route 10.0.4.1 255.255.255.255 192.168.1.2
!
!
ip pim bidir-enable
ip pim ssm default
ip pim vrf CEB bsr-candidate Loopback2 0
ip pim vrf CEB rp-candidate Loopback2
!
ip explicit-path name Primary enable
next-address 192.168.1.18
next-address 10.0.4.1
!
ip explicit-path name Secondary enable
next-address 192.168.1.2
next-address 192.168.1.6
next-address 192.168.1.10
next-address 10.0.4.1
!
logging 171.16.200.1
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
password 7 14141B180F0B7B7977
login
!
ntp authentication-key 1 md5 00273A352774 7
ntp authenticate
ntp trusted-key 1
ntp clock-period 17179887
ntp server 10.0.1.1 key 1
!
end
PE11#
PE12#sh running-config
Building configuration...
Current configuration : 2223 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all In_EXP_3
match mpls experimental topmost 3
class-map match-all In_EXP_4
match mpls experimental topmost 4
!
!
policy-map Core_Out
class In_EXP_4
bandwidth 256
class In_EXP_3
bandwidth 128
class class-default
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
ip address 192.168.1.5 255.255.255.252
ip pim sparse-mode
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/2
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 192.168.1.1 102 broadcast
frame-relay lmi-type ansi
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 10.0.2.1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/1
no passive-interface Serial1/2
network 10.0.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.7 area 0
!
ip http server
!
!
ip pim bidir-enable
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
PE12#
PE12#
PE12#
PE13#sh running-config
Building configuration...
Current configuration : 2073 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE13
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip multicast-routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all In_EXP_3
match mpls experimental topmost 3
class-map match-all In_EXP_4
match mpls experimental topmost 4
!
!
policy-map Core_Out
class In_EXP_4
bandwidth 256
class In_EXP_3
bandwidth 128
class class-default
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.1.6 255.255.255.252
ip pim sparse-mode
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/1
ip address 192.168.1.9 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 192.168.1.10 103 broadcast
frame-relay lmi-type ansi
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 10.0.3.1
log-adjacency-changes
network 10.0.3.1 0.0.0.0 area 0
network 192.168.1.4 0.0.0.3 area 0
network 192.168.1.8 0.0.0.3 area 0
!
ip http server
!
!
ip pim bidir-enable
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
PE13#
PE14#sh running-config
Building configuration...
Current configuration : 5219 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE14
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEB
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64513:100
mdt default 239.2.2.2
!
ip multicast-routing
ip multicast-routing vrf CEB
mpls label protocol ldp
mpls ldp explicit-null
mpls traffic-eng tunnels
!
!
key chain CEA
key 1
key-string CEA
!
!
!
!
!
!
!
!
!
!
!
username CEB privilege 15 password 0 cisco123
username CEB autocommand menu CEB
!
!
class-map match-all VOIP
match ip dscp ef
class-map match-all QoS_3
match mpls experimental topmost 3
class-map match-all QoS_4
match mpls experimental topmost 4
class-map match-all DATA
match ip dscp af31
class-map match-all EXP_3
match qos-group 3
class-map match-all EXP_4
match qos-group 4
class-map match-all In_EXP_3
match mpls experimental topmost 3
class-map match-all In_EXP_4
match mpls experimental topmost 4
!
!
policy-map To_CE3A
class EXP_4
set ip dscp ef
class EXP_3
set ip dscp af31
class class-default
policy-map From_CE3A
class VOIP
set mpls experimental imposition 4
class DATA
set mpls experimental imposition 3
class class-default
policy-map Core_Out
class In_EXP_4
bandwidth 256
class In_EXP_3
bandwidth 128
class class-default
policy-map Core_In
class QoS_4
set qos-group 4
class QoS_3
set qos-group 3
class class-default
!
!
!
!
!
interface Tunnel10
ip unnumbered Loopback0
tunnel destination 10.0.2.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 1000
tunnel mpls traffic-eng path-option 1 explicit name Secondary
tunnel mpls traffic-eng path-option 2 explicit name Primary
no routing dynamic
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback1
no ip address
!
interface FastEthernet0/0
ip address 192.168.1.18 255.255.255.252
shutdown
duplex auto
speed auto
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.1.10 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 192.168.1.9 301 broadcast
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/1
no ip address
encapsulation frame-relay
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay map ip 192.168.1.26 104 broadcast
frame-relay lmi-type ansi
!
interface Serial1/2
ip vrf forwarding CEB
ip address 192.168.1.33 255.255.255.252
ip pim sparse-mode
no dce-terminal-timing-enable
service-policy input From_CE3A
service-policy output To_CE3A
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 10.0.4.1
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface Serial1/0
no passive-interface Serial1/1
network 10.0.4.1 0.0.0.0 area 0
network 192.168.1.8 0.0.0.3 area 0
network 192.168.1.16 0.0.0.3 area 0
!
router rip
version 2
!
address-family ipv4 vrf CEB
redistribute bgp 64513 metric 10
network 192.168.1.0
no auto-summary
exit-address-family
!
router bgp 64513
bgp router-id 10.0.4.1
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.2.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 multicast
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEB
redistribute connected
redistribute rip
no synchronization
exit-address-family
!
ip http server
ip route 10.0.2.1 255.255.255.255 192.168.1.9
!
!
ip pim bidir-enable
ip pim ssm default
!
ip explicit-path name Primary enable
next-address 192.168.1.17
next-address 10.0.2.1
!
ip explicit-path name Secondary enable
next-address 192.168.1.9
next-address 192.168.1.5
next-address 192.168.1.1
next-address 10.0.2.1
!
!
menu CEB title ^C
Menu for CEB Users on PEs
^C
menu CEB prompt ^CSelect: ^C
menu CEB text 1. View Routes
menu CEB command 1. show ip route vrf CEB
menu CEB command 1.show ip route vrf CEB
menu CEB text 2. Ping Test
menu CEB command 2. ping vrf CEB 192.168.1.34
menu CEB text 3. Exit
menu CEB command 3. exit
menu CEB single-space
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login local
!
!
end
PE14#
PE14#
***********************************************************************************
OUTPUT Multicast MPLS VPN
**********************************************************************************
CE3A#ping
Protocol [ip]:
Target IP address: 224.88.88.88
Repeat count [1]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: Serial1/0
Time to live [255]:
Source address: 192.168.1.34
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.88.88.88, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.34
Reply to request 0 from 192.168.1.38, 1256 ms
Reply to request 1 from 192.168.1.38, 536 ms
Reply to request 2 from 192.168.1.38, 672 ms
Reply to request 3 from 192.168.1.38, 592 ms
Reply to request 4 from 192.168.1.38, 540 ms
Reply to request 5 from 192.168.1.38, 560 ms
CE3A#sh ip mroute 224.77.77.77
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.77.77.77), 00:27:58/stopped, RP 192.168.128.1, flags: SJPCL
Incoming interface: Serial1/0, RPF nbr 192.168.1.33
Outgoing interface list: Null
(192.168.1.38, 224.77.77.77), 00:02:52/00:01:10, flags: PLTX
Incoming interface: Serial1/0, RPF nbr 192.168.1.33
Outgoing interface list: Null
CE3A#sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 192.168.128.1 (?), v2
Info source: 192.168.128.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:47:44, expires: 00:02:02
CE3A#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.33 Serial1/0 00:16:59/00:01:30 v2 1 / S
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.128.0/32 is subnetted, 1 subnets
R 192.168.128.1 [120/10] via 192.168.1.33, 00:00:21, Serial1/0
C 192.168.250.0/24 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.32 is directly connected, Serial1/0
R 192.168.1.36 [120/10] via 192.168.1.33, 00:00:21, Serial1/0
CE3A#traceroute 192.168.1.38
Type escape sequence to abort.
Tracing the route to 192.168.1.38
1 192.168.1.33 80 msec 176 msec 116 msec
2 192.168.1.9 528 msec 408 msec 692 msec
3 192.168.1.5 464 msec 308 msec 164 msec
4 192.168.1.37 308 msec 272 msec 192 msec
5 192.168.1.38 260 msec 248 msec *
CE3A#
CE4A#ping
Protocol [ip]:
Target IP address: 224.77.77.77
Repeat count [1]: 100
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: Serial1/0
Time to live [255]:
Source address: 192.168.1.38
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.77.77.77, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.38
Reply to request 0 from 192.168.1.34, 600 ms
Reply to request 1 from 192.168.1.34, 1116 ms
Reply to request 2 from 192.168.1.34, 500 ms
Reply to request 3 from 192.168.1.34, 424 ms
Reply to request 4 from 192.168.1.34, 636 ms
Reply to request 5 from 192.168.1.34, 332 ms
CE4A#sh run
CE4A#sh running-config in
CE4A#sh running-config interface s1/0
Building configuration...
Current configuration : 191 bytes
!
interface Serial1/0
ip address 192.168.1.38 255.255.255.252
ip pim sparse-mode
ip igmp join-group 224.88.88.88
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
end
CE4A#
CE4A#sh ip mrou
CE4A#sh ip mroute 224.77.77.77
Group 224.77.77.77 not found
CE4A#sh ip mroute 224.88.88.88
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.88.88.88), 00:33:59/stopped, RP 192.168.128.1, flags: SJPCL
Incoming interface: Serial1/0, RPF nbr 192.168.1.37
Outgoing interface list: Null
(192.168.1.34, 224.88.88.88), 00:00:53/00:02:50, flags: PLTX
Incoming interface: Serial1/0, RPF nbr 192.168.1.37
Outgoing interface list: Null
CE4A#sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 192.168.128.1 (?), v2
Info source: 192.168.128.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:38:49, expires: 00:01:55
CE4A#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.37 Serial1/0 00:56:15/00:01:22 v2 1 / S
CE4A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
192.168.128.0/32 is subnetted, 1 subnets
R 192.168.128.1 [120/1] via 192.168.1.37, 00:00:23, Serial1/0
C 192.168.254.0/24 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
R 192.168.1.32 [120/10] via 192.168.1.37, 00:00:23, Serial1/0
C 192.168.1.36 is directly connected, Serial1/0
CE4A#traceroute 192.168.1.34
Type escape sequence to abort.
Tracing the route to 192.168.1.34
1 192.168.1.37 76 msec 40 msec 124 msec
2 192.168.1.33 452 msec 432 msec 792 msec
3 192.168.1.34 464 msec 484 msec 296 msec
CE4A#
PE11#sh ip mroute vrf CEB 224.88.88.88
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.88.88.88), 00:36:23/00:03:27, RP 192.168.128.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/1, Forward/Sparse, 00:36:23/00:03:27
(192.168.1.34, 224.88.88.88), 00:03:27/00:01:05, flags: T
Incoming interface: Tunnel1, RPF nbr 10.0.4.1
Outgoing interface list:
Serial1/1, Forward/Sparse, 00:03:27/00:03:27
PE11#sh ip mroute vrf CEB 224.77.77.77
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.77.77.77), 00:33:23/stopped, RP 192.168.128.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel1, Forward/Sparse, 00:33:23/00:02:54
(192.168.1.38, 224.77.77.77), 00:00:28/00:02:50, flags: T
Incoming interface: Serial1/1, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel1, Forward/Sparse, 00:00:28/00:02:32
PE11#
PE14#sh ip mroute vrf CEB 224.88.88.88
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connect
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 224.88.88.88), 00:07:22/stopped, RP 192.168.128.1, flags: SPF
Incoming interface: Tunnel1, RPF nbr 10.0.2.1
Outgoing interface list: Null
(192.168.1.34, 224.88.88.88), 00:00:08/00:02:51, flags: FT
Incoming interface: Serial1/2, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Tunnel1, Forward/Sparse, 00:00:07/00:03:22
PE14#
***********************************************************************************
OUTPUT VPN-QOS
************************************************************************************
CE3A#ping
Protocol [ip]:
Target IP address: 192.168.1.38
Repeat count [5]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 0x68
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 192.168.1.38, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (995/1000), round-trip min/avg/max = 92/549/1496 ms
CE3A#
PE14#show policy-map interface s1/2 input
Serial1/2
Service-policy input: From_CE3A
Class-map: VOIP (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
mpls experimental imposition 4
Packets marked 0
Class-map: DATA (match-all)
56 packets, 5824 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
mpls experimental imposition 3
Packets marked 57
Class-map: class-default (match-any)
7 packets, 400 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#show policy-map interface s1/0 output
Serial1/0
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
154 packets, 17248 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2/224
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
106 packets, 7476 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#
PE14#show policy-map interface s1/0 output
Serial1/0
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
166 packets, 18592 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 3/336
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
115 packets, 8149 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#
PE13#show policy-map interface s1/0 output
Serial1/0
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
311 packets, 34832 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 1/112
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
221 packets, 16668 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE13#
PE13#show policy-map interface s1/0 output
Serial1/0
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
317 packets, 35504 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 1/112
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
225 packets, 17074 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE13#
PE13#
PE12#show policy-map interface s1/2 output
Serial1/2
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
382 packets, 42784 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 3/336
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
270 packets, 18443 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE12#
PE12#show policy-map interface s1/2 output
Serial1/2
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
388 packets, 43456 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 4/448
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
275 packets, 18747 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE12#
PE12#
PE12#
PE11#show policy-map interface s1/2 input
Serial1/2
Service-policy input: Core_In
Class-map: QoS_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0
Class-map: QoS_3 (match-all)
40 packets, 4480 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 40
Class-map: class-default (match-any)
118 packets, 8869 bytes
PE11#show policy-map interface s1/2 input
Serial1/2
Service-policy input: Core_In
Class-map: QoS_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0
Class-map: QoS_3 (match-all)
44 packets, 4928 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 44
Class-map: class-default (match-any)
118 packets, 8869 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#
PE11#show policy-map interface s1/1 output
Serial1/1
Service-policy output: To_CE4A
Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 4
QoS Set
dscp ef
Packets marked 0
Class-map: EXP_3 (match-all)
880 packets, 91520 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
dscp af31
Packets marked 880
Class-map: class-default (match-any)
1315 packets, 124473 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#
PE11#
CE4A#show policy-map interface s1/0 input
Serial1/0
Service-policy input: From_PE11
Class-map: VOIP (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp cs3
Packets marked 0
Class-map: DATA (match-all)
613 packets, 63752 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 613
Class-map: class-default (match-any)
43 packets, 2806 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE4A#
CE4A#
CE4A#
CE4A#show policy-map interface s1/0 input
Serial1/0
Service-policy input: From_PE11
Class-map: VOIP (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp cs3
Packets marked 0
Class-map: DATA (match-all)
619 packets, 64376 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 619
Class-map: class-default (match-any)
43 packets, 2806 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE4A#
CE4A#
*******************************************************************
CE4A#ping
Protocol [ip]:
Target IP address: 192.168.1.34
Repeat count [5]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 0xB8
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 192.168.1.34, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!..!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!..!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 99 percent (898/905), round-trip min/avg/max = 76/626/1764 ms
CE4A#
PE11#show policy-map interface s1/1 input
Serial1/1
Service-policy input: From_CE4A
Class-map: VOIP (match-all)
97 packets, 10088 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
mpls experimental imposition 4
Packets marked 97
Class-map: DATA (match-all)
1100 packets, 114400 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
mpls experimental imposition 3
Packets marked 1100
Class-map: class-default (match-any)
93 packets, 5316 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#show policy-map interface s1/1 input
Serial1/1
Service-policy input: From_CE4A
Class-map: VOIP (match-all)
103 packets, 10712 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
mpls experimental imposition 4
Packets marked 103
Class-map: DATA (match-all)
1100 packets, 114400 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
mpls experimental imposition 3
Packets marked 1100
Class-map: class-default (match-any)
94 packets, 5374 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#
PE11#
PE11#
PE11#show policy-map interface s1/2 output
Serial1/2
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
238 packets, 26656 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2/224
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
100 packets, 11200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2/224
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
303 packets, 20797 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#show policy-map interface s1/2 output
Serial1/2
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
245 packets, 27440 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2/224
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
100 packets, 11200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 2/224
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
306 packets, 20961 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE11#
PE11#
PE12#show policy-map int s1/1 output
Serial1/1
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
308 packets, 34496 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 5/560
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
1100 packets, 123200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 10/1120
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
1009 packets, 75947 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE12#show policy-map int s1/1 output
Serial1/1
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
315 packets, 35280 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 5/560
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
1100 packets, 123200 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 10/1120
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
1012 packets, 76081 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE12#
PE12#
PE13#show policy-map int s1/1 output
Serial1/1
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
392 packets, 43904 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 4/448
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
1095 packets, 118880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 14/1524
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
1048 packets, 71318 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE13#show policy-map int s1/1 output
Serial1/1
Service-policy output: Core_Out
Class-map: In_EXP_4 (match-all)
400 packets, 44800 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
Queueing
Output Queue: Conversation 265
Bandwidth 256 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 4/448
(depth/total drops/no-buffer drops) 0/0/0
Class-map: In_EXP_3 (match-all)
1095 packets, 118880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
Queueing
Output Queue: Conversation 266
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 14/1524
(depth/total drops/no-buffer drops) 0/0/0
Class-map: class-default (match-any)
1055 packets, 71686 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE13#
PE13#
PE14#show policy-map int s1/0 input
Serial1/0
Service-policy input: Core_In
Class-map: QoS_4 (match-all)
466 packets, 52192 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 466
Class-map: QoS_3 (match-all)
1095 packets, 118880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 1095
Class-map: class-default (match-any)
904 packets, 68736 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#
PE14#
PE14#show policy-map int s1/0 input
Serial1/0
Service-policy input: Core_In
Class-map: QoS_4 (match-all)
472 packets, 52864 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 472
Class-map: QoS_3 (match-all)
1095 packets, 118880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 1095
Class-map: class-default (match-any)
905 packets, 68802 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#
PE14#show policy-map int s1/2 output
Serial1/2
Service-policy output: To_CE3A
Class-map: EXP_4 (match-all)
530 packets, 55120 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: qos-group 4
QoS Set
dscp ef
Packets marked 530
Class-map: EXP_3 (match-all)
1095 packets, 113880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
dscp af31
Packets marked 1095
Class-map: class-default (match-any)
278 packets, 18062 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#show policy-map int s1/2 output
Serial1/2
Service-policy output: To_CE3A
Class-map: EXP_4 (match-all)
536 packets, 55744 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: qos-group 4
QoS Set
dscp ef
Packets marked 536
Class-map: EXP_3 (match-all)
1095 packets, 113880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
dscp af31
Packets marked 1095
Class-map: class-default (match-any)
279 packets, 18086 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE14#
PE14#
CE3A#show policy-map interface s1/0 input
Serial1/0
Service-policy input: From_PE14
Class-map: VOIP (match-all)
565 packets, 58760 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp cs3
Packets marked 565
Class-map: DATA (match-all)
1095 packets, 113880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 1095
Class-map: class-default (match-any)
133 packets, 8676 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE3A#
CE3A#
CE3A#show policy-map interface s1/0 input
Serial1/0
Service-policy input: From_PE14
Class-map: VOIP (match-all)
570 packets, 59280 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp cs3
Packets marked 570
Class-map: DATA (match-all)
1095 packets, 113880 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 1095
Class-map: class-default (match-any)
134 packets, 8738 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE3A#
CE3A#
PE14#

No comments:

Post a Comment