Wednesday, June 30, 2010

Implementing NGN Broadband Networks for HSI/IPTV using PPPoE & IPoE LAB
















Configuration Guidelines
***********************************************************
Scenario: An ISP wants to transtion to Next Generation Networks
Architecture therrvy to offer High Speed Internet Access
and IPTV Services by leveraging its existing MPLS Core Network
and not running native Multicast in its Core.

Design Consideration and Solution:

ISP has to use MPLS across its Aggregation Layer and use
MPLS L2 Transport in the aggregation Layer to connection
the Access Nodes to the Broadband Network Gateway over
PPPoE/IPoE.

ISP can use mLDP across its MPLS Core to deliver the IPTV
Services using NGN MPVPN over mLDP. Internet Access
can be provided in another MPLS L3 VPN Context
therby providing separation the the Data Plane for both
Services.

HSI can be delivered over regular PPPoE and IPTV can be
delivered over IPoE utilising DHCP.

ISP AS used 64513
IGP used OSPF Area0 both in MPLS Core and MPLS Aggregation
VRF used in Core N/W
Internet
rd 64513:1
rt 64513:100
IPTV
rd 64513:2
rt 64513:200
vpn id 200:1
root-address 10.0.2.1

PPPoe Pool used 10.0.201.0/24
DHCP Pool used 10.0.100.0/24

MPLS Psuedowire used in Aggregation N/W
VCID 10 for Internet
VCID 20 for IPTV

PIM SSM used for IPTV

CE LAN

IGP used OSPF for Internet
IGP used EIGRP for IPTV

NAT Overload done at LAN_GW with Dialer Interface for HSI

NAT Overload done at LAN_GW with Fa0/0 Interface for IPTV

IGMP Group used 232.4.4.4 for IPTV
Source 192.168.101.0/24 & 192.168.201.0/24

Internet Dummy Networks used 172.16.101.0/24
& 172.16.201.0/24
**********************************************************

CE_LAN#sh running-config
Building configuration...

Current configuration : 1316 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE_LAN
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.151.1 255.255.255.0
!
interface Loopback1
ip address 192.168.251.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 232.4.4.4 source 192.168.101.1
ip igmp join-group 232.4.4.4 source 192.168.201.1
!
interface FastEthernet0/0
description Internet
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description IPTV
ip address 192.168.2.1 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
router eigrp 10
network 192.168.2.0 0.0.0.3
network 192.168.251.0
auto-summary
eigrp router-id 192.168.251.1
!
router ospf 10
router-id 192.168.151.1
log-adjacency-changes
network 192.168.1.0 0.0.0.3 area 0
network 192.168.151.0 0.0.0.255 area 0
!
ip http server
ip classless
!
!
ip pim ssm default
ip mroute 0.0.0.0 0.0.0.0 192.168.2.2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE_LAN#

LAN_GW#sh running-config
Building configuration...

Current configuration : 2485 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LAN_GW
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description IPTV
ip address dhcp
ip pim sparse-mode
ip nat outside
ip virtual-reassembly
ip igmp join-group 232.2.2.2 source 192.168.101.1
ip igmp join-group 232.2.2.2 source 192.168.201.1
duplex auto
speed auto
!
interface FastEthernet0/1
description Internet
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1452
speed 100
full-duplex
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet1/0
description LAN_Internet
ip address 192.168.1.2 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet2/0
description LAN_IPTV
ip address 192.168.2.2 255.255.255.252
ip pim sparse-mode
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip igmp join-group 239.1.1.1
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname cisco
ppp chap password 0 sisco
ppp pap sent-username cisco password 0 sisco
!
router eigrp 10
redistribute static route-map IPTV
network 192.168.2.0 0.0.0.3
network 192.168.251.0
auto-summary
eigrp router-id 192.168.2.2
!
router ospf 10
router-id 192.168.1.2
log-adjacency-changes
network 192.168.1.0 0.0.0.3 area 0
network 192.168.151.0 0.0.0.255 area 0
default-information originate always
!
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.0.0 255.255.0.0 10.0.100.1
!
!
ip pim ssm default
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 2 interface FastEthernet0/0 overload
!
!
ip prefix-list IPTV seq 5 permit 192.168.0.0/16
access-list 1 permit 192.168.1.0 0.0.0.3
access-list 1 permit 192.168.151.0 0.0.0.255
access-list 2 permit 192.168.2.0 0.0.0.3
access-list 2 permit 192.168.251.0 0.0.0.255
!
route-map IPTV permit 10
match ip address prefix-list IPTV
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

LAN_GW#

edge2.pop2#sh running-config
Building configuration...

Current configuration : 2351 bytes
!
! Last configuration change at 14:24:51 UTC Wed Jun 30 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge2.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel backup srlg exclude force
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all DSLBB
match any
!
policy-map Core_Out
class EXP_5
policy-map DSLBB
class DSLBB
set mpls experimental imposition 5
!
pseudowire-class Internet
encapsulation mpls
!
pseudowire-class IPTV
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description BNG-IPTV
no ip address
negotiation auto
no keepalive
xconnect 10.0.5.1 20 pw-class IPTV
service-policy input DSLBB
!
interface GigabitEthernet2/0
description edge1.pop2-L1
ip address 10.0.40.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng srlg 1
service-policy output Core_Out
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description edge1.pop2-L2
ip address 10.0.50.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng srlg 1
service-policy output Core_Out
ip rsvp bandwidth
!
interface GigabitEthernet4/0
description BNG-Internet
no ip address
negotiation auto
no keepalive
xconnect 10.0.5.1 10 pw-class Internet
service-policy input DSLBB
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge2.pop2#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2406 bytes
!
! Last configuration change at 14:24:44 UTC Wed Jun 30 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel backup srlg exclude force
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all DSLBB
match any
!
policy-map Core_Out
class EXP_5
policy-map DSLBB
class DSLBB
set mpls experimental imposition 5
!
pseudowire-class Internet
encapsulation mpls
!
pseudowire-class IPTV
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.5.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge2.pop2-L1
ip address 10.0.40.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng srlg 1
service-policy output Core_Out
ip rsvp bandwidth
!
interface FastEthernet2/0
description cus1.pop2-IPTV
no ip address
speed auto
duplex auto
no keepalive
xconnect 10.0.4.1 20 pw-class IPTV
service-policy input DSLBB
!
interface FastEthernet2/1
description cus1.pop2-Internet
no ip address
speed auto
duplex auto
no keepalive
xconnect 10.0.4.1 10 pw-class Internet
service-policy input DSLBB
!
interface GigabitEthernet3/0
description edge2.pop2-L2
ip address 10.0.50.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng srlg 1
service-policy output Core_Out
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.5.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

BNG.pop2#sh running-config
Building configuration...

Current configuration : 3306 bytes
!
! Last configuration change at 15:09:33 UTC Wed Jun 30 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BNG.pop2
!
boot-start-marker
boot-end-marker
!
security passwords min-length 1
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:200
route-target import 64513:200
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
ip dhcp excluded-address 10.0.100.250 10.0.100.254
!
ip dhcp pool IPTV
network 10.0.100.0 255.255.255.0
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
username cisco password 0 sisco
!
!
!
!
!
!
!
bba-group pppoe global
virtual-template 1
!
bba-group pppoe dsl-pppoe
virtual-template 1
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop2
ip address 10.0.30.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description IPTV
ip vrf forwarding IPTV
ip address 10.0.100.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.1.1.1 source 192.168.101.1
ip igmp join-group 232.1.1.1 source 192.168.201.1
negotiation auto
!
interface GigabitEthernet3/0
description Internet
no ip address
negotiation auto
pppoe enable group global
!
interface Virtual-Template1
mtu 1492
ip vrf forwarding Internet
ip address 10.0.101.1 255.255.255.0
ip pim sparse-mode
peer default ip address pool pppoepool
ppp authentication pap chap
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description iBGP
neighbor 10.0.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
redistribute connected
redistribute static
exit-address-family
!
ip local pool pppoepool 10.0.201.1 10.0.201.254
no ip http server
no ip http secure-server
!
!
ip pim vrf IPTV ssm default
ip route vrf Internet 10.0.0.0 255.0.0.0 Null0
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

BNG.pop2#

core1.pop2#sh running-config
Building configuration...

Current configuration : 1793 bytes
!
! Last configuration change at 13:07:24 UTC Wed Jun 30 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop1-L2
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description BNG.pop2
ip address 10.0.30.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop2#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 3371 bytes
!
! Last configuration change at 14:24:20 UTC Wed Jun 30 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:2
vpn id 200:1
route-target export 64513:200
route-target import 64513:200
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
ip vrf Internet
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop2
ip address 10.0.10.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description core1.pop2-L2
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
no ip address
speed auto
duplex auto
!
interface FastEthernet3/0.1
description Internet
encapsulation dot1Q 10
ip vrf forwarding Internet
ip address 172.16.1.1 255.255.255.252
!
interface FastEthernet3/0.2
description IPTV
encapsulation dot1Q 20
ip vrf forwarding IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description iBGP
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
neighbor 192.168.1.2 remote-as 64514
neighbor 192.168.1.2 description IPTV
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
network 0.0.0.0
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description Internet
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm default
ip pim vrf IPTV ssm default
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop1#

Internet-IPTV#sh running-config
Building configuration...

Current configuration : 2059 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet-IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.255
!
interface Loopback1
ip address 172.16.201.1 255.255.255.0
!
interface Loopback2
ip address 192.168.101.1 255.255.255.0
ip pim sparse-mode
!
interface Loopback3
ip address 192.168.201.1 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description ISP-Internet
encapsulation dot1Q 10
ip address 172.16.1.2 255.255.255.252
no snmp trap link-status
!
interface FastEthernet0/0.2
description ISP-IPTV
encapsulation dot1Q 20
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.0.0
network 192.168.0.0 mask 255.255.0.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description ISP-Internet
neighbor 172.16.1.1 soft-reconfiguration inbound
neighbor 172.16.1.1 route-map Internet out
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 route-map IPTV out
no auto-summary
!
ip http server
ip classless
ip route 172.16.0.0 255.255.0.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim ssm default
!
!
ip prefix-list IPTV seq 5 permit 192.168.0.0/16
!
ip prefix-list Internet seq 5 permit 172.16.0.0/16
!
route-map IPTV permit 10
match ip address prefix-list IPTV
!
route-map Internet permit 10
match ip address prefix-list Internet
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Internet-IPTV#


**********************************
OUTPUT
***********************************
UNICAST TRAFFIC
************************************

CE_LAN#traceroute 172.16.101.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 192.168.1.2 192 msec 280 msec 208 msec
2 10.0.101.1 620 msec 1504 msec 856 msec
3 10.0.30.2 1272 msec 1728 msec 1644 msec
4 172.16.1.1 1876 msec 1308 msec 1792 msec
5 172.16.1.2 1440 msec 2708 msec *
CE_LAN#traceroute 192.168.201.1 source lo1

Type escape sequence to abort.
Tracing the route to 192.168.201.1

1 192.168.2.2 176 msec 8 msec 392 msec
2 10.0.100.1 920 msec 648 msec 1548 msec
3 10.0.30.2 1576 msec 268 msec *
4 192.168.1.1 1452 msec * *
5 192.168.1.2 1960 msec 1200 msec 1008 msec
CE_LAN#

Internet-IPTV#traceroute 10.0.100.2 source lo2

Type escape sequence to abort.
Tracing the route to 10.0.100.2

1 192.168.1.1 472 msec 168 msec 156 msec
2 10.0.20.2 [AS 64513] 320 msec 288 msec 384 msec
3 10.0.100.1 [AS 64513] 1128 msec 480 msec 384 msec
4 10.0.100.2 [AS 64513] 672 msec 600 msec 864 msec
Internet-IPTV#traceroute 10.0.201.1 source lo0

Type escape sequence to abort.
Tracing the route to 10.0.201.1

1 172.16.1.1 244 msec 264 msec 192 msec
2 10.0.20.2 [AS 64513] 1224 msec * 1940 msec
3 10.0.101.1 [AS 64513] 408 msec 264 msec 288 msec
4 10.0.201.1 [AS 64513] 552 msec 1344 msec 668 msec
Internet-IPTV#

************************
Multicast TRAFFIC
*****************************
Internet-IPTV#ping 232.4.4.4 source lo3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.201.1

Reply to request 0 from 10.0.100.2, 1580 ms
Reply to request 0 from 10.0.100.2, 1580 ms
Internet-IPTV#ping 232.4.4.4 source lo2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 10.0.100.2, 812 ms
Reply to request 0 from 10.0.100.2, 908 ms
Internet-IPTV#

Internet-IPTV#show ip mroute 232.4.4.4
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.4.4.4), 00:15:03/00:02:56, flags: sT
Incoming interface: Loopback2, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0.2, Forward/Sparse, 00:15:03/00:02:56

(192.168.201.1, 232.4.4.4), 00:14:38/00:02:34, flags: sT
Incoming interface: Loopback3, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0.2, Forward/Sparse, 00:14:25/00:02:34

Internet-IPTV#

edge1.pop1#sh ip mroute vrf IPTV 232.4.4.4
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.201.1, 232.4.4.4), 00:12:59/00:03:23, flags: sT
Incoming interface: FastEthernet3/0.2, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse, 00:12:59/00:03:23

(192.168.101.1, 232.4.4.4), 00:13:38/00:02:44, flags: sT
Incoming interface: FastEthernet3/0.2, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse, 00:13:38/00:02:44

edge1.pop1#

BNG.pop2#sh ip mroute vrf IPTV 232.4.4.4
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.201.1, 232.4.4.4), 00:15:09/00:03:18, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1
Outgoing interface list:
GigabitEthernet2/0, Forward/Sparse, 00:15:09/00:03:18

(192.168.101.1, 232.4.4.4), 00:15:47/00:02:40, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1
Outgoing interface list:
GigabitEthernet2/0, Forward/Sparse, 00:15:47/00:02:40

BNG.pop2#

LAN_GW#sh ip mroute 232.4.4.4
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.4.4.4), 00:15:55/00:03:13, flags: sT
Incoming interface: FastEthernet0/0, RPF nbr 10.0.100.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:15:55/00:03:13

(192.168.201.1, 232.4.4.4), 00:15:17/00:02:50, flags: sT
Incoming interface: FastEthernet0/0, RPF nbr 10.0.100.1
Outgoing interface list:
FastEthernet2/0, Forward/Sparse, 00:15:17/00:02:50

LAN_GW#

CE_LAN#sh ip mroute 232.4.4.4
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.4.4.4), 00:16:25/stopped, flags: sLTI
Incoming interface: FastEthernet0/1, RPF nbr 192.168.2.2, Mroute
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:16:25/00:01:40

(192.168.201.1, 232.4.4.4), 00:15:46/stopped, flags: sLTI
Incoming interface: FastEthernet0/1, RPF nbr 192.168.2.2, Mroute
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:15:46/00:02:18

CE_LAN#


**********************
PPPoE/IPoE
**********************

BNG.pop2#show subscriber session username cisco
Unique Session ID: 2
Identifier: cisco
SIP subscriber access type(s): PPPoE/PPP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:42:51, Last Changed: 00:42:52
Interface: Virtual-Access2.1

Policy information:
Authentication status: authen

Configuration sources associated with this session:
Interface: Virtual-Template1, Active Time = 00:42:51

BNG.pop2#

BNG.pop2#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.0.100.2 0063.6973.636f.2d63. Jul 01 2010 02:23 PM Automatic
6330.382e.3063.6434.
2e30.3030.302d.4661.
302f.30
BNG.pop2#



LAN_GW#sh ip int brief
Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0/0 10.0.100.2 YES DHCP up up

FastEthernet0/1 unassigned YES manual up up

FastEthernet0/1.20 unassigned YES DHCP deleted down

FastEthernet1/0 192.168.1.2 YES manual up up

FastEthernet2/0 192.168.2.2 YES manual up up

NVI0 unassigned YES unset up up

Virtual-Access1 unassigned YES unset up up

Virtual-Access2 unassigned YES unset up up

Dialer1 10.0.201.1 YES IPCP up up

LAN_GW#

LAN_GW#show pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st
N/A 2 ca05.0cd4.0054 Fa0/1 Di1 Vi2 N/A
cc08.0cd4.0001 UP
LAN_GW#

BNG.pop2#show pppoe session
1 session in LOCALLY_TERMINATED (PTA) State
1 session total

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
2 2 cc08.0cd4.0001 Gi3/0 1 Vi2.1 PTA
ca05.0cd4.0054 UP
BNG.pop2#show ip local pool pppoepool | beg Inuse
Inuse addresses:
10.0.201.1 Vi2.1 cisco
BNG.pop2#

**************************
VRF ROUTING TABLE
***************************

BNG.pop2#sh ip route vrf Internet

Routing Table: Internet
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
S 10.0.0.0/8 is directly connected, Null0
C 10.0.101.0/24 is directly connected, Virtual-Access2.1
L 10.0.101.1/32 is directly connected, Virtual-Access2.1
C 10.0.201.1/32 is directly connected, Virtual-Access2.1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
B 172.16.0.0/16 [200/0] via 10.0.1.1, 00:27:48
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:27:48

BNG.pop2#sh ip route vrf IPTV

Routing Table: IPTV
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.100.0/24 is directly connected, GigabitEthernet2/0
L 10.0.100.1/32 is directly connected, GigabitEthernet2/0
B 192.168.0.0/16 [200/0] via 10.0.1.1, 00:27:51
192.168.1.0/30 is subnetted, 1 subnets
B 192.168.1.0 [200/0] via 10.0.1.1, 00:27:51
BNG.pop2#

BNG.pop2#sh ip vrf Internet
Name Default RD Interfaces
Internet 64513:1 Vt1
Vi2.1
BNG.pop2#sh ip vrf IPTV
Name Default RD Interfaces
IPTV 64513:2 Ls0
Gi2/0
BNG.pop2#


*******************
CE LAN ROUTING
********************
CE_LAN#sh ip protocols summary
Index Process Name
0 connected
1 static
2 ospf 10
3 eigrp 10
CE_LAN#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
192.168.1.2 1 FULL/BDR 00:00:31 192.168.1.2 FastEthernet0/
0
CE_LAN#sh ip eig nei
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.2.2 Fa0/1 11 00:37:16 188 1128 0 6
CE_LAN#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

C 192.168.151.0/24 is directly connected, Loopback0
C 192.168.251.0/24 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/30 is directly connected, FastEthernet0/1
D 192.168.2.0/24 is a summary, 00:40:55, Null0
O*E2 0.0.0.0/0 [110/1] via 192.168.1.2, 00:31:48, FastEthernet0/0
D EX 192.168.0.0/16 [170/30720] via 192.168.2.2, 00:14:13, FastEthernet0/1
CE_LAN#

******************************************
AGGREGATION NETWORK MPLS AToM Psuedowire
Transport
******************************************
edge2.pop2#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Gi4/0 Ethernet 10.0.5.1 10 UP
Gi1/0 Ethernet 10.0.5.1 20 UP
edge2.pop2#

edge1.pop2#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/1 Ethernet 10.0.4.1 10 UP
Fa2/0 Ethernet 10.0.4.1 20 UP
edge1.pop2#

*******************
NGN MVPN
*******************

edge1.pop1#show ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet3/0.2 01:25:33/00:01:16 v2 1 / DR S G
10.0.3.1 Lspvif0 01:19:19/00:01:16 v2 1 / DR S P G

edge1.pop1#show mpls mldp nei

MLDP peer ID : 10.0.2.1:0, uptime 01:38:58 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 1
Branch count : 0
Path count : 4
Path(s) : 10.0.2.1 No LDP Tunnel65337
: 10.0.2.1 No LDP Tunnel65336
: 10.0.10.2 LDP GigabitEthernet1/0
: 10.0.20.2 LDP GigabitEthernet2/0
Nhop count : 3
Nhop list : 10.0.2.1 10.0.10.2 10.0.20.2
edge1.pop1#show mpls mldp bind
System ID: DF000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 23, local binding[D]: 23 active

edge1.pop1#

BNG.pop2#show ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.1.1 Lspvif0 00:30:29/00:01:40 v2 1 / S P G
10.0.100.2 GigabitEthernet2/0 00:39:32/00:01:15 v2 1 / DR S G
BNG.pop2#show mpls mldp nei

MLDP peer ID : 10.0.2.1:0, uptime 00:30:58 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 1
Branch count : 0
Path count : 2
Path(s) : 10.0.2.1 No LDP Tunnel65336
: 10.0.30.2 LDP GigabitEthernet1/0
Nhop count : 2
Nhop list : 10.0.2.1 10.0.30.2
BNG.pop2#show mpls mldp bind
System ID: 1B000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 16, local binding[D]: 16 active

BNG.pop2#

core1.pop2#show mpls mldp neighbors

MLDP peer ID : 10.0.1.1:0, uptime 01:42:08 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 1
Path count : 4
Path(s) : 10.0.1.1 No LDP Tunnel65337
: 10.0.1.1 No LDP Tunnel65336
: 10.0.10.1 LDP GigabitEthernet1/0
: 10.0.20.1 LDP GigabitEthernet2/0
Nhop count : 0

MLDP peer ID : 10.0.3.1:0, uptime 00:31:16 Up,
Target Adj : Yes
Session hndl : 3
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.3.1 No LDP Tunnel65338
: 10.0.30.1 LDP GigabitEthernet3/0
Nhop count : 0
core1.pop2#show mpls mldp bin
System ID: A000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 200:1 0]
lsr: 10.0.1.1:0, local binding[U]: 23, remote binding[D]: 23
lsr: 10.0.3.1:0, local binding[U]: 16, remote binding[D]: 16

core1.pop2#

*****************************
CORE NETWORK TE Auto-Tunnel
*****************************


edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 640 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 1 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 1050 seconds
Periodic auto-bw collection: every 300 seconds, next in 40 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop1_t65337 10.0.2.1 - Gi2/0 up/up
edge1.pop1_t65436 10.0.2.1 - Gi2/0 up/up
edge1.pop1_t65437 10.0.2.1 - Gi1/0 up/up
core1.pop2_t65336 10.0.1.1 Gi1/0 - up/up

core1.pop2_t65337 10.0.1.1 Gi2/0 - up/up

core1.pop2_t65436 10.0.1.1 Gi2/0 - up/up

core1.pop2_t65437 10.0.1.1 Gi1/0 - up/up

Displayed 4 (of 4) heads, 0 (of 0) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#
edge1.pop1#
edge1.pop1#

core1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (3 ), id-range:65436-65535
onehop Enabled (3 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 680 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 1020 seconds
Periodic auto-bw collection: every 300 seconds, next in 80 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop2_t65336 10.0.1.1 - Gi1/0 up/up
core1.pop2_t65337 10.0.1.1 - Gi2/0 up/up
core1.pop2_t65338 10.0.3.1 - Gi3/0 up/up
core1.pop2_t65436 10.0.1.1 - Gi2/0 up/up
core1.pop2_t65437 10.0.1.1 - Gi1/0 up/up
core1.pop2_t65438 10.0.3.1 - unknown up/down
edge1.pop1_t65336 10.0.2.1 Gi1/0 - up/up

edge1.pop1_t65337 10.0.2.1 Gi2/0 - up/up

edge1.pop1_t65436 10.0.2.1 Gi2/0 - up/up

edge1.pop1_t65437 10.0.2.1 Gi1/0 - up/up

BNG.pop2_t65336 10.0.2.1 Gi3/0 - up/up

Displayed 6 (of 6) heads, 0 (of 0) midpoints, 5 (of 5) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop2#

BNG.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (1 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1714 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 4 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 1487 seconds
Periodic auto-bw collection: every 300 seconds, next in 214 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
BNG.pop2_t65336 10.0.2.1 - Gi1/0 up/up
BNG.pop2_t65436 10.0.2.1 - unknown up/down
core1.pop2_t65338 10.0.3.1 Gi1/0 - up/up

Displayed 2 (of 2) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
BNG.pop2#

edge2.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 298 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 1 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 544 seconds
Periodic auto-bw collection: every 300 seconds, next in 298 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge2.pop2_t65336 10.0.5.1 - Gi2/0 up/up
edge2.pop2_t65337 10.0.5.1 - Gi3/0 up/up
edge2.pop2_t65436 10.0.5.1 - unknown up/down
edge2.pop2_t65437 10.0.5.1 - unknown up/down
edge1.pop2_t65336 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65337 10.0.4.1 Gi3/0 - up/up

Displayed 4 (of 4) heads, 0 (of 0) midpoints, 2 (of 2) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge2.pop2#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3537 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 5 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 501 seconds
Periodic auto-bw collection: every 300 seconds, next in 237 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.4.1 - Gi1/0 up/up
edge1.pop2_t65337 10.0.4.1 - Gi3/0 up/up
edge1.pop2_t65436 10.0.4.1 - unknown up/down
edge1.pop2_t65437 10.0.4.1 - unknown up/down
edge2.pop2_t65336 10.0.5.1 Gi1/0 - up/up

edge2.pop2_t65337 10.0.5.1 Gi3/0 - up/up

Displayed 4 (of 4) heads, 0 (of 0) midpoints, 2 (of 2) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop2#

No comments:

Post a Comment