Wednesday, December 21, 2011

Implementing MPLS L3 VPN in Juniper Backbone LAB




Configuration Guidelines::
***********************************************************
Scenario: An ISP wants to offer MPLS L3 VPN Services to its
Customers across its Juniper Backbone.


Design Consideration and Solution:

For Scalabile MPLS L3 VPN Solution ISP utilises the concept of
separate RR for vpnv4 traffic.

The RRs are placed in 1:1 redundancy in different clusters and
do not run mp-ibgp session with them.


ISP IGP used OSPF Area 0
PE-CE ROuting Protocol used EBGP
ISP AS used 64513
VRF used is CUS with different RD/pop at each PE
junos.edge1.pop1- 64513:1
junos.edge2.pop1- 64513:1
junos.edge1.pop2- 64513:2
junos.edge2.pop2- 64513:2
Customer AS used 64514

AS-Override used on PE-CE eBGP to prevent routing updates to be dropped
becuase of BGP inherit AS-Path Loop Prevention.
********************************************************************

root@junos.edge1.pop1# run show configuration | display set
set version 10.1R1.8
set system host-name junos.edge1.pop1
set system root-authentication encrypted-password "$1$8c.PLWdc$BpqhWoyZPjq/uir/e
jjdS1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.0.10.9/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 172.16.1.5/30
set interfaces em2 unit 0 family inet address 10.0.10.13/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.17/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.1/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.5/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.1.1/32
set routing-options router-id 10.0.1.1
set routing-options autonomous-system 64513
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em0.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.1.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.3.1
set protocols bgp group mp-ibgp neighbor 10.0.6.1
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ldp interface em0.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0
set policy-options policy-statement EXPORT term 10 from protocol direct
set policy-options policy-statement EXPORT term 10 then accept
set policy-options policy-statement EXPORT term 20 from protocol bgp
set policy-options policy-statement EXPORT term 20 then accept
set routing-instances CUS instance-type vrf
set routing-instances CUS interface em1.0
set routing-instances CUS route-distinguisher 64513:1
set routing-instances CUS vrf-target target:64513:100
set routing-instances CUS vrf-table-label
set routing-instances CUS protocols bgp export EXPORT
set routing-instances CUS protocols bgp group eBGP type external
set routing-instances CUS protocols bgp group eBGP peer-as 64514
set routing-instances CUS protocols bgp group eBGP as-override
set routing-instances CUS protocols bgp group eBGP neighbor 172.16.1.6

[edit]
root@junos.edge1.pop1#

root@junos.edge1.pop2# run show configuration | display set
set version 10.1R1.8
set system host-name junos.edge1.pop2
set system root-authentication encrypted-password "$1$gDG8j.uO$1VXcyYKU3JvfvMZ6F
5AUJ."
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.0.10.25/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 172.16.1.1/30
set interfaces em2 unit 0 family inet address 10.0.10.21/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.18/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.33/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.29/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.2.1/32
set routing-options router-id 10.0.2.1
set routing-options autonomous-system 64513
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.2.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.3.1
set protocols bgp group mp-ibgp neighbor 10.0.6.1
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ldp interface em0.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0
set policy-options policy-statement EXPORT term 10 from protocol direct
set policy-options policy-statement EXPORT term 10 then accept
set policy-options policy-statement EXPORT term 20 from protocol bgp
set policy-options policy-statement EXPORT term 20 then accept
set routing-instances CUS instance-type vrf
set routing-instances CUS interface em1.0
set routing-instances CUS route-distinguisher 64513:2
set routing-instances CUS vrf-target target:64513:100
set routing-instances CUS vrf-table-label
set routing-instances CUS protocols bgp export EXPORT
set routing-instances CUS protocols bgp group eBGP type external
set routing-instances CUS protocols bgp group eBGP peer-as 64514
set routing-instances CUS protocols bgp group eBGP as-override
set routing-instances CUS protocols bgp group eBGP neighbor 172.16.1.2
[edit]
root@junos.edge1.pop2#



root@junos.edge2.pop1# run show configuration | display set
set version 10.1R1.8
set system host-name junos.edge2.pop1
set system root-authentication encrypted-password "$1$MNIMnabM$NMZqZeNJrhRM9qLL
sZIM1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 172.16.1.13/30
set interfaces em1 unit 0 family inet address 10.0.10.42/30
set interfaces em1 unit 0 family mpls
set interfaces em2 unit 0 family inet address 10.0.10.46/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.73/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.58/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.6/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.7.1/32
set routing-options router-id 10.0.7.1
set routing-options autonomous-system 64513
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em1.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.7.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.3.1
set protocols bgp group mp-ibgp neighbor 10.0.6.1
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ldp interface em1.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0
set policy-options policy-statement EXPORT term 10 from protocol direct
set policy-options policy-statement EXPORT term 10 then accept
set policy-options policy-statement EXPORT term 20 from protocol bgp
set policy-options policy-statement EXPORT term 20 then accept
set routing-instances CUS instance-type vrf
set routing-instances CUS interface em0.0
set routing-instances CUS route-distinguisher 64513:1
set routing-instances CUS vrf-target target:64513:100
set routing-instances CUS vrf-table-label
set routing-instances CUS protocols bgp export EXPORT
set routing-instances CUS protocols bgp group eBGP type external
set routing-instances CUS protocols bgp group eBGP peer-as 64514
set routing-instances CUS protocols bgp group eBGP as-override
set routing-instances CUS protocols bgp group eBGP neighbor 172.16.1.14



[edit]
root@junos.edge2.pop1#


root@junos.edge2.pop2# run show configuration | display set
set version 10.1R1.8
set system host-name junos.edge2.pop2
set system root-authentication encrypted-password "$1$jGtOOB2M$6bxnX1s40ki5ewL4
UobK/"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 172.16.1.9/30
set interfaces em1 unit 0 family inet address 10.0.10.70/30
set interfaces em1 unit 0 family mpls
set interfaces em2 unit 0 family inet address 10.0.10.62/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.74/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.50/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.30/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.8.1/32
set routing-options router-id 10.0.8.1
set routing-options autonomous-system 64513
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em1.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.8.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.3.1
set protocols bgp group mp-ibgp neighbor 10.0.6.1
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ldp interface em1.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0
set policy-options policy-statement EXPORT term 10 from protocol direct
set policy-options policy-statement EXPORT term 10 then accept
set policy-options policy-statement EXPORT term 20 from protocol bgp
set policy-options policy-statement EXPORT term 20 then accept
set routing-instances CUS instance-type vrf
set routing-instances CUS interface em0.0
set routing-instances CUS route-distinguisher 64513:2
set routing-instances CUS vrf-target target:64513:100
set routing-instances CUS vrf-table-label
set routing-instances CUS protocols bgp export EXPORT
set routing-instances CUS protocols bgp group eBGP type external
set routing-instances CUS protocols bgp group eBGP peer-as 64514
set routing-instances CUS protocols bgp group eBGP as-override
set routing-instances CUS protocols bgp group eBGP neighbor 172.16.1.10



[edit]
root@junos.edge2.pop2#


root@junos.core1.pop1# run show configuration | display set
set version 10.1R1.8
set system host-name junos.core1.pop1
set system root-authentication encrypted-password "$1$2YtcBGE7$toxArK22Z6p0YcWMQ
01eg1"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.0.10.10/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 10.0.10.53/30
set interfaces em1 unit 0 family mpls
set interfaces em2 unit 0 family inet address 10.0.10.45/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.38/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.22/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.49/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.4.1/32
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em0.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols mpls interface em1.0
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ldp interface em0.0
set protocols ldp interface em1.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0





[edit]
root@junos.core1.pop1#


root@junos.core1.pop2# run show configuration | display set
set version 10.1R1.8
set system host-name junos.core1.pop2
set system root-authentication encrypted-password "$1$IOfZTCKq$KlBJX18UjRjoCFYCM
5TjL."
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em0 unit 0 family inet address 10.0.10.26/30
set interfaces em0 unit 0 family mpls
set interfaces em1 unit 0 family inet address 10.0.10.54/30
set interfaces em1 unit 0 family mpls
set interfaces em2 unit 0 family inet address 10.0.10.61/30
set interfaces em2 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.65/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.57/30
set interfaces em4 unit 0 family mpls
set interfaces em5 unit 0 family inet address 10.0.10.14/30
set interfaces em5 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.5.1/32
set routing-options router-id 10.0.5.1
set protocols mpls interface em3.0
set protocols mpls interface em2.0
set protocols mpls interface em0.0
set protocols mpls interface em5.0
set protocols mpls interface em4.0
set protocols mpls interface em1.0
set protocols ospf area 0.0.0.0 interface em0.0
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em2.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ldp interface em0.0
set protocols ldp interface em1.0
set protocols ldp interface em2.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface em5.0
set protocols ldp interface lo0.0

[edit]
root@junos.core1.pop2#


root@junos.rr.pop1# run show configuration | display set
set version 10.1R1.8
set system host-name junos.rr.pop1
set system root-authentication encrypted-password "$1$ooZGdfCs$rMyVvb.QQFcRVgFWb
ifoW/"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em1 unit 0 family inet address 10.0.10.41/30
set interfaces em1 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.37/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.2/30
set interfaces em4 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.3.1/32
set routing-options router-id 10.0.3.1
set routing-options autonomous-system 64513
set protocols mpls interface em1.0
set protocols mpls interface em3.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.3.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp cluster 10.0.3.1
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.1.1
set protocols bgp group mp-ibgp neighbor 10.0.2.1
set protocols bgp group mp-ibgp neighbor 10.0.7.1
set protocols bgp group mp-ibgp neighbor 10.0.8.1
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ldp interface em1.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface lo0.0

[edit]
root@junos.rr.pop1#


root@junos.rr1.pop2# run show configuration | display set
set version 10.1R1.8
set system host-name junos.rr1.pop2
set system root-authentication encrypted-password "$1$2602/tak$/eJomvrvKqMhhajfE
ZGOX0"
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set interfaces em1 unit 0 family inet address 10.0.10.69/30
set interfaces em1 unit 0 family mpls
set interfaces em3 unit 0 family inet address 10.0.10.66/30
set interfaces em3 unit 0 family mpls
set interfaces em4 unit 0 family inet address 10.0.10.34/30
set interfaces em4 unit 0 family mpls
set interfaces lo0 unit 0 family inet address 10.0.6.1/32
set routing-options router-id 10.0.6.1
set routing-options autonomous-system 64513
set protocols mpls interface em1.0
set protocols mpls interface em3.0
set protocols mpls interface em4.0
set protocols bgp group mp-ibgp type internal
set protocols bgp group mp-ibgp local-address 10.0.6.1
set protocols bgp group mp-ibgp family inet-vpn unicast
set protocols bgp group mp-ibgp cluster 10.0.6.1
set protocols bgp group mp-ibgp peer-as 64513
set protocols bgp group mp-ibgp neighbor 10.0.1.1
set protocols bgp group mp-ibgp neighbor 10.0.2.1
set protocols bgp group mp-ibgp neighbor 10.0.7.1
set protocols bgp group mp-ibgp neighbor 10.0.8.1
set protocols ospf area 0.0.0.0 interface em1.0
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em4.0
set protocols ospf area 0.0.0.0 interface lo0.0
set protocols ldp interface em1.0
set protocols ldp interface em3.0
set protocols ldp interface em4.0
set protocols ldp interface lo0.0

[edit]
root@junos.rr1.pop2#


cisco.ce1.pop1#sh running-config
Building configuration...

Current configuration : 1267 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco.ce1.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.10.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.100.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.10.6
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.10.4 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp router-id 172.16.1.6
bgp log-neighbor-changes
redistribute ospf 1 match internal external 1 external 2
neighbor 172.16.1.5 remote-as 64513
neighbor 172.16.1.5 soft-reconfiguration inbound
neighbor 172.16.100.5 remote-as 64514
neighbor 172.16.100.5 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cisco.ce1.pop1#

cisco.ce1.pop2#sh running-config
Building configuration...

Current configuration : 1267 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco.ce1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.100.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.10.5
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.10.0 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp router-id 172.16.1.2
bgp log-neighbor-changes
redistribute ospf 1 match internal external 1 external 2
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 soft-reconfiguration inbound
neighbor 172.16.100.6 remote-as 64514
neighbor 172.16.100.6 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cisco.ce1.pop2#


LAN.User.Pop1#sh running-config
Building configuration...

Current configuration : 925 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LAN.User.Pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.151.1 255.255.255.0
!
interface Loopback10
ip address 172.16.101.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.10.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.151.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

LAN.User.Pop1#

cisco.ce2.pop1#sh running-config
Building configuration...

Current configuration : 1271 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco.ce2.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.20.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.14 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.200.6 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.20.6
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.20.4 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp router-id 172.16.1.14
bgp log-neighbor-changes
redistribute ospf 1 match internal external 1 external 2
neighbor 172.16.1.13 remote-as 64513
neighbor 172.16.1.13 soft-reconfiguration inbound
neighbor 172.16.200.5 remote-as 64514
neighbor 172.16.200.5 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cisco.ce2.pop1#

cisco.ce3.pop2#sh running-config
Building configuration...

Current configuration : 1269 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco.ce3.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.20.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.10 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 172.16.200.5 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.20.2
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.20.0 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp router-id 172.16.1.10
bgp log-neighbor-changes
redistribute ospf 1 match internal external 1 external 2
neighbor 172.16.1.9 remote-as 64513
neighbor 172.16.1.9 soft-reconfiguration inbound
neighbor 172.16.200.6 remote-as 64514
neighbor 172.16.200.6 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cisco.ce3.pop2#

LAN.User.Pop2#sh running-config
Building configuration...

Current configuration : 925 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LAN.User.Pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.251.1 255.255.255.0
!
interface Loopback10
ip address 172.16.201.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.20.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.20.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
router-id 172.16.251.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

LAN.User.Pop2#


LAN.User.Pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.20.6 64 msec
172.16.20.2 116 msec
172.16.20.6 20 msec
2 172.16.1.9 112 msec
172.16.1.13 56 msec
172.16.1.9 76 msec
3 172.16.1.6 220 msec * 468 msec
4 172.16.10.5 396 msec * 204 msec
LAN.User.Pop2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
O E2 172.16.151.1/32 [110/1] via 172.16.20.6, 00:00:57, FastEthernet0/0
[110/1] via 172.16.20.2, 00:00:57, FastEthernet0/1
C 172.16.251.0/24 is directly connected, Loopback0
C 172.16.20.0/30 is directly connected, FastEthernet0/1
C 172.16.20.4/30 is directly connected, FastEthernet0/0
O E2 172.16.1.12/30 [110/1] via 172.16.20.2, 00:06:39, FastEthernet0/1
O E2 172.16.10.4/30 [110/1] via 172.16.20.6, 00:04:39, FastEthernet0/0
[110/1] via 172.16.20.2, 00:04:39, FastEthernet0/1
O E2 172.16.1.8/30 [110/1] via 172.16.20.6, 00:06:58, FastEthernet0/0
O E2 172.16.10.0/30 [110/1] via 172.16.20.6, 00:05:11, FastEthernet0/0
[110/1] via 172.16.20.2, 00:05:11, FastEthernet0/1
O E2 172.16.1.4/30 [110/1] via 172.16.20.6, 00:06:27, FastEthernet0/0
[110/1] via 172.16.20.2, 00:06:27, FastEthernet0/1
O E2 172.16.1.0/30 [110/1] via 172.16.20.6, 00:06:29, FastEthernet0/0
[110/1] via 172.16.20.2, 00:06:29, FastEthernet0/1
LAN.User.Pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.20.6 60 msec
172.16.20.2 104 msec
172.16.20.6 48 msec
2 172.16.1.9 28 msec
172.16.1.13 44 msec
172.16.1.9 88 msec
3 172.16.1.6 648 msec * 208 msec
4 172.16.10.5 368 msec * 300 msec
LAN.User.Pop2#

LAN.User.Pop1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
C 172.16.151.0/24 is directly connected, Loopback0
O E2 172.16.251.1/32 [110/1] via 172.16.10.6, 00:06:05, FastEthernet0/0
[110/1] via 172.16.10.2, 00:06:05, FastEthernet0/1
O E2 172.16.20.0/30 [110/1] via 172.16.10.6, 00:05:55, FastEthernet0/0
[110/1] via 172.16.10.2, 00:05:55, FastEthernet0/1
O E2 172.16.20.4/30 [110/1] via 172.16.10.6, 00:08:44, FastEthernet0/0
[110/1] via 172.16.10.2, 00:08:44, FastEthernet0/1
O E2 172.16.1.12/30 [110/1] via 172.16.10.6, 00:11:54, FastEthernet0/0
[110/1] via 172.16.10.2, 00:11:54, FastEthernet0/1
C 172.16.10.4/30 is directly connected, FastEthernet0/0
O E2 172.16.1.8/30 [110/1] via 172.16.10.6, 00:11:54, FastEthernet0/0
[110/1] via 172.16.10.2, 00:11:54, FastEthernet0/1
C 172.16.10.0/30 is directly connected, FastEthernet0/1
O E2 172.16.1.4/30 [110/1] via 172.16.10.2, 00:11:54, FastEthernet0/1
O E2 172.16.1.0/30 [110/1] via 172.16.10.6, 00:11:54, FastEthernet0/0
LAN.User.Pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.10.6 108 msec
172.16.10.2 88 msec
172.16.10.6 52 msec
2 172.16.1.1 92 msec
172.16.1.5 60 msec
172.16.1.1 56 msec
3 172.16.1.14 348 msec * 292 msec
4 172.16.20.5 536 msec * 444 msec
LAN.User.Pop1#

**************
OUTPUT
**************
root@junos.edge1.pop1# run show route table CUS.inet.0

CUS.inet.0: 13 destinations, 26 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.1.0/30 *[BGP/170] 01:40:52, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.18 via em3.0, Push 16
[BGP/170] 01:40:52, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.18 via em3.0, Push 16
172.16.1.4/30 *[Direct/0] 01:52:33
> via em1.0
172.16.1.5/32 *[Local/0] 01:52:33
Local via em1.0
172.16.1.8/30 *[BGP/170] 01:39:13, localpref 100, from 10.0.3.1
AS path: I
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
[BGP/170] 01:39:12, localpref 100, from 10.0.6.1
AS path: I
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
[BGP/170] 00:00:54, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.1.12/30 *[BGP/170] 01:39:45, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 01:39:42, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:54, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.10.0/30 *[BGP/170] 00:02:04, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.10.4/30 *[BGP/170] 00:02:03, MED 0, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.20.0/30 *[BGP/170] 00:01:50, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
> to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
[BGP/170] 00:01:58, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
> to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
172.16.20.4/30 *[BGP/170] 00:00:27, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:25, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
172.16.101.1/32 *[BGP/170] 00:02:04, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.151.1/32 *[BGP/170] 00:02:04, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.6 via em1.0
172.16.201.1/32 *[BGP/170] 00:00:19, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:18, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:22, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
[BGP/170] 00:00:22, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
172.16.251.1/32 *[BGP/170] 00:00:19, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:18, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.6 via em5.0, Push 16
[BGP/170] 00:00:22, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)
[BGP/170] 00:00:22, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.10 via em0.0, Push 16, Push 299872(top)
> to 10.0.10.14 via em2.0, Push 16, Push 299984(top)
to 10.0.10.18 via em3.0, Push 16, Push 300240(top)
to 10.0.10.6 via em5.0, Push 16, Push 300176(top)

[edit]
root@junos.edge1.pop1#

root@junos.edge1.pop2# run show route table CUS.inet.0

CUS.inet.0: 13 destinations, 30 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.1.0/30 *[Direct/0] 01:47:05
> via em1.0
172.16.1.1/32 *[Local/0] 01:47:05
Local via em1.0
172.16.1.4/30 *[BGP/170] 01:47:48, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.17 via em3.0, Push 16
[BGP/170] 01:47:47, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.17 via em3.0, Push 16
172.16.1.8/30 *[BGP/170] 01:28:25, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.30 via em5.0, Push 16
[BGP/170] 01:28:25, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.30 via em5.0, Push 16
172.16.1.12/30 *[BGP/170] 01:45:40, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 01:45:41, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
172.16.10.0/30 *[BGP/170] 00:04:22, MED 0, localpref 100
AS path: 64514 ?
> to 172.16.1.2 via em1.0
172.16.10.4/30 *[BGP/170] 00:06:53, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
[BGP/170] 00:07:03, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
[BGP/170] 00:04:22, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.2 via em1.0
172.16.20.0/30 *[BGP/170] 00:06:53, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16
[BGP/170] 00:07:03, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16
172.16.20.4/30 *[BGP/170] 00:03:54, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
> to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 00:03:54, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
> to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
172.16.101.1/32 *[BGP/170] 00:04:22, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.2 via em1.0
[BGP/170] 00:05:44, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
[BGP/170] 00:06:09, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
172.16.151.1/32 *[BGP/170] 00:04:22, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.2 via em1.0
[BGP/170] 00:05:44, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
[BGP/170] 00:06:09, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.17 via em3.0, Push 16
172.16.201.1/32 *[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
> to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
> to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 00:05:24, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16
[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16
172.16.251.1/32 *[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
> to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.26 via em0.0, Push 16, Push 300000(top)
> to 10.0.10.22 via em2.0, Push 16, Push 299888(top)
to 10.0.10.17 via em3.0, Push 16, Push 300288(top)
to 10.0.10.30 via em5.0, Push 16, Push 300208(top)
[BGP/170] 00:05:24, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16
[BGP/170] 00:05:23, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.30 via em5.0, Push 16

[edit]
root@junos.edge1.pop2#

root@junos.edge2.pop1# run show route table CUS.inet.0

CUS.inet.0: 13 destinations, 30 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.1.0/30 *[BGP/170] 01:47:53, localpref 100, from 10.0.3.1
AS path: I
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
> to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
[BGP/170] 01:47:53, localpref 100, from 10.0.6.1
AS path: I
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
> to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
172.16.1.4/30 *[BGP/170] 01:48:38, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 01:48:38, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.5 via em5.0, Push 16
172.16.1.8/30 *[BGP/170] 01:47:41, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.74 via em3.0, Push 16
[BGP/170] 01:47:41, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.74 via em3.0, Push 16
172.16.1.12/30 *[Direct/0] 01:48:13
> via em0.0
172.16.1.13/32 *[Local/0] 01:48:13
Local via em0.0
172.16.10.0/30 *[BGP/170] 00:05:30, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
> to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
[BGP/170] 00:05:29, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
> to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
172.16.10.4/30 *[BGP/170] 00:08:16, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 00:08:20, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
172.16.20.0/30 *[BGP/170] 00:08:17, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16
[BGP/170] 00:08:20, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16
[BGP/170] 00:07:19, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.14 via em0.0
172.16.20.4/30 *[BGP/170] 00:07:18, MED 0, localpref 100
AS path: 64514 ?
> to 172.16.1.14 via em0.0
172.16.101.1/32 *[BGP/170] 00:07:06, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 00:07:16, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 00:05:34, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
> to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
[BGP/170] 00:05:33, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
> to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
172.16.151.1/32 *[BGP/170] 00:07:06, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 00:07:16, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.5 via em5.0, Push 16
[BGP/170] 00:05:34, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
> to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
[BGP/170] 00:05:33, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.45 via em2.0, Push 16, Push 299904(top)
to 10.0.10.74 via em3.0, Push 16, Push 300224(top)
> to 10.0.10.57 via em4.0, Push 16, Push 300016(top)
to 10.0.10.5 via em5.0, Push 16, Push 300304(top)
172.16.201.1/32 *[BGP/170] 00:07:19, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.14 via em0.0
[BGP/170] 00:06:42, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16
[BGP/170] 00:06:43, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16
172.16.251.1/32 *[BGP/170] 00:07:19, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.14 via em0.0
[BGP/170] 00:06:42, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16
[BGP/170] 00:06:43, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.74 via em3.0, Push 16





[edit]
root@junos.edge2.pop1#

root@junos.edge2.pop2# run show route table CUS.inet.0

CUS.inet.0: 13 destinations, 30 routes (13 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

172.16.1.0/30 *[BGP/170] 01:44:51, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.29 via em5.0, Push 16
[BGP/170] 01:44:50, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.29 via em5.0, Push 16
172.16.1.4/30 *[BGP/170] 01:44:16, localpref 100, from 10.0.3.1
AS path: I
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 01:44:16, localpref 100, from 10.0.6.1
AS path: I
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
172.16.1.8/30 *[Direct/0] 01:44:35
> via em0.0
172.16.1.9/32 *[Local/0] 01:44:35
Local via em0.0
172.16.1.12/30 *[BGP/170] 01:44:52, localpref 100, from 10.0.3.1
AS path: I
> to 10.0.10.73 via em3.0, Push 16
[BGP/170] 01:44:51, localpref 100, from 10.0.6.1
AS path: I
> to 10.0.10.73 via em3.0, Push 16
172.16.10.0/30 *[BGP/170] 00:06:27, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
[BGP/170] 00:06:26, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
172.16.10.4/30 *[BGP/170] 00:09:03, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 00:09:14, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
172.16.20.0/30 *[BGP/170] 00:09:20, MED 0, localpref 100
AS path: 64514 ?
> to 172.16.1.10 via em0.0
172.16.20.4/30 *[BGP/170] 00:06:09, MED 0, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16
[BGP/170] 00:06:09, MED 0, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16
[BGP/170] 00:09:21, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.10 via em0.0
172.16.101.1/32 *[BGP/170] 00:07:56, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 00:08:26, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 00:06:27, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
[BGP/170] 00:06:30, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
172.16.151.1/32 *[BGP/170] 00:07:56, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 00:08:26, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
to 10.0.10.61 via em2.0, Push 16, Push 299904(top)
to 10.0.10.73 via em3.0, Push 16, Push 300128(top)
> to 10.0.10.49 via em4.0, Push 16, Push 299776(top)
to 10.0.10.29 via em5.0, Push 16, Push 300128(top)
[BGP/170] 00:06:27, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
[BGP/170] 00:06:30, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.29 via em5.0, Push 16
172.16.201.1/32 *[BGP/170] 00:09:21, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.10 via em0.0
[BGP/170] 00:07:35, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16
[BGP/170] 00:07:36, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16
172.16.251.1/32 *[BGP/170] 00:09:21, MED 2, localpref 100
AS path: 64514 ?
> to 172.16.1.10 via em0.0
[BGP/170] 00:07:35, MED 2, localpref 100, from 10.0.3.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16
[BGP/170] 00:07:36, MED 2, localpref 100, from 10.0.6.1
AS path: 64514 ?
> to 10.0.10.73 via em3.0, Push 16

[edit]
root@junos.edge2.pop2#

root@junos.rr.pop1# run show bgp summary
Groups: 1 Peers: 4 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 16 16 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.1.1 64513 309 287 0 0 1:31:24 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.2.1 64513 299 296 0 0 1:31:17 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.7.1 64513 315 286 0 0 1:31:17 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.8.1 64513 304 285 0 0 1:31:13 Es
tabl
bgp.l3vpn.0: 4/4/4/0

[edit]
root@junos.rr.pop1#


root@junos.rr1.pop2# run show bgp summary
Groups: 1 Peers: 4 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 16 16 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.1.1 64513 307 361 0 0 2:08:09 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.2.1 64513 297 369 0 0 2:08:05 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.7.1 64513 314 360 0 0 2:08:01 Es
tabl
bgp.l3vpn.0: 4/4/4/0
10.0.8.1 64513 302 357 0 0 2:07:58 Es
tabl
bgp.l3vpn.0: 4/4/4/0

[edit]
root@junos.rr1.pop2#


root@junos.edge1.pop1# run show bgp summary
Groups: 2 Peers: 3 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 24 12 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.3.1 64513 289 312 0 0 2:08:09 Es
tabl
bgp.l3vpn.0: 12/12/12/0
CUS.inet.0: 8/12/12/0
10.0.6.1 64513 362 309 0 0 2:06:54 Es
tabl
bgp.l3vpn.0: 0/12/12/0
CUS.inet.0: 0/12/12/0
172.16.1.6 64514 42 42 0 1 12:08 Es
tabl
CUS.inet.0: 3/4/4/0

[edit]
root@junos.edge1.pop1#

root@junos.edge1.pop2# run show bgp summary
Groups: 2 Peers: 3 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 24 12 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.3.1 64513 298 302 0 0 2:09:30 Es
tabl
bgp.l3vpn.0: 12/12/12/0
CUS.inet.0: 8/12/12/0
10.0.6.1 64513 371 300 0 0 2:08:21 Es
tabl
bgp.l3vpn.0: 0/12/12/0
CUS.inet.0: 0/12/12/0
172.16.1.2 64514 96 105 0 1 9:30 Es
tabl
CUS.inet.0: 3/4/4/0

[edit]
root@junos.edge1.pop2#

root@junos.edge2.pop1# run show bgp summary
Groups: 2 Peers: 3 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 24 12 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.3.1 64513 288 320 0 0 2:11:29 Es
tabl
bgp.l3vpn.0: 12/12/12/0
CUS.inet.0: 8/12/12/0
10.0.6.1 64513 362 317 0 0 2:10:15 Es
tabl
bgp.l3vpn.0: 0/12/12/0
CUS.inet.0: 0/12/12/0
172.16.1.14 64514 36 35 0 1 12:21 Es
tabl
CUS.inet.0: 3/4/4/0

[edit]
root@junos.edge2.pop1#

root@junos.edge2.pop2# run show bgp summary
Groups: 2 Peers: 3 Down peers: 0
Table Tot Paths Act Paths Suppressed History Damp State Pending
bgp.l3vpn.0 24 12 0 0 0 0
Peer AS InPkt OutPkt OutQ Flaps Last Up/Dwn St
ate|#Active/Received/Accepted/Damped...
10.0.3.1 64513 288 309 0 0 2:06:37 Es
tabl
bgp.l3vpn.0: 12/12/12/0
CUS.inet.0: 8/12/12/0
10.0.6.1 64513 360 306 0 0 2:05:27 Es
tabl
bgp.l3vpn.0: 0/12/12/0
CUS.inet.0: 0/12/12/0
172.16.1.10 64514 41 41 0 1 13:10 Es
tabl
CUS.inet.0: 3/4/4/0

[edit]
root@junos.edge2.pop2#

No comments:

Post a Comment