Saturday, December 17, 2011

Implementing Per-Packet Load-Balancing in MPLS L3 VPN LAB



Configuration Guidelines
***********************************************************
Scenario: An ISP wants to offer Load-Balancing Solution to
its Dual-Homed MPLS VPN Customers such that both the ISP's
PE-CE Links are utilized for forward and reverse traffic


Design Consideration and Solution:

There are two possible solutions for offering Load-Balancing
Services to Dual-Homed MPLS VPN Customers
1. Using per-destination load-balancing
2. using per-packet load-balaning

Here we are focussing on 2nd solution to provide per-packet
load-balancing by using different RD Values for the Same CUstomer
VRF on per PE-Basis to make the same Customer Prefix to be recognized
as unique VPNv4 Prefix in the MPLS VPN Cloud and enabling MP-iBGP
Multi-Path at PEs under VRF Address-Family to select both the routes
for traffic exit across MPLS Cloud.


Apart from this we need to enable per-packet load-balancing across
SP Core as by default MPLS Traffic is CEF Based Process Switched and
even though we would have two paths in the VRF ROuting Table for the
same destination prefix traffic would be exited via one PE only.


Challenges: Enabling Per-Packet Load-Sharing across SP Core would
result in unwanted per-packet load-balancing for any MPLS VPN Customer
for which MP-iBGP Multipath is enabled and per-destination load-balancing
was desired.This can affect Voice Traffic Significantly.Consideration has
to be taken by SP whether it can provide this kind of load-balancing
services to its MPLS VPN Customer.

ISP IGP used OSPF Area 0
Per-Packet Load-Sharing enabled in SP Core.
PE-CE ROuting Protocol used EBGP
ISP AS used 64513
VRF used is cus1 with different RD/pop at each PE
edge1.pop1- 64513:1
edge2.pop1- 64513:2
edge1.pop2- 64513:1
edge2.pop2- 64513:2
Customer AS used 64514
Per-Packet Load-Sharing enabled on CE-PE Uplinks.



**********************************************************

edge1.pop1#sh running-config
Building configuration...

Current configuration : 2420 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.10.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.30.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/0
ip address 10.0.20.1 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 10.0.40.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
ip vrf forwarding cus1
ip address 172.16.1.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr peer-group
neighbor mp-ibgp_rr remote-as 64513
neighbor mp-ibgp_rr update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp_rr
neighbor 10.0.4.1 peer-group mp-ibgp_rr
!
address-family vpnv4
neighbor mp-ibgp_rr send-community extended
neighbor mp-ibgp_rr next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 as-override
neighbor 172.16.1.2 soft-reconfiguration inbound
maximum-paths ibgp 4
no auto-summary
no synchronization
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

edge1.pop1#

edge2.pop1#sh running-config
Building configuration...

Current configuration : 2392 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge2.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip vrf cus1
rd 64513:2
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.60.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.30.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/0
ip address 10.0.50.1 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 10.0.70.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
ip vrf forwarding cus1
ip address 172.16.1.5 255.255.255.252
no ip route-cache cef
duplex auto
speed auto
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr peer-group
neighbor mp-ibgp_rr remote-as 64513
neighbor mp-ibgp_rr update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp_rr
neighbor 10.0.4.1 peer-group mp-ibgp_rr
!
address-family vpnv4
neighbor mp-ibgp_rr send-community extended
neighbor mp-ibgp_rr next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.1.6 remote-as 64514
neighbor 172.16.1.6 activate
neighbor 172.16.1.6 as-override
neighbor 172.16.1.6 soft-reconfiguration inbound
maximum-paths ibgp 4
no auto-summary
no synchronization
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

edge2.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2393 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.5.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.10.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.100.1 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/0
ip address 10.0.50.2 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 10.0.80.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
ip vrf forwarding cus1
ip address 172.16.2.1 255.255.255.252
no ip route-cache cef
duplex auto
speed auto
!
router ospf 1
router-id 10.0.5.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.5.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr peer-group
neighbor mp-ibgp_rr remote-as 64513
neighbor mp-ibgp_rr update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp_rr
neighbor 10.0.4.1 peer-group mp-ibgp_rr
!
address-family vpnv4
neighbor mp-ibgp_rr send-community extended
neighbor mp-ibgp_rr next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.2.2 remote-as 64514
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 as-override
neighbor 172.16.2.2 soft-reconfiguration inbound
maximum-paths ibgp 4
no auto-summary
no synchronization
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

edge1.pop2#

edge2.pop2#sh running-config
Building configuration...

Current configuration : 2412 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge2.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip vrf cus1
rd 64513:2
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.6.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.60.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.100.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet1/0
ip address 10.0.20.2 255.255.255.252
ip load-sharing per-packet
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet2/0
ip address 10.0.90.2 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
ip vrf forwarding cus1
ip address 172.16.2.5 255.255.255.252
no ip route-cache cef
duplex auto
speed auto
!
router ospf 1
router-id 10.0.6.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.6.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr peer-group
neighbor mp-ibgp_rr remote-as 64513
neighbor mp-ibgp_rr update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp_rr
neighbor 10.0.4.1 peer-group mp-ibgp_rr
!
address-family vpnv4
neighbor mp-ibgp_rr send-community extended
neighbor mp-ibgp_rr next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.2.6 remote-as 64514
neighbor 172.16.2.6 activate
neighbor 172.16.2.6 as-override
neighbor 172.16.2.6 soft-reconfiguration inbound
maximum-paths ibgp 4
no auto-summary
no synchronization
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

edge2.pop2#

rr.pop1#sh running-config
Building configuration...

Current configuration : 1654 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rr.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.40.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.80.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr_client peer-group
neighbor mp-ibgp_rr_client remote-as 64513
neighbor mp-ibgp_rr_client update-source Loopback0
neighbor 10.0.1.1 peer-group mp-ibgp_rr_client
neighbor 10.0.2.1 peer-group mp-ibgp_rr_client
neighbor 10.0.5.1 peer-group mp-ibgp_rr_client
neighbor 10.0.6.1 peer-group mp-ibgp_rr_client
!
address-family vpnv4
neighbor mp-ibgp_rr_client send-community extended
neighbor mp-ibgp_rr_client route-reflector-client
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.5.1 activate
neighbor 10.0.6.1 activate
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

rr.pop1#

rr.pop2#sh running-config
Building configuration...

Current configuration : 1654 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rr.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.70.2 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
ip address 10.0.90.1 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor mp-ibgp_rr_client peer-group
neighbor mp-ibgp_rr_client remote-as 64513
neighbor mp-ibgp_rr_client update-source Loopback0
neighbor 10.0.1.1 peer-group mp-ibgp_rr_client
neighbor 10.0.2.1 peer-group mp-ibgp_rr_client
neighbor 10.0.5.1 peer-group mp-ibgp_rr_client
neighbor 10.0.6.1 peer-group mp-ibgp_rr_client
!
address-family vpnv4
neighbor mp-ibgp_rr_client send-community extended
neighbor mp-ibgp_rr_client route-reflector-client
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.5.1 activate
neighbor 10.0.6.1 activate
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

rr.pop2#

cus1.pop1#sh running-config
Building configuration...

Current configuration : 1153 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.151.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.6 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.151.1
bgp log-neighbor-changes
network 172.16.151.0 mask 255.255.255.0
neighbor eBGP peer-group
neighbor eBGP remote-as 64513
neighbor eBGP soft-reconfiguration inbound
neighbor 172.16.1.1 peer-group eBGP
neighbor 172.16.1.5 peer-group eBGP
maximum-paths 4
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cus1.pop1#


cus1.pop2#sh running-config
Building configuration...

Current configuration : 1153 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.251.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.2.6 255.255.255.252
ip load-sharing per-packet
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.251.1
bgp log-neighbor-changes
network 172.16.251.0 mask 255.255.255.0
neighbor eBGP peer-group
neighbor eBGP remote-as 64513
neighbor eBGP soft-reconfiguration inbound
neighbor 172.16.2.1 peer-group eBGP
neighbor 172.16.2.5 peer-group eBGP
maximum-paths 4
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

cus1.pop2#

**************************************
OUTPUT
******************************************************
TRACE BEFORE Enabling Per-Packet Load-Sharing in Core
********************************************************

edge1.pop1#traceroute vrf cus1 172.16.251.1

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.2.5 [MPLS: Label 28 Exp 0] 212 msec
172.16.2.1 [MPLS: Label 28 Exp 0] 200 msec
172.16.2.5 [MPLS: Label 28 Exp 0] 116 msec
2 172.16.2.2 164 msec
172.16.2.6 332 msec
172.16.2.2 316 msec
edge1.pop1#show ip cef vrf cus1 172.16.251.0
172.16.251.0/24, version 13, epoch 0, per-destination sharing
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
via 10.0.6.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.20.2, FastEthernet1/0 via 10.0.6.1/32
valid adjacency
tag rewrite with Fa1/0, 10.0.20.2, tags imposed: {28}
via 10.0.5.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.10.2, FastEthernet0/0 via 10.0.5.1/32
valid adjacency
tag rewrite with Fa0/0, 10.0.10.2, tags imposed: {28}
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
edge1.pop1#



cus1.pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.1.1 160 msec
172.16.1.5 152 msec
172.16.1.1 52 msec
2 172.16.2.1 [AS 64513] 184 msec 204 msec 164 msec
3 172.16.2.2 [AS 64513] 148 msec * 228 msec
cus1.pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.1.5 80 msec
172.16.1.1 128 msec
172.16.1.5 96 msec
2 172.16.2.1 [AS 64513] 272 msec 284 msec 52 msec
3 172.16.2.2 [AS 64513] 328 msec * 280 msec
cus1.pop1#

***************

edge1.pop2#traceroute vrf cus1 172.16.151.1

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.1.5 [MPLS: Label 28 Exp 0] 132 msec
172.16.1.1 [MPLS: Label 28 Exp 0] 168 msec
172.16.1.5 [MPLS: Label 28 Exp 0] 136 msec
2 172.16.1.2 216 msec
172.16.1.6 280 msec *
edge1.pop2#show ip cef vrf cus1 172.16.151.0
172.16.151.0/24, version 12, epoch 0, per-destination sharing
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
via 10.0.2.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.50.1, FastEthernet1/0 via 10.0.2.1/32
valid adjacency
tag rewrite with Fa1/0, 10.0.50.1, tags imposed: {28}
via 10.0.1.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.10.1, FastEthernet0/0 via 10.0.1.1/32
valid adjacency
tag rewrite with Fa0/0, 10.0.10.1, tags imposed: {28}
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
edge1.pop2#

cus1.pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.1 56 msec
172.16.2.5 208 msec
172.16.2.1 224 msec
2 172.16.1.5 [AS 64513] 224 msec 280 msec 88 msec
3 172.16.1.6 [AS 64513] 260 msec * 280 msec
cus1.pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.5 152 msec
172.16.2.1 212 msec
172.16.2.5 84 msec
2 172.16.1.5 [AS 64513] 180 msec 136 msec 148 msec
3 172.16.1.6 [AS 64513] 456 msec * 224 msec
cus1.pop2#


******************************************************
TRACE AFTER Enabling Per-Packet Load-Sharing in Core
******************************************************



edge1.pop1#show ip cef vrf cus1 172.16.251.0
172.16.251.0/24, version 13, epoch 0, per-packet sharing
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
via 10.0.6.1, 0 dependencies, recursive
traffic share 1, current path
next hop 10.0.20.2, FastEthernet1/0 via 10.0.6.1/32
valid adjacency
tag rewrite with Fa1/0, 10.0.20.2, tags imposed: {28}
via 10.0.5.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.10.2, FastEthernet0/0 via 10.0.5.1/32
valid adjacency
tag rewrite with Fa0/0, 10.0.10.2, tags imposed: {28}
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
edge1.pop1#

cus1.pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.1.5 184 msec
172.16.1.1 80 msec
172.16.1.5 56 msec
2 172.16.2.1 [AS 64513] 104 msec 132 msec
172.16.2.5 [AS 64513] 216 msec
3 172.16.2.6 [AS 64513] 304 msec
172.16.2.2 [AS 64513] 320 msec 220 msec
cus1.pop1#


edge1.pop2#show ip cef vrf cus1 172.16.151.0
172.16.151.0/24, version 12, epoch 0, per-packet sharing
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
via 10.0.2.1, 0 dependencies, recursive
traffic share 1, current path
next hop 10.0.50.1, FastEthernet1/0 via 10.0.2.1/32
valid adjacency
tag rewrite with Fa1/0, 10.0.50.1, tags imposed: {28}
via 10.0.1.1, 0 dependencies, recursive
traffic share 1
next hop 10.0.10.1, FastEthernet0/0 via 10.0.1.1/32
valid adjacency
tag rewrite with Fa0/0, 10.0.10.1, tags imposed: {28}
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
edge1.pop2#

cus1.pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.5 156 msec
172.16.2.1 132 msec
172.16.2.5 196 msec
2 172.16.1.5 [AS 64513] 212 msec
172.16.1.1 [AS 64513] 160 msec 112 msec
3 172.16.1.6 [AS 64513] 164 msec *
172.16.1.2 [AS 64513] 468 msec
cus1.pop2#
****************************
SNAPSHOTS
****************************

cus1.pop1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C 172.16.151.0/24 is directly connected, Loopback0
B 172.16.251.0/24 [20/0] via 172.16.1.5, 00:47:07
[20/0] via 172.16.1.1, 00:47:07
C 172.16.1.4/30 is directly connected, FastEthernet0/1
B 172.16.2.4/30 [20/0] via 172.16.1.5, 00:49:29
[20/0] via 172.16.1.1, 00:49:29
C 172.16.1.0/30 is directly connected, FastEthernet0/0
B 172.16.2.0/30 [20/0] via 172.16.1.5, 00:49:29
[20/0] via 172.16.1.1, 00:49:29
cus1.pop1#show ip bgp
BGP table version is 10, local router ID is 172.16.151.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
r> 172.16.1.0/30 172.16.1.1 0 0 64513 ?
r 172.16.1.5 0 64513 ?
r> 172.16.1.4/30 172.16.1.1 0 64513 ?
r 172.16.1.5 0 0 64513 ?
*> 172.16.2.0/30 172.16.1.1 0 64513 ?
* 172.16.1.5 0 64513 ?
*> 172.16.2.4/30 172.16.1.1 0 64513 ?
* 172.16.1.5 0 64513 ?
*> 172.16.151.0/24 0.0.0.0 0 32768 i
*> 172.16.251.0/24 172.16.1.5 0 64513 64513 i
* 172.16.1.1 0 64513 64513 i
cus1.pop1#

cus1.pop1#show ip cef 172.16.251.0 detail
172.16.251.0/24, version 16, epoch 0, per-packet sharing
0 packets, 0 bytes
via 172.16.1.5, 0 dependencies, recursive
traffic share 1
next hop 172.16.1.5, FastEthernet0/1 via 172.16.1.5/32
valid adjacency
via 172.16.1.1, 0 dependencies, recursive
traffic share 1, current path
next hop 172.16.1.1, FastEthernet0/0 via 172.16.1.1/32
valid adjacency
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
cus1.pop1#

cus1.pop2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.0/24 [20/0] via 172.16.2.5, 00:48:24
[20/0] via 172.16.2.1, 00:48:24
C 172.16.251.0/24 is directly connected, Loopback0
B 172.16.1.4/30 [20/0] via 172.16.2.5, 00:48:24
[20/0] via 172.16.2.1, 00:48:24
C 172.16.2.4/30 is directly connected, FastEthernet0/1
B 172.16.1.0/30 [20/0] via 172.16.2.5, 00:48:24
[20/0] via 172.16.2.1, 00:48:24
C 172.16.2.0/30 is directly connected, FastEthernet0/0
cus1.pop2#show ip bgp
BGP table version is 9, local router ID is 172.16.251.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/30 172.16.2.1 0 64513 ?
* 172.16.2.5 0 64513 ?
*> 172.16.1.4/30 172.16.2.1 0 64513 ?
* 172.16.2.5 0 64513 ?
r> 172.16.2.0/30 172.16.2.1 0 0 64513 ?
r 172.16.2.5 0 64513 ?
r> 172.16.2.4/30 172.16.2.1 0 64513 ?
r 172.16.2.5 0 0 64513 ?
*> 172.16.151.0/24 172.16.2.1 0 64513 64513 i
* 172.16.2.5 0 64513 64513 i
*> 172.16.251.0/24 0.0.0.0 0 32768 i
cus1.pop2#

cus1.pop2#show ip cef 172.16.151.0 detail
172.16.151.0/24, version 15, epoch 0, per-packet sharing
0 packets, 0 bytes
via 172.16.2.5, 0 dependencies, recursive
traffic share 1
next hop 172.16.2.5, FastEthernet0/1 via 172.16.2.5/32
valid adjacency
via 172.16.2.1, 0 dependencies, recursive
traffic share 1, current path
next hop 172.16.2.1, FastEthernet0/0 via 172.16.2.1/32
valid adjacency
0 packets, 0 bytes switched through the prefix
tmstats: external 0 packets, 0 bytes
internal 0 packets, 0 bytes
cus1.pop2#


edge1.pop1#show ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.0/24 [20/0] via 172.16.1.2, 00:51:13
B 172.16.251.0/24 [200/0] via 10.0.6.1, 00:49:27
[200/0] via 10.0.5.1, 00:49:27
B 172.16.1.4/30 [200/0] via 10.0.2.1, 00:52:27
B 172.16.2.4/30 [200/0] via 10.0.6.1, 00:52:27
C 172.16.1.0/30 is directly connected, FastEthernet3/0
B 172.16.2.0/30 [200/0] via 10.0.5.1, 00:52:27
edge1.pop1#show ip bgp vpnv4 vrf cus1
BGP table version is 24, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf cus1)
*> 172.16.1.0/30 0.0.0.0 0 32768 ?
*>i172.16.1.4/30 10.0.2.1 0 100 0 ?
*>i172.16.2.0/30 10.0.5.1 0 100 0 ?
* i 10.0.5.1 0 100 0 ?
*>i172.16.2.4/30 10.0.6.1 0 100 0 ?
* i172.16.151.0/24 10.0.2.1 0 100 0 64514 i
*> 172.16.1.2 0 0 64514 i
* i172.16.251.0/24 10.0.6.1 0 100 0 64514 i
* i 10.0.5.1 0 100 0 64514 i
*>i 10.0.5.1 0 100 0 64514 i
edge1.pop1#

edge1.pop1#show ip bgp vpnv4 vrf cus1 172.16.251.0
BGP routing table entry for 64513:1:172.16.251.0/24, version 24
Paths: (3 available, best #3, table cus1)
Multipath: iBGP
Advertised to update-groups:
3
64514, imported path from 64513:2:172.16.251.0/24
10.0.6.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community: RT:64513:100
Originator: 10.0.6.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514
10.0.5.1 (metric 2) from 10.0.4.1 (10.0.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
Originator: 10.0.5.1, Cluster list: 10.0.4.1,
mpls labels in/out nolabel/28
64514
10.0.5.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath, best
Extended Community: RT:64513:100
Originator: 10.0.5.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
edge1.pop1#

edge2.pop1#show ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.0/24 [20/0] via 172.16.1.6, 00:51:43
B 172.16.251.0/24 [200/0] via 10.0.6.1, 00:50:13
[200/0] via 10.0.5.1, 00:50:13
C 172.16.1.4/30 is directly connected, FastEthernet3/0
B 172.16.2.4/30 [200/0] via 10.0.6.1, 00:53:59
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:53:13
B 172.16.2.0/30 [200/0] via 10.0.5.1, 00:53:13
edge2.pop1#show ip bgp vpnv4 vrf cus1
BGP table version is 21, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:2 (default for vrf cus1)
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
*> 172.16.1.4/30 0.0.0.0 0 32768 ?
*>i172.16.2.0/30 10.0.5.1 0 100 0 ?
* i172.16.2.4/30 10.0.6.1 0 100 0 ?
*>i 10.0.6.1 0 100 0 ?
* i172.16.151.0/24 10.0.1.1 0 100 0 64514 i
*> 172.16.1.6 0 0 64514 i
*>i172.16.251.0/24 10.0.5.1 0 100 0 64514 i
* i 10.0.6.1 0 100 0 64514 i
* i 10.0.6.1 0 100 0 64514 i
edge2.pop1#


edge2.pop1#show ip bgp vpnv4 vrf cus1 172.16.251.0
BGP routing table entry for 64513:2:172.16.251.0/24, version 21
Paths: (3 available, best #1, table cus1)
Multipath: iBGP
Advertised to update-groups:
1
64514, imported path from 64513:1:172.16.251.0/24
10.0.5.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath, best
Extended Community: RT:64513:100
Originator: 10.0.5.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514
10.0.6.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community: RT:64513:100
Originator: 10.0.6.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514
10.0.6.1 (metric 2) from 10.0.4.1 (10.0.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
Originator: 10.0.6.1, Cluster list: 10.0.4.1,
mpls labels in/out nolabel/28
edge2.pop1#

edge1.pop2#show ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.0/24 [200/0] via 10.0.2.1, 00:52:14
[200/0] via 10.0.1.1, 00:52:14
B 172.16.251.0/24 [20/0] via 172.16.2.2, 00:50:44
B 172.16.1.4/30 [200/0] via 10.0.2.1, 00:53:44
B 172.16.2.4/30 [200/0] via 10.0.6.1, 00:53:44
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:53:44
C 172.16.2.0/30 is directly connected, FastEthernet3/0
edge1.pop2#show ip bgp vpnv4 vrf cus1
BGP table version is 25, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf cus1)
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
* i 10.0.1.1 0 100 0 ?
*>i172.16.1.4/30 10.0.2.1 0 100 0 ?
*> 172.16.2.0/30 0.0.0.0 0 32768 ?
*>i172.16.2.4/30 10.0.6.1 0 100 0 ?
* i172.16.151.0/24 10.0.1.1 0 100 0 64514 i
*>i 10.0.1.1 0 100 0 64514 i
* i 10.0.2.1 0 100 0 64514 i
* i172.16.251.0/24 10.0.6.1 0 100 0 64514 i
*> 172.16.2.2 0 0 64514 i
edge1.pop2#

edge1.pop2#show ip bgp vpnv4 vrf cus1 172.16.151.0
BGP routing table entry for 64513:1:172.16.151.0/24, version 20
Paths: (3 available, best #2, table cus1)
Multipath: iBGP
Advertised to update-groups:
1
64514
10.0.1.1 (metric 2) from 10.0.4.1 (10.0.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
Originator: 10.0.1.1, Cluster list: 10.0.4.1,
mpls labels in/out nolabel/28
64514
10.0.1.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath, best
Extended Community: RT:64513:100
Originator: 10.0.1.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514, imported path from 64513:2:172.16.151.0/24
10.0.2.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community: RT:64513:100
Originator: 10.0.2.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
edge1.pop2#

edge2.pop2#show ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.0/24 [200/0] via 10.0.2.1, 00:52:55
[200/0] via 10.0.1.1, 00:52:55
B 172.16.251.0/24 [20/0] via 172.16.2.6, 00:51:11
B 172.16.1.4/30 [200/0] via 10.0.2.1, 00:54:55
C 172.16.2.4/30 is directly connected, FastEthernet3/0
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:54:11
B 172.16.2.0/30 [200/0] via 10.0.5.1, 00:54:11
edge2.pop2#show ip bgp vpnv4 vrf cus1
BGP table version is 23, local router ID is 10.0.6.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:2 (default for vrf cus1)
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
* i172.16.1.4/30 10.0.2.1 0 100 0 ?
*>i 10.0.2.1 0 100 0 ?
*>i172.16.2.0/30 10.0.5.1 0 100 0 ?
*> 172.16.2.4/30 0.0.0.0 0 32768 ?
*>i172.16.151.0/24 10.0.1.1 0 100 0 64514 i
* i 10.0.2.1 0 100 0 64514 i
* i 10.0.2.1 0 100 0 64514 i
* i172.16.251.0/24 10.0.5.1 0 100 0 64514 i
*> 172.16.2.6 0 0 64514 i
edge2.pop2#

edge2.pop2#show ip bgp vpnv4 vrf cus1 172.16.151.0
BGP routing table entry for 64513:2:172.16.151.0/24, version 19
Paths: (3 available, best #1, table cus1)
Multipath: iBGP
Advertised to update-groups:
1
64514, imported path from 64513:1:172.16.151.0/24
10.0.1.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath, best
Extended Community: RT:64513:100
Originator: 10.0.1.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514
10.0.2.1 (metric 2) from 10.0.3.1 (10.0.3.1)
Origin IGP, metric 0, localpref 100, valid, internal, multipath
Extended Community: RT:64513:100
Originator: 10.0.2.1, Cluster list: 10.0.3.1,
mpls labels in/out nolabel/28
64514
10.0.2.1 (metric 2) from 10.0.4.1 (10.0.4.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
Originator: 10.0.2.1, Cluster list: 10.0.4.1,
mpls labels in/out nolabel/28
edge2.pop2#

No comments:

Post a Comment