Saturday, January 7, 2012

Implementing MPLS L3 Hub and Spoke VPN with redundant Hub_LAB




Scenario: An ISP wants to offer MPLS L3 VPN Hub and Spoke Services to its customer along with the the need to provide the HUB servcies in alternate redundant way such that HUB1 will be primary for spoke-A, secondary for spoke-B HUB2 will be primary for spoke-B, secondary for spoke-A


Design Consideration and Solution:


1. HUB & Spoke Services

We will require 2 VRFs on the HUB-PEs viz one Hub_Ingress VRF to collect the routes from the remote spoke PE and send it towards the HUB and one Hub_Egress VRF to send the Hub_Routes as well as remote Spoke Routes from the HUB back to the MP-iBGP cloud. Having said that we would need two logical L3 peering between HUB PE-CE . One peering to be part of Hub_Ingress VRF and other Peering to be part of Hub_Egress VRF..We will have two eBGP neighbourship between HUB PE-CE ie one per VRF..

Also an important point to consider here is that because of default AS-Path Loop Prevention mechanism of BGP on the HUB-PEs under HUB_Egress VRF BGP Neighbourship config we need to add " allowas-in " command so that the spokes routes sent via HUB_Ingress VRF are not dropped when coming back to the HUB PE.


2. Alternate Redundant HUB Services to Spokes


To achive the deisgn such that Spoke 1 is services by HUB1 as Primary and HUB2 as Secondary and vice-versa for Spoke 2 we would need to design the RTs in such a way that on the remote spoke PE we can macth on the unique RT value and change the local preference of the HUB_PE2 routes under Spoke1_VRF to Lower Value so that Spoke1 prefers HUB1 PE as Primary and similarly we need to macth on the unique RT value and change the local preference of the HUB_PE2 routes under Spoke2_VRF to Lower Value so that Spoke1 prefers HUB1 PE as Primary

So from the above points the VRF Design would be as below


HUB-PE1


VRF: HUB1_Ingress
rd 64513:1
route-target import 64513:200
route-target import 64513:300


VRF: HUB1_Egress
rd 64513:2
route-target export 64513:100


HUB-PE2

VRF: HUB2_Ingress
rd 64513:3
route-target import 64513:200
route-target import 64513:300

VRF: HUB1_Egress
rd 64513:4
route-target export 64513:400


Spoke-PE

VRF: Spoke1
rd 64513:5
route-target import 64513:100
route-target import 64513:400
route-target export 64513:200


VRF: Spoke2
rd 64513:6
route-target import 64513:100
route-target import 64513:400
route-target export 64513:300


Also on Spoke PE we need to apply inbound import-map to change the LP to higher value as discussed above


SPoke PE


ip vrf Spoke1
import map HUB1
!
ip vrf Spoke2
import map HUB2
!
route-map HUB1 permit 10
match extcommunity HUB2
set local-preference 50
!
route-map HUB1 permit 20
!
route-map HUB2 permit 10
match extcommunity HUB1
set local-preference 50
!
route-map HUB2 permit 20
!
ip extcommunity-list standard HUB1 permit rt 64513:100
ip extcommunity-list standard HUB2 permit rt 64513:400

Also to ensure that HUB_CE to Spoke1 Traffic flows via HUB1-PE1 and HUB_CE to Spoke2

Traffic flows via HUB2-PE2 we use standard BGP community tagging at PE1 for Spoke2 routes and at PE2 for Spoke1 routes such that on HUB1 while redistributing BGP to OSPF we set the metric for Spoke2 routes to higher value and same ways on HUB2 while redistributing BGP to OSPF we set the metric for Spoke1 routes to higher value

ISP IGP used ISIS Level-2
Hub PE-CE ROuting Protocol used eBGP
Spoke PE-CE ROuting Protocol used OSPF Area 0
ISP AS used 64513
HUB1 AS used 64514
HUB2 AS used 64515
HUB_CE IGP used OSPF Area 0
Standard Community for Spoke1 64513:2000
Standard Community for Spoke2 64513:3000
**************************************************************************************
edge1.pop1#sh running-config
Building configuration...

Current configuration : 3282 bytes
!
! Last configuration change at 00:14:34 UTC Sun Jan 8 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf HUB1_Egress
rd 64513:2
route-target export 64513:100
!
ip vrf HUB1_Ingress
rd 64513:1
route-target import 64513:200
route-target import 64513:300
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description HUB1_Ingress
ip vrf forwarding HUB1_Ingress
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0.100
description HUB1_Egress
encapsulation dot1Q 100
ip vrf forwarding HUB1_Egress
ip address 172.16.1.5 255.255.255.252
!
interface FastEthernet1/1
description edge2.pop1
ip address 10.0.30.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/0
description edge1.pop2
ip address 10.0.20.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/1
description rr.pop1
ip address 10.0.10.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.0010.0000.1001.00
is-type level-2-only
!
router bgp 64513
no synchronization
bgp router-id 10.0.1.1
bgp log-neighbor-changes
neighbor mp-ibgp peer-group
neighbor mp-ibgp remote-as 64513
neighbor mp-ibgp update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp
neighbor 10.0.4.1 peer-group mp-ibgp
no auto-summary
!
address-family vpnv4
neighbor mp-ibgp send-community extended
neighbor mp-ibgp next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf HUB1_Egress
no synchronization
redistribute connected
neighbor 172.16.1.6 remote-as 64514
neighbor 172.16.1.6 activate
neighbor 172.16.1.6 allowas-in 5
neighbor 172.16.1.6 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf HUB1_Ingress
no synchronization
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 send-community
neighbor 172.16.1.2 soft-reconfiguration inbound
neighbor 172.16.1.2 route-map Spoke2 out
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip extcommunity-list standard Spoke2 permit rt 64513:300
ip bgp-community new-format
!
!
!
route-map Spoke2 permit 10
match extcommunity Spoke2
set community 64513:3000
!
route-map Spoke2 permit 20
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop1#

edge2.pop1#sh running-config
Building configuration...

Current configuration : 3506 bytes
!
! Last configuration change at 00:20:15 UTC Sun Jan 8 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge2.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf HUB2_Egress
rd 64513:4
route-target export 64513:400
!
ip vrf HUB2_Ingress
rd 64513:3
route-target import 64513:200
route-target import 64513:300
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description HUB2_Ingress
ip vrf forwarding HUB2_Ingress
ip address 172.16.2.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0.100
description HUB2_Egress
encapsulation dot1Q 100
ip vrf forwarding HUB2_Egress
ip address 172.16.2.5 255.255.255.252
!
interface FastEthernet1/1
description edge1.pop1
ip address 10.0.30.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/0
description edge1.pop2
ip address 10.0.40.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/1
description rr.pop2
ip address 10.0.50.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.0010.0000.2001.00
is-type level-2-only
!
router bgp 64513
bgp router-id 10.0.2.1
bgp log-neighbor-changes
neighbor mp-ibgp peer-group
neighbor mp-ibgp remote-as 64513
neighbor mp-ibgp update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp
neighbor 10.0.4.1 peer-group mp-ibgp
neighbor 172.16.2.2 remote-as 64515
!
address-family ipv4
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor mp-ibgp send-community extended
neighbor mp-ibgp next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf HUB2_Egress
no synchronization
redistribute connected
neighbor 172.16.2.6 remote-as 64515
neighbor 172.16.2.6 activate
neighbor 172.16.2.6 allowas-in 5
neighbor 172.16.2.6 soft-reconfiguration inbound
exit-address-family
!
address-family ipv4 vrf HUB2_Ingress
no synchronization
redistribute connected
neighbor 172.16.2.2 remote-as 64515
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 send-community
neighbor 172.16.2.2 soft-reconfiguration inbound
neighbor 172.16.2.2 route-map Spoke1 out
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip extcommunity-list standard Spoke1 permit rt 64513:200
ip bgp-community new-format
!
!
!
route-map Spoke1 permit 10
match extcommunity Spoke1
set community 64513:2000
!
route-map Spoke1 permit 20
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge2.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 3808 bytes
!
! Last configuration change at 23:40:26 UTC Sat Jan 7 2012
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf Spoke1
rd 64513:5
import map HUB1
route-target export 64513:200
route-target import 64513:100
route-target import 64513:400
!
ip vrf Spoke2
rd 64513:6
import map HUB2
route-target export 64513:300
route-target import 64513:100
route-target import 64513:400
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.5.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description edge1.pop1
ip address 10.0.20.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description edge2.pop1
ip address 10.0.40.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/0
description rr.pop1
ip address 10.0.60.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet2/1
description rr.pop2
ip address 10.0.70.1 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet3/0
description Spoke1
ip vrf forwarding Spoke1
ip address 172.16.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet3/1
description Spoke2
ip vrf forwarding Spoke2
ip address 172.16.4.1 255.255.255.252
duplex auto
speed auto
!
router ospf 10 vrf Spoke1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.3.0 0.0.0.3 area 0
!
router ospf 20 vrf Spoke2
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.4.0 0.0.0.3 area 0
!
router isis
net 49.0001.0010.0000.5001.00
is-type level-2-only
!
router bgp 64513
bgp router-id 10.0.5.1
bgp log-neighbor-changes
neighbor mp-ibgp peer-group
neighbor mp-ibgp remote-as 64513
neighbor mp-ibgp update-source Loopback0
neighbor 10.0.3.1 peer-group mp-ibgp
neighbor 10.0.4.1 peer-group mp-ibgp
!
address-family ipv4
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor mp-ibgp send-community extended
neighbor mp-ibgp next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf Spoke1
no synchronization
redistribute connected
redistribute ospf 10 vrf Spoke1 match internal external 1 external 2
exit-address-family
!
address-family ipv4 vrf Spoke2
no synchronization
redistribute connected
redistribute ospf 20 vrf Spoke2 match internal external 1 external 2
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip extcommunity-list standard HUB1 permit rt 64513:100
ip extcommunity-list standard HUB2 permit rt 64513:400
!
!
!
route-map HUB2 permit 10
match extcommunity HUB1
set local-preference 50
!
route-map HUB2 permit 20
!
route-map HUB1 permit 10
match extcommunity HUB2
set local-preference 50
!
route-map HUB1 permit 20
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop2#

rr.pop1#sh running-config
Building configuration...

Current configuration : 1695 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rr.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
description edge1.pop1
ip address 10.0.10.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet0/1
description edge1.pop2
ip address 10.0.60.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.0010.0000.3001.00
is-type level-2-only
!
router bgp 64513
no synchronization
bgp router-id 10.0.3.1
bgp cluster-id 10.0.3.1
bgp log-neighbor-changes
neighbor mp-ibgp peer-group
neighbor mp-ibgp remote-as 64513
neighbor mp-ibgp update-source Loopback0
neighbor 10.0.1.1 peer-group mp-ibgp
neighbor 10.0.2.1 peer-group mp-ibgp
neighbor 10.0.5.1 peer-group mp-ibgp
no auto-summary
!
address-family vpnv4
neighbor mp-ibgp send-community extended
neighbor mp-ibgp route-reflector-client
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.5.1 activate
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

rr.pop1#

rr.pop2#sh running-config
Building configuration...

Current configuration : 1695 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rr.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
mpls label protocol ldp
mpls ldp router-id Loopback0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
description edge2.pop1
ip address 10.0.50.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet0/1
description edge1.pop2
ip address 10.0.70.2 255.255.255.252
ip router isis
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.0010.0000.4001.00
is-type level-2-only
!
router bgp 64513
no synchronization
bgp router-id 10.0.4.1
bgp cluster-id 10.0.4.1
bgp log-neighbor-changes
neighbor mp-ibgp peer-group
neighbor mp-ibgp remote-as 64513
neighbor mp-ibgp update-source Loopback0
neighbor 10.0.1.1 peer-group mp-ibgp
neighbor 10.0.2.1 peer-group mp-ibgp
neighbor 10.0.5.1 peer-group mp-ibgp
no auto-summary
!
address-family vpnv4
neighbor mp-ibgp send-community extended
neighbor mp-ibgp route-reflector-client
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.5.1 activate
exit-address-family
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

rr.pop2#

Spoke1.pop2#sh running-config
Building configuration...

Current configuration : 848 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke1.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.201.1 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 172.16.201.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

Spoke1.pop2#


Spoke2.pop2#sh running-config
Building configuration...

Current configuration : 786 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke2.pop2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.251.1 255.255.255.255
!
interface FastEthernet0/0
ip address 172.16.4.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 20
router-id 172.16.251.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Spoke2.pop2#
HUB1.pop1#sh running-config
Building configuration...

Current configuration : 1715 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HUB1.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description HUB1_Ingress
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/0.100
description HUB1_Egress
encapsulation dot1Q 100
ip address 172.16.1.6 255.255.255.252
no snmp trap link-status
!
interface FastEthernet0/1
description HUB2
ip address 172.16.10.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
description HUB2
ip address 172.16.30.1 255.255.255.252
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 172.16.10.2
log-adjacency-changes
redistribute bgp 64514 metric-type 1 subnets route-map Spoke1
network 172.16.10.0 0.0.0.3 area 0
!
router bgp 64514
no synchronization
bgp router-id 172.16.1.2
bgp log-neighbor-changes
network 172.16.10.0 mask 255.255.255.252
network 172.16.151.1 mask 255.255.255.255
neighbor eBGP peer-group
neighbor eBGP remote-as 64513
neighbor eBGP soft-reconfiguration inbound
neighbor 172.16.1.1 peer-group eBGP
neighbor 172.16.1.5 peer-group eBGP
no auto-summary
!
no ip http server
ip classless
!
!
ip bgp-community new-format
ip community-list standard Spoke1 permit 64513:3000
!
!
route-map Spoke1 permit 10
match community Spoke1
set metric 3000
!
route-map Spoke1 permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

HUB1.pop1#

HUB2.pop1#sh running-config
Building configuration...

Current configuration : 1674 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HUB2.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description HUB2_Ingress
ip address 172.16.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/0.100
description HUB2_Egress
encapsulation dot1Q 100
ip address 172.16.2.6 255.255.255.252
no snmp trap link-status
!
interface FastEthernet0/1
description HUB_CE
ip address 172.16.20.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 172.16.20.2
log-adjacency-changes
redistribute bgp 64515 metric-type 1 subnets route-map Spoke2
network 172.16.20.0 0.0.0.3 area 0
!
router bgp 64515
no synchronization
bgp router-id 172.16.2.2
bgp log-neighbor-changes
network 172.16.20.0 mask 255.255.255.252
network 172.16.151.1 mask 255.255.255.255
neighbor eBGP peer-group
neighbor eBGP remote-as 64513
neighbor eBGP soft-reconfiguration inbound
neighbor 172.16.2.1 peer-group eBGP
neighbor 172.16.2.5 peer-group eBGP
no auto-summary
!
no ip http server
ip classless
!
!
ip bgp-community new-format
ip community-list standard Spoke2 permit 64513:2000
!
!
route-map Spoke2 permit 10
match community Spoke2
set metric 2000
!
route-map Spoke2 permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

HUB2.pop1#

HUBCE.pop1#sh running-config
Building configuration...

Current configuration : 899 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HUBCE.pop1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.151.1 255.255.255.255
!
interface FastEthernet0/0
description HUB1
ip address 172.16.10.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description HUB2
ip address 172.16.20.1 255.255.255.252
duplex auto
speed auto
!
router ospf 10
router-id 172.16.151.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

HUBCE.pop1#
*****************
******************************************

HUBCE.pop1#traceroute 172.16.201.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.10.2 80 msec 76 msec 128 msec
2 172.16.1.1 208 msec 432 msec 376 msec
3 172.16.3.1 488 msec 212 msec 212 msec
4 172.16.3.2 440 msec * 316 msec
HUBCE.pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.20.2 104 msec 56 msec 172 msec
2 172.16.2.1 192 msec 204 msec 292 msec
3 172.16.4.1 332 msec 508 msec 344 msec
4 172.16.4.2 536 msec * 272 msec
HUBCE.pop1#


Spoke1.pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.3.1 112 msec 160 msec 200 msec
2 172.16.1.5 272 msec 264 msec 324 msec
3 172.16.1.6 236 msec 216 msec 196 msec
4 172.16.10.1 244 msec 536 msec *
Spoke1.pop2#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.3.1 148 msec 128 msec 100 msec
2 172.16.1.5 392 msec 208 msec 432 msec
3 172.16.1.6 312 msec 96 msec 144 msec
4 172.16.1.1 208 msec 144 msec 424 msec
5 172.16.4.1 432 msec 288 msec 376 msec
6 172.16.4.2 520 msec 436 msec *
Spoke1.pop2#

Spoke2.pop2#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.4.1 44 msec 88 msec 64 msec
2 172.16.2.5 272 msec 400 msec 356 msec
3 172.16.2.6 88 msec 252 msec 148 msec
4 172.16.20.1 292 msec 440 msec *

Spoke2.pop2#traceroute 172.16.201.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.4.1 116 msec 116 msec 144 msec
2 172.16.2.5 360 msec 356 msec 544 msec
3 172.16.2.6 328 msec 272 msec 268 msec
4 172.16.2.1 372 msec 276 msec 324 msec
5 172.16.3.1 396 msec 548 msec 760 msec
6 172.16.3.2 1304 msec 844 msec 948 msec
Spoke2.pop2#

HUBCE.pop1#traceroute 172.16.201.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.20.2 204 msec
172.16.10.2 128 msec
172.16.20.2 84 msec
2 172.16.1.1 392 msec
172.16.2.1 360 msec
172.16.1.1 568 msec
3 172.16.3.1 276 msec 264 msec 236 msec
4 172.16.3.2 536 msec * 484 msec
HUBCE.pop1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.20.2 40 msec
172.16.10.2 304 msec
172.16.20.2 68 msec
2 172.16.1.1 424 msec
172.16.2.1 676 msec
172.16.1.1 424 msec
3 172.16.4.1 288 msec 280 msec 300 msec
4 172.16.4.2 568 msec * 360 msec
HUBCE.pop1#

HUBCE.pop1#show ip ospf database external

OSPF Router with ID (172.16.151.1) (Process ID 10)

Type-5 AS External Link States

Routing Bit Set on this LSA
LS age: 529
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.3.0 (External Network Number )
Advertising Router: 172.16.10.2
LS Seq Number: 80000001
Checksum: 0xE6C9
Length: 36
Network Mask: /30
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 64513

Routing Bit Set on this LSA
LS age: 1108
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.3.0 (External Network Number )
Advertising Router: 172.16.20.2
LS Seq Number: 80000003
Checksum: 0xF9D3
Length: 36
Network Mask: /30
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 2000
Forward Address: 0.0.0.0
External Route Tag: 64513

LS age: 539
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.4.0 (External Network Number )
Advertising Router: 172.16.10.2
LS Seq Number: 80000002
Checksum: 0x6A81
Length: 36
Network Mask: /30
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 3000
Forward Address: 0.0.0.0
External Route Tag: 64513

Routing Bit Set on this LSA
LS age: 1817
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.4.0 (External Network Number )
Advertising Router: 172.16.20.2
LS Seq Number: 80000002
Checksum: 0x9311
Length: 36
Network Mask: /30
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 64513

Routing Bit Set on this LSA
LS age: 529
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.201.1 (External Network Number )
Advertising Router: 172.16.10.2
LS Seq Number: 80000001
Checksum: 0x6481
Length: 36
Network Mask: /32
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 64513

Routing Bit Set on this LSA
LS age: 1108
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.201.1 (External Network Number )
Advertising Router: 172.16.20.2
LS Seq Number: 80000004
Checksum: 0x758C
Length: 36
Network Mask: /32
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 2000
Forward Address: 0.0.0.0
External Route Tag: 64513

LS age: 539
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.251.1 (External Network Number )
Advertising Router: 172.16.10.2
LS Seq Number: 80000002
Checksum: 0xCA25
Length: 36
Network Mask: /32
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 3000
Forward Address: 0.0.0.0
External Route Tag: 64513

Routing Bit Set on this LSA
LS age: 1795
Options: (No TOS-capability, DC)
LS Type: AS External Link
Link State ID: 172.16.251.1 (External Network Number )
Advertising Router: 172.16.20.2
LS Seq Number: 80000001
Checksum: 0xF5B3
Length: 36
Network Mask: /32
Metric Type: 1 (Comparable directly to link state metric)
TOS: 0
Metric: 1
Forward Address: 0.0.0.0
External Route Tag: 64513

HUBCE.pop1#

HUB1.pop1#show ip bgp 172.16.201.1
BGP routing table entry for 172.16.201.1/32, version 6
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
1
64513, (received & used)
172.16.1.1 from 172.16.1.1 (10.0.1.1)
Origin incomplete, localpref 100, valid, external, best
HUB1.pop1#show ip bgp 172.16.251.1
BGP routing table entry for 172.16.251.1/32, version 7
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
1
64513, (received & used)
172.16.1.1 from 172.16.1.1 (10.0.1.1)
Origin incomplete, localpref 100, valid, external, best
Community: 64513:3000
HUB1.pop1#

HUB2.pop1#show ip bgp 172.16.201.1
BGP routing table entry for 172.16.201.1/32, version 28
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
2
64513, (received & used)
172.16.2.1 from 172.16.2.1 (10.0.2.1)
Origin incomplete, localpref 100, valid, external, best
Community: 64513:2000
HUB2.pop1#show ip bgp 172.16.251.1
BGP routing table entry for 172.16.251.1/32, version 24
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to update-groups:
2
64513, (received & used)
172.16.2.1 from 172.16.2.1 (10.0.2.1)
Origin incomplete, localpref 100, valid, external, best
HUB2.pop1#

HUBCE.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.16.151.1/32 is directly connected, Loopback0
O E1 172.16.251.1/32 [110/2] via 172.16.20.2, 00:05:01, FastEthernet0/1
O E1 172.16.201.1/32 [110/2] via 172.16.10.2, 00:04:51, FastEthernet0/0
C 172.16.20.0/30 is directly connected, FastEthernet0/1
C 172.16.10.0/30 is directly connected, FastEthernet0/0
O E1 172.16.4.0/30 [110/2] via 172.16.20.2, 00:05:01, FastEthernet0/1
O E1 172.16.3.0/30 [110/2] via 172.16.10.2, 00:04:51, FastEthernet0/0
HUBCE.pop1#

HUB1.pop1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O 172.16.151.1/32 [110/2] via 172.16.10.1, 00:06:39, FastEthernet0/1
B 172.16.251.1/32 [20/0] via 172.16.1.1, 00:07:17
B 172.16.201.1/32 [20/0] via 172.16.1.1, 00:07:17
O 172.16.20.0/30 [110/2] via 172.16.10.1, 00:06:39, FastEthernet0/1
C 172.16.10.0/30 is directly connected, FastEthernet0/1
B 172.16.4.0/30 [20/0] via 172.16.1.1, 00:07:17
C 172.16.1.4/30 is directly connected, FastEthernet0/0.100
C 172.16.1.0/30 is directly connected, FastEthernet0/0
B 172.16.3.0/30 [20/0] via 172.16.1.1, 00:07:17
HUB1.pop1#

HUB2.pop1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
O 172.16.151.1/32 [110/2] via 172.16.20.1, 00:07:05, FastEthernet0/1
B 172.16.251.1/32 [20/0] via 172.16.2.1, 00:25:40
B 172.16.201.1/32 [20/0] via 172.16.2.1, 00:11:23
C 172.16.20.0/30 is directly connected, FastEthernet0/1
O 172.16.10.0/30 [110/2] via 172.16.20.1, 00:07:05, FastEthernet0/1
B 172.16.4.0/30 [20/0] via 172.16.2.1, 00:28:27
C 172.16.2.4/30 is directly connected, FastEthernet0/0.100
C 172.16.2.0/30 is directly connected, FastEthernet0/0
B 172.16.3.0/30 [20/0] via 172.16.2.1, 00:11:23
HUB2.pop1#


Spoke1.pop2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 11 subnets, 2 masks
O E2 172.16.151.1/32 [110/1] via 172.16.3.1, 00:08:59, FastEthernet0/0
O E2 172.16.251.1/32 [110/1] via 172.16.3.1, 00:13:16, FastEthernet0/0
C 172.16.201.1/32 is directly connected, Loopback0
O E2 172.16.20.0/30 [110/1] via 172.16.3.1, 00:08:30, FastEthernet0/0
O E2 172.16.10.0/30 [110/1] via 172.16.3.1, 00:09:20, FastEthernet0/0
O E2 172.16.4.0/30 [110/1] via 172.16.3.1, 00:13:17, FastEthernet0/0
O E2 172.16.1.4/30 [110/1] via 172.16.3.1, 00:13:24, FastEthernet0/0
O E2 172.16.2.4/30 [110/1] via 172.16.3.1, 00:13:24, FastEthernet0/0
O E2 172.16.1.0/30 [110/1] via 172.16.3.1, 00:13:24, FastEthernet0/0
O E2 172.16.2.0/30 [110/1] via 172.16.3.1, 00:13:23, FastEthernet0/0
C 172.16.3.0/30 is directly connected, FastEthernet0/0
Spoke1.pop2#

Spoke2.pop2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 11 subnets, 2 masks
O E2 172.16.151.1/32 [110/1] via 172.16.4.1, 00:08:46, FastEthernet0/0
C 172.16.251.1/32 is directly connected, Loopback0
O E2 172.16.201.1/32 [110/1] via 172.16.4.1, 00:13:03, FastEthernet0/0
O E2 172.16.20.0/30 [110/1] via 172.16.4.1, 00:08:17, FastEthernet0/0
O E2 172.16.10.0/30 [110/1] via 172.16.4.1, 00:09:07, FastEthernet0/0
C 172.16.4.0/30 is directly connected, FastEthernet0/0
O E2 172.16.1.4/30 [110/1] via 172.16.4.1, 00:13:10, FastEthernet0/0
O E2 172.16.2.4/30 [110/1] via 172.16.4.1, 00:13:10, FastEthernet0/0
O E2 172.16.1.0/30 [110/1] via 172.16.4.1, 00:13:10, FastEthernet0/0
O E2 172.16.2.0/30 [110/1] via 172.16.4.1, 00:13:10, FastEthernet0/0
O E2 172.16.3.0/30 [110/1] via 172.16.4.1, 00:13:03, FastEthernet0/0
Spoke2.pop2#


edge1.pop1#show ip route vrf HUB1_Egress

Routing Table: HUB1_Egress
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
B 172.16.1.0/30 [20/0] via 172.16.1.6, 00:19:18
C 172.16.1.4/30 is directly connected, FastEthernet1/0.100
L 172.16.1.5/32 is directly connected, FastEthernet1/0.100
B 172.16.3.0/30 [20/0] via 172.16.1.6, 00:13:39
B 172.16.4.0/30 [20/0] via 172.16.1.6, 00:13:39
B 172.16.10.0/30 [20/0] via 172.16.1.6, 00:09:46
B 172.16.151.1/32 [20/2] via 172.16.1.6, 00:06:21
B 172.16.201.1/32 [20/0] via 172.16.1.6, 00:13:39
B 172.16.251.1/32 [20/0] via 172.16.1.6, 00:13:39
edge1.pop1#show ip route vrf HUB1_Ingress

Routing Table: HUB1_Ingress
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.1.0/30 is directly connected, FastEthernet1/0
L 172.16.1.1/32 is directly connected, FastEthernet1/0
B 172.16.3.0/30 [200/0] via 10.0.5.1, 00:13:46
B 172.16.4.0/30 [200/0] via 10.0.5.1, 00:13:46
B 172.16.10.0/30 [20/0] via 172.16.1.2, 00:09:49
B 172.16.151.1/32 [20/2] via 172.16.1.2, 00:06:24
B 172.16.201.1/32 [200/2] via 10.0.5.1, 00:13:46
B 172.16.251.1/32 [200/2] via 10.0.5.1, 00:13:46
edge1.pop1#

edge2.pop1#show ip route vrf HUB2_Egress

Routing Table: HUB2_Egress
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
B 172.16.2.0/30 [20/0] via 172.16.2.6, 00:16:19
C 172.16.2.4/30 is directly connected, FastEthernet1/0.100
L 172.16.2.5/32 is directly connected, FastEthernet1/0.100
B 172.16.3.0/30 [20/0] via 172.16.2.6, 00:14:10
B 172.16.4.0/30 [20/0] via 172.16.2.6, 00:14:10
B 172.16.20.0/30 [20/0] via 172.16.2.6, 00:09:17
B 172.16.151.1/32 [20/2] via 172.16.2.6, 00:09:48
B 172.16.201.1/32 [20/0] via 172.16.2.6, 00:14:10
B 172.16.251.1/32 [20/0] via 172.16.2.6, 00:14:10
edge2.pop1#show ip route vrf HUB2_Ingress

Routing Table: HUB2_Ingress
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.2.0/30 is directly connected, FastEthernet1/0
L 172.16.2.1/32 is directly connected, FastEthernet1/0
B 172.16.3.0/30 [200/0] via 10.0.5.1, 00:14:15
B 172.16.4.0/30 [200/0] via 10.0.5.1, 00:14:15
B 172.16.20.0/30 [20/0] via 172.16.2.2, 00:09:22
B 172.16.151.1/32 [20/2] via 172.16.2.2, 00:09:53
B 172.16.201.1/32 [200/2] via 10.0.5.1, 00:14:15
B 172.16.251.1/32 [200/2] via 10.0.5.1, 00:14:15
edge2.pop1#

edge1.pop2#show ip route vrf Spoke1

Routing Table: Spoke1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 12 subnets, 2 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:14:32
B 172.16.1.4/30 [200/0] via 10.0.1.1, 00:14:32
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:14:32
B 172.16.2.4/30 [200/0] via 10.0.2.1, 00:14:32
C 172.16.3.0/30 is directly connected, FastEthernet3/0
L 172.16.3.1/32 is directly connected, FastEthernet3/0
B 172.16.4.0/30 [200/0] via 10.0.1.1, 00:14:25
B 172.16.10.0/30 [200/0] via 10.0.1.1, 00:10:28
B 172.16.20.0/30 [200/0] via 10.0.2.1, 00:09:38
B 172.16.151.1/32 [200/2] via 10.0.1.1, 00:07:07

edge1.pop2#show ip route vrf Spoke2

Routing Table: Spoke2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 12 subnets, 2 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:14:34
B 172.16.1.4/30 [200/0] via 10.0.1.1, 00:14:34
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:14:34
B 172.16.2.4/30 [200/0] via 10.0.2.1, 00:14:34
B 172.16.3.0/30 [200/0] via 10.0.2.1, 00:14:27
C 172.16.4.0/30 is directly connected, FastEthernet3/1
L 172.16.4.1/32 is directly connected, FastEthernet3/1
B 172.16.10.0/30 [200/0] via 10.0.1.1, 00:10:30
B 172.16.20.0/30 [200/0] via 10.0.2.1, 00:09:40
B 172.16.151.1/32 [200/2] via 10.0.2.1, 00:10:10
B 172.16.201.1/32 [200/0] via 10.0.2.1, 00:14:29
O 172.16.251.1/32 [110/2] via 172.16.4.2, 00:30:24, FastEthernet3/1
edge1.pop2#

edge1.pop2#show ip bgp vpnv4 vrf Spoke1
BGP table version is 50, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:5 (default for vrf Spoke1)
*>i172.16.1.0/30 10.0.1.1 0 500 0 64514 64513 ?
*>i172.16.1.4/30 10.0.1.1 0 500 0 ?
*>i172.16.2.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.2.4/30 10.0.2.1 0 100 0 ?
* i172.16.3.0/30 10.0.2.1 0 100 0 64515 64513 ?
* i 10.0.1.1 0 500 0 64514 64513 ?
*> 0.0.0.0 0 32768 ?
* i172.16.4.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i 10.0.1.1 0 500 0 64514 64513 ?
*>i172.16.10.0/30 10.0.1.1 0 500 0 64514 i
*>i172.16.20.0/30 10.0.2.1 0 100 0 64515 i
*>i172.16.151.1/32 10.0.1.1 2 500 0 64514 i
* i 10.0.2.1 2 100 0 64515 i
* i172.16.201.1/32 10.0.2.1 0 100 0 64515 64513 ?
* i 10.0.1.1 0 500 0 64514 64513 ?
*> 172.16.3.2 2 32768 ?
* i172.16.251.1/32 10.0.2.1 0 100 0 64515 64513 ?
*>i 10.0.1.1 0 500 0 64514 64513 ?
edge1.pop2#
edge1.pop2#

edge1.pop2#show ip bgp vpnv4 vrf Spoke2
BGP table version is 50, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:6 (default for vrf Spoke2)
*>i172.16.1.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.1.4/30 10.0.1.1 0 100 0 ?
*>i172.16.2.0/30 10.0.2.1 0 500 0 64515 64513 ?
*>i172.16.2.4/30 10.0.2.1 0 500 0 ?
*>i172.16.3.0/30 10.0.2.1 0 500 0 64515 64513 ?
* i 10.0.1.1 0 100 0 64514 64513 ?
* i172.16.4.0/30 10.0.2.1 0 500 0 64515 64513 ?
* i 10.0.1.1 0 100 0 64514 64513 ?
*> 0.0.0.0 0 32768 ?
*>i172.16.10.0/30 10.0.1.1 0 100 0 64514 i
*>i172.16.20.0/30 10.0.2.1 0 500 0 64515 i
* i172.16.151.1/32 10.0.1.1 2 100 0 64514 i
*>i 10.0.2.1 2 500 0 64515 i
*>i172.16.201.1/32 10.0.2.1 0 500 0 64515 64513 ?
* i 10.0.1.1 0 100 0 64514 64513 ?
* i172.16.251.1/32 10.0.2.1 0 500 0 64515 64513 ?
* i 10.0.1.1 0 100 0 64514 64513 ?
*> 172.16.4.2 2 32768 ?
edge1.pop2#

rr.pop1#show ip bgp vpnv4 all
BGP table version is 123, local router ID is 10.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
*>i172.16.10.0/30 10.0.1.1 0 100 0 64514 i
*>i172.16.151.1/32 10.0.1.1 2 100 0 64514 i
Route Distinguisher: 64513:2
*>i172.16.1.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.1.4/30 10.0.1.1 0 100 0 ?
*>i172.16.3.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.4.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.10.0/30 10.0.1.1 0 100 0 64514 i
*>i172.16.151.1/32 10.0.1.1 2 100 0 64514 i
*>i172.16.201.1/32 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.251.1/32 10.0.1.1 0 100 0 64514 64513 ?
Route Distinguisher: 64513:3
*>i172.16.2.0/30 10.0.2.1 0 100 0 ?
*>i172.16.20.0/30 10.0.2.1 0 100 0 64515 i
*>i172.16.151.1/32 10.0.2.1 2 100 0 64515 i
Route Distinguisher: 64513:4
*>i172.16.2.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.2.4/30 10.0.2.1 0 100 0 ?
*>i172.16.3.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.4.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.20.0/30 10.0.2.1 0 100 0 64515 i
*>i172.16.151.1/32 10.0.2.1 2 100 0 64515 i
*>i172.16.201.1/32 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.251.1/32 10.0.2.1 0 100 0 64515 64513 ?
Route Distinguisher: 64513:5
*>i172.16.3.0/30 10.0.5.1 0 100 0 ?
*>i172.16.201.1/32 10.0.5.1 2 100 0 ?
Route Distinguisher: 64513:6
*>i172.16.4.0/30 10.0.5.1 0 100 0 ?
*>i172.16.251.1/32 10.0.5.1 2 100 0 ?
rr.pop1#

rr.pop2#show ip bgp vpnv4 all
BGP table version is 123, local router ID is 10.0.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
*>i172.16.10.0/30 10.0.1.1 0 100 0 64514 i
*>i172.16.151.1/32 10.0.1.1 2 100 0 64514 i
Route Distinguisher: 64513:2
*>i172.16.1.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.1.4/30 10.0.1.1 0 100 0 ?
*>i172.16.3.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.4.0/30 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.10.0/30 10.0.1.1 0 100 0 64514 i
*>i172.16.151.1/32 10.0.1.1 2 100 0 64514 i
*>i172.16.201.1/32 10.0.1.1 0 100 0 64514 64513 ?
*>i172.16.251.1/32 10.0.1.1 0 100 0 64514 64513 ?
Route Distinguisher: 64513:3
*>i172.16.2.0/30 10.0.2.1 0 100 0 ?
*>i172.16.20.0/30 10.0.2.1 0 100 0 64515 i
*>i172.16.151.1/32 10.0.2.1 2 100 0 64515 i
Route Distinguisher: 64513:4
*>i172.16.2.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.2.4/30 10.0.2.1 0 100 0 ?
*>i172.16.3.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.4.0/30 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.20.0/30 10.0.2.1 0 100 0 64515 i
*>i172.16.151.1/32 10.0.2.1 2 100 0 64515 i
*>i172.16.201.1/32 10.0.2.1 0 100 0 64515 64513 ?
*>i172.16.251.1/32 10.0.2.1 0 100 0 64515 64513 ?
Route Distinguisher: 64513:5
*>i172.16.3.0/30 10.0.5.1 0 100 0 ?
*>i172.16.201.1/32 10.0.5.1 2 100 0 ?
Route Distinguisher: 64513:6
*>i172.16.4.0/30 10.0.5.1 0 100 0 ?
*>i172.16.251.1/32 10.0.5.1 2 100 0 ?
rr.pop2#

edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 No Label 172.16.1.0/30[V] 0 aggregate/HUB1_Ingress
17 No Label 172.16.1.4/30[V] 0 aggregate/HUB1_Egress
18 Pop Label 10.0.2.1/32 0 Fa1/1 10.0.30.2
19 Pop Label 10.0.40.0/30 0 Fa2/0 10.0.20.2
Pop Label 10.0.40.0/30 0 Fa1/1 10.0.30.2
20 Pop Label 10.0.50.0/30 0 Fa1/1 10.0.30.2
21 Pop Label 10.0.5.1/32 540 Fa2/0 10.0.20.2
22 Pop Label 10.0.60.0/30 0 Fa2/1 10.0.10.2
Pop Label 10.0.60.0/30 0 Fa2/0 10.0.20.2
23 Pop Label 10.0.70.0/30 0 Fa2/0 10.0.20.2
24 Pop Label 10.0.3.1/32 11764 Fa2/1 10.0.10.2
25 24 10.0.4.1/32 0 Fa2/0 10.0.20.2
25 10.0.4.1/32 0 Fa1/1 10.0.30.2
26 No Label 172.16.1.0/30[V] 0 Fa1/0.100 172.16.1.6
30 No Label 172.16.10.0/30[V] \
0 Fa1/0 172.16.1.2
31 No Label 172.16.3.0/30[V] 0 Fa1/0.100 172.16.1.6
32 No Label 172.16.4.0/30[V] 0 Fa1/0.100 172.16.1.6
33 No Label 172.16.201.1/32[V] \
0 Fa1/0.100 172.16.1.6
34 No Label 172.16.10.0/30[V] \
0 Fa1/0.100 172.16.1.6
40 No Label 172.16.251.1/32[V] \
1332 Fa1/0.100 172.16.1.6
44 No Label 172.16.151.1/32[V] \
0 Fa1/0 172.16.1.2
45 No Label 172.16.151.1/32[V] \
982 Fa1/0.100 172.16.1.6
edge1.pop1#show ip bgp vpnv4 all labels
Network Next Hop In label/Out label
Route Distinguisher: 64513:1 (HUB1_Ingress)
172.16.1.0/30 0.0.0.0 16/nolabel(HUB1_Ingress)
172.16.3.0/30 10.0.5.1 nolabel/21
172.16.4.0/30 10.0.5.1 nolabel/22
172.16.10.0/30 172.16.1.2 30/nolabel
172.16.151.1/32 172.16.1.2 44/nolabel
172.16.201.1/32 10.0.5.1 nolabel/25
172.16.251.1/32 10.0.5.1 nolabel/26
Route Distinguisher: 64513:2 (HUB1_Egress)
172.16.1.0/30 172.16.1.6 26/nolabel
172.16.1.4/30 172.16.1.6 17/nolabel
0.0.0.0 17/nolabel(HUB1_Egress)
172.16.3.0/30 172.16.1.6 31/nolabel
172.16.4.0/30 172.16.1.6 32/nolabel
172.16.10.0/30 172.16.1.6 34/nolabel
172.16.151.1/32 172.16.1.6 45/nolabel
172.16.201.1/32 172.16.1.6 33/nolabel
172.16.251.1/32 172.16.1.6 40/nolabel
Route Distinguisher: 64513:5
172.16.3.0/30 10.0.5.1 nolabel/21
10.0.5.1 nolabel/21
172.16.201.1/32 10.0.5.1 nolabel/25
10.0.5.1 nolabel/25
Route Distinguisher: 64513:6
172.16.4.0/30 10.0.5.1 nolabel/22
10.0.5.1 nolabel/22
172.16.251.1/32 10.0.5.1 nolabel/26
10.0.5.1 nolabel/26

edge1.pop1#

edge2.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label 10.0.1.1/32 6201 Fa1/1 10.0.30.1
17 Pop Label 10.0.20.0/30 0 Fa1/1 10.0.30.1
Pop Label 10.0.20.0/30 0 Fa2/0 10.0.40.2
18 Pop Label 10.0.10.0/30 0 Fa1/1 10.0.30.1
19 No Label 172.16.2.0/30[V] 0 aggregate/HUB2_Ingress
20 No Label 172.16.2.4/30[V] 0 aggregate/HUB2_Egress
21 Pop Label 10.0.5.1/32 0 Fa2/0 10.0.40.2
22 Pop Label 10.0.60.0/30 0 Fa2/0 10.0.40.2
23 Pop Label 10.0.70.0/30 0 Fa2/0 10.0.40.2
Pop Label 10.0.70.0/30 0 Fa2/1 10.0.50.2
24 24 10.0.3.1/32 0 Fa1/1 10.0.30.1
23 10.0.3.1/32 0 Fa2/0 10.0.40.2
25 Pop Label 10.0.4.1/32 0 Fa2/1 10.0.50.2
27 No Label 172.16.201.1/32[V] \
1258 Fa1/0.100 172.16.2.6
28 No Label 172.16.4.0/30[V] 0 Fa1/0.100 172.16.2.6
30 No Label 172.16.251.1/32[V] \
0 Fa1/0.100 172.16.2.6
31 No Label 172.16.3.0/30[V] 0 Fa1/0.100 172.16.2.6
32 No Label 172.16.2.0/30[V] 0 Fa1/0.100 172.16.2.6
33 No Label 172.16.20.0/30[V] \
0 Fa1/0 172.16.2.2
34 No Label 172.16.20.0/30[V] \
0 Fa1/0.100 172.16.2.6
37 No Label 172.16.151.1/32[V] \
0 Fa1/0 172.16.2.2
38 No Label 172.16.151.1/32[V] \
982 Fa1/0.100 172.16.2.6
edge2.pop1#show ip bgp vpnv4 all labels
Network Next Hop In label/Out label
Route Distinguisher: 64513:3 (HUB2_Ingress)
172.16.2.0/30 0.0.0.0 19/nolabel(HUB2_Ingress)
172.16.3.0/30 10.0.5.1 nolabel/21
172.16.4.0/30 10.0.5.1 nolabel/22
172.16.20.0/30 172.16.2.2 33/nolabel
172.16.151.1/32 172.16.2.2 37/nolabel
172.16.201.1/32 10.0.5.1 nolabel/25
172.16.251.1/32 10.0.5.1 nolabel/26
Route Distinguisher: 64513:4 (HUB2_Egress)
172.16.2.0/30 172.16.2.6 32/nolabel
172.16.2.4/30 172.16.2.6 20/nolabel
0.0.0.0 20/nolabel(HUB2_Egress)
172.16.3.0/30 172.16.2.6 31/nolabel
172.16.4.0/30 172.16.2.6 28/nolabel
172.16.20.0/30 172.16.2.6 34/nolabel
172.16.151.1/32 172.16.2.6 38/nolabel
172.16.201.1/32 172.16.2.6 27/nolabel
172.16.251.1/32 172.16.2.6 30/nolabel
Route Distinguisher: 64513:5
172.16.3.0/30 10.0.5.1 nolabel/21
10.0.5.1 nolabel/21
172.16.201.1/32 10.0.5.1 nolabel/25
10.0.5.1 nolabel/25
Route Distinguisher: 64513:6
172.16.4.0/30 10.0.5.1 nolabel/22
10.0.5.1 nolabel/22
172.16.251.1/32 10.0.5.1 nolabel/26
10.0.5.1 nolabel/26

edge2.pop1#

edge1.pop2#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label 10.0.2.1/32 29420 Fa1/1 10.0.40.1
17 Pop Label 10.0.1.1/32 13437 Fa1/0 10.0.20.1
18 Pop Label 10.0.30.0/30 0 Fa1/0 10.0.20.1
Pop Label 10.0.30.0/30 0 Fa1/1 10.0.40.1
19 Pop Label 10.0.50.0/30 0 Fa1/1 10.0.40.1
Pop Label 10.0.50.0/30 0 Fa2/1 10.0.70.2
20 Pop Label 10.0.10.0/30 0 Fa1/0 10.0.20.1
Pop Label 10.0.10.0/30 0 Fa2/0 10.0.60.2
21 No Label 172.16.3.0/30[V] 0 aggregate/Spoke1
22 No Label 172.16.4.0/30[V] 0 aggregate/Spoke2
23 Pop Label 10.0.3.1/32 14889 Fa2/0 10.0.60.2
24 Pop Label 10.0.4.1/32 20641 Fa2/1 10.0.70.2
25 No Label 172.16.201.1/32[V] \
2800 Fa3/0 172.16.3.2
26 No Label 172.16.251.1/32[V] \
2870 Fa3/1 172.16.4.2
edge1.pop2#show ip bgp vpnv4 all labels
Network Next Hop In label/Out label
Route Distinguisher: 64513:2
172.16.1.0/30 10.0.1.1 nolabel/26
10.0.1.1 nolabel/26
172.16.1.4/30 10.0.1.1 nolabel/17
10.0.1.1 nolabel/17
172.16.3.0/30 10.0.1.1 nolabel/31
10.0.1.1 nolabel/31
172.16.4.0/30 10.0.1.1 nolabel/32
10.0.1.1 nolabel/32
172.16.10.0/30 10.0.1.1 nolabel/34
10.0.1.1 nolabel/34
172.16.151.1/32 10.0.1.1 nolabel/45
10.0.1.1 nolabel/45
172.16.201.1/32 10.0.1.1 nolabel/33
10.0.1.1 nolabel/33
172.16.251.1/32 10.0.1.1 nolabel/40
10.0.1.1 nolabel/40
Route Distinguisher: 64513:4
172.16.2.0/30 10.0.2.1 nolabel/32
10.0.2.1 nolabel/32
172.16.2.4/30 10.0.2.1 nolabel/20
10.0.2.1 nolabel/20
172.16.3.0/30 10.0.2.1 nolabel/31
10.0.2.1 nolabel/31
172.16.4.0/30 10.0.2.1 nolabel/28
10.0.2.1 nolabel/28
172.16.20.0/30 10.0.2.1 nolabel/34
10.0.2.1 nolabel/34
172.16.151.1/32 10.0.2.1 nolabel/38
10.0.2.1 nolabel/38
172.16.201.1/32 10.0.2.1 nolabel/27
10.0.2.1 nolabel/27
172.16.251.1/32 10.0.2.1 nolabel/30
10.0.2.1 nolabel/30
Route Distinguisher: 64513:5 (Spoke1)
172.16.1.0/30 10.0.1.1 nolabel/26
172.16.1.4/30 10.0.1.1 nolabel/17
172.16.2.0/30 10.0.2.1 nolabel/32
172.16.2.4/30 10.0.2.1 nolabel/20
172.16.3.0/30 10.0.1.1 21/31
10.0.2.1 21/31
0.0.0.0 21/nolabel(Spoke1)
172.16.4.0/30 10.0.1.1 nolabel/32
10.0.2.1 nolabel/28
172.16.10.0/30 10.0.1.1 nolabel/34
172.16.20.0/30 10.0.2.1 nolabel/34
172.16.151.1/32 10.0.1.1 nolabel/45
10.0.2.1 nolabel/38
172.16.201.1/32 10.0.1.1 25/33
10.0.2.1 25/27
172.16.3.2 25/nolabel
172.16.251.1/32 10.0.1.1 nolabel/40
10.0.2.1 nolabel/30
Route Distinguisher: 64513:6 (Spoke2)
172.16.1.0/30 10.0.1.1 nolabel/26
172.16.1.4/30 10.0.1.1 nolabel/17
172.16.2.0/30 10.0.2.1 nolabel/32
172.16.2.4/30 10.0.2.1 nolabel/20
172.16.3.0/30 10.0.1.1 nolabel/31
10.0.2.1 nolabel/31
172.16.4.0/30 10.0.1.1 22/32
10.0.2.1 22/28
0.0.0.0 22/nolabel(Spoke2)
172.16.10.0/30 10.0.1.1 nolabel/34
172.16.20.0/30 10.0.2.1 nolabel/34
172.16.151.1/32 10.0.1.1 nolabel/45
10.0.2.1 nolabel/38
172.16.201.1/32 10.0.1.1 nolabel/33
10.0.2.1 nolabel/27
172.16.251.1/32 10.0.1.1 26/40
10.0.2.1 26/30
172.16.4.2 26/nolabel

edge1.pop2#

rr.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.5.1/32 0 Fa0/1 10.0.60.1
17 Pop tag 10.0.20.0/30 0 Fa0/1 10.0.60.1
Pop tag 10.0.20.0/30 0 Fa0/0 10.0.10.1
18 Pop tag 10.0.40.0/30 0 Fa0/1 10.0.60.1
19 Pop tag 10.0.70.0/30 0 Fa0/1 10.0.60.1
20 Pop tag 10.0.1.1/32 0 Fa0/0 10.0.10.1
21 16 10.0.2.1/32 0 Fa0/1 10.0.60.1
18 10.0.2.1/32 0 Fa0/0 10.0.10.1
22 Pop tag 10.0.30.0/30 0 Fa0/0 10.0.10.1
23 19 10.0.50.0/30 0 Fa0/1 10.0.60.1
20 10.0.50.0/30 0 Fa0/0 10.0.10.1
24 24 10.0.4.1/32 0 Fa0/1 10.0.60.1
rr.pop1#show ip bgp vpnv4 all la
rr.pop1#show ip bgp vpnv4 all labels
Network Next Hop In label/Out label
Route Distinguisher: 64513:1
172.16.1.0/30 10.0.1.1 nolabel/16
172.16.10.0/30 10.0.1.1 nolabel/30
172.16.151.1/32 10.0.1.1 nolabel/44
Route Distinguisher: 64513:2
172.16.1.0/30 10.0.1.1 nolabel/26
172.16.1.4/30 10.0.1.1 nolabel/17
172.16.3.0/30 10.0.1.1 nolabel/31
172.16.4.0/30 10.0.1.1 nolabel/32
172.16.10.0/30 10.0.1.1 nolabel/34
172.16.151.1/32 10.0.1.1 nolabel/45
172.16.201.1/32 10.0.1.1 nolabel/33
172.16.251.1/32 10.0.1.1 nolabel/40
Route Distinguisher: 64513:3
172.16.2.0/30 10.0.2.1 nolabel/19
172.16.20.0/30 10.0.2.1 nolabel/33
172.16.151.1/32 10.0.2.1 nolabel/37
Route Distinguisher: 64513:4
172.16.2.0/30 10.0.2.1 nolabel/32
172.16.2.4/30 10.0.2.1 nolabel/20
172.16.3.0/30 10.0.2.1 nolabel/31
172.16.4.0/30 10.0.2.1 nolabel/28
172.16.20.0/30 10.0.2.1 nolabel/34
172.16.151.1/32 10.0.2.1 nolabel/38
172.16.201.1/32 10.0.2.1 nolabel/27
172.16.251.1/32 10.0.2.1 nolabel/30
Route Distinguisher: 64513:5
172.16.3.0/30 10.0.5.1 nolabel/21
172.16.201.1/32 10.0.5.1 nolabel/25
Route Distinguisher: 64513:6
172.16.4.0/30 10.0.5.1 nolabel/22
172.16.251.1/32 10.0.5.1 nolabel/26

rr.pop1#

rr.pop2#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.5.1/32 0 Fa0/1 10.0.70.1
17 Pop tag 10.0.20.0/30 0 Fa0/1 10.0.70.1
18 Pop tag 10.0.40.0/30 0 Fa0/1 10.0.70.1
Pop tag 10.0.40.0/30 0 Fa0/0 10.0.50.1
19 Pop tag 10.0.60.0/30 0 Fa0/1 10.0.70.1
20 Pop tag 10.0.2.1/32 0 Fa0/0 10.0.50.1
21 23 10.0.3.1/32 0 Fa0/1 10.0.70.1
22 17 10.0.1.1/32 0 Fa0/1 10.0.70.1
16 10.0.1.1/32 0 Fa0/0 10.0.50.1
23 Pop tag 10.0.30.0/30 0 Fa0/0 10.0.50.1
24 20 10.0.10.0/30 0 Fa0/1 10.0.70.1
18 10.0.10.0/30 0 Fa0/0 10.0.50.1
rr.pop2#show ip bgp vpnv4 all labels
Network Next Hop In label/Out label
Route Distinguisher: 64513:1
172.16.1.0/30 10.0.1.1 nolabel/16
172.16.10.0/30 10.0.1.1 nolabel/30
172.16.151.1/32 10.0.1.1 nolabel/44
Route Distinguisher: 64513:2
172.16.1.0/30 10.0.1.1 nolabel/26
172.16.1.4/30 10.0.1.1 nolabel/17
172.16.3.0/30 10.0.1.1 nolabel/31
172.16.4.0/30 10.0.1.1 nolabel/32
172.16.10.0/30 10.0.1.1 nolabel/34
172.16.151.1/32 10.0.1.1 nolabel/45
172.16.201.1/32 10.0.1.1 nolabel/33
172.16.251.1/32 10.0.1.1 nolabel/40
Route Distinguisher: 64513:3
172.16.2.0/30 10.0.2.1 nolabel/19
172.16.20.0/30 10.0.2.1 nolabel/33
172.16.151.1/32 10.0.2.1 nolabel/37
Route Distinguisher: 64513:4
172.16.2.0/30 10.0.2.1 nolabel/32
172.16.2.4/30 10.0.2.1 nolabel/20
172.16.3.0/30 10.0.2.1 nolabel/31
172.16.4.0/30 10.0.2.1 nolabel/28
172.16.20.0/30 10.0.2.1 nolabel/34
172.16.151.1/32 10.0.2.1 nolabel/38
172.16.201.1/32 10.0.2.1 nolabel/27
172.16.251.1/32 10.0.2.1 nolabel/30
Route Distinguisher: 64513:5
172.16.3.0/30 10.0.5.1 nolabel/21
172.16.201.1/32 10.0.5.1 nolabel/25
Route Distinguisher: 64513:6
172.16.4.0/30 10.0.5.1 nolabel/22
172.16.251.1/32 10.0.5.1 nolabel/26

rr.pop2#

edge1.pop1#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
edge2.pop1 L2 Fa1/1 10.0.30.2 UP 6 edge2.pop1.02

rr.pop1 L2 Fa2/1 10.0.10.2 UP 8 rr.pop1.02

edge1.pop2 L2 Fa2/0 10.0.20.2 UP 7 edge1.pop2.02

edge1.pop1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 15 subnets, 2 masks
C 10.0.1.1/32 is directly connected, Loopback0
i L2 10.0.2.1/32 [115/20] via 10.0.30.2, FastEthernet1/1
i L2 10.0.3.1/32 [115/20] via 10.0.10.2, FastEthernet2/1
i L2 10.0.4.1/32 [115/30] via 10.0.30.2, FastEthernet1/1
[115/30] via 10.0.20.2, FastEthernet2/0
i L2 10.0.5.1/32 [115/20] via 10.0.20.2, FastEthernet2/0
C 10.0.10.0/30 is directly connected, FastEthernet2/1
L 10.0.10.1/32 is directly connected, FastEthernet2/1
C 10.0.20.0/30 is directly connected, FastEthernet2/0
L 10.0.20.1/32 is directly connected, FastEthernet2/0
C 10.0.30.0/30 is directly connected, FastEthernet1/1
L 10.0.30.1/32 is directly connected, FastEthernet1/1
i L2 10.0.40.0/30 [115/20] via 10.0.30.2, FastEthernet1/1
[115/20] via 10.0.20.2, FastEthernet2/0
i L2 10.0.50.0/30 [115/20] via 10.0.30.2, FastEthernet1/1
i L2 10.0.60.0/30 [115/20] via 10.0.20.2, FastEthernet2/0
[115/20] via 10.0.10.2, FastEthernet2/1
i L2 10.0.70.0/30 [115/20] via 10.0.20.2, FastEthernet2/0
edge1.pop1#

edge2.pop1#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
edge1.pop1 L2 Fa1/1 10.0.30.1 UP 23 edge2.pop1.02

rr.pop2 L2 Fa2/1 10.0.50.2 UP 8 rr.pop2.02

edge1.pop2 L2 Fa2/0 10.0.40.2 UP 6 edge1.pop2.03

edge2.pop1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 15 subnets, 2 masks
i L2 10.0.1.1/32 [115/20] via 10.0.30.1, FastEthernet1/1
C 10.0.2.1/32 is directly connected, Loopback0
i L2 10.0.3.1/32 [115/30] via 10.0.40.2, FastEthernet2/0
[115/30] via 10.0.30.1, FastEthernet1/1
i L2 10.0.4.1/32 [115/20] via 10.0.50.2, FastEthernet2/1
i L2 10.0.5.1/32 [115/20] via 10.0.40.2, FastEthernet2/0
i L2 10.0.10.0/30 [115/20] via 10.0.30.1, FastEthernet1/1
i L2 10.0.20.0/30 [115/20] via 10.0.40.2, FastEthernet2/0
[115/20] via 10.0.30.1, FastEthernet1/1
C 10.0.30.0/30 is directly connected, FastEthernet1/1
L 10.0.30.2/32 is directly connected, FastEthernet1/1
C 10.0.40.0/30 is directly connected, FastEthernet2/0
L 10.0.40.1/32 is directly connected, FastEthernet2/0
C 10.0.50.0/30 is directly connected, FastEthernet2/1
L 10.0.50.1/32 is directly connected, FastEthernet2/1
i L2 10.0.60.0/30 [115/20] via 10.0.40.2, FastEthernet2/0
i L2 10.0.70.0/30 [115/20] via 10.0.50.2, FastEthernet2/1
[115/20] via 10.0.40.2, FastEthernet2/0
edge2.pop1#

edge1.pop2#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
edge1.pop1 L2 Fa1/0 10.0.20.1 UP 28 edge1.pop2.02

edge2.pop1 L2 Fa1/1 10.0.40.1 UP 28 edge1.pop2.03

rr.pop1 L2 Fa2/0 10.0.60.2 UP 9 rr.pop1.03

rr.pop2 L2 Fa2/1 10.0.70.2 UP 9 rr.pop2.03

edge1.pop2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 16 subnets, 2 masks
i L2 10.0.1.1/32 [115/20] via 10.0.20.1, FastEthernet1/0
i L2 10.0.2.1/32 [115/20] via 10.0.40.1, FastEthernet1/1
i L2 10.0.3.1/32 [115/20] via 10.0.60.2, FastEthernet2/0
i L2 10.0.4.1/32 [115/20] via 10.0.70.2, FastEthernet2/1
C 10.0.5.1/32 is directly connected, Loopback0
i L2 10.0.10.0/30 [115/20] via 10.0.60.2, FastEthernet2/0
[115/20] via 10.0.20.1, FastEthernet1/0
C 10.0.20.0/30 is directly connected, FastEthernet1/0
L 10.0.20.2/32 is directly connected, FastEthernet1/0
i L2 10.0.30.0/30 [115/20] via 10.0.40.1, FastEthernet1/1
[115/20] via 10.0.20.1, FastEthernet1/0
C 10.0.40.0/30 is directly connected, FastEthernet1/1
L 10.0.40.2/32 is directly connected, FastEthernet1/1
i L2 10.0.50.0/30 [115/20] via 10.0.70.2, FastEthernet2/1
[115/20] via 10.0.40.1, FastEthernet1/1
C 10.0.60.0/30 is directly connected, FastEthernet2/0
L 10.0.60.1/32 is directly connected, FastEthernet2/0
C 10.0.70.0/30 is directly connected, FastEthernet2/1
L 10.0.70.1/32 is directly connected, FastEthernet2/1
edge1.pop2#

rr.pop1#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
edge1.pop1 L2 Fa0/0 10.0.10.1 UP 29 rr.pop1.02
edge1.pop2 L2 Fa0/1 10.0.60.1 UP 26 rr.pop1.03
rr.pop1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
C 10.0.10.0/30 is directly connected, FastEthernet0/0
C 10.0.3.1/32 is directly connected, Loopback0
i L2 10.0.2.1/32 [115/30] via 10.0.60.1, FastEthernet0/1
[115/30] via 10.0.10.1, FastEthernet0/0
i L2 10.0.1.1/32 [115/20] via 10.0.10.1, FastEthernet0/0
i L2 10.0.5.1/32 [115/20] via 10.0.60.1, FastEthernet0/1
i L2 10.0.4.1/32 [115/30] via 10.0.60.1, FastEthernet0/1
i L2 10.0.30.0/30 [115/20] via 10.0.10.1, FastEthernet0/0
i L2 10.0.20.0/30 [115/20] via 10.0.60.1, FastEthernet0/1
[115/20] via 10.0.10.1, FastEthernet0/0
i L2 10.0.40.0/30 [115/20] via 10.0.60.1, FastEthernet0/1
C 10.0.60.0/30 is directly connected, FastEthernet0/1
i L2 10.0.50.0/30 [115/30] via 10.0.60.1, FastEthernet0/1
[115/30] via 10.0.10.1, FastEthernet0/0
i L2 10.0.70.0/30 [115/20] via 10.0.60.1, FastEthernet0/1
rr.pop1#

rr.pop2#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
edge2.pop1 L2 Fa0/0 10.0.50.1 UP 21 rr.pop2.02
edge1.pop2 L2 Fa0/1 10.0.70.1 UP 28 rr.pop2.03
rr.pop2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 12 subnets, 2 masks
i L2 10.0.10.0/30 [115/30] via 10.0.70.1, FastEthernet0/1
[115/30] via 10.0.50.1, FastEthernet0/0
i L2 10.0.3.1/32 [115/30] via 10.0.70.1, FastEthernet0/1
i L2 10.0.2.1/32 [115/20] via 10.0.50.1, FastEthernet0/0
i L2 10.0.1.1/32 [115/30] via 10.0.70.1, FastEthernet0/1
[115/30] via 10.0.50.1, FastEthernet0/0
i L2 10.0.5.1/32 [115/20] via 10.0.70.1, FastEthernet0/1
C 10.0.4.1/32 is directly connected, Loopback0
i L2 10.0.30.0/30 [115/20] via 10.0.50.1, FastEthernet0/0
i L2 10.0.20.0/30 [115/20] via 10.0.70.1, FastEthernet0/1
i L2 10.0.40.0/30 [115/20] via 10.0.70.1, FastEthernet0/1
[115/20] via 10.0.50.1, FastEthernet0/0
i L2 10.0.60.0/30 [115/20] via 10.0.70.1, FastEthernet0/1
C 10.0.50.0/30 is directly connected, FastEthernet0/0
C 10.0.70.0/30 is directly connected, FastEthernet0/1
rr.pop2#

No comments:

Post a Comment