Friday, January 27, 2012

Implementing Multicast VPN in MPLS Hub & Spoke L3 VPN LAB




*****************************************************************
Scenario: An ISP wants to offer MPLS L3 VPN Hub and Spoke Services to its customer along with the Multicast VPN Services. There will also be a colocated Spoke on the HUB Site terminating on the same MPLS PE


Design Consideration and Solution:


1. HUB & Spoke Services


We will require 2 VRFs on the HUB-PEs viz one Hub_Ingress VRF to collect the routes from the remote spoke PE and send it towards the HUB and one Hub_Egress VRF to send the Hub_Routes as well as remote Spoke Routes from the HUB back to the MP-iBGP cloud. Having said that we would need two logical L3 peering between HUB PE-CE . One peering to be part of Hub_Ingress VRF and other Peering to be part of Hub_Egress VRF..We will have two eBGP neighbourship between HUB PE-CE ie one per VRF..

Also an important point to consider here is that because of default AS-Path Loop Prevention mechanism of BGP on the HUB-PEs under HUB_Egress VRF BGP Neighbourship config we need to add " allowas-in " command so that the spokes routes sent via HUB_Ingress VRF are not dropped when coming back to the HUB PE.

For the Co-located Spoke it will be configured as being part of HUB_Egress VRF for Unicast and Multicast communication


2. Multicast VPN Services


To achive the Multicast VPN deisgn in a HUB and Spoke MPLS VPN we would use default mdt in the HUB_Ingress VRF on the HUB_MPLS_PE such that the same mdt is configured on all the Spoke MPLS_PEs except the local colocated Spoke. All the remote Spokes will access Multicast Services via the HUB_Ingress VRF and Co-located Spoke will access Multicast Services via the HUB_Egress VRF for which no mdt will be used and it will be a local multicast vrf traffic for HUB_MPLS PE.

PIM Sparse-Mode will be used withing ISP network for Multicast Traffic with HUB_MPLS_PE as the Auto-RP. PIM Sparse-Dense Mode will be used on the PE-CE links with the HUB_CE as the Auto-RP.

So from the above points the VRF Design would be as below


HUB-PE1


VRF: HUB1_Ingress
rd 64513:1
route-target import 64513:200
route-target import 64513:300
mdt default 239.1.1.1


VRF: HUB1_Egress
rd 64513:2
route-target export 64513:100




Spoke-PE1

VRF: SPOKE1
rd 64513:3
route-target import 64513:100
route-target export 64513:200
mdt default 239.1.1.1
Spoke-PE2

VRF: SPOKE2
rd 64513:4
route-target import 64513:100
route-target export 64513:300
mdt default 239.1.1.1


ISP IGP used OSPF Area 0
Hub PE-CE ROuting Protocol used eBGP
Spoke PE-CE ROuting Protocol used eBGP
ISP AS used 64513
HUB_CE AS used 64514
SPOKE1 AS used 64515
SPOKE2 AS used 64516
SPOKE1 AS used 64517

PIM SM used in ISP backbone
PIM SM-DM used for CE Domain and PE-CE links

IGMP groups used for testing
HUB_CE 224.4.4.4
SPOKE1 224.1.1.1
SPOKE2 224.2.2.2
SPOKE3 224.3.3.3

*****************************************************************
HubPE#sh running-config
Building configuration...

Current configuration : 3113 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname HubPE
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf HUB_Egress
rd 64513:2
route-target export 64513:100
!
ip vrf HUB_Ingress
rd 64513:1
route-target import 64513:200
route-target import 64513:300
mdt default 239.1.1.1
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf HUB_Ingress
ip multicast-routing vrf HUB_Egress
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description SpokePE1
ip address 10.0.10.1 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet2/0
description SpokePE2
ip address 10.0.20.1 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
description HUB_Ingress
ip vrf forwarding HUB_Ingress
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet3/1
description HUB_Egress
ip vrf forwarding HUB_Egress
ip address 172.16.1.5 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet4/0
description SPOKE1
ip vrf forwarding HUB_Egress
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet4/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
no synchronization
bgp router-id 10.0.1.1
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.2.1 peer-group MP-iBGP
neighbor 10.0.3.1 peer-group MP-iBGP
no auto-summary
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor 10.0.2.1 activate
neighbor 10.0.3.1 activate
exit-address-family
!
address-family ipv4 vrf HUB_Ingress
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
address-family ipv4 vrf HUB_Egress
neighbor 172.16.1.6 remote-as 64514
neighbor 172.16.1.6 activate
neighbor 172.16.1.6 allowas-in 5
neighbor 172.16.1.6 soft-reconfiguration inbound
neighbor 172.16.2.2 remote-as 64515
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
logging alarm informational
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end

HubPE#

SpokePE1#sh running-config
Building configuration...

Current configuration : 2359 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SpokePE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf SPOKE1
rd 64513:3
route-target export 64513:200
route-target import 64513:100
mdt default 239.1.1.1
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf SPOKE1
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description HubPE
ip address 10.0.10.2 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet2/0
description SpokePE2
ip address 10.0.30.1 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
description Spoke2
ip vrf forwarding SPOKE1
ip address 172.16.2.5 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.2.1
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group MP-iBGP
neighbor 172.16.2.6 remote-as 64516
!
address-family ipv4
redistribute connected
neighbor 10.0.1.1 activate
neighbor 172.16.2.6 activate
neighbor 172.16.2.6 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor 10.0.1.1 activate
exit-address-family
!
address-family ipv4 vrf SPOKE1
redistribute connected
neighbor 172.16.2.6 remote-as 64516
neighbor 172.16.2.6 activate
neighbor 172.16.2.6 soft-reconfiguration inbound
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end

SpokePE1#

SpokePE2#sh running-config
Building configuration...

Current configuration : 2148 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SpokePE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf SPOKE2
rd 64513:4
route-target export 64513:300
route-target import 64513:100
mdt default 239.1.1.1
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf SPOKE2
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description HubPE
ip address 10.0.20.2 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface GigabitEthernet2/0
description SpokePE2
ip address 10.0.30.2 255.255.255.252
ip pim sparse-mode
negotiation auto
mpls label protocol ldp
mpls ip
!
interface FastEthernet3/0
description Spoke3
ip vrf forwarding SPOKE2
ip address 172.16.2.9 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet3/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 64513
no synchronization
bgp router-id 10.0.2.1
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group MP-iBGP
no auto-summary
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor 10.0.1.1 activate
exit-address-family
!
address-family ipv4 vrf SPOKE2
redistribute connected
neighbor 172.16.2.10 remote-as 64517
neighbor 172.16.2.10 activate
neighbor 172.16.2.10 soft-reconfiguration inbound
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
!
end

SpokePE2#

Hub#sh running-config
Building configuration...

Current configuration : 1296 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hub
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.4.4.4
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.6 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.101.1 mask 255.255.255.255
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 soft-reconfiguration inbound
neighbor 172.16.1.5 remote-as 64513
neighbor 172.16.1.5 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

Hub#

Spoke1#sh running-config
Building configuration...

Current configuration : 1080 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.51.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64515
no synchronization
bgp router-id 172.16.51.1
bgp log-neighbor-changes
network 172.16.51.1 mask 255.255.255.255
neighbor 172.16.2.1 remote-as 64513
neighbor 172.16.2.1 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

Spoke1#

Spoke2#sh running-config
Building configuration...

Current configuration : 1083 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.151.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.2.2.2
!
interface FastEthernet0/0
ip address 172.16.2.6 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64516
no synchronization
bgp router-id 172.16.151.1
bgp log-neighbor-changes
network 172.16.151.1 mask 255.255.255.255
neighbor 172.16.2.5 remote-as 64513
neighbor 172.16.2.5 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

Spoke2#

Spoke3#sh running-config
Building configuration...

Current configuration : 1084 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Spoke3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.251.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.3.3.3
!
interface FastEthernet0/0
ip address 172.16.2.10 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64517
no synchronization
bgp router-id 172.16.251.1
bgp log-neighbor-changes
network 172.16.251.1 mask 255.255.255.255
neighbor 172.16.2.9 remote-as 64513
neighbor 172.16.2.9 soft-reconfiguration inbound
no auto-summary
!
no ip http server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

Spoke3#

*******************
OUTPUT
******************
MULTICAST LAYER
******************

Spoke1#ping 224.4.4.4 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.51.1

Reply to request 0 from 172.16.1.6, 300 ms
Spoke1#ping 224.3.3.3 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 172.16.51.1

Reply to request 0 from 172.16.2.10, 780 ms
Spoke1#ping 224.2.2.2 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 172.16.51.1

Reply to request 0 from 172.16.2.6, 1132 ms
Spoke1#mtrace 172.16.101.1 172.16.51.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.51.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.51.1
-1 172.16.51.1 PIM [172.16.101.1/32]
-2 172.16.2.1 PIM [172.16.101.1/32]
-3 * * * 172.16.1.6
Spoke1#mtrace 172.16.51.1 172.16.101.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.51.1 to 172.16.101.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.101.1
-1 * 172.16.1.6 PIM Reached RP/Core [172.16.51.1/32]
Spoke1#mtrace 172.16.51.1 172.16.151.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.51.1 to 172.16.151.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.151.1
-1 * 172.16.2.6 PIM [172.16.51.1/32]
-2 * 172.16.2.5 PIM Admin. Prohibited [172.16.51.1/32]
-3 * * * 10.0.1.1
Spoke1#mtrace 172.16.51.1 172.16.251.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.51.1 to 172.16.251.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.251.1
-1 * 172.16.2.10 PIM [172.16.51.1/32]
-2 * 172.16.2.9 PIM Admin. Prohibited [172.16.51.1/32]
-3 * * * 10.0.1.1
Spoke1#


Hub#ping 224.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.101.1

Reply to request 0 from 172.16.2.2, 336 ms
Reply to request 0 from 172.16.2.2, 336 ms
Hub#ping 224.2.2.2 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 172.16.101.1

Reply to request 0 from 172.16.2.6, 452 ms
Reply to request 0 from 172.16.2.6, 452 ms
Hub#ping 224.3.3.3 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 172.16.101.1

Reply to request 0 from 172.16.2.10, 296 ms
Reply to request 0 from 172.16.2.10, 520 ms
Hub#mtrace 172.16.101.1 172.16.51.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.51.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path...
0 172.16.51.1
-1 172.16.2.2 PIM [172.16.101.1/32]
-2 172.16.2.1 PIM [172.16.101.1/32]
-3 172.16.1.6 PIM Reached RP/Core [172.16.101.1/32]
Hub#mtrace 172.16.101.1 172.16.151.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.151.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.151.1
-1 * 172.16.2.6 PIM [172.16.101.1/32]
-2 * 172.16.2.5 PIM Admin. Prohibited [172.16.101.1/32]
-3 * 0.0.0.0 PIM Prune sent upstream [172.16.101.1/32]
-4 * 172.16.1.2 PIM Reached RP/Core [172.16.101.1/32]
-5 * Route must have changed...try again

Hub#mtrace 172.16.101.1 172.16.251.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.251.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.251.1
-1 * 172.16.2.10 PIM [172.16.101.1/32]
-2 * 172.16.2.9 PIM Admin. Prohibited [172.16.101.1/32]
-3 * 0.0.0.0 PIM Prune sent upstream [172.16.101.1/32]
-4 * 172.16.1.2 PIM Reached RP/Core [172.16.101.1/32]
-5 * Route must have changed...try again

Spoke2#ping 224.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.151.1

Reply to request 0 from 172.16.2.2, 664 ms
Reply to request 0 from 172.16.2.2, 828 ms
Spoke2#ping 224.3.3.3 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 172.16.151.1

Reply to request 0 from 172.16.2.10, 516 ms
Reply to request 0 from 172.16.2.10, 516 ms
Spoke2#ping 224.4.4.4 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.151.1
.
Spoke2#ping 224.4.4.4 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.151.1

Reply to request 0 from 172.16.1.2, 404 ms
Reply to request 0 from 172.16.1.2, 588 ms
Spoke2#mtrace 172.16.151.1 172.16.51.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.151.1 to 172.16.51.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.51.1
-1 * 172.16.2.2 PIM [172.16.151.1/32]
-2 * 172.16.2.1 PIM Prune sent upstream [172.16.151.1/32]
-3 * 172.16.1.6 PIM Reached RP/Core [172.16.151.1/32]
-4 * 172.16.1.1 PIM Admin. Prohibited [172.16.151.1/32]
-5 * 0.0.0.0 PIM [172.16.151.1/32]
-6 * 172.16.2.6 PIM [172.16.151.1/32]
-7 * Route must have changed...try again

Spoke2#mtrace 172.16.151.1 172.16.101.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.151.1 to 172.16.101.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.101.1
-1 * 172.16.1.6 PIM Reached RP/Core [172.16.151.1/32]
-2 * 172.16.1.1 PIM Admin. Prohibited [172.16.151.1/32]
-3 * 0.0.0.0 PIM [172.16.151.1/32]
-4 * 172.16.2.6 PIM [172.16.151.1/32]
-5 * Route must have changed...try again

Spoke2#mtrace 172.16.151.1 172.16.251.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.151.1 to 172.16.251.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.251.1
-1 * 172.16.2.10 PIM [172.16.151.1/32]
-2 * 172.16.2.9 PIM Prune sent upstream [172.16.151.1/32]
-3 * 0.0.0.0 PIM Admin. Prohibited [172.16.151.1/32]
-4 * 0.0.0.0 PIM [172.16.151.1/32]
-5 * 172.16.2.6 PIM [172.16.151.1/32]
-6 * Route must have changed...try again

Spoke2#mtrace 172.16.51.1 172.16.151.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.51.1 to 172.16.151.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.151.1
-1 172.16.151.1 PIM [172.16.51.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.5 [default]
-3 0.0.0.0 PIM [default]
-4 172.16.1.2 PIM Reached RP/Core [172.16.51.1/32]
Spoke2#mtrace 172.16.101.1 172.16.151.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.151.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.151.1
-1 172.16.151.1 PIM [172.16.101.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.5 [default]
-3 0.0.0.0 PIM [172.16.101.1/32]
-4 172.16.1.2 PIM Reached RP/Core [172.16.101.1/32]
Spoke2#mtrace 172.16.251.1 172.16.151.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.251.1 to 172.16.151.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.151.1
-1 172.16.151.1 PIM [172.16.251.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.5 [default]
-3 0.0.0.0 PIM [172.16.251.1/32]
-4 172.16.1.2 PIM Reached RP/Core [172.16.251.1/32]
Spoke2#

Spoke3#ping 224.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.251.1

Reply to request 0 from 172.16.2.2, 588 ms
Reply to request 0 from 172.16.2.2, 588 ms
Spoke3#ping 224.2.2.2 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 172.16.251.1

Reply to request 0 from 172.16.2.6, 792 ms
Reply to request 0 from 172.16.2.6, 864 ms
Spoke3#ping 224.4.4.4 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.251.1
.
Spoke3#ping 224.4.4.4 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.251.1

Reply to request 0 from 172.16.1.2, 280 ms
Reply to request 0 from 172.16.1.2, 284 ms
Spoke3#mtrace 172.16.251.1 172.16.51.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.251.1 to 172.16.51.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.51.1
-1 * 172.16.2.2 PIM [172.16.251.1/32]
-2 * 172.16.2.1 PIM [172.16.251.1/32]
-3 * 172.16.1.6 PIM Reached RP/Core [172.16.251.1/32]
-4 * 172.16.1.1 PIM Prune sent upstream [172.16.251.1/32]
-5 * 0.0.0.0 PIM Prune sent upstream [172.16.251.1/32]
-6 * 172.16.2.10 PIM Prune sent upstream [172.16.251.1/32]
-7 * Route must have changed...try again

Spoke3#mtrace 172.16.251.1 172.16.101.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.251.1 to 172.16.101.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.101.1
-1 * 172.16.1.6 PIM Reached RP/Core [172.16.251.1/32]
-2 * 172.16.1.1 PIM Prune sent upstream [172.16.251.1/32]
-3 * 0.0.0.0 PIM Prune sent upstream [172.16.251.1/32]
-4 * 172.16.2.10 PIM [172.16.251.1/32]
-5 * Route must have changed...try again

Spoke3#mtrace 172.16.251.1 172.16.151.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.251.1 to 172.16.151.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.151.1
-1 * 172.16.2.6 PIM [172.16.251.1/32]
-2 * 172.16.2.5 PIM Prune sent upstream [172.16.251.1/32]
-3 * 0.0.0.0 PIM Admin. Prohibited [172.16.251.1/32]
-4 * 0.0.0.0 PIM [172.16.251.1/32]
-5 * 172.16.2.10 PIM [172.16.251.1/32]
-6 * Route must have changed...try again

Spoke3#mtrace 172.16.51.1 172.16.251.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.51.1 to 172.16.251.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.251.1
-1 172.16.251.1 PIM [172.16.51.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.9 [default]
-3 0.0.0.0 PIM [default]
-4 172.16.1.2 PIM Reached RP/Core [172.16.51.1/32]
Spoke3#mtrace 172.16.101.1 172.16.251.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.251.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.251.1
-1 172.16.251.1 PIM [172.16.101.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.9 [default]
-3 0.0.0.0 PIM [172.16.101.1/32]
-4 172.16.1.2 PIM Reached RP/Core [172.16.101.1/32]
Spoke3#mtrace 172.16.151.1 172.16.251.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.151.1 to 172.16.251.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.251.1
-1 172.16.251.1 PIM [172.16.151.1/32]
-2 0.0.0.0 None Admin. Prohibited !RPF!172.16.2.9 [default]
-3 0.0.0.0 PIM [172.16.151.1/32]
-4 172.16.1.2 PIM Reached RP/Core [172.16.151.1/32]
Spoke3#

Hub#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 01:10:04/00:02:31, RP 172.16.101.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 01:10:04/00:02:31

(172.16.2.10, 224.1.1.1), 00:02:57/00:00:02, flags:
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:02:57/00:03:29

(172.16.251.1, 224.1.1.1), 00:02:57/00:00:02, flags:
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:02:57/00:03:29

(*, 224.2.2.2), 01:10:13/00:03:24, RP 172.16.101.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:10:13/00:03:24

(172.16.2.10, 224.2.2.2), 00:02:50/00:00:09, flags: PX
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list: Null

(172.16.251.1, 224.2.2.2), 00:02:50/00:00:09, flags: PX
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list: Null

(*, 224.3.3.3), 01:10:24/00:03:10, RP 172.16.101.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:10:24/00:03:10

(172.16.2.10, 224.3.3.3), 00:02:18/00:00:47, flags: PT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list: Null

(172.16.251.1, 224.3.3.3), 00:02:08/00:00:57, flags: PX
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list: Null

(*, 224.4.4.4), 00:53:20/stopped, RP 172.16.101.1, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:53:20/00:02:25

(172.16.2.10, 224.4.4.4), 00:02:44/00:00:26, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:02:44/00:02:25

(172.16.251.1, 224.4.4.4), 00:02:44/00:00:26, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:02:44/00:02:25

(*, 224.0.1.39), 01:17:12/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:17:07/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:17:12/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 01:17:12/00:00:00

(172.16.101.1, 224.0.1.39), 01:17:12/00:02:48, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:17:07/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:17:07/00:00:00

(*, 224.0.1.40), 01:18:56/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 01:18:55/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 01:18:55/00:00:00
Loopback0, Forward/Sparse-Dense, 01:18:56/00:00:00

(172.16.101.1, 224.0.1.40), 01:16:12/00:02:15, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:16:12/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:16:12/00:00:00

Hub#

Spoke1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 01:10:47/00:02:20, RP 172.16.101.1, flags: SJCLF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:10:47/00:02:14

(*, 224.0.1.39), 01:17:54/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:17:54/00:00:00

(172.16.101.1, 224.0.1.39), 00:02:53/00:00:06, flags: PT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list: Null

(*, 224.0.1.40), 01:21:01/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:21:00/00:00:00
Loopback0, Forward/Sparse-Dense, 01:21:01/00:00:00

(172.16.101.1, 224.0.1.40), 01:16:54/00:02:41, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:16:54/00:00:00

Spoke1#

Spoke2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 01:11:16/stopped, RP 172.16.101.1, flags: SJCLF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.5
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:11:16/00:02:21

(172.16.151.1, 224.2.2.2), 00:03:16/00:00:13, flags: LFT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:03:16/00:01:12

(*, 224.0.1.39), 01:11:14/00:02:46, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:11:14/00:00:00

(*, 224.0.1.40), 01:23:21/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:23:17/00:00:00
Loopback0, Forward/Sparse-Dense, 01:23:21/00:00:00

(172.16.101.1, 224.0.1.40), 01:17:13/00:02:22, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.5
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:17:13/00:00:00

Spoke2#

Spoke3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:04:15/00:02:21, RP 172.16.101.1, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.9
Outgoing interface list: Null

(*, 224.2.2.2), 00:04:08/00:02:31, RP 172.16.101.1, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.9
Outgoing interface list: Null

(*, 224.3.3.3), 01:11:42/stopped, RP 172.16.101.1, flags: SJCLF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.9
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:11:42/00:02:10

(172.16.2.10, 224.3.3.3), 00:03:35/00:00:48, flags: LFT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:03:35/00:02:10

(172.16.251.1, 224.3.3.3), 00:03:26/00:01:18, flags: LFT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:43/00:03:04

(*, 224.4.4.4), 00:04:01/00:02:41, RP 172.16.101.1, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.9
Outgoing interface list: Null

(*, 224.0.1.39), 01:15:29/00:02:31, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:15:29/00:00:00

(*, 224.0.1.40), 01:22:11/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 01:22:10/00:00:00
Loopback0, Forward/Sparse-Dense, 01:22:10/00:00:00

(172.16.101.1, 224.0.1.40), 01:15:29/00:02:57, flags: LT
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.9
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:15:29/00:00:00

Spoke3#

HubPE#show ip mroute vrf HUB_Ingress
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.4.4.4), 00:09:36/00:02:01, RP 172.16.101.1, flags: SP
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list: Null

(*, 224.2.2.2), 01:12:04/00:03:22, RP 172.16.101.1, flags: S
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 01:12:04/00:03:22

(172.16.151.1, 224.2.2.2), 00:02:08/00:01:53, flags: R
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 00:00:09/00:03:22

(*, 224.3.3.3), 01:12:16/00:03:09, RP 172.16.101.1, flags: S
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 01:12:16/00:03:09

(172.16.2.10, 224.3.3.3), 00:04:08/00:02:39, flags: PR
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list: Null

(172.16.251.1, 224.3.3.3), 00:00:58/00:02:31, flags:
Incoming interface: Tunnel1, RPF nbr 10.0.3.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 00:00:58/00:02:31

(*, 224.1.1.1), 00:12:09/00:01:42, RP 172.16.101.1, flags: SP
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list: Null

(*, 224.0.1.39), 01:19:03/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:19:03/00:00:00
Tunnel1, Forward/Sparse-Dense, 01:19:03/00:00:00

(172.16.101.1, 224.0.1.39), 00:00:01/00:02:57, flags: T
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 00:00:01/00:02:58

(*, 224.0.1.40), 01:31:09/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:20:46/00:00:00
Tunnel1, Forward/Sparse-Dense, 01:31:09/00:00:00

(172.16.101.1, 224.0.1.40), 01:18:03/00:02:24, flags: LT
Incoming interface: FastEthernet3/0, RPF nbr 172.16.1.2
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 01:18:03/00:00:00

HubPE#show ip mroute vrf HUB_Egress
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 01:11:59/00:03:15, RP 172.16.101.1, flags: S
Incoming interface: FastEthernet3/1, RPF nbr 172.16.1.6
Outgoing interface list:
FastEthernet4/0, Forward/Sparse-Dense, 01:11:59/00:03:15

(*, 224.0.1.39), 01:19:07/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet4/0, Forward/Sparse-Dense, 01:19:07/00:00:00
FastEthernet3/1, Forward/Sparse-Dense, 01:19:07/00:00:00

(172.16.101.1, 224.0.1.39), 00:00:05/00:02:54, flags: PT
Incoming interface: FastEthernet3/1, RPF nbr 172.16.1.6
Outgoing interface list:
FastEthernet4/0, Prune/Sparse-Dense, 00:00:05/00:02:54

(*, 224.0.1.40), 01:31:10/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/1, Forward/Sparse-Dense, 01:20:48/00:00:00
FastEthernet4/0, Forward/Sparse-Dense, 01:22:12/00:00:00

(172.16.101.1, 224.0.1.40), 01:18:06/00:02:22, flags: LT
Incoming interface: FastEthernet3/1, RPF nbr 172.16.1.6
Outgoing interface list:
FastEthernet4/0, Forward/Sparse-Dense, 01:18:06/00:00:00

HubPE#

SpokePE1#show ip mroute vrf SPOKE1
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 01:12:27/00:02:56, RP 172.16.101.1, flags: S
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:12:27/00:02:56

(172.16.151.1, 224.2.2.2), 00:02:31/00:01:27, flags: R
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 00:00:33/00:02:56

(*, 224.0.1.39), 01:12:25/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:12:25/00:00:00
Tunnel0, Forward/Sparse-Dense, 01:12:25/00:00:00

(172.16.101.1, 224.0.1.39), 00:00:24/00:02:44, flags: PT
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Prune/Sparse-Dense, 00:00:24/00:02:35

(*, 224.0.1.40), 01:27:29/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:24:28/00:00:00
Tunnel0, Forward/Sparse-Dense, 01:27:28/00:00:00

(172.16.101.1, 224.0.1.40), 01:18:25/00:02:04, flags: LT
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:18:25/00:00:00

SpokePE1#

SpokePE2#show ip mroute vrf SPOKE2
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.4.4.4), 00:05:15/00:01:22, RP 172.16.101.1, flags: SP
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list: Null

(*, 224.2.2.2), 00:05:21/00:01:13, RP 172.16.101.1, flags: SP
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list: Null

(*, 224.3.3.3), 01:12:55/00:03:25, RP 172.16.101.1, flags: S
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:12:55/00:03:25

(172.16.251.1, 224.3.3.3), 00:01:38/00:01:51, flags:
Incoming interface: FastEthernet3/0, RPF nbr 172.16.2.10
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:38/00:02:49

(*, 224.1.1.1), 00:05:28/00:01:05, RP 172.16.101.1, flags: SP
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list: Null

(*, 224.0.1.39), 01:19:42/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:19:42/00:00:00
Tunnel0, Forward/Sparse-Dense, 01:19:42/00:00:00

(172.16.101.1, 224.0.1.39), 00:00:42/00:02:25, flags: PT
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Prune/Sparse-Dense, 00:00:41/00:02:18

(*, 224.0.1.40), 01:26:14/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:26:14/00:00:00
Tunnel0, Forward/Sparse-Dense, 01:24:56/00:00:00

(172.16.101.1, 224.0.1.40), 01:18:42/00:02:45, flags: LT
Incoming interface: Tunnel0, RPF nbr 10.0.1.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse-Dense, 01:18:42/00:00:00

SpokePE2#

Spoke1#show ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.1 FastEthernet0/0 01:23:10/00:01:23 v2 1 / S
Spoke1#

Hub#show ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.1 FastEthernet0/0 01:22:06/00:01:24 v2 1 / S
172.16.1.5 FastEthernet0/1 01:22:05/00:01:28 v2 1 / S
Hub#

Spoke2#show ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.5 FastEthernet0/0 01:25:40/00:01:17 v2 1 / S
Spoke2#

Spoke3#show ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.9 FastEthernet0/0 01:24:31/00:01:26 v2 1 / S
Spoke3#

HubPE#show ip pim vrf HUB_Ingress neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.3.1 Tunnel1 01:19:16/00:01:22 v2 1 / DR S
10.0.2.1 Tunnel1 01:22:43/00:01:43 v2 1 / S
172.16.1.2 FastEthernet3/0 01:23:08/00:01:24 v2 1 / DR S
HubPE#show ip pim vrf HUB_Egress neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.6 FastEthernet3/1 01:23:11/00:01:43 v2 1 / DR S
172.16.2.2 FastEthernet4/0 01:24:34/00:01:21 v2 1 / DR S
HubPE#

SpokePE1#show ip pim vrf SPOKE1 neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.6 FastEthernet3/0 01:26:56/00:01:30 v2 1 / DR S
10.0.3.1 Tunnel0 01:19:44/00:01:23 v2 1 / DR S
10.0.1.1 Tunnel0 01:28:57/00:01:43 v2 1 / S
SpokePE1#

SpokePE2#show ip pim vrf SPOKE2 neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.10 FastEthernet3/0 01:26:15/00:01:41 v2 1 / DR S
10.0.2.1 Tunnel0 01:23:51/00:01:32 v2 1 / S
10.0.1.1 Tunnel0 01:27:48/00:01:31 v2 1 / S
SpokePE2#

SpokePE2#show ip rpf vrf SPOKE2 172.16.151.1
RPF information for ? (172.16.151.1)
RPF interface: Tunnel0
RPF neighbor: ? (10.0.1.1)
RPF route/mask: 172.16.151.1/32
RPF type: unicast (bgp 64513)
RPF recursion count: 0
Doing distance-preferred lookups across tables
SpokePE2#

SpokePE1#show ip rpf vrf SPOKE1 172.16.251.1
RPF information for ? (172.16.251.1)
RPF interface: Tunnel0
RPF neighbor: ? (10.0.1.1)
RPF route/mask: 172.16.251.1/32
RPF type: unicast (bgp 64513)
RPF recursion count: 0
Doing distance-preferred lookups across tables
SpokePE1#

HubPE#show ip rpf vrf HUB_Ingress 172.16.151.1
RPF information for ? (172.16.151.1)
RPF interface: Tunnel1
RPF neighbor: ? (10.0.2.1)
RPF route/mask: 172.16.151.1/32
RPF type: unicast (bgp 64513)
RPF recursion count: 0
Doing distance-preferred lookups across tables
HubPE#show ip rpf vrf HUB_Ingress 172.16.251.1
RPF information for ? (172.16.251.1)
RPF interface: Tunnel1
RPF neighbor: ? (10.0.3.1)
RPF route/mask: 172.16.251.1/32
RPF type: unicast (bgp 64513)
RPF recursion count: 0
Doing distance-preferred lookups across tables
HubPE#show ip rpf vrf HUB_Egress 172.16.51.1
RPF information for ? (172.16.51.1)
RPF interface: FastEthernet4/0
RPF neighbor: ? (172.16.2.2)
RPF route/mask: 172.16.51.1/32
RPF type: unicast (bgp 64513)
RPF recursion count: 1
Doing distance-preferred lookups across tables
HubPE#

Hub#show ip rpf 172.16.151.1
RPF information for ? (172.16.151.1)
RPF interface: FastEthernet0/0
RPF neighbor: ? (172.16.1.1)
RPF route/mask: 172.16.151.1/32
RPF type: unicast (bgp 64514)
RPF recursion count: 1
Doing distance-preferred lookups across tables
Hub#show ip rpf 172.16.251.1
RPF information for ? (172.16.251.1)
RPF interface: FastEthernet0/0
RPF neighbor: ? (172.16.1.1)
RPF route/mask: 172.16.251.1/32
RPF type: unicast (bgp 64514)
RPF recursion count: 1
Doing distance-preferred lookups across tables
Hub#show ip rpf 172.16.51.1
RPF information for ? (172.16.51.1)
RPF interface: FastEthernet0/1
RPF neighbor: ? (172.16.1.5)
RPF route/mask: 172.16.51.1/32
RPF type: unicast (bgp 64514)
RPF recursion count: 1
Doing distance-preferred lookups across tables
Hub#

********************************
UNICAST ROUTES
********************************

Spoke2#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.2.5 140 msec 120 msec 28 msec
2 172.16.1.5 140 msec 128 msec 56 msec
3 172.16.1.6 172 msec 384 msec 208 msec
4 172.16.1.1 [AS 64513] 200 msec 48 msec 80 msec
5 172.16.2.9 [AS 64513] 288 msec 320 msec 256 msec
6 172.16.2.10 [AS 64513] 300 msec * 416 msec
Spoke2#

Spoke3#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.9 40 msec 72 msec 140 msec
2 172.16.1.5 148 msec 180 msec 164 msec
3 172.16.1.6 220 msec 220 msec 160 msec
4 172.16.1.1 [AS 64513] 124 msec 124 msec 224 msec
5 172.16.2.5 [AS 64513] 340 msec 396 msec 408 msec
6 172.16.2.6 [AS 64513] 308 msec * 316 msec
Spoke3#

Hub#traceroute 172.16.51.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.51.1

1 172.16.1.5 112 msec 156 msec 88 msec
2 172.16.2.2 156 msec * 172 msec
Hub#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.1.1 44 msec 72 msec 56 msec
2 172.16.2.5 [AS 64513] 160 msec 144 msec 204 msec
3 172.16.2.6 [AS 64513] 188 msec * 284 msec
Hub#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.1.1 72 msec 52 msec 172 msec
2 172.16.2.9 [AS 64513] 96 msec 148 msec 128 msec
3 172.16.2.10 [AS 64513] 192 msec * 56 msec
Hub#

Spoke1#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.1 40 msec 40 msec 24 msec
2 172.16.1.6 176 msec 120 msec 44 msec
3 * * *
4 172.16.2.5 [AS 64513] 156 msec 140 msec 132 msec
5 172.16.2.6 [AS 64513] 268 msec * 380 msec
Spoke1#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.2.1 60 msec 64 msec 80 msec
2 172.16.1.6 92 msec 188 msec 84 msec
3 * * *
4 172.16.2.9 [AS 64513] 208 msec 224 msec 236 msec
5 172.16.2.10 [AS 64513] 388 msec * 180 msec
Spoke1#traceroute 172.16.101.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.1 24 msec 72 msec 72 msec
2 172.16.1.6 152 msec * 172 msec
Spoke1#

Spoke3#traceroute 172.16.151.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.151.1

1 172.16.2.9 40 msec 72 msec 140 msec
2 172.16.1.5 148 msec 180 msec 164 msec
3 172.16.1.6 220 msec 220 msec 160 msec
4 172.16.1.1 [AS 64513] 124 msec 124 msec 224 msec
5 172.16.2.5 [AS 64513] 340 msec 396 msec 408 msec
6 172.16.2.6 [AS 64513] 308 msec * 316 msec
Spoke3#traceroute 172.16.101.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.9 108 msec 208 msec 72 msec
2 172.16.1.5 216 msec 152 msec 216 msec
3 172.16.1.6 280 msec * 148 msec
Spoke3#traceroute 172.16.51.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.51.1

1 172.16.2.9 112 msec 96 msec 20 msec
2 172.16.2.1 236 msec 152 msec 144 msec
3 172.16.2.2 188 msec * 336 msec
Spoke3#

Spoke2#traceroute 172.16.251.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.2.5 140 msec 120 msec 28 msec
2 172.16.1.5 140 msec 128 msec 56 msec
3 172.16.1.6 172 msec 384 msec 208 msec
4 172.16.1.1 [AS 64513] 200 msec 48 msec 80 msec
5 172.16.2.9 [AS 64513] 288 msec 320 msec 256 msec
6 172.16.2.10 [AS 64513] 300 msec * 416 msec
Spoke2#traceroute 172.16.101.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.5 80 msec 68 msec 52 msec
2 172.16.1.5 260 msec 216 msec 240 msec
3 172.16.1.6 112 msec * 116 msec
Spoke2#traceroute 172.16.51.1 source lo0

Type escape sequence to abort.
Tracing the route to 172.16.51.1

1 172.16.2.5 36 msec 128 msec 12 msec
2 172.16.2.1 132 msec 228 msec 220 msec
3 172.16.2.2 224 msec * 228 msec
Spoke2#

Hub#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
B 172.16.151.1/32 [20/0] via 172.16.1.1, 01:36:44
B 172.16.251.1/32 [20/0] via 172.16.1.1, 01:33:33
B 172.16.51.1/32 [20/0] via 172.16.1.5, 01:36:44
B 172.16.2.8/30 [20/0] via 172.16.1.1, 01:33:33
C 172.16.1.4/30 is directly connected, FastEthernet0/1
B 172.16.2.4/30 [20/0] via 172.16.1.1, 01:36:44
C 172.16.1.0/30 is directly connected, FastEthernet0/0
C 172.16.101.1/32 is directly connected, Loopback0
Hub#show ip bgp summ
BGP router identifier 172.16.101.1, local AS number 64514
BGP table version is 9, main routing table version 9
7 network entries using 819 bytes of memory
7 path entries using 364 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2147 total bytes of memory
BGP activity 7/0 prefixes, 7/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.1.1 4 64513 105 107 9 0 0 01:36:49 5
172.16.1.5 4 64513 107 108 9 0 0 01:37:12 1
Hub#

Spoke1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
B 172.16.151.1/32 [20/0] via 172.16.2.1, 01:37:18
B 172.16.251.1/32 [20/0] via 172.16.2.1, 01:34:07
C 172.16.51.1/32 is directly connected, Loopback0
B 172.16.2.8/30 [20/0] via 172.16.2.1, 01:34:07
B 172.16.2.4/30 [20/0] via 172.16.2.1, 01:37:18
B 172.16.1.0/30 [20/0] via 172.16.2.1, 01:37:18
C 172.16.2.0/30 is directly connected, FastEthernet0/0
B 172.16.101.1/32 [20/0] via 172.16.2.1, 01:37:18
Spoke1#show ip bgp sum
BGP router identifier 172.16.51.1, local AS number 64515
BGP table version is 8, main routing table version 8
7 network entries using 819 bytes of memory
7 path entries using 364 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2023 total bytes of memory
BGP activity 7/0 prefixes, 7/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.2.1 4 64513 109 104 8 0 0 01:39:03 6
Spoke1#

Spoke3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
B 172.16.151.1/32 [20/0] via 172.16.2.9, 01:34:36
C 172.16.251.1/32 is directly connected, Loopback0
B 172.16.51.1/32 [20/0] via 172.16.2.9, 01:34:36
C 172.16.2.8/30 is directly connected, FastEthernet0/0
B 172.16.2.4/30 [20/0] via 172.16.2.9, 01:34:36
B 172.16.1.0/30 [20/0] via 172.16.2.9, 01:34:36
B 172.16.101.1/32 [20/0] via 172.16.2.9, 01:34:36
Spoke3#show ip bgp su
BGP router identifier 172.16.251.1, local AS number 64517
BGP table version is 11, main routing table version 11
7 network entries using 819 bytes of memory
7 path entries using 364 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2171 total bytes of memory
BGP activity 8/1 prefixes, 8/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.2.9 4 64513 110 104 11 0 0 01:39:43 6
Spoke3#

Spoke2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.16.151.1/32 is directly connected, Loopback0
B 172.16.251.1/32 [20/0] via 172.16.2.5, 01:34:53
B 172.16.51.1/32 [20/0] via 172.16.2.5, 01:38:09
B 172.16.2.8/30 [20/0] via 172.16.2.5, 01:34:53
C 172.16.2.4/30 is directly connected, FastEthernet0/0
B 172.16.1.0/30 [20/0] via 172.16.2.5, 01:37:54
B 172.16.101.1/32 [20/0] via 172.16.2.5, 01:37:54
Spoke2#show ip bgp su
BGP router identifier 172.16.151.1, local AS number 64516
BGP table version is 9, main routing table version 9
7 network entries using 819 bytes of memory
7 path entries using 364 bytes of memory
7/6 BGP path/bestpath attribute entries using 868 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2171 total bytes of memory
BGP activity 7/0 prefixes, 7/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.2.5 4 64513 111 106 9 0 0 01:41:33 6
Spoke2#

HubPE#show ip route vrf HUB_Ingress

Routing Table: HUB_Ingress
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.151.1/32 [200/0] via 10.0.2.1, 01:38:55
B 172.16.251.1/32 [200/0] via 10.0.3.1, 01:35:39
B 172.16.2.8/30 [200/0] via 10.0.3.1, 01:35:39
B 172.16.2.4/30 [200/0] via 10.0.2.1, 01:38:55
C 172.16.1.0/30 is directly connected, FastEthernet3/0
B 172.16.101.1/32 [20/0] via 172.16.1.2, 01:38:50
HubPE#show ip route vrf HUB_Egress

Routing Table: HUB_Egress
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
B 172.16.151.1/32 [20/0] via 172.16.1.6, 01:38:52
B 172.16.251.1/32 [20/0] via 172.16.1.6, 01:35:42
B 172.16.51.1/32 [20/0] via 172.16.2.2, 01:40:31
B 172.16.2.8/30 [20/0] via 172.16.1.6, 01:35:42
C 172.16.1.4/30 is directly connected, FastEthernet3/1
B 172.16.2.4/30 [20/0] via 172.16.1.6, 01:38:52
B 172.16.1.0/30 [20/0] via 172.16.1.6, 01:38:52
C 172.16.2.0/30 is directly connected, FastEthernet4/0
B 172.16.101.1/32 [20/0] via 172.16.1.6, 01:38:52
HubPE#show ip bgp vpnv4 all
BGP table version is 36, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf HUB_Ingress)
*> 172.16.1.0/30 0.0.0.0 0 32768 ?
*>i172.16.2.4/30 10.0.2.1 0 100 0 ?
*>i172.16.2.8/30 10.0.3.1 0 100 0 ?
*> 172.16.101.1/32 172.16.1.2 0 0 64514 i
*>i172.16.151.1/32 10.0.2.1 0 100 0 64516 i
*>i172.16.251.1/32 10.0.3.1 0 100 0 64517 i
Route Distinguisher: 64513:2 (default for vrf HUB_Egress)
*> 172.16.1.0/30 172.16.1.6 0 64514 64513 ?
*> 172.16.2.4/30 172.16.1.6 0 64514 64513 ?
*> 172.16.2.8/30 172.16.1.6 0 64514 64513 ?
* 172.16.51.1/32 172.16.1.6 0 64514 64513 64515 i
*> 172.16.2.2 0 0 64515 i
*> 172.16.101.1/32 172.16.1.6 0 0 64514 i
*> 172.16.151.1/32 172.16.1.6 0 64514 64513 64516 i
*> 172.16.251.1/32 172.16.1.6 0 64514 64513 64517 i
Route Distinguisher: 64513:3
*>i172.16.2.4/30 10.0.2.1 0 100 0 ?
*>i172.16.151.1/32 10.0.2.1 0 100 0 64516 i
Route Distinguisher: 64513:4
*>i172.16.2.8/30 10.0.3.1 0 100 0 ?
*>i172.16.251.1/32 10.0.3.1 0 100 0 64517 i
Route Distinguisher: 2:64513:1
*> 10.0.1.1/32 0.0.0.0 0 ?
Route Distinguisher: 2:64513:3
*>i10.0.2.1/32 10.0.2.1 0 100 0 ?
Route Distinguisher: 2:64513:4
*>i10.0.3.1/32 10.0.3.1 0 100 0 ?
HubPE#

HubPE#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Aggregate 172.16.1.0/30[V] 0
17 Untagged 172.16.2.8/30[V] 570 Fa3/1 172.16.1.6
18 Pop tag 10.0.30.0/30 0 Gi2/0 10.0.20.2
Pop tag 10.0.30.0/30 0 Gi1/0 10.0.10.2
19 Untagged 172.16.251.1/32[V] \
5832 Fa3/1 172.16.1.6
20 Pop tag 10.0.3.1/32 0 Gi2/0 10.0.20.2
21 Untagged 172.16.51.1/32[V] 7840 Fa4/0 172.16.2.2
22 Pop tag 10.0.2.1/32 0 Gi1/0 10.0.10.2
23 Untagged 172.16.101.1/32[V] \
0 Fa3/0 172.16.1.2
24 Untagged 172.16.101.1/32[V] \
22504 Fa3/1 172.16.1.6
25 Untagged 172.16.1.0/30[V] 228 Fa3/1 172.16.1.6
26 Untagged 172.16.2.4/30[V] 342 Fa3/1 172.16.1.6
27 Untagged 172.16.151.1/32[V] \
4714 Fa3/1 172.16.1.6
HubPE#show mpls forwarding-table vrf HUB_Ingress
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Aggregate 172.16.1.0/30[V] 0
23 Untagged 172.16.101.1/32[V] \
0 Fa3/0 172.16.1.2
HubPE#show mpls forwarding-table vrf HUB_Egress
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
17 Untagged 172.16.2.8/30[V] 570 Fa3/1 172.16.1.6
19 Untagged 172.16.251.1/32[V] \
5832 Fa3/1 172.16.1.6
21 Untagged 172.16.51.1/32[V] 7840 Fa4/0 172.16.2.2
24 Untagged 172.16.101.1/32[V] \
22504 Fa3/1 172.16.1.6
25 Untagged 172.16.1.0/30[V] 228 Fa3/1 172.16.1.6
26 Untagged 172.16.2.4/30[V] 342 Fa3/1 172.16.1.6
27 Untagged 172.16.151.1/32[V] \
4714 Fa3/1 172.16.1.6
HubPE#

SpokePE1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.1.1/32 1331 Gi1/0 10.0.10.1
17 Pop tag 10.0.20.0/30 0 Gi2/0 10.0.30.2
Pop tag 10.0.20.0/30 0 Gi1/0 10.0.10.1
18 Aggregate 172.16.2.4/30[V] 5646
19 Untagged 172.16.151.1/32[V] \
12342 Fa3/0 172.16.2.6
20 Pop tag 10.0.3.1/32 1968 Gi2/0 10.0.30.2
SpokePE1#show mpls forwarding-table vrf SPOKE1
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
18 Aggregate 172.16.2.4/30[V] 5646
19 Untagged 172.16.151.1/32[V] \
12342 Fa3/0 172.16.2.6
SpokePE1#

SpokePE2#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.10.0/30 0 Gi2/0 10.0.30.1
Pop tag 10.0.10.0/30 0 Gi1/0 10.0.20.1
17 Pop tag 10.0.1.1/32 0 Gi1/0 10.0.20.1
18 Aggregate 172.16.2.8/30[V] 5040
19 Untagged 172.16.251.1/32[V] \
16714 Fa3/0 172.16.2.10
20 Pop tag 10.0.2.1/32 0 Gi2/0 10.0.30.1
SpokePE2#show mpls forwarding-table vrf SPOKE2
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
18 Aggregate 172.16.2.8/30[V] 5040
19 Untagged 172.16.251.1/32[V] \
16714 Fa3/0 172.16.2.10
SpokePE2#

No comments:

Post a Comment