Monday, February 1, 2010

Implementing Inter-AS Multicast in MPLS L3 VPNS using Fully Meshed GRE Tunnels between CEs LAB
















COnfiguration Gudelines
****************************************************************************
Scenario - Providing Inter-AS Multicast MPLS L3 VPN Services Providing Multicast
Traffic between Multicast Server in AS 64513 and Multicast Clients in AS 64514
and vice-versa.


Design Cconsiderations and Soultions: Can use PIM Dense or Sparse Mode. Dense Mode
causes Traffic Flooding whereas Sparse Mode is via Shared Tree where RP is needed

To Provide Inter-AS MPLS VPN Services the ASBRs peering via Unicast IPv4 should peer via MP-eBGP
for vpnv4 to provide IPv4 Unicast Connectivity between the CEs in different ASes

Inter-AS Multicast is achieved by estabilishing GRE Tunnels between CEs and running PIM over the tunnels.
Provider Core is free from ROuting MUlticast Traffic and This is just PIM Dense Mode SOlution.

Caveats: This solution fits only for Inetr-AS MVPN when there are few sites as we need to establish
n*(n-1)/2 GRE Tunnels for full meshed connectivity.

Also static mroutes are needed to achieve Multicast Traffuc Flow between CEs


ISP 1 AS used 64513
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces
ISP 1 AS used 64514
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces

EBGP used within ASes


PIM Sparse-Dense-Mode used On ISP Backbone Links and Peering between ISP 1 & 2
via PE12 and PE22


IGMP Join-group used to simulate Mutlicast Traffic

224.11.11.11 on CE1A ,224.22.22.22 on CE2A and 224.33.33.33 on CE3A

*************************************************************************************


CE1A#sh running-config
Building configuration...

Current configuration : 1716 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
description <>
ip address 172.16.100.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 172.16.25.1
!
interface Tunnel102
ip address 172.16.154.2 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 172.16.200.1
!
interface Loopback0
description <>
ip address 172.16.15.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
!
interface FastEthernet0/0
description <>
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.1.0 0.0.0.3 area 0
!
ip http server
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip mroute 0.0.0.0 0.0.0.0 Tunnel100
ip mroute 172.16.25.0 255.255.255.0 Tunnel100
ip mroute 172.16.2.0 255.255.255.252 Tunnel100
ip mroute 172.16.3.0 255.255.255.252 Tunnel102
ip mroute 172.16.200.0 255.255.255.0 Tunnel102
ip mroute 172.16.254.0 255.255.255.0 Tunnel100
ip mroute 172.16.254.0 255.255.255.252 Tunnel100
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE1A#
CE1A#
CE2A#sh running-config
Building configuration...

Current configuration : 2040 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
description <>
ip address 172.16.100.2 255.255.255.252
ip pim sparse-mode
tunnel source Loopback0
tunnel destination 172.16.15.1
!
interface Tunnel101
ip address 172.16.254.2 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 172.16.200.1
!
interface Loopback0
description <>
ip address 172.16.25.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.22.22.22
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected route-map Local
network 172.16.2.0 0.0.0.3
auto-summary
!
ip http server
!
!
ip pim rp-address 172.16.15.1
ip pim accept-rp auto-rp
ip mroute 0.0.0.0 0.0.0.0 Tunnel100
ip mroute 172.16.200.0 255.255.255.0 Tunnel101
ip mroute 172.16.3.0 255.255.255.252 Tunnel101
ip mroute 172.16.15.0 255.255.255.0 Tunnel100
ip mroute 172.16.11.0 255.255.255.252 Tunnel100
ip mroute 172.16.1.0 255.255.255.252 Tunnel100
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE2A#
CE2A#

CE3A#sh running-config
Building configuration...

Current configuration : 1758 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel101
ip address 172.16.254.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 172.16.25.1
!
interface Tunnel102
ip address 172.16.154.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 172.16.15.1
!
interface Loopback0
ip address 172.16.200.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.33.33.33
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.3.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
network 172.16.3.0 0.0.0.3
network 172.16.200.0 0.0.0.255
auto-summary
!
ip http server
!
!
ip mroute 0.0.0.0 0.0.0.0 Tunnel101
ip mroute 172.16.1.0 255.255.255.252 Tunnel102
ip mroute 172.16.100.0 255.255.255.0 Tunnel101
ip mroute 172.16.100.0 255.255.255.252 Tunnel101
ip mroute 172.16.15.0 255.255.255.0 Tunnel102
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE3A#


PE11#sh running-config
Building configuration...

Current configuration : 2627 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1
!
ip multicast-routing
ip multicast-routing vrf CEA
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.1.1.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
ip igmp join-group 224.88.88.88
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface serial1/0
description <>
encapsulation frame-relay
frame-relay lmi-type ansi
ip address 192.168.1.1 255.255.255.252
frame-relay map ip 192.168.1.2 104 broadcast
ip ospf network point-to-point
serial restart-delay 0
ip pim sparse-dense-mode
no snmp trap link-status
mpls label protocol ldp
mpls ip

!
interface FastEthernet2/0
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.1.0 0.0.0.3 area 0
!
router ospf 1
network 192.168.1.0 0.0.0.3 area 0
network 10.1.1.1 0.0.0.0 area 0
passive-interface default
no passive-interface serial1/0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.1.2.1 remote-as 64513
neighbor 10.1.2.1 description <>
neighbor 10.1.2.1 update-source Loopback0
!
address-family vpnv4
neighbor 10.1.2.1 activate
neighbor 10.1.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
logging alarm informational
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
!
end

PE11#


PE12#sh running-config
Building configuration...

Current configuration : 3554 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf C
!

ip multicast-routing
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.1.2.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.33.33.33
!

interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/1
description <>
ip address 172.16.20.1 255.255.255.252
ip pim sparse-dense-mode
mpls bgp forwarding
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 172.16.20.2 102 broadcast
frame-relay lmi-type ansi
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface serial1/0
description <>
encapsulation frame-relay
frame-relay lmi-type ansi
ip address 192.168.1.2 255.255.255.252
frame-relay map ip 192.168.1.1 401 broadcast
ip ospf network point-to-point
ip pim sparse-dense-mode
no snmp trap link-status
mpls label protocol ldp
mpls ip

!
router ospf 1
network 192.168.1.0 0.0.0.3 area 0
network 10.1.2.1 0.0.0.0 area 0
network 172.16.20.0 0.0.0.3 area 0
passive-interface default
no passive-interface serial1/0
!
router bgp 64513
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 64513
neighbor 10.1.1.1 description <>
neighbor 10.1.1.1 update-source Loopback0
neighbor 172.16.20.2 remote-as 64514
neighbor 172.16.20.2 description <>
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.1 next-hop-self
neighbor 172.16.20.2 activate
neighbor 172.16.20.2 send-community extended
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
!
logging alarm informational
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
!
end

PE12#
PE12#

PE22#sh running-config
Building configuration...

Current configuration : 2944 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
!
!
!
ip multicast-routing
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.2.1.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.55.55.55
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 172.16.20.2 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
mpls bgp forwarding
serial restart-delay 0
frame-relay map ip 172.16.20.1 201 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.6 301 broadcast
frame-relay lmi-type ansi
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute bgp 64514 subnets
passive-interface default
no passive-interface Serial1/1
network 10.2.1.1 0.0.0.0 area 0
network 172.16.20.0 0.0.0.3 area 0
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64514
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 64514
neighbor 10.2.2.1 description <>
neighbor 10.2.2.1 update-source Loopback0
neighbor 172.16.20.1 remote-as 64513
neighbor 172.16.20.1 description <>
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.1 next-hop-self
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 send-community extended
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
logging alarm informational
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end


PE22#
PE21#sh running-config
Building configuration...

Current configuration : 2937 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.2.2.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.5 103 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
description <>
ip vrf forwarding CEA
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
!
interface Serial1/2
ip vrf forwarding CEA
ip address 172.16.3.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
!
address-family ipv4 vrf CEA
autonomous-system 100
network 172.16.2.0 0.0.0.3
network 172.16.3.0 0.0.0.3
network 172.16.254.0 0.0.0.255
redistribute bgp 64514 metric 1544 2000 255 200 1500
exit-address-family
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.2.2.1 0.0.0.0 area 0
network 192.168.0.0 0.0.0.3 area 0
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.2.1.1 remote-as 64514
neighbor 10.2.1.1 description <>
neighbor 10.2.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.1.1 activate
neighbor 10.2.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE21#


****************************************
OUTPUT

******************************************

CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.154.0/30 is directly connected, Tunnel102
O E2 172.16.200.0/24 [110/1] via 172.16.1.1, 00:04:17, FastEthernet0/0
O E2 172.16.25.0/24 [110/1] via 172.16.1.1, 00:05:17, FastEthernet0/0
C 172.16.15.0/24 is directly connected, Loopback0
C 172.16.1.0/30 is directly connected, FastEthernet0/0
O E2 172.16.2.0/30 [110/1] via 172.16.1.1, 00:05:17, FastEthernet0/0
O E2 172.16.3.0/30 [110/1] via 172.16.1.1, 00:05:17, FastEthernet0/0
C 172.16.100.0/30 is directly connected, Tunnel100
CE1A#

CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.254.0/30 is directly connected, Tunnel101
D 172.16.200.0/24 [90/2809856] via 172.16.2.1, 00:05:52, Serial1/0
C 172.16.25.0/24 is directly connected, Loopback0
D EX 172.16.15.0/24 [170/2681856] via 172.16.2.1, 00:05:53, Serial1/0
D EX 172.16.1.0/30 [170/2681856] via 172.16.2.1, 00:05:53, Serial1/0
C 172.16.2.0/30 is directly connected, Serial1/0
D 172.16.3.0/30 [90/2681856] via 172.16.2.1, 00:05:53, Serial1/0
C 172.16.100.0/30 is directly connected, Tunnel100
CE2A#

CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
C 172.16.154.0/30 is directly connected, Tunnel102
C 172.16.254.0/30 is directly connected, Tunnel101
C 172.16.200.0/24 is directly connected, Loopback0
D EX 172.16.25.0/24 [170/2809856] via 172.16.3.1, 00:05:56, Serial1/0
D EX 172.16.15.0/24 [170/2681856] via 172.16.3.1, 00:06:02, Serial1/0
D EX 172.16.1.0/30 [170/2681856] via 172.16.3.1, 00:06:02, Serial1/0
D 172.16.2.0/30 [90/2681856] via 172.16.3.1, 00:05:54, Serial1/0
C 172.16.3.0/30 is directly connected, Serial1/0
CE3A#

CE1A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.11.11.11), 00:02:14/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:02:14/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:02:14/00:00:00
Loopback0, Forward/Sparse-Dense, 00:02:14/00:00:00

(172.16.100.2, 224.11.11.11), 00:01:54/00:01:16, flags: LT
Incoming interface: Tunnel100, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:54/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:01:54/00:00:00

(*, 224.22.22.22), 00:01:43/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:01:43/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:01:43/00:00:00

(172.16.15.1, 224.22.22.22), 00:01:44/00:02:26, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Prune/Sparse-Dense, 00:01:44/00:01:17
Tunnel100, Forward/Sparse-Dense, 00:01:44/00:00:00

(*, 224.0.1.40), 00:28:32/00:02:10, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:02:43/00:00:00
Loopback0, Forward/Sparse-Dense, 00:28:32/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:26:21/00:00:00

CE1A#

CE1A#ping 224.22.22.22

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.22.22.22, timeout is 2 seconds:

Reply to request 0 from 172.16.100.2, 1144 ms
CE1A#

CE1A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.1 FastEthernet0/0 00:27:28/00:01:18 v2 1 / S
172.16.100.2 Tunnel100 00:03:51/00:01:22 v2 1 / S
CE1A#

CE1A#mtrace 172.16.15.1 172.16.25.1 224.22.22.22
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.25.1 via group 224.22.22.22
From source (?) to destination (?)
Querying full reverse path...
0 172.16.25.1
-1 172.16.100.2 PIM/Static [default]
-2 172.16.100.1 PIM [172.16.15.0/24]
-3 172.16.15.1
CE1A#

CE2A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.11.11.11), 00:02:40/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:02:40/00:00:00

(172.16.25.1, 224.11.11.11), 00:02:40/00:00:48, flags: PT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Prune/Sparse-Dense, 00:02:40/00:00:20

(*, 224.22.22.22), 00:02:50/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:02:50/00:00:00
Loopback0, Forward/Sparse-Dense, 00:02:50/00:00:00

(172.16.100.1, 224.22.22.22), 00:02:28/00:02:48, flags: LT
Incoming interface: Tunnel100, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:02:28/00:00:00
Serial1/0, Forward/Sparse-Dense, 00:02:29/00:00:00

(*, 224.0.1.40), 00:22:00/00:02:12, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:22:00/00:00:00
Serial1/0, Forward/Sparse-Dense, 00:18:51/00:00:00

CE2A#
CE2A#ping 224.11.11.11

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:

Reply to request 0 from 172.16.100.1, 1292 ms

CE2A#ping 224.33.33.33 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.33.33.33, timeout is 2 seconds:
Packet sent with a source address of 172.16.25.1

Reply to request 0 from 172.16.254.1, 700 ms
Reply to request 0 from 172.16.254.1, 700 ms
CE2A#

CE2A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.100.1 Tunnel100 00:03:43/00:01:20 v2 1 / S
172.16.254.1 Tunnel101 00:06:54/00:01:34 v2 1 / S
CE2A#


CE2A#mtrace 172.16.25.1 172.16.15.1 224.11.11.11
Type escape sequence to abort.
Mtrace from 172.16.25.1 to 172.16.15.1 via group 224.11.11.11
From source (?) to destination (?)
Querying full reverse path...
0 172.16.15.1
-1 172.16.100.1 PIM/Static [default]
-2 172.16.100.2 PIM [172.16.25.0/24]
-3 172.16.25.1
CE2A#


CE3A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.11.11.11), 00:20:22/stopped, RP 172.16.15.1, flags: SPF
Incoming interface: Tunnel102, RPF nbr 172.16.154.2, Mroute
Outgoing interface list: Null

(172.16.200.1, 224.11.11.11), 00:10:37/00:01:44, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering (data-header)
Outgoing interface list:
Tunnel101, Forward/Sparse-Dense, 00:01:33/00:02:19

(*, 224.22.22.22), 00:08:06/00:02:39, RP 172.16.15.1, flags: SP
Incoming interface: Tunnel102, RPF nbr 172.16.154.2, Mroute
Outgoing interface list: Null

(*, 224.33.33.33), 00:13:07/00:02:20, RP 172.16.15.1, flags: SJCL
Incoming interface: Tunnel102, RPF nbr 172.16.154.2, Mroute
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:13:07/00:02:20

(*, 224.0.1.39), 00:18:00/00:02:40, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel101, Forward/Sparse-Dense, 00:01:34/00:00:00
Tunnel102, Forward/Sparse-Dense, 00:02:54/00:00:00

(*, 224.0.1.40), 00:33:58/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel101, Forward/Sparse-Dense, 00:01:34/00:00:00
Tunnel102, Forward/Sparse-Dense, 00:02:54/00:00:00
Loopback0, Forward/Sparse-Dense, 00:33:58/00:00:00

(172.16.15.1, 224.0.1.40), 00:18:10/00:00:58, flags: L
Incoming interface: Tunnel102, RPF nbr 172.16.154.2, Mroute
Outgoing interface list:
Tunnel101, Forward/Sparse-Dense, 00:01:35/00:00:00
Loopback0, Forward/Sparse-Dense, 00:18:10/00:00:00

CE3A#
CE3A#

CE3A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.254.2 Tunnel101 00:16:29/00:01:32 v2 1 / S
172.16.154.2 Tunnel102 00:01:07/00:01:28 v2 1 / S
CE3A#

CE3A#ping 224.22.22.22 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.22.22.22, timeout is 2 seconds:
Packet sent with a source address of 172.16.200.1

Reply to request 0 from 172.16.254.2, 368 ms
Reply to request 0 from 172.16.100.2, 1328 ms

CE3A#ping 224.11.11.11 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:
Packet sent with a source address of 172.16.200.1

Reply to request 0 from 172.16.154.2, 1116 ms
CE3A#



CE3A#mtrace 172.16.200.1 172.16.15.1 224.11.11.11
Type escape sequence to abort.
Mtrace from 172.16.200.1 to 172.16.15.1 via group 224.11.11.11
From source (?) to destination (?)
Querying full reverse path...
0 172.16.15.1
-1 172.16.154.2 PIM Reached RP/Core [172.16.200.0/24]
CE3A#

CE1A#mtrace 172.16.15.1 172.16.200.1 224.11.11.11
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.200.1 via group 224.11.11.11
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.200.1
-1 * 172.16.3.2 PIM/Static [172.16.15.0/24]
CE1A#

CE1A#mtrace 172.16.15.1 172.16.200.1 224.33.33.33
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.200.1 via group 224.33.33.33
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.200.1
-1 * * 172.16.3.2 PIM/Static [172.16.15.0/24]
CE1A#

CE1A#mtrace 172.16.15.1 172.16.200.1 224.33.33.33
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.200.1 via group 224.33.33.33
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.200.1
-1 * * 172.16.3.2 PIM/Static [172.16.15.0/24]
CE1A#mtrace 172.16.15.1 172.16.25.1 224.22.22.22
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.25.1 via group 224.22.22.22
From source (?) to destination (?)
Querying full reverse path...
0 172.16.25.1
-1 172.16.100.2 PIM/Static [172.16.15.0/24]
-2 172.16.100.1 PIM Reached RP/Core [172.16.15.0/24]
CE1A#mtrace 172.16.15.1 172.16.25.1 224.11.11.11
Type escape sequence to abort.
Mtrace from 172.16.15.1 to 172.16.25.1 via group 224.11.11.11
From source (?) to destination (?)
Querying full reverse path...
0 172.16.25.1
-1 172.16.100.2 PIM/Static Prune sent upstream [172.16.15.0/24]
CE1A#

No comments:

Post a Comment