Wednesday, March 17, 2010

Implementing Anycast RP in MPLS L3 Mutlicast VPN LAB
















Configuration Guidelines
******************************************************************************
Scenario- ISP 64513 Needs to Provide Multicast Services to his MPLS
VPN Customer CEA and Customer CEA wants to run Anycast RP in their Multicast
Domain for failover redundancy


Design COnsiderations and Solution:
ISP 64513 Implements PIM Sparse Mode for the Custmer and Own AS.

Customer CEA Implements RP Selection via Anycast Auto RP using same IP Address
for the RPs at CE3A and CE4A. Enterprise also implements MSDP Between
the two RPs sharing the common ANycast Address for Providing Multicast Traffic
Merger in case of failover between RPs and to join the source talking via the
Active RP ealrier to the multicast group.


For Transporting Multicast Traffic Over MPLS L3 VPN ISP Implements Source
Specific Multicast (SSM) and Multicast Distributio Tree (MDT) feature
thereby carrying Multicast Traffic over auto GRET Tunnels between PEs (PE11
and PE14)

ISP AS used 64513
IGP Used ISIS with Core Links in level-2 and Loopbacks in Level-1
PE-CE Routing Protocol Used EBGP between PE1 and CE3A and CE4A

PE-CE Routing Protocol Used OSPF between PE2 and CE1A

VRF Used CEA
rd 64513:1
rt 64513:100

RP Selected for VRF CEA Via ANycast Auto RP
IGMP Group 224.11.11.11 Used at CE4A to Simulate Multicast Traffic
IGMP Group 224.33.33.33 Used at CE3A to Simulate Multicast Traffic
IGMP Group 224.222.222.222 Used at CE1A to Simulate Multicast Traffic
IGMP Group 224.111.111.111 Used at CE5A to Simulate Multicast Traffic

*************************************************************************


CE5A#sh running-config
Building configuration...

Current configuration : 920 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE5A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.252.1 255.255.255.0
ip pim sparse-dense-mode
ip ospf network point-to-point
ip igmp join-group 224.111.111.111
!
interface FastEthernet0/0
ip address 172.16.154.2 255.255.255.0
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.156.2 255.255.255.0
ip pim sparse-dense-mode
duplex auto
speed auto
!
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE5A#
CE5A#

CE4A#sh running-config
Building configuration...

Current configuration : 2236 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE4A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.10.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
!
interface Loopback1
ip address 172.16.255.255 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
ip address 172.16.156.1 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10
log-adjacency-changes
redistribute bgp 64514 subnets
passive-interface Serial1/0
network 172.16.0.0 0.0.255.255 area 0
default-information originate always
!
router bgp 64514
no synchronization
bgp router-id 172.16.154.1
bgp log-neighbor-changes
network 172.16.154.0 mask 255.255.255.0
network 172.16.155.0 mask 255.255.255.252
network 172.16.156.0 mask 255.255.255.0
network 172.16.252.0 mask 255.255.255.0
network 172.16.254.0 mask 255.255.255.0
network 172.16.255.255 mask 255.255.255.255
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 soft-reconfiguration inbound
distance bgp 120 220 10
no auto-summary
!
ip http server
ip route 172.16.2.0 255.255.255.0 FastEthernet0/1
!
!
ip pim send-rp-announce Loopback1 scope 100
ip pim send-rp-discovery Loopback1 scope 100
ip msdp peer 172.16.20.1 connect-source Loopback0
ip msdp originator-id Loopback0
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE4A#

CE3A#sh running-config
Building configuration...

Current configuration : 2151 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.20.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.33.33.33
!
interface Loopback1
ip address 172.16.255.255 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
ip address 172.16.154.1 255.255.255.0
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10
log-adjacency-changes
redistribute bgp 64514 subnets
passive-interface Serial1/0
network 172.16.0.0 0.0.255.255 area 0
default-information originate always
!
router bgp 64514
no synchronization
bgp router-id 172.16.154.1
bgp log-neighbor-changes
network 172.16.154.0 mask 255.255.255.0
network 172.16.156.0 mask 255.255.255.0
network 172.16.252.0 mask 255.255.255.0
network 172.16.254.0 mask 255.255.255.0
network 172.16.255.255 mask 255.255.255.255
neighbor 172.16.2.1 remote-as 64513
neighbor 172.16.2.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip route 172.16.1.0 255.255.255.0 FastEthernet0/1
!
!
ip pim send-rp-announce Loopback1 scope 100
ip pim send-rp-discovery Loopback1 scope 100
ip msdp peer 172.16.10.1 connect-source Loopback0
ip msdp originator-id Loopback0
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE3A#

CE1A#sh running-config
Building configuration...

Current configuration : 1264 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.30.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.22.22.22
ip igmp join-group 224.222.222.222
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.3.2 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE1A#

PE1#sh running-config
Building configuration...

Current configuration : 3334 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
mdt default 239.1.1.1
mdt data 238.2.2.0 0.0.0.255 threshold 1
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf CEA
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding CEA
ip address 172.16.100.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback2
no ip address
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/1
ip vrf forwarding CEA
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
ip vrf forwarding CEA
ip address 172.16.4.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.2.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
neighbor 172.16.2.2 remote-as 64514
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery scope 100
ip pim ssm default
!
logging alarm informational
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

PE1#

PE2#sh running-config
Building configuration...

Current configuration : 2814 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
mdt default 239.1.1.1
mdt data 239.2.2.0 0.0.0.255 threshold 1
!
no ip domain lookup
ip multicast-routing
ip multicast-routing vrf CEA
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding CEA
ip address 172.16.200.1 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback2
no ip address
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/1
ip vrf forwarding CEA
ip address 172.16.3.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router isis
net 49.0002.4444.2222.3333.00
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
!
logging alarm informational
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

PE2#

************************************************************

OUTPUT
************************************************************

ROuting Table & Connectivity
***********************************
CE5A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.154.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 13 subnets, 3 masks
C 172.16.156.0/24 is directly connected, FastEthernet0/1
C 172.16.154.0/24 is directly connected, FastEthernet0/0
O 172.16.155.0/30 [110/2] via 172.16.154.1, 00:00:05, FastEthernet0/0
C 172.16.252.0/24 is directly connected, Loopback0
O E2 172.16.200.1/32 [110/1] via 172.16.154.1, 00:00:05, FastEthernet0/0
O E2 172.16.30.1/32 [110/1] via 172.16.154.1, 00:00:05, FastEthernet0/0
O 172.16.20.1/32 [110/2] via 172.16.154.1, 00:00:05, FastEthernet0/0
O 172.16.10.1/32 [110/3] via 172.16.154.1, 00:00:05, FastEthernet0/0
O 172.16.255.255/32 [110/2] via 172.16.154.1, 00:00:05, FastEthernet0/0
O 172.16.1.0/30 [110/66] via 172.16.154.1, 00:00:05, FastEthernet0/0
O 172.16.2.0/30 [110/65] via 172.16.154.1, 00:00:05, FastEthernet0/0
O E2 172.16.3.0/30 [110/1] via 172.16.154.1, 00:00:05, FastEthernet0/0
O E2 172.16.100.1/32 [110/1] via 172.16.154.1, 00:00:08, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 172.16.154.1, 00:00:32, FastEthernet0/0

CE5A#ping 172.16.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 532/689/952 ms
CE5A#tra
CE5A#traceroute 172.16.30.1

Type escape sequence to abort.
Tracing the route to 172.16.30.1

1 172.16.154.1 228 msec 216 msec 192 msec
2 172.16.2.1 372 msec 688 msec 344 msec
3 172.16.3.1 332 msec 568 msec 424 msec
4 172.16.3.2 512 msec * 656 msec
CE5A#ping 224.222.222.222

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.222.222.222, timeout is 2 seconds:

Reply to request 0 from 172.16.3.2, 1524 ms
Reply to request 0 from 172.16.3.2, 1692 ms
Reply to request 0 from 172.16.3.2, 1528 ms
CE5A#

PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
B 172.16.156.0/24 [20/3] via 172.16.1.2, 00:00:05
B 172.16.154.0/24 [20/2] via 172.16.1.2, 00:00:05
B 172.16.155.0/30 [20/0] via 172.16.1.2, 01:06:38
B 172.16.252.0/24 [20/3] via 172.16.1.2, 00:00:05
B 172.16.200.1/32 [200/0] via 10.0.2.1, 01:06:54
B 172.16.30.1/32 [200/65] via 10.0.2.1, 00:03:35
B 172.16.255.255/32 [20/0] via 172.16.1.2, 00:33:38
C 172.16.1.0/30 is directly connected, Serial1/2
B 172.16.3.0/30 [200/0] via 10.0.2.1, 00:03:50
C 172.16.100.1/32 is directly connected, Loopback1

PE2#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 11 subnets, 3 masks
B 172.16.156.0/24 [200/3] via 10.0.1.1, 00:00:37
B 172.16.154.0/24 [200/2] via 10.0.1.1, 00:00:37
B 172.16.155.0/30 [200/0] via 10.0.1.1, 01:07:07
B 172.16.252.0/24 [200/3] via 10.0.1.1, 00:00:37
C 172.16.200.1/32 is directly connected, Loopback1
O 172.16.30.1/32 [110/65] via 172.16.3.2, 00:04:19, Serial1/1
B 172.16.255.255/32 [200/0] via 10.0.1.1, 01:07:32
B 172.16.1.0/30 [200/0] via 10.0.1.1, 01:07:22
B 172.16.2.0/30 [200/0] via 10.0.1.1, 00:00:04
C 172.16.3.0/30 is directly connected, Serial1/1
B 172.16.100.1/32 [200/0] via 10.0.1.1, 01:39:23


CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.30.0/24 is directly connected, Loopback0
C 172.16.3.0/30 is directly connected, Serial1/0

CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 11 subnets, 3 masks
O E2 172.16.156.0/24 [110/2] via 172.16.3.1, 00:00:12, Serial1/0
O E2 172.16.154.0/24 [110/1] via 172.16.3.1, 00:00:12, Serial1/0
O E2 172.16.155.0/30 [110/1] via 172.16.3.1, 00:00:12, Serial1/0
O E2 172.16.252.0/24 [110/2] via 172.16.3.1, 00:00:12, Serial1/0
O 172.16.200.1/32 [110/65] via 172.16.3.1, 00:00:12, Serial1/0
C 172.16.30.0/24 is directly connected, Loopback0
O E2 172.16.255.255/32 [110/1] via 172.16.3.1, 00:00:12, Serial1/0
O IA 172.16.1.0/30 [110/65] via 172.16.3.1, 00:00:12, Serial1/0
O IA 172.16.2.0/30 [110/65] via 172.16.3.1, 00:00:12, Serial1/0
C 172.16.3.0/30 is directly connected, Serial1/0
O IA 172.16.100.1/32 [110/65] via 172.16.3.1, 00:00:12, Serial1/0

CE1A#ping 172.16.255.255

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.255.255, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 328/608/952 ms

CE1A#ping 224.11.11.11

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:

Reply to request 0 from 172.16.155.2, 916 ms
CE1A#ping 224.33.33.33

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.33.33.33, timeout is 2 seconds:

Reply to request 0 from 172.16.2.2, 840 ms
Reply to request 0 from 172.16.2.2, 1196 ms
CE1A#ping 224.111.111.111

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.111.111.111, timeout is 2 seconds:

Reply to request 0 from 172.16.154.2, 1380 ms
Reply to request 0 from 172.16.154.2, 1560 ms

CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 13 subnets, 3 masks
O 172.16.156.0/24 [110/2] via 172.16.154.2, 00:00:33, FastEthernet0/0
C 172.16.154.0/24 is directly connected, FastEthernet0/0
C 172.16.155.0/30 is directly connected, FastEthernet0/1
O 172.16.252.0/24 [110/2] via 172.16.154.2, 00:00:33, FastEthernet0/0
O E2 172.16.200.1/32 [110/1] via 172.16.155.2, 00:00:33, FastEthernet0/1
O E2 172.16.30.1/32 [110/1] via 172.16.155.2, 00:00:33, FastEthernet0/1
C 172.16.20.0/24 is directly connected, Loopback0
O 172.16.10.1/32 [110/2] via 172.16.155.2, 00:00:33, FastEthernet0/1
C 172.16.255.255/32 is directly connected, Loopback1
O 172.16.1.0/30 [110/65] via 172.16.155.2, 00:00:33, FastEthernet0/1
S 172.16.1.0/24 is directly connected, FastEthernet0/1
O E2 172.16.3.0/30 [110/1] via 172.16.155.2, 00:00:33, FastEthernet0/1
O E2 172.16.100.1/32 [110/1] via 172.16.155.2, 00:00:33, FastEthernet0/1

CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 14 subnets, 3 masks
O 172.16.156.0/24 [110/2] via 172.16.154.2, 00:00:20, FastEthernet0/0
C 172.16.154.0/24 is directly connected, FastEthernet0/0
C 172.16.155.0/30 is directly connected, FastEthernet0/1
O 172.16.252.0/24 [110/2] via 172.16.154.2, 00:00:20, FastEthernet0/0
O E2 172.16.200.1/32 [110/1] via 172.16.155.2, 00:00:20, FastEthernet0/1
O E2 172.16.30.1/32 [110/1] via 172.16.155.2, 00:00:20, FastEthernet0/1
C 172.16.20.0/24 is directly connected, Loopback0
O 172.16.10.1/32 [110/2] via 172.16.155.2, 00:00:20, FastEthernet0/1
C 172.16.255.255/32 is directly connected, Loopback1
O 172.16.1.0/30 [110/65] via 172.16.155.2, 00:00:20, FastEthernet0/1
S 172.16.1.0/24 is directly connected, FastEthernet0/1
C 172.16.2.0/30 is directly connected, Serial1/0
O E2 172.16.3.0/30 [110/1] via 172.16.155.2, 00:00:20, FastEthernet0/1
O E2 172.16.100.1/32 [110/1] via 172.16.155.2, 00:00:20, FastEthernet0/1

CE4A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 14 subnets, 3 masks
O 172.16.156.0/24 [110/3] via 172.16.155.1, 00:00:08, FastEthernet0/1
O 172.16.154.0/24 [110/2] via 172.16.155.1, 00:00:08, FastEthernet0/1
C 172.16.155.0/30 is directly connected, FastEthernet0/1
O 172.16.252.0/24 [110/3] via 172.16.155.1, 00:00:08, FastEthernet0/1
B 172.16.200.1/32 [20/0] via 172.16.1.1, 01:07:15
B 172.16.30.1/32 [120/0] via 172.16.1.1, 00:01:00
O 172.16.20.1/32 [110/2] via 172.16.155.1, 00:00:09, FastEthernet0/1
C 172.16.10.0/24 is directly connected, Loopback0
C 172.16.255.255/32 is directly connected, Loopback1
C 172.16.1.0/30 is directly connected, Serial1/0
O 172.16.2.0/30 [110/65] via 172.16.155.1, 00:00:09, FastEthernet0/1
S 172.16.2.0/24 is directly connected, FastEthernet0/1
B 172.16.3.0/30 [120/0] via 172.16.1.1, 00:01:01
B 172.16.100.1/32 [20/0] via 172.16.1.1, 01:07:15


********************************
PIM NEIGHBOURSHIP
********************************


PE1#sh ip pim vrf CEA nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.2.1 Tunnel0 01:50:52/00:01:43 v2 1 / DR B S
172.16.2.2 Serial1/1 00:04:17/00:01:24 v2 1 / S
172.16.1.2 Serial1/2 01:11:47/00:01:41 v2 1 / S
PE1#



PE2#sh ip pim vrf CEA nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.3.2 Serial1/1 00:09:06/00:01:21 v2 1 / S
10.0.1.1 Tunnel0 01:51:14/00:01:19 v2 1 / B S
PE2#



CE5A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.154.1 FastEthernet0/0 00:42:18/00:01:16 v2 1 / S
172.16.156.1 FastEthernet0/1 00:00:05/00:01:40 v2 1 / S
CE5A#

CE3A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.1 Serial1/0 00:07:59/00:01:39 v2 1 / S
172.16.154.2 FastEthernet0/0 00:36:02/00:01:38 v2 1 / DR S
172.16.155.2 FastEthernet0/1 01:15:18/00:01:33 v2 1 / DR S
CE3A#

CE4A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.156.2 FastEthernet0/0 00:00:29/00:01:15 v2 1 / DR S
172.16.155.1 FastEthernet0/1 01:33:56/00:01:24 v2 1 / S
172.16.1.1 Serial1/0 01:16:54/00:01:20 v2 1 / S
CE4A#

CE1A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.3.1 Serial1/0 00:14:04/00:01:36 v2 1 / S
CE1A#


***************************
MSDP NEIGBOURSHIP
***************************

CE3A#sh ip msdp peer
MSDP Peer 172.16.10.1 (?), AS ?
Connection status:
State: Up, Resets: 0, Connection source: Loopback0 (172.16.20.1)
Uptime(Downtime): 00:32:39, Messages sent/received: 36/45
Output messages discarded: 0
Connection and counters cleared 00:33:19 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 7
Input queue size: 0, Output queue size: 0
MD5 signature protection on MSDP TCP connection: not enabled
CE3A#


CE4A#sh ip ms
CE4A#sh ip msdp pe
CE4A#sh ip msdp peer
MSDP Peer 172.16.20.1 (?), AS ?
Connection status:
State: Up, Resets: 0, Connection source: Loopback0 (172.16.10.1)
Uptime(Downtime): 00:32:54, Messages sent/received: 45/36
Output messages discarded: 0
Connection and counters cleared 00:33:55 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
MD5 signature protection on MSDP TCP connection: not enabled
CE4A#

********************************
Anycast RP Test

********************************

When the Active RP fails ,
the Anycast RP on the Other CE Takes over
and it has the knowledge of the Multicast Topology
via MSDP and can still forward traffic.


CE3A#sh ip int brief
Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0/0 172.16.154.1 YES manual up up

FastEthernet0/1 172.16.155.1 YES manual up up

Serial1/0 172.16.2.2 YES manual up up

Serial1/1 unassigned YES unset administratively down down

Serial1/2 unassigned YES unset administratively down down

Serial1/3 unassigned YES unset administratively down down

Loopback0 172.16.20.1 YES manual up up

Loopback1 172.16.255.255 YES manual up up

CE3A#conf t
Enter configuration commands, one per line. End with CNTL/Z.
CE3A(config)#int s1/0
CE3A(config-if)#shu
CE3A(config-if)#shutdown
CE3A(config-if)#^Z

CE1A#ping vrf
CE1A#ping
Protocol [ip]:
Target IP address: 224.111.111.111
Repeat count [1]: 150
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 150, 100-byte ICMP Echos to 224.111.111.111, timeout is 2 seconds:

Reply to request 0 from 172.16.154.2, 528 ms
Reply to request 0 from 172.16.154.2, 540 ms
Reply to request 1 from 172.16.154.2, 400 ms
Reply to request 1 from 172.16.154.2, 568 ms
Reply to request 2 from 172.16.154.2, 624 ms
Reply to request 2 from 172.16.154.2, 624 ms
Reply to request 3 from 172.16.154.2, 424 ms
Reply to request 3 from 172.16.154.2, 536 ms
Reply to request 4 from 172.16.154.2, 520 ms
Reply to request 4 from 172.16.154.2, 520 ms
Reply to request 5 from 172.16.154.2, 528 ms
Reply to request 5 from 172.16.154.2, 528 ms
Reply to request 6 from 172.16.154.2, 496 ms
Reply to request 6 from 172.16.154.2, 500 ms
Reply to request 7 from 172.16.154.2, 720 ms
Reply to request 7 from 172.16.154.2, 720 ms
Reply to request 8 from 172.16.154.2, 736 ms
Reply to request 8 from 172.16.154.2, 736 ms
Reply to request 9 from 172.16.154.2, 328 ms
Reply to request 9 from 172.16.154.2, 548 ms
Reply to request 10 from 172.16.154.2, 436 ms
Reply to request 10 from 172.16.154.2, 436 ms
Reply to request 11 from 172.16.154.2, 572 ms
Reply to request 11 from 172.16.154.2, 576 ms
Reply to request 12 from 172.16.154.2, 476 ms
Reply to request 12 from 172.16.154.2, 476 ms
Reply to request 13 from 172.16.154.2, 392 ms
Reply to request 13 from 172.16.154.2, 392 ms
Reply to request 14 from 172.16.154.2, 536 ms
Reply to request 14 from 172.16.154.2, 548 ms
Reply to request 15 from 172.16.154.2, 656 ms
Reply to request 15 from 172.16.154.2, 656 ms
Reply to request 16 from 172.16.154.2, 660 ms
Reply to request 16 from 172.16.154.2, 660 ms.......
Reply to request 24 from 172.16.154.2, 932 ms
Reply to request 24 from 172.16.154.2, 932 ms
Reply to request 25 from 172.16.154.2, 1820 ms
Reply to request 25 from 172.16.154.2, 1820 ms
Reply to request 26 from 172.16.154.2, 748 ms
Reply to request 26 from 172.16.154.2, 748 ms
Reply to request 27 from 172.16.154.2, 388 ms
Reply to request 27 from 172.16.154.2, 388 ms
Reply to request 28 from 172.16.154.2, 656 ms
Reply to request 28 from 172.16.154.2, 660 ms
Reply to request 29 from 172.16.154.2, 496 ms
Reply to request 29 from 172.16.154.2, 592 ms
Reply to request 30 from 172.16.154.2, 568 ms
Reply to request 30 from 172.16.154.2, 576 ms
Reply to request 31 from 172.16.154.2, 936 ms
Reply to request 31 from 172.16.154.2, 1008 ms
Reply to request 32 from 172.16.154.2, 840 ms
Reply to request 32 from 172.16.154.2, 844 ms
Reply to request 33 from 172.16.154.2, 1200 ms
Reply to request 33 from 172.16.154.2, 1200 ms
Reply to request 34 from 172.16.154.2, 356 ms
Reply to request 34 from 172.16.154.2, 356 ms
Reply to request 35 from 172.16.154.2, 564 ms
Reply to request 35 from 172.16.154.2, 568 ms
Reply to request 36 from 172.16.154.2, 564 ms
Reply to request 36 from 172.16.154.2, 828 ms
Reply to request 37 from 172.16.154.2, 340 ms
Reply to request 37 from 172.16.154.2, 340 ms
Reply to request 38 from 172.16.154.2, 564 ms
Reply to request 38 from 172.16.154.2, 564 ms
Reply to request 39 from 172.16.154.2, 716 ms
Reply to request 39 from 172.16.154.2, 716 ms
Reply to request 40 from 172.16.154.2, 636 ms
Reply to request 40 from 172.16.154.2, 640 ms
Reply to request 41 from 172.16.154.2, 812 ms
Reply to request 41 from 172.16.154.2, 812 ms
Reply to request 42 from 172.16.154.2, 560 ms
Reply to request 42 from 172.16.154.2, 560 ms
Reply to request 43 from 172.16.154.2, 488 ms
Reply to request 43 from 172.16.154.2, 488 ms
Reply to request 44 from 172.16.154.2, 468 ms
Reply to request 44 from 172.16.154.2, 600 ms
Reply to request 45 from 172.16.154.2, 724 ms
Reply to request 45 from 172.16.154.2, 724 ms
Reply to request 46 from 172.16.154.2, 480 ms
Reply to request 46 from 172.16.154.2, 480 ms
Reply to request 47 from 172.16.154.2, 1040 ms
Reply to request 47 from 172.16.154.2, 1044 ms
Reply to request 48 from 172.16.154.2, 392 ms
Reply to request 48 from 172.16.154.2, 396 ms
Reply to request 49 from 172.16.154.2, 572 ms
Reply to request 49 from 172.16.154.2, 572 ms
Reply to request 50 from 172.16.154.2, 908 ms
Reply to request 50 from 172.16.154.2, 908 ms
Reply to request 51 from 172.16.154.2, 560 ms
Reply to request 51 from 172.16.154.2, 560 ms....
Reply to request 56 from 172.16.154.2, 900 ms
Reply to request 56 from 172.16.154.2, 900 ms
Reply to request 57 from 172.16.154.2, 576 ms
Reply to request 57 from 172.16.154.2, 576 ms
Reply to request 58 from 172.16.154.2, 864 ms
Reply to request 58 from 172.16.154.2, 864 ms
Reply to request 59 from 172.16.154.2, 808 ms
Reply to request 59 from 172.16.154.2, 812 ms
Reply to request 60 from 172.16.154.2, 1016 ms
Reply to request 60 from 172.16.154.2, 1016 ms
Reply to request 61 from 172.16.154.2, 1456 ms
Reply to request 61 from 172.16.154.2, 1460 ms
Reply to request 62 from 172.16.154.2, 1464 ms
Reply to request 62 from 172.16.154.2, 1464 ms
Reply to request 63 from 172.16.154.2, 936 ms
Reply to request 63 from 172.16.154.2, 1080 ms
Reply to request 64 from 172.16.154.2, 1572 ms
Reply to request 64 from 172.16.154.2, 1572 ms
Reply to request 65 from 172.16.154.2, 1056 ms
Reply to request 65 from 172.16.154.2, 1056 ms
CE1A#tra






CE3A#sh ip msdp sa-cache
MSDP Source-Active Cache - 7 entries
(172.16.3.2, 224.33.33.33), RP 172.16.10.1, BGP/AS 0, 00:03:03/00:05:37, Peer 17
2.16.10.1
(172.16.30.1, 224.33.33.33), RP 172.16.10.1, BGP/AS 0, 00:03:03/00:05:37, Peer 1
72.16.10.1
(172.16.3.2, 224.11.11.11), RP 172.16.10.1, BGP/AS 0, 00:03:12/00:05:37, Peer 17
2.16.10.1
(172.16.30.1, 224.11.11.11), RP 172.16.10.1, BGP/AS 0, 00:02:10/00:05:37, Peer 1
72.16.10.1
(172.16.200.1, 224.11.11.11), RP 172.16.10.1, BGP/AS 0, 00:05:52/00:02:50, Peer
172.16.10.1
(172.16.3.2, 224.111.111.111), RP 172.16.10.1, BGP/AS 0, 00:02:53/00:05:37, Peer
172.16.10.1
(172.16.30.1, 224.111.111.111), RP 172.16.10.1, BGP/AS 0, 00:02:53/00:05:37, Pee
r 172.16.10.1





*************************************
mtrace during anycast RP switchover
*************************************
CE3A#sh ip ms
CE3A#sh ip msdp pe

PE2#mtrace vrf CEA 172.16.200.1 172.16.255.255 224.11.11.11
Type escape sequence to abort.
Mtrace from 172.16.200.1 to 172.16.255.255 via group 224.11.11.11 in VRF CEA
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.255.255
-1 * 172.16.2.2 PIM Reached RP/Core [172.16.200.1/32]



PE2#ping vrf CEA
Protocol [ip]:
Target IP address: 224.111.111.111
Repeat count [1]: 150
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 150, 100-byte ICMP Echos to 224.111.111.111, timeout is 2 seconds:

Reply to request 0 from 172.16.154.2, 508 ms
Reply to request 1 from 172.16.154.2, 316 ms
Reply to request 2 from 172.16.154.2, 424 ms
Reply to request 3 from 172.16.154.2, 600 ms
Reply to request 4 from 172.16.154.2, 496 ms
Reply to request 5 from 172.16.154.2, 288 ms
Reply to request 6 from 172.16.154.2, 308 ms
Reply to request 7 from 172.16.154.2, 224 ms
Reply to request 8 from 172.16.154.2, 336 ms
Reply to request 9 from 172.16.154.2, 372 ms.
Reply to request 11 from 172.16.154.2, 596 ms
Reply to request 12 from 172.16.154.2, 336 ms
Reply to request 13 from 172.16.154.2, 416 ms
Reply to request 14 from 172.16.154.2, 456 ms
Reply to request 15 from 172.16.154.2, 376 ms
Reply to request 16 from 172.16.154.2, 388 ms
Reply to request 17 from 172.16.154.2, 444 ms
Reply to request 18 from 172.16.154.2, 332 ms
PE2#


CE3A#sh ip msdp sa-cache
MSDP Source-Active Cache - 2 entries
(172.16.200.1, 224.11.11.11), RP 172.16.10.1, BGP/AS 0, 00:09:02/now, Peer 172.1
6.10.1
(172.16.200.1, 224.111.111.111), RP 172.16.10.1, BGP/AS 0, 00:01:35/00:05:16, Pe
er 172.16.10.1
CE3A#


PE2#mtrace vrf CEA 172.16.200.1 172.16.252.1 224.111.111.111
Type escape sequence to abort.
Mtrace from 172.16.200.1 to 172.16.252.1 via group 224.111.111.111 in VRF CEA
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.252.1
-1 * 172.16.154.2 PIM [172.16.200.1/32]
-2 * 172.16.154.1 PIM Reached RP/Core [172.16.200.1/32]
-3 * 172.16.155.2 PIM Reached RP/Core [172.16.200.1/32]
-4 * 172.16.1.1 PIM Admin. Prohibited [172.16.200.1/32]
-5 * 0.0.0.0 PIM [172.16.200.1/32]
#NAME?

PE2#

*****************************
MROUTE
******************************

CE1A#ping 224.111.111.111

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.111.111.111, timeout is 2 seconds:

Reply to request 0 from 172.16.156.2, 1040 ms
Reply to request 0 from 172.16.156.2, 1044 ms
CE1A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.111.111.111), 00:00:04/stopped, RP 172.16.255.255, flags: SPF
Incoming interface: Serial1/0, RPF nbr 172.16.3.1
Outgoing interface list: Null

(172.16.30.1, 224.111.111.111), 00:00:04/00:03:28, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:00:03/00:03:26

(*, 224.22.22.22), 00:22:36/00:02:55, RP 172.16.255.255, flags: SJCL
Incoming interface: Serial1/0, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:22:36/00:02:55

(*, 224.222.222.222), 00:08:33/00:02:55, RP 172.16.255.255, flags: SJCL
Incoming interface: Serial1/0, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:08:33/00:02:55

(*, 224.0.1.39), 00:22:51/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:22:51/00:00:00

(172.16.255.255, 224.0.1.39), 00:00:42/00:02:17, flags: PT
Incoming interface: Serial1/0, RPF nbr 172.16.3.1
Outgoing interface list: Null

(*, 224.0.1.40), 00:54:19/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:50:59/00:00:00
Loopback0, Forward/Sparse-Dense, 00:54:06/00:00:00

(172.16.255.255, 224.0.1.40), 00:22:51/00:02:53, flags: LT
Incoming interface: Serial1/0, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:22:51/00:00:00

CE1A#

CE5A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.111.111.111), 00:37:51/00:02:35, RP 172.16.255.255, flags: SJCL
Incoming interface: FastEthernet0/1, RPF nbr 172.16.156.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:37:51/00:02:57

(172.16.3.2, 224.111.111.111), 00:00:25/00:02:35, flags: LJ
Incoming interface: FastEthernet0/0, RPF nbr 172.16.154.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:00:25/00:02:57

(172.16.30.1, 224.111.111.111), 00:00:25/00:02:34, flags: LJ
Incoming interface: FastEthernet0/0, RPF nbr 172.16.154.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:00:25/00:02:57

(*, 224.0.1.39), 00:38:46/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:01:40/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:38:47/00:00:00

(172.16.255.255, 224.0.1.39), 00:01:41/00:01:57, flags: PTX
Incoming interface: FastEthernet0/1, RPF nbr 172.16.156.1
Outgoing interface list:
FastEthernet0/0, Prune/Sparse-Dense, 00:01:06/00:01:53

(*, 224.0.1.40), 00:44:05/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:01:43/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:43:57/00:00:00
Loopback0, Forward/Sparse-Dense, 00:44:06/00:00:00

(172.16.255.255, 224.0.1.40), 00:38:38/00:02:26, flags: LT
Incoming interface: FastEthernet0/1, RPF nbr 172.16.156.1
Outgoing interface list:
FastEthernet0/0, Prune/Sparse-Dense, 00:00:40/00:02:20
Loopback0, Forward/Sparse-Dense, 00:38:39/00:00:00

CE5A#

CE3A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.111.111.111), 00:38:12/stopped, RP 172.16.255.255, flags: SP
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

(172.16.3.2, 224.111.111.111), 00:00:45/00:02:44, flags:
Incoming interface: Serial1/0, RPF nbr 172.16.2.1
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:00:45/00:02:44
FastEthernet0/0, Forward/Sparse-Dense, 00:00:45/00:02:44

(172.16.30.1, 224.111.111.111), 00:00:45/00:02:44, flags:
Incoming interface: Serial1/0, RPF nbr 172.16.2.1
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:00:45/00:02:44
FastEthernet0/0, Forward/Sparse-Dense, 00:00:45/00:02:44

(*, 224.33.33.33), 01:00:13/00:02:37, RP 172.16.255.255, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:00:13/00:02:37

(*, 224.0.1.39), 01:22:35/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:10:58/00:00:00
Loopback1, Forward/Sparse-Dense, 01:22:28/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 01:22:28/00:00:00
Loopback0, Forward/Sparse-Dense, 01:22:28/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:22:35/00:00:00

(172.16.255.255, 224.0.1.39), 01:22:35/00:02:00, flags: LTA
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:10:58/00:00:00, A
FastEthernet0/0, Forward/Sparse-Dense, 01:22:28/00:00:00, A
Loopback0, Forward/Sparse-Dense, 01:22:28/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:22:28/00:00:00, A

(*, 224.0.1.40), 01:46:46/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:10:46/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:38:49/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:18:05/00:00:00
Loopback1, Forward/Sparse-Dense, 01:22:28/00:00:00

(172.16.255.255, 224.0.1.40), 01:21:35/00:02:43, flags: PLTA
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Prune/Sparse-Dense, 00:01:15/00:01:47, A
FastEthernet0/0, Prune/Sparse-Dense, 00:00:52/00:02:08, A
FastEthernet0/1, Prune/Sparse-Dense, 00:44:22/00:02:06, A

CE3A#

CE4A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.11.11.11), 01:19:33/00:02:13, RP 172.16.255.255, flags: SJCLF
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:19:33/00:02:13

(*, 224.111.111.111), 00:02:04/00:03:24, RP 172.16.255.255, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:04/00:03:24

(172.16.3.2, 224.111.111.111), 00:01:05/00:01:54, flags: A
Incoming interface: FastEthernet0/1, RPF nbr 172.16.155.1
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:01:05/00:03:23

(172.16.30.1, 224.111.111.111), 00:01:05/00:01:54, flags: A
Incoming interface: FastEthernet0/1, RPF nbr 172.16.155.1
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:01:05/00:03:23

(*, 224.22.22.22), 00:15:41/00:02:47, RP 172.16.255.255, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:15:41/00:02:47

(*, 224.222.222.222), 00:09:34/00:02:47, RP 172.16.255.255, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0, Forward/Sparse-Dense, 00:09:34/00:02:47

(*, 224.0.1.39), 01:20:13/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:21/00:00:00
Loopback1, Forward/Sparse-Dense, 00:44:57/00:00:00
Loopback0, Forward/Sparse-Dense, 00:44:57/00:00:00
Serial1/0, Forward/Sparse-Dense, 01:20:13/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:20:13/00:00:00

(172.16.255.255, 224.0.1.39), 00:47:40/00:02:16, flags: LA
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:21/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 00:44:57/00:00:00, A
Loopback0, Forward/Sparse-Dense, 00:44:57/00:00:00
Serial1/0, Forward/Sparse-Dense, 00:44:57/00:00:00

(*, 224.0.1.40), 01:35:49/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:21/00:00:00
Loopback1, Forward/Sparse-Dense, 00:44:57/00:00:00
Serial1/0, Forward/Sparse-Dense, 01:35:47/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 01:35:48/00:00:00

(172.16.255.255, 224.0.1.40), 01:19:13/00:02:43, flags: LA
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:02:04/00:00:00, A
Serial1/0, Forward/Sparse-Dense, 00:45:18/00:00:00

CE4A#

No comments:

Post a Comment