Sunday, March 28, 2010

Implementing Inter-AS MPLS VPN using Class Based Tunnel Selection with Inter-AS MPLS TE Tunnel for QoS LAB



















********************************************************************
Config Guidelines
*******************************************************************
Scenario: Inter-AS MPLS VPN with Guranteed QoS for the VPN using
Inter-AS MPLS TE Between ISPs and Inter-Area MPLS TEs with ISP backbone

Scenario Description- ISPA and ISPB are running Hierarichal OSPF Backbone and the
LSP Spanning acorss Multiple Areas and wants to implement Traffic Forwarding for an
MPLS L3 VPN Customers whose one Site is with ISPA and other Site with ISPB.
Also the MPLS L3 VPN Traffic needs to be forwarded across differnt
Traffic ENgineering Tunnels based upon the variuos QoS Levels Offered under Short
Pipe Mode wherein Service Provider'S QoS policies conforms to CUstomer's QoS Policies.
This way the ISPs can Offer Guranteed BW Services accroding to Customer requiremnets for
different classes of traffic such as Voice Payload,Voice Signalling and Normal Data.


All this ISPs have to achive while forming InterArea Traffic Enginerring
Tunnels via the LSP Spannings acorss Multiple Areas and Inter-AS Traffic
Engineering Tunnels Spanning between the ASBRs

Design Considerations and Soultions:

ISP Can form Inter-Domain TE Tunnels by annoucning the TE Tunnels as a Static
into ROuting Table using "autoroute destination" instead of "autoroute announce"


Also on the OSPF ABR and ASBR Routers Traffic Engineering needs to be enabled both for
all the Areas under global instance of OSPF.

For establishing Inter-AS TE Tunnel between ASBRs we need to use the "vertibam" opton under
path option for the Inter-AS TE Tunnels whereby we ignore the ASBR Links for TE Tunnel Path Calc
which are not present in IGP's TE Database.

The ISP Can then achive this differentiated traffic treatment for different traffic classes
by using Class Based Tunnel Selection feature for MPLS Traffic ENgineering Tunnels wherein
we make the TE Tunnels EXP aware and then different traffic class of traffic can be
dynamically routed across these TE Tunnels.

To achieve the Dynamic Routing of Different Traffic Class across Different EXP aware TE Tunnels
Service Provider need to provision PE-PE and ASBR-ASBR EXP Aware TE TUnnels on a Per PE/ASBR Basis
and then create a Master PE-PE/ASBR-ASBR TE Tunnel which will be EXP-Bundle Master
and attach the Individual EXP aware TE Tunnels as Member to the Master Tunnel.

The Master Tunnel does not needs any priority and BW Specifications but need to be announced to
IGP via autoroute.

What happens here is that by building Master PE-PE/ASBR-ASBR TE Tunnel and annoucning that into IGP
we are making the MP-iBGP/MP-eBGP Next Hop for the VPNs reachbale across the Master TE Tunnel.
Once traffic is forced to Master TE Tunnel , a second level EXP Based routing happens inside one
of the EXP Aware TE Tunnel Matching the EXP of the Packet. If the EXP matches no EXP aware TE
Tunnel the packet is sent across an EXP aware TE Tunnel configured with default EXP. If none
of the tunnels are confifured with EXP Default the packet is sent acorss the EXP aware TE Tunnel
configured for Lowest EXP Value.

The MPLS TE Router ID needs to be same as of MPLS Router ID and should be the one used for the
MP-iBGP Loopback Peering IPs



ISP A AS used 64513-
VRF USed CEA
rd 64513:1
rt 64513:100

ISP B AS used 64514-
VRF USed CEA
rd 64514:1
rt 64514:100

IGP is ISPA and ISPB Domain used OSPF with Core Links between PEs in Area 0 and Loopbacks are as Follows
PE11 & PE21 Area 2
PE12 & PE22 Area 2

IGP in Custmer AS Used OSPF
PE-CE ROuting Protocol is OSPF


Traffic Classes Used
(ICMP is CoS 0)
Silver (DSCP/COS af31,cs4 and default/4 3 0 )
Gold (DSCP/COS ef/5 )

TE Tunnels Used within AS
100- Gold
101- Gold_Backup
200-Silver
201-Silver_Backup

1001- Master Tunnel

TE Tunnels Used Between AS

Tu111-Inter-AS_Gold
Tu211-Inter-AS_Silver
Tu111-Inter-AS_Gold_Backup
Tu211-Inter-AS_Silver_Backup

*****************************************************



CE1A#sh running-config
Building configuration...

Current configuration : 1694 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all Signalling_2
match ip dscp cs4
!
!
policy-map PE_Out
class Voice
priority percent 30
class Signalling
priority percent 30
class Signalling_2
priority percent 10
class class-default
policy-map PE_In
class Voice
set ip dscp ef
class Signalling
set ip dscp af31
class Signalling_2
set ip dscp cs4
class class-default
!
!
!
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
service-policy input PE_In
service-policy output PE_Out
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE1A#


CE2A#sh running-config
Building configuration...

Current configuration : 1668 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all Signalling_2
match ip dscp cs4
!
!
policy-map PE_Out
class Voice
priority percent 30
class Signalling
priority percent 30
class Signalling_2
priority percent 10
class class-default
policy-map PE_In
class Voice
set ip dscp ef
class Signalling
set ip dscp af31
class Signalling_2
set ip dscp cs4
class class-default
!
!
!
!
!
interface Loopback0
ip address 172.16.200.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.2.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
service-policy input PE_In
service-policy output PE_Out
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE2A#

PE11#sh running-config
Building configuration...

Current configuration : 6492 bytes
!
! Last configuration change at 21:35:32 UTC Mon Mar 29 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
!
!
!
no ip domain lookup
ip multicast-routing vrf CEA
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_3
match mpls experimental topmost 3
class-map match-all EXP_4
match mpls experimental topmost 4
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all In_EXP_3
match qos-group 3
class-map match-all In_EXP_4
match qos-group 4
class-map match-all Signalling_2
match ip dscp cs4
class-map match-all In_EXP_5
match qos-group 5
!
policy-map CE_In
class Voice
set mpls experimental imposition 5
class Signalling
set mpls experimental imposition 3
class Signalling_2
set mpls experimental imposition 4
class class-default
policy-map Core_In
class EXP_5
set qos-group 5
class EXP_4
set qos-group 4
class EXP_3
set qos-group 3
class class-default
policy-map Core_Out
class EXP_5
priority percent 30
class EXP_4
priority percent 30
class EXP_3
priority percent 30
class class-default
policy-map CE_Out
class In_EXP_5
set ip dscp ef
class In_EXP_4
set ip dscp cs4
class In_EXP_3
set ip dscp af31
class class-default
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel101
description Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold_Backup
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel201
description Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver_Backup
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1001
description Master Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel101
tunnel mpls traffic-eng exp-bundle member Tunnel200
tunnel mpls traffic-eng exp-bundle member Tunnel201
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
serial restart-delay 0
service-policy input CE_In
service-policy output CE_Out
!
interface Serial1/1
ip address 10.0.10.1 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel101
serial restart-delay 0
frame-relay interface-dlci 102
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/2
ip address 10.0.20.1 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel201
serial restart-delay 0
frame-relay interface-dlci 103
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
service-policy input Core_In
service-policy output Core_Out
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.1.0 0.0.0.3 area 0
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.1.1 0.0.0.0 area 1
network 10.0.10.0 0.0.0.3 area 0
network 10.0.20.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 1
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name Gold enable
next-address 10.0.10.2
!
ip explicit-path name Silver_Backup enable
next-address 10.0.10.2
!
ip explicit-path name Gold_Backup enable
next-address 10.0.20.2
!
ip explicit-path name Silver enable
next-address 10.0.20.2
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE11#
PE11#
PE11#


PE21#sh running-config
Building configuration...

Current configuration : 6440 bytes
!
! Last configuration change at 20:43:23 UTC Mon Mar 29 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_3
match mpls experimental topmost 3
class-map match-all EXP_4
match mpls experimental topmost 4
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all In_EXP_3
match qos-group 3
class-map match-all In_EXP_4
match qos-group 4
class-map match-all Signalling_2
match ip dscp cs4
class-map match-all In_EXP_5
match qos-group 5
!
policy-map CE_In
class Voice
set mpls experimental imposition 5
class Signalling
set mpls experimental imposition 3
class Signalling_2
set mpls experimental imposition 4
class class-default
policy-map Core_In
class EXP_5
set qos-group 5
class EXP_4
set qos-group 4
class EXP_3
set qos-group 3
class class-default
policy-map Core_Out
class EXP_5
priority percent 30
class EXP_4
priority percent 30
class EXP_3
priority percent 30
class class-default
policy-map CE_Out
class In_EXP_5
set ip dscp ef
class In_EXP_4
set ip dscp cs4
class In_EXP_3
set ip dscp af31
class class-default
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel101
description Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold_Backup
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel201
description Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver_Backup
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1001
description Master Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel101
tunnel mpls traffic-eng exp-bundle member Tunnel200
tunnel mpls traffic-eng exp-bundle member Tunnel201
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip vrf forwarding CEA
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
service-policy input CE_In
service-policy output CE_Out
!
interface Serial1/1
ip address 192.168.10.1 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel101
serial restart-delay 0
frame-relay interface-dlci 102
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial1/2
ip address 192.168.20.1 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel201
serial restart-delay 0
frame-relay interface-dlci 103
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
service-policy input Core_In
service-policy output Core_Out
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64515 subnets
network 172.16.2.0 0.0.0.3 area 0
!
router ospf 1
router-id 192.168.1.1
log-adjacency-changes
network 192.168.1.1 0.0.0.0 area 1
network 192.168.10.0 0.0.0.3 area 0
network 192.168.20.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 1
!
router bgp 64515
bgp router-id 192.168.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.2.1 remote-as 64515
neighbor 192.168.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 send-community extended
neighbor 192.168.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name Gold enable
next-address 192.168.10.2
!
ip explicit-path name Silver_Backup enable
next-address 192.168.10.2
!
ip explicit-path name Gold_Backup enable
next-address 192.168.20.2
!
ip explicit-path name Silver enable
next-address 192.168.20.2
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE21#


PE12#sh running-config
Building configuration...

Current configuration : 9587 bytes
!
! Last configuration change at 21:26:09 UTC Mon Mar 29 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_3
match mpls experimental topmost 3
class-map match-all EXP_4
match mpls experimental topmost 4
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all In_EXP_3
match qos-group 3
class-map match-all In_EXP_4
match qos-group 4
class-map match-all Signalling_2
match ip dscp cs4
class-map match-all In_EXP_5
match qos-group 5
!
policy-map Core_In
class EXP_5
set qos-group 5
class EXP_4
set qos-group 4
class EXP_3
set qos-group 3
class class-default
policy-map Core_Out
class EXP_5
priority percent 30
class EXP_4
priority percent 30
class EXP_3
priority percent 30
class class-default
policy-map ISP_Out
class In_EXP_5
priority percent 30
class In_EXP_4
priority percent 30
class In_EXP_3
priority percent 30
class class-default
policy-map ISP_In
class EXP_5
class EXP_4
class EXP_3
class class-default
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!

!
interface Loopback1
ip vrf forwarding CEA
ip address 172.16.254.254 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel101
description Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold_Backup
tunnel mpls traffic-eng exp 5
!
interface Tunnel111
description Inter-AS_Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Gold verbatim
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel112
description Inter-AS_Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Gold_Backup verbat
im
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel201
description Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver_Backup
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel211
description Inter-AS_Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Silver verbatim
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel212
description Inter-AS_Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Silver_Backup verb
atim
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1001
description Master_Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel101
tunnel mpls traffic-eng exp-bundle member Tunnel200
tunnel mpls traffic-eng exp-bundle member Tunnel201
!
interface Tunnel1002
description Inter-AS_Master_Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel212
tunnel mpls traffic-eng exp-bundle member Tunnel111
tunnel mpls traffic-eng exp-bundle member Tunnel112
tunnel mpls traffic-eng exp-bundle member Tunnel211
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 10.0.10.2 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel101
serial restart-delay 0
frame-relay interface-dlci 201
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/1
ip address 10.0.20.2 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel201
serial restart-delay 0
frame-relay interface-dlci 301
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/2
ip address 10.0.30.1 255.255.255.252
encapsulation frame-relay
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel112
mpls bgp forwarding
serial restart-delay 0
frame-relay interface-dlci 102
frame-relay lmi-type ansi
service-policy input ISP_In
service-policy output ISP_Out
ip rsvp bandwidth
!
interface Serial1/3
ip address 10.0.40.1 255.255.255.252
encapsulation frame-relay
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel212
mpls bgp forwarding
serial restart-delay 0
frame-relay interface-dlci 103
frame-relay lmi-type ansi
service-policy input ISP_In
service-policy output ISP_Out
ip rsvp bandwidth
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.2.1 0.0.0.0 area 2
network 10.0.10.0 0.0.0.3 area 0
network 10.0.20.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 2
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 192.168.2.1 remote-as 64515
neighbor 192.168.2.1 ebgp-multihop 2
!
address-family ipv4
no synchronization
redistribute static
redistribute ospf 1 match internal external 1 external 2
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 next-hop-self
neighbor 192.168.2.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 send-community extended
neighbor 192.168.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip route 192.168.2.1 255.255.255.255 Serial1/2 10.0.30.2
ip route 192.168.2.1 255.255.255.255 Serial1/3 10.0.40.2
!
ip explicit-path name Gold enable
next-address 10.0.10.1
!
ip explicit-path name Gold_Backup enable
next-address 10.0.20.1
!
ip explicit-path name Silver_Backup enable
next-address 10.0.10.1
!
ip explicit-path name Silver enable
next-address 10.0.20.1
!
ip explicit-path name Inter-AS_Gold enable
next-address loose 10.0.30.2
!
ip explicit-path name Inter-AS_Silver enable
next-address loose 10.0.40.2
!
ip explicit-path name Inter-AS_Gold_Backup enable
next-address loose 10.0.40.2
!
ip explicit-path name Inter-AS_Silver_Backup enable
next-address loose 10.0.30.2
!
!
route-map Local permit 10
match interface Serial1/2 Serial1/3
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end


PE22#sh running-config
Building configuration...

Current configuration : 9604 bytes
!
! Last configuration change at 20:57:43 UTC Mon Mar 29 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_3
match mpls experimental topmost 3
class-map match-all EXP_4
match mpls experimental topmost 4
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all Signalling
match ip dscp af31
class-map match-all Voice
match ip dscp ef
class-map match-all In_EXP_3
match qos-group 3
class-map match-all In_EXP_4
match qos-group 4
class-map match-all Signalling_2
match ip dscp cs4
class-map match-all In_EXP_5
match qos-group 5
!
policy-map Core_In
class EXP_5
set qos-group 5
class EXP_4
set qos-group 4
class EXP_3
set qos-group 3
class class-default
policy-map Core_Out
class EXP_5
priority percent 30
class EXP_4
priority percent 30
class EXP_3
priority percent 30
class class-default
policy-map ISP_Out
class In_EXP_5
priority percent 30
class In_EXP_4
priority percent 30
class In_EXP_3
priority percent 30
class class-default
policy-map ISP_In
class EXP_5
class EXP_4
class EXP_3
class class-default
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.255
!
!
interface Loopback1
ip vrf forwarding CEA
ip address 172.16.255.255 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel101
description Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Gold_Backup
tunnel mpls traffic-eng exp 5
!
interface Tunnel111
description Inter-AS_Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Gold verbatim
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 5
!
interface Tunnel112
description Inter-AS_Gold_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Gold_Backup verbat
im
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel201
description Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Silver_Backup
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel211
description Inter-AS_Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Silver verbatim
tunnel mpls traffic-eng fast-reroute
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel212
description Inter-AS_Silver_Backup
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 256
tunnel mpls traffic-eng path-option 1 explicit name Inter-AS_Silver_Backup verb
atim
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1001
description Master_Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 192.168.1.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel101
tunnel mpls traffic-eng exp-bundle member Tunnel200
tunnel mpls traffic-eng exp-bundle member Tunnel201
!
interface Tunnel1002
description Inter-AS_Master_Tunnel
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute destination
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel111
tunnel mpls traffic-eng exp-bundle member Tunnel112
tunnel mpls traffic-eng exp-bundle member Tunnel211
tunnel mpls traffic-eng exp-bundle member Tunnel212
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 10.0.30.2 255.255.255.252
encapsulation frame-relay
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel112
mpls bgp forwarding
serial restart-delay 0
frame-relay interface-dlci 201
frame-relay lmi-type ansi
service-policy input ISP_In
service-policy output ISP_Out
ip rsvp bandwidth
!
interface Serial1/1
ip address 10.0.40.2 255.255.255.252
encapsulation frame-relay
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel212
mpls bgp forwarding
serial restart-delay 0
frame-relay interface-dlci 301
frame-relay lmi-type ansi
service-policy input ISP_In
service-policy output ISP_Out
ip rsvp bandwidth
!
interface Serial1/2
ip address 192.168.10.2 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel101
serial restart-delay 0
frame-relay interface-dlci 201
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/3
ip address 192.168.20.2 255.255.255.252
encapsulation frame-relay
ip ospf network point-to-point
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
mpls traffic-eng backup-path Tunnel201
serial restart-delay 0
frame-relay interface-dlci 301
frame-relay lmi-type ansi
service-policy input Core_In
service-policy output Core_Out
ip rsvp bandwidth
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 192.168.2.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 192.168.2.1 0.0.0.0 area 2
network 192.168.10.0 0.0.0.3 area 0
network 192.168.20.0 0.0.0.3 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng area 2
!
router bgp 64515
bgp router-id 192.168.2.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 ebgp-multihop 2
neighbor 192.168.1.1 remote-as 64515
neighbor 192.168.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
redistribute static
redistribute ospf 1 match internal external 1 external 2
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community both
neighbor 10.0.2.1 next-hop-self
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 send-community extended
neighbor 192.168.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip route 10.0.2.1 255.255.255.255 Serial1/0 10.0.30.1
ip route 10.0.2.1 255.255.255.255 Serial1/1 10.0.40.1
!
ip explicit-path name Gold enable
next-address 192.168.10.1
!
ip explicit-path name Gold_Backup enable
next-address 192.168.20.1
!
ip explicit-path name Silver_Backup enable
next-address 192.168.10.1
!
ip explicit-path name Silver enable
next-address 192.168.20.1
!
ip explicit-path name Inter-AS_Gold enable
next-address loose 10.0.30.1
!
ip explicit-path name Inter-AS_Silver enable
next-address loose 10.0.40.1
!
ip explicit-path name Inter-AS_Gold_Backup enable
next-address loose 10.0.40.1
!
ip explicit-path name Inter-AS_Silver_Backup enable
next-address loose 10.0.30.1
!
!
route-map Local permit 10
match interface Serial1/0 Serial1/1
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE22#

******************************
OUTPUT
******************************
CE1A#traceroute 172.16.200.1

Type escape sequence to abort.
Tracing the route to 172.16.200.1

1 172.16.1.1 108 msec 96 msec 144 msec
2 10.0.20.2 1220 msec 1192 msec 1032 msec
3 10.0.40.2 1240 msec 1152 msec 728 msec
4 172.16.2.1 952 msec 776 msec 944 msec
5 172.16.2.2 648 msec 896 msec 552 msec

CE2A#traceroute 172.16.100.1

Type escape sequence to abort.
Tracing the route to 172.16.100.1

1 172.16.2.1 320 msec 244 msec 80 msec
2 192.168.20.2 692 msec 976 msec 1016 msec
3 10.0.30.1 1200 msec 1532 msec *
4 172.16.1.1 1188 msec 1872 msec 1704 msec
5 172.16.1.2 1616 msec 1252 msec 1332 msec

PE11#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 3170 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 170 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 10.0.2.1 - Se1/1 up/up
Gold_Backup 10.0.2.1 - Se1/2 up/up
Silver 10.0.2.1 - Se1/2 up/up
Silver_Backup 10.0.2.1 - Se1/1 up/up
Master Tunnel 10.0.2.1 - unknown up/up
Gold 10.0.1.1 Se1/1 - up/up

Gold_Backup 10.0.1.1 Se1/2 - up/up

Silver 10.0.1.1 Se1/2 - up/up

Silver_Backup 10.0.1.1 Se1/1 - up/up

Displayed 5 (of 5) heads, 0 (of 0) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
PE11#

PE21#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 3384 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 84 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 192.168.2.1 - Se1/1 up/up
Gold_Backup 192.168.2.1 - Se1/2 up/up
Silver 192.168.2.1 - Se1/2 up/up
Silver_Backup 192.168.2.1 - Se1/1 up/up
Master Tunnel 192.168.2.1 - unknown up/up
Gold 192.168.1.1 Se1/1 - up/up

Gold_Backup 192.168.1.1 Se1/2 - up/up

Silver 192.168.1.1 Se1/2 - up/up

Silver_Backup 192.168.1.1 Se1/1 - up/up

Displayed 5 (of 5) heads, 0 (of 0) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
PE21#

PE12#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 469 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 169 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 10.0.1.1 - Se1/0 up/up
Gold_Backup 10.0.1.1 - Se1/1 up/up
Inter-AS_Gold 192.168.2.1 - Se1/2 up/up
Inter-AS_Gold_Backup 192.168.2.1 - Se1/3 up/up
Silver 10.0.1.1 - Se1/1 up/up
Silver_Backup 10.0.1.1 - Se1/0 up/up
Inter-AS_Silver 192.168.2.1 - Se1/3 up/up
Inter-AS_Silver_Backup 192.168.2.1 - Se1/2 up/up
Master_Tunnel 10.0.1.1 - unknown up/up
Inter-AS_Master_Tunnel 192.168.2.1 - unknown up/up
Gold 10.0.2.1 Se1/0 - up/up

Gold_Backup 10.0.2.1 Se1/1 - up/up

Silver 10.0.2.1 Se1/1 - up/up

Silver_Backup 10.0.2.1 Se1/0 - up/up

Inter-AS_Gold 10.0.2.1 Se1/2 - up/up

Inter-AS_Gold_Backup 10.0.2.1 Se1/3 - up/up

Inter-AS_Silver 10.0.2.1 Se1/3 - up/up

Inter-AS_Silver_Backup 10.0.2.1 Se1/2 - up/up

Displayed 10 (of 10) heads, 0 (of 0) midpoints, 8 (of 8) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
PE12#

PE22#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 927 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 27 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 192.168.1.1 - Se1/2 up/up
Gold_Backup 192.168.1.1 - Se1/3 up/up
Inter-AS_Gold 10.0.2.1 - Se1/0 up/up
Inter-AS_Gold_Backup 10.0.2.1 - Se1/1 up/up
Silver 192.168.1.1 - Se1/3 up/up
Silver_Backup 192.168.1.1 - Se1/2 up/up
Inter-AS_Silver 10.0.2.1 - Se1/1 up/up
Inter-AS_Silver_Backup 10.0.2.1 - Se1/0 up/up
Master_Tunnel 192.168.1.1 - unknown up/up
Inter-AS_Master_Tunnel 10.0.2.1 - unknown up/up
Inter-AS_Gold 192.168.2.1 Se1/0 - up/up

Inter-AS_Gold_Backup 192.168.2.1 Se1/1 - up/up

Inter-AS_Silver 192.168.2.1 Se1/1 - up/up

Inter-AS_Silver_Backup 192.168.2.1 Se1/0 - up/up

Gold 192.168.2.1 Se1/2 - up/up

Gold_Backup 192.168.2.1 Se1/3 - up/down

Gold_Backup 192.168.2.1 Se1/3 - up/up

Silver 192.168.2.1 Se1/3 - up/up

Silver_Backup 192.168.2.1 Se1/2 - up/up

Displayed 10 (of 10) heads, 0 (of 0) midpoints, 9 (of 9) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
PE22#

PE12#show mpls traffic-eng tunnels | begin Master
Name: Master_Tunnel (Tunnel1001) Destination: 10.0.1.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel101: Config Exp: 5
Tunnel200: Config Exp: 0 3 4
Tunnel201: Config Exp: 0 3 4


History:
Tunnel:
Time since created: 52 minutes, 23 seconds
Number of LSP IDs (Tun_Instances) used: 0

Name: Inter-AS_Master_Tunnel (Tunnel1002) Destination: 192.168.2.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel212: Config Exp: 0 3 4
Tunnel111: Config Exp: 5
Tunnel112: Config Exp: 5
Tunnel211: Config Exp: 0 3 4


PE22#show mpls traffic-eng tunnels | begin Master
Name: Master_Tunnel (Tunnel1001) Destination: 192.168.1.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel101: Config Exp: 5
Tunnel200: Config Exp: 0 3 4
Tunnel201: Config Exp: 0 3 4


History:
Tunnel:
Time since created: 45 minutes, 4 seconds
Number of LSP IDs (Tun_Instances) used: 0

Name: Inter-AS_Master_Tunnel (Tunnel1002) Destination: 10.0.2.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel111: Config Exp: 5
Tunnel112: Config Exp: 5
Tunnel211: Config Exp: 0 3 4
Tunnel212: Config Exp: 0 3 4


PE11#show mpls traffic-eng tunnels | begin Master
Name: Master Tunnel (Tunnel1001) Destination: 10.0.2.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel101: Config Exp: 5
Tunnel200: Config Exp: 0 3 4
Tunnel201: Config Exp: 0 3 4


PE21#show mpls traffic-eng tunnels | begin Master
Name: Master Tunnel (Tunnel1001) Destination: 192.168.2.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel101: Config Exp: 5
Tunnel200: Config Exp: 0 3 4
Tunnel201: Config Exp: 0 3 4


PE11#show mpls traffic-eng fast-reroute database
P2P Headend FRR information:
Protected tunnel In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------
Tunnel100 Tun hd Se1/1:implicit-n Tu101:implicit-n Ready
Tunnel200 Tun hd Se1/2:implicit-n Tu201:implicit-n Ready

P2P LSP midpoint frr information:
LSP identifier In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

P2MP Sub-LSP FRR information:
*Sub-LSP identifier
src_lspid[subid]->dst_tunid In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
PE11#

PE21#show mpls traffic-eng fast-reroute database
P2P Headend FRR information:
Protected tunnel In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------
Tunnel100 Tun hd Se1/1:implicit-n Tu101:implicit-n Ready
Tunnel200 Tun hd Se1/2:implicit-n Tu201:implicit-n Ready

P2P LSP midpoint frr information:
LSP identifier In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

P2MP Sub-LSP FRR information:
*Sub-LSP identifier
src_lspid[subid]->dst_tunid In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
PE21#

PE12#show mpls traffic-eng fast-reroute database
P2P Headend FRR information:
Protected tunnel In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------
Tunnel100 Tun hd Se1/0:implicit-n Tu101:implicit-n Ready
Tunnel111 Tun hd Se1/2:implicit-n Tu112:implicit-n Ready
Tunnel200 Tun hd Se1/1:implicit-n Tu201:implicit-n Ready
Tunnel211 Tun hd Se1/3:implicit-n Tu212:implicit-n Ready

P2P LSP midpoint frr information:
LSP identifier In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

P2MP Sub-LSP FRR information:
*Sub-LSP identifier
src_lspid[subid]->dst_tunid In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
PE12#

PE22#show mpls traffic-eng fast-reroute database
P2P Headend FRR information:
Protected tunnel In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------
Tunnel100 Tun hd Se1/2:implicit-n Tu101:implicit-n Ready
Tunnel111 Tun hd Se1/0:implicit-n Tu112:implicit-n Ready
Tunnel200 Tun hd Se1/3:implicit-n Tu201:implicit-n Ready
Tunnel211 Tun hd Se1/1:implicit-n Tu212:implicit-n Ready

P2P LSP midpoint frr information:
LSP identifier In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

P2MP Sub-LSP FRR information:
*Sub-LSP identifier
src_lspid[subid]->dst_tunid In-label Out intf/label FRR intf/label Status
--------------------------- -------- -------------- -------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
PE22#

CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
O IA 172.16.200.1/32 [110/65] via 172.16.1.1, 00:05:01, Serial1/0
O E2 172.16.255.255/32 [110/1] via 172.16.1.1, 00:04:56, Serial1/0
O E2 172.16.254.254/32 [110/1] via 172.16.1.1, 00:04:56, Serial1/0
C 172.16.1.0/30 is directly connected, Serial1/0
O IA 172.16.2.0/30 [110/65] via 172.16.1.1, 00:05:01, Serial1/0
C 172.16.100.0/24 is directly connected, Loopback0
CE1A#
CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
C 172.16.200.0/24 is directly connected, Loopback0
O E2 172.16.255.255/32 [110/1] via 172.16.2.1, 00:04:59, Serial1/0
O E2 172.16.254.254/32 [110/1] via 172.16.2.1, 00:04:59, Serial1/0
O IA 172.16.1.0/30 [110/65] via 172.16.2.1, 00:05:27, Serial1/0
C 172.16.2.0/30 is directly connected, Serial1/0
O IA 172.16.100.1/32 [110/65] via 172.16.2.1, 00:05:04, Serial1/0
CE2A#

PE11#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.0.1.1/32 is directly connected, Loopback0
S 10.0.2.1/32 is directly connected, Tunnel1001
C 10.0.10.0/30 is directly connected, Serial1/1
L 10.0.10.1/32 is directly connected, Serial1/1
C 10.0.20.0/30 is directly connected, Serial1/2
L 10.0.20.1/32 is directly connected, Serial1/2
O E2 10.0.30.0/30 [110/20] via 10.0.20.2, 00:05:47, Serial1/2
[110/20] via 10.0.10.2, 00:05:47, Serial1/1
O E2 10.0.40.0/30 [110/20] via 10.0.20.2, 00:05:47, Serial1/2
[110/20] via 10.0.10.2, 00:05:47, Serial1/1
PE11#

PE21#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 2 subnets
O E2 10.0.30.0 [110/20] via 192.168.20.2, 00:06:11, Serial1/2
[110/20] via 192.168.10.2, 00:06:12, Serial1/1
O E2 10.0.40.0 [110/20] via 192.168.20.2, 00:06:12, Serial1/2
[110/20] via 192.168.10.2, 00:06:12, Serial1/1
192.168.1.0/32 is subnetted, 1 subnets
C 192.168.1.1 is directly connected, Loopback0
192.168.2.0/32 is subnetted, 1 subnets
S 192.168.2.1 is directly connected, Tunnel1001
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/30 is directly connected, Serial1/1
L 192.168.10.1/32 is directly connected, Serial1/1
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/30 is directly connected, Serial1/2
L 192.168.20.1/32 is directly connected, Serial1/2
PE21#

PE12#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
S 10.0.1.1/32 is directly connected, Tunnel1001
C 10.0.2.1/32 is directly connected, Loopback0
C 10.0.10.0/30 is directly connected, Serial1/0
L 10.0.10.2/32 is directly connected, Serial1/0
C 10.0.20.0/30 is directly connected, Serial1/1
L 10.0.20.2/32 is directly connected, Serial1/1
C 10.0.30.0/30 is directly connected, Serial1/2
L 10.0.30.1/32 is directly connected, Serial1/2
C 10.0.40.0/30 is directly connected, Serial1/3
L 10.0.40.1/32 is directly connected, Serial1/3
192.168.1.0/32 is subnetted, 1 subnets
B 192.168.1.1 [20/0] via 192.168.2.1, 00:41:23
192.168.2.0/32 is subnetted, 1 subnets
S 192.168.2.1 [1/0] via 10.0.40.2, Serial1/3
[1/0] via 10.0.30.2, Serial1/2
is directly connected, Tunnel1002
192.168.10.0/30 is subnetted, 1 subnets
B 192.168.10.0 [20/0] via 192.168.2.1, 00:41:23
192.168.20.0/30 is subnetted, 1 subnets
B 192.168.20.0 [20/0] via 192.168.2.1, 00:41:23
PE12#

PE22#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
B 10.0.1.1/32 [20/0] via 10.0.2.1, 00:41:46
S 10.0.2.1/32 [1/0] via 10.0.40.1, Serial1/1
[1/0] via 10.0.30.1, Serial1/0
is directly connected, Tunnel1002
B 10.0.10.0/30 [20/0] via 10.0.2.1, 00:41:46
B 10.0.20.0/30 [20/0] via 10.0.2.1, 00:41:46
C 10.0.30.0/30 is directly connected, Serial1/0
L 10.0.30.2/32 is directly connected, Serial1/0
C 10.0.40.0/30 is directly connected, Serial1/1
L 10.0.40.2/32 is directly connected, Serial1/1
192.168.1.0/32 is subnetted, 1 subnets
S 192.168.1.1 is directly connected, Tunnel1001
192.168.2.0/32 is subnetted, 1 subnets
C 192.168.2.1 is directly connected, Loopback0
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/30 is directly connected, Serial1/2
L 192.168.10.2/32 is directly connected, Serial1/2
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/30 is directly connected, Serial1/3
L 192.168.20.2/32 is directly connected, Serial1/3
PE22#

QoS

***************
CE1A#ping
Protocol [ip]:
Target IP address: 172.16.200.1
Repeat count [5]: 25
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 0x68
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 25, 100-byte ICMP Echos to 172.16.200.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!.!!!
Success rate is 96 percent (24/25), round-trip min/avg/max = 408/933/1452 ms
CE1A#

Forward Path

CE1A-PE11-Tu200-PE12-Tu200-PE22-Tu200-PE21-CE2A


Reverse Path

CE2A-PE21-Tu200-PE22-Tu200-PE12-Tu200-PE11-CE1A



CE1A#show policy-map interface s1/0 output
Serial1/0

Service-policy output: PE_Out

Class-map: Voice (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 30 (%)
Bandwidth 463 (kbps) Burst 11575 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0

Class-map: Signalling (match-all)
25 packets, 2600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 30 (%)
Bandwidth 463 (kbps) Burst 11575 (Bytes)
(pkts matched/bytes matched) 25/2600
(total drops/bytes drops) 0/0

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs4 (32)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 10 (%)
Bandwidth 154 (kbps) Burst 3850 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0

Class-map: class-default (match-any)
242 packets, 17586 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE1A#

PE11#show policy-map interface s1/0 input
Serial1/0

Service-policy input: CE_In

Class-map: Voice (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp ef (46)
QoS Set
mpls experimental imposition 5
Packets marked 0

Class-map: Signalling (match-all)
25 packets, 2600 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp af31 (26)
QoS Set
mpls experimental imposition 3
Packets marked 25

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp cs4 (32)
QoS Set
mpls experimental imposition 4
Packets marked 0

Class-map: class-default (match-any)
106 packets, 9004 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
106 packets, 9004 bytes
5 minute rate 0 bps
PE11#

PE11#show policy-map interface s1/2 output

Serial1/2

Service-policy output: Core_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 25/2700

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
523 packets, 42416 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
523 packets, 42416 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 527/42844
PE11#

PE12#show policy-map interface s1/1 input

Serial1/1

Service-policy input: Core_In

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 0

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0

Class-map: EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 25

Class-map: class-default (match-any)
218 packets, 22090 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
218 packets, 22090 bytes
5 minute rate 0 bps
PE12#

PE12#show policy-map interface s1/3 output

Serial1/3

Service-policy output: ISP_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 25/2700

Class-map: In_EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: In_EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
20 packets, 2230 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
20 packets, 2230 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 20/2230
PE12#

PE22#show policy-map interface s1/1 input

Serial1/1

Service-policy input: ISP_In

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 5

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 4

Class-map: EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 3

Class-map: class-default (match-any)
15 packets, 2888 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
15 packets, 2888 bytes
5 minute rate 0 bps
PE22#

PE22#show policy-map interface s1/3 output

Serial1/3

Service-policy output: Core_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 25/2700

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
317 packets, 27770 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
317 packets, 27770 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 319/27850
PE22#

PE21#show policy-map interface s1/2 input

Serial1/2

Service-policy input: Core_In

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 0

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0

Class-map: EXP_3 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 25

Class-map: class-default (match-any)
360 packets, 39794 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
360 packets, 39794 bytes
5 minute rate 0 bps
PE21#

PE21#show policy-map interface s1/0 output
Serial1/0

Service-policy output: CE_Out

Class-map: In_EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 5
QoS Set
dscp ef
Packets marked 0

Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 4
QoS Set
dscp cs4
Packets marked 0

Class-map: In_EXP_3 (match-all)
25 packets, 2600 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 3
QoS Set
dscp af31
Packets marked 25

Class-map: class-default (match-any)
300 packets, 22904 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
300 packets, 22904 bytes
5 minute rate 0 bps
PE21#

CE2A#show policy-map interface s1/0 input
Serial1/0

Service-policy input: PE_In

Class-map: Voice (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp ef
Packets marked 0

Class-map: Signalling (match-all)
25 packets, 2600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 25

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs4 (32)
QoS Set
dscp cs4
Packets marked 0

Class-map: class-default (match-any)
128 packets, 10872 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE2A#










CE2A#ping
Protocol [ip]:
Target IP address: 172.16.100.1
Repeat count [5]: 25
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface:
Type of service [0]: 0xB8
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 25, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!.!!!!
Success rate is 96 percent (24/25), round-trip min/avg/max = 992/1419/1908 ms
CE2A#

CE2A#show policy-map interface s1/0 output
Serial1/0

Service-policy output: PE_Out

Class-map: Voice (match-all)
25 packets, 2600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 30 (%)
Bandwidth 463 (kbps) Burst 11575 (Bytes)
(pkts matched/bytes matched) 25/2600
(total drops/bytes drops) 0/0

Class-map: Signalling (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 30 (%)
Bandwidth 463 (kbps) Burst 11575 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs4 (32)
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 10 (%)
Bandwidth 154 (kbps) Burst 3850 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0

Class-map: class-default (match-any)
23 packets, 1493 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE2A#

PE21#show policy-map interface s1/0 input
Serial1/0

Service-policy input: CE_In

Class-map: Voice (match-all)
25 packets, 2600 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp ef (46)
QoS Set
mpls experimental imposition 5
Packets marked 25

Class-map: Signalling (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp af31 (26)
QoS Set
mpls experimental imposition 3
Packets marked 0

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: ip dscp cs4 (32)
QoS Set
mpls experimental imposition 4
Packets marked 0

Class-map: class-default (match-any)
12 packets, 1008 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
12 packets, 1008 bytes
5 minute rate 0 bps
PE21#

PE21#show policy-map interface s1/2 output

Serial1/2

Service-policy output: Core_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0

Class-map: EXP_5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
91 packets, 7950 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
91 packets, 7950 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 91/7950
PE21#

PE22#show policy-map interface s1/2 input

Serial1/2

Service-policy input: Core_In

Class-map: EXP_5 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 25

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0

Class-map: EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 0

Class-map: class-default (match-any)
266 packets, 25347 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
266 packets, 25347 bytes
5 minute rate 0 bps
PE22#show policy-map interface s1/0 ou
PE22#show policy-map interface s1/0 output

Serial1/0

Service-policy output: ISP_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 25/2700

Class-map: In_EXP_5 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: In_EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
134 packets, 14491 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
134 packets, 14491 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 138/14952
PE22#

PE12#show policy-map interface s1/2 input

Serial1/2

Service-policy input: ISP_In

Class-map: EXP_5 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 5

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 4

Class-map: EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 3

Class-map: class-default (match-any)
27 packets, 4417 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
27 packets, 4417 bytes
5 minute rate 0 bps
PE12#

PE12#show policy-map interface serial 1/0 output

Serial1/0

Service-policy output: Core_Out

queue stats for all priority classes:
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 25/2700

Class-map: EXP_5 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
Priority: 30% (463 kbps), burst bytes 11550, b/w exceed drops: 0


Class-map: class-default (match-any)
357 packets, 29121 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
357 packets, 29121 bytes
5 minute rate 0 bps

queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 363/29809
PE12#

PE11#show policy-map interface s1/1 input

Serial1/1

Service-policy input: Core_In

Class-map: EXP_5 (match-all)
25 packets, 2700 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 25

Class-map: EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 4
QoS Set
qos-group 4
Packets marked 0

Class-map: EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 0

Class-map: class-default (match-any)
125 packets, 11737 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
125 packets, 11737 bytes
5 minute rate 0 bps
PE11#

PE11#show policy-map interface s1/0 output
Serial1/0

Service-policy output: CE_Out

Class-map: In_EXP_5 (match-all)
25 packets, 2600 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 5
QoS Set
dscp ef
Packets marked 25

Class-map: In_EXP_4 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 4
QoS Set
dscp cs4
Packets marked 0

Class-map: In_EXP_3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: qos-group 3
QoS Set
dscp af31
Packets marked 0

Class-map: class-default (match-any)
70 packets, 4892 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
70 packets, 4892 bytes
5 minute rate 0 bps
PE11#
PE11#


CE1A#show policy-map interface s1/0 input
Serial1/0

Service-policy input: PE_In

Class-map: Voice (match-all)
25 packets, 2600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef (46)
QoS Set
dscp ef
Packets marked 25

Class-map: Signalling (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp af31 (26)
QoS Set
dscp af31
Packets marked 0

Class-map: Signalling_2 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp cs4 (32)
QoS Set
dscp cs4
Packets marked 0

Class-map: class-default (match-any)
136 packets, 10100 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
CE1A#

No comments:

Post a Comment