Thursday, May 13, 2010

Implementing Hub & Spoke MPLS L2 VPN with Internet Access via MPLS L3 VPN VRF aware NAT LAB
















Configuration Guidelines
******************************************************
Scenario- An ISP is offering L2 MPLS VPN Services to
his Customers and Customer wants to have a Hub & Spoke
Connectivity across the MPLS VPN Services offered such
that Hub Site can talk to every Spoke and few spokes
can directly talk to each other while other spokes
can talk to the spokes via the Hub

Also ISP needs to provide Internet Access to his MPLS
L2 VPN Services

Also Customer will be running Multicast over his CE Network

ISP is using Dynamic Auto-Tunnel MPLS TE in his Core

Design Consideration:

To Provision Hub & Spoke L2 MPLS VPN, ISP Needs to make careful
use of MPLS L2 Psuedowire Cross-Connects which are Point-to=Point

ISP will need to use 1 Psuedowire/Customer from Hub PE to Each Spoke PE
and a Direct Psuedowire/Customer between Spokes who want to have direct
communication bypassing Hub

For Internet Access ISP will use a dedicated Sub-Interface to Hub CE
and provision MPLS L3 VPN for that Link and use VRF Aware NAT at the PE
Router Haing Internet Peering Link.

ISP is using VRF Internet to transport default route to Customer MPLS
L3 VPN vrf cus1 for Internet Access.This way all spokes go to Internet via
Hub CE.

ISP has enabled Dynamic MPLS TE using Auto-Tunnel Primary

Customer is using PIM Sparse-Dense Mode with Hube CE as Auto-RP


Hub talks to Spoke A,B,C
Spoke A talks directly to Spoke B
Spoke C talks to veryone via Hub

ISP AS used 64513
IGP used OSPF Area 0
psuedowire used cus1

For Internet
VRF used cus1
rd 64513:1
RT 64513:100

VRF used Internet
rd 64513:9
RT 64513:9999

IGMP Groups used
224.1.1.1 Hub CE
224.2.2.2 Spoke A
224.3.3.3 Spoke B
224.4.4.4 Spoke C

*********************************

cus1.pop1#sh running-config
Building configuration...

Current configuration : 1678 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.1.1.1
!
interface FastEthernet0/0
description edge1.pop1-MPLS L2 VPN
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 100
ip address 10.0.10.1 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/0.2
encapsulation dot1Q 200
ip address 10.0.20.1 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/0.3
encapsulation dot1Q 300
ip address 10.0.30.1 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/0.4
description Internet_Link
encapsulation dot1Q 500
ip address 192.168.1.1 255.255.255.252
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 172.16.101.1 0.0.0.0 area 0
default-information originate always
!
router ospf 10
router-id 192.168.1.1
log-adjacency-changes
network 192.168.1.0 0.0.0.3 area 0
!
ip http server
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop1#
cus1.pop2#sh running-config
Building configuration...

Current configuration : 1147 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.102.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.2.2.2
!
interface FastEthernet0/0
description edge1.pop2
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 100
ip address 10.0.10.2 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/0.2
encapsulation dot1Q 400
ip address 10.0.40.1 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 172.16.102.1 0.0.0.0 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop2#

cus1.pop3#sh running-config
Building configuration...

Current configuration : 1123 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.103.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.3.3.3
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 200
ip address 10.0.20.2 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/0.2
encapsulation dot1Q 400
ip address 10.0.40.2 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
network 172.16.103.1 0.0.0.0 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop3#

cus1.pop4#sh running-config
Building configuration...

Current configuration : 1058 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop4
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.104.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.4.4.4
!
interface FastEthernet0/0
description edge1.pop4
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 300
ip address 10.0.30.2 255.255.255.252
ip pim sparse-dense-mode
no snmp trap link-status
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
router-id 172.16.104.1
log-adjacency-changes
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 0
network 172.16.104.1 0.0.0.0 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop4#

ISP#sh running-config
Building configuration...

Current configuration : 1335 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.254.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop3
ip address 10.0.100.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 10.0.254.0 mask 255.255.255.0
neighbor 10.0.100.1 remote-as 64513
neighbor 10.0.100.1 default-originate
neighbor 10.0.100.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

ISP#
edge1.pop1#sh running-config
Building configuration...

Current configuration : 4413 bytes
!
! Last configuration change at 16:04:31 UTC Thu May 13 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:9999
!
!
!
no ip domain lookup
no ipv6 cef
!
!
!
track 1 interface Tunnel65337 line-protocol
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description cus1.pop1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description cus1.pop1
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.1
encapsulation dot1Q 100
xconnect 10.0.2.1 100 pw-class cus1
!
interface FastEthernet1/1.2
encapsulation dot1Q 200
xconnect 10.0.3.1 100 pw-class cus1
!
interface FastEthernet1/1.3
encapsulation dot1Q 300
xconnect 10.0.4.1 100 pw-class cus1
!
interface FastEthernet1/1.4
description Internet_Link_cus1
encapsulation dot1Q 500
ip vrf forwarding cus1
ip address 192.168.1.2 255.255.255.252
!
interface Serial2/0
description edge1.pop2
ip address 10.0.12.1 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial2/1
description edge1.pop3
ip address 10.0.13.1 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial2/2
description edge1.pop4
ip address 10.0.14.1 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute static subnets
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
default-information originate
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute static
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
ip http server
no ip http secure-server
!
!
ip route vrf cus1 10.0.10.0 255.255.255.252 FastEthernet1/1.4 192.168.1.1
ip route vrf cus1 10.0.20.0 255.255.255.252 FastEthernet1/1.4 192.168.1.1
ip route vrf cus1 10.0.30.0 255.255.255.252 FastEthernet1/1.4 192.168.1.1
ip route vrf cus1 10.0.40.0 255.255.255.252 FastEthernet1/1.4 192.168.1.1
ip route vrf cus1 172.16.0.0 255.255.0.0 192.168.1.1
ip route vrf cus1 172.16.0.0 255.255.0.0 FastEthernet1/1.4 192.168.1.1
!
ip explicit-path name Gold enable
next-address 10.0.12.2
next-address 10.0.23.2
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!

track 1 interface Tunnel65336 line-protocol

!
event manager applet mplsTE
event track 1 state up
action 1.0 cli command "enable"
action 1.1 cli command "conf terminal"
action 1.2 cli command "int tun65336"
action 1.3 cli command "mpls ip"
action 2 syslog msg "MPLS was activated over TE-Tunnel!"
!
end

edge1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2302 bytes
!
! Last configuration change at 13:55:07 UTC Thu May 13 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description cus1.pop2
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description cus1.pop2
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.1
encapsulation dot1Q 100
xconnect 10.0.1.1 100 pw-class cus1
!
interface FastEthernet1/1.2
encapsulation dot1Q 400
xconnect 10.0.3.1 100 pw-class cus1
!
interface Serial2/0
description edge1.pop1
ip address 10.0.12.2 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/1
description edge1.pop4
ip address 10.0.24.1 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/2
description edge1.pop3
ip address 10.0.23.1 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

edge1.pop3#sh running-config
Building configuration...

Current configuration : 4538 bytes
!
! Last configuration change at 16:04:51 UTC Thu May 13 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf Internet
rd 64513:9
route-target export 64513:9999
route-target import 64513:9999
route-target import 64513:100
!
!
!
no ip domain lookup
no ipv6 cef
!
!
!
track 1 interface Tunnel65337 line-protocol
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description cus1.pop3
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description cus1.pop3
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.1
encapsulation dot1Q 200
xconnect 10.0.1.1 100 pw-class cus1
!
interface FastEthernet1/1.2
encapsulation dot1Q 400
xconnect 10.0.2.1 100 pw-class cus1
!
interface Serial2/0
description edge1.pop1
ip address 10.0.13.2 255.255.255.252
ip nat inside
ip ospf authentication-key 7 045802150C2E
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial2/1
description edge1.pop4
ip address 10.0.34.1 255.255.255.252
ip nat inside
ip ospf authentication-key 7 070C285F4D06
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/2
description edge1.pop2
ip address 10.0.23.2 255.255.255.252
ip nat inside
ip ospf authentication-key 7 030752180500
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
ip rsvp bandwidth
!
interface Serial2/3
description Internet_Link
ip vrf forwarding Internet
ip address 10.0.100.1 255.255.255.252
shutdown
serial restart-delay 0
!
interface Serial2/4
description ISP_Internet_Link
ip address 10.0.100.1 255.255.255.252
ip nat outside
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
area 0 authentication message-digest
redistribute bgp 64513 subnets
network 10.0.0.0 0.255.255.255 area 0
default-information originate always
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.100.2 remote-as 64514
!
address-family ipv4
no synchronization
network 10.0.0.0
network 10.0.200.0 mask 255.255.255.0
neighbor 10.0.100.2 activate
neighbor 10.0.100.2 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf Internet
no synchronization
network 0.0.0.0
network 10.0.200.0 mask 255.255.255.0
exit-address-family
!
ip nat pool Internet 10.0.200.1 10.0.200.100 netmask 255.255.255.0
ip nat inside source route-map Internet pool Internet vrf Internet
no ip http server
no ip http secure-server
!
!
ip route 10.0.0.0 255.0.0.0 Null0
ip route 10.0.200.0 255.255.255.0 Null0
ip route vrf Internet 0.0.0.0 0.0.0.0 Serial2/4 10.0.100.2
!
ip explicit-path name Gold enable
next-address 10.0.23.1
next-address 10.0.12.1
!
access-list 14 permit 10.0.10.0 0.0.0.3
access-list 14 permit 10.0.20.0 0.0.0.3
access-list 14 permit 10.0.30.0 0.0.0.3
access-list 14 permit 10.0.40.0 0.0.0.3
access-list 14 permit 172.16.0.0 0.0.255.255
access-list 14 permit 192.168.1.0 0.0.0.3
!
route-map Internet permit 10
match ip address 14
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
track 1 interface Tunnel65336 line-protocol

!
event manager applet mplsTE
event track 1 state up
action 1.0 cli command "enable"
action 1.1 cli command "conf terminal"
action 1.2 cli command "int tun65336"
action 1.3 cli command "mpls ip"
action 2 syslog msg "MPLS was activated over TE-Tunnel!"
!
end

edge1.pop3#


edge1.pop4#sh running-config
Building configuration...

Current configuration : 2054 bytes
!
! Last configuration change at 13:54:27 UTC Thu May 13 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop4
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description cus1.pop4
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
description cus1.pop4
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.1
encapsulation dot1Q 300
xconnect 10.0.1.1 100 pw-class cus1
!
interface Serial2/0
description edge1.pop2
ip address 10.0.24.2 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/1
description edge1.pop3
ip address 10.0.34.2 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/2
description edge1.pop1
ip address 10.0.14.2 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop4#
*******************************************
OUTPUTS
*******************************************
HUB & SPOKE TRAFFIC
*******************************************

cus1.pop4#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.30.1 900 msec 532 msec *
cus1.pop4#traceroute 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 10.0.30.1 336 msec 256 msec 280 msec
2 10.0.10.2 780 msec 1372 msec 848 msec
cus1.pop4#traceroute 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 10.0.30.1 936 msec 564 msec 640 msec
2 10.0.20.2 972 msec 1208 msec 1464 msec
cus1.pop4#


cus1.pop3#traceroute 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 10.0.20.1 300 msec 144 msec 340 msec
2 10.0.30.2 796 msec 700 msec 576 msec
cus1.pop3#traceroute 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 10.0.40.1 448 msec * 448 msec
cus1.pop3#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.20.1 576 msec 512 msec 264 msec
cus1.pop3#


cus1.pop2#traceroute 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 10.0.10.1 292 msec 480 msec 312 msec
2 10.0.30.2 1020 msec 804 msec 888 msec
cus1.pop2#traceroute 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 10.0.40.2 188 msec * 164 msec
cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.10.1 512 msec 624 msec 608 msec
cus1.pop2#


cus1.pop1#traceroute 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 10.0.30.2 204 msec * 340 msec
cus1.pop1#traceroute 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 10.0.20.2 268 msec 564 msec 628 msec
cus1.pop1#traceroute 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 10.0.10.2 288 msec * 548 msec
cus1.pop1#

****************************
INTERNET TRAFFIC VIA HUB
*****************************

edge1.pop3#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
udp 10.0.200.1:49189 10.0.10.2:49189 10.0.254.1:33443 10.0.254.1:33443
udp 10.0.200.1:49190 10.0.10.2:49190 10.0.254.1:33444 10.0.254.1:33444
udp 10.0.200.1:49191 10.0.10.2:49191 10.0.254.1:33445 10.0.254.1:33445
udp 10.0.200.3:49182 10.0.20.2:49182 10.0.254.1:33443 10.0.254.1:33443
udp 10.0.200.3:49183 10.0.20.2:49183 10.0.254.1:33444 10.0.254.1:33444
udp 10.0.200.3:49184 10.0.20.2:49184 10.0.254.1:33445 10.0.254.1:33445
udp 10.0.200.4:49176 192.168.1.1:49176 10.0.254.1:33440 10.0.254.1:33440
udp 10.0.200.4:49177 192.168.1.1:49177 10.0.254.1:33441 10.0.254.1:33441
udp 10.0.200.4:49178 192.168.1.1:49178 10.0.254.1:33442 10.0.254.1:33442
edge1.pop3#

cus1.pop4#traceroute 10.0.254.1

Type escape sequence to abort.
Tracing the route to 10.0.254.1

1 10.0.30.1 516 msec 284 msec 996 msec
2 192.168.1.2 1360 msec 1068 msec 700 msec
3 10.0.13.2 1636 msec 232 msec 1652 msec
4 10.0.100.2 896 msec 1984 msec 460 msec
cus1.pop4#

cus1.pop3#traceroute 10.0.254.1

Type escape sequence to abort.
Tracing the route to 10.0.254.1

1 10.0.20.1 392 msec 584 msec 144 msec
2 192.168.1.2 632 msec 232 msec 572 msec
3 10.0.13.2 556 msec 452 msec 412 msec
4 10.0.100.2 568 msec 708 msec 100 msec
cus1.pop3#

cus1.pop2#traceroute 10.0.254.1

Type escape sequence to abort.
Tracing the route to 10.0.254.1

1 10.0.10.1 340 msec 352 msec 240 msec
2 192.168.1.2 464 msec 480 msec 488 msec
3 10.0.13.2 604 msec 412 msec 376 msec
4 10.0.100.2 768 msec 560 msec 784 msec
cus1.pop2#

cus1.pop1#traceroute 10.0.254.1

Type escape sequence to abort.
Tracing the route to 10.0.254.1

1 192.168.1.2 136 msec 172 msec 184 msec
2 10.0.13.2 200 msec 208 msec 276 msec
3 10.0.100.2 72 msec 880 msec 752 msec
cus1.pop1#


**********************************
MULTICAST TRAFFIC
***********************************
cus1.pop4#mtrace 172.16.104.1 172.16.102.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.104.1 to 172.16.102.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.102.1
-1 10.0.10.2 PIM [172.16.104.1/32]
-2 10.0.10.1 PIM Reached RP/Core [172.16.104.1/32]

cus1.pop4#mtrace 172.16.104.1 172.16.103.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.104.1 to 172.16.103.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.103.1
-1 10.0.20.2 PIM [172.16.104.1/32]
-2 10.0.20.1 PIM Reached RP/Core [172.16.104.1/32]
cus1.pop4#

cus1.pop4#mtrace 172.16.104.1 172.16.101.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.104.1 to 172.16.101.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path...
0 172.16.101.1
-1 10.0.30.1 PIM Reached RP/Core [172.16.104.1/32]
cus1.pop4#


cus1.pop3#mtrace 172.16.103.1 172.16.102.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.103.1 to 172.16.102.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.102.1
-1 10.0.40.1 PIM [172.16.103.1/32]
-2 10.0.10.1 PIM Reached RP/Core [172.16.103.1/32]
cus1.pop3#

cus1.pop3#mtrace 172.16.103.1 172.16.104.1 224.4.4.4
Type escape sequence to abort.
Mtrace from 172.16.103.1 to 172.16.104.1 via group 224.4.4.4
From source (?) to destination (?)
Querying full reverse path...
0 172.16.104.1
-1 10.0.30.2 PIM [172.16.103.1/32]
-2 10.0.30.1 PIM Reached RP/Core [172.16.103.1/32]

cus1.pop3#mtrace 172.16.103.1 172.16.101.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.103.1 to 172.16.101.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path...
0 172.16.101.1
-1 10.0.20.1 PIM Reached RP/Core [172.16.103.1/32]
cus1.pop3#

cus1.pop2#mtrace 172.16.102.1 172.16.103.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.102.1 to 172.16.103.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.103.1
-1 10.0.40.2 PIM [172.16.102.1/32]
-2 10.0.40.1 PIM [172.16.102.0/24]
-3 172.16.102.1
cus1.pop2#

cus1.pop2#mtrace 172.16.102.1 172.16.104.1 224.4.4.4
Type escape sequence to abort.
Mtrace from 172.16.102.1 to 172.16.104.1 via group 224.4.4.4
From source (?) to destination (?)
Querying full reverse path...
0 172.16.104.1
-1 10.0.30.2 PIM [172.16.102.1/32]
-2 10.0.30.1 PIM Reached RP/Core [172.16.102.1/32]


cus1.pop2#mtrace 172.16.102.1 172.16.101.1 224.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.102.1 to 172.16.101.1 via group 224.1.1.1
From source (?) to destination (?)
Querying full reverse path...
0 172.16.101.1
-1 10.0.10.1 PIM Reached RP/Core [172.16.102.1/32]
cus1.pop2#


cus1.pop1#mtrace 172.16.101.1 172.16.102.1 224.2.2.2
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.102.1 via group 224.2.2.2
From source (?) to destination (?)
Querying full reverse path...
0 172.16.102.1
-1 10.0.10.2 PIM [172.16.101.1/32]
-2 10.0.10.1 PIM Reached RP/Core [172.16.101.0/24]

cus1.pop1#mtrace 172.16.101.1 172.16.103.1 224.3.3.3
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.103.1 via group 224.3.3.3
From source (?) to destination (?)
Querying full reverse path...
0 172.16.103.1
-1 10.0.20.2 PIM [172.16.101.1/32]
-2 10.0.20.1 PIM Reached RP/Core [172.16.101.0/24]

cus1.pop1#mtrace 172.16.101.1 172.16.104.1 224.4.4.4
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 172.16.104.1 via group 224.4.4.4
From source (?) to destination (?)
Querying full reverse path...
0 172.16.104.1
-1 10.0.30.2 PIM [172.16.101.1/32]
-2 10.0.30.1 PIM Reached RP/Core [172.16.101.0/24]
cus1.pop1#

cus1.pop1#ping 224.4.4.4

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:

Reply to request 0 from 10.0.30.2, 640 ms
Reply to request 0 from 10.0.30.2, 1212 ms
Reply to request 0 from 10.0.30.2, 640 ms
Reply to request 0 from 10.0.30.2, 640 ms
cus1.pop1#ping 224.3.3.3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:

Reply to request 0 from 10.0.20.2, 324 ms
Reply to request 0 from 10.0.20.2, 432 ms
Reply to request 0 from 10.0.20.2, 340 ms
Reply to request 0 from 10.0.20.2, 324 ms
cus1.pop1#ping 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 10.0.10.2, 404 ms
Reply to request 0 from 10.0.10.2, 804 ms
Reply to request 0 from 10.0.10.2, 804 ms
Reply to request 0 from 10.0.10.2, 404 ms
cus1.pop1#

cus1.pop2#ping 224.4.4.4

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:

Reply to request 0 from 10.0.30.2, 928 ms
Reply to request 0 from 10.0.30.2, 1664 ms
Reply to request 0 from 10.0.30.2, 1660 ms
cus1.pop2#ping 224.3.3.3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:

Reply to request 0 from 10.0.40.2, 564 ms
Reply to request 0 from 10.0.20.2, 564 ms
Reply to request 0 from 10.0.20.2, 564 ms
cus1.pop2#ping 224.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.0.10.1, 844 ms
cus1.pop2#

cus1.pop3#ping 224.4.4.4

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.4.4.4, timeout is 2 seconds:

Reply to request 0 from 10.0.30.2, 548 ms
Reply to request 0 from 10.0.30.2, 552 ms
Reply to request 0 from 10.0.30.2, 548 ms
cus1.pop3#ping 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 10.0.40.1, 756 ms
Reply to request 0 from 10.0.10.2, 756 ms
Reply to request 0 from 10.0.10.2, 756 ms
cus1.pop3#ping 224.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.0.20.1, 324 ms
cus1.pop3#

cus1.pop4#ping 224.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.0.30.1, 636 ms
cus1.pop4#ping 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 10.0.10.2, 1064 ms
Reply to request 0 from 10.0.10.2, 1068 ms
cus1.pop4#ping 224.3.3.3

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.3.3.3, timeout is 2 seconds:

Reply to request 0 from 10.0.20.2, 544 ms
Reply to request 0 from 10.0.20.2, 592 ms
cus1.pop4#

************************************
MPLS TE AUTO-TUNNEL

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1900 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 8 seconds
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 100 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65337 10.0.3.1 - Se2/1 up/up
edge1.pop3_t65336 10.0.1.1 Se2/1 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#show mpls traffic-eng tunnels

P2P TUNNELS/LSPs:

Name: edge1.pop1_t65337 (Tunnel65337) Destination: 10.0.3.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65337 (Basis for Setup, path we
ight 64)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial2/1, implicit-null
Next Hop : 10.0.13.2
RSVP Signalling Info:
Src 10.0.1.1, Dst 10.0.3.1, Tun_Id 65337, Tun_Instance 4394
RSVP Path Info:
My Address: 10.0.13.1
Explicit Route: 10.0.13.2 10.0.3.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 10.0.3.1(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 6 minutes, 25 seconds
Time since path change: 6 minutes, 24 seconds
Number of LSP IDs (Tun_Instances) used: 1
Current LSP: [ID: 4394]
Uptime: 6 minutes, 24 seconds

LSP Tunnel edge1.pop3_t65336 is signalled, connection is up
InLabel : Serial2/1, implicit-null
Prev Hop : 10.0.13.2
OutLabel : -
RSVP Signalling Info:
Src 10.0.3.1, Dst 10.0.1.1, Tun_Id 65336, Tun_Instance 8125
RSVP Path Info:
My Address: 10.0.1.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

P2MP TUNNELS:

P2MP SUB-LSPS:
edge1.pop1#

edge1.pop3#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Disabled (0 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2205 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
Periodic auto-bw collection: every 300 seconds, next in 105 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop3_t65336 10.0.1.1 - Se2/0 up/up
edge1.pop1_t65337 10.0.3.1 Se2/0 - up/up

Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop3#show mpls traffic-eng tunnels

P2P TUNNELS/LSPs:

Name: edge1.pop3_t65336 (Tunnel65336) Destination: 10.0.1.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65336 (Basis for Setup, path we
ight 64)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial2/0, implicit-null
Next Hop : 10.0.13.1
RSVP Signalling Info:
Src 10.0.3.1, Dst 10.0.1.1, Tun_Id 65336, Tun_Instance 8125
RSVP Path Info:
My Address: 10.0.13.2
Explicit Route: 10.0.13.1 10.0.1.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 10.0.1.1(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
History:
Tunnel:
Time since created: 6 minutes, 55 seconds
Time since path change: 6 minutes, 55 seconds
Number of LSP IDs (Tun_Instances) used: 1
Current LSP: [ID: 8125]
Uptime: 6 minutes, 55 seconds

LSP Tunnel edge1.pop1_t65337 is signalled, connection is up
InLabel : Serial2/0, implicit-null
Prev Hop : 10.0.13.1
OutLabel : -
RSVP Signalling Info:
Src 10.0.1.1, Dst 10.0.3.1, Tun_Id 65337, Tun_Instance 4394
RSVP Path Info:
My Address: 10.0.3.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

P2MP TUNNELS:

P2MP SUB-LSPS:
edge1.pop3#
***********************************

*********************************
L2 MPLS Psuedowires ISP Domain
*********************************
edge1.pop1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/1.1 Eth VLAN 100 10.0.2.1 100 UP
Fa1/1.2 Eth VLAN 200 10.0.3.1 100 UP
Fa1/1.3 Eth VLAN 300 10.0.4.1 100 UP
edge1.pop1#

edge1.pop2#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/1.1 Eth VLAN 100 10.0.1.1 100 UP
Fa1/1.2 Eth VLAN 400 10.0.3.1 100 UP
edge1.pop2#

edge1.pop3#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/1.1 Eth VLAN 200 10.0.1.1 100 UP
Fa1/1.2 Eth VLAN 400 10.0.2.1 100 UP
edge1.pop3#

edge1.pop4#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/1.1 Eth VLAN 300 10.0.1.1 100 UP
edge1.pop4#

*********************************
L3 MPLS VRFs ISP Domain
*********************************
edge1.pop1#sh ip vrf
Name Default RD Interfaces
cus1 64513:1 Fa1/1.4
edge1.pop1#sh ip bgp vpnv4 vrf cus1
BGP table version is 22, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-externa
l
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf cus1)
*>i0.0.0.0 10.0.3.1 0 100 0 i
*> 10.0.10.0/30 192.168.1.1 0 32768 ?
*> 10.0.20.0/30 192.168.1.1 0 32768 ?
*> 10.0.30.0/30 192.168.1.1 0 32768 ?
*> 10.0.40.0/30 192.168.1.1 0 32768 ?
*> 172.16.0.0 192.168.1.1 0 32768 ?
*> 192.168.1.0/30 0.0.0.0 0 32768 ?
edge1.pop1#

edge1.pop3#sh ip vrf
Name Default RD Interfaces
Internet 64513:9 Se2/3
edge1.pop3#sh ip bgp vpnv4 vrf Internet
BGP table version is 26, local router ID is 10.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-externa
l
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:9 (default for vrf Internet)
*> 0.0.0.0 0.0.0.0 0 32768 i
*>i10.0.10.0/30 10.0.1.1 0 100 0 ?
*>i10.0.20.0/30 10.0.1.1 0 100 0 ?
*>i10.0.30.0/30 10.0.1.1 0 100 0 ?
*>i10.0.40.0/30 10.0.1.1 0 100 0 ?
*>i172.16.0.0 10.0.1.1 0 100 0 ?
*>i192.168.1.0/30 10.0.1.1 0 100 0 ?
edge1.pop3#

**************************
ROUTING TABLE-CE DOMAIN
**************************

cus1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O E2 172.16.0.0/16 [110/20] via 192.168.1.2, 00:37:07, FastEthernet0/0.4
O 172.16.104.1/32 [110/2] via 10.0.30.2, 01:14:18, FastEthernet0/0.3
C 172.16.101.0/24 is directly connected, Loopback0
O 172.16.103.1/32 [110/2] via 10.0.20.2, 01:14:18, FastEthernet0/0.2
O 172.16.102.1/32 [110/2] via 10.0.10.2, 01:14:18, FastEthernet0/0.1
10.0.0.0/30 is subnetted, 4 subnets
C 10.0.10.0 is directly connected, FastEthernet0/0.1
C 10.0.30.0 is directly connected, FastEthernet0/0.3
C 10.0.20.0 is directly connected, FastEthernet0/0.2
O 10.0.40.0 [110/2] via 10.0.20.2, 01:14:18, FastEthernet0/0.2
[110/2] via 10.0.10.2, 01:14:18, FastEthernet0/0.1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0.4
O*E2 0.0.0.0/0 [110/1] via 192.168.1.2, 00:53:21, FastEthernet0/0.4
cus1.pop1#

cus1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.10.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O 172.16.104.1/32 [110/3] via 10.0.10.1, 01:14:43, FastEthernet0/0.1
O 172.16.101.1/32 [110/2] via 10.0.10.1, 01:14:43, FastEthernet0/0.1
O 172.16.103.1/32 [110/2] via 10.0.40.2, 01:14:43, FastEthernet0/0.2
C 172.16.102.0/24 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 4 subnets
C 10.0.10.0 is directly connected, FastEthernet0/0.1
O 10.0.30.0 [110/2] via 10.0.10.1, 01:14:43, FastEthernet0/0.1
O 10.0.20.0 [110/2] via 10.0.40.2, 01:14:43, FastEthernet0/0.2
[110/2] via 10.0.10.1, 01:14:43, FastEthernet0/0.1
C 10.0.40.0 is directly connected, FastEthernet0/0.2
O*E2 0.0.0.0/0 [110/1] via 10.0.10.1, 01:14:43, FastEthernet0/0.1
cus1.pop2#

cus1.pop3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.20.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O 172.16.104.1/32 [110/3] via 10.0.20.1, 01:13:35, FastEthernet0/0.1
O 172.16.101.1/32 [110/2] via 10.0.20.1, 01:13:35, FastEthernet0/0.1
C 172.16.103.0/24 is directly connected, Loopback0
O 172.16.102.1/32 [110/2] via 10.0.40.1, 01:13:35, FastEthernet0/0.2
10.0.0.0/30 is subnetted, 4 subnets
O 10.0.10.0 [110/2] via 10.0.40.1, 01:13:35, FastEthernet0/0.2
[110/2] via 10.0.20.1, 01:13:35, FastEthernet0/0.1
O 10.0.30.0 [110/2] via 10.0.20.1, 01:13:35, FastEthernet0/0.1
C 10.0.20.0 is directly connected, FastEthernet0/0.1
C 10.0.40.0 is directly connected, FastEthernet0/0.2
O*E2 0.0.0.0/0 [110/1] via 10.0.20.1, 01:13:36, FastEthernet0/0.1
cus1.pop3#

**************************
ROUTING TABLE-ISP DOMAIN
**************************

edge1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.13.2 to network 0.0.0.0

O*E2 0.0.0.0/0 [110/1] via 10.0.13.2, 00:52:28, Serial2/1
10.0.0.0/8 is variably subnetted, 17 subnets, 4 masks
O E2 10.0.0.0/8 [110/1] via 10.0.13.2, 00:51:28, Serial2/1
C 10.0.1.1/32 is directly connected, Loopback0
O 10.0.2.1/32 [110/65] via 10.0.12.2, 01:58:07, Serial2/0
O 10.0.3.1/32 [110/65] via 10.0.13.2, 01:58:07, Serial2/1
O 10.0.4.1/32 [110/65] via 10.0.14.2, 01:57:17, Serial2/2
C 10.0.12.0/30 is directly connected, Serial2/0
L 10.0.12.1/32 is directly connected, Serial2/0
C 10.0.13.0/30 is directly connected, Serial2/1
L 10.0.13.1/32 is directly connected, Serial2/1
C 10.0.14.0/30 is directly connected, Serial2/2
L 10.0.14.1/32 is directly connected, Serial2/2
O 10.0.23.0/30 [110/128] via 10.0.13.2, 01:58:08, Serial2/1
[110/128] via 10.0.12.2, 01:58:08, Serial2/0
O 10.0.24.0/30 [110/128] via 10.0.14.2, 01:57:18, Serial2/2
[110/128] via 10.0.12.2, 01:57:48, Serial2/0
O 10.0.34.0/30 [110/128] via 10.0.14.2, 01:57:18, Serial2/2
[110/128] via 10.0.13.2, 01:57:48, Serial2/1
O 10.0.100.0/30 [110/128] via 10.0.13.2, 00:56:42, Serial2/1
O E2 10.0.200.0/24 [110/1] via 10.0.13.2, 00:53:45, Serial2/1
O E2 10.0.254.0/24 [110/1] via 10.0.13.2, 00:53:45, Serial2/1
edge1.pop1#

edge1.pop1#sh ip route vrf cus1

Routing Table: cus1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.3.1 to network 0.0.0.0

B* 0.0.0.0/0 [200/0] via 10.0.3.1, 00:55:24
10.0.0.0/30 is subnetted, 4 subnets
S 10.0.10.0 [1/0] via 192.168.1.1, FastEthernet1/1.4
S 10.0.20.0 [1/0] via 192.168.1.1, FastEthernet1/1.4
S 10.0.30.0 [1/0] via 192.168.1.1, FastEthernet1/1.4
S 10.0.40.0 [1/0] via 192.168.1.1, FastEthernet1/1.4
S 172.16.0.0/16 [1/0] via 192.168.1.1, FastEthernet1/1.4
[1/0] via 192.168.1.1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/30 is directly connected, FastEthernet1/1.4
L 192.168.1.2/32 is directly connected, FastEthernet1/1.4
edge1.pop1#

edge1.pop2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.23.2 to network 0.0.0.0

O*E2 0.0.0.0/0 [110/1] via 10.0.23.2, 00:52:46, Serial2/2
10.0.0.0/8 is variably subnetted, 17 subnets, 4 masks
O E2 10.0.0.0/8 [110/1] via 10.0.23.2, 00:51:47, Serial2/2
O 10.0.1.1/32 [110/65] via 10.0.12.1, 01:58:25, Serial2/0
C 10.0.2.1/32 is directly connected, Loopback0
O 10.0.3.1/32 [110/65] via 10.0.23.2, 01:58:25, Serial2/2
O 10.0.4.1/32 [110/65] via 10.0.24.2, 01:57:36, Serial2/1
C 10.0.12.0/30 is directly connected, Serial2/0
L 10.0.12.2/32 is directly connected, Serial2/0
O 10.0.13.0/30 [110/128] via 10.0.23.2, 01:58:25, Serial2/2
[110/128] via 10.0.12.1, 01:58:25, Serial2/0
O 10.0.14.0/30 [110/128] via 10.0.24.2, 01:57:36, Serial2/1
[110/128] via 10.0.12.1, 01:58:15, Serial2/0
C 10.0.23.0/30 is directly connected, Serial2/2
L 10.0.23.1/32 is directly connected, Serial2/2
C 10.0.24.0/30 is directly connected, Serial2/1
L 10.0.24.1/32 is directly connected, Serial2/1
O 10.0.34.0/30 [110/128] via 10.0.24.2, 01:57:36, Serial2/1
[110/128] via 10.0.23.2, 01:58:05, Serial2/2
O 10.0.100.0/30 [110/128] via 10.0.23.2, 00:57:00, Serial2/2
O E2 10.0.200.0/24 [110/1] via 10.0.23.2, 00:54:03, Serial2/2
O E2 10.0.254.0/24 [110/1] via 10.0.23.2, 00:54:03, Serial2/2
edge1.pop2#
cus1.pop4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.30.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.104.0/24 is directly connected, Loopback0
O 172.16.101.1/32 [110/2] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
O 172.16.103.1/32 [110/3] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
O 172.16.102.1/32 [110/3] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
10.0.0.0/30 is subnetted, 4 subnets
O 10.0.10.0 [110/2] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
C 10.0.30.0 is directly connected, FastEthernet0/0.1
O 10.0.20.0 [110/2] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
O 10.0.40.0 [110/3] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
O*E2 0.0.0.0/0 [110/1] via 10.0.30.1, 01:14:55, FastEthernet0/0.1
cus1.pop4#

edge1.pop3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.100.2 to network 0.0.0.0

B* 0.0.0.0/0 [20/0] via 10.0.100.2, 00:53:11
10.0.0.0/8 is variably subnetted, 18 subnets, 4 masks
S 10.0.0.0/8 is directly connected, Null0
O 10.0.1.1/32 [110/65] via 10.0.13.1, 00:53:11, Serial2/0
O 10.0.2.1/32 [110/65] via 10.0.23.1, 00:53:11, Serial2/2
C 10.0.3.1/32 is directly connected, Loopback0
O 10.0.4.1/32 [110/65] via 10.0.34.2, 00:53:11, Serial2/1
O 10.0.12.0/30 [110/128] via 10.0.23.1, 00:53:11, Serial2/2
[110/128] via 10.0.13.1, 00:53:11, Serial2/0
C 10.0.13.0/30 is directly connected, Serial2/0
L 10.0.13.2/32 is directly connected, Serial2/0
O 10.0.14.0/30 [110/128] via 10.0.34.2, 00:53:11, Serial2/1
[110/128] via 10.0.13.1, 00:53:11, Serial2/0
C 10.0.23.0/30 is directly connected, Serial2/2
L 10.0.23.2/32 is directly connected, Serial2/2
O 10.0.24.0/30 [110/128] via 10.0.34.2, 00:53:11, Serial2/1
[110/128] via 10.0.23.1, 00:53:11, Serial2/2
C 10.0.34.0/30 is directly connected, Serial2/1
L 10.0.34.1/32 is directly connected, Serial2/1
C 10.0.100.0/30 is directly connected, Serial2/4
L 10.0.100.1/32 is directly connected, Serial2/4
S 10.0.200.0/24 is directly connected, Null0
B 10.0.254.0/24 [20/0] via 10.0.100.2, 00:53:11
edge1.pop3#sh ip route vrf Internet

Routing Table: Internet
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.100.2 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 10.0.100.2, Serial2/4
10.0.0.0/30 is subnetted, 4 subnets
B 10.0.10.0 [200/0] via 10.0.1.1, 00:32:22
B 10.0.20.0 [200/0] via 10.0.1.1, 00:32:18
B 10.0.30.0 [200/0] via 10.0.1.1, 00:32:12
B 10.0.40.0 [200/0] via 10.0.1.1, 00:31:21
B 172.16.0.0/16 [200/0] via 10.0.1.1, 00:38:09
192.168.1.0/30 is subnetted, 1 subnets
B 192.168.1.0 [200/0] via 10.0.1.1, 01:09:39
edge1.pop3#

edge1.pop4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is 10.0.34.1 to network 0.0.0.0

O*E2 0.0.0.0/0 [110/1] via 10.0.34.1, 00:53:47, Serial2/1
10.0.0.0/8 is variably subnetted, 17 subnets, 4 masks
O E2 10.0.0.0/8 [110/1] via 10.0.34.1, 00:52:48, Serial2/1
O 10.0.1.1/32 [110/65] via 10.0.14.1, 01:58:42, Serial2/2
O 10.0.2.1/32 [110/65] via 10.0.24.1, 01:58:42, Serial2/0
O 10.0.3.1/32 [110/65] via 10.0.34.1, 01:58:42, Serial2/1
C 10.0.4.1/32 is directly connected, Loopback0
O 10.0.12.0/30 [110/128] via 10.0.24.1, 01:58:42, Serial2/0
[110/128] via 10.0.14.1, 01:58:42, Serial2/2
O 10.0.13.0/30 [110/128] via 10.0.34.1, 01:58:42, Serial2/1
[110/128] via 10.0.14.1, 01:58:42, Serial2/2
C 10.0.14.0/30 is directly connected, Serial2/2
L 10.0.14.2/32 is directly connected, Serial2/2
O 10.0.23.0/30 [110/128] via 10.0.34.1, 01:58:42, Serial2/1
[110/128] via 10.0.24.1, 01:58:42, Serial2/0
C 10.0.24.0/30 is directly connected, Serial2/0
L 10.0.24.2/32 is directly connected, Serial2/0
C 10.0.34.0/30 is directly connected, Serial2/1
L 10.0.34.2/32 is directly connected, Serial2/1
O 10.0.100.0/30 [110/128] via 10.0.34.1, 00:58:01, Serial2/1
O E2 10.0.200.0/24 [110/1] via 10.0.34.1, 00:55:04, Serial2/1
O E2 10.0.254.0/24 [110/1] via 10.0.34.1, 00:55:04, Serial2/1
edge1.pop4#

***************************************
ROUTING TABLE-Inetrnet Provider DOMAIN
*****************************************
ISP#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
B 10.0.0.0/8 [20/0] via 10.0.100.1, 00:53:40
C 10.0.100.0/30 is directly connected, Serial1/0
B 10.0.200.0/24 [20/0] via 10.0.100.1, 00:58:08
C 10.0.254.0/24 is directly connected, Loopback0
ISP#

No comments:

Post a Comment