Saturday, May 15, 2010

Implementing MPLS TE Auto-Tunnel FRR Link Protection for L3 and L2 MPLS VPNs LAB
















Config Guidelines
**********************************************************************
An ISP wants to offfer MPLS L2/L3 VPN Services with Traffic Gurantee
suing different SLAs and is using MPLS TE Auto-Tunnel in his core to
achieve FRR across his core

Design COnsiderations:

ISP is using P-P MPLS TE Tunnels and hence they need to be MPLS aware
so that the LSP for the BGP VPNv4 Remote Peer does not breaks at the
P routers .

Also when we use Auto-Tunnel Backup feature the tunnel created as backup
itself is not MPLS aware but what happens is In the event of Primary Tunnel
Failover due to the protected path being down the Primary Tunnel itself is
mapped to the already existing Backup Tunnel to the same Tailend. Since the
Primary Tunnel is MPLS enabled and hence traffic is still flows smoothly.
The MPLS forwarding table always shows the MPLS Labels for the BGP VPNv4
remote peer as learnt via Primary Tunnel (though labels are lost for a
while and rebuilt). The backup tunnel does not actually carries the traffic
but tells the Primary Tunnel to be rerouted across the Backup Tunnel Path.


ISP AS used 64513
IGP used ISIS
VRF used cus1
rd 64513:1
rt used 64513:100

Psuedowire Used cus1

PE-CE Routing Protocol used OSPF for MPLS L3 VPN
CE-CE Rotuing Protocol used EIGRP for MPLS L2 VPN

******************************************************************************

cus1.pop1#sh running-config
Building configuration...

Current configuration : 1396 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
!
interface Loopback1
description MPLS L2 VPN Dummy Subnet
ip address 192.168.101.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop1
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop1-MPLS l2 VPN
ip address 192.168.1.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
network 192.168.0.0 0.0.255.255
no auto-summary
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop1#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 1395 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.201.1 255.255.255.0
!
interface Loopback1
description MPLS L2 VPN Dummy Subnet
ip address 192.168.201.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop2
ip address 172.16.2.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop2-MPLS L2 VPN
ip address 192.168.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
network 192.168.0.0 0.0.255.255
no auto-summary
!
router ospf 10
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop2#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 2793 bytes
!
! Last configuration change at 14:01:35 UTC Fri May 14 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:100
route-target export 64513:101
route-target import 64513:100
route-target import 64513:101
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.8.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding cus1
ip address 172.16.151.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description cus1.pop1
ip vrf forwarding cus1
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description core1.pop1
ip address 10.0.70.2 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial1/2
description cus1.pop1-MPLS L2 VPN
no ip address
serial restart-delay 0
xconnect 10.0.4.1 100 pw-class cus1
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description cus1.pop1-MPLS L2 VPN
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
ip address 10.0.80.1 255.255.255.252
ip router isis
speed auto
duplex auto
mpls ip
mpls label protocol ldp
isis circuit-type level-1
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.1.0 0.0.0.3 area 0
!
router isis
net 49.0001.0010.0000.8001.00
metric-style wide
!
router bgp 64513
bgp router-id 10.0.8.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2448 bytes
!
! Last configuration change at 14:13:20 UTC Fri May 14 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:101
route-target import 64513:101
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding cus1
ip address 172.16.251.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description cus1.pop2
ip vrf forwarding cus1
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description core1.pop2
ip address 10.0.60.2 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial1/2
description cus1.pop2-MPLS L2 VPN
no ip address
serial restart-delay 0
xconnect 10.0.8.1 100 pw-class cus1
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.2.0 0.0.0.3 area 0
!
router isis
net 49.0002.0010.0000.4001.00
metric-style wide
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.8.1 remote-as 64513
neighbor 10.0.8.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.8.1 activate
neighbor 10.0.8.1 send-community extended
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

core1.pop1#sh running-config
Building configuration...

Current configuration : 2074 bytes
!
! Last configuration change at 16:54:34 UTC Fri May 14 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description core1.pop2-L1
bandwidth 1550000
ip address 10.0.20.1 255.255.255.252
ip router isis
shutdown
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
ip rsvp bandwidth
!
interface Serial1/1
bandwidth 1550000
no ip address
shutdown
!
interface Serial1/2
description edge1.pop1
ip address 10.0.70.1 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial1/3
bandwidth 1550000
ip address 10.0.110.1 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
isis circuit-type level-2-only
ip rsvp bandwidth
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.0010.0000.2001.00
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-1
mpls traffic-eng level-2
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2448 bytes
!
! Last configuration change at 14:13:20 UTC Fri May 14 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:101
route-target import 64513:101
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
pseudowire-class cus1
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding cus1
ip address 172.16.251.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description cus1.pop2
ip vrf forwarding cus1
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description core1.pop2
ip address 10.0.60.2 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial1/2
description cus1.pop2-MPLS L2 VPN
no ip address
serial restart-delay 0
xconnect 10.0.8.1 100 pw-class cus1
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.2.0 0.0.0.3 area 0
!
router isis
net 49.0002.0010.0000.4001.00
metric-style wide
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.8.1 remote-as 64513
neighbor 10.0.8.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.8.1 activate
neighbor 10.0.8.1 send-community extended
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

core1.pop2#sh running-config
Building configuration...

Current configuration : 2062 bytes
!
! Last configuration change at 16:46:52 UTC Fri May 14 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls ldp holdtime 15
mpls ldp discovery hello holdtime 10
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description core1.pop2-L1
bandwidth 1550000
ip address 10.0.20.2 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
isis circuit-type level-2-only
ip rsvp bandwidth
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
description edge1.pop2
ip address 10.0.60.1 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
serial restart-delay 0
!
interface Serial1/3
bandwidth 1550000
ip address 10.0.120.1 255.255.255.252
ip router isis
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
serial restart-delay 0
isis circuit-type level-2-only
ip rsvp bandwidth
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.0010.0000.3001.00
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop2#

cus1.pop2#ping 192.168.101.1 repeat 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 192.168.101.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!...............................!!!!!!!!!!!!!!!!!.
Success rate is 52 percent (35/67), round-trip min/avg/max = 116/608/1392 ms

*******************************
OUTPUTS
*******************************

Normal Traffic Path
*********************


cus1.pop1#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.1.1 112 msec 128 msec 28 msec
2 10.0.70.1 420 msec 396 msec 484 msec
3 10.0.20.2 284 msec 540 msec 432 msec
4 172.16.2.1 620 msec 404 msec 216 msec
5 172.16.2.2 336 msec * 528 msec
cus1.pop1#traceroute 192.168.201.1

Type escape sequence to abort.
Tracing the route to 192.168.201.1

1 192.168.1.2 440 msec 540 msec *
cus1.pop1#

cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.1 128 msec 112 msec 64 msec
2 10.0.60.1 368 msec 320 msec 584 msec
3 10.0.20.1 424 msec 568 msec 352 msec
4 172.16.1.1 376 msec 356 msec 556 msec
5 172.16.1.2 652 msec 788 msec 608 msec
cus1.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 192.168.1.1 248 msec * 316 msec
cus1.pop2#

************************
Failover Traffic Path
************************
cus1.pop1#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.1.1 168 msec 48 msec 80 msec
2 10.0.70.1 500 msec 476 msec 384 msec
3 10.0.110.2 524 msec 300 msec 228 msec
4 10.0.120.1 332 msec 292 msec 468 msec
5 172.16.2.1 552 msec 260 msec 188 msec
6 172.16.2.2 496 msec * 400 msec
cus1.pop1#

cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.1 96 msec 212 msec 72 msec
2 10.0.60.1 408 msec 1156 msec 1024 msec
3 10.0.120.2 332 msec 960 msec 732 msec
4 10.0.110.1 560 msec 896 msec 1036 msec
5 172.16.1.1 988 msec 744 msec 428 msec
6 172.16.1.2 260 msec 1456 msec 1388 msec
cus1.pop2#


*************************
Provider Domain MPLS TE
************************
core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2557 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 922 seconds
Periodic auto-bw collection: every 300 seconds, next in 157 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.11.1 - Se1/3 up/up
core1.pop1_t65337 10.0.3.1 - Se1/0 up/up
core1.pop1_t65436 10.0.3.1 - Se1/3 up/up
core1.pop1_t65437 10.0.11.1 - Se1/0 up/up
core1.pop2_t65337 10.0.2.1 Se1/0 - up/up

core1.pop2_t65436 10.0.2.1 Se1/3 - up/up

core1.pop2_t65437 10.0.11.1 Se1/0 Se1/3 up/up

core2.pop1_t65336 10.0.2.1 Se1/3 - up/up

core2.pop1_t65436 10.0.2.1 Se1/0 - up/up

core2.pop1_t65437 10.0.3.1 Se1/3 Se1/0 up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop1#
core1.pop1#

core1.pop1#sh ip rsvp fast-reroute
P2P Protect BW Backup
Protected LSP I/F BPS:Type Tunnel:Label State Level Type
------------- ------- -------- ------------- ------ ----- ------
core1.pop1_t65337 Se1/0 0:G Tu65436:0 Ready any-unl Nhop
core1.pop1_t65336 Se1/3 0:G Tu65437:0 Ready any-unl Nhop

P2MP
*Protected Sub-LSP Protect BW Backup
src_lspid[subid]->dst_tunid I/F BPS:Type Tunnel:Label State
--------------------------- ------- -------- ------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
core1.pop1#

core2.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 637 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 7 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 2197 seconds
Periodic auto-bw collection: every 300 seconds, next in 37 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core2.pop1_t65336 10.0.2.1 - Se1/0 up/up
core2.pop1_t65337 10.0.3.1 - Se1/1 up/up
core2.pop1_t65436 10.0.2.1 - Se1/1 up/up
core2.pop1_t65437 10.0.3.1 - Se1/0 up/up
core1.pop1_t65336 10.0.11.1 Se1/0 - up/up

core1.pop1_t65436 10.0.3.1 Se1/0 Se1/1 up/up

core1.pop1_t65437 10.0.11.1 Se1/1 - up/up

core1.pop2_t65336 10.0.11.1 Se1/1 - up/up

core1.pop2_t65436 10.0.2.1 Se1/1 Se1/0 up/up

core1.pop2_t65437 10.0.11.1 Se1/0 - up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core2.pop1#
core2.pop1#

core2.pop1#sh ip rsvp fast-reroute
P2P Protect BW Backup
Protected LSP I/F BPS:Type Tunnel:Label State Level Type
------------- ------- -------- ------------- ------ ----- ------
core2.pop1_t65336 Se1/0 0:G Tu65436:0 Ready any-unl Nhop
core2.pop1_t65337 Se1/1 0:G Tu65437:0 Ready any-unl Nhop

P2MP
*Protected Sub-LSP Protect BW Backup
src_lspid[subid]->dst_tunid I/F BPS:Type Tunnel:Label State
--------------------------- ------- -------- ------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
core2.pop1#

core1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2395 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 864 seconds
Periodic auto-bw collection: every 300 seconds, next in 295 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop2_t65336 10.0.11.1 - Se1/3 up/up
core1.pop2_t65337 10.0.2.1 - Se1/0 up/up
core1.pop2_t65436 10.0.2.1 - Se1/3 up/up
core1.pop2_t65437 10.0.11.1 - Se1/0 up/up
core1.pop1_t65337 10.0.3.1 Se1/0 - up/up

core1.pop1_t65436 10.0.3.1 Se1/3 - up/up

core1.pop1_t65437 10.0.11.1 Se1/0 Se1/3 up/up

core2.pop1_t65337 10.0.3.1 Se1/3 - up/up

core2.pop1_t65436 10.0.2.1 Se1/3 Se1/0 up/up

core2.pop1_t65437 10.0.3.1 Se1/0 - up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop2#
core1.pop2#

core1.pop2#sh ip rsvp fast-reroute
P2P Protect BW Backup
Protected LSP I/F BPS:Type Tunnel:Label State Level Type
------------- ------- -------- ------------- ------ ----- ------
core1.pop2_t65337 Se1/0 0:G Tu65436:0 Ready any-unl Nhop
core1.pop2_t65336 Se1/3 0:G Tu65437:0 Ready any-unl Nhop

P2MP
*Protected Sub-LSP Protect BW Backup
src_lspid[subid]->dst_tunid I/F BPS:Type Tunnel:Label State
--------------------------- ------- -------- ------------- ------

* Sub-LSP identifier format: _[SubgroupID]->_
Note: Sub-LSP identifier may be truncated.
Use 'detail' display for the complete key.
core1.pop2#



************************
Customer Domain Routing
***********************

cus1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O E2 172.16.251.0/24 [110/1] via 172.16.1.1, 00:15:25, Serial1/0
O IA 172.16.201.1/32 [110/129] via 172.16.1.1, 00:15:30, Serial1/0
C 172.16.1.0/30 is directly connected, Serial1/0
O IA 172.16.2.0/30 [110/65] via 172.16.1.1, 00:15:30, Serial1/0
C 172.16.101.0/24 is directly connected, Loopback0
D 192.168.201.0/24 [90/2297856] via 192.168.1.2, 00:06:13, Serial1/1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/1
C 192.168.101.0/24 is directly connected, Loopback1
cus1.pop1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
172.16.151.1 0 FULL/ - 00:00:31 172.16.1.1 Serial1/0
cus1.pop1#sh ip eig nei
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.2 Se1/1 14 00:06:25 909 5000 0 8
cus1.pop1#

cus1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O E2 172.16.151.0/24 [110/1] via 172.16.2.1, 00:16:08, Serial1/0
C 172.16.201.0/24 is directly connected, Loopback0
O IA 172.16.1.0/30 [110/65] via 172.16.2.1, 00:16:08, Serial1/0
C 172.16.2.0/30 is directly connected, Serial1/0
O IA 172.16.101.1/32 [110/129] via 172.16.2.1, 00:16:08, Serial1/0
C 192.168.201.0/24 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/1
D 192.168.101.0/24 [90/2297856] via 192.168.1.1, 00:06:45, Serial1/1
cus1.pop2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
172.16.251.1 0 FULL/ - 00:00:34 172.16.2.1 Serial1/0
cus1.pop2#sh ip eig nei
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.1 Se1/1 14 00:06:56 427 2562 0 5
cus1.pop2#



****************************
DURING FAILOVER
*****************************

core1.pop1#show mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial1/0 Yes Yes No No No
Serial1/2 Yes (ldp) No No No Yes
Serial1/3 Yes (ldp) Yes No No Yes
Tunnel65437 No No No No No
Tunnel65336 Yes No No No Yes
Tunnel65436 No No No No Yes
Tunnel65337 Yes No No No Yes
core1.pop1#

core1.pop2#show mpls interfaces
Interface IP Tunnel BGP Static Operational
Serial1/0 Yes Yes No No No
Serial1/2 Yes (ldp) No No No Yes
Serial1/3 Yes (ldp) Yes No No Yes
Tunnel65436 No No No No Yes
Tunnel65337 Yes No No No Yes
Tunnel65336 Yes No No No Yes
Tunnel65437 No No No No No
core1.pop2#


cus1.pop1#ping 172.16.201.1 repeat 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.201.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...................
.......!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.
Success rate is 91 percent (290/317), round-trip min/avg/max = 28/453/1576 ms

cus1.pop2#ping 192.168.101.1 repeat 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 192.168.101.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!...............................!!!!!!!!!!!!!!!!!.
Success rate is 52 percent (35/67), round-trip min/avg/max = 116/608/1392 ms
cus1.pop2#

*********************
BEFORE S1/0 LINK FAILS
*********************

cus1.pop1#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.1.1 108 msec 44 msec 196 msec
2 10.0.70.1 344 msec 472 msec 432 msec
3 10.0.20.2 508 msec 408 msec 472 msec
4 172.16.2.1 384 msec 264 msec 304 msec
5 172.16.2.2 212 msec * 536 msec
cus1.pop1#


core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 751 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 3 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 2715 seconds
Periodic auto-bw collection: every 300 seconds, next in 151 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.11.1 - Se1/3 up/up
core1.pop1_t65337 10.0.3.1 - Se1/0 up/up

core1.pop1#show mpls traffic-eng tunnels Tu65337

Name: core1.pop1_t65337 (Tunnel65337) Destination: 10.0.3.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65337 (Basis for Setup, path we
ight 10)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/0, implicit-null
Next Hop : 10.0.20.2
FRR OutLabel : Tunnel65436, explicit-null
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.3.1, Tun_Id 65337, Tun_Instance 99
RSVP Path Info:
My Address: 10.0.20.1
Explicit Route: 10.0.20.2 10.0.3.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 10.0.3.1(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 10 (TE)
Explicit Route: 10.0.20.2 10.0.3.1
History:
Tunnel:
Time since created: 15 minutes, 12 seconds
Time since path change: 15 minutes, 11 seconds
Number of LSP IDs (Tun_Instances) used: 23
Current LSP: [ID: 99]
Uptime: 4 minutes, 45 seconds
Selection: reoptimization
Prior LSP: [ID: 77]
ID: path option 1 [77]
Removal Trigger: re-route path error
Last Error: RSVP:: Path Error from 10.0.2.1: Notify: Tunnel locally repair
ed (flags 0)
core1.pop1#
core1.pop1#

core1.pop1#show mpls traffic-eng tunnels Tu65436

Name: core1.pop1_t65436 (Tunnel65436) Destination: 10.0.3.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65436 (Basis for Setup, path we
ight 20)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: disabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/3, 29
Next Hop : 10.0.110.2
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.3.1, Tun_Id 65436, Tun_Instance 102
RSVP Path Info:
My Address: 10.0.110.1
Explicit Route: 10.0.110.2 10.0.120.1 10.0.3.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 10 (TE)
Explicit Route: 10.0.20.2 10.0.3.1
History:
Tunnel:
Time since created: 2 hours, 25 minutes
Time since path change: 59 minutes, 6 seconds
Number of LSP IDs (Tun_Instances) used: 102
Current LSP: [ID: 102]
Uptime: 59 minutes, 6 seconds
Prior LSP: [ID: 97]
ID: path option unknown
Removal Trigger: signalling shutdown
core1.pop1#
core1.pop1#

core1.pop1#sh ip rsvp fast-reroute
P2P Protect BW Backup
Protected LSP I/F BPS:Type Tunnel:Label State Level Type
------------- ------- -------- ------------- ------ ----- ------
core1.pop1_t65337 Se1/0 0:G Tu65436:0 Ready any-unl Nhop
core1.pop1_t65336 Se1/3 0:G Tu65437:0 Ready any-unl Nhop

core1.pop1#show mpls forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 [T] 27 10.0.4.1/32 868 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#

*********************
AFTER S1/0 LINK FAILS
*********************


core1.pop1#show mpls forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 [T] No Label 10.0.4.1/32 67 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#show mpls forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 [T] No Label 10.0.4.1/32 67 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#show mpls forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 [T] No Label 10.0.4.1/32 115 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#
core1.pop1#show mpls
forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
26 [T] 27 10.0.4.1/32 1276 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#show mpls traffic-eng tunnels Tu65337


core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 151 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 4 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 2116 seconds
Periodic auto-bw collection: every 300 seconds, next in 151 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.11.1 - Se1/3 up/up
core1.pop1_t65337 10.0.3.1 - Se1/0 up/up

core1.pop1#show mpls traffic-eng tunnels Tu65337

Name: core1.pop1_t65337 (Tunnel65337) Destination: 10.0.3.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65337 (Basis for Setup, path we
ight 10)
Change in required resources detected: reroute pending
Currently Signalled Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFF
FF
Metric Type: TE (default)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/0, implicit-null
Next Hop : 10.0.20.2
FRR OutLabel : Tunnel65436, explicit-null (in use)
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.3.1, Tun_Id 65337, Tun_Instance 99
RSVP Path Info:
My Address: 10.0.20.1
Explicit Route: 10.0.3.1 10.0.3.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 10.0.3.1(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 20 (TE)
Explicit Route: 10.0.110.2 10.0.120.1 10.0.3.1
History:
Tunnel:
Time since created: 24 minutes, 52 seconds
Time since path change: 24 minutes, 51 seconds
Number of LSP IDs (Tun_Instances) used: 30
Current LSP: [ID: 99]
Uptime: 14 minutes, 25 seconds
Selection: reoptimization
Prior LSP: [ID: 77]
ID: path option 1 [99]
Removal Trigger: re-route path error
Last Error: RSVP:: Path Error from 10.0.2.1: Notify: Tunnel locally repair
ed (flags 0)
core1.pop1#
core1.pop1#
core1.pop1#

cus1.pop1#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.1.1 168 msec 48 msec 80 msec
2 10.0.70.1 500 msec 476 msec 384 msec
3 10.0.110.2 524 msec 300 msec 228 msec
4 10.0.120.1 332 msec 292 msec 468 msec
5 172.16.2.1 552 msec 260 msec 188 msec
6 172.16.2.2 496 msec * 400 msec
cus1.pop1#

******************************************************


cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.2.1 140 msec 160 msec 232 msec
2 10.0.60.1 448 msec 708 msec 340 msec
3 10.0.120.2 256 msec 700 msec 408 msec
4 10.0.110.1 616 msec 208 msec 540 msec
5 172.16.1.1 468 msec 256 msec 528 msec
6 172.16.1.2 852 msec 420 msec *
cus1.pop2#

core1.pop2#show mpls forwarding-table 10.0.8.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
20 [T] 23 10.0.8.1/32 13695 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 42 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 2111 seconds
Periodic auto-bw collection: every 300 seconds, next in 42 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop2_t65336 10.0.11.1 - Se1/3 up/up
core1.pop2_t65337 10.0.2.1 - Se1/0 up/up

core1.pop2#show mpls traffic-eng tunnels Tu65337

Name: core1.pop2_t65337 (Tunnel65337) Destination: 10.0.2.1
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit __dynamic_tunnel65337 (Basis for Setup, path we
ight 10)
Change in required resources detected: reroute pending
Currently Signalled Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFF
FF
Metric Type: TE (default)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 7 7 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute announce: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
Active Path Option Parameters:
State: explicit path option 1 is active
BandwidthOverride: disabled LockDown: disabled Verbatim: disabled


InLabel : -
OutLabel : Serial1/0, implicit-null
Next Hop : 10.0.20.1
FRR OutLabel : Tunnel65436, explicit-null (in use)
RSVP Signalling Info:
Src 10.0.3.1, Dst 10.0.2.1, Tun_Id 65337, Tun_Instance 177
RSVP Path Info:
My Address: 10.0.20.2
Explicit Route: 10.0.2.1 10.0.2.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 10.0.2.1(0)
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 20 (TE)
Explicit Route: 10.0.120.2 10.0.110.1 10.0.2.1
History:
Tunnel:
Time since created: 24 minutes, 56 seconds
Time since path change: 24 minutes, 54 seconds
Number of LSP IDs (Tun_Instances) used: 32
Current LSP: [ID: 177]
Uptime: 14 minutes, 40 seconds
Selection: reoptimization
Prior LSP: [ID: 154]
ID: path option 1 [177]
Removal Trigger: re-route path verification failed
Last Error: RSVP:: Path Error from 10.0.3.1: Notify: Tunnel locally repair
ed (flags 0)
core1.pop2#

No comments:

Post a Comment