Friday, May 7, 2010

Implementing Hub & Spoke MPLS L3 VPN LAB















Configuration Guidelines
******************************************************
Scenario- An ISP is offering L3 MPLS VPN Services to
his Customers and Customer wants to have a Hub & Spoke
Connectivity across the MPLS VPN Services offered such
that Hub Site can talk to every Spoke and few spokes
can directly talk to each other while other spokes
can talk to the spokes via the Hub

Design Consideration:

To Provision Hub & Spoke L3 MPLS VPN, ISP Needs to make use
of the RT and Customer needs to send default route to Spokes.

ISP will need to use differnt Export RT for each Spoke
and those will be imported onto Hub. Hub will use separate
Export RT which will be only imported on each Spoke.
Any two Spokes who want to talk directly will need to
import each others respective export RTs to bypass Hub.
The Spoke which just needs communication via Hub to every other
Spoke will import the Hub's Export RT.

So all together RTs provide us the required communication
along with the default route being sent from Hub to Spokes

Hub talks to Spoke A,B,C
Spoke A talks directly to Spoke B
Spoke C talks to veryone via Hub

ISP AS used 64513
IGP used OSPF Area 0
VRF used cus1
rd used 64513:1

RTs Used

Hub:
Export RT 64513:101
Import RT 64513:102 64513:103 64513:104

Spoke A
Export RT 64513:102
Import RT 64513:101
Import RT 64513:103

Spoke B
Export RT 64513:103
Import RT 64513:101
Import RT 64513:102

Spoke C
Export RT 64513:103
Import RT 64513:101


******************************************************

cus1.pop1#sh running-config
Building configuration...

Current configuration : 977 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
!
interface FastEthernet0/0
description edge1.pop1-MPLS_L3_VPN
ip address 172.16.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.101.0 mask 255.255.255.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 default-originate
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop1#

cus1.pop3#sh running-config
Building configuration...

Current configuration : 938 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.103.1 255.255.255.0
!
interface FastEthernet0/0
description edge1.pop1-MPLS_L3_VPN
ip address 172.16.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.103.1
bgp log-neighbor-changes
network 172.16.103.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 64513
neighbor 172.16.3.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop3#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 2596 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:101
route-target import 64513:101
route-target import 64513:102
route-target import 64513:103
route-target import 64513:104
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
description cus1.pop1
ip vrf forwarding cus1
ip address 172.16.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop2
ip address 10.0.12.1 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop3
ip address 10.0.13.1 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
description edge1.pop4
ip address 10.0.14.1 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.2.1 peer-group MP-iBGP
neighbor 10.0.3.1 peer-group MP-iBGP
neighbor 10.0.4.1 peer-group MP-iBGP
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor MP-iBGP next-hop-self
neighbor 10.0.2.1 activate
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 as-override
neighbor 172.16.1.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

edge1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2622 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:102
route-target import 64513:101
route-target import 64513:103
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding cus1
ip address 172.16.102.1 255.255.255.0
!
interface FastEthernet0/0
description cus1.pop2
ip vrf forwarding cus1
ip address 172.16.2.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop1
ip address 10.0.12.2 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop4
ip address 10.0.24.1 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
description edge1.pop3
ip address 10.0.23.1 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group MP-iBGP
neighbor 10.0.3.1 peer-group MP-iBGP
neighbor 10.0.4.1 peer-group MP-iBGP
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor MP-iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.2.2 remote-as 64514
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 as-override
neighbor 172.16.2.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

edge1.pop2#

edge1.pop3#sh running-config
Building configuration...

Current configuration : 2537 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:103
route-target import 64513:101
route-target import 64513:102
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
description cus1.pop3
ip vrf forwarding cus1
ip address 172.16.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop4
ip address 10.0.34.1 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop1
ip address 10.0.13.2 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
description edge1.pop2
ip address 10.0.23.2 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group MP-iBGP
neighbor 10.0.2.1 peer-group MP-iBGP
neighbor 10.0.4.1 peer-group MP-iBGP
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor MP-iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.3.2 remote-as 64514
neighbor 172.16.3.2 activate
neighbor 172.16.3.2 as-override
neighbor 172.16.3.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

edge1.pop3#

edge1.pop4#sh running-config
Building configuration...

Current configuration : 2591 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop4
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf cus1
rd 64513:1
route-target export 64513:104
route-target import 64513:101
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface Loopback1
ip vrf forwarding cus1
ip address 172.16.104.1 255.255.255.0
!
interface FastEthernet0/0
description cus1.pop4
ip vrf forwarding cus1
ip address 172.16.4.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop3
ip address 10.0.34.2 255.255.255.252
ip ospf authentication-key 7 070C285F4D06
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description edge1.pop2
ip address 10.0.24.2 255.255.255.252
ip ospf authentication-key 7 045802150C2E
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
description edge1.pop1
ip address 10.0.14.2 255.255.255.252
ip ospf authentication-key 7 030752180500
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
area 0 authentication message-digest
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor MP-iBGP peer-group
neighbor MP-iBGP remote-as 64513
neighbor MP-iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group MP-iBGP
neighbor 10.0.2.1 peer-group MP-iBGP
neighbor 10.0.3.1 peer-group MP-iBGP
!
address-family vpnv4
neighbor MP-iBGP send-community extended
neighbor MP-iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.2.1 activate
neighbor 10.0.3.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
redistribute connected
neighbor 172.16.4.2 remote-as 64514
neighbor 172.16.4.2 activate
neighbor 172.16.4.2 as-override
neighbor 172.16.4.2 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

edge1.pop4#

**************
OUTPUT
*************
cus1.pop1#traceroute 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 172.16.1.1 52 msec 136 msec 108 msec
2 172.16.102.1 [AS 64513] 236 msec * 216 msec
cus1.pop1#traceroute 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 172.16.1.1 212 msec 200 msec 64 msec
2 172.16.3.1 [AS 64513] 292 msec 228 msec 236 msec
3 172.16.3.2 [AS 64513] 508 msec * 296 msec
cus1.pop1#traceroute 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 172.16.1.1 132 msec 188 msec 132 msec
2 172.16.104.1 [AS 64513] 264 msec * 220 msec
cus1.pop1#

edge1.pop2#traceroute vrf cus1 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.1.1 [MPLS: Label 24 Exp 0] 12 msec 60 msec 252 msec
2 172.16.1.2 432 msec * 232 msec
edge1.pop2#traceroute vrf cus1 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 172.16.3.1 [MPLS: Label 23 Exp 0] 264 msec 252 msec 164 msec
2 172.16.3.2 188 msec * 268 msec
edge1.pop2#traceroute vrf cus1 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 172.16.1.1 [MPLS: Label 23 Exp 0] 32 msec 76 msec 136 msec
2 172.16.1.2 180 msec 228 msec 172 msec
3 172.16.1.1 296 msec 408 msec 256 msec
4 172.16.104.1 424 msec * 548 msec
edge1.pop2#

cus1.pop3#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.3.1 204 msec 92 msec 160 msec
2 172.16.1.1 [AS 64513] 64 msec 468 msec 416 msec
3 172.16.1.2 [AS 64513] 572 msec * 436 msec
cus1.pop3#traceroute 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 172.16.3.1 148 msec 224 msec 56 msec
2 172.16.102.1 [AS 64513] 164 msec * 184 msec
cus1.pop3#traceroute 172.16.104.1

Type escape sequence to abort.
Tracing the route to 172.16.104.1

1 172.16.3.1 104 msec 76 msec 180 msec
2 172.16.1.1 [AS 64513] 184 msec 288 msec 172 msec
3 172.16.1.2 [AS 64513] 632 msec 356 msec 400 msec
4 172.16.1.1 [AS 64513] 724 msec 368 msec 504 msec
5 172.16.104.1 [AS 64513] 456 msec * 552 msec
cus1.pop3#

edge1.pop4#traceroute vrf cus1 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.1.1 [MPLS: Label 24 Exp 0] 240 msec 200 msec 76 msec
2 172.16.1.2 204 msec * 260 msec
edge1.pop4#traceroute vrf cus1 172.16.102.1

Type escape sequence to abort.
Tracing the route to 172.16.102.1

1 172.16.1.1 [MPLS: Label 23 Exp 0] 108 msec 176 msec 40 msec
2 172.16.1.2 136 msec 176 msec 188 msec
3 172.16.1.1 272 msec 320 msec 136 msec
4 172.16.102.1 236 msec 640 msec *
edge1.pop4#traceroute vrf cus1 172.16.103.1

Type escape sequence to abort.
Tracing the route to 172.16.103.1

1 172.16.1.1 [MPLS: Label 23 Exp 0] 304 msec 240 msec 104 msec
2 172.16.1.2 288 msec 268 msec 348 msec
3 172.16.1.1 340 msec 208 msec 192 msec
4 172.16.3.1 [MPLS: Label 23 Exp 0] 416 msec 316 msec 384 msec
5 172.16.3.2 464 msec * 616 msec
edge1.pop4#

edge1.pop1#sh ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.2 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
B 172.16.4.0/30 [200/0] via 10.0.4.1, 00:11:45
C 172.16.1.0/30 is directly connected, FastEthernet0/0
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:14:16
B 172.16.3.0/30 [200/0] via 10.0.3.1, 00:13:01
B 172.16.104.0/24 [200/0] via 10.0.4.1, 00:06:45
B 172.16.101.0/24 [20/0] via 172.16.1.2, 00:09:38
B 172.16.102.0/24 [200/0] via 10.0.2.1, 00:06:31
B 172.16.103.0/24 [200/0] via 10.0.3.1, 00:06:00
B* 0.0.0.0/0 [20/0] via 172.16.1.2, 00:09:45
edge1.pop1#

edge1.pop2#sh ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.1.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:14:42
C 172.16.2.0/30 is directly connected, FastEthernet0/0
B 172.16.3.0/30 [200/0] via 10.0.3.1, 00:13:12
B 172.16.101.0/24 [200/0] via 10.0.1.1, 00:09:42
C 172.16.102.0/24 is directly connected, Loopback1
B 172.16.103.0/24 [200/0] via 10.0.3.1, 00:06:27
B* 0.0.0.0/0 [200/0] via 10.0.1.1, 00:09:57
edge1.pop2#

edge1.pop3#sh ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.1.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:13:26
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:13:26
C 172.16.3.0/30 is directly connected, FastEthernet0/0
B 172.16.101.0/24 [200/0] via 10.0.1.1, 00:09:56
B 172.16.102.0/24 [200/0] via 10.0.2.1, 00:06:56
B 172.16.103.0/24 [20/0] via 172.16.3.2, 00:06:42
B* 0.0.0.0/0 [200/0] via 10.0.1.1, 00:10:11
edge1.pop3#

edge1.pop4#sh ip route vrf cus1

Routing Table: cus1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.1.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.4.0/30 is directly connected, FastEthernet0/0
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:12:41
C 172.16.104.0/24 is directly connected, Loopback1
B 172.16.101.0/24 [200/0] via 10.0.1.1, 00:10:11
B* 0.0.0.0/0 [200/0] via 10.0.1.1, 00:10:26
edge1.pop4#

cus1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
B 172.16.4.0/30 [20/0] via 172.16.1.1, 00:10:45
C 172.16.1.0/30 is directly connected, FastEthernet0/0
B 172.16.2.0/30 [20/0] via 172.16.1.1, 00:10:45
B 172.16.3.0/30 [20/0] via 172.16.1.1, 00:10:45
B 172.16.104.0/24 [20/0] via 172.16.1.1, 00:07:45
C 172.16.101.0/24 is directly connected, Loopback0
B 172.16.102.0/24 [20/0] via 172.16.1.1, 00:07:30
B 172.16.103.0/24 [20/0] via 172.16.1.1, 00:07:00
cus1.pop1#

cus1.pop3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.3.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
B 172.16.1.0/30 [20/0] via 172.16.3.1, 00:07:25
B 172.16.2.0/30 [20/0] via 172.16.3.1, 00:07:25
C 172.16.3.0/30 is directly connected, FastEthernet0/0
B 172.16.101.0/24 [20/0] via 172.16.3.1, 00:07:25
B 172.16.102.0/24 [20/0] via 172.16.3.1, 00:07:25
C 172.16.103.0/24 is directly connected, Loopback0
B* 0.0.0.0/0 [20/0] via 172.16.3.1, 00:07:25
cus1.pop3#

No comments:

Post a Comment