Tuesday, February 23, 2010

Implementing IPv6 VRF-Lite IPv6 VPN LAB
















Confgiguration Guidelines
*************************************************************************

Scenario - ISP having no MPLS Backbone Providing IPv6 VPN Services to IPv6 Customers
using VRF Lite and Having IPv4 Backbone.


Design Considerations and Soultions: To Provide IPv6 VPN Services across IPv4
Backbone we need to assign Customer Peering Interfaces to the VRFs and then establishing
a Tunnel Between PEs per VRF (Per Customer). This Tunnel will be placed in the Customer VRF
and an IPv6 VRF BGP Peering will be established between PEs to transport Customer IPv6 Routes
across PEs.

Caveats: This design will suffer from n*(n-1)/2 scalabiltiy issue as multiple tunnels between PEs
will need to be established for Full Mesh Connectivity when large number of PEs involved.

ISP AS used 64513 -
VRF USed CEA
rd 64513:1
rt 64513:100

IGP in ISP AS is ISIS

Customer AS used 64514
PE-CE ROuting Protocol is EBGP
****************************************************************************


CE1A#sh running-config
Building configuration...

Current configuration : 1795 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
ipv6 cef
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ipv6 address 2001:810:FFFF:1::2/64
frame-relay interface-dlci 201
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
bgp router-id 172.16.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 allowas-in 5
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0.1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE1A#


CE2A#sh running-config
Building configuration...

Current configuration : 1714 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
ipv6 cef
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ipv6 address 2001:1210:FFFF:1::2/64
frame-relay interface-dlci 501
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
bgp router-id 172.16.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0.1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE2A#


CE3A#sh running-config
Building configuration...

Current configuration : 1758 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
no ip address
ipv6 address FEC0:0:0:3::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ipv6 address 2001:410:FFFF:1::2/64
frame-relay interface-dlci 601
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
bgp router-id 172.16.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:410:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:410:FFFF:1::1 activate
neighbor 2001:410:FFFF:1::1 send-community extended
neighbor 2001:410:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
!
!
!
ipv6 route ::/0 Serial1/0.1 2001:410:FFFF:1::1
!
route-map Local permit 10
match interface Loopback0 Serial1/0.1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE3A#


PE1#sh running-config
Building configuration...

Current configuration : 2675 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
frame-relay switching
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
vrf forwarding CEA
no ip address
ipv6 address 2001:1610:FFFF:1::1/64
tunnel source Loopback0
tunnel destination 10.0.3.1
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
vrf forwarding CEA
ipv6 address 2001:810:FFFF:1::1/64
frame-relay interface-dlci 102
!
interface Serial1/1
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial1/1.1 point-to-point
ip address 10.0.10.1 255.255.255.252
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 301
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::2 remote-as 64514
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 next-hop-self
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1610:FFFF:1::2 remote-as 64513
neighbor 2001:1610:FFFF:1::2 activate
neighbor 2001:1610:FFFF:1::2 next-hop-self
neighbor 2001:1610:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

PE1#


P#sh running-config
Building configuration...

Current configuration : 1480 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
no dce-terminal-timing-enable
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ip address 10.0.10.2 255.255.255.252
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 103
!
interface Serial1/0.2 point-to-point
ip address 10.0.20.2 255.255.255.252
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 104
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router isis
net 49.0002.2222.3333.1111.00
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

P#

PE2#sh running-config
Building configuration...

Current configuration : 3116 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
frame-relay switching
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
vrf forwarding CEA
no ip address
ipv6 address 2001:1610:FFFF:1::2/64
tunnel source Loopback0
tunnel destination 10.0.1.1
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial1/0.1 point-to-point
ip address 10.0.20.1 255.255.255.252
ip router isis
isis circuit-type level-2-only
frame-relay interface-dlci 401
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type ansi
!
interface Serial1/1.1 point-to-point
vrf forwarding CEA
ipv6 address 2001:1210:FFFF:1::1/64
frame-relay interface-dlci 105
!
interface Serial1/1.2 point-to-point
vrf forwarding CEA
ipv6 address 2001:410:FFFF:1::1/64
frame-relay interface-dlci 106
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.3333.1111.2222.00
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1610:FFFF:1::1 remote-as 64513
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:410:FFFF:1::2 remote-as 64514
neighbor 2001:410:FFFF:1::2 activate
neighbor 2001:410:FFFF:1::2 default-originate
neighbor 2001:410:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 next-hop-self
neighbor 2001:1210:FFFF:1::2 as-override
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1610:FFFF:1::1 remote-as 64513
neighbor 2001:1610:FFFF:1::1 activate
neighbor 2001:1610:FFFF:1::1 next-hop-self
neighbor 2001:1610:FFFF:1::1 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

PE2#


*************************************************************
OUTPUT
*************************************************************

CE1A#ping ipv6 FEC0:0:0:2::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
!...!
Success rate is 40 percent (2/5), round-trip min/avg/max = 512/520/528 ms
CE1A#ping ipv6 FEC0:0:0:3::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:3::1, timeout is 2 seconds:
..!..
Success rate is 20 percent (1/5), round-trip min/avg/max = 360/360/360 ms
CE1A#

CE2A#ping ipv6 FEC0:0:0:1::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!..!.
Success rate is 40 percent (2/5), round-trip min/avg/max = 488/526/564 ms
CE2A#ping ipv6 FEC0:0:0:3::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:3::1, timeout is 2 seconds:
!..!.
Success rate is 40 percent (2/5), round-trip min/avg/max = 308/314/320 ms
CE2A#

CE3A#ping ipv6 FEC0:0:0:1::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!...!
Success rate is 40 percent (2/5), round-trip min/avg/max = 476/596/716 ms
CE3A#ping ipv6 FEC0:0:0:2::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
.!...
Success rate is 20 percent (1/5), round-trip min/avg/max = 448/448/448 ms
CE3A#


CE1A#traceroute ipv6 FEC0:0:0:2::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1

1 2001:810:FFFF:1::1 84 msec 196 msec 108 msec
2 2001:1610:FFFF:1::2 336 msec * 252 msec
3 *
FEC0:0:0:2::1 376 msec *
CE1A#


CE1A#traceroute ipv6 FEC0:0:0:3::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:3::1

1 2001:810:FFFF:1::1 280 msec 8 msec 232 msec
2 2001:1610:FFFF:1::2 620 msec * 428 msec
3 *
FEC0:0:0:3::1 1268 msec *
CE1A#

CE2A#traceroute ipv6 FEC0:0:0:1::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1

1 2001:1210:FFFF:1::1 220 msec 220 msec 212 msec
2 2001:1610:FFFF:1::1 524 msec * 536 msec
3 *
FEC0:0:0:1::1 1140 msec *
CE2A#traceroute ipv6 FEC0:0:0:3::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:3::1

1 2001:1210:FFFF:1::1 460 msec 4 msec 248 msec
2 FEC0:0:0:3::1 832 msec * 328 msec
CE2A#


CE3A#traceroute ipv6 FEC0:0:0:2::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1

1 2001:410:FFFF:1::1 316 msec 344 msec 204 msec
2 FEC0:0:0:2::1 600 msec * 484 msec
CE3A#traceroute ipv6 FEC0:0:0:1::1

Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1

1 2001:410:FFFF:1::1 344 msec 284 msec 276 msec
2 2001:1610:FFFF:1::1 724 msec * 904 msec
3 *
FEC0:0:0:1::1 1024 msec *
CE3A#
CE1A#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:410:FFFF:1::/64 [20/0]
via FE80::C802:AFF:FE48:0, Serial1/0.1
C 2001:810:FFFF:1::/64 [0/0]
via ::, Serial1/0.1
L 2001:810:FFFF:1::2/128 [0/0]
via ::, Serial1/0.1
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C802:AFF:FE48:0, Serial1/0.1
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:2::1/128 [20/0]
via FE80::C802:AFF:FE48:0, Serial1/0.1
B FEC0:0:0:3::1/128 [20/0]
via FE80::C802:AFF:FE48:0, Serial1/0.1
L FF00::/8 [0/0]
via ::, Null0
CE1A#


CE2A#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:410:FFFF:1::/64 [20/0]
via FE80::C803:AFF:FE48:0, Serial1/0.1
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C803:AFF:FE48:0, Serial1/0.1
C 2001:1210:FFFF:1::/64 [0/0]
via ::, Serial1/0.1
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, Serial1/0.1
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [20/0]
via FE80::C803:AFF:FE48:0, Serial1/0.1
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:3::1/128 [20/0]
via FE80::C803:AFF:FE48:0, Serial1/0.1
L FF00::/8 [0/0]
via ::, Null0
CE2A#

PE2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
i L2 10.0.1.1/32 [115/30] via 10.0.20.2, Serial1/0.1
i L2 10.0.2.1/32 [115/20] via 10.0.20.2, Serial1/0.1
C 10.0.3.1/32 is directly connected, Loopback0
i L2 10.0.10.0/30 [115/20] via 10.0.20.2, Serial1/0.1
C 10.0.20.0/30 is directly connected, Serial1/0.1
L 10.0.20.1/32 is directly connected, Serial1/0.1
PE2#

PE2#show bgp vrf CEA all summary
For address family: VPNv6 Unicast
BGP router identifier 10.0.2.1, local AS number 64513
BGP table version is 11, main routing table version 11
6 network entries using 990 bytes of memory
12 path entries using 1152 bytes of memory
5/2 BGP path/bestpath attribute entries using 380 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2570 total bytes of memory
6 received paths for inbound soft reconfiguration
BGP activity 6/0 prefixes, 14/2 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:410:FFFF:1::2
4 64514 20 24 11 0 0 00:15:34 2
2001:1210:FFFF:1::2
4 64514 45 48 11 0 0 00:38:40 2
2001:1610:FFFF:1::1
4 64513 32 32 11 0 0 00:23:27 2
PE2#


PE1#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:410:FFFF:1::/64 [200/0]
via 2001:1610:FFFF:1::2
C 2001:810:FFFF:1::/64 [0/0]
via Serial1/0.1, directly connected
L 2001:810:FFFF:1::1/128 [0/0]
via Serial1/0.1, receive
B 2001:1210:FFFF:1::/64 [200/0]
via 2001:1610:FFFF:1::2
C 2001:1610:FFFF:1::/64 [0/0]
via Tunnel100, directly connected
L 2001:1610:FFFF:1::1/128 [0/0]
via Tunnel100, receive
B FEC0:0:0:1::1/128 [20/0]
via FE80::CE05:7FF:FEA4:0, Serial1/0.1
B [200/0]
via 2001:1610:FFFF:1::2
B FEC0:0:0:3::1/128 [200/0]
via 2001:1610:FFFF:1::2
L FF00::/8 [0/0]
via Null0, receive
PE1#

Implementing Internet Access in Carrier Supporting Carrier MPLS L3 VPN LAB















Confgiguration Guidelines
*************************************************************************

Scenario - Providing Carrier Internet Access to Customer Carrier in Carrier
Supporting Carrier Multicast MPLS L3 VPN Services Both Customer Carrier
and Customer Carrier running MPLS


Design Considerations and Soultions: To Provide Internet Access in CSC MPLS VPN
Services we are considering Option Making Customer Carrier a MPLS
VPN Customer for Parent Carrier and Using Route Leaking with VRF Aware NAT at
the Internet PE in Parent Carrier and VRF Aware NAT at the Local PE in Customer Carrier



ISP A AS used 64514 - Parent carrier
ISP 2 AS used 64513 - Customer Carrier
IGP in ISPA is ISIS

****************************************************************************


CE1A#sh running-config
Building configuration...

Current configuration : 844 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
no ftp-server write-enable
!
!
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.252
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 172.16.100.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.3 area 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

CE1A#


CE2A#sh running-config
Building configuration...

Current configuration : 844 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
no ftp-server write-enable
!
!
!
!
interface Loopback0
ip address 172.16.200.1 255.255.255.252
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 172.16.200.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.3 area 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end

CE2A#
CE2A#
CE2A#


ISPB_PE1#sh running-config
Building configuration...

Current configuration : 2217 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPB_PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
half-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip vrf forwarding CEA
ip address 192.168.1.1 255.255.255.252
ip nat inside
ip virtual-reassembly
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 192.168.3.1 255.255.255.252
ip nat outside
ip virtual-reassembly
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 20 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
default-information originate always
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute static
redistribute ospf 20 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
ip route 0.0.0.0 0.0.0.0 Serial1/1
ip route vrf CEA 0.0.0.0 0.0.0.0 192.168.3.2 global
!
!
ip nat inside source list 10 interface Serial1/1 vrf CEA overload
!
access-list 10 deny 10.0.1.1
access-list 10 permit any
!
!
!
!
control-plane
!
!
!
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ISPB_PE1#


ISPB_PE2#sh running-config
Building configuration...

Current configuration : 2012 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPB_PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
half-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.4.1 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip vrf forwarding CEA
ip address 192.168.2.1 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 20 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.2.0 0.0.0.3 area 0
!
router ospf 10
log-adjacency-changes
redistribute bgp 64513 subnets
network 10.0.2.1 0.0.0.0 area 0
network 192.168.4.0 0.0.0.3 area 0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 20 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ISPB_PE2#
ISPB_PE2#
ISPB_PE2#

ISPA_PE1#sh running-config
Building configuration...

Current configuration : 2495 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPA_PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.10.1 255.255.255.255
ip router isis
ip nat outside
ip virtual-reassembly
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
half-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip vrf forwarding CEA
ip address 192.168.3.2 255.255.255.252
ip nat inside
ip virtual-reassembly
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
ip address 172.16.20.2 255.255.255.252
ip nat outside
ip virtual-reassembly
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
ip address 172.16.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute isis level-1-2
network 172.16.20.0 0.0.0.3
auto-summary
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 192.168.3.0 0.0.0.3 area 0
default-information originate always
!
router isis
net 49.0001.1111.2222.3333.00
redistribute eigrp 100
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 172.16.20.1 remote-as 64514
neighbor 172.16.20.1 update-source Loopback0
!
address-family vpnv4
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute static
redistribute ospf 10 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
ip route vrf CEA 0.0.0.0 0.0.0.0 172.16.20.1 global
!
!
ip nat inside source list 10 interface Serial1/1 vrf CEA overload
!
access-list 10 deny 172.16.10.1
access-list 10 permit any
!
!
!
!
control-plane
!
!
!
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
login
!
!
end

ISPA_PE1#
ISPA_PE1#


ISPA_PE2#sh running-config
Building configuration...

Current configuration : 2024 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPA_PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.20.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
half-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/1
ip vrf forwarding CEA
ip address 192.168.4.2 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 192.168.4.0 0.0.0.3 area 0
!
router isis
net 49.0002.2222.3333.4444.00
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 172.16.10.1 remote-as 64514
neighbor 172.16.10.1 update-source Loopback0
!
address-family vpnv4
neighbor 172.16.10.1 activate
neighbor 172.16.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
no synchronization
exit-address-family
!
no ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ISPA_PE2#


Internet#sh running-config
Building configuration...

Current configuration : 1300 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.154.1 255.255.255.0
!
interface Loopback1
ip address 172.16.254.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 172.16.20.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected route-map Local
network 172.16.20.0 0.0.0.3
auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 Loopback1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Internet#
Internet#
Internet#
Internet#

*********************************************************

OUTPUT

*********************************************************

CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.100.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.1.1, 00:07:36, Serial0/0
CE1A#

ISPB_PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.3.2 to network 0.0.0.0

172.16.0.0/32 is subnetted, 1 subnets
O 172.16.100.1 [110/65] via 192.168.1.2, 00:23:32, Serial1/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial1/0
S* 0.0.0.0/0 [1/0] via 192.168.3.2
ISPB_PE1#


ISPA_PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.20.1 to network 0.0.0.0

192.168.3.0/30 is subnetted, 1 subnets
C 192.168.3.0 is directly connected, Serial1/0
S* 0.0.0.0/0 [1/0] via 172.16.20.1
ISPA_PE1#
CE1A#ping 172.16.200.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 292/384/468 ms
CE1A#ping 172.16.154.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.154.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/153/260 ms
CE1A#ping 172.16.254.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.254.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/133/220 ms
CE1A#
CE1A#

ISPB_PE1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 192.168.3.1:4278 192.168.1.2:4278 172.16.154.1:4278 172.16.154.1:4278
icmp 192.168.3.1:4279 192.168.1.2:4279 172.16.154.1:4279 172.16.154.1:4279
icmp 192.168.3.1:4280 192.168.1.2:4280 172.16.154.1:4280 172.16.154.1:4280
icmp 192.168.3.1:4281 192.168.1.2:4281 172.16.154.1:4281 172.16.154.1:4281
icmp 192.168.3.1:4282 192.168.1.2:4282 172.16.154.1:4282 172.16.154.1:4282
icmp 192.168.3.1:8636 192.168.1.2:8636 172.16.254.1:8636 172.16.254.1:8636
icmp 192.168.3.1:8637 192.168.1.2:8637 172.16.254.1:8637 172.16.254.1:8637
icmp 192.168.3.1:8638 192.168.1.2:8638 172.16.254.1:8638 172.16.254.1:8638
icmp 192.168.3.1:8639 192.168.1.2:8639 172.16.254.1:8639 172.16.254.1:8639
icmp 192.168.3.1:8640 192.168.1.2:8640 172.16.254.1:8640 172.16.254.1:8640
udp 192.168.3.1:646 192.168.3.1:646 224.0.0.2:646 224.0.0.2:646
ISPB_PE1#
ISPB_PE1#
ISPA_PE1#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 172.16.20.2:4278 192.168.3.1:4278 172.16.154.1:4278 172.16.154.1:4278
icmp 172.16.20.2:4279 192.168.3.1:4279 172.16.154.1:4279 172.16.154.1:4279
icmp 172.16.20.2:4280 192.168.3.1:4280 172.16.154.1:4280 172.16.154.1:4280
icmp 172.16.20.2:4281 192.168.3.1:4281 172.16.154.1:4281 172.16.154.1:4281
icmp 172.16.20.2:4282 192.168.3.1:4282 172.16.154.1:4282 172.16.154.1:4282
icmp 172.16.20.2:8636 192.168.3.1:8636 172.16.254.1:8636 172.16.254.1:8636
icmp 172.16.20.2:8637 192.168.3.1:8637 172.16.254.1:8637 172.16.254.1:8637
icmp 172.16.20.2:8638 192.168.3.1:8638 172.16.254.1:8638 172.16.254.1:8638
icmp 172.16.20.2:8639 192.168.3.1:8639 172.16.254.1:8639 172.16.254.1:8639
icmp 172.16.20.2:8640 192.168.3.1:8640 172.16.254.1:8640 172.16.254.1:8640
tcp 172.16.20.2:12722 192.168.3.2:12722 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:16359 192.168.3.2:16359 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:22042 192.168.3.2:22042 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:22461 192.168.3.2:22461 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:22602 192.168.3.2:22602 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:26207 192.168.3.2:26207 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:26556 192.168.3.2:26556 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:27051 192.168.3.2:27051 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:41139 192.168.3.2:41139 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:42953 192.168.3.2:42953 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:43963 192.168.3.2:43963 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:45960 192.168.3.2:45960 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:46434 192.168.3.2:46434 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:50853 192.168.3.2:50853 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:51355 192.168.3.2:51355 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:51413 192.168.3.2:51413 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:51428 192.168.3.2:51428 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:53173 192.168.3.2:53173 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:56329 192.168.3.2:56329 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:56631 192.168.3.2:56631 10.0.1.1:646 10.0.1.1:646
tcp 172.16.20.2:65300 192.168.3.2:65300 10.0.1.1:646 10.0.1.1:646
ISPA_PE1#
ISPA_PE1#

Monday, February 22, 2010

Implemeting Carrier Supporting Carrier MVPN LAB
















Confgiguration Guidelines
*************************************************************************

Scenario - Providing Carrier Supporting Carrier Multicast MPLS L3 VPN Services Providing
Multicast Traffic between Multicast Server and Clients in Customer Carrier AS 64513
using AS 64514 as Parent Carrier. Both Customer Carrier and Customer Carrier running MPLS


Design Considerations and Soultions: Can use PIM Dense or Sparse Mode. Dense Mode
causes Traffic Flooding whereas Sparse Mode is via Shared Tree where RP is needed

To Provide CSC MPLS VPN Services the we are considering Option Making Customer Carrier a MPLS
VPN Customer for Parent Carrier and using MDT for establishing Multicast across the VPNs in
Parent and Customer Carrrier




ISP A AS used 64514 - Parent carrier
ISP 2 AS used 64513 - Customer Carrier
IGP in ISPA is ISIS


PIM Sparse-Dense-Mode used On ISP Backbone Links and Peering between ISP A & B


IGMP Join-group used to simulate Mutlicast Traffic

224.11.11.11 on CE1A for VRF CEA,224.22.22.22 on CE2A for VRF CEA


****************************************************************************


CE1A#sh running-config
Building configuration...

Current configuration : 944 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
ip multicast-routing
no ftp-server write-enable
!
!
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 172.16.100.0 0.0.0.3 area 0
network 192.168.1.0 0.0.0.3 area 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
!
!
end

CE1A#
CE1A#

CE2A#sh run
Building configuration...

Current configuration : 944 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 15
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
ip multicast-routing
no ftp-server write-enable
!
!
!
!
interface Loopback0
ip address 172.16.200.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.22.22.22
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.2.2 255.255.255.252
ip pim sparse-dense-mode
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 20
log-adjacency-changes
network 172.16.200.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.3 area 0
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
!
!
end

CE2A#
CE2A#
CE2A#


ISPB_PE1#sh running-config
Building configuration...

Current configuration : 2671 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPB_PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.111.111.111
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip vrf forwarding CEA
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.3.1 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 20 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router ospf 10
log-adjacency-changes
redistribute bgp 64513 subnets
network 10.0.1.1 0.0.0.0 area 0
network 192.168.3.0 0.0.0.3 area 0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 20 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
ip pim vrf CEA bsr-candidate Serial1/0 0
ip pim vrf CEA rp-candidate Serial1/0
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

ISPB_PE1#


ISPB_PE2#sh running-config
Building configuration...

Current configuration : 2503 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPB_PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip pim sparse-dense-mode
ip igmp join-group 224.222.222.222
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.4.1 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
ip vrf forwarding CEA
ip address 192.168.2.1 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 20 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.2.0 0.0.0.3 area 0
!
router ospf 10
log-adjacency-changes
redistribute bgp 64513 subnets
network 10.0.2.1 0.0.0.0 area 0
network 192.168.4.0 0.0.0.3 area 0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 20 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

ISPB_PE2#


ISPA_PE1#sh running-config
Building configuration...

Current configuration : 2588 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPA_PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.10.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip vrf forwarding CEA
ip address 192.168.3.2 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
ip address 172.16.1.1 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 192.168.3.0 0.0.0.3 area 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 172.16.20.1 remote-as 64514
neighbor 172.16.20.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim vrf CEA bsr-candidate Serial1/0 0
ip pim vrf CEA rp-candidate Serial1/0
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

ISPA_PE1#


ISPA_PE2#sh running-config
Building configuration...

Current configuration : 2439 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISPA_PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.20.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
ip vrf forwarding CEA
ip address 192.168.4.2 255.255.255.252
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 192.168.4.0 0.0.0.3 area 0
!
router isis
net 49.0002.2222.3333.4444.00
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 172.16.10.1 remote-as 64514
neighbor 172.16.10.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 172.16.10.1 activate
neighbor 172.16.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

ISPA_PE2#





********************************
OUTPUT
********************************




CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O IA 172.16.200.1/32 [110/129] via 192.168.1.1, 00:28:12, Serial0/0
C 172.16.100.0/30 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0
192.168.2.0/30 is subnetted, 1 subnets
O IA 192.168.2.0 [110/65] via 192.168.1.1, 00:28:49, Serial0/0
CE1A#ping 172.16.200.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 412/539/696 ms
CE1A#


CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.200.0/30 is directly connected, Loopback0
O IA 172.16.100.1/32 [110/129] via 192.168.2.1, 00:28:42, Serial0/0
192.168.1.0/30 is subnetted, 1 subnets
O IA 192.168.1.0 [110/65] via 192.168.2.1, 00:28:42, Serial0/0
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, Serial0/0
CE2A#ping 172.16.100.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 300/749/1144 ms
CE2A#


CE1A#ping 224.22.22.22

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.22.22.22, timeout is 2 seconds:

Reply to request 0 from 192.168.2.2, 408 ms
Reply to request 0 from 192.168.2.2, 660 ms
CE1A#

CE2A#ping 224.11.11.11

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:

Reply to request 0 from 192.168.1.2, 1444 ms
Reply to request 0 from 192.168.1.2, 1496 ms
CE2A#


CE1A#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
224.11.11.11 Loopback0 00:13:12 00:02:22 172.16.100.1
224.0.1.40 Loopback0 00:20:44 00:02:18 172.16.100.1
CE1A#


CE2A#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
224.22.22.22 Loopback0 00:11:17 00:02:20 172.16.200.1
224.0.1.40 Loopback0 00:18:02 00:02:15 172.16.200.1
CE2A#


CE2A#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
RP 192.168.1.1 (?), v2
Info source: 192.168.1.1 (?), via bootstrap, priority 0
Uptime: 00:03:00, expires: 00:01:29
CE2A#


ISPB_PE1#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.3.2 Serial1/1 00:15:57/00:01:25 v2 1 / S P
ISPB_PE1#sh ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.2.1 Tunnel0 00:04:08/00:01:32 v2 1 / DR B S P
192.168.1.2 Serial1/0 00:20:14/00:01:36 v2 1 / S
ISPB_PE1#

ISPB_PE2#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.4.2 Serial1/0 00:15:14/00:01:18 v2 1 / S P
ISPB_PE2#sh ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.1.1 Tunnel0 00:04:26/00:01:15 v2 1 / B S P
192.168.2.2 Serial1/1 00:18:11/00:01:19 v2 1 / S
ISPB_PE2#


ISPA_PE1#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.2 Serial1/1 00:15:41/00:01:17 v2 1 / S P
ISPA_PE1#sh ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.20.1 Tunnel0 00:05:16/00:01:21 v2 1 / DR S P
192.168.3.1 Serial1/0 00:16:50/00:01:20 v2 1 / S P
ISPA_PE1#


ISPA_PE2#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.1 Serial1/0 00:16:07/00:01:20 v2 1 / S P
ISPA_PE2#sh ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.4.1 Serial1/1 00:15:56/00:01:32 v2 1 / S P
172.16.10.1 Tunnel0 00:05:43/00:01:27 v2 1 / S P
ISPA_PE2#

ISPB_PE1#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Gr
oup Accounted
239.1.1.1 Loopback0 00:21:44 stopped 0.0.0.0
224.111.111.111 Loopback0 00:15:22 00:02:12 10.0.1.1
224.0.1.39 Serial1/1 00:21:08 stopped 192.168.3.1
224.0.1.39 Loopback0 00:21:08 00:02:11 10.0.1.1
224.0.1.40 Loopback0 00:21:44 00:02:08 10.0.1.1
ISPB_PE1#

ISPB_PE2#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Gr
oup Accounted
239.1.1.1 Loopback0 00:19:35 stopped 0.0.0.0
224.222.222.222 Loopback0 00:16:00 00:02:28 10.0.2.1
224.0.1.40 Loopback0 00:19:35 00:02:32 10.0.2.1
ISPB_PE2#

ISPB_PE2#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
RP 10.0.1.1 (?), v2v1
Info source: 10.0.1.1 (?), elected via Auto-RP, via bootstrap, priority 0, h
oldtime 181
Uptime: 00:06:03, expires: 00:02:04
ISPB_PE2#

ISPB_PE1#ping 224.222.222.222

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.222.222.222, timeout is 2 seconds:

Reply to request 0 from 192.168.4.1, 136 ms
Reply to request 0 from 192.168.4.1, 144 ms
ISPB_PE1#


ISPB_PE2#ping 224.111.111.111

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.111.111.111, timeout is 2 seconds:

Reply to request 0 from 192.168.3.1, 876 ms
Reply to request 0 from 192.168.3.1, 1016 ms
ISPB_PE2#

Thursday, February 4, 2010

Implementing Inter-AS MVPN Using GRE Tunnel Between PE LAB















Confgiguration Guidelines
*************************************************************************

Scenario - Providing Inter-AS Multicast MPLS L3 VPN Services Providing Multicast
Traffic between Multicast Server in AS 64513 and Multicast Clients in AS 64514
and vice-versa


Design Considerations and Soultions: Can use PIM Dense or Sparse Mode. Dense Mode
causes Traffic Flooding whereas Sparse Mode is via Shared Tree where RP is needed

To Provide Inter-AS MPLS VPN Services the we are considering Option for creating GRE Tunnel
between the PEs attached to CEs and running PIM over GRE Tunnels


CAVEATS: This solution is not scalable as for multiple sites attached to different PEs
Full meshed GRE Tunnels needs to be created between PEs with n(n-1)/2 scalability issue

Static mroutes need to defined for interested source-destination networks for multicast
traffic flow


ISP 1 AS used 64513
ISP 2AS used 64514
IGP in ISP2 is ISIS

PIM Sparse-Dense-Mode used On ISP Backbone Links and Peering between ISP 1 & 2
via PE12 and PE22


IGMP Join-group used to simulate Mutlicast Traffic

224.11.11.11 on CE1A for VRF CEA,224.22.22.22 on CE2A for VRF CEA


****************************************************************************



CE1A#sh running-config
Building configuration...

Current configuration : 880 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 10
log-adjacency-changes
network 172.16.1.0 0.0.0.3 area 0
network 172.16.100.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE1A#

CE2A#sh running-config
Building configuration...

Current configuration : 880 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.200.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.22.22.22
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 10
log-adjacency-changes
network 172.16.2.0 0.0.0.3 area 0
network 172.16.200.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CE2A#


PE12#sh running-config
Building configuration...

Current configuration : 3168 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
ip address 172.16.254.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 10.0.3.1
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
ip address 172.16.20.1 255.255.255.252
ip pim sparse-dense-mode
ip multicast boundary 1
mpls bgp forwarding
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.1.0 0.0.0.3 area 0
!
router bgp 64513
bgp log-neighbor-changes
neighbor 172.16.20.2 remote-as 64514
!
address-family ipv4
no synchronization
network 10.0.1.1 mask 255.255.255.255
neighbor 172.16.20.2 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 172.16.20.2 activate
neighbor 172.16.20.2 send-community extended
exit-address-family
!

!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
ip pim vrf CEA send-rp-announce FastEthernet1/0 scope 100
ip pim vrf CEA send-rp-discovery FastEthernet1/0 scope 100
ip pim vrf CEA ssm default
ip mroute 172.16.2.0 255.255.255.252 Tunnel100
ip mroute 172.16.200.0 255.255.255.252 Tunnel100
!
access-list 1 deny 224.0.1.39
access-list 1 deny 224.0.1.40
access-list 1 permit any
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE12#
PE12#
PE12#





PE21#sh running-config
Building configuration...

Current configuration : 3036 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
mdt default 239.1.1.1

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
ip address 172.16.254.2 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 10.0.1.1
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip vrf forwarding CEA
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
ip address 192.168.1.6 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.2.0 0.0.0.3 area 0
!
router isis
net 49.0002.2222.3333.1111.00
!
router bgp 64514
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64514
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
network 10.0.3.1 mask 255.255.255.255
network 192.168.1.4 mask 255.255.255.252
neighbor 10.0.2.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!

!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip mroute 172.16.1.0 255.255.255.252 Tunnel100
ip mroute 172.16.100.0 255.255.255.0 Tunnel100
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE21#

PE22#sh running-config
Building configuration...

Current configuration : 2797 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
ip multicast-routing
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 172.16.20.2 255.255.255.252
ip pim bsr-border
ip pim sparse-dense-mode
mpls bgp forwarding
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.1.5 255.255.255.252
ip router isis
ip pim sparse-dense-mode
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Local
!
router bgp 64514
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64514
neighbor 10.0.3.1 update-source Loopback0
neighbor 172.16.20.1 remote-as 64513
!
address-family ipv4
no synchronization
network 10.0.2.1 mask 255.255.255.255
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 next-hop-self
neighbor 172.16.20.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 send-community extended
exit-address-family
!

!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip pim ssm default
!
access-list 1 deny 224.0.1.39
access-list 1 deny 224.0.1.40
access-list 1 permit any
route-map Local permit 10
match interface Serial1/0
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

PE22#

*********************************************
OUTPUT
***********************************************

PE12#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES manual administratively down down
FastEthernet1/0 172.16.1.1 YES manual up up
FastEthernet1/1 unassigned YES manual administratively down down
Serial2/0 172.16.20.1 YES manual up up
Serial2/1 unassigned YES manual administratively down down
Serial2/2 unassigned YES manual administratively down down
Serial2/3 unassigned YES manual administratively down down
Serial2/4 unassigned YES manual administratively down down
Serial2/5 unassigned YES manual administratively down down
Serial2/6 unassigned YES manual administratively down down
Serial2/7 unassigned YES manual administratively down down
Loopback0 10.0.1.1 YES manual up up
Tunnel0 172.16.20.1 YES unset up up
Tunnel100 172.16.254.1 YES manual up up
PE12#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.20.2 Serial2/0 01:05:14/00:01:29 v2 1 / B S P
172.16.254.2 Tunnel100 00:07:59/00:01:34 v2 1 / S P
PE12#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:14:33/stopped, RP 10.0.1.1, flags: SJCZ
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:14:33/00:00:54

(172.16.20.1, 239.1.1.1), 00:12:42/00:02:39, flags: PT
Incoming interface: Serial2/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(10.0.3.1, 239.1.1.1), 00:13:39/00:02:58, flags: PJTXZ
Incoming interface: Serial2/0, RPF nbr 172.16.20.2
Outgoing interface list: Null

(*, 224.0.1.39), 01:05:39/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:10:39/00:00:00
Loopback0, Forward/Sparse-Dense, 01:05:39/00:00:00

(10.0.1.1, 224.0.1.39), 01:05:40/00:02:19, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:10:40/00:00:00

(*, 224.0.1.40), 01:06:07/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:08:07/00:00:00
Loopback0, Forward/Sparse-Dense, 01:06:08/00:00:00

(10.0.1.1, 224.0.1.40), 01:04:42/00:02:09, flags: LT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:08:08/00:00:00

PE12#
PE12#


PE21#sh ip int bri
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES manual administratively down down
FastEthernet1/0 172.16.2.1 YES manual up up
FastEthernet1/1 unassigned YES unset administratively down down
Serial2/0 192.168.1.6 YES manual up up
Serial2/1 unassigned YES unset administratively down down
Serial2/2 unassigned YES unset administratively down down
Serial2/3 unassigned YES unset administratively down down
Serial2/4 unassigned YES unset administratively down down
Serial2/5 unassigned YES unset administratively down down
Serial2/6 unassigned YES unset administratively down down
Serial2/7 unassigned YES unset administratively down down
Loopback0 10.0.3.1 YES manual up up
Tunnel0 10.0.3.1 YES unset up up
Tunnel100 172.16.254.2 YES manual up up
PE21#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.5 Serial2/0 01:05:58/00:01:17 v2 1 / S P
172.16.254.1 Tunnel100 00:08:48/00:01:20 v2 1 / S P
PE21#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:15:26/stopped, RP 10.0.2.1, flags: SJCFZ
Incoming interface: Serial2/0, RPF nbr 192.168.1.5
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:15:26/00:02:57

(10.0.3.1, 239.1.1.1), 00:13:17/00:03:24, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial2/0, Forward/Sparse-Dense, 00:10:28/00:03:01

(172.16.20.1, 239.1.1.1), 00:13:18/00:02:54, flags: JTZ
Incoming interface: Serial2/0, RPF nbr 192.168.1.5
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:13:18/00:02:57

(*, 224.0.1.39), 00:36:26/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:08:52/00:00:00
Serial2/0, Forward/Sparse-Dense, 00:36:26/00:00:00

(172.16.1.1, 224.0.1.39), 00:00:34/00:02:25, flags:
Incoming interface: Tunnel100, RPF nbr 172.16.254.1, Mroute
Outgoing interface list:
Serial2/0, Forward/Sparse-Dense, 00:00:34/00:00:00

(10.0.1.1, 224.0.1.39), 00:01:26/00:01:33, flags:
Incoming interface: Serial2/0, RPF nbr 192.168.1.5
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:01:26/00:00:00

(*, 224.0.1.40), 01:06:51/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:08:52/00:00:00
Loopback0, Forward/Sparse-Dense, 01:06:51/00:00:00
Serial2/0, Forward/Sparse-Dense, 01:06:03/00:00:00

(10.0.1.1, 224.0.1.40), 00:00:35/00:02:24, flags: L
Incoming interface: Serial2/0, RPF nbr 192.168.1.5
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:00:35/00:00:00
Tunnel100, Forward/Sparse-Dense, 00:00:35/00:00:00

PE21#

CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C 172.16.200.0/24 is directly connected, Loopback0
O IA 172.16.1.0/30 [110/2] via 172.16.2.1, 00:08:49, FastEthernet0/0
C 172.16.2.0/30 is directly connected, FastEthernet0/0
O IA 172.16.100.1/32 [110/3] via 172.16.2.1, 00:08:49, FastEthernet0/0
CE2A#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.1 FastEthernet0/0 01:05:07/00:01:25 v2 1 / S
CE2A#sh ip pim rp mapp
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
RP 172.16.1.1 (?), v2v1
Info source: 172.16.1.1 (?), elected via Auto-RP
Uptime: 00:05:05, expires: 00:02:45
CE2A#ping 224.11.11.11

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:

Reply to request 0 from 172.16.1.2, 1624 ms
Reply to request 0 from 172.16.1.2, 1624 ms
CE2A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.44.44.44), 00:06:04/00:02:32, RP 172.16.1.1, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:06:04/00:02:32

(*, 224.88.88.88), 00:06:04/00:02:36, RP 172.16.1.1, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:06:04/00:02:36

(*, 224.11.11.11), 00:06:03/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list: Null

(172.16.2.2, 224.11.11.11), 00:00:05/00:02:59, flags: PFT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(172.16.200.1, 224.11.11.11), 00:01:23/00:03:28, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:01:24/00:02:55

(*, 224.66.66.66), 00:06:05/00:02:31, RP 172.16.1.1, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1