Tuesday, February 2, 2010

Implementing Inter-AS MVPN Using Option A Back-to-Back VRF with BGP MDT SAFI LAB















Confgiguration Guidelines
*************************************************************************

Scenario - Providing Inter-AS Multicast MPLS L3 VPN Services Providing Multicast
Traffic between Multicast Server in AS 64513 and Multicast Clients in AS 64514
and vice-versa


Design Cconsiderations and Soultions: Can use PIM Dense or Sparse Mode. Dense Mode
causes Traffic Flooding whereas Sparse Mode is via Shared Tree where RP is needed

To Provide Inter-AS MPLS VPN Services the we are considering Option A whereby we are using back-to-back
VRFs between ASBRs.

Inter-AS Multicast is achieved by utilising BGP MDT SAFI and estabilishing MDT Tunnels between PEs.

Caveats: This solution for Inetr-AS MVPN requires a dedicated Physical Interface or Subinterfaces between ASBRs
per VRF


ISP 1 AS used 64513
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces
ISP 1 AS used 64514
IGP in ISP1 is OSPF with passive-interfaces for non-ospf Interfaces


PIM Sparse-Dense-Mode used On ISP Backbone Links and Peering between ISP 1 & 2
via PE12 and PE22


IGMP Join-group used to simulate Mutlicast Traffic

224.11.11.11 on CE1A for VRF CEA,224.22.22.22 on CE1A for VRF CEA;224.33.33.33 on CE2A
for VRF CEA and 224.44.44.44on CE2A for VRF CEB


****************************************************************************
CE1A#sh running-config
Building configuration...

Current configuration : 1830 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.11.11.11
!
interface Loopback1
ip address 172.16.200.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.22.22.22
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/0.10 point-to-point
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 108
!
interface Serial1/0.20 point-to-point
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 109
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
network 172.16.2.0 0.0.0.3
network 172.16.200.0 0.0.0.255
no auto-summary
!
router ospf 10
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0.10
network 172.16.1.0 0.0.0.3 area 0
network 172.16.100.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE1A#

CE2A#sh running-config
Building configuration...

Current configuration : 1830 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.154.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.33.33.33
!
interface Loopback1
ip address 172.16.254.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 224.44.44.44
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/0.10 point-to-point
ip address 172.16.3.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 106
!
interface Serial1/0.20 point-to-point
ip address 172.16.4.2 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 107
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
network 172.16.4.0 0.0.0.3
network 172.16.254.0 0.0.0.255
no auto-summary
!
router ospf 10
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0.10
network 172.16.3.0 0.0.0.3 area 0
network 172.16.154.0 0.0.0.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

CE2A#


PE11#sh running-config
Building configuration...

Current configuration : 4080 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
ip vrf CEB
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64514:200
mdt default 239.2.2.2

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
ip multicast-routing vrf CEB
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.1.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.2 102 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
!
interface Serial1/1.10 point-to-point
description <>
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 108
!
interface Serial1/1.20 point-to-point
description <>
ip vrf forwarding CEB
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 109
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEB
autonomous-system 100
network 172.16.2.0 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 200 1500
exit-address-family
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.1.0 0.0.0.3 area 0
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.3 area 0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.1.2.1 remote-as 64513
neighbor 10.1.2.1 description <>
neighbor 10.1.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.1.2.1 activate
neighbor 10.1.2.1 send-community extended
neighbor 10.1.2.1 next-hop-self
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.2.1 activate
neighbor 10.1.2.1 send-community extended
neighbor 10.1.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
address-family ipv4 vrf CEB
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
ip pim vrf CEA send-rp-announce Serial1/1.10 scope 100
ip pim vrf CEA send-rp-discovery Serial1/1.10 scope 100
ip pim vrf CEB bsr-candidate Serial1/1.20 0
ip pim vrf CEB rp-candidate Serial1/1.20
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE11#
PE11#
PE11#

PE12#sh running-config
Building configuration...

Current configuration : 3919 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
ip vrf CEB
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64514:200
mdt default 239.2.2.2

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
ip multicast-routing vrf CEB
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.1.2.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.1 201 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type ansi
!
interface Serial1/1.10 point-to-point
description <>
ip vrf forwarding CEA
ip address 172.16.5.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.55.55.55
frame-relay interface-dlci 103
!
interface Serial1/1.20 point-to-point
description <>
ip vrf forwarding CEB
ip address 172.16.6.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.66.66.66
frame-relay interface-dlci 105
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEB
autonomous-system 100
network 172.16.6.0 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 200 1500
exit-address-family
!
address-family ipv4 vrf CEA
autonomous-system 100
network 172.16.3.0 0.0.0.3
network 172.16.5.0 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 200 1500
exit-address-family
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.1.2.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.3 area 0
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 64513
neighbor 10.1.1.1 description <>
neighbor 10.1.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.1 next-hop-self
exit-address-family
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
address-family ipv4 vrf CEB
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE12#
PE12#


PE22#sh running-config
Building configuration...

Current configuration : 3922 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64514:100
mdt default 239.1.1.1

!
ip vrf CEB
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64514:200
mdt default 239.2.2.2

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
ip multicast-routing vrf CEB
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.2.2.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type ansi
!
interface Serial1/0.10 point-to-point
description <>
ip vrf forwarding CEA
ip address 172.16.5.2 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.222.222.222
frame-relay interface-dlci 301
!
interface Serial1/0.20 point-to-point
description <>
ip vrf forwarding CEB
ip address 172.16.6.2 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.88.88.88
frame-relay interface-dlci 501
!
interface Serial1/1
ip address 192.168.1.6 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.5 401 broadcast
frame-relay lmi-type ansi
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEB
autonomous-system 100
network 172.16.6.0 0.0.0.3
no auto-summary
redistribute bgp 64514 metric 1544 2000 255 200 1500
exit-address-family
!
address-family ipv4 vrf CEA
autonomous-system 100
network 172.16.3.0 0.0.0.3
network 172.16.5.0 0.0.0.3
no auto-summary
redistribute bgp 64514 metric 1544 2000 255 200 1500
exit-address-family
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/1
network 10.2.2.1 0.0.0.0 area 0
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.2.1.1 remote-as 64514
neighbor 10.2.1.1 description <>
neighbor 10.2.1.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.1.1 activate
neighbor 10.2.1.1 send-community extended
neighbor 10.2.1.1 next-hop-self
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.1.1 activate
neighbor 10.2.1.1 send-community extended
neighbor 10.2.1.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
address-family ipv4 vrf CEB
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim ssm default
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE22#

PE21#sh running-config
Building configuration...

Current configuration : 3920 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip cef
!
!
ip vrf CEA
description <>
rd 64514:1
route-target export 64514:100
route-target import 64514:100
route-target import 64513:100
mdt default 239.1.1.1

!
ip vrf CEB
rd 64514:2
route-target export 64514:200
route-target import 64514:200
route-target import 64513:200
mdt default 239.2.2.2

!
!
!
ip multicast-routing
ip multicast-routing vrf CEA
ip multicast-routing vrf CEB
no ip domain lookup
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.2.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.5 255.255.255.252
ip pim sparse-dense-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
serial restart-delay 0
frame-relay map ip 192.168.1.6 104 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay intf-type dce
!
interface Serial1/1.10 point-to-point
description <>
ip vrf forwarding CEA
ip address 172.16.3.1 255.255.255.252
ip pim sparse-dense-mode
frame-relay interface-dlci 106
!
interface Serial1/1.20 point-to-point
description <>
ip vrf forwarding CEB
ip address 172.16.4.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.111.111.111
frame-relay interface-dlci 107
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEB
autonomous-system 100
network 172.16.4.0 0.0.0.3
no auto-summary
redistribute bgp 64514 metric 1544 2000 255 200 1500
exit-address-family
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.16.3.0 0.0.0.3 area 0
!
router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Serial1/0
network 10.2.1.1 0.0.0.0 area 0
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64514
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 64514
neighbor 10.2.2.1 description <>
neighbor 10.2.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.1 next-hop-self
exit-address-family
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute ospf 10 vrf CEA match internal external 1 external 2
exit-address-family
!
address-family ipv4 vrf CEB
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
no ip http server
no ip http secure-server
!
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
ip pim ssm default
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

PE21#
PE21#
PE21#

**************************************************************
OUTPUT
**************************************************************

CE1A#ping 224.44.44.44

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.44.44.44, timeout is 2 seconds:

Reply to request 0 from 172.16.3.2, 1388 ms
CE1A#ping 224.33.33.33

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.33.33.33, timeout is 2 seconds:

Reply to request 0 from 172.16.3.2, 1820 ms
CE1A#

CE2A#ping 224.11.11.11

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.11.11.11, timeout is 2 seconds:

Reply to request 0 from 172.16.1.2, 1964 ms
CE2A#ping 224.22.22.22

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.22.22.22, timeout is 2 seconds:

Reply to request 0 from 172.16.1.2, 960 ms


PE11#sh ip pim mdt bgp
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 239.1.1.1
64513:1:10.1.2.1 10.1.2.1 10.1.2.1
MDT group 239.2.2.2
64513:2:10.1.2.1 10.1.2.1 10.1.2.1
PE11#

PE12#sh ip pim mdt bgp
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 239.1.1.1
64513:1:10.1.1.1 10.1.1.1 10.1.1.1
MDT group 239.2.2.2
64513:2:10.1.1.1 10.1.1.1 10.1.1.1
PE12#

PE22#sh ip pim mdt bgp
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 239.1.1.1
64514:1:10.2.1.1 10.2.1.1 10.2.1.1
MDT group 239.2.2.2
64514:2:10.2.1.1 10.2.1.1 10.2.1.1
PE22#

PE21#sh ip pim mdt bgp
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 239.1.1.1
64513:1:10.2.2.1 10.2.2.1 10.2.2.1
MDT group 239.2.2.2
64513:2:10.2.2.1 10.2.2.1 10.2.2.1
PE21#


CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
O E2 172.16.154.1/32 [110/2681856] via 172.16.1.1, 00:06:16, Serial1/0.10
D 172.16.254.0/24 [90/3321856] via 172.16.2.1, 00:19:30, Serial1/0.20
C 172.16.200.0/24 is directly connected, Loopback1
D 172.16.4.0/30 [90/3193856] via 172.16.2.1, 00:19:45, Serial1/0.20
O E2 172.16.5.0/30 [110/1] via 172.16.1.1, 00:05:34, Serial1/0.10
D 172.16.6.0/30 [90/2681856] via 172.16.2.1, 00:33:13, Serial1/0.20
C 172.16.1.0/30 is directly connected, Serial1/0.10
C 172.16.2.0/30 is directly connected, Serial1/0.20
O E2 172.16.3.0/30 [110/2681856] via 172.16.1.1, 00:06:16, Serial1/0.10
C 172.16.100.0/24 is directly connected, Loopback0
CE1A#


CE1A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.1 Serial1/0.10 01:06:06/00:01:19 v2 1 / S
172.16.2.1 Serial1/0.20 01:06:05/00:01:19 v2 1 / S



CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 3 masks
C 172.16.154.0/24 is directly connected, Loopback0
C 172.16.254.0/24 is directly connected, Loopback1
D 172.16.200.0/24 [90/3321856] via 172.16.4.1, 00:19:17, Serial1/0.20
C 172.16.4.0/30 is directly connected, Serial1/0.20
O E2 172.16.5.0/30 [110/1] via 172.16.3.1, 00:05:04, Serial1/0.10
D 172.16.6.0/30 [90/2681856] via 172.16.4.1, 00:19:17, Serial1/0.20
O E2 172.16.1.0/30 [110/2681856] via 172.16.3.1, 00:05:33, Serial1/0.10
D 172.16.2.0/30 [90/3193856] via 172.16.4.1, 00:19:17, Serial1/0.20
C 172.16.3.0/30 is directly connected, Serial1/0.10
O E2 172.16.100.1/32 [110/2681856] via 172.16.3.1, 00:05:33, Serial1/0.10
CE2A#


CE2A#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.3.1 Serial1/0.10 00:19:09/00:01:44 v2 1 / S
172.16.4.1 Serial1/0.20 00:19:09/00:01:19 v2 1 / S
CE2A#


CE1A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.44.44.44), 00:00:59/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list: Null

(172.16.100.1, 224.44.44.44), 00:00:59/00:02:53, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.10, Forward/Sparse-Dense, 00:00:57/00:02:32

(172.16.200.1, 224.44.44.44), 00:00:59/00:02:53, flags: FT
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 00:00:54/00:02:35

(*, 224.11.11.11), 01:04:19/stopped, RP 172.16.1.1, flags: SJCLF
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 01:04:19/00:02:38

(172.16.3.1, 224.11.11.11), 00:02:07/00:00:55, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:02:07/00:02:37

(172.16.3.2, 224.11.11.11), 00:01:44/00:01:35, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:44/00:02:37

(172.16.154.1, 224.11.11.11), 00:01:24/00:01:45, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:24/00:02:37

(*, 224.22.22.22), 01:04:21/stopped, RP 172.16.1.1, flags: SJCLF
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 01:04:21/00:02:31

(172.16.3.1, 224.22.22.22), 00:02:30/00:00:37, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:02:31/00:02:30

(172.16.154.1, 224.22.22.22), 00:01:52/00:01:46, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:01:52/00:02:30

(*, 224.33.33.33), 00:01:07/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list: Null

(172.16.100.1, 224.33.33.33), 00:01:07/00:02:49, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.10, Forward/Sparse-Dense, 00:01:05/00:02:24

(172.16.200.1, 224.33.33.33), 00:01:07/00:02:49, flags: FT
Incoming interface: Loopback1, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 00:01:00/00:02:29

(*, 224.222.222.222), 00:02:50/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: Serial1/0.10, RPF nbr 172.16.1.1
Outgoing interface list: Null

(172.16.100.1, 224.222.222.222), 00:02:50/00:00:49, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial1/0.10, Forward/Sparse-Dense, 00:02:49/00:02:53

(172.16.200.1, 224.222.222.222), 00:02:51/00:00:18, flags: PFT
Incoming interface: Loopback1, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(*, 224.0.1.39), 01:04:16/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 01:04:16/00:00:00
Serial1/0.10, Forward/Sparse-Dense, 01:04:16/00:00:00

(172.16.1.1, 224.0.1.39), 01:04:16/00:02:08, flags: T
Incoming interface: Serial1/0.10, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 01:04:16/00:00:00

(*, 224.0.1.40), 01:04:24/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 01:04:16/00:00:00
Serial1/0.10, Forward/Sparse-Dense, 01:04:16/00:00:00
Loopback0, Forward/Sparse-Dense, 01:04:25/00:00:00

(172.16.1.1, 224.0.1.40), 01:04:17/00:02:36, flags: LT
Incoming interface: Serial1/0.10, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 01:04:17/00:00:00
Loopback0, Forward/Sparse-Dense, 01:04:17/00:00:00

CE1A#

CE2A#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.44.44.44), 00:19:41/00:01:40, RP 172.16.1.1, flags: SJCLF
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:19:41/00:02:17

(172.16.1.2, 224.44.44.44), 00:01:25/00:01:50, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:01:25/00:02:17

(172.16.100.1, 224.44.44.44), 00:01:25/00:01:50, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:01:25/00:02:17

(172.16.200.1, 224.44.44.44), 00:01:24/00:01:50, flags: LJT
Incoming interface: Serial1/0.20, RPF nbr 172.16.4.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:01:24/00:02:17

(*, 224.11.11.11), 00:02:35/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list: Null

(172.16.3.1, 224.11.11.11), 00:02:35/00:00:32, flags: PFT
Incoming interface: Serial1/0.10, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(172.16.4.1, 224.11.11.11), 00:02:36/00:00:32, flags: PFT
Incoming interface: Serial1/0.20, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(172.16.154.1, 224.11.11.11), 00:02:12/00:01:42, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial1/0.10, Forward/Sparse-Dense, 00:01:49/00:02:38

(172.16.254.1, 224.11.11.11), 00:02:13/00:01:12, flags: PFT
Incoming interface: Loopback1, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(*, 224.22.22.22), 00:02:59/stopped, RP 172.16.1.1, flags: SPF
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list: Null

(172.16.3.1, 224.22.22.22), 00:02:59/00:00:04, flags: PFT
Incoming interface: Serial1/0.10, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(172.16.4.1, 224.22.22.22), 00:02:59/00:00:04, flags: PFT
Incoming interface: Serial1/0.20, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(172.16.154.1, 224.22.22.22), 00:02:20/00:01:43, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
Serial1/0.10, Forward/Sparse-Dense, 00:02:17/00:03:07

(172.16.254.1, 224.22.22.22), 00:02:21/00:01:13, flags: PFT
Incoming interface: Loopback1, RPF nbr 0.0.0.0, Registering
Outgoing interface list: Null

(*, 224.33.33.33), 00:19:44/00:01:49, RP 172.16.1.1, flags: SJCL
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:19:44/00:02:13

(172.16.1.2, 224.33.33.33), 00:01:34/00:01:55, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:34/00:02:12

(172.16.100.1, 224.33.33.33), 00:01:34/00:01:54, flags: LJT
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:35/00:02:12

(172.16.200.1, 224.33.33.33), 00:01:35/00:01:53, flags: LJT
Incoming interface: Serial1/0.20, RPF nbr 172.16.4.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:01:35/00:02:11

(*, 224.0.1.39), 00:03:36/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 00:03:37/00:00:00
Serial1/0.10, Forward/Sparse-Dense, 00:03:37/00:00:00

(172.16.1.1, 224.0.1.39), 00:03:37/00:02:43, flags: T
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 00:03:37/00:00:00

(*, 224.0.1.40), 00:19:47/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Serial1/0.20, Forward/Sparse-Dense, 00:18:46/00:00:00
Serial1/0.10, Forward/Sparse-Dense, 00:18:46/00:00:00
Loopback0, Forward/Sparse-Dense, 00:19:48/00:00:00

(172.16.1.1, 224.0.1.40), 00:04:10/00:02:12, flags: LT
Incoming interface: Serial1/0.10, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:04:10/00:00:00
Serial1/0.20, Forward/Sparse-Dense, 00:04:10/00:00:00

CE2A#

No comments:

Post a Comment