Tuesday, June 8, 2010

Implementing Broadband PPPoE Services over MPLS Backbone LAB















Configuration Guidelines
*******************************************************************
Scenario: An ISP wants to offer Broadband PPPoE Services
over his MPLS Backbone and theryby provide Internet and
Multicast Traffic.Also ISP is using MPLS TE across his Core for
Optimal Utilization of BW.ISP is using MPLS TE CBTS to implement MPLS
AToM Vll(Virtual Leased Line) by pushing all the MPLS L2 VPN Traffic
across its core through the EXP Aware TE Tunnel for EXP 5
Also here ISP is peering to Internet Gateway for Internet and Multicast
services

Design Considerations:

To offer Broadband PPPoE over MPLS Backbone ISP needs to connect the
Broadband PPPoE CPE and the Broadband RAS across the MPLS Backbone
over a L2 MPLS VPN.SP Backbone has MPLS TE enabled for Optimal BW
Utilization.The SP MPLS Backbone can be used to provide the Broadband
Services as well as legacy MPLS VPN Services with better SLA and BW
Guarantee.

To Offer Multicast over Broadband PPPoE ISP is using PIM SM-DM at the
Broadband RAS and Broadband PPPoE CPE (MPLS Backbone need not be enabled
for Multicast until unless ISP is offering Multicast Services to legacy
MPLS VPN Customers)

Internet Gateway provides Internet Traffic to ISP as we as Multicast
Services. Internet GW is using PIM BSR for RP and ISP is using Auto-RP
MSDP is being run between ISP and Internet GW for Inter-Domain
Multicast Traffic. ISP-INternet GW Link is configured for preventing
the Inter-Domain RP flooding.

Broadband PPPoE CPE is using Dialer Interface for PPPoE

ISP bba-group for pppoe used "group'
ISP virtual-template 1 used with local pool used pppoepool
10.0.10.1 10.0.10.200
EBGP used between ISP and Internet-GW

PIM SM-DM used between ISP & Internet-GW
For ISP MPLS Backbone
IGP used OSPF Area 0
L2 Xconnect used VCID 100
TE Tunnel used 100 EXP aware - EXP 5
TE Tunnel used 200 EXP Aware -EXP 0 3 4
TE 1000- Master Tunnel


Customer IGP used OSPF Area 0
NAT used on LAN GW for Internet Access

*************************************************

CE_LAN#sh running-config
Building configuration...

Current configuration : 991 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE_LAN
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 239.2.2.2
!
interface FastEthernet0/0
description LAN_GW
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 1
router-id 192.168.101.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

CE_LAN#


LAN_GW#sh running-config
Building configuration...

Current configuration : 1708 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LAN_GW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 192.168.2.1 255.255.255.255
!
interface FastEthernet0/0
description LAN_SEGMENT
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
ip tcp adjust-mss 1452
speed 100
full-duplex
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip igmp join-group 239.1.1.1
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap chap callin
ppp chap hostname cisco
ppp chap password 0 sisco
ppp pap sent-username cisco password 0 sisco
!
!
router ospf 1
router-id 192.168.2.1
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
default-information originate always
!
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.2.1
access-list 1 permit 192.168.1.0 0.0.0.3
access-list 1 permit 192.168.101.0 0.0.0.255
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

LAN_GW#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 3149 bytes
!
! Last configuration change at 13:36:33 UTC Tue Jun 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all DSLBB
match any
!
policy-map Core_Out
class EXP_5
policy-map DSLBB
class DSLBB
set mpls experimental imposition 5
!
pseudowire-class dsl
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric 100000
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1000
description Master
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.2.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel200
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description core1.pop1
ip address 10.0.110.1 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
service-policy output Core_Out
ip rsvp bandwidth
!
interface FastEthernet1/1
description core1.pop1
ip address 10.0.130.1 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
service-policy output Core_Out
ip rsvp bandwidth
!
interface FastEthernet2/0
description dslam.pop1
no ip address
speed auto
duplex auto
no keepalive
xconnect 10.0.2.1 100 pw-class dsl
service-policy input DSLBB
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name Gold enable
next-address 10.0.110.2
next-address 10.0.120.1
!
ip explicit-path name Silver enable
next-address 10.0.130.2
next-address 10.0.140.1
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop1#

core1.pop1#sh running-config
Building configuration...

Current configuration : 1684 bytes
!
! Last configuration change at 16:42:04 UTC Mon Jun 7 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description edge1.pop1
ip address 10.0.130.2 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet1/1
description edge1.pop1
ip address 10.0.110.2 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description edge1.noc
ip address 10.0.120.2 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/1
description edge1.noc
ip address 10.0.140.2 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop1#

edge1.noc#sh running-config
Building configuration...

Current configuration : 3148 bytes
!
! Last configuration change at 13:40:25 UTC Tue Jun 8 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.noc
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
!
class-map match-all EXP_5
match mpls experimental topmost 5
class-map match-all DSLBB
match any
!
policy-map Core_Out
class EXP_5
policy-map DSLBB
class DSLBB
set mpls experimental imposition 5
!
pseudowire-class dsl
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface Tunnel100
description Gold
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.4.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name Gold
tunnel mpls traffic-eng exp 5
!
interface Tunnel200
description Silver
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.4.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric 100000
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name Silver
tunnel mpls traffic-eng exp 0 3 4
!
interface Tunnel1000
description Master
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 10.0.4.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng exp-bundle master
tunnel mpls traffic-eng exp-bundle member Tunnel100
tunnel mpls traffic-eng exp-bundle member Tunnel200
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description dslam.pop1
no ip address
speed auto
duplex auto
no keepalive
xconnect 10.0.4.1 100 pw-class dsl
service-policy input DSLBB
!
interface FastEthernet1/1
description core1.pop1
ip address 10.0.120.1 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
service-policy output Core_Out
ip rsvp bandwidth
!
interface FastEthernet2/0
description core1.pop1
ip address 10.0.140.1 255.255.255.252
speed auto
duplex auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
service-policy output Core_Out
ip rsvp bandwidth
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
no ip http server
no ip http secure-server
!
!
!
ip explicit-path name Gold enable
next-address 10.0.120.2
next-address 10.0.110.1
!
ip explicit-path name Silver enable
next-address 10.0.140.2
next-address 10.0.130.1
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.noc#

BRAS#sh running-config
Building configuration...

Current configuration : 2003 bytes
!
! Last configuration change at 17:18:51 UTC Mon Jun 7 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname BRAS
!
boot-start-marker
boot-end-marker
!
security passwords min-length 1
!
aaa new-model
!
!
aaa authorization network default local
!
!
!
!
!
aaa session-id common
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
username cisco password 0 sisco
!
!
!
!
!
!
!
bba-group pppoe global
virtual-template 1
!
bba-group pppoe dsl-pppoe
virtual-template 1
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
no ip address
ip pim sparse-mode
load-interval 30
speed 100
duplex full
pppoe enable group global
!
interface FastEthernet1/1
description Internet
ip address 172.16.1.2 255.255.255.252
ip pim bsr-border
ip pim sparse-dense-mode
speed 100
duplex full
!
interface Virtual-Template1
mtu 1492
ip unnumbered FastEthernet1/1
ip pim sparse-dense-mode
peer default ip address pool pppoepool
ppp authentication pap chap
!
router bgp 64513
no synchronization
bgp router-id 10.0.1.1
bgp log-neighbor-changes
network 10.0.0.0
network 10.0.1.1 mask 255.255.255.255
network 10.0.10.0 mask 255.255.255.0
neighbor 172.16.1.1 remote-as 64514
neighbor 172.16.1.1 description Internet
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip local pool pppoepool 10.10.10.1 10.10.10.200
no ip http server
no ip http secure-server
!
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 172.16.1.1 remote-as 64514
ip msdp cache-sa-state
ip route 10.0.0.0 255.0.0.0 Null0
!
logging alarm informational
access-list 1 deny 239.0.1.40
access-list 1 deny 239.0.1.39
access-list 1 permit any
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
!
end

BRAS#

Internet#sh running-config
Building configuration...

Current configuration : 1397 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no crypto isakmp ccm
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
description BRAS
ip address 172.16.1.1 255.255.255.252
ip pim bsr-border
ip pim sparse-dense-mode
speed 100
full-duplex
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.252
network 172.16.101.0 mask 255.255.255.0
neighbor 172.16.1.2 remote-as 64513
neighbor 172.16.1.2 description eBGP
neighbor 172.16.1.2 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip msdp peer 172.16.1.2 connect-source FastEthernet0/0
!
access-list 1 deny 239.0.1.40
access-list 1 deny 239.0.1.39
access-list 1 permit any
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Internet#

************************
OUTPUT
************************
PPPoE SESSION
************************

BRAS#show subscriber session
Current Subscriber Information: Total sessions 1

Uniq ID Interface State Service Identifier Up-time
4 Vi1.1 authen Local Term cisco 00:36:05

BRAS#show subscriber session username cisco detailed
Unique Session ID: 4
Identifier: cisco
SIP subscriber access type(s): PPPoE/PPP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:36:06, Last Changed: 00:36:07
Interface: Virtual-Access1.1

Policy information:
Context 6666BA98: Handle BA000004
AAA_id 0000000F: Flow_handle 0
Authentication status: authen

Configuration sources associated with this session:
Interface: Virtual-Template1, Active Time = 00:36:06

BRAS#

BRAS#show ip local pool pppoepool | begin Inuse
Inuse addresses:
10.10.10.4 Vi1.1 cisco
BRAS#

CE_LAN#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 192.168.1.2 80 msec 80 msec 64 msec
2 172.16.1.2 672 msec 376 msec 352 msec
3 172.16.1.1 232 msec * 488 msec
CE_LAN#ping 172.16.101.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.101.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 116/168/240 ms
CE_LAN#

LAN_GW#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 10.10.10.4:19 192.168.1.1:19 172.16.101.1:19 172.16.101.1:19
udp 10.10.10.4:49217 192.168.1.1:49217 172.16.101.1:33437 172.16.101.1:33437
udp 10.10.10.4:49218 192.168.1.1:49218 172.16.101.1:33438 172.16.101.1:33438
udp 10.10.10.4:49219 192.168.1.1:49219 172.16.101.1:33439 172.16.101.1:33439
udp 10.10.10.4:49220 192.168.1.1:49220 172.16.101.1:33440 172.16.101.1:33440
udp 10.10.10.4:49221 192.168.1.1:49221 172.16.101.1:33441 172.16.101.1:33441
udp 10.10.10.4:49222 192.168.1.1:49222 172.16.101.1:33442 172.16.101.1:33442
LAN_GW#

LAN_GW#show pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st
N/A 4 ca03.0ba4.001c Fa0/1 Di1 Vi2 N/A
c405.0c44.0001 UP
LAN_GW#show pppoe session all
Total PPPoE sessions 1


session id: 4
local MAC address: c405.0c44.0001, remote MAC address: ca03.0ba4.001c
virtual access interface: Vi2, outgoing interface: Fa0/1
2281 packets sent, 2197 received
100418 bytes sent, 96524 received
LAN_GW#

LAN_GW#sh ip int brief
Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0/0 192.168.1.2 YES manual up up

FastEthernet0/1 unassigned YES manual up up

NVI0 unassigned YES unset up up

Virtual-Access1 unassigned YES unset up up

Virtual-Access2 unassigned YES unset up up

Dialer1 10.10.10.4 YES IPCP up up

Loopback0 192.168.2.1 YES manual up up

LAN_GW#

LAN_GW#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

172.16.0.0/32 is subnetted, 1 subnets
C 172.16.1.2 is directly connected, Dialer1
10.0.0.0/32 is subnetted, 1 subnets
C 10.10.10.4 is directly connected, Dialer1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
192.168.2.0/32 is subnetted, 1 subnets
C 192.168.2.1 is directly connected, Loopback0
192.168.101.0/32 is subnetted, 1 subnets
O 192.168.101.1 [110/11] via 192.168.1.1, 02:38:58, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, Dialer1
LAN_GW#

CE_LAN#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.1.2 to network 0.0.0.0

192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
192.168.2.0/32 is subnetted, 1 subnets
O 192.168.2.1 [110/11] via 192.168.1.2, 02:39:04, FastEthernet0/0
C 192.168.101.0/24 is directly connected, Loopback0
O*E2 0.0.0.0/0 [110/1] via 192.168.1.2, 02:39:04, FastEthernet0/0
CE_LAN#

******************
MPLS Backbone
******************



edge1.pop1#show mpls l2transport summary
Destination address: 10.0.2.1, total number of vc: 1
0 unknown, 1 up, 0 down, 0 admin down, 0 recovering, 0 standby, 0 hotstandby
1 active vc on MPLS interface Tu100
edge1.pop1#show mpls l2transport vc

Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0 Ethernet 10.0.2.1 100 UP
edge1.pop1#show mpls l2transport vc detail
Local interface: Fa1/0 up, line protocol up, Ethernet up
Destination address: 10.0.2.1, VC ID: 100, VC status: up
Output interface: Tu100, imposed label stack {18 21}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 02:30:56, last status change time: 00:40:28
Signaling protocol: LDP, peer 10.0.2.1:0 up
Targeted Hello: 10.0.4.1(LDP Id) -> 10.0.2.1, LDP is UP
Status TLV support (local/remote) : enabled/supported
LDP route watch : enabled
Label/status state machine : established, LruRru
Last local dataplane status rcvd: No fault
Last local SSS circuit status rcvd: No fault
Last local SSS circuit status sent: No fault
Last local LDP TLV status sent: No fault
Last remote LDP TLV status rcvd: No fault
Last remote LDP ADJ status rcvd: No fault
MPLS VC labels: local 21, remote 21
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: dslam.pop1
Sequencing: receive disabled, send disabled
Control Word: On (configured: autosense)
VC statistics:
transit packet totals: receive 3192, send 1163
transit byte totals: receive 272594, send 135874
transit packet drops: receive 0, seq error 0, send 0

edge1.pop1#

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 2002 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 202 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 10.0.2.1 - Fa1/0 up/up
Silver 10.0.2.1 - Fa1/1 up/up
Master 10.0.2.1 - unknown up/up
Gold 10.0.4.1 Fa1/0 - up/up

Silver 10.0.4.1 Fa1/1 - up/up

Displayed 3 (of 3) heads, 0 (of 0) midpoints, 2 (of 2) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#show mpls traffic-eng tunnels | beg Master
Name: Master (Tunnel1000) Destination: 10.0.2.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel200: Config Exp: 0 3 4


History:
Tunnel:
Time since created: 26 minutes, 40 seconds
Number of LSP IDs (Tun_Instances) used: 0

LSP Tunnel Gold is signalled, connection is up
InLabel : FastEthernet1/0, implicit-null
Prev Hop : 10.0.110.2
OutLabel : -
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.4.1, Tun_Id 100, Tun_Instance 11
RSVP Path Info:
My Address: 10.0.4.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel Silver is signalled, connection is up
InLabel : FastEthernet1/1, implicit-null
Prev Hop : 10.0.130.2
OutLabel : -
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.4.1, Tun_Id 200, Tun_Instance 11
RSVP Path Info:
My Address: 10.0.4.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

P2MP TUNNELS:

P2MP SUB-LSPS:

edge1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.0.2.1/32 [110/3] via 10.0.2.1, 00:20:05, Tunnel1000
O 10.0.3.1/32 [110/2] via 10.0.130.2, 00:20:05, FastEthernet1/1
[110/2] via 10.0.110.2, 00:20:05, FastEthernet1/0
C 10.0.4.1/32 is directly connected, Loopback0
C 10.0.110.0/30 is directly connected, FastEthernet1/0
L 10.0.110.1/32 is directly connected, FastEthernet1/0
O 10.0.120.0/30 [110/2] via 10.0.130.2, 00:20:05, FastEthernet1/1
[110/2] via 10.0.110.2, 00:20:05, FastEthernet1/0
C 10.0.130.0/30 is directly connected, FastEthernet1/1
L 10.0.130.1/32 is directly connected, FastEthernet1/1
O 10.0.140.0/30 [110/2] via 10.0.130.2, 00:20:05, FastEthernet1/1
[110/2] via 10.0.110.2, 00:20:05, FastEthernet1/0
edge1.pop1#

edge1.pop1#show mpls forwarding-table 10.0.2.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
20 [T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.2.1/32 0 Tu1000 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop1#


core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 2069 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 269 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 10.0.4.1 Fa1/0 Fa2/0 up/up

Silver 10.0.4.1 Fa1/1 Fa2/1 up/up

Gold 10.0.2.1 Fa2/0 Fa1/0 up/up

Silver 10.0.2.1 Fa2/1 Fa1/1 up/up

Displayed 0 (of 0) heads, 4 (of 4) midpoints, 0 (of 0) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop1#


edge1.noc#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 2277 seconds
Periodic FRR Promotion: Not Running
Periodic auto-bw collection: every 300 seconds, next in 177 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
Gold 10.0.4.1 - Fa1/1 up/up
Silver 10.0.4.1 - Fa2/0 up/up
Master 10.0.4.1 - unknown up/up
Gold 10.0.2.1 Fa1/1 - up/up

Silver 10.0.2.1 Fa2/0 - up/up

Displayed 3 (of 3) heads, 0 (of 0) midpoints, 2 (of 2) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.noc#show mpls traffic-eng tunnels | beg Master
Name: Master (Tunnel1000) Destination: 10.0.4.1
Status: Master
Admin: up Oper: up Signalling: N/A

Member Tunnels: Member Autoroute: Inactive

Tunnel100: Config Exp: 5
Tunnel200: Config Exp: 0 3 4


History:
Tunnel:
Time since created: 22 minutes, 3 seconds
Number of LSP IDs (Tun_Instances) used: 0

LSP Tunnel Gold is signalled, connection is up
InLabel : FastEthernet1/1, implicit-null
Prev Hop : 10.0.120.2
OutLabel : -
RSVP Signalling Info:
Src 10.0.4.1, Dst 10.0.2.1, Tun_Id 100, Tun_Instance 30
RSVP Path Info:
My Address: 10.0.2.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

LSP Tunnel Silver is signalled, connection is up
InLabel : FastEthernet2/0, implicit-null
Prev Hop : 10.0.140.2
OutLabel : -
RSVP Signalling Info:
Src 10.0.4.1, Dst 10.0.2.1, Tun_Id 200, Tun_Instance 28
RSVP Path Info:
My Address: 10.0.2.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits

P2MP TUNNELS:

P2MP SUB-LSPS:
edge1.noc#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 10.0.2.1/32 is directly connected, Loopback0
O 10.0.3.1/32 [110/2] via 10.0.140.2, 00:19:04, FastEthernet2/0
[110/2] via 10.0.120.2, 00:19:04, FastEthernet1/1
O 10.0.4.1/32 [110/3] via 10.0.4.1, 00:19:04, Tunnel1000
O 10.0.110.0/30 [110/2] via 10.0.140.2, 00:19:04, FastEthernet2/0
[110/2] via 10.0.120.2, 00:19:04, FastEthernet1/1
C 10.0.120.0/30 is directly connected, FastEthernet1/1
L 10.0.120.1/32 is directly connected, FastEthernet1/1
O 10.0.130.0/30 [110/2] via 10.0.140.2, 00:19:04, FastEthernet2/0
[110/2] via 10.0.120.2, 00:19:04, FastEthernet1/1
C 10.0.140.0/30 is directly connected, FastEthernet2/0
L 10.0.140.1/32 is directly connected, FastEthernet2/0
edge1.noc#show mpls forwarding-table 10.0.4.1
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
17 [T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point
[T] Pop Label 10.0.4.1/32 0 Tu1000 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.noc#

**************
Multicast
**************

Internet#ping 239.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.1.1.1, timeout is 2 seconds:

Reply to request 0 from 10.10.10.4, 1212 ms
Reply to request 0 from 10.10.10.4, 1212 ms
Internet#ping 239.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.2.2.2, timeout is 2 seconds:

Reply to request 0 from 10.10.10.4, 1544 ms
Reply to request 0 from 10.10.10.4, 1544 ms
Internet#

CE_LAN#mtrace 172.16.101.1 192.168.101.1 239.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 192.168.101.1 via group 239.1.1.1
From source (?) to destination (?)
Querying full reverse path...
0 192.168.101.1
-1 192.168.101.1 PIM [default]
-2 192.168.101.1 PIM Prune sent upstream [default]
-3 172.16.1.2 PIM/MBGP Reached RP/Core [172.16.101.0/24]
-4 172.16.1.1 PIM Reached RP/Core [172.16.101.0/24]
CE_LAN#

CE_LAN#sh ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet0/0 01:41:19/00:01:23 v2 1 / DR S
CE_LAN#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
RP 10.0.1.1 (?), v2
Info source: 10.0.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:42:40, expires: 00:02:22
CE_LAN#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.2.2.2), 00:16:50/00:02:57, RP 10.0.1.1, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 192.168.1.2
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:16:50/00:02:57

(*, 224.0.1.40), 00:16:50/00:02:58, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:16:50/00:00:00

CE_LAN#

LAN_GW#sh ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.2 Dialer1 00:45:07/00:01:20 v2 1 / S
0.0.0.0 Dialer1 01:11:15/now 0 / DR
192.168.1.1 FastEthernet0/0 01:42:14/00:01:28 v2 1 / S
LAN_GW#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
RP 10.0.1.1 (?), v2
Info source: 10.0.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:43:06, expires: 00:01:56
LAN_GW#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:17:07/stopped, RP 10.0.1.1, flags: SJPCL
Incoming interface: Dialer1, RPF nbr 172.16.1.2
Outgoing interface list: Null

(*, 239.2.2.2), 00:16:16/00:03:01, RP 10.0.1.1, flags: S
Incoming interface: Dialer1, RPF nbr 172.16.1.2
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:16:16/00:03:01

(*, 224.0.1.40), 00:17:07/00:02:32, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:17:07/00:00:00
Dialer1, Forward/Sparse-Dense, 00:17:07/00:00:00

LAN_GW#

BRAS#sh ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.1 FastEthernet1/1 01:45:10/00:01:15 v2 1 / S G
10.10.10.4 Virtual-Access1.1 00:43:32/00:01:30 v2 1 / S G
BRAS#sh ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)

Group(s) 224.0.0.0/4
RP 10.0.1.1 (?), v2
Info source: 10.0.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 01:46:55, expires: 00:01:34
BRAS#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:16:55/00:03:19, RP 10.0.1.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Virtual-Access1.1, Forward/Sparse-Dense, 00:16:55/00:03:19

(*, 239.2.2.2), 00:17:04/00:03:12, RP 10.0.1.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Virtual-Access1.1, Forward/Sparse-Dense, 00:17:04/00:03:12

(*, 224.0.1.40), 00:17:04/00:02:59, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Virtual-Access1.1, Forward/Sparse-Dense, 00:17:04/00:00:00
FastEthernet1/1, Forward/Sparse-Dense, 00:17:04/00:00:00
Loopback0, Forward/Sparse-Dense, 00:17:04/00:00:00

BRAS#

BRAS#sh ip msdp summary
MSDP Peer Status Summary
Peer Address AS State Uptime/ Reset SA Peer Name
Downtime Count Count
172.16.1.1 64514 Up 02:18:17 1 0 ?
BRAS#sh ip msdp peer
MSDP Peer 172.16.1.1 (?), AS 64514 (configured AS)
Connection status:
State: Up, Resets: 1, Connection source: none configured
Uptime(Downtime): 02:18:20, Messages sent/received: 182/159
Output messages discarded: 0
Connection and counters cleared 02:18:47 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Number of connection transitions to Established state: 2
Input queue size: 0, Output queue size: 0
MD5 signature protection on MSDP TCP connection: not enabled
Message counters:
RPF Failure count: 0
SA Messages in/out: 72/66
SA Requests in: 0
SA Responses out: 0
Data Packets in/out: 11/36
BRAS#

Internet#sh ip pim neighbor
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.2 FastEthernet0/0 01:46:02/00:01:42 v2 1 / DR S
Internet#sh ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)

Group(s) 224.0.0.0/4
RP 172.16.101.1 (?), v2
Info source: 172.16.101.1 (?), via bootstrap, priority 0, holdtime 210
Uptime: 01:48:10, expires: 00:03:16
Internet#show ip msdp summary
MSDP Peer Status Summary
Peer Address AS State Uptime/ Reset SA Peer Name
Downtime Count Count
172.16.1.2 64513 Up 02:17:37 0 0 ?
Internet#show ip msdp peer
MSDP Peer 172.16.1.2 (?), AS 64513
Connection status:
State: Up, Resets: 0, Connection source: FastEthernet0/0 (172.16.1.1)
Uptime(Downtime): 02:17:40, Messages sent/received: 159/182
Output messages discarded: 0
Connection and counters cleared 02:17:41 ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Peer ttl threshold: 0
SAs learned from this peer: 0
Input queue size: 0, Output queue size: 0
Internet#

****************
QoS
****************
edge1.pop1#show class-map

Class Map match-all EXP_5 (id 2)
Match mpls experimental topmost 5

Class Map match-any class-default (id 0)
Match any

Class Map match-all DSLBB (id 1)
Match any

edge1.pop1#show policy-map

Policy Map Core_Out
Class EXP_5
Policy Map DSLBB
Class DSLBB
set mpls experimental imposition 5
edge1.pop1#

edge1.pop1#show policy-map interface f1/0 input
FastEthernet1/0

Service-policy input: DSLBB

Class-map: DSLBB (match-all)
475 packets, 37197 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
QoS Set
mpls experimental imposition 5
Packets marked 479

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps
edge1.pop1#show policy-map interface f2/0 output
FastEthernet2/0

Service-policy output: Core_Out

Class-map: EXP_5 (match-all)
479 packets, 49923 bytes
5 minute offered rate 0000 bps
Match: mpls experimental topmost 5

Class-map: class-default (match-any)
994 packets, 94777 bytes
5 minute offered rate 0000 bps, drop rate 0000 bps
Match: any
994 packets, 94777 bytes
5 minute rate 0 bps
edge1.pop1#

No comments:

Post a Comment