Monday, June 7, 2010

Implementing PIM SSM for MPLS Backbone to provide Multimedia Services LAB














Configuration Guidelines
**********************************************************************
Scenario: An ISP wants to offer Multimedia Services such as Video
on Demand,IPTV e.t.c over his MPLS enabled Service Provider Backbone.
Also ISP is using MPLS TE across his Core for Optimal Utilization of
BW. Also here ISP is peering to two CSP (Content Service Providers)A
& B but ISP will not act as a Transit AS to them.

Design Considerations:

Multimedia Services such as VoD and IPTV are based on IP Multicast
Technology whererby a Content Service Provider Offers the Multimedia
over Multicast Streams in a one-to-many fashion.

SP Backbone has MPLS TE enabled and hence care should be taken to not
break the Multicast Traffic as the RPF would fail for Multicast Stream
in case of TE until unless we define static mroutes(not scalable)
for all the Multicast Source /Receivers.Other option is to disable
the Multicast RPF check(multicast traffic-eng multicast-intact)
over TE Tunnel Path and instead use the normal
IP Routing Path.

The ISM (Internet Standard Multicast ) has more Multicast States
maintained in the Core as the Number of Multicast Receivers increases
To overcome this Memory and CPU Intensive limitation we can use
SSM (Source Specific Multicast) whereby each Multicast Receiver
explicitly joins to a Multicast Source for a particulat Multicast
(Set Top Box) Group it wants to receive traffic,Multicast Receivers signal
membership for a particular group using IGMPv3.
Hence there is just (S,G) entries across Core and there is no Shared Tree
Needed and hence no RP needed.

Multicast Receivers signal membership for a particular group using IGMPv3

For ISP to not work as a Transit AS between the CSPs ,ISP is using AS Path
Filters to dynamically just advertise its own routes to them and
communities to send dyamically Customer Unicast Routes to them.

ISP is also using communities to dyamically send CSP Unicast Routes to
Customers

ISP is also using Port-Channel across his Core Backbone Links for increased BW and
PPP Multilink/FR Multilink on CE/CSP Links for better BW

ISP AS used 64513
IGP used Area 0
PIM SM used on Core Links and PIM SSM enabled.
PIM SSM range 239.0.0.0/8
AS-Path Access List used 13 to permit ^$
Customer Communities used 64513:513
E-ISP communities used 64513:999

Customer AS used 64516
PE-CE used EBGP
PIM SM used on PE-CE Links

CSPA AS used 64515
PE-CE used EBGP
PIM SM used on PE-CSP Link
CSPA Multicast Groups 239.115.115.115 & 239.251.251.251

CSPB AS used 64514
PE-CE used EBGP
PIM SM used on PE-CSP Link
CSPA Multicast Groups 239.114.114.114 & 239.151.151.151





**********************************************************************


cus1.pop1#sh running-config
Building configuration...

Current configuration : 2290 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.101.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.151.151.151 source 172.16.101.1
ip igmp join-group 239.251.251.251 source 192.168.101.1
!
interface Loopback1
ip address 10.0.151.1 255.255.255.0
!
interface Multilink16
description edge1.pop1
ip address 10.0.110.2 255.255.255.252
ip pim sparse-mode
ip igmp join-group 239.151.151.151 source 172.16.101.1
ip igmp join-group 239.251.251.251 source 192.168.101.1
ppp multilink
ppp multilink group 16
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop1-Mu16-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/1
description edge1.pop1-Mu16-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64516
bgp router-id 10.0.101.1
bgp log-neighbor-changes
neighbor 10.0.110.1 remote-as 64517
neighbor 10.0.110.1 description eBGP-edge1.pop1
!
address-family ipv4
neighbor 10.0.110.1 activate
neighbor 10.0.110.1 capability orf prefix-list receive
neighbor 10.0.110.1 allowas-in 5
neighbor 10.0.110.1 soft-reconfiguration inbound
no auto-summary
no synchronization
network 10.0.101.0 mask 255.255.255.0
network 10.0.110.0 mask 255.255.255.252
network 10.0.151.0 mask 255.255.255.0
exit-address-family
!
ip http server
!
!
ip pim ssm range 13
!
access-list 13 permit 239.0.0.0 0.255.255.255
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

cus1.pop1#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 2221 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.201.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 239.114.114.114 source 172.16.101.1
ip igmp join-group 239.115.115.115 source 192.168.101.1
!
interface Loopback1
ip address 10.0.151.1 255.255.255.0
!
interface Multilink16
description edge1.pop1
ip address 10.0.120.2 255.255.255.252
ip pim sparse-mode
ip igmp join-group 239.114.114.114 source 172.16.101.1
ip igmp join-group 239.115.115.115 source 192.168.101.1
ppp multilink
ppp multilink group 16
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop2-Mu16-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
ppp multilink
ppp multilink group 16
!
interface Serial1/1
description edge1.pop2-Mu16-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64516
bgp router-id 10.0.201.1
bgp log-neighbor-changes
neighbor 10.0.120.1 remote-as 64517
neighbor 10.0.120.1 description eBGP-edge1.pop2
!
address-family ipv4
neighbor 10.0.120.1 activate
neighbor 10.0.120.1 allowas-in 5
neighbor 10.0.120.1 soft-reconfiguration inbound
no auto-summary
no synchronization
network 10.0.120.0 mask 255.255.255.252
network 10.0.201.0 mask 255.255.255.0
exit-address-family
!
ip http server
!
!
ip pim ssm range 13
!
access-list 13 permit 239.0.0.0 0.255.255.255
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end

cus1.pop2#

CSPA#sh running-config
Building configuration...

Current configuration : 1739 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CSPA
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.0
ip pim sparse-mode
!
interface Multilink15
description edge1.pop2-Mu15
ip address 192.168.10.2 255.255.255.252
ip pim sparse-mode
ppp multilink
ppp multilink group 15
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop2-Mu15-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 15
!
interface Serial1/1
description edge1.pop2-Mu15-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 15
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64515
no synchronization
bgp router-id 192.168.101.1
bgp log-neighbor-changes
network 192.168.0.0 mask 255.255.0.0
neighbor 192.168.10.1 remote-as 64513
neighbor 192.168.10.1 description eBGP-edge1.pop2
neighbor 192.168.10.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip route 192.168.0.0 255.255.0.0 Null0
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CSPA#

CSPB#sh running-config
Building configuration...

Current configuration : 1792 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CSPB
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-mode
!
interface MFR14
description edge1.pop2
ip address 172.16.10.2 255.255.255.252
ip pim sparse-mode
no arp frame-relay
frame-relay interface-dlci 114
frame-relay lmi-type cisco
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description edge1.pop2-MFR14-L1
no ip address
encapsulation frame-relay MFR14
serial restart-delay 0
no dce-terminal-timing-enable
no arp frame-relay
frame-relay multilink lid ISPB-MFR14-L1
!
interface Serial1/1
description edge1.pop2-MFR14-L2
no ip address
encapsulation frame-relay MFR14
serial restart-delay 0
no dce-terminal-timing-enable
no arp frame-relay
frame-relay multilink lid ISPB-MFR14-L2
!
interface Serial1/2
no ip address
shutdown
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.0.0
neighbor 172.16.10.1 remote-as 64513
neighbor 172.16.10.1 description eBGP-edge1.pop2
neighbor 172.16.10.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip route 172.16.0.0 255.255.0.0 Null0
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

CSPB#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 4640 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
description TE
ip unnumbered lo0
tunnel destination 10.0.4.1
ip pim sparse-mode
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name TE
no routing dynamic
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
ip pim sparse-mode
!
interface Multilink16
description cus1.pop1
ip address 10.0.110.1 255.255.255.252
ip pim sparse-mode
ip igmp join-group 239.151.151.151 source 172.16.101.1
ip igmp join-group 239.251.251.251 source 192.168.101.1
ip igmp v3lite
ppp multilink
ppp multilink group 16
!
interface MFR16
ip address 10.0.110.1 255.255.255.252
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description cus1.pop1-Mu16-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/1
description cus1.pop1-Mu16-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/2
description core1.pop1-L1
ip address 10.0.10.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 102
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial1/3
description core1.pop1-L2
ip address 10.0.20.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 103
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
router-id 10.0.1.1
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute bgp 64513 subnets route-map cus_routes
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.4.1 peer-group iBGP
neighbor 10.0.110.2 remote-as 64516
neighbor 10.0.110.2 local-as 64517
neighbor 10.0.110.2 description eBGP-cus1.pop1
!
address-family ipv4
neighbor iBGP send-community
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.4.1 activate
neighbor 10.0.110.2 activate
neighbor 10.0.110.2 capability orf prefix-list send
neighbor 10.0.110.2 soft-reconfiguration inbound
neighbor 10.0.110.2 prefix-list cus1.pop1 in
neighbor 10.0.110.2 route-map cus_standard_mpls in
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.4.1 activate
exit-address-family
!
no ip http server
no ip http secure-server
!
ip bgp-community new-format
ip community-list standard cus_routes permit 64513:513
!
ip pim ssm range 13
!
ip explicit-path name TE enable
next-address 10.0.10.2
next-address 10.0.30.2
next-address 10.0.50.1
!
!
ip prefix-list cus1.pop1 seq 5 permit 10.0.110.0/30
ip prefix-list cus1.pop1 seq 10 permit 10.0.101.0/24
logging alarm informational
access-list 13 permit 239.0.0.0 0.255.255.255
route-map cus_routes permit 10
match community cus_routes
!
route-map Local permit 10
match interface Multilink16
!
route-map cus_standard_mpls permit 10
set community 64513:513
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

edge1.pop1#

core1.pop1#sh running-config
Building configuration...

Current configuration : 2740 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip pim sparse-mode
!
interface Port-channel13
description core1.pop2
ip address 10.0.30.1 255.255.255.252
ip pim sparse-mode
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
hold-queue 150 in
ip rsvp bandwidth
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-po13-L1
no ip address
negotiation auto
channel-group 13
!
interface GigabitEthernet2/0
description core1.pop1-po13-L2
no ip address
negotiation auto
channel-group 13
!
interface Serial3/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 201
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial3/1
description edge1.pop1-L2
ip address 10.0.20.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
shutdown
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 301
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/4
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/5
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/6
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/7
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
no ip http server
no ip http secure-server
!
!
ip pim ssm range 13
!
logging alarm informational
access-list 13 permit 239.0.0.0 0.255.255.255
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

core1.pop1#

core1.pop2#sh running-config
Building configuration...

Current configuration : 2730 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname core1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
ip pim sparse-mode
!
interface Port-channel13
description core1.pop1
ip address 10.0.30.2 255.255.255.252
ip pim sparse-mode
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
hold-queue 150 in
ip rsvp bandwidth
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-po13-L1
no ip address
negotiation auto
channel-group 13
!
interface GigabitEthernet2/0
description core1.pop1-po13-L2
no ip address
negotiation auto
channel-group 13
!
interface Serial3/0
description edge1.pop2-L1
ip address 10.0.50.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 201
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial3/1
description edge1.pop2-L2
ip address 10.0.60.2 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 301
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/4
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/5
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/6
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial3/7
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
!
no ip http server
no ip http secure-server
!
!
ip pim ssm range 13
!
logging alarm informational
access-list 13 permit 239.0.0.0 0.255.255.255
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

core1.pop2#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 6024 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
frame-relay switching
mpls label protocol ldp
mpls traffic-eng tunnels
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel100
description TE
ip unnumbered lo0
tunnel destination 10.0.1.1
ip pim sparse-mode
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name TE
no routing dynamic
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
ip pim sparse-mode
!
interface Multilink15
description ISPA
ip address 192.168.10.1 255.255.255.252
ip pim sparse-mode
ppp multilink
ppp multilink group 15
!
interface Multilink16
description cus1.pop2
ip address 10.0.120.1 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 239.114.114.114 source 172.16.101.1
ip igmp join-group 239.115.115.115 source 192.168.101.1
ppp multilink
ppp multilink group 16
!
interface MFR14
description ISPB
ip address 172.16.10.1 255.255.255.252
ip pim sparse-mode
frame-relay interface-dlci 114
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description ISPA-Mu15-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 15
!
interface Serial1/1
description ISPA-Mu15-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 15
!
interface Serial1/2
description ISPB-MFR14-L1
no ip address
encapsulation frame-relay MFR14
serial restart-delay 0
no dce-terminal-timing-enable
no arp frame-relay
frame-relay multilink lid ISPB-MFR14-L1
!
interface Serial1/3
description ISPB-MFR14-L2
no ip address
encapsulation frame-relay MFR14
serial restart-delay 0
no dce-terminal-timing-enable
no arp frame-relay
frame-relay multilink lid ISPB-MFR14-L2
!
interface Serial1/4
description cus1.pop2-Mu16-L1
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/5
description cus1.pop2-Mu16-L2
no ip address
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp multilink
ppp multilink group 16
!
interface Serial1/6
description core1.pop2-L1
ip address 10.0.50.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 102
frame-relay lmi-type ansi
ip rsvp bandwidth
!
interface Serial1/7
description core1.pop2-L2
ip address 10.0.60.1 255.255.255.252
ip pim sparse-mode
encapsulation frame-relay
ip ospf network point-to-point
mpls label protocol ldp
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 103
frame-relay lmi-type ansi
ip rsvp bandwidth
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
router-id 10.0.4.1
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute bgp 64513 subnets route-map e-ISP-routes
network 10.0.0.0 0.255.255.255 area 0
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.120.2 remote-as 64516
neighbor 10.0.120.2 local-as 64517
neighbor 10.0.120.2 description eBGP-cus1.pop2
neighbor 172.16.10.2 remote-as 64514
neighbor 172.16.10.2 description eBGP-ISPB
neighbor 192.168.10.2 remote-as 64515
neighbor 192.168.10.2 description eBGP-ISPA
!
address-family ipv4
neighbor iBGP send-community
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.120.2 activate
neighbor 10.0.120.2 capability orf prefix-list send
neighbor 10.0.120.2 soft-reconfiguration inbound
neighbor 10.0.120.2 prefix-list cus1.pop1 in
neighbor 10.0.120.2 route-map cus_standard_mpls in
neighbor 172.16.10.2 activate
neighbor 172.16.10.2 soft-reconfiguration inbound
neighbor 172.16.10.2 route-map e-ISP-in in
neighbor 172.16.10.2 route-map e-ISP out
neighbor 192.168.10.2 activate
neighbor 192.168.10.2 soft-reconfiguration inbound
neighbor 192.168.10.2 route-map e-ISP-in in
neighbor 192.168.10.2 route-map e-ISP out
no auto-summary
no synchronization
network 10.0.0.0
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.1.1 activate
exit-address-family
!
ip route 10.0.0.0 255.0.0.0 Null0
no ip http server
no ip http secure-server
!
ip bgp-community new-format
ip community-list standard ISP_cus_standard_mpls permit 64513:513
ip community-list standard e-ISP permit 64513:999
ip as-path access-list 13 permit ^$
!
ip pim ssm range 13
!
ip explicit-path name TE enable
next-address 10.0.50.2
next-address 10.0.30.1
next-address 10.0.10.1
!
logging alarm informational
access-list 13 permit 239.0.0.0 0.255.255.255
route-map e-ISP permit 10
match as-path 13
!
route-map e-ISP permit 20
match community ISP_cus_standard_mpls
!
route-map e-ISP-routes permit 10
match community e-ISP
!
route-map e-ISP-in permit 10
set community 64513:999
!
route-map Local permit 10
match interface Multilink16 MFR14 Multilink15
!
route-map cus_standard_mpls permit 10
set community 64513:513
!
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

edge1.pop2#

*********************************
OUTPUT
*********************************
MULTICAST ROUTING
*********************************

CSPA#ping 239.115.115.115 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.115.115.115, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 192.168.10.1, 132 ms
Reply to request 0 from 10.0.120.2, 712 ms
ISPA#

cus1.pop1#mtrace 172.16.101.1 10.0.101.1 239.151.151.151
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 10.0.101.1 via group 239.151.151.151
From source (?) to destination (?)
Querying full reverse path...
0 10.0.101.1
-1 10.0.101.1 PIM [172.16.0.0/16]
-2 10.0.110.1 PIM [172.16.0.0/16]
-3 10.0.10.2 PIM [172.16.0.0/16]
-4 10.0.30.2 PIM [172.16.0.0/16]
-5 10.0.60.1 PIM [172.16.0.0/16]
-6 172.16.10.2 PIM [172.16.101.0/24]
-7 172.16.101.1
cus1.pop1#

cus1.pop1#mtrace 192.168.101.1 10.0.101.1 239.251.251.251
Type escape sequence to abort.
Mtrace from 192.168.101.1 to 10.0.101.1 via group 239.251.251.251
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 10.0.101.1
-1 10.0.101.1 PIM [192.168.0.0/16]
-2 10.0.110.1 PIM [192.168.0.0/16]
-3 10.0.10.2 PIM [192.168.0.0/16]
-4 10.0.30.2 PIM [192.168.0.0/16]
-5 10.0.60.1 PIM [192.168.0.0/16]
-6 * * * 192.168.10.2 [version 12.4] didn't respond

cus1.pop1#

cus1.pop2#mtrace 172.16.101.1 10.0.201.1 239.114.114.114
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 10.0.201.1 via group 239.114.114.114
From source (?) to destination (?)
Querying full reverse path...
0 10.0.201.1
-1 10.0.201.1 PIM [172.16.0.0/16]
-2 10.0.120.1 PIM [172.16.0.0/16]
-3 172.16.10.2 PIM [172.16.101.0/24]
-4 172.16.101.1
cus1.pop2#mtrace 192.168.101.1 10.0.201.1 239.115.115.115
Type escape sequence to abort.
Mtrace from 192.168.101.1 to 10.0.201.1 via group 239.115.115.115
From source (?) to destination (?)
Querying full reverse path...
0 10.0.201.1
-1 10.0.201.1 PIM [192.168.0.0/16]
-2 10.0.120.1 PIM [192.168.0.0/16]
-3 192.168.10.2 PIM [192.168.101.0/24]
-4 192.168.101.1
cus1.pop2#



*************************
MULTICAST RPF
***************************
edge1.pop2#sh ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: Multilink15
RPF neighbor: ? (192.168.10.2)
RPF route/mask: 192.168.0.0/16
RPF type: unicast (bgp 64513)
RPF recursion count: 0
Doing distance-preferred lookups across tables
edge1.pop2#sh ip rpf 10.0.101.1
RPF information for ? (10.0.101.1)
RPF interface: Serial1/6
RPF neighbor: ? (0.0.0.0)
RPF route/mask: 10.0.0.0/8
RPF type: static
RPF recursion count: 0
Doing distance-preferred lookups across tables
edge1.pop2#

edge1.pop1#show ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: Serial1/2
RPF neighbor: ? (0.0.0.0)
RPF route/mask: 192.168.0.0/16
RPF type: static
RPF recursion count: 0
Doing distance-preferred lookups across tables
edge1.pop1#show ip rpf 172.16.101.1
RPF information for ? (172.16.101.1)
RPF interface: Serial1/2
RPF neighbor: ? (0.0.0.0)
RPF route/mask: 172.16.0.0/16
RPF type: static
RPF recursion count: 0
Doing distance-preferred lookups across tables
edge1.pop1#


CSPA#sh ip mroute 239.251.251.251
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.251.251.251), 00:02:00/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Multilink15, Forward/Sparse-Dense, 00:02:00/00:00:00

(192.168.101.1, 239.251.251.251), 00:02:00/00:01:29, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Multilink15, Forward/Sparse-Dense, 00:02:00/00:00:00

ISPA#
********************
IP ROUTING
********************

cus1.pop1#traceroute 10.0.201.1

Type escape sequence to abort.
Tracing the route to 10.0.201.1

1 10.0.110.1 616 msec 260 msec 184 msec
2 10.0.10.2 [AS 64513] 920 msec 344 msec 1004 msec
3 10.0.30.2 [AS 64513] 908 msec 2084 msec 692 msec
4 10.0.50.1 [AS 64513] 1008 msec 1512 msec 692 msec
5 10.0.120.2 [AS 64516] 1676 msec 712 msec 796 msec
cus1.pop1#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.110.1 168 msec 760 msec 1032 msec
2 10.0.10.2 [AS 64513] 704 msec 2020 msec 1764 msec
3 10.0.30.2 [AS 64513] 1208 msec 1468 msec 1580 msec
4 10.0.50.1 [AS 64513] 940 msec 688 msec 668 msec
5 172.16.10.2 [AS 64514] 8 msec 904 msec *
cus1.pop1#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 10.0.110.1 364 msec 248 msec 304 msec
2 10.0.10.2 [AS 64513] 1084 msec 1644 msec 836 msec
3 10.0.30.2 [AS 64513] 1140 msec 372 msec 768 msec
4 10.0.50.1 [AS 64513] 1000 msec 1900 msec 884 msec
5 192.168.10.2 [AS 64515] 2412 msec 2384 msec 1616 msec
cus1.pop1#



cus1.pop2#traceroute 10.0.101.1

Type escape sequence to abort.
Tracing the route to 10.0.101.1

1 10.0.120.1 236 msec 308 msec 696 msec
2 10.0.50.2 [AS 64513] 884 msec 1564 msec 2268 msec
3 10.0.30.1 [AS 64513] 548 msec 1548 msec 264 msec
4 10.0.10.1 [AS 64513] 920 msec 1060 msec 1776 msec
5 10.0.110.2 [AS 64516] 2224 msec 1360 msec 1208 msec
cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 10.0.120.1 328 msec 400 msec 488 msec
2 172.16.10.2 [AS 64514] 460 msec 876 msec 468 msec
cus1.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 10.0.120.1 128 msec 96 msec 72 msec
2 192.168.10.2 [AS 64515] 788 msec * 84 msec
cus1.pop2#

CSPA#traceroute 10.0.101.1

Type escape sequence to abort.
Tracing the route to 10.0.101.1

1 192.168.10.1 284 msec 404 msec 1000 msec
2 10.0.50.2 [AS 64513] 1504 msec 492 msec *
3 10.0.30.1 [AS 64513] 1000 msec 624 msec 372 msec
4 10.0.10.1 [AS 64513] 2200 msec 1008 msec 788 msec
5 *
10.0.110.2 [AS 64516] 2212 msec 2776 msec
CSPA#traceroute 10.0.201.1

Type escape sequence to abort.
Tracing the route to 10.0.201.1

1 192.168.10.1 1008 msec 196 msec 48 msec
2 10.0.120.2 [AS 64516] 1996 msec 484 msec 12 msec
CSPA#
CSPA#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 * * *
2
CSPA#

CSPB#traceroute 10.0.101.1

Type escape sequence to abort.
Tracing the route to 10.0.101.1

1 172.16.10.1 672 msec 144 msec 344 msec
2 10.0.50.2 [AS 64513] 840 msec 552 msec 1488 msec
3 10.0.30.1 [AS 64513] 1584 msec 1288 msec 1080 msec
4 *
10.0.10.1 [AS 64513] 1032 msec 948 msec
5 10.0.110.2 [AS 64516] 1424 msec 1412 msec *
CSPB#traceroute 10.0.201.1

Type escape sequence to abort.
Tracing the route to 10.0.201.1

1 172.16.10.1 324 msec 364 msec 484 msec
2 10.0.120.2 [AS 64516] 1124 msec * 284 msec
CSPB#
CSPB#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 * * *
2
CSPB#

*************************
UNICAST ROUTIG TABLE
*************************

cus1.pop1#sh ip bgp summary
BGP router identifier 10.0.101.1, local AS number 64516
BGP table version is 77, main routing table version 77
8 network entries using 936 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2192 total bytes of memory
BGP activity 33/25 prefixes, 43/35 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.110.1 4 64517 279 244 77 0 0 00:25:38 5

cus1.pop1#sh ip bgp
BGP table version is 77, local router ID is 10.0.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 10.0.110.1 0 64517 64513 i
*> 10.0.101.0/24 0.0.0.0 0 32768 i
*> 10.0.110.0/30 0.0.0.0 0 32768 i
*> 10.0.120.0/30 10.0.110.1 0 64517 64513 64517 6
4516 i
*> 10.0.151.0/24 0.0.0.0 0 32768 i
*> 10.0.201.0/24 10.0.110.1 0 64517 64513 64517 6
4516 i
*> 172.16.0.0 10.0.110.1 0 64517 64513 64514 i
*> 192.168.0.0/16 10.0.110.1 0 64517 64513 64515 i
cus1.pop1#

cus1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B 172.16.0.0/16 [20/0] via 10.0.110.1, 00:23:10
10.0.0.0/8 is variably subnetted, 7 subnets, 4 masks
B 10.0.0.0/8 [20/0] via 10.0.110.1, 00:24:42
C 10.0.110.0/30 is directly connected, Multilink16
C 10.0.110.1/32 is directly connected, Multilink16
C 10.0.101.0/24 is directly connected, Loopback0
B 10.0.120.0/30 [20/0] via 10.0.110.1, 00:23:42
C 10.0.151.0/24 is directly connected, Loopback1
B 10.0.201.0/24 [20/0] via 10.0.110.1, 00:23:42
B 192.168.0.0/16 [20/0] via 10.0.110.1, 00:23:42
cus1.pop1#

edge1.pop1#sh ip bgp summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 107, main routing table version 107
7 network entries using 819 bytes of memory
9 path entries using 468 bytes of memory
7/5 BGP path/bestpath attribute entries using 868 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
2 BGP community entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2275 total bytes of memory
2 received paths for inbound soft reconfiguration
BGP activity 22/15 prefixes, 34/25 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.4.1 4 64513 245 239 107 0 0 00:32:45 5
10.0.110.2 4 64516 243 280 107 0 0 00:26:24 2

edge1.pop1#sh ip ospf int bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Tu100 1 0 0.0.0.0/0 11111 P2P 0/0
Lo0 1 0 10.0.1.1/32 1 LOOP 0/0
Mu16 1 0 10.0.110.1/30 32 P2P 0/0
MF16 1 0 10.0.110.1/30 1 DOWN 0/0
Se1/3 1 0 10.0.20.1/30 64 DOWN 0/0
Se1/2 1 0 10.0.10.1/30 64 P2P 1/1
edge1.pop1#sh ip osp nei

Neighbor ID Pri State Dead Time Address Interface
10.0.2.1 0 FULL/ - 00:00:36 10.0.10.2 Serial1/2
edge1.pop1#
edge1.pop1#sh ip ospf database

OSPF Router with ID (10.0.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.0.1.1 10.0.1.1 1642 0x80000012 0x007211 4
10.0.2.1 10.0.2.1 1575 0x8000000E 0x008543 4
10.0.3.1 10.0.3.1 1525 0x80000015 0x00D45C 6
10.0.4.1 10.0.4.1 1978 0x80000014 0x00B82D 6

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.0.30.2 10.0.3.1 1576 0x80000001 0x0038B1

Type-10 Opaque Link Area Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Opaque ID
1.0.0.0 10.0.1.1 1997 0x8000000C 0x00D9F1 0
1.0.0.0 10.0.2.1 1354 0x8000000B 0x0034D9 0
1.0.0.0 10.0.3.1 1525 0x8000000B 0x00EE87 0
1.0.0.0 10.0.4.1 1525 0x8000000F 0x00D39D 0
1.0.0.1 10.0.2.1 103 0x8000000A 0x009352 1
1.0.0.1 10.0.3.1 1524 0x80000008 0x00C0BE 1
1.0.0.1 10.0.4.1 1525 0x80000003 0x00B6CD 1
1.0.0.2 10.0.2.1 1575 0x80000001 0x00A5B0 2
1.0.0.3 10.0.3.1 1582 0x80000001 0x00B2A0 3

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
10.0.101.0 10.0.1.1 1588 0x80000005 0x00032F 64517
10.0.110.2 10.0.1.1 1615 0x8000000A 0x0019F7 0
10.0.120.2 10.0.4.1 1525 0x80000003 0x00A367 0
172.16.0.0 10.0.4.1 1468 0x80000001 0x0018D0 64514
172.16.10.0 10.0.4.1 1500 0x80000007 0x00596E 0
192.168.0.0 10.0.4.1 1492 0x80000001 0x00FD3D 64515
192.168.10.0 10.0.4.1 1510 0x80000005 0x0031EB 0
192.168.10.2 10.0.4.1 1510 0x80000005 0x002FE8 0
edge1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
O E2 192.168.10.2/32 [110/20] via 0.0.0.0, 00:13:00, Tunnel100
O E2 192.168.10.0/30 [110/20] via 0.0.0.0, 00:13:00, Tunnel100
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2 172.16.10.0/30 [110/20] via 0.0.0.0, 00:13:00, Tunnel100
O E2 172.16.0.0/16 [110/1] via 0.0.0.0, 00:13:00, Tunnel100
10.0.0.0/8 is variably subnetted, 15 subnets, 4 masks
C 10.0.10.0/30 is directly connected, Serial1/2
O 10.0.3.1/32 [110/66] via 10.0.10.2, 00:13:00, Serial1/2
O 10.0.2.1/32 [110/65] via 10.0.10.2, 00:13:00, Serial1/2
C 10.0.1.1/32 is directly connected, Loopback0
B 10.0.0.0/8 [200/0] via 10.0.4.1, 00:25:19
O 10.0.4.1/32 [110/130] via 0.0.0.0, 00:13:00, Tunnel100
O 10.0.30.0/30 [110/65] via 10.0.10.2, 00:13:00, Serial1/2
O 10.0.60.0/30 [110/129] via 10.0.10.2, 00:13:00, Serial1/2
O 10.0.50.0/30 [110/129] via 10.0.10.2, 00:13:00, Serial1/2
C 10.0.110.0/30 is directly connected, Multilink16
C 10.0.110.2/32 is directly connected, Multilink16
B 10.0.101.0/24 [20/0] via 10.0.110.2, 00:26:40
O E2 10.0.120.2/32 [110/20] via 0.0.0.0, 00:13:00, Tunnel100
O 10.0.120.0/30 [110/161] via 0.0.0.0, 00:13:00, Tunnel100
B 10.0.201.0/24 [200/0] via 10.0.4.1, 00:25:05
O E2 192.168.0.0/16 [110/1] via 0.0.0.0, 00:13:00, Tunnel100
edge1.pop1#

core1.pop1#sh ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 1 0 10.0.2.1/32 1 LOOP 0/0
Po13 1 0 10.0.30.1/30 1 BDR 1/1
Se3/1 1 0 10.0.20.2/30 64 DOWN 0/0
Se3/0 1 0 10.0.10.2/30 64 P2P 1/1
core1.pop1#sh ip osp nei

Neighbor ID Pri State Dead Time Address Interface
10.0.3.1 1 FULL/DR 00:00:36 10.0.30.2 Port-channel13
10.0.1.1 0 FULL/ - 00:00:31 10.0.10.1 Serial3/0
core1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
O E2 192.168.10.2/32 [110/20] via 10.0.30.2, 00:26:40, Port-channel13
O E2 192.168.10.0/30 [110/20] via 10.0.30.2, 00:26:40, Port-channel13
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2 172.16.10.0/30 [110/20] via 10.0.30.2, 00:26:32, Port-channel13
O E2 172.16.0.0/16 [110/1] via 10.0.30.2, 00:25:59, Port-channel13
10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
C 10.0.10.0/30 is directly connected, Serial3/0
O 10.0.3.1/32 [110/2] via 10.0.30.2, 00:27:02, Port-channel13
C 10.0.2.1/32 is directly connected, Loopback0
O 10.0.1.1/32 [110/65] via 10.0.10.1, 00:27:02, Serial3/0
O 10.0.4.1/32 [110/66] via 10.0.30.2, 00:27:02, Port-channel13
C 10.0.30.0/30 is directly connected, Port-channel13
O 10.0.60.0/30 [110/65] via 10.0.30.2, 00:27:04, Port-channel13
O 10.0.50.0/30 [110/65] via 10.0.30.2, 00:27:04, Port-channel13
O 10.0.110.0/30 [110/96] via 10.0.10.1, 00:27:04, Serial3/0
O E2 10.0.110.2/32 [110/20] via 10.0.10.1, 00:27:04, Serial3/0
O E2 10.0.101.0/24 [110/1] via 10.0.10.1, 00:27:04, Serial3/0
O E2 10.0.120.2/32 [110/20] via 10.0.30.2, 00:27:04, Port-channel13
O 10.0.120.0/30 [110/97] via 10.0.30.2, 00:27:04, Port-channel13
O E2 192.168.0.0/16 [110/1] via 10.0.30.2, 00:26:25, Port-channel13
core1.pop1#


core1.pop2#sh ip ospf int brief
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 1 0 10.0.3.1/32 1 LOOP 0/0
Po13 1 0 10.0.30.2/30 1 DR 1/1
Se3/1 1 0 10.0.60.2/30 64 P2P 1/1
Se3/0 1 0 10.0.50.2/30 64 P2P 1/1
core1.pop2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.2.1 1 FULL/BDR 00:00:31 10.0.30.1 Port-channel13
10.0.4.1 0 FULL/ - 00:00:30 10.0.60.1 Serial3/1
10.0.4.1 0 FULL/ - 00:00:30 10.0.50.1 Serial3/0
core1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
O E2 192.168.10.2/32 [110/20] via 10.0.60.1, 00:27:14, Serial3/1
[110/20] via 10.0.50.1, 00:27:14, Serial3/0
O E2 192.168.10.0/30 [110/20] via 10.0.60.1, 00:27:14, Serial3/1
[110/20] via 10.0.50.1, 00:27:14, Serial3/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2 172.16.10.0/30 [110/20] via 10.0.60.1, 00:27:06, Serial3/1
[110/20] via 10.0.50.1, 00:27:06, Serial3/0
O E2 172.16.0.0/16 [110/1] via 10.0.60.1, 00:26:33, Serial3/1
[110/1] via 10.0.50.1, 00:26:33, Serial3/0
10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
O 10.0.10.0/30 [110/65] via 10.0.30.1, 00:27:36, Port-channel13
C 10.0.3.1/32 is directly connected, Loopback0
O 10.0.2.1/32 [110/2] via 10.0.30.1, 00:27:37, Port-channel13
O 10.0.1.1/32 [110/66] via 10.0.30.1, 00:27:38, Port-channel13
O 10.0.4.1/32 [110/65] via 10.0.60.1, 00:27:38, Serial3/1
[110/65] via 10.0.50.1, 00:27:38, Serial3/0
C 10.0.30.0/30 is directly connected, Port-channel13
C 10.0.60.0/30 is directly connected, Serial3/1
C 10.0.50.0/30 is directly connected, Serial3/0
O 10.0.110.0/30 [110/97] via 10.0.30.1, 00:27:38, Port-channel13
O E2 10.0.110.2/32 [110/20] via 10.0.30.1, 00:27:38, Port-channel13
O E2 10.0.101.0/24 [110/1] via 10.0.30.1, 00:27:38, Port-channel13
O E2 10.0.120.2/32 [110/20] via 10.0.60.1, 00:27:38, Serial3/1
[110/20] via 10.0.50.1, 00:27:38, Serial3/0
O 10.0.120.0/30 [110/96] via 10.0.60.1, 00:27:38, Serial3/1
[110/96] via 10.0.50.1, 00:27:38, Serial3/0
O E2 192.168.0.0/16 [110/1] via 10.0.60.1, 00:26:59, Serial3/1
[110/1] via 10.0.50.1, 00:26:59, Serial3/0
core1.pop2#

edge1.pop2#sh ip bgp summary
BGP router identifier 10.0.4.1, local AS number 64513
BGP table version is 62, main routing table version 62
7 network entries using 819 bytes of memory
11 path entries using 572 bytes of memory
9/5 BGP path/bestpath attribute entries using 1116 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
2 BGP community entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2627 total bytes of memory
4 received paths for inbound soft reconfiguration
BGP activity 19/12 prefixes, 34/23 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 236 253 62 0 0 00:33:31 2
10.0.120.2 4 64516 80 95 62 0 0 00:27:48 2
172.16.10.2 4 64514 148 157 62 0 0 00:27:12 1
192.168.10.2 4 64515 108 116 62 0 0 00:27:34 1
edge1.pop2#sh ip ospf int bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Tu100 1 0 0.0.0.0/0 11111 P2P 0/0
Lo0 1 0 10.0.4.1/32 1 LOOP 0/0
Mu16 1 0 10.0.120.1/30 32 P2P 0/0
Se1/7 1 0 10.0.60.1/30 64 P2P 1/1
Se1/6 1 0 10.0.50.1/30 64 P2P 1/1
edge1.pop2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.3.1 0 FULL/ - 00:00:35 10.0.60.2 Serial1/7
10.0.3.1 0 FULL/ - 00:00:35 10.0.50.2 Serial1/6
edge1.pop2#sh ip ospf database

OSPF Router with ID (10.0.4.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.0.1.1 10.0.1.1 1819 0x80000012 0x007211 4
10.0.2.1 10.0.2.1 1751 0x8000000E 0x008543 4
10.0.3.1 10.0.3.1 1702 0x80000015 0x00D45C 6
10.0.4.1 10.0.4.1 95 0x80000015 0x00B62E 6

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.0.30.2 10.0.3.1 1750 0x80000001 0x0038B1

Type-10 Opaque Link Area Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Opaque ID
1.0.0.0 10.0.1.1 146 0x8000000D 0x00D7F2 0
1.0.0.0 10.0.2.1 1531 0x8000000B 0x0034D9 0
1.0.0.0 10.0.3.1 1703 0x8000000B 0x00EE87 0
1.0.0.0 10.0.4.1 1697 0x8000000F 0x00D39D 0
1.0.0.1 10.0.2.1 282 0x8000000A 0x009352 1
1.0.0.1 10.0.3.1 1701 0x80000008 0x00C0BE 1
1.0.0.1 10.0.4.1 1699 0x80000003 0x00B6CD 1
1.0.0.2 10.0.2.1 1754 0x80000001 0x00A5B0 2
1.0.0.3 10.0.3.1 1759 0x80000001 0x00B2A0 3

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
10.0.101.0 10.0.1.1 1769 0x80000005 0x00032F 64517
10.0.110.2 10.0.1.1 1795 0x8000000A 0x0019F7 0
10.0.120.2 10.0.4.1 1699 0x80000003 0x00A367 0
172.16.0.0 10.0.4.1 1646 0x80000001 0x0018D0 64514
172.16.10.0 10.0.4.1 1682 0x80000007 0x00596E 0
192.168.0.0 10.0.4.1 1669 0x80000001 0x00FD3D 64515
192.168.10.0 10.0.4.1 1689 0x80000005 0x0031EB 0
192.168.10.2 10.0.4.1 1690 0x80000005 0x002FE8 0
edge1.pop2#

edge1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.2/32 is directly connected, Multilink15
C 192.168.10.0/30 is directly connected, Multilink15
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.10.0/30 is directly connected, MFR14
B 172.16.0.0/16 [20/0] via 172.16.10.2, 00:27:47
10.0.0.0/8 is variably subnetted, 15 subnets, 4 masks
O 10.0.10.0/30 [110/129] via 10.0.60.2, 00:16:35, Serial1/7
[110/129] via 10.0.50.2, 00:16:35, Serial1/6
O 10.0.3.1/32 [110/65] via 10.0.60.2, 00:16:35, Serial1/7
[110/65] via 10.0.50.2, 00:16:35, Serial1/6
O 10.0.2.1/32 [110/66] via 10.0.60.2, 00:16:35, Serial1/7
[110/66] via 10.0.50.2, 00:16:35, Serial1/6
O 10.0.1.1/32 [110/130] via 0.0.0.0, 00:16:35, Tunnel100
S 10.0.0.0/8 is directly connected, Null0
C 10.0.4.1/32 is directly connected, Loopback0
O 10.0.30.0/30 [110/65] via 10.0.60.2, 00:16:36, Serial1/7
[110/65] via 10.0.50.2, 00:16:36, Serial1/6
C 10.0.60.0/30 is directly connected, Serial1/7
C 10.0.50.0/30 is directly connected, Serial1/6
O 10.0.110.0/30 [110/161] via 0.0.0.0, 00:16:36, Tunnel100
O E2 10.0.110.2/32 [110/20] via 0.0.0.0, 00:16:36, Tunnel100
O E2 10.0.101.0/24 [110/1] via 0.0.0.0, 00:16:36, Tunnel100
C 10.0.120.2/32 is directly connected, Multilink16
C 10.0.120.0/30 is directly connected, Multilink16
B 10.0.201.0/24 [20/0] via 10.0.120.2, 00:28:26
B 192.168.0.0/16 [20/0] via 192.168.10.2, 00:28:12
edge1.pop2#
edge1.pop2#

cus1.pop2#sh ip bgp summary
BGP router identifier 10.0.201.1, local AS number 64516
BGP table version is 28, main routing table version 28
7 network entries using 819 bytes of memory
7 path entries using 364 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2023 total bytes of memory
BGP activity 17/10 prefixes, 17/10 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.120.1 4 64517 69 58 28 0 0 00:29:23 5
cus1.pop2#sh ip bgp
BGP table version is 28, local router ID is 10.0.201.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 10.0.120.1 0 0 64517 64513 i
*> 10.0.101.0/24 10.0.120.1 0 64517 64513 64517 6
4516 i
*> 10.0.110.0/30 10.0.120.1 0 64517 64513 64517 6
4516 i
*> 10.0.120.0/30 0.0.0.0 0 32768 i
*> 10.0.201.0/24 0.0.0.0 0 32768 i
*> 172.16.0.0 10.0.120.1 0 64517 64513 64514 i
*> 192.168.0.0/16 10.0.120.1 0 64517 64513 64515 i
cus1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B 172.16.0.0/16 [20/0] via 10.0.120.1, 00:28:32
10.0.0.0/8 is variably subnetted, 7 subnets, 4 masks
B 10.0.0.0/8 [20/0] via 10.0.120.1, 00:29:30
B 10.0.110.0/30 [20/0] via 10.0.120.1, 00:29:30
B 10.0.101.0/24 [20/0] via 10.0.120.1, 00:29:30
C 10.0.120.0/30 is directly connected, Multilink16
C 10.0.120.1/32 is directly connected, Multilink16
C 10.0.151.0/24 is directly connected, Loopback1
C 10.0.201.0/24 is directly connected, Loopback0
B 192.168.0.0/16 [20/0] via 10.0.120.1, 00:29:02
cus1.pop2#

CSPA#sh ip bgp summary
BGP router identifier 192.168.101.1, local AS number 64515
BGP table version is 25, main routing table version 25
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1558 total bytes of memory
BGP activity 15/9 prefixes, 15/9 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.10.1 4 64513 117 111 25 0 0 00:29:57 5
CSPA#sh ip bgp
BGP table version is 25, local router ID is 192.168.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 192.168.10.1 0 0 64513 i
*> 10.0.101.0/24 192.168.10.1 0 64513 64517 64516 i
*> 10.0.110.0/30 192.168.10.1 0 64513 64517 64516 i
*> 10.0.120.0/30 192.168.10.1 0 64513 64517 64516 i
*> 10.0.201.0/24 192.168.10.1 0 64513 64517 64516 i
*> 192.168.0.0/16 0.0.0.0 0 32768 i
CSPA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/30 is directly connected, Multilink15
C 192.168.10.1/32 is directly connected, Multilink15
10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
B 10.0.0.0/8 [20/0] via 192.168.10.1, 00:30:04
B 10.0.110.0/30 [20/0] via 192.168.10.1, 00:30:04
B 10.0.101.0/24 [20/0] via 192.168.10.1, 00:30:04
B 10.0.120.0/30 [20/0] via 192.168.10.1, 00:30:04
B 10.0.201.0/24 [20/0] via 192.168.10.1, 00:30:04
C 192.168.101.0/24 is directly connected, Loopback0
S 192.168.0.0/16 is directly connected, Null0
CSPA#

CSPB#sh ip bgp summary
BGP router identifier 172.16.101.1, local AS number 64514
BGP table version is 25, main routing table version 25
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1558 total bytes of memory
BGP activity 15/9 prefixes, 15/9 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.10.1 4 64513 157 151 25 0 0 00:30:06 5
CSPB#sh ip bgp
BGP table version is 25, local router ID is 172.16.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 172.16.10.1 0 0 64513 i
*> 10.0.101.0/24 172.16.10.1 0 64513 64517 64516 i
*> 10.0.110.0/30 172.16.10.1 0 64513 64517 64516 i
*> 10.0.120.0/30 172.16.10.1 0 64513 64517 64516 i
*> 10.0.201.0/24 172.16.10.1 0 64513 64517 64516 i
*> 172.16.0.0 0.0.0.0 0 32768 i
CSPB#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C 172.16.10.0/30 is directly connected, MFR14
S 172.16.0.0/16 is directly connected, Null0
C 172.16.101.0/24 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
B 10.0.0.0/8 [20/0] via 172.16.10.1, 00:30:04
B 10.0.110.0/30 [20/0] via 172.16.10.1, 00:30:04
B 10.0.101.0/24 [20/0] via 172.16.10.1, 00:30:04
B 10.0.120.0/30 [20/0] via 172.16.10.1, 00:30:04
B 10.0.201.0/24 [20/0] via 172.16.10.1, 00:30:05
CSPB#

***************************
TRAFFIC MANIPULATION TOOLS
***************************

edge1.pop1#show route-map
route-map cus_routes, permit, sequence 10
Match clauses:
community (community-list filter): cus_routes
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map Local, permit, sequence 10
Match clauses:
interface Multilink16
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map cus_standard_mpls, permit, sequence 10
Match clauses:
Set clauses:
community 64513:513
Policy routing matches: 0 packets, 0 bytes
edge1.pop1#sh ip community-list
Named Community standard list cus_routes
permit 64513:513
edge1.pop1#

edge1.pop2#show route-map
route-map e-ISP, permit, sequence 10
Match clauses:
as-path (as-path filter): 13
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map e-ISP, permit, sequence 20
Match clauses:
community (community-list filter): ISP_cus_standard_mpls
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map e-ISP-routes, permit, sequence 10
Match clauses:
community (community-list filter): e-ISP
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map e-ISP-in, permit, sequence 10
Match clauses:
Set clauses:
community 64513:999
Policy routing matches: 0 packets, 0 bytes
route-map Local, permit, sequence 10
Match clauses:
interface Multilink16 MFR14 Multilink15
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map cus_standard_mpls, permit, sequence 10
Match clauses:
Set clauses:
community 64513:513
Policy routing matches: 0 packets, 0 bytes
edge1.pop2#
edge1.pop2#sh ip community-list
Named Community standard list ISP_cus_standard_mpls
permit 64513:513
Named Community standard list e-ISP
permit 64513:999
edge1.pop2#

*******************************
MPLS TRAFFIC-ENGINEERING
*******************************

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 276 seconds
Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
TE 10.0.4.1 - Se1/2 up/up
TE 10.0.1.1 Se1/2 - up/up
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails
edge1.pop1#show mpls traffic-eng tunnels tunnel 100

Name: TE (Tunnel100) Destination: 10.0.4.1
Status:
Admin: up Oper: up Path: valid Signalling: connected

path option 1, type explicit TE (Basis for Setup, path weight 129)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled

InLabel : -
OutLabel : Serial1/2, 24
RSVP Signalling Info:
Src 10.0.1.1, Dst 10.0.4.1, Tun_Id 100, Tun_Instance 65
RSVP Path Info:
My Address: 10.0.1.1
Explicit Route: 10.0.10.2 10.0.30.1 10.0.30.2 10.0.50.1
10.0.4.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 129 (TE)
Explicit Route: 10.0.10.2 10.0.30.1 10.0.30.2 10.0.50.1
10.0.4.1
History:
Tunnel:
Time since created: 3 hours, 23 minutes
Time since path change: 33 minutes, 18 seconds
Current LSP:
Uptime: 33 minutes, 18 seconds
Prior LSP:
ID: path option 1 [61]
Removal Trigger: path verification failed
edge1.pop1#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 255 seconds
Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
TE 10.0.1.1 - Se1/6 up/up
TE 10.0.4.1 Se1/6 - up/up
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails
edge1.pop2#show mpls traffic-eng tunnels tunnel 100

Name: TE (Tunnel100) Destination: 10.0.1.1
Status:
Admin: up Oper: up Path: valid Signalling: connected

path option 1, type explicit TE (Basis for Setup, path weight 129)

Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled

InLabel : -
OutLabel : Serial1/6, 31
RSVP Signalling Info:
Src 10.0.4.1, Dst 10.0.1.1, Tun_Id 100, Tun_Instance 82
RSVP Path Info:
My Address: 10.0.4.1
Explicit Route: 10.0.50.2 10.0.30.2 10.0.30.1 10.0.10.1
10.0.1.1
Record Route: NONE
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 129 (TE)
Explicit Route: 10.0.50.2 10.0.30.2 10.0.30.1 10.0.10.1
10.0.1.1
History:
Tunnel:
Time since created: 3 hours, 29 minutes
Time since path change: 33 minutes, 48 seconds
Current LSP:
Uptime: 33 minutes, 49 seconds
Prior LSP:
ID: path option 1 [73]
Removal Trigger: path verification failed
edge1.pop2#
edge1.pop2#

core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 463 seconds
Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
TE 10.0.4.1 Se3/0 Po13 up/up
TE 10.0.1.1 Po13 Se3/0 up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails
core1.pop1#

core1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
RSVP Process: running
Forwarding: enabled
Periodic reoptimization: every 3600 seconds, next in 610 seconds
Periodic auto-bw collection: disabled
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT
TE 10.0.4.1 Po13 Se3/0 up/up
TE 10.0.1.1 Se3/0 Po13 up/up
Displayed 0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails
core1.pop2#

*******************************
MPLS FORWARDING-TABLE
******************************
edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 10.0.110.2/32 5788 Mu16 point2point
17 Pop tag 10.0.2.1/32 0 Se1/2 10.0.10.2
18 Pop tag 10.0.30.0/30 0 Se1/2 10.0.10.2
19 19 10.0.3.1/32 0 Se1/2 10.0.10.2
20 20 10.0.50.0/30 0 Se1/2 10.0.10.2
21 21 10.0.60.0/30 0 Se1/2 10.0.10.2
22 Pop tag [T] 10.0.4.1/32 0 Tu100 point2point
23 Untagged[T] 172.16.10.0/30 0 Tu100 point2point
24 Untagged[T] 192.168.10.0/30 0 Tu100 point2point
26 Untagged[T] 192.168.10.2/32 0 Tu100 point2point
27 Untagged[T] 10.0.120.2/32 0 Tu100 point2point
33 Untagged[T] 10.0.120.0/30 0 Tu100 point2point
34 Untagged[T] 192.168.0.0/16 0 Tu100 point2point
35 Untagged[T] 172.16.0.0/16 0 Tu100 point2point

[T] Forwarding through a TSP tunnel.
View additional tagging info with the 'detail' option
edge1.pop1#

edge1.pop2#show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.30.0/30 0 Se1/7 10.0.60.2
Pop tag 10.0.30.0/30 0 Se1/6 10.0.50.2
17 17 10.0.2.1/32 0 Se1/7 10.0.60.2
17 10.0.2.1/32 0 Se1/6 10.0.50.2
18 Pop tag 10.0.3.1/32 0 Se1/7 10.0.60.2
Pop tag 10.0.3.1/32 0 Se1/6 10.0.50.2
19 18 10.0.10.0/30 0 Se1/7 10.0.60.2
18 10.0.10.0/30 0 Se1/6 10.0.50.2
20 Pop tag [T] 10.0.1.1/32 0 Tu100 point2point
21 Untagged[T] 10.0.110.0/30 0 Tu100 point2point
22 Untagged[T] 10.0.101.0/24 0 Tu100 point2point
23 Untagged[T] 10.0.110.2/32 0 Tu100 point2point
24 Untagged 192.168.10.2/32 0 Mu15 point2point
25 Untagged 10.0.120.2/32 0 Mu16 point2point

[T] Forwarding through a TSP tunnel.
View additional tagging info with the 'detail' option
edge1.pop2#

No comments:

Post a Comment