Thursday, June 24, 2010

Implementing IPTV using P2MP RSVP TE Lab















Configuration Guidelines
***************************************************************
Scenario: An ISP wants to offer IPTV Services witout
using native multicast across his SP Core.

Design Considerations and Soultion:

There are two possinle solutions for offering Multicast Services
to Customers witout running native Multicast in SP Core.
1. Using P2MP RSVP-TE Tunnels
2. using NGN MVPN over m-LDP

Here we are focussing on 1st solution to provide IPTV services by
creating point-to-multipoint TE across SP Core with the help of RSVP
TE Extensions.The Head of the P2MP RSVP TE is rooted at the PE peering
to IPTV and we need to join the IPTV Channels on the P2MP TE Headend
Tunnel.The P2MP RSVP TE creates LSP Virtual Interfaces on the Tail Ends
for the Multicast Communication back to the head end and also so that
the RPF does not fails as the tail ends are for the individual P2P
sub-LSPs for the P2MP RSVP TE.

Access Link to EUs are normal Internet Links and using PIM SSM between
PE-CE and on the Edge PEs Customers can Switch to their desire of channel
and STBs can receive the interested Multicast Streamm for the Channel
The SP Core is free from Native Multicast and the Multicast Communication
happens over the LSP Virtual Interfaces.


Challenges: Static mroutes are needed on PEs connecting to Customers
Since we are using LSP Virtual Interfaces We will also need to define
static mroutes at the PEs connecting to Customers pointing back to
P2MP TE Headend for rpf sanity.

ISP IGP used OSPF Area 0
Primary Onehop Auto-Tunnels and Primary nhop-only Backup Tunnels used in
SP Core.
PE-CE ROuting Protocol used EBGP
PIM SSM Used for PE-CE
IGMP Group used for Testing 232.1.1.1;232.2.2.2
********************************************************************************


IPTV#sh running-config
Building configuration...

Current configuration : 1143 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/0
description edge1.pop1
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64515
no synchronization
bgp router-id 192.168.101.1
bgp log-neighbor-changes
network 192.168.0.0 mask 255.255.0.0
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 description edge1.pop1
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip classless
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

IPTV#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 1288 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.1.1.1 source 192.168.101.1
ip igmp join-group 232.2.2.2 source 192.168.101.1
!
interface FastEthernet0/0
description edge1.pop2
ip address 172.16.1.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.101.1
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.252
network 172.16.101.0 mask 255.255.255.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description edge1.pop1
neighbor 172.16.1.1 allowas-in 5
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

cus1.pop2#

cus1.pop3#sh running-config
Building configuration...

Current configuration : 1288 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.201.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.1.1.1 source 192.168.101.1
ip igmp join-group 232.2.2.2 source 192.168.101.1
!
interface FastEthernet0/0
description edge1.pop3
ip address 172.16.2.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64514
no synchronization
bgp router-id 172.16.201.1
bgp log-neighbor-changes
network 172.16.2.0 mask 255.255.255.252
network 172.16.201.0 mask 255.255.255.0
neighbor 172.16.2.1 remote-as 64513
neighbor 172.16.2.1 description edge1.pop1
neighbor 172.16.2.1 allowas-in 5
neighbor 172.16.2.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

cus1.pop3#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 3213 bytes
!
! Last configuration change at 13:07:42 UTC Thu Jun 24 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
!
mpls traffic-eng destination list name P2MP
ip 10.0.3.1 path-option 1 explicit name edge1.pop2
ip 10.0.4.1 path-option 1 explicit name edge1.pop3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface Tunnel100
description P2MP
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.2.2.2 source 192.168.101.1
ip igmp static-group 232.1.1.1 source 192.168.101.1
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name P2MP
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng fast-reroute
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-L1
ip address 10.0.10.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet2/0
description IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.3.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
neighbor 192.168.1.2 remote-as 64515
neighbor 192.168.1.2 description IPTV
!
address-family ipv4
no synchronization
network 10.0.0.0
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm default
ip route 10.0.0.0 255.0.0.0 Null0
!
ip explicit-path name edge1.pop2 enable
next-address 10.0.10.2
next-address 10.0.20.1
!
ip explicit-path name edge1.pop3 enable
next-address 10.0.10.2
next-address 10.0.30.1
!
!
route-map Local permit 10
match interface FastEthernet2/0
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop1#
core1.pop1#sh running-config
Building configuration...

Current configuration : 1810 bytes
!
! Last configuration change at 12:26:24 UTC Thu Jun 24 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description edge1.pop3
ip address 10.0.30.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2797 bytes
!
! Last configuration change at 13:00:06 UTC Thu Jun 24 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
ip multicast mpls traffic-eng
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop3
ip address 10.0.40.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop1
ip address 172.16.1.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.3.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description cus1.pop2
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.4.1 activate
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm default
ip mroute 192.168.101.1 255.255.255.255 10.0.1.1
ip mroute 192.168.101.0 255.255.255.0 10.0.1.1
ip mroute 192.168.0.0 255.255.0.0 10.0.1.1
ip mroute 192.168.1.0 255.255.255.252 10.0.1.1
!
!
route-map Local permit 10
match interface FastEthernet3/0
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

edge1.pop3#sh running-config
Building configuration...

Current configuration : 2816 bytes
!
! Last configuration change at 13:00:27 UTC Thu Jun 24 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip multicast-routing
ip multicast mpls traffic-eng
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.30.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.40.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop3
ip address 172.16.2.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.4.1
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.3.1 peer-group iBGP
neighbor 172.16.2.2 remote-as 64514
neighbor 172.16.2.2 description cus1.pop3
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim ssm default
ip mroute 192.168.101.1 255.255.255.255 10.0.1.1
ip mroute 192.168.101.0 255.255.255.0 10.0.1.1
ip mroute 192.168.0.0 255.255.0.0 10.0.1.1
ip mroute 192.168.1.0 255.255.255.252 10.0.1.1
!
!
route-map Local permit 10
match interface FastEthernet3/0
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop3#
***************************************
OUTPUT
**************************************
Multicast TRAFFIC
*************************************
IPTV#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.1.2, 232.1.1.1), 00:06:19/00:01:40, flags: sPT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.101.1, 232.1.1.1), 00:12:37/00:02:36, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:12:37/00:02:36

(192.168.101.1, 232.2.2.2), 00:00:52/00:02:37, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:00:52/00:02:37

(*, 224.0.1.40), 00:27:28/00:02:54, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:27:28/00:02:54
Loopback0, Forward/Sparse, 00:27:28/00:02:42

IPTV#ping 232.2.2.2 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.2.2.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 172.16.1.2, 556 ms
Reply to request 0 from 172.16.2.2, 1396 ms
IPTV#

cus1.pop2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:11:20/00:01:47, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:11:20/00:00:40

(192.168.101.1, 232.2.2.2), 00:00:32/00:02:27, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:00:32/00:02:27

(*, 224.0.1.40), 00:23:34/00:02:46, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:23:34/00:02:46

cus1.pop2#

cus1.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:08:49/00:01:51, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:08:49/00:00:11

(192.168.101.1, 232.2.2.2), 00:00:07/00:02:52, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.2.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:00:07/00:02:52

(*, 224.0.1.40), 00:16:30/00:02:22, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:16:30/00:02:22

cus1.pop3#

edge1.pop1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.2.2.2), 00:01:11/00:01:48, flags: sTI
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.2
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:01:11/00:01:48

(192.168.1.2, 232.1.1.1), 00:02:19/00:00:40, flags: sPT
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.2
Outgoing interface list: Null

(192.168.101.1, 232.1.1.1), 00:14:00/stopped, flags: sTI
Incoming interface: FastEthernet2/0, RPF nbr 192.168.1.2
Outgoing interface list:
Tunnel100, Forward/Sparse-Dense, 00:14:00/00:00:59

(*, 224.0.1.40), 00:37:30/00:02:35, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop1#

edge1.pop2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.2.2.2), 00:01:18/00:03:09, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:01:18/00:03:09

(192.168.101.1, 232.1.1.1), 00:14:43/00:03:12, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:11:22/00:03:12

(*, 224.0.1.40), 00:31:45/00:02:19, RP 0.0.0.0, flags: DPCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop2#

edge1.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.2.2.2), 00:00:46/00:02:43, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:00:46/00:02:43

(192.168.101.1, 232.1.1.1), 00:11:39/00:02:54, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.1.1, Mroute
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:08:54/00:02:54

(*, 224.0.1.40), 00:27:17/00:02:48, RP 0.0.0.0, flags: DPCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop3#

edge1.pop1#sh ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: FastEthernet2/0
RPF neighbor: ? (192.168.1.2)
RPF route/mask: 192.168.0.0/16
RPF type: unicast (bgp 64513)
Doing distance-preferred lookups across tables
RPF topology: ipv4 multicast base, originated from ipv4 unicast base
edge1.pop1#

edge1.pop2#sh ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: Lspvif0
RPF neighbor: ? (10.0.1.1)
RPF route/mask: 192.168.101.1/32
RPF type: multicast (static)
Doing distance-preferred lookups across tables
RPF topology: ipv4 multicast base, originated from ipv4 unicast base
edge1.pop2#


edge1.pop3#sh ip rpf 192.168.101.1
RPF information for ? (192.168.101.1)
RPF interface: Lspvif0
RPF neighbor: ? (10.0.1.1)
RPF route/mask: 192.168.101.1/32
RPF type: multicast (static)
Doing distance-preferred lookups across tables
RPF topology: ipv4 multicast base, originated from ipv4 unicast base
edge1.pop3#

************************************
UNICAST TRAFFIC and INT
*************************************

IPTV#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 192.168.1.1 984 msec 240 msec 264 msec
2 10.0.10.2 [AS 64513] 216 msec 872 msec 296 msec
3 10.0.20.1 [AS 64513] 388 msec 240 msec 292 msec
4 172.16.1.2 [AS 64514] 1132 msec 2120 msec 656 msec
IPTV#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 192.168.1.1 2216 msec 244 msec 92 msec
2 10.0.10.2 [AS 64513] 360 msec 236 msec 832 msec
3 10.0.30.1 [AS 64513] 444 msec 416 msec 676 msec
4 172.16.2.2 [AS 64514] 764 msec 412 msec *
IPTV#

cus1.pop2#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 172.16.1.1 208 msec 144 msec 168 msec
2 10.0.20.2 [AS 64513] 264 msec 192 msec 360 msec
3 10.0.10.1 [AS 64513] 764 msec 324 msec 592 msec
4 192.168.1.2 [AS 64515] 560 msec 396 msec *
cus1.pop2#

cus1.pop3#traceroute 192.168.101.1

Type escape sequence to abort.
Tracing the route to 192.168.101.1

1 172.16.2.1 120 msec 332 msec 120 msec
2 10.0.30.2 [AS 64513] 1344 msec 1688 msec 376 msec
3 10.0.10.1 [AS 64513] 1524 msec 720 msec 992 msec
4 192.168.1.2 [AS 64515] 504 msec 1712 msec 768 msec
cus1.pop3#

edge1.pop1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
GigabitEthernet1/0 10.0.10.1 YES manual up up
FastEthernet2/0 192.168.1.1 YES manual up up
FastEthernet2/1 unassigned YES unset administratively down down
GigabitEthernet3/0 unassigned YES unset administratively down down
Loopback0 10.0.1.1 YES manual up up
Tunnel100 10.0.1.1 YES TFTP up up
Tunnel65336 10.0.1.1 YES TFTP up up
Tunnel65436 10.0.1.1 YES TFTP up down
edge1.pop1#

edge1.pop2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
GigabitEthernet1/0 10.0.20.1 YES manual up up
GigabitEthernet2/0 10.0.40.1 YES manual up up
FastEthernet3/0 172.16.1.1 YES manual up up
FastEthernet3/1 unassigned YES unset administratively down down
Loopback0 10.0.3.1 YES manual up up
Lspvif0 10.0.3.1 YES unset up up
Tunnel65336 10.0.3.1 YES TFTP up up
Tunnel65337 10.0.3.1 YES TFTP up up
Tunnel65436 10.0.3.1 YES TFTP up up
Tunnel65437 10.0.3.1 YES TFTP up up
edge1.pop2#

edge1.pop3#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES manual administratively down down
GigabitEthernet1/0 10.0.30.1 YES manual up up
GigabitEthernet2/0 10.0.40.2 YES manual up up
FastEthernet3/0 172.16.2.1 YES manual up up
FastEthernet3/1 unassigned YES manual administratively down down
Loopback0 10.0.4.1 YES manual up up
Lspvif0 10.0.4.1 YES unset up up
Tunnel65336 10.0.4.1 YES TFTP up up
Tunnel65337 10.0.4.1 YES TFTP up up
Tunnel65436 10.0.4.1 YES TFTP up up
Tunnel65437 10.0.4.1 YES TFTP up up
edge1.pop3#
*******************************************
MPLS TE
*******************************************

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (1 ), id-range:65436-65535
onehop Enabled (1 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3358 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 1 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 278 seconds
Periodic auto-bw collection: every 300 seconds, next in 58 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop1_t65436 10.0.2.1 - unknown up/down
core1.pop1_t65336 10.0.1.1 Gi1/0 - up/up

Displayed 2 (of 2) heads, 0 (of 0) midpoints, 1 (of 1) tails

P2MP TUNNELS:
DEST CURRENT
INTERFACE STATE/PROT UP/CFG TUNID LSPID
Tunnel100 up/up 2/2 100 86
Displayed 1 (of 1) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 86 10.0.3.1 1 Up head Gi1/0
10.0.1.1 100 86 10.0.4.1 2 Up head Gi1/0
Displayed 2 P2MP sub-LSPs:
2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

Tunnel100 (p2mp), Admin: up, Oper: up
Name: P2MP

Tunnel100 Destinations Information:

Destination State SLSP UpTime
10.0.3.1 Up 00:00:59
10.0.4.1 Up 00:01:01

Summary: Destinations: 2 [Up: 2, Proceeding: 0, Down: 0 ]
[destination list name: P2MP]

History:
Tunnel:
Time since created: 58 minutes, 26 seconds
Time since path change: 56 seconds
Number of LSP IDs (Tun_Instances) used: 86
Current LSP: [ID: 86]
Uptime: 1 minutes, 1 seconds
Selection: reoptimization
Prior LSP: [ID: 70]
Removal Trigger: re-route path verification failed

Tunnel100 LSP Information:
Configured LSP Parameters:
Bandwidth: 0 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)

Session Information
Source: 10.0.1.1, TunID: 100

LSPs
ID: 86 (Current), Path-Set ID: 0x7
Sub-LSPs: 2, Up: 2, Proceeding: 0, Down: 0

Total LSPs: 1

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 86
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 1, Role: head
Path-Set ID: 0x7
OutLabel : GigabitEthernet1/0, 20
Next Hop : 10.0.10.2
Explicit Route: 10.0.10.2 10.0.20.2 10.0.20.1 10.0.3.1
Record Route (Path): NONE
Record Route (Resv): 10.0.2.1(20) 10.0.3.1(24)

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: head
Path-Set ID: 0x7
OutLabel : GigabitEthernet1/0, 20
Next Hop : 10.0.10.2
Explicit Route: 10.0.10.2 10.0.30.2 10.0.30.1 10.0.4.1
Record Route (Path): NONE
Record Route (Resv): 10.0.2.1(20) 10.0.4.1(26)
edge1.pop1#

core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (3 ), id-range:65436-65535
onehop Enabled (3 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 267 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 907 seconds
Periodic auto-bw collection: every 300 seconds, next in 267 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65337 10.0.3.1 - Gi2/0 up/up
core1.pop1_t65338 10.0.4.1 - Gi3/0 up/up
core1.pop1_t65436 10.0.1.1 - unknown up/down
core1.pop1_t65437 10.0.3.1 - Gi3/0 up/up
core1.pop1_t65438 10.0.4.1 - Gi2/0 up/up
edge1.pop1_t65336 10.0.2.1 Gi1/0 - up/up

edge1.pop2_t65336 10.0.2.1 Gi2/0 - up/up

edge1.pop2_t65436 10.0.2.1 Gi3/0 - up/up

edge1.pop2_t65437 10.0.4.1 Gi2/0 Gi3/0 up/up

edge1.pop3_t65337 10.0.2.1 Gi3/0 - up/up

edge1.pop3_t65436 10.0.3.1 Gi3/0 Gi2/0 up/up

edge1.pop3_t65437 10.0.2.1 Gi2/0 - up/up

Displayed 6 (of 6) heads, 2 (of 2) midpoints, 5 (of 5) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 86 10.0.3.1 1 Up Gi1/0 Gi2/0
10.0.1.1 100 86 10.0.4.1 2 Up Gi1/0 Gi3/0
Displayed 2 P2MP sub-LSPs:
0 (of 0) heads, 2 (of 2) midpoints, 0 (of 0) tails
core1.pop1#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 86
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 1, Role: midpoint
Path-Set ID: 0x79000006
InLabel : GigabitEthernet1/0, 20
Prev Hop : 10.0.10.1
OutLabel : GigabitEthernet2/0, 24
Next Hop : 10.0.20.1
FRR OutLabel : Tunnel65437, 24
Explicit Route: 10.0.20.1 10.0.3.1
Record Route (Path): NONE
Record Route (Resv): 10.0.3.1(24)

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: midpoint
Path-Set ID: 0x79000006
InLabel : GigabitEthernet1/0, 20
Prev Hop : 10.0.10.1
OutLabel : GigabitEthernet3/0, 26
Next Hop : 10.0.30.1
FRR OutLabel : Tunnel65438, 26
Explicit Route: 10.0.30.1 10.0.4.1
Record Route (Path): NONE
Record Route (Resv): 10.0.4.1(26)
core1.pop1#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 627 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 935 seconds
Periodic auto-bw collection: every 300 seconds, next in 27 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop2_t65337 10.0.4.1 - Gi2/0 up/up
edge1.pop2_t65436 10.0.2.1 - Gi2/0 up/up
edge1.pop2_t65437 10.0.4.1 - Gi1/0 up/up
core1.pop1_t65337 10.0.3.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.3.1 Gi2/0 - up/up

core1.pop1_t65438 10.0.4.1 Gi1/0 Gi2/0 up/up

edge1.pop3_t65336 10.0.3.1 Gi2/0 - up/up

edge1.pop3_t65436 10.0.3.1 Gi1/0 - up/up

edge1.pop3_t65437 10.0.2.1 Gi2/0 Gi1/0 up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 86 10.0.3.1 1 Up Gi1/0 tail
Displayed 1 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 1 (of 1) tails
edge1.pop2#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 86
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.3.1, P2MP Subgroup ID: 1, Role: tail
Path-Set ID: 0xC1000006
InLabel : GigabitEthernet1/0, 24
Prev Hop : 10.0.20.2
OutLabel : -
Explicit Route: NONE
Record Route (Path): NONE
Record Route (Resv): NONE
edge1.pop2#

edge1.pop3#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 1077 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 1098 seconds
Periodic auto-bw collection: every 300 seconds, next in 177 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop3_t65336 10.0.3.1 - Gi2/0 up/up
edge1.pop3_t65337 10.0.2.1 - Gi1/0 up/up
edge1.pop3_t65436 10.0.3.1 - Gi1/0 up/up
edge1.pop3_t65437 10.0.2.1 - Gi2/0 up/up
core1.pop1_t65338 10.0.4.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.3.1 Gi1/0 Gi2/0 up/up

core1.pop1_t65438 10.0.4.1 Gi2/0 - up/down

core1.pop1_t65438 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65337 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65436 10.0.2.1 Gi2/0 Gi1/0 up/up

edge1.pop2_t65437 10.0.4.1 Gi1/0 - up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 5 (of 5) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
SOURCE TUNID LSPID DESTINATION SUBID STATE UP IF DOWN IF
10.0.1.1 100 77 10.0.4.1 2 Proc Gi1/0 tail
10.0.1.1 100 86 10.0.4.1 2 Up Gi1/0 tail
Displayed 2 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 2 (of 2) tails
edge1.pop3#show mpls traffic-eng tunnels dest-mode p2mp

P2MP TUNNELS:

P2MP SUB-LSPS:

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 77
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: tail
Path-Set ID: none

LSP: Source: 10.0.1.1, TunID: 100, LSPID: 86
P2MP ID: 100, Subgroup Originator: 10.0.1.1
Name: P2MP
Bandwidth: 0, Global Pool

Sub-LSP to 10.0.4.1, P2MP Subgroup ID: 2, Role: tail
Path-Set ID: 0xE5000006
InLabel : GigabitEthernet1/0, 26
Prev Hop : 10.0.30.2
OutLabel : -
Explicit Route: NONE
Record Route (Path): NONE
Record Route (Resv): NONE
edge1.pop3#

******************************************
MPLS FIB
******************************************
edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
17 [T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
18 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
19 [T] 17 10.0.3.1/32 0 Tu65336 point2point
20 [T] 18 10.0.40.0/30 0 Tu65336 point2point
21 [T] 21 10.0.4.1/32 0 Tu65336 point2point
22 [T] 24 172.16.1.0/30 0 Tu65336 point2point
24 [T] 25 172.16.2.0/30 0 Tu65336 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop1#

core1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.1.1/32 2894 Tu65336 point2point
17 [T] Pop Label 10.0.3.1/32 11874 Tu65337 point2point
18 [T] Pop Label 10.0.40.0/30 0 Tu65337 point2point
[T] Pop Label 10.0.40.0/30 0 Tu65338 point2point
19 [T] Pop Label 192.168.1.0/30 0 Tu65336 point2point
20 26 10.0.1.1 100 [86] \
0 Gi3/0 10.0.30.1
24 10.0.1.1 100 [86] \
0 Gi2/0 10.0.20.1
21 [T] Pop Label 10.0.4.1/32 635 Tu65338 point2point
23 Pop Label 10.0.4.1 65436 [17] \
0 Gi2/0 10.0.20.1
24 [T] Pop Label 172.16.1.0/30 420 Tu65337 point2point
25 [T] Pop Label 172.16.2.0/30 0 Tu65338 point2point
29 Pop Label 10.0.3.1 65437 [30] \
0 Gi3/0 10.0.30.1

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#

edge1.pop2#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
17 [T] 16 10.0.1.1/32 0 Tu65336 point2point
18 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.30.0/30 0 Tu65337 point2point
19 [T] Pop Label 10.0.10.0/30 0 Tu65336 point2point
20 [T] 19 192.168.1.0/30 0 Tu65336 point2point
21 [T] Pop Label 10.0.4.1/32 0 Tu65337 point2point
22 Pop Label 10.0.4.1 65437 [17] \
0 Gi1/0 10.0.20.2
24 [T] No Label 10.0.1.1 100 [86] \
0 aggregate
25 Pop Label 10.0.2.1 65438 [29] \
0 Gi2/0 10.0.40.2
26 [T] Pop Label 172.16.2.0/30 0 Tu65337 point2point

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop2#

edge1.pop3#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] 19 192.168.1.0/30 0 Tu65337 point2point
18 Pop Label 10.0.2.1 65437 [45] \
0 Gi2/0 10.0.40.1
19 [T] Pop Label 10.0.3.1/32 0 Tu65336 point2point
20 [T] Pop Label 10.0.2.1/32 0 Tu65337 point2point
21 [T] 16 10.0.1.1/32 0 Tu65337 point2point
22 [T] Pop Label 10.0.10.0/30 0 Tu65337 point2point
23 [T] Pop Label 10.0.20.0/30 0 Tu65337 point2point
[T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
24 Pop Label 10.0.3.1 65436 [45] \
0 Gi1/0 10.0.30.2
25 [T] Pop Label 172.16.1.0/30 0 Tu65336 point2point
26 [T] No Label 10.0.1.1 100 [86] \
0 aggregate

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop3#

***********************
IP FIB
***********************
IPTV#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
B 172.16.201.0/24 [20/0] via 192.168.1.1, 00:04:59
B 172.16.1.0/30 [20/0] via 192.168.1.1, 00:04:59
B 172.16.2.0/30 [20/0] via 192.168.1.1, 00:04:59
B 172.16.101.0/24 [20/0] via 192.168.1.1, 00:04:59
B 10.0.0.0/8 [20/0] via 192.168.1.1, 00:04:59
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0
192.168.101.0/32 is subnetted, 1 subnets
C 192.168.101.1 is directly connected, Loopback0
S 192.168.0.0/16 is directly connected, Null0
IPTV#

cus1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
B 172.16.201.0/24 [20/0] via 172.16.1.1, 00:11:11
C 172.16.1.0/30 is directly connected, FastEthernet0/0
B 172.16.2.0/30 [20/0] via 172.16.1.1, 00:11:11
C 172.16.101.0/24 is directly connected, Loopback0
B 10.0.0.0/8 [20/0] via 172.16.1.1, 00:30:19
B 192.168.0.0/16 [20/0] via 172.16.1.1, 00:30:19
cus1.pop2#

cus1.pop3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 172.16.201.0/24 is directly connected, Loopback0
B 172.16.1.0/30 [20/0] via 172.16.2.1, 00:02:39
C 172.16.2.0/30 is directly connected, FastEthernet0/0
B 172.16.101.0/24 [20/0] via 172.16.2.1, 00:02:39
B 10.0.0.0/8 [20/0] via 172.16.2.1, 00:10:03
B 192.168.0.0/16 [20/0] via 172.16.2.1, 00:02:39
cus1.pop3#

edge1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 10 subnets, 3 masks
S 10.0.0.0/8 is directly connected, Null0
C 10.0.1.1/32 is directly connected, Loopback0
O 10.0.2.1/32 [110/2] via 10.0.2.1, 00:07:04, Tunnel65336
O 10.0.3.1/32 [110/3] via 10.0.2.1, 00:07:04, Tunnel65336
O 10.0.4.1/32 [110/3] via 10.0.2.1, 00:05:43, Tunnel65336
C 10.0.10.0/30 is directly connected, GigabitEthernet1/0
L 10.0.10.1/32 is directly connected, GigabitEthernet1/0
O 10.0.20.0/30 [110/2] via 10.0.2.1, 00:07:04, Tunnel65336
O 10.0.30.0/30 [110/2] via 10.0.2.1, 00:05:43, Tunnel65336
O 10.0.40.0/30 [110/3] via 10.0.2.1, 00:05:33, Tunnel65336
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
O E2 172.16.1.0/30 [110/20] via 10.0.2.1, 00:07:04, Tunnel65336
O E2 172.16.2.0/30 [110/20] via 10.0.2.1, 00:05:43, Tunnel65336
B 172.16.101.0/24 [200/0] via 10.0.3.1, 00:31:56
B 172.16.201.0/24 [200/0] via 10.0.4.1, 00:12:03
B 192.168.0.0/16 [20/0] via 192.168.1.2, 00:07:41
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/30 is directly connected, FastEthernet2/0
L 192.168.1.1/32 is directly connected, FastEthernet2/0
edge1.pop1#

core1.pop1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 11 subnets, 2 masks
O 10.0.1.1/32 [110/2] via 10.0.1.1, 00:05:41, Tunnel65336
C 10.0.2.1/32 is directly connected, Loopback0
O 10.0.3.1/32 [110/2] via 10.0.3.1, 00:05:41, Tunnel65337
O 10.0.4.1/32 [110/2] via 10.0.4.1, 00:05:41, Tunnel65338
C 10.0.10.0/30 is directly connected, GigabitEthernet1/0
L 10.0.10.2/32 is directly connected, GigabitEthernet1/0
C 10.0.20.0/30 is directly connected, GigabitEthernet2/0
L 10.0.20.2/32 is directly connected, GigabitEthernet2/0
C 10.0.30.0/30 is directly connected, GigabitEthernet3/0
L 10.0.30.2/32 is directly connected, GigabitEthernet3/0
O 10.0.40.0/30 [110/2] via 10.0.4.1, 00:05:41, Tunnel65338
[110/2] via 10.0.3.1, 00:05:41, Tunnel65337
172.16.0.0/30 is subnetted, 2 subnets
O E2 172.16.1.0 [110/20] via 10.0.3.1, 00:05:41, Tunnel65337
O E2 172.16.2.0 [110/20] via 10.0.4.1, 00:05:41, Tunnel65338
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.1.1, 00:05:41, Tunnel65336
core1.pop1#

edge1.pop2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
B 10.0.0.0/8 [200/0] via 10.0.1.1, 00:36:29
O 10.0.1.1/32 [110/3] via 10.0.2.1, 00:05:40, Tunnel65336
O 10.0.2.1/32 [110/2] via 10.0.2.1, 00:05:40, Tunnel65336
C 10.0.3.1/32 is directly connected, Loopback0
O 10.0.4.1/32 [110/2] via 10.0.4.1, 00:05:40, Tunnel65337
O 10.0.10.0/30 [110/2] via 10.0.2.1, 00:05:40, Tunnel65336
C 10.0.20.0/30 is directly connected, GigabitEthernet1/0
L 10.0.20.1/32 is directly connected, GigabitEthernet1/0
O 10.0.30.0/30 [110/2] via 10.0.4.1, 00:05:40, Tunnel65337
[110/2] via 10.0.2.1, 00:05:40, Tunnel65336
C 10.0.40.0/30 is directly connected, GigabitEthernet2/0
L 10.0.40.1/32 is directly connected, GigabitEthernet2/0
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C 172.16.1.0/30 is directly connected, FastEthernet3/0
L 172.16.1.1/32 is directly connected, FastEthernet3/0
O E2 172.16.2.0/30 [110/20] via 10.0.4.1, 00:05:40, Tunnel65337
B 172.16.101.0/24 [20/0] via 172.16.1.2, 00:29:00
B 172.16.201.0/24 [200/0] via 10.0.4.1, 00:11:26
B 192.168.0.0/16 [200/0] via 10.0.1.1, 00:06:31
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.2.1, 00:05:40, Tunnel65336
edge1.pop2#

edge1.pop3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
B 10.0.0.0/8 [200/0] via 10.0.1.1, 00:10:39
O 10.0.1.1/32 [110/3] via 10.0.2.1, 00:06:14, Tunnel65337
O 10.0.2.1/32 [110/2] via 10.0.2.1, 00:06:14, Tunnel65337
O 10.0.3.1/32 [110/2] via 10.0.3.1, 00:06:14, Tunnel65336
C 10.0.4.1/32 is directly connected, Loopback0
O 10.0.10.0/30 [110/2] via 10.0.2.1, 00:06:14, Tunnel65337
O 10.0.20.0/30 [110/2] via 10.0.3.1, 00:06:14, Tunnel65336
[110/2] via 10.0.2.1, 00:06:14, Tunnel65337
C 10.0.30.0/30 is directly connected, GigabitEthernet1/0
L 10.0.30.1/32 is directly connected, GigabitEthernet1/0
C 10.0.40.0/30 is directly connected, GigabitEthernet2/0
L 10.0.40.2/32 is directly connected, GigabitEthernet2/0
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O E2 172.16.1.0/30 [110/20] via 10.0.3.1, 00:06:14, Tunnel65336
C 172.16.2.0/30 is directly connected, FastEthernet3/0
L 172.16.2.1/32 is directly connected, FastEthernet3/0
B 172.16.101.0/24 [200/0] via 10.0.3.1, 00:05:48
B 172.16.201.0/24 [20/0] via 172.16.2.2, 00:23:15
B 192.168.0.0/16 [200/0] via 10.0.1.1, 00:05:48
192.168.1.0/30 is subnetted, 1 subnets
O E2 192.168.1.0 [110/20] via 10.0.2.1, 00:06:14, Tunnel65337
edge1.pop3#

*************************
IGP and EGP
*************************

IPTV#sh ip bgp summary
BGP router identifier 192.168.101.1, local AS number 64515
BGP table version is 25, main routing table version 25
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1558 total bytes of memory
BGP activity 13/7 prefixes, 15/9 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.1.1 4 64513 55 48 25 0 0 00:06:59 5
IPTV#sh ip bgp
BGP table version is 25, local router ID is 192.168.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 192.168.1.1 0 0 64513 i
*> 172.16.1.0/30 192.168.1.1 0 64513 64514 i
*> 172.16.2.0/30 192.168.1.1 0 64513 64514 i
*> 172.16.101.0/24 192.168.1.1 0 64513 64514 i
*> 172.16.201.0/24 192.168.1.1 0 64513 64514 i
*> 192.168.0.0/16 0.0.0.0 0 32768 i
IPTV#

cus1.pop2#sh ip bgp summary
BGP router identifier 172.16.101.1, local AS number 64514
BGP table version is 11, main routing table version 11
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 14/8 prefixes, 14/8 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.1.1 4 64513 55 47 11 0 0 00:32:35 4
cus1.pop2#sh ip bgp
BGP table version is 11, local router ID is 172.16.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 172.16.1.1 0 64513 i
*> 172.16.1.0/30 0.0.0.0 0 32768 i
*> 172.16.2.0/30 172.16.1.1 0 64513 64514 i
*> 172.16.101.0/24 0.0.0.0 0 32768 i
*> 172.16.201.0/24 172.16.1.1 0 64513 64514 i
*> 192.168.0.0/16 172.16.1.1 0 64513 64515 i
cus1.pop2#

cus1.pop2#sh ip bgp summary
BGP router identifier 172.16.101.1, local AS number 64514
BGP table version is 11, main routing table version 11
6 network entries using 702 bytes of memory
6 path entries using 312 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1706 total bytes of memory
BGP activity 14/8 prefixes, 14/8 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.1.1 4 64513 55 48 11 0 0 00:33:01 4
cus1.pop2#sh ip bgp
BGP table version is 11, local router ID is 172.16.101.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.0.0 172.16.1.1 0 64513 i
*> 172.16.1.0/30 0.0.0.0 0 32768 i
*> 172.16.2.0/30 172.16.1.1 0 64513 64514 i
*> 172.16.101.0/24 0.0.0.0 0 32768 i
*> 172.16.201.0/24 172.16.1.1 0 64513 64514 i
*> 192.168.0.0/16 172.16.1.1 0 64513 64515 i
cus1.pop2#

edge1.pop1#sh ip bgp summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 22, main routing table version 22
6 network entries using 768 bytes of memory
6 path entries using 312 bytes of memory
3/3 BGP path/bestpath attribute entries using 372 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1500 total bytes of memory
BGP activity 9/3 prefixes, 11/5 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State
/PfxRcd
10.0.3.1 4 64513 51 55 22 0 0 00:44:55
2
10.0.4.1 4 64513 21 25 22 0 0 00:16:24
2
192.168.1.2 4 64515 15 19 22 0 0 00:12:02
1
edge1.pop1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.2.1 1 FULL/DR 00:00:37 10.0.10.2 GigabitEtherne
t1/0
edge1.pop1#

core1.pop1#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.4.1 1 FULL/DR 00:00:30 10.0.30.1 GigabitEtherne
t3/0
10.0.3.1 1 FULL/BDR 00:00:37 10.0.20.1 GigabitEtherne
t2/0
10.0.1.1 1 FULL/BDR 00:00:37 10.0.10.1 GigabitEtherne
t1/0
core1.pop1#

edge1.pop2#sh ip bgp summary
BGP router identifier 10.0.3.1, local AS number 64513
BGP table version is 20, main routing table version 20
6 network entries using 768 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 496 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1624 total bytes of memory
BGP activity 11/5 prefixes, 12/6 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State
/PfxRcd
10.0.1.1 4 64513 57 53 20 0 0 00:43:50
2
10.0.4.1 4 64513 23 24 20 0 0 00:17:37
2
172.16.1.2 4 64514 42 46 20 0 0 00:35:41
2
edge1.pop2#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.4.1 1 FULL/DR 00:00:38 10.0.40.2 GigabitEtherne
t2/0
10.0.2.1 1 FULL/DR 00:00:33 10.0.20.2 GigabitEtherne
t1/0
edge1.pop2#

edge1.pop3#sh ip bgp summary
BGP router identifier 10.0.4.1, local AS number 64513
BGP table version is 27, main routing table version 27
6 network entries using 768 bytes of memory
6 path entries using 312 bytes of memory
4/4 BGP path/bestpath attribute entries using 496 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1624 total bytes of memory
BGP activity 8/2 prefixes, 13/7 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State
/PfxRcd
10.0.1.1 4 64513 28 24 27 0 0 00:17:02
2
10.0.3.1 4 64513 25 23 27 0 0 00:17:17
2
172.16.2.2 4 64514 35 45 27 0 0 00:29:38
2
edge1.pop3#sh ip ospf nei

Neighbor ID Pri State Dead Time Address Interface
10.0.3.1 1 FULL/BDR 00:00:32 10.0.40.1 GigabitEtherne
t2/0
10.0.2.1 1 FULL/BDR 00:00:37 10.0.30.2 GigabitEtherne
t1/0
edge1.pop3#

No comments:

Post a Comment