Wednesday, June 23, 2010

Implementing IPTV using NGN MVPN over m-LDP LAB
















Configuration Guidelines
********************************************************
Scenario: An ISP wants to offer IPTV Services witout
using native multicast across his SP Core.

Design Considerations and Soultion:

There are two possinle solutions for offering Multicast Services
to Customers witout running native Multicast in SP Core.
1. Using P2MP RSVP-TE Tunnels
2. using NGN MVPN over m-LDP

Here we are focussing on 2nd solution to provide IPTV services by
an MVPN for IPTV across SP Core over m-LDP and putting IPTV Customers
Access Link into the IPTV VRF and using PIM SSM for the IPTV VRF so
that Customers can Switch to their desire of channel and STBs
can receive the interested Multicast Streamm for the Channel


The traditional way to offer MVPN services us using GRE Tunnels across
SP Core using default MDT (Multicast Tunnel Interfaces) which needs
SP to run native multicast across its core .

m-LDP(Multicast LDP) is an Overlay Solution which lifts up the need
to run native multicast across its core and still provide Multicast
VPN Services to the MPLS VPN users using Label Switched m-LDP Signalling to
establish PIM adjancies per vrf over LSP Virtual Interfaces (LSPvif)

It basically creates a M2MP (Multipoint to Multippint) mesh of LSP
Virtual Interfcaes overlayed upon the underlying TE Mesh using the mldp
neighbouring between already existing LDP neighbours

The SP only needs to run Multicast for the VRFs and not on core links.
This solution is all the same as The GRE Tunnel Overlayed MVPN excpet
here we are using LDP as Signalling for Multicast Traffic

Challenges: Since we are using the same VRF for lot of Customers there is
a potential shared group over this MVPN. To keep a check on this
we use a Hub and Spoke Model for the IPTV Source and Receivers. we
use separate export RTs per Customer and Import same into IPTV Source
We import the IPTv Source RT into each Customer VPN instance.

ISP IGP used OSPF Area 0
Primary Onehop Auto-Tunnels and Primary nhop-only Backup Tunnels used in
SP Core.
Root-Address for SP used as core1.pop1 Lo0 10.0.2.1
PE-CE ROuting Protocol used OSPF
PIM SSM Used for IPTV MVPN
IGMP Group used for Testing 232.1.1.1
********************************************************************************





cus1.pop1#sh running-config
Building configuration...

Current configuration : 976 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.1.1.1 source 192.168.101.1
!
interface FastEthernet0/0
description edge1.pop1
ip address 172.16.1.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 172.16.101.1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop1#

cus1.pop3#sh running-config
Building configuration...

Current configuration : 976 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.201.1 255.255.255.0
ip pim sparse-mode
ip igmp join-group 232.1.1.1 source 192.168.101.1
!
interface FastEthernet0/0
description edge1.pop3
ip address 172.16.3.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 10
router-id 172.16.201.1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
ip classless
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop3#

IPTV#sh running-config
Building configuration...

Current configuration : 1134 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IPTV
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip subnet-zero
!
!
ip cef
no ip domain lookup
no ip dhcp use vrf connected
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.101.1 255.255.255.0
ip pim sparse-mode
!
interface FastEthernet0/0
description edge1.pop2
ip address 192.168.1.2 255.255.255.252
ip pim sparse-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 64515
no synchronization
bgp router-id 192.168.101.1
bgp log-neighbor-changes
network 192.168.0.0 mask 255.255.0.0
neighbor 192.168.1.1 remote-as 64513
neighbor 192.168.1.1 description ISP
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip classless
ip route 192.168.0.0 255.255.0.0 Null0
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

IPTV#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 3053 bytes
!
! Last configuration change at 18:07:29 UTC Wed Jun 23 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:1
vpn id 100:1
route-target export 64513:101
route-target import 64513:100
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-L1
ip address 10.0.10.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description core1.pop1-L2
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop1
ip vrf forwarding IPTV
ip address 172.16.1.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 10 vrf IPTV
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.3.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
redistribute ospf 10 vrf IPTV match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim vrf IPTV ssm default
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop1#

core1.pop1#sh running-config
Building configuration...

Current configuration : 1985 bytes
!
! Last configuration change at 17:30:42 UTC Wed Jun 23 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop1-L2
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description edge1.pop2
ip address 10.0.30.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet4/0
description edge1.pop3
ip address 10.0.40.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
mpls traffic-eng multicast-intact
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

core1.pop1#

edge1.pop3#sh run
Building configuration...

Current configuration : 2993 bytes
!
! Last configuration change at 18:06:55 UTC Wed Jun 23 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:1
vpn id 100:1
route-target export 64513:102
route-target import 64513:100
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.40.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.50.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop3
ip vrf forwarding IPTV
ip address 172.16.3.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 10 vrf IPTV
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.3.1 peer-group iBGP
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
redistribute ospf 10 vrf IPTV match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim vrf IPTV ssm default
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop3#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 3155 bytes
!
! Last configuration change at 17:46:13 UTC Wed Jun 23 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf IPTV
rd 64513:1
vpn id 100:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:101
route-target import 64513:102
route-target import 64513:103
route-target import 64513:104
route-target import 64513:105
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
no ip domain lookup
ip multicast-routing vrf IPTV
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.30.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop3
ip address 10.0.50.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description IPTV
ip vrf forwarding IPTV
ip address 192.168.1.1 255.255.255.252
ip pim sparse-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
neighbor 192.168.1.2 remote-as 64515
neighbor 192.168.1.2 description IPTV
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.4.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf IPTV
no synchronization
redistribute connected
neighbor 192.168.1.2 remote-as 64515
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 soft-reconfiguration inbound
exit-address-family
!
no ip http server
no ip http secure-server
!
!
ip pim vrf IPTV ssm default
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

***************************************************
OUTPUT
***************************************************
MULTICAST TRAFFIC PATH
***************************
IPTV#mtrace 172.16.101.1 192.168.101.1 232.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.101.1 to 192.168.101.1 via group 232.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 192.168.101.1
-1 192.168.101.1 PIM [172.16.101.1/32]
-2 192.168.1.1 PIM/MBGP [172.16.101.1/32]
-3 * * * 10.0.1.1
IPTV#mtrace 172.16.201.1 192.168.101.1 232.1.1.1
Type escape sequence to abort.
Mtrace from 172.16.201.1 to 192.168.101.1 via group 232.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 192.168.101.1
-1 192.168.101.1 PIM [172.16.201.1/32]
-2 192.168.1.1 PIM/MBGP [172.16.201.1/32]
-3 * * * 10.0.4.1
IPTV#ping 232.1.1.1 source lo0

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 232.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.101.1

Reply to request 0 from 172.16.1.2, 564 ms
Reply to request 0 from 172.16.3.2, 684 ms
IPTV#

cus1.pop1#mtrace 192.168.101.1 172.16.101.1 232.1.1.1
Type escape sequence to abort.
Mtrace from 192.168.101.1 to 172.16.101.1 via group 232.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.101.1
-1 172.16.101.1 PIM [192.168.0.0/16]
-2 172.16.1.1 PIM/MBGP [192.168.0.0/16]
-3 * * * 10.0.3.1
cus1.pop1#

cus1.pop3#mtrace 192.168.201.1 172.16.201.1 232.1.1.1
Type escape sequence to abort.
Mtrace from 192.168.201.1 to 172.16.201.1 via group 232.1.1.1
From source (?) to destination (?)
Querying full reverse path... * switching to hop-by-hop:
0 172.16.201.1
-1 172.16.201.1 PIM [192.168.0.0/16]
-2 172.16.3.1 PIM/MBGP [192.168.0.0/16]
-3 * * * 10.0.3.1
cus1.pop3#


****************************
Multicast Routing Table
***************************
IPTV#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.1.2, 232.1.1.1), 00:03:51/00:01:17, flags: sPT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(192.168.101.1, 232.1.1.1), 00:33:01/00:03:14, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:33:01/00:03:14

(*, 224.0.1.40), 00:43:00/00:02:22, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:43:00/00:02:22

IPTV#

cus1.pop1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:47:26/00:00:44, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.1.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:47:26/00:00:36

(*, 224.0.1.40), 00:48:17/00:02:52, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:48:15/00:02:52
Loopback0, Forward/Sparse, 00:48:17/00:02:50

cus1.pop1#

cus1.pop3#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:47:14/00:00:03, flags: sLTI
Incoming interface: FastEthernet0/0, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:47:14/00:00:49

(*, 224.0.1.40), 00:47:18/00:02:51, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:35:55/00:02:14
Loopback0, Forward/Sparse, 00:47:18/00:02:51

cus1.pop3#
cus1.pop1#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
232.1.1.1 Loopback0 00:48:24 stopped 172.16.101.1
224.0.1.40 FastEthernet0/0 00:49:13 00:02:55 172.16.1.1
224.0.1.40 Loopback0 00:49:15 00:02:48 172.16.101.1
cus1.pop1#

cus1.pop3#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
232.1.1.1 Loopback0 00:47:56 stopped 172.16.201.1
224.0.1.40 FastEthernet0/0 00:47:52 00:02:41 172.16.3.1
224.0.1.40 Loopback0 00:47:56 00:02:14 172.16.201.1
cus1.pop3#

edge1.pop2#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:35:12/00:03:17, flags: sT
Incoming interface: FastEthernet3/0, RPF nbr 192.168.1.2
Outgoing interface list:
Lspvif0, Forward/Sparse, 00:35:12/00:03:17

(*, 224.0.1.40), 00:53:52/00:02:25, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop2#

edge1.pop3#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:35:25/00:03:07, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.3.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:35:25/00:03:07

(*, 224.0.1.40), 00:51:14/00:02:45, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif0, Forward/Sparse, 00:50:11/00:02:12

edge1.pop3#

edge1.pop1#sh ip mroute vrf IPTV
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.101.1, 232.1.1.1), 00:35:06/00:02:40, flags: sT
Incoming interface: Lspvif0, RPF nbr 10.0.3.1
Outgoing interface list:
FastEthernet3/0, Forward/Sparse, 00:35:06/00:02:40

(*, 224.0.1.40), 01:04:47/00:02:41, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

edge1.pop1#



****************************
PIM Neighbourship over m-LDP
****************************
edge1.pop1#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.2 FastEthernet3/0 00:51:11/00:01:38 v2 1 / DR S G
10.0.4.1 Lspvif0 00:52:08/00:01:19 v2 1 / DR S P G
10.0.3.1 Lspvif0 00:55:32/00:01:14 v2 1 / S P G
edge1.pop1#

edge1.pop3#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.3.2 FastEthernet3/0 00:38:20/00:01:32 v2 1 / DR S G
10.0.1.1 Lspvif0 00:51:53/00:01:37 v2 1 / S P G
10.0.3.1 Lspvif0 00:51:54/00:01:31 v2 1 / S P G
edge1.pop3#

edge1.pop2#sh ip pim vrf IPTV neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet3/0 00:42:01/00:01:17 v2 1 / DR S G
10.0.4.1 Lspvif0 00:52:07/00:01:19 v2 1 / DR S P G
10.0.1.1 Lspvif0 00:55:35/00:01:20 v2 1 / S P G
edge1.pop2#
********************************
m-LDP
******************************

edge1.pop1#show mpls mldp nei

MLDP peer ID : 10.0.2.1:0, uptime 01:03:28 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 1
Branch count : 0
Path count : 4
Path(s) : 10.0.2.1 No LDP Tunnel65337
: 10.0.2.1 No LDP Tunnel65336
: 10.0.10.2 LDP GigabitEthernet1/0
: 10.0.20.2 LDP GigabitEthernet2/0
Nhop count : 3
Nhop list : 10.0.2.1 10.0.10.2 10.0.20.2
edge1.pop1#show mpls mldp bindings
System ID: 91000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 20, local binding[D]: 20 active

edge1.pop1#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : 91000001 (RNR LSM ID: FF000002) Type: MP2MP Uptime : 01:07:11
FEC Root : 10.0.2.1
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
RNR active LSP : (this entry)
Upstream client(s) :
10.0.2.1:0 [Active]
Expires : Never Path Set ID : 15000001
Out Label (U) : 17 Interface : Tunnel65337*
Local Label (D): 20 Next Hop : 10.0.2.1
Replication client(s):
MDT (VRF IPTV)
Uptime : 01:07:11 Path Set ID : C3000002
Interface : Lspvif0

edge1.pop1#

core1.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.1.1:0, uptime 01:03:42 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 1
Path count : 4
Path(s) : 10.0.1.1 No LDP Tunnel65336
: 10.0.1.1 No LDP Tunnel65337
: 10.0.10.1 LDP GigabitEthernet1/0
: 10.0.20.1 LDP GigabitEthernet2/0
Nhop count : 0

MLDP peer ID : 10.0.3.1:0, uptime 00:57:21 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.3.1 No LDP Tunnel65338
: 10.0.30.1 LDP GigabitEthernet3/0
Nhop count : 0

MLDP peer ID : 10.0.4.1:0, uptime 00:53:58 Up,
Target Adj : Yes
Session hndl : 3
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.4.1 No LDP Tunnel65339
: 10.0.40.1 LDP GigabitEthernet4/0
Nhop count : 0
core1.pop1#show mpls mldp bindings
System ID: 14000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.1.1:0, local binding[U]: 20, remote binding[D]: 20
lsr: 10.0.3.1:0, local binding[U]: 21, remote binding[D]: 21
lsr: 10.0.4.1:0, local binding[U]: 22, remote binding[D]: 22

core1.pop1#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : 14000001 Type: MP2MP Uptime : 01:03:52
FEC Root : 10.0.2.1 (we are the root)
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
Upstream client(s) :
None
Expires : N/A Path Set ID : C4000001
Replication client(s):
10.0.1.1:0
Uptime : 01:03:52 Path Set ID : BF000002
Out label (D) : 20 Interface : Tunnel65336*
Local label (U): 17 Next Hop : 10.0.1.1
10.0.3.1:0
Uptime : 00:57:11 Path Set ID : 20000003
Out label (D) : 21 Interface : Tunnel65338*
Local label (U): 19 Next Hop : 10.0.3.1
10.0.4.1:0
Uptime : 00:54:09 Path Set ID : 7D000004
Out label (D) : 22 Interface : Tunnel65339*
Local label (U): 22 Next Hop : 10.0.4.1

core1.pop1#

edge1.pop3#show mpls mldp nei

MLDP peer ID : 10.0.2.1:0, uptime 00:54:15 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 1
Branch count : 0
Path count : 1
Path(s) : 10.0.2.1 No LDP Tunnel65336
Nhop count : 1
Nhop list : 10.0.2.1

MLDP peer ID : 10.0.3.1:0, uptime 00:44:15 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 10.0.3.1 No LDP Tunnel65337
Nhop count : 0
edge1.pop3#show mpls mldp bindings
System ID: 66000001
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 22, local binding[D]: 22 active

edge1.pop3#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : 66000001 (RNR LSM ID: 23000002) Type: MP2MP Uptime : 00:54:38
FEC Root : 10.0.2.1
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
RNR active LSP : (this entry)
Upstream client(s) :
10.0.2.1:0 [Active]
Expires : Never Path Set ID : 9A000001
Out Label (U) : 22 Interface : Tunnel65336*
Local Label (D): 22 Next Hop : 10.0.2.1
Replication client(s):
MDT (VRF IPTV)
Uptime : 00:54:38 Path Set ID : 38000002
Interface : Lspvif0

edge1.pop3#

edge1.pop2#show mpls mldp neighbors

MLDP peer ID : 10.0.2.1:0, uptime 00:58:06 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 1
Branch count : 0
Path count : 1
Path(s) : 10.0.2.1 No LDP Tunnel65336
Nhop count : 1
Nhop list : 10.0.2.1

MLDP peer ID : 10.0.4.1:0, uptime 00:44:39 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 10.0.4.1 No LDP Tunnel65337
Nhop count : 0
edge1.pop2#show mpls mldp bindings
System ID: 1
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 21, local binding[D]: 21 active

edge1.pop2#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : 1 (RNR LSM ID: DB000002) Type: MP2MP Uptime : 00:57:59
FEC Root : 10.0.2.1
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
RNR active LSP : (this entry)
Upstream client(s) :
10.0.2.1:0 [Active]
Expires : Never Path Set ID : FA000001
Out Label (U) : 19 Interface : Tunnel65336*
Local Label (D): 21 Next Hop : 10.0.2.1
Replication client(s):
MDT (VRF IPTV)
Uptime : 00:57:59 Path Set ID : 33000002
Interface : Lspvif0

edge1.pop2#


****************************************
MPLS TE and Forwarding Table
****************************************

edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 2954 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 7 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 3197 seconds
Periodic auto-bw collection: every 300 seconds, next in 254 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65336 10.0.2.1 - Gi2/0 up/up
edge1.pop1_t65337 10.0.2.1 - Gi1/0 up/up
edge1.pop1_t65436 10.0.2.1 - Gi1/0 up/up
edge1.pop1_t65437 10.0.2.1 - Gi2/0 up/up
core1.pop1_t65336 10.0.1.1 Gi2/0 - up/up

core1.pop1_t65337 10.0.1.1 Gi1/0 - up/up

core1.pop1_t65436 10.0.1.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.1.1 Gi2/0 - up/up

Displayed 4 (of 4) heads, 0 (of 0) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#

edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 No Label 172.16.1.0/30[V] 0 aggregate/IPTV
17 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
[T] Pop Label 10.0.2.1/32 0 Tu65337 point2point
18 [T] Pop Label 10.0.40.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.40.0/30 0 Tu65337 point2point
19 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.30.0/30 0 Tu65337 point2point
20 [T] No Label [mdt 100:1 0][V] 19392 aggregate/IPTV
21 [T] 18 10.0.3.1/32 0 Tu65336 point2point
[T] 18 10.0.3.1/32 0 Tu65337 point2point
22 [T] 20 10.0.4.1/32 0 Tu65336 point2point
[T] 20 10.0.4.1/32 0 Tu65337 point2point
23 [T] 21 10.0.50.0/30 0 Tu65336 point2point
[T] 21 10.0.50.0/30 0 Tu65337 point2point
24 No Label 172.16.101.1/32[V] \
232 Fa3/0 172.16.1.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop1#

core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (4 ), id-range:65436-65535
onehop Enabled (4 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3140 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 1 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 139 seconds
Periodic auto-bw collection: every 300 seconds, next in 140 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.1.1 - Gi2/0 up/up
core1.pop1_t65337 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65338 10.0.3.1 - Gi3/0 up/up
core1.pop1_t65339 10.0.4.1 - Gi4/0 up/up
core1.pop1_t65436 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65437 10.0.1.1 - Gi2/0 up/up
core1.pop1_t65438 10.0.3.1 - Gi4/0 up/up
core1.pop1_t65439 10.0.4.1 - Gi3/0 up/up
edge1.pop1_t65336 10.0.2.1 Gi2/0 - up/up

edge1.pop1_t65337 10.0.2.1 Gi1/0 - up/up

edge1.pop1_t65436 10.0.2.1 Gi1/0 - up/up

edge1.pop1_t65437 10.0.2.1 Gi2/0 - up/up

edge1.pop2_t65336 10.0.2.1 Gi3/0 - up/up

edge1.pop2_t65436 10.0.2.1 Gi4/0 - up/up

edge1.pop2_t65437 10.0.4.1 Gi3/0 Gi4/0 up/up

edge1.pop3_t65336 10.0.2.1 Gi4/0 - up/up

edge1.pop3_t65436 10.0.2.1 Gi3/0 - up/up

edge1.pop3_t65437 10.0.3.1 Gi4/0 Gi3/0 up/up

Displayed 8 (of 8) heads, 2 (of 2) midpoints, 8 (of 8) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop1#show mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.1.1/32 20044 Tu65336 point2point
[T] Pop Label 10.0.1.1/32 11733 Tu65337 point2point
17 [T] 21 [mdt 100:1 0] 14812 Tu65338 point2point
[T] 22 [mdt 100:1 0] 14100 Tu65339 point2point
18 [T] Pop Label 10.0.3.1/32 27129 Tu65338 point2point
19 20 [mdt 100:1 0] 14832
[T] 22 [mdt 100:1 0] 13864 Tu65339 point2point
20 [T] Pop Label 10.0.4.1/32 15727 Tu65339 point2point
21 [T] Pop Label 10.0.50.0/30 0 Tu65338 point2point
[T] Pop Label 10.0.50.0/30 0 Tu65339 point2point
22 20 [mdt 100:1 0] 10836
[T] 21 [mdt 100:1 0] 10836 Tu65338 point2point
23 Pop Label 10.0.4.1 65437 [1] \
0 Gi3/0 10.0.30.1
24 Pop Label 10.0.3.1 65437 [1] \
0 Gi4/0 10.0.40.1

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
core1.pop1#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3501 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 740 seconds
Periodic auto-bw collection: every 300 seconds, next in 201 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop2_t65337 10.0.4.1 - Gi2/0 up/up
edge1.pop2_t65436 10.0.2.1 - Gi2/0 up/up
edge1.pop2_t65437 10.0.4.1 - Gi1/0 up/up
core1.pop1_t65338 10.0.3.1 Gi1/0 - up/up

core1.pop1_t65438 10.0.3.1 Gi2/0 - up/up

core1.pop1_t65439 10.0.4.1 Gi1/0 Gi2/0 up/up

edge1.pop3_t65337 10.0.3.1 Gi2/0 - up/up

edge1.pop3_t65436 10.0.2.1 Gi2/0 Gi1/0 up/up

edge1.pop3_t65437 10.0.3.1 Gi1/0 - up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop2#show mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
17 [T] 16 10.0.1.1/32 0 Tu65336 point2point
18 [T] Pop Label 10.0.40.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.40.0/30 0 Tu65337 point2point
19 [T] Pop Label 10.0.10.0/30 0 Tu65336 point2point
20 [T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
21 [T] No Label [mdt 100:1 0][V] 19410 aggregate/IPTV
22 [T] Pop Label 10.0.4.1/32 0 Tu65337 point2point
23 No Label 192.168.0.0/16[V] \
2948 Fa3/0 192.168.1.2
24 No Label 192.168.1.0/30[V] \
0 aggregate/IPTV
25 Pop Label 10.0.2.1 65439 [25] \
0 Gi2/0 10.0.50.2
26 Pop Label 10.0.4.1 65436 [25] \
0 Gi1/0 10.0.30.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop2#

edge1.pop3#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 161 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 794 seconds
Periodic auto-bw collection: every 300 seconds, next in 161 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop3_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop3_t65337 10.0.3.1 - Gi2/0 up/up
edge1.pop3_t65436 10.0.2.1 - Gi2/0 up/up
edge1.pop3_t65437 10.0.3.1 - Gi1/0 up/up
core1.pop1_t65339 10.0.4.1 Gi1/0 - up/up

core1.pop1_t65438 10.0.3.1 Gi1/0 Gi2/0 up/up

core1.pop1_t65439 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65337 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65436 10.0.2.1 Gi2/0 Gi1/0 up/up

edge1.pop2_t65437 10.0.4.1 Gi1/0 - up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop3#show mpls for
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.3.1/32 0 Tu65337 point2point
17 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
18 [T] 16 10.0.1.1/32 0 Tu65336 point2point
19 [T] Pop Label 10.0.10.0/30 0 Tu65336 point2point
20 [T] Pop Label 10.0.20.0/30 0 Tu65336 point2point
21 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.30.0/30 0 Tu65337 point2point
22 [T] No Label [mdt 100:1 0][V] 20970 aggregate/IPTV
23 No Label 172.16.3.0/30[V] 0 aggregate/IPTV
24 Pop Label 10.0.3.1 65436 [38] \
0 Gi1/0 10.0.40.2
25 Pop Label 10.0.2.1 65438 [36] \
0 Gi2/0 10.0.50.1
26 No Label 172.16.201.1/32[V] \
0 Fa3/0 172.16.3.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop3#

1 comment:

  1. Interesting and amazing how your post is! It Is Useful and helpful for me That I like it very much, and I am looking forward to Hearing from your next.. best IPTV 2020

    ReplyDelete