Tuesday, June 22, 2010

Implementing NGN Label Switched Multicast MPLS Multicast VPNs using m-LDP LAB















Configuration Guidelines
********************************************************
Scenario: An ISP wants to offer Multicast MPLS VPN Services
but without using native multicast across his SP Core.

Design Considerations and Soultion:

The traditional way to offer MVPN services us using GRE Tunnels across
SP Core using default MDT (Multicast Tunnel Interfaces) which needs
SP to run native multicast across its core .

m-LDP(Multicast LDP) is an Overlay Solution which lifts up the need
to run native multicast across its core and still provide Multicast
VPN Services to the MPLS VPN users using Label Switched m-LDP Signalling to
establish PIM adjancies per vrf over LSP Virtual Interfaces (LSPvif)

It basically creates a M2MP (Multipoint to Multippint) mesh of LSP
Virtual Interfcaes overlayed upon the underlying TE Mesh using the mldp
neighbouring between already existing LDP neighbours

The SP only needs to run Multicast for the VRFs and not on core links.
The Customer can use his choice of PIM Mode inside its VRF. This solution
is all the same as The GRE Tunnel Overlayed MVPN excpet here we are
using LDP as Signalling for Multicast Traffic

ISP IGP used OSPF Area 0
Primary Onehop Auto-Tunnels and Primary nhop-only Backup Tunnels used in
SP Core.
Root-Address for SP used as core1.pop1 Lo0 10.0.2.1
PE-CE ROuting Protocol used OSPF
RP used in CE Domain BSR
IGMP Group used for Testing 239.16.16.16
********************************************************************************

cus1.pop1#sh running-config
Building configuration...

Current configuration : 947 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.101.1 255.255.255.0
ip pim sparse-dense-mode
!
interface FastEthernet0/0
description edge1.pop1
ip address 172.16.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 10
router-id 172.16.101.1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop1#
cus1.pop2#sh running-config
Building configuration...

Current configuration : 917 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.201.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 239.16.16.16
!
interface FastEthernet0/0
description edge1.pop3
ip address 172.16.2.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 10
router-id 172.16.201.1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
ip pim ssm default
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop3#

cus1.pop2#sh running-config
Building configuration...

Current configuration : 876 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cus1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
ip multicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.251.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 239.16.16.16
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
description edge1.pop2
ip address 172.16.3.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
!
router ospf 10
router-id 172.16.251.1
log-adjacency-changes
network 172.16.0.0 0.0.255.255 area 0
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

cus1.pop2#

edge1.pop1#sh running-config
Building configuration...

Current configuration : 2967 bytes
!
! Last configuration change at 17:08:54 UTC Mon Jun 21 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
vpn id 100:1
route-target export 64513:100
route-target import 64513:100
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
no ip domain lookup
ip multicast-routing vrf cus1
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex half
!
interface GigabitEthernet1/0
description core1.pop1-L1
ip address 10.0.10.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description core1.pop1-L2
ip address 10.0.20.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop1
ip vrf forwarding cus1
ip address 172.16.1.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router ospf 1
router-id 10.0.1.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.3.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop1#

core1.pop1#sh running-config
Building configuration...

Current configuration : 1969 bytes
!
! Last configuration change at 17:07:53 UTC Mon Jun 21 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname core1.pop1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description edge1.pop1-L1
ip address 10.0.10.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.30.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet3/0
description edge1.pop3
ip address 10.0.40.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet4/0
description edge1.pop1-L2
ip address 10.0.20.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
router ospf 1
router-id 10.0.2.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

core1.pop1#

edge1.pop2#sh running-config
Building configuration...

Current configuration : 2563 bytes
!
! Last configuration change at 17:08:11 UTC Mon Jun 21 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
ip vrf cus1
rd 64513:1
vpn id 100:1
route-target export 64513:100
route-target import 64513:100
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.30.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop3
ip address 10.0.50.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet3/1
description cus1.pop1
ip vrf forwarding cus1
ip address 172.16.3.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
interface FastEthernet4/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet4/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 1
router-id 10.0.3.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.4.1 peer-group iBGP
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.4.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.4.1 activate
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end

edge1.pop2#

edge1.pop3#sh running-config
Building configuration...

Current configuration : 2990 bytes
!
! Last configuration change at 17:08:24 UTC Mon Jun 21 2010
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname edge1.pop3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip source-route
ip cef
!
!
ip vrf cus1
rd 64513:1
vpn id 100:1
route-target export 64513:100
route-target import 64513:100
mdt preference mldp
mdt default mpls mldp 10.0.2.1

!
!
!
no ip domain lookup
ip multicast-routing vrf cus1
no ipv6 cef
!
!
multilink bundle-name authenticated
mpls mldp path traffic-eng
mpls traffic-eng tunnels
mpls traffic-eng auto-tunnel backup nhop-only
mpls traffic-eng auto-tunnel backup config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary onehop
mpls traffic-eng auto-tunnel primary config unnumbered-interface Loopback0
mpls traffic-eng auto-tunnel primary config mpls ip
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.4.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
description core1.pop1
ip address 10.0.40.1 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface GigabitEthernet2/0
description edge1.pop2
ip address 10.0.50.2 255.255.255.252
negotiation auto
mpls ip
mpls label protocol ldp
mpls traffic-eng tunnels
ip rsvp bandwidth
!
interface FastEthernet3/0
description cus1.pop3
ip vrf forwarding cus1
ip address 172.16.2.1 255.255.255.252
ip pim sparse-dense-mode
speed auto
duplex auto
!
interface FastEthernet3/1
no ip address
shutdown
speed auto
duplex auto
!
router ospf 10 vrf cus1
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.16.0.0 0.0.255.255 area 0
!
router ospf 1
router-id 10.0.4.1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor iBGP peer-group
neighbor iBGP remote-as 64513
neighbor iBGP description iBGP
neighbor iBGP update-source Loopback0
neighbor 10.0.1.1 peer-group iBGP
neighbor 10.0.3.1 peer-group iBGP
!
address-family ipv4
no synchronization
neighbor iBGP next-hop-self
neighbor iBGP soft-reconfiguration inbound
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor iBGP send-community extended
neighbor iBGP next-hop-self
neighbor 10.0.1.1 activate
neighbor 10.0.3.1 activate
exit-address-family
!
address-family ipv4 vrf cus1
no synchronization
redistribute connected
redistribute ospf 10 vrf cus1 match internal external 1 external 2
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end

edge1.pop3#

OUTPUT
*********************************************************
CE ROuting Table and Unicast/Multicast Traffic
*********************************************************
cus1.pop1#ping 239.16.16.16

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.16.16.16, timeout is 2 seconds:

Reply to request 0 from 172.16.2.2, 996 ms
Reply to request 0 from 172.16.3.2, 1280 ms
Reply to request 0 from 172.16.3.2, 1044 ms
Reply to request 0 from 172.16.2.2, 1044 ms
cus1.pop1#

Cus1.pop2#traceroute 172.16.101.1

Type escape sequence to abort.
Tracing the route to 172.16.101.1

1 172.16.3.1 568 msec 856 msec 608 msec
2 10.0.30.2 736 msec 696 msec 1504 msec
3 172.16.1.1 1068 msec 452 msec 396 msec
4 172.16.1.2 944 msec * 1332 msec
cus1.pop2#traceroute 172.16.201.1

Type escape sequence to abort.
Tracing the route to 172.16.201.1

1 172.16.3.1 292 msec 488 msec 232 msec
2 172.16.2.1 340 msec 592 msec 320 msec
3 172.16.2.2 964 msec 1088 msec *
cus1.pop2#

cus1.pop1#traceroute 172.16.251.1

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.1.1 416 msec 332 msec 296 msec
2 10.0.20.2 848 msec 560 msec 984 msec
3 172.16.3.1 728 msec 856 msec 904 msec
4 172.16.3.2 372 msec 2136 msec 600 msec
cus1.pop1#

cus1.pop3#traceroute 172.16.251.1

Type escape sequence to abort.
Tracing the route to 172.16.251.1

1 172.16.2.1 164 msec 224 msec 784 msec
2 172.16.3.1 996 msec 176 msec 112 msec
3 172.16.3.2 1688 msec 308 msec 1992 msec
cus1.pop3#

cus1.pop1#ping 239.16.16.16

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.16.16.16, timeout is 2 seconds:

Reply to request 0 from 172.16.3.2, 1112 ms
Reply to request 0 from 172.16.3.2, 1116 ms
cus1.pop1#

cus1.pop1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
O IA 172.16.251.1/32 [110/3] via 172.16.1.1, 00:10:32, FastEthernet0/0
O IA 172.16.201.1/32 [110/3] via 172.16.1.1, 00:58:15, FastEthernet0/0
C 172.16.1.0/30 is directly connected, FastEthernet0/0
O IA 172.16.2.0/30 [110/2] via 172.16.1.1, 00:58:15, FastEthernet0/0
O IA 172.16.3.0/30 [110/2] via 172.16.1.1, 00:14:02, FastEthernet0/0
C 172.16.101.0/24 is directly connected, Loopback0
cus1.pop1#

cus1.pop2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
C 172.16.251.0/24 is directly connected, Loopback0
O IA 172.16.201.1/32 [110/3] via 172.16.3.1, 00:10:44, FastEthernet0/1
O IA 172.16.1.0/30 [110/2] via 172.16.3.1, 00:10:44, FastEthernet0/1
O IA 172.16.2.0/30 [110/2] via 172.16.3.1, 00:10:44, FastEthernet0/1
C 172.16.3.0/30 is directly connected, FastEthernet0/1
O IA 172.16.101.1/32 [110/3] via 172.16.3.1, 00:10:44, FastEthernet0/1
cus1.pop2#

cus1.pop3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 6 subnets, 3 masks
O IA 172.16.251.1/32 [110/3] via 172.16.2.1, 00:11:03, FastEthernet0/0
C 172.16.201.0/24 is directly connected, Loopback0
O IA 172.16.1.0/30 [110/2] via 172.16.2.1, 01:01:13, FastEthernet0/0
C 172.16.2.0/30 is directly connected, FastEthernet0/0
O IA 172.16.3.0/30 [110/2] via 172.16.2.1, 00:14:35, FastEthernet0/0
O IA 172.16.101.1/32 [110/3] via 172.16.2.1, 00:58:38, FastEthernet0/0
cus1.pop3#



cus1.pop2#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.16.16.16), 00:14:06/stopped, RP 172.16.101.1, flags: SJCL
Incoming interface: FastEthernet0/1, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:14:06/00:02:49

(172.16.1.2, 239.16.16.16), 00:00:18/00:02:45, flags: LJT
Incoming interface: FastEthernet0/1, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:00:18/00:02:49

(172.16.101.1, 239.16.16.16), 00:00:29/00:02:45, flags: LJT
Incoming interface: FastEthernet0/1, RPF nbr 172.16.3.1
Outgoing interface list:
Loopback0, Forward/Sparse, 00:00:29/00:02:49

(*, 224.0.1.40), 00:15:28/00:02:57, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:10:28/00:02:57
Loopback0, Forward/Sparse, 00:15:28/00:02:43

cus1.pop2#

cus1.pop1#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.16.16.16), 00:30:53/00:03:05, RP 172.16.101.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:30:53/00:03:05

(172.16.1.2, 239.16.16.16), 00:00:46/00:02:25, flags: PT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null

(172.16.101.1, 239.16.16.16), 00:00:46/00:02:56, flags: T
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:00:46/00:03:05

(*, 224.0.1.40), 00:31:13/00:02:35, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:31:13/00:00:00
Loopback0, Forward/Sparse-Dense, 00:31:13/00:00:00

cus1.pop1#
cus1.pop1#
cus1.pop1#



cus1.pop2#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
239.16.16.16 Loopback0 00:15:30 00:02:24 172.16.251.1
224.0.1.40 FastEthernet0/1 00:11:52 00:02:24 172.16.3.1
224.0.1.40 Loopback0 00:16:51 00:02:19 172.16.251.1
cus1.pop2#

********************************
MPLDP
********************************
edge1.pop2#show mpls mldp bindings opaque_type mdt
System ID: 15000003
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 28, local binding[D]: 28 active

edge1.pop2#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : 15000003 (RNR LSM ID: C1000004) Type: MP2MP Uptime : 00:05:10
FEC Root : 10.0.2.1
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
RNR active LSP : (this entry)
Upstream client(s) :
10.0.2.1:0 [Active]
Expires : Never Path Set ID : 6D000005
Out Label (U) : 24 Interface : Tunnel65337*
Local Label (D): 28 Next Hop : 10.0.2.1
Replication client(s):
MDT (VRF cus1)
Uptime : 00:05:10 Path Set ID : 35000006
Interface : Lspvif0

edge1.pop2#show mpls mldp nei

MLDP peer ID : 10.0.4.1:0, uptime 01:18:42 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 10.0.4.1 No LDP Tunnel65336
Nhop count : 0

MLDP peer ID : 10.0.2.1:0, uptime 01:15:14 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 1
Branch count : 0
Path count : 1
Path(s) : 10.0.2.1 No LDP Tunnel65337
Nhop count : 1
Nhop list : 10.0.2.1
edge1.pop2#

edge1.pop3#show mpls mldp neighbors

MLDP peer ID : 10.0.3.1:0, uptime 01:19:09 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 10.0.3.1 No LDP Tunnel65336
Nhop count : 0

MLDP peer ID : 10.0.2.1:0, uptime 01:14:57 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 1
Branch count : 0
Path count : 1
Path(s) : 10.0.2.1 No LDP Tunnel65337
Nhop count : 1
Nhop list : 10.0.2.1
edge1.pop3#
edge1.pop3#
edge1.pop3#show mpls mldp bindigs
^
% Invalid input detected at '^' marker.

edge1.pop3#show mpls mldp bindings
System ID: B000003
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.2.1:0, remote binding[U]: 27, local binding[D]: 27 active

edge1.pop3#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : B000003 (RNR LSM ID: 4) Type: MP2MP Uptime : 00:05:09
FEC Root : 10.0.2.1
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
RNR active LSP : (this entry)
Upstream client(s) :
10.0.2.1:0 [Active]
Expires : Never Path Set ID : 9000003
Out Label (U) : 25 Interface : Tunnel65337*
Local Label (D): 27 Next Hop : 10.0.2.1
Replication client(s):
MDT (VRF cus1)
Uptime : 00:05:09 Path Set ID : 54000004
Interface : Lspvif0

edge1.pop3#
edge1.pop3#
edge1.pop3#

core1.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.1.1:0, uptime 01:23:12 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.1.1 No LDP Tunnel65338
: 10.0.1.1 No LDP Tunnel65336
Nhop count : 0

MLDP peer ID : 10.0.3.1:0, uptime 01:16:11 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 1
Path count : 1
Path(s) : 10.0.3.1 No LDP Tunnel65337
Nhop count : 0

MLDP peer ID : 10.0.4.1:0, uptime 01:15:28 Up,
Target Adj : Yes
Session hndl : 3
Upstream count : 0
Branch count : 1
Path count : 1
Path(s) : 10.0.4.1 No LDP Tunnel65339
Nhop count : 0
core1.pop1#

core1.pop1#show mpls mldp neighbors

MLDP peer ID : 10.0.1.1:0, uptime 01:23:12 Up,
Target Adj : Yes
Session hndl : 1
Upstream count : 0
Branch count : 1
Path count : 2
Path(s) : 10.0.1.1 No LDP Tunnel65338
: 10.0.1.1 No LDP Tunnel65336
Nhop count : 0

MLDP peer ID : 10.0.3.1:0, uptime 01:16:11 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 0
Branch count : 1
Path count : 1
Path(s) : 10.0.3.1 No LDP Tunnel65337
Nhop count : 0

MLDP peer ID : 10.0.4.1:0, uptime 01:15:28 Up,
Target Adj : Yes
Session hndl : 3
Upstream count : 0
Branch count : 1
Path count : 1
Path(s) : 10.0.4.1 No LDP Tunnel65339
Nhop count : 0
core1.pop1#

core1.pop1#show mpls mldp bindings
System ID: AA000002
Type: MP2MP, Root Node: 10.0.2.1, Opaque Len: 14
Opaque value: [mdt 100:1 0]
lsr: 10.0.3.1:0, local binding[U]: 28, remote binding[D]: 28
lsr: 10.0.4.1:0, local binding[U]: 27, remote binding[D]: 27
lsr: 10.0.1.1:0, local binding[U]: 22, remote binding[D]: 22

core1.pop1#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : AA000002 Type: MP2MP Uptime : 00:06:59
FEC Root : 10.0.2.1 (we are the root)
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
Upstream client(s) :
None
Expires : N/A Path Set ID : 3C000003
Replication client(s):
10.0.3.1:0
Uptime : 00:06:59 Path Set ID : B4000004
Out label (D) : 28 Interface : Tunnel65337*
Local label (U): 24 Next Hop : 10.0.3.1
10.0.4.1:0
Uptime : 00:05:55 Path Set ID : 26000005
Out label (D) : 27 Interface : Tunnel65339*
Local label (U): 25 Next Hop : 10.0.4.1
10.0.1.1:0
Uptime : 00:05:34 Path Set ID : 7A000006
Out label (D) : 22 Interface : Tunnel65338*
Local label (U): 26 Next Hop : 10.0.1.1

core1.pop1#

***********************
PIM VRF
************************
edge1.pop1#show ip pim vrf cus1 neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.1.2 FastEthernet3/0 01:01:47/00:01:43 v2 1 / DR S G
10.0.3.1 Lspvif0 00:05:50/00:01:12 v2 1 / S P G
10.0.4.1 Lspvif0 00:05:51/00:01:21 v2 1 / DR S P G
edge1.pop1#

edge1.pop2#show ip pim vrf cus1 neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.3.2 FastEthernet3/1 00:08:54/00:01:35 v2 1 / DR S G
10.0.1.1 Lspvif0 00:05:25/00:01:36 v2 1 / S P G
10.0.4.1 Lspvif0 00:05:44/00:01:37 v2 1 / DR S P G
edge1.pop2#

edge1.pop3#show ip pim vrf cus1 neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
172.16.2.2 FastEthernet3/0 01:00:57/00:01:25 v2 1 / DR S G
10.0.1.1 Lspvif0 00:06:29/00:01:36 v2 1 / S P G
10.0.3.1 Lspvif0 00:06:51/00:01:25 v2 1 / S P G
edge1.pop3#

***********************
MPLS TE
*************************
edge1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3177 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 383 seconds
Periodic auto-bw collection: every 300 seconds, next in 177 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop1_t65336 10.0.2.1 - Gi1/0 up/up
edge1.pop1_t65337 10.0.2.1 - Gi2/0 up/up
edge1.pop1_t65436 10.0.2.1 - Gi2/0 up/up
edge1.pop1_t65437 10.0.2.1 - Gi1/0 up/up
core1.pop1_t65336 10.0.1.1 Gi1/0 - up/up

core1.pop1_t65338 10.0.1.1 Gi2/0 - up/up

core1.pop1_t65436 10.0.1.1 Gi2/0 - up/up

core1.pop1_t65438 10.0.1.1 Gi1/0 - up/up

Displayed 4 (of 4) heads, 0 (of 0) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop1#

edge1.pop3#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 92 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 4 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 384 seconds
Periodic auto-bw collection: every 300 seconds, next in 92 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop3_t65336 10.0.3.1 - Gi2/0 up/up
edge1.pop3_t65337 10.0.2.1 - Gi1/0 up/up
edge1.pop3_t65436 10.0.3.1 - Gi1/0 up/up
edge1.pop3_t65437 10.0.2.1 - Gi2/0 up/up
core1.pop1_t65339 10.0.4.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.3.1 Gi1/0 Gi2/0 up/up

core1.pop1_t65439 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65336 10.0.4.1 Gi2/0 - up/up

edge1.pop2_t65436 10.0.4.1 Gi1/0 - up/up

edge1.pop2_t65437 10.0.2.1 Gi2/0 Gi1/0 up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop3#
edge1.pop3#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3592 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 2 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 278 seconds
Periodic auto-bw collection: every 300 seconds, next in 292 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.4.1 - Gi2/0 up/up
edge1.pop2_t65337 10.0.2.1 - Gi1/0 up/up
edge1.pop2_t65436 10.0.4.1 - Gi1/0 up/up
edge1.pop2_t65437 10.0.2.1 - Gi2/0 up/up
core1.pop1_t65337 10.0.3.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.3.1 Gi2/0 - up/up

core1.pop1_t65439 10.0.4.1 Gi1/0 Gi2/0 up/up

edge1.pop3_t65336 10.0.3.1 Gi2/0 - up/up

edge1.pop3_t65436 10.0.3.1 Gi1/0 - up/up

edge1.pop3_t65437 10.0.2.1 Gi2/0 Gi1/0 up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop2#
edge1.pop2#

edge1.pop2#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (2 ), id-range:65436-65535
onehop Enabled (2 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3569 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: Not Running
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 255 seconds
Periodic auto-bw collection: every 300 seconds, next in 269 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
edge1.pop2_t65336 10.0.4.1 - Gi2/0 up/up
edge1.pop2_t65337 10.0.2.1 - Gi1/0 up/up
edge1.pop2_t65436 10.0.4.1 - Gi1/0 up/up
edge1.pop2_t65437 10.0.2.1 - Gi2/0 up/up
core1.pop1_t65337 10.0.3.1 Gi1/0 - up/up

core1.pop1_t65437 10.0.3.1 Gi2/0 - up/up

core1.pop1_t65439 10.0.4.1 Gi1/0 Gi2/0 up/up

edge1.pop3_t65336 10.0.3.1 Gi2/0 - up/up

edge1.pop3_t65436 10.0.3.1 Gi1/0 - up/up

edge1.pop3_t65437 10.0.2.1 Gi2/0 Gi1/0 up/up

Displayed 4 (of 4) heads, 2 (of 2) midpoints, 4 (of 4) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
edge1.pop2#

core1.pop1#show mpls traffic-eng tunnels brief
Signalling Summary:
LSP Tunnels Process: running
Passive LSP Listener: running
RSVP Process: running
Forwarding: enabled
auto-tunnel:
backup Enabled (4 ), id-range:65436-65535
onehop Enabled (4 ), id-range:65336-65435
mesh Disabled (0 ), id-range:64336-65335

Periodic reoptimization: every 3600 seconds, next in 3429 seconds
Periodic FRR Promotion: Not Running
Periodic auto-tunnel:
primary establish scan: every 10 seconds, next in 9 seconds
primary rm active scan: disabled
backup notinuse scan: every 3600 seconds, next in 318 seconds
Periodic auto-bw collection: every 300 seconds, next in 129 seconds

P2P TUNNELS/LSPs:
TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PR
OT
core1.pop1_t65336 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65337 10.0.3.1 - Gi2/0 up/up
core1.pop1_t65338 10.0.1.1 - Gi4/0 up/up
core1.pop1_t65339 10.0.4.1 - Gi3/0 up/up
core1.pop1_t65436 10.0.1.1 - Gi4/0 up/up
core1.pop1_t65437 10.0.3.1 - Gi3/0 up/up
core1.pop1_t65438 10.0.1.1 - Gi1/0 up/up
core1.pop1_t65439 10.0.4.1 - Gi2/0 up/up
edge1.pop1_t65336 10.0.2.1 Gi1/0 - up/up

edge1.pop1_t65337 10.0.2.1 Gi4/0 - up/up

edge1.pop1_t65436 10.0.2.1 Gi4/0 - up/up

edge1.pop1_t65437 10.0.2.1 Gi1/0 - up/up

edge1.pop2_t65337 10.0.2.1 Gi2/0 - up/up

edge1.pop2_t65436 10.0.4.1 Gi2/0 Gi3/0 up/up

edge1.pop2_t65437 10.0.2.1 Gi3/0 - up/up

edge1.pop3_t65337 10.0.2.1 Gi3/0 - up/up

edge1.pop3_t65436 10.0.3.1 Gi3/0 Gi2/0 up/up

edge1.pop3_t65437 10.0.2.1 Gi2/0 - up/up

Displayed 8 (of 8) heads, 2 (of 2) midpoints, 8 (of 8) tails

P2MP TUNNELS:
Displayed 0 (of 0) P2MP heads

P2MP SUB-LSPS:
Displayed 0 P2MP sub-LSPs:
0 (of 0) heads, 0 (of 0) midpoints, 0 (of 0) tails
core1.pop1#
core1.pop1#

edge1.pop2#show mpls mldp database
* Indicates MLDP recursive forwarding is enabled

LSM ID : E4000001 Type: MP2MP Uptime : 00:46:25
FEC Root : 10.0.3.1 (we are the root)
Opaque decoded : [mdt 100:1 0]
Opaque length : 11 bytes
Opaque value : 07 000B 0001000000000100000000
Upstream client(s) :
None
Expires : N/A Path Set ID : 45000001
Replication client(s):
10.0.2.1:0
Uptime : 00:46:25 Path Set ID : 90000002
Out label (D) : 21 Interface : Tunnel65337*
Local label (U): 24 Next Hop : 10.0.2.1
10.0.4.1:0
Uptime : 00:44:44 Path Set ID : FE000003
Out label (D) : 24 Interface : Tunnel65336*
Local label (U): 25 Next Hop : 10.0.4.1

edge1.pop2#
***********************
MPLS Forwarding-Table
***********************
edge1.pop1#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.2.1/32 0 Tu65336 point2point
[T] Pop Label 10.0.2.1/32 0 Tu65337 point2point
17 [T] Pop Label 10.0.40.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.40.0/30 0 Tu65337 point2point
18 [T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
[T] Pop Label 10.0.30.0/30 0 Tu65337 point2point
19 [T] 17 10.0.4.1/32 0 Tu65336 point2point
[T] 17 10.0.4.1/32 0 Tu65337 point2point
20 [T] 18 10.0.3.1/32 0 Tu65336 point2point
[T] 18 10.0.3.1/32 0 Tu65337 point2point
21 [T] 19 10.0.50.0/30 0 Tu65336 point2point
[T] 19 10.0.50.0/30 0 Tu65337 point2point
22 [T] No Label [mdt 100:1 0][V] 7292 aggregate/cus1
23 No Label 172.16.1.0/30[V] 114 aggregate/cus1
24 No Label 172.16.101.1/32[V] \
2826 Fa3/0 172.16.1.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop1#

edge1.pop3#show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 [T] Pop Label 10.0.3.1/32 0 Tu65336 point2point
17 [T] Pop Label 10.0.30.0/30 0 Tu65337 point2point
[T] Pop Label 10.0.30.0/30 0 Tu65336 point2point
18 [T] Pop Label 10.0.2.1/32 0 Tu65337 point2point
19 [T] 16 10.0.1.1/32 0 Tu65337 point2point
20 [T] Pop Label 10.0.20.0/30 0 Tu65337 point2point
21 [T] Pop Label 10.0.10.0/30 0 Tu65337 point2point
22 Pop Label 10.0.3.1 65437 [12] \
0 Gi1/0 10.0.40.2
23 Pop Label 10.0.2.1 65437 [14] \
0 Gi2/0 10.0.50.1
24 [T] No Label [mdt 100:1 0][V] 9418 aggregate/cus1
25 No Label 172.16.2.0/30[V] 166 aggregate/cus1
26 No Label 172.16.201.1/32[V] \
1130 Fa3/0 172.16.2.2

[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
edge1.pop3#

No comments:

Post a Comment