Wednesday, December 23, 2009

Implementing BGP SoO in MPLS L3 VPN LAB



Config Guidelines
*********************************************************************************
ISP AS used 64513
IGP in ISP AS USed ISIS with Loopbacks in Level-1 and backbone links in level-2
Customer AS used 64514
PE-CE Routing Protocol used EBGP
VRF Used CEA
rd 64513:1
rt 64513:100
CE1A & CE2A have IBGP between them
SoO used 64513:1000 on PE1 and PE2 at neighbor level in the VRF EBGP
*************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1626 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.50.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description <>
ip address 172.16.4.2 255.255.255.252
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.16.10.0 mask 255.255.255.0
network 172.16.50.0 mask 255.255.255.0
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description <>
neighbor 172.16.1.1 soft-reconfiguration inbound
neighbor 172.16.4.1 remote-as 64514
neighbor 172.16.4.1 description <>
neighbor 172.16.4.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1619 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.40.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.16.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
description <>
ip address 172.16.4.1 255.255.255.252
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.2.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.16.20.0 mask 255.255.255.0
network 172.16.40.0 mask 255.255.255.0
neighbor 172.16.2.1 remote-as 64513
neighbor 172.16.2.1 description <>
neighbor 172.16.2.1 soft-reconfiguration inbound
neighbor 172.16.4.2 remote-as 64514
neighbor 172.16.4.2 description <>
neighbor 172.16.4.2 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE2A#
CE2A#
CE3A#sh running-config
Building configuration...
Current configuration : 1352 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.30.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.3.2 255.255.255.252
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.16.30.0 mask 255.255.255.0
neighbor 172.16.3.1 remote-as 64513
neighbor 172.16.3.1 description <>
neighbor 172.16.3.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE3A#
PE1#sh running-config
Building configuration...
Current configuration : 2888 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
neighbor 172.16.1.2 remote-as 64514
neighbor 172.16.1.2 description <>
neighbor 172.16.1.2 activate
neighbor 172.16.1.2 as-override
neighbor 172.16.1.2 soft-reconfiguration inbound
neighbor 172.16.1.2 route-map SoO in
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
access-list 10 permit any
!
route-map SoO permit 10
match ip address 10
set extcommunity soo 64513:1000
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1#
PE2#sh running-config
Building configuration...
Current configuration : 2889 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 172.16.2.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.2222.3333.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
neighbor 172.16.2.2 remote-as 64514
neighbor 172.16.2.2 description <>
neighbor 172.16.2.2 activate
neighbor 172.16.2.2 as-override
neighbor 172.16.2.2 soft-reconfiguration inbound
neighbor 172.16.2.2 route-map SoO in
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
access-list 20 permit any
!
route-map SoO permit 10
match ip address 20
set extcommunity soo 64513:1000
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2#
PE2#
PE3#sh running-config
Building configuration...
Current configuration : 2724 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip vrf forwarding CEA
ip address 172.16.3.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.3333.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
neighbor 172.16.3.2 remote-as 64514
neighbor 172.16.3.2 description <>
neighbor 172.16.3.2 activate
neighbor 172.16.3.2 as-override
neighbor 172.16.3.2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE3#
PE3#
PE3#
******************************************************************************
OUTPUT
*******************************************************************************
BEFORE Implementing BGP SoO
*******************************************************************************
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks
C 172.16.1.0/30 is directly connected, Serial1/0
L 172.16.1.1/32 is directly connected, Serial1/0
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:04:42
B 172.16.3.0/30 [200/0] via 10.0.3.1, 00:22:58
B 172.16.10.0/24 [20/0] via 172.16.1.2, 00:09:57
B 172.16.20.0/24 [20/0] via 172.16.1.2, 00:09:57
B 172.16.30.0/24 [200/0] via 10.0.3.1, 00:18:13
B 172.16.40.0/24 [20/0] via 172.16.1.2, 00:09:57
B 172.16.50.0/24 [20/0] via 172.16.1.2, 00:09:57
PE1#
PE1#sh ip bgp vpnv4 all
BGP table version is 16, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*> 172.16.1.0/30 0.0.0.0 0 32768 ?
*>i172.16.2.0/30 10.0.2.1 0 100 0 ?
*>i172.16.3.0/30 10.0.3.1 0 100 0 ?
* i172.16.10.0/24 10.0.2.1 0 100 0 64514 i
*> 172.16.1.2 0 0 64514 i
* i172.16.20.0/24 10.0.2.1 0 100 0 64514 i
*> 172.16.1.2 0 64514 i
*>i172.16.30.0/24 10.0.3.1 0 100 0 64514 i
* i172.16.40.0/24 10.0.2.1 0 100 0 64514 i
*> 172.16.1.2 0 64514 i
* i172.16.50.0/24 10.0.2.1 0 100 0 64514 i
*> 172.16.1.2 0 0 64514 i
PE1#sh ip bgp vpnv4 all 172.16.40.0
BGP routing table entry for 64513:1:172.16.40.0/24, version 13
Paths: (3 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.2.1 (metric 20) from 10.0.2.1 (10.0.2.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
mpls labels in/out 22/22
64514
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, localpref 100, valid, external, best
Extended Community: RT:64513:100
mpls labels in/out 22/nolabel
64514, (received-only)
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, localpref 100, valid, external
mpls labels in/out 22/nolabel
PE1#
PE2#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:11:10
C 172.16.2.0/30 is directly connected, Serial1/0
L 172.16.2.1/32 is directly connected, Serial1/0
B 172.16.3.0/30 [200/0] via 10.0.3.1, 00:20:41
B 172.16.10.0/24 [20/0] via 172.16.2.2, 00:05:38
B 172.16.20.0/24 [20/0] via 172.16.2.2, 00:05:38
B 172.16.30.0/24 [200/0] via 10.0.3.1, 00:19:11
B 172.16.40.0/24 [20/0] via 172.16.2.2, 00:05:38
B 172.16.50.0/24 [20/0] via 172.16.2.2, 00:05:38
PE2#sh ip bgp vpnv4 all
BGP table version is 24, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
*> 172.16.2.0/30 0.0.0.0 0 32768 ?
*>i172.16.3.0/30 10.0.3.1 0 100 0 ?
*> 172.16.10.0/24 172.16.2.2 0 64514 i
* i 10.0.1.1 0 100 0 64514 i
*> 172.16.20.0/24 172.16.2.2 0 0 64514 i
* i 10.0.1.1 0 100 0 64514 i
*>i172.16.30.0/24 10.0.3.1 0 100 0 64514 i
*> 172.16.40.0/24 172.16.2.2 0 0 64514 i
* i 10.0.1.1 0 100 0 64514 i
*> 172.16.50.0/24 172.16.2.2 0 64514 i
* i 10.0.1.1 0 100 0 64514 i
PE2#sh ip bgp vpnv4 all 172.16.50.0
BGP routing table entry for 64513:1:172.16.50.0/24, version 22
Paths: (3 available, best #1, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, localpref 100, valid, external, best
Extended Community: RT:64513:100
mpls labels in/out 21/nolabel
64514, (received-only)
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, localpref 100, valid, external
mpls labels in/out 21/nolabel
64514
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
mpls labels in/out 21/20
PE2#
PE3#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 9 subnets, 3 masks
B 172.16.1.0/30 [200/0] via 10.0.1.1, 00:07:24
B 172.16.2.0/30 [200/0] via 10.0.2.1, 00:02:09
C 172.16.3.0/30 is directly connected, Serial1/2
L 172.16.3.1/32 is directly connected, Serial1/2
B 172.16.10.0/24 [200/0] via 10.0.1.1, 00:07:09
B 172.16.20.0/24 [200/0] via 10.0.1.1, 00:07:09
B 172.16.30.0/24 [20/0] via 172.16.3.2, 00:15:41
B 172.16.40.0/24 [200/0] via 10.0.1.1, 00:07:09
B 172.16.50.0/24 [200/0] via 10.0.1.1, 00:07:09
PE3#sh ip bgp vpnv4 all
BGP table version is 19, local router ID is 10.0.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*>i172.16.1.0/30 10.0.1.1 0 100 0 ?
*>i172.16.2.0/30 10.0.2.1 0 100 0 ?
*> 172.16.3.0/30 0.0.0.0 0 32768 ?
* i172.16.10.0/24 10.0.2.1 0 100 0 64514 i
*>i 10.0.1.1 0 100 0 64514 i
* i172.16.20.0/24 10.0.2.1 0 100 0 64514 i
*>i 10.0.1.1 0 100 0 64514 i
*> 172.16.30.0/24 172.16.3.2 0 0 64514 i
* i172.16.40.0/24 10.0.2.1 0 100 0 64514 i
*>i 10.0.1.1 0 100 0 64514 i
* i172.16.50.0/24 10.0.2.1 0 100 0 64514 i
*>i 10.0.1.1 0 100 0 64514 i
PE3#sh ip bgp vpnv4 all 172.16.40.0
BGP routing table entry for 64513:1:172.16.40.0/24, version 16
Paths: (2 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.2.1 (metric 20) from 10.0.2.1 (10.0.2.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
mpls labels in/out nolabel/22
64514
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64513:100
mpls labels in/out nolabel/22
PE3#sh ip bgp vpnv4 all 172.16.50.0
BGP routing table entry for 64513:1:172.16.50.0/24, version 17
Paths: (2 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.2.1 (metric 20) from 10.0.2.1 (10.0.2.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: RT:64513:100
mpls labels in/out nolabel/21
64514
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin IGP, metric 0, localpref 100, valid, internal, best
Extended Community: RT:64513:100
mpls labels in/out nolabel/20
PE3#
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
C 172.16.50.0/24 is directly connected, Loopback0
B 172.16.40.0/24 [200/0] via 172.16.4.1, 00:13:29
B 172.16.30.0/24 [20/0] via 172.16.1.1, 00:13:29
B 172.16.20.0/24 [200/0] via 172.16.4.1, 00:13:29
C 172.16.10.0/24 is directly connected, FastEthernet0/0
C 172.16.4.0/30 is directly connected, FastEthernet0/1
C 172.16.1.0/30 is directly connected, Serial1/0
B 172.16.2.0/30 [20/0] via 172.16.1.1, 00:08:15
B 172.16.3.0/30 [20/0] via 172.16.1.1, 00:13:29
CE1A#ping 172.16.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 192/319/468 ms
CE1A#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 9 subnets, 2 masks
B 172.16.50.0/24 [200/0] via 172.16.4.2, 00:14:10
C 172.16.40.0/24 is directly connected, Loopback0
B 172.16.30.0/24 [20/0] via 172.16.2.1, 00:08:47
C 172.16.20.0/24 is directly connected, FastEthernet0/0
B 172.16.10.0/24 [200/0] via 172.16.4.2, 00:14:10
C 172.16.4.0/30 is directly connected, FastEthernet0/1
B 172.16.1.0/30 [20/0] via 172.16.2.1, 00:08:47
C 172.16.2.0/30 is directly connected, Serial1/0
B 172.16.3.0/30 [20/0] via 172.16.2.1, 00:08:47
CE2A#ping 172.16.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 100/212/312 ms
CE2A#
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 8 subnets, 2 masks
B 172.16.50.0/24 [20/0] via 172.16.3.1, 00:15:43
B 172.16.40.0/24 [20/0] via 172.16.3.1, 00:15:43
C 172.16.30.0/24 is directly connected, Loopback0
B 172.16.20.0/24 [20/0] via 172.16.3.1, 00:15:43
B 172.16.10.0/24 [20/0] via 172.16.3.1, 00:15:43
B 172.16.1.0/30 [20/0] via 172.16.3.1, 00:15:58
B 172.16.2.0/30 [20/0] via 172.16.3.1, 00:10:42
C 172.16.3.0/30 is directly connected, Serial1/0
CE3A#ping 172.16.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/102/244 ms
CE3A#ping 172.16.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/104/196 ms
CE3A#
CE3A#traceroute 172.16.50.1
Type escape sequence to abort.
Tracing the route to 172.16.50.1
1 172.16.3.1 56 msec 80 msec 60 msec
2 172.16.1.1 [AS 64513] 28 msec 168 msec 44 msec
3 172.16.1.2 [AS 64513] 184 msec 128 msec *
CE3A#traceroute 172.16.40.1
Type escape sequence to abort.
Tracing the route to 172.16.40.1
1 172.16.3.1 212 msec 64 msec 60 msec
2 172.16.1.1 [AS 64513] 96 msec 84 msec 132 msec
3 172.16.1.2 [AS 64513] 224 msec 240 msec 124 msec
4 172.16.4.1 120 msec 184 msec *
CE3A#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 172.16.3.1 64 msec 60 msec 76 msec
2 172.16.1.1 [AS 64513] 172 msec 116 msec 76 msec
3 172.16.1.2 [AS 64513] 136 msec 108 msec 60 msec
4 172.16.4.1 84 msec 92 msec *
CE3A#
*******************************************************************************
AFTER Implementing BGP SoO
*******************************************************************************
PE1#sh ip bgp vpnv4 all 172.16.10.0
BGP routing table entry for 64513:1:172.16.10.0/24, version 5
Paths: (3 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.2.1 (metric 20) from 10.0.2.1 (10.0.2.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 25/25
64514
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, metric 0, localpref 100, valid, external, best
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 25/nolabel
64514, (received-only)
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, metric 0, localpref 100, valid, external
mpls labels in/out 25/nolabel
PE1#sh ip bgp vpnv4 all 172.16.40.0
BGP routing table entry for 64513:1:172.16.40.0/24, version 8
Paths: (3 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.2.1 (metric 20) from 10.0.2.1 (10.0.2.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 27/27
64514
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, localpref 100, valid, external, best
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 27/nolabel
64514, (received-only)
172.16.1.2 from 172.16.1.2 (172.16.50.1)
Origin IGP, localpref 100, valid, external
mpls labels in/out 27/nolabel
PE1#
PE2#sh ip bgp vpnv4 all 172.16.50.0
BGP routing table entry for 64513:1:172.16.50.0/24, version 9
Paths: (3 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 28/28
64514
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, localpref 100, valid, external, best
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 28/nolabel
64514, (received-only)
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, localpref 100, valid, external
mpls labels in/out 28/nolabel
PE2#sh ip bgp vpnv4 all 172.16.20.0
BGP routing table entry for 64513:1:172.16.20.0/24, version 6
Paths: (3 available, best #2, table CEA)
Flag: 0x820
Advertised to update-groups:
1
64514
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin IGP, metric 0, localpref 100, valid, internal
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 26/26
64514
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, metric 0, localpref 100, valid, external, best
Extended Community: SoO:64513:1000 RT:64513:100
mpls labels in/out 26/nolabel
64514, (received-only)
172.16.2.2 from 172.16.2.2 (172.16.40.1)
Origin IGP, metric 0, localpref 100, valid, external
mpls labels in/out 26/nolabel
PE2#
CE1A#sh ip bgp
BGP table version is 19, local router ID is 172.16.50.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
r i172.16.1.0/30 172.16.2.1 0 100 0 64513 ?
r> 172.16.1.1 0 0 64513 ?
*> 172.16.2.0/30 172.16.1.1 0 64513 ?
* i 172.16.2.1 0 100 0 64513 ?
*> 172.16.3.0/30 172.16.1.1 0 64513 ?
* i 172.16.2.1 0 100 0 64513 ?
*> 172.16.10.0/24 0.0.0.0 0 32768 i
*>i172.16.20.0/24 172.16.4.1 0 100 0 i
*> 172.16.30.0/24 172.16.1.1 0 64513 64513 i
* i 172.16.2.1 0 100 0 64513 64513 i
*>i172.16.40.0/24 172.16.4.1 0 100 0 i
*> 172.16.50.0/24 0.0.0.0 0 32768 i
CE1A#
CE2A#sh ip bgp
BGP table version is 23, local router ID is 172.16.40.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 172.16.1.0/30 172.16.2.1 0 64513 ?
* i 172.16.1.1 0 100 0 64513 ?
r i172.16.2.0/30 172.16.1.1 0 100 0 64513 ?
r> 172.16.2.1 0 0 64513 ?
* i172.16.3.0/30 172.16.1.1 0 100 0 64513 ?
*> 172.16.2.1 0 64513 ?
*>i172.16.10.0/24 172.16.4.2 0 100 0 i
*> 172.16.20.0/24 0.0.0.0 0 32768 i
* i172.16.30.0/24 172.16.1.1 0 100 0 64513 64513 i
*> 172.16.2.1 0 64513 64513 i
*> 172.16.40.0/24 0.0.0.0 0 32768 i
*>i172.16.50.0/24 172.16.4.2 0 100 0 i
CE2A#

No comments:

Post a Comment