Monday, December 14, 2009

Implementing Load Balancing with MHSRP and BGP Split-Routing LAB



Config Guidelines
********************************************************************************
Customer AS 64514
Provider AS 64513
Internet AS 64515
IGP used in Provider Domain as ISIS with Loopbacks in Level 1 and PE1,PE2 in same Area.
P is i different Area and Peering between PEs and P is Level 2.
Provider to Internet Peering is EBGP
IGP used in Customer Domain is OSPF and MHSRP is running between CE1A and CE2A with
Standby Group 1 as Default Gateway for CE1A End User and Standby Group 2 as Default
Gateway for CE2A End User
Customer to Provider Peering is EBGP
Split Static Routing Used at PEs for the Subnet 10.0.1.0/24 and redistributed into IBGP
so that Reverse path goes via PE1 & PE2 for 10.0.1.0/25 and 10.0.1.128/25 respectively normally.
Also 10.0.1.0/24 is pointed as a Static towards CEs and redistributed into BGP for PE-CE Failure conditions
In case of PE-CE Link failure redundancy between CEs and ISPs Peerings via BGP
In case of LAN Link failure between Router to Switchesand redundancy between CEs is via MHSRP.
************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1946 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description <>
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
standby 1 ip 10.0.1.2
standby 1 preempt
standby 1 track Serial0/0
standby 1 track FastEthernet0/0
standby 2 ip 10.0.1.130
standby 2 priority 95
standby 2 preempt
standby 2 track Serial0/0
standby 2 track FastEthernet0/0
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
shutdown
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.1.0 0.0.0.255 area 0
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.129 remote-as 64514
neighbor 10.0.1.129 description <>
neighbor 10.0.1.129 next-hop-self
neighbor 10.0.1.129 default-originate
neighbor 10.0.1.129 soft-reconfiguration inbound
neighbor 192.168.1.2 remote-as 64513
neighbor 192.168.1.2 description <>
neighbor 192.168.1.2 soft-reconfiguration inbound
neighbor 192.168.1.2 route-map PE1_OUT out
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
ip http server
no ip http secure-server
!
!
!
ip prefix-list PE1_OUT seq 10 deny 0.0.0.0/0
route-map PE1_OUT permit 10
match ip address prefix-list PE1_OUT
!
route-map Local permit 10
match interface Serial0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1928 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description <>
ip address 10.0.1.129 255.255.255.0
duplex auto
speed auto
standby 1 ip 10.0.1.2
standby 1 priority 95
standby 1 preempt
standby 1 track Serial0/0
standby 1 track FastEthernet0/0
standby 2 ip 10.0.1.130
standby 2 preempt
standby 2 track Serial0/0
standby 2 track FastEthernet0/0
!
interface Serial0/0
description <>
ip address 192.168.1.5 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.1.0 0.0.0.255 area 0
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64514
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 default-originate
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 192.168.1.6 remote-as 64513
neighbor 192.168.1.6 description <>
neighbor 192.168.1.6 soft-reconfiguration inbound
neighbor 192.168.1.6 route-map PE2_OUT out
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.6
!
ip http server
no ip http secure-server
!
!
!
ip prefix-list PE2_OUT seq 10 deny 0.0.0.0/0
route-map PE2_OUT permit 10
match ip address prefix-list PE2_OUT
!
route-map Local permit 10
match interface Serial0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
CE2A#
CE2A#
PE1#sh running-config
Building configuration...
Current configuration : 2141 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.10.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/2
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3
no ip address
shutdown
clockrate 2000000
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Local
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
redistribute static
neighbor 192.168.1.1 remote-as 64514
neighbor 192.168.1.1 description <>
neighbor 192.168.1.1 default-originate
neighbor 192.168.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 route-map STATIC out
neighbor 192.168.30.1 remote-as 64513
neighbor 192.168.30.1 description <>
neighbor 192.168.30.1 update-source Loopback0
neighbor 192.168.30.1 next-hop-self
neighbor 192.168.30.1 soft-reconfiguration inbound
no auto-summary
!
ip classless
ip route 10.0.1.0 255.255.255.0 192.168.1.1
ip route 10.0.1.0 255.255.255.128 192.168.1.1
!
ip as-path access-list 10 permit ^$
ip http server
no ip http secure-server
!
!
route-map STATIC deny 10
match as-path 10
!
route-map STATIC permit 20
!
route-map Local permit 10
match interface Serial0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
PE1#
PE1#
PE1#
PE2#sh running-config
Building configuration...
Current configuration : 2144 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.20.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.13 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
description <>
ip address 192.168.1.6 255.255.255.252
clockrate 2000000
!
interface Serial0/2
no ip address
shutdown
clockrate 2000000
!
interface Serial0/3
no ip address
shutdown
clockrate 2000000
!
router isis
net 49.0001.2222.3333.4444.00
redistribute connected route-map Local
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
redistribute static
neighbor 192.168.1.5 remote-as 64514
neighbor 192.168.1.5 description <>
neighbor 192.168.1.5 default-originate
neighbor 192.168.1.5 soft-reconfiguration inbound
neighbor 192.168.1.5 route-map STATIC out
neighbor 192.168.30.1 remote-as 64513
neighbor 192.168.30.1 description <>
neighbor 192.168.30.1 update-source Loopback0
neighbor 192.168.30.1 next-hop-self
neighbor 192.168.30.1 soft-reconfiguration inbound
no auto-summary
!
ip classless
ip route 10.0.1.0 255.255.255.0 192.168.1.5
ip route 10.0.1.128 255.255.255.128 192.168.1.5
!
ip as-path access-list 10 permit ^$
ip http server
no ip http secure-server
!
!
route-map STATIC deny 10
match as-path 10
!
route-map STATIC permit 20
!
route-map Local permit 10
match interface Serial0/1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
P#sh run
P#sh running-config
Building configuration...
Current configuration : 2340 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.30.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
description <>
ip address 192.168.1.14 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/2
description <>
ip address 172.16.1.1 255.255.255.252
clockrate 2000000
!
interface Serial0/3
no ip address
shutdown
clockrate 2000000
!
interface Serial0/4
no ip address
shutdown
clockrate 2000000
!
interface Serial0/5
no ip address
shutdown
clockrate 2000000
!
router isis
net 49.0002.4444.5555.6666.00
redistribute connected route-map Local
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
aggregate-address 10.0.1.0 255.255.255.0 summary-only
redistribute connected route-map Local
neighbor 172.16.1.2 remote-as 64515
neighbor 172.16.1.2 description <>
neighbor 172.16.1.2 soft-reconfiguration inbound
neighbor 192.168.10.1 remote-as 64513
neighbor 192.168.10.1 description <>
neighbor 192.168.10.1 update-source Loopback0
neighbor 192.168.10.1 next-hop-self
neighbor 192.168.10.1 soft-reconfiguration inbound
neighbor 192.168.20.1 remote-as 64513
neighbor 192.168.20.1 description <>
neighbor 192.168.20.1 update-source Loopback0
neighbor 192.168.20.1 next-hop-self
neighbor 192.168.20.1 soft-reconfiguration inbound
no auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Serial0/2
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
P#
Internet#sh running-config
Building configuration...
Current configuration : 1260 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet
!
boot-start-marker
boot-end-marker
!
no logging console
!
memory-size iomem 5
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.10.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 172.16.1.2 255.255.255.252
clockrate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 default-originate
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip classless
!
ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end
Internet#
Internet#

No comments:

Post a Comment