Monday, December 28, 2009

Implementing Internet Access In MPLS VPN Using VRF Aware NAT at Local PE LAB



Config Guidelines
****************************************************************************************
Scenario - Providing Internet Access to MPLS VPN Cusomer using Route-Leaking via Global
Internet Table with using NAT for the Customer's Private IP Block used for Internet
ISP AS used 64513
IGP in ISP is ISIS with Loopbacks in Level-1 and Core Links in Level-2
EBGP used with Internet Router
Customer AS Used 64514
PE-CE Routing Protocol EBGP
Internet AS 64515
Lo0 and Lo1 used for Dummy Traffic
VRF Used CEA
rd 64513:1
rt 6413:100
CE1B is Normal IP Customer in AS 64516 running EBGP with PE2
CE1A and CE2A are VPN Sites with CE1A only having Internet Access.
Used NAT Inside on Serial1/0 at PE1 and NAT Outisde on Core Link Serial1/1towards P
NAT Pool Used GRE_Internet 192.168.1/0/30
Extended ACL used 134 Denying 10.0.1.1/32 and Allowing 192.168.100.0/24
CE1A has a default Route towards PE1 via Serial1/0
ANy Non-VPN Traffic from CE1A comes to PE1 via Serial1/0 and get Natted Outbound to
192.168.1.1 and Goes to Internet Router Internet Router has Reverse Route till PE1
for 192.168.1.1 and from there Reverse NAT Happens towards CE1A
***************************************************************************************
CE1A#show running-config
Building configuration...
Current configuration : 1474 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 10.0.2.10 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 10.0.2.9 remote-as 64513
neighbor 10.0.2.9 description <>
neighbor 10.0.2.9 allowas-in 5
neighbor 10.0.2.9 soft-reconfiguration inbound
no auto-summary
!
ip http server
ip route 0.0.0.0 0.0.0.0 Serial1/0
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE1A#
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1380 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.20.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 10.0.2.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 10.0.2.5 remote-as 64513
neighbor 10.0.2.5 description <>
neighbor 10.0.2.5 allowas-in 5
neighbor 10.0.2.5 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE2A#
CE1B#sh running-config
Building configuration...
Current configuration : 1424 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1B
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.200.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 192.168.1.9 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64516
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 192.168.1.10 remote-as 64513
neighbor 192.168.1.10 description <>
neighbor 192.168.1.10 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE1B#
PE1#sh running-config
Building configuration...
Current configuration : 2733 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 10.0.2.9 255.255.255.252
ip nat inside
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip nat outside
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
neighbor 10.0.2.10 remote-as 64514
neighbor 10.0.2.10 description <>
neighbor 10.0.2.10 activate
neighbor 10.0.2.10 soft-reconfiguration inbound
exit-address-family
!
ip nat pool Internet 192.168.1.1 192.168.1.2 netmask 255.255.255.252
ip nat inside source list 134 pool Internet vrf CEA overload
ip classless
ip route vrf CEA 0.0.0.0 0.0.0.0 192.168.1.2 global
!
!
no ip http server
no ip http secure-server
!
access-list 134 deny ip host 10.0.1.1 any
access-list 134 permit ip 192.168.100.0 0.0.0.255 any
!
route-map CEA permit 10
match ip address CEA
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1#
PE2#sh running-config
Building configuration...
Current configuration : 2790 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
ip address 192.168.1.10 255.255.255.252
serial restart-delay 0
!
interface Serial1/2
description
ip vrf forwarding CEA
ip address 10.0.2.5 255.255.255.252
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.2222.3333.4444.00
redistribute connected route-map Local
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
aggregate-address 192.168.0.0 255.255.0.0 summary-only
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 192.168.1.9 remote-as 64516
neighbor 192.168.1.9 description <>
neighbor 192.168.1.9 default-originate
neighbor 192.168.1.9 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
neighbor 10.0.2.6 remote-as 64514
neighbor 10.0.2.6 description <>
neighbor 10.0.2.6 activate
neighbor 10.0.2.6 send-community extended
neighbor 10.0.2.6 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Serial1/1
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2#
PE2#
P#sh running-config
Building configuration...
Current configuration : 2419 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.3333.2222.1111.00
redistribute connected route-map Local
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
aggregate-address 192.168.0.0 255.255.0.0 summary-only
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
neighbor 172.16.1.2 remote-as 64515
neighbor 172.16.1.2 description <>
neighbor 172.16.1.2 soft-reconfiguration inbound
no auto-summary
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Serial1/1
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
P#
Internet_Router#sh running-config
Building configuration...
Current configuration : 1511 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet_Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.10.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.16.20.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 172.16.1.1 remote-as 64513
neighbor 172.16.1.1 description <>
neighbor 172.16.1.1 default-originate
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
Internet_Router#
***********************************************************************
OUTPUT
**********************************************************************
CE1A#ping 172.16.10.1 source fastEthernet 0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.100.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 112/311/420 ms
CE1A#
CE1A#traceroute 172.16.20.1 source fastEthernet 0/0
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 10.0.2.9 168 msec 136 msec 568 msec
2 192.168.1.2 340 msec 584 msec 196 msec
3 172.16.1.2 492 msec 364 msec *
CE1A#
CE1A#ping 10.0.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 200/272/372 ms
CE1A#
CE2A#traceroute 10.0.10.1
Type escape sequence to abort.
Tracing the route to 10.0.10.1
1 10.0.2.5 68 msec 156 msec 96 msec
2 192.168.1.6 400 msec 528 msec 304 msec
3 10.0.2.9 [AS 64513] 308 msec 420 msec 192 msec
4 10.0.2.10 [AS 64513] 720 msec 516 msec 1184 msec
CE2A#
PE1#show access-lists
Extended IP access list 134
10 deny ip host 10.0.1.1 any
20 permit ip 192.168.100.0 0.0.0.255 any (13 matches)
PE1#sho
PE1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
tcp 192.168.1.1:4097 192.168.100.2:3316 20.137.181.130:445 20.137.181.130:445
tcp 192.168.1.1:4099 192.168.100.2:3324 20.137.181.166:443 20.137.181.166:443
tcp 192.168.1.1:4096 192.168.100.2:3329 20.137.181.166:443 20.137.181.166:443
tcp 192.168.1.1:4098 192.168.100.2:3330 20.198.16.7:445 20.198.16.7:445
tcp 192.168.1.1:4100 192.168.100.2:3331 20.198.16.7:139 20.198.16.7:139
tcp 192.168.1.1:4101 192.168.100.2:3339 20.137.181.166:443 20.137.181.166:443
udp 192.168.1.1:4501 192.168.100.2:3340 20.198.58.50:389 20.198.58.50:389
PE1#
CE1B#ping 172.16.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 200/379/588 ms
CE1B#tra
CE1B#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 192.168.1.10 [AS 64513] 260 msec 308 msec 120 msec
2 192.168.1.6 [AS 64513] 708 msec 696 msec 1312 msec
3 172.16.1.2 [AS 64513] 504 msec 364 msec 360 msec
CE1B#
CE2A#ping 192.168.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE2A#
CE1B#ping 10.0.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.10.1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
CE1B#
CE1B#ping 10.0.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.20.1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
CE1B#
CE2A#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE2A#
CE1A#ping 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE1A#
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.0.10.0/24 is directly connected, Loopback0
C 10.0.2.8/30 is directly connected, Serial1/0
B 10.0.2.4/30 [20/0] via 10.0.2.9, 00:19:24
B 10.0.20.0/24 [20/0] via 10.0.2.9, 00:19:24
C 192.168.100.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, Serial1/0
CE1A#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.10.0/24 [20/0] via 10.0.2.5, 00:19:28
B 10.0.2.8/30 [20/0] via 10.0.2.5, 00:19:28
C 10.0.2.4/30 is directly connected, Serial1/0
C 10.0.20.0/24 is directly connected, Loopback0
B 192.168.100.0/24 [20/0] via 10.0.2.5, 00:19:28
CE2A#
CE1B#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.10 to network 0.0.0.0
C 192.168.10.0/24 is directly connected, Loopback0
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [20/0] via 192.168.1.10, 00:56:03
C 192.168.200.0/24 is directly connected, FastEthernet0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.8 is directly connected, Serial1/0
B* 0.0.0.0/0 [20/0] via 192.168.1.10, 00:58:15
B 192.168.0.0/16 [20/0] via 192.168.1.10, 00:58:15
CE1B#
PE1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is 10.0.3.1 to network 0.0.0.0
B* 0.0.0.0/0 [200/0] via 10.0.3.1, 00:20:06
10.0.0.0/32 is subnetted, 3 subnets
C 10.0.1.1 is directly connected, Loopback0
i L2 10.0.2.1 [115/30] via 192.168.1.2, Serial1/1
i L2 10.0.3.1 [115/20] via 192.168.1.2, Serial1/1
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 10.0.3.1, 00:20:06
B 192.168.0.0/16 [200/0] via 10.0.2.1, 00:20:06
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial1/1
L 192.168.1.1/32 is directly connected, Serial1/1
i L2 192.168.1.4/30 [115/20] via 192.168.1.2, Serial1/1
i L2 192.168.1.8/30 [115/20] via 192.168.1.2, Serial1/1
PE1#sh ip rou
PE1#sh ip route v
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is 192.168.1.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.1.2
10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
B 10.0.2.4/30 [200/0] via 10.0.2.1, 00:20:12
C 10.0.2.8/30 is directly connected, Serial1/0
L 10.0.2.9/32 is directly connected, Serial1/0
B 10.0.10.0/24 [20/0] via 10.0.2.10, 00:20:44
B 10.0.20.0/24 [200/0] via 10.0.2.1, 00:20:12
B 192.168.100.0/24 [20/0] via 10.0.2.10, 00:20:44
PE1#
Internet_Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.20.0/24 is directly connected, Loopback1
C 172.16.10.0/24 is directly connected, Loopback0
C 172.16.1.0/30 is directly connected, Serial1/0
B 192.168.0.0/16 [20/0] via 172.16.1.1, 00:57:07
Internet_Router#
P#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is 172.16.1.2 to network 0.0.0.0
B* 0.0.0.0/0 [20/0] via 172.16.1.2, 00:57:20
10.0.0.0/32 is subnetted, 3 subnets
i L2 10.0.1.1 [115/20] via 192.168.1.1, Serial1/0
i L2 10.0.2.1 [115/20] via 192.168.1.5, Serial1/1
C 10.0.3.1 is directly connected, Loopback0
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C 172.16.1.0/30 is directly connected, Serial1/2
L 172.16.1.1/32 is directly connected, Serial1/2
B 172.16.10.0/24 [20/0] via 172.16.1.2, 00:57:15
B 192.168.0.0/16 [200/0] via 10.0.2.1, 00:59:01
192.168.1.0/24 is variably subnetted, 5 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial1/0
L 192.168.1.2/32 is directly connected, Serial1/0
C 192.168.1.4/30 is directly connected, Serial1/1
L 192.168.1.6/32 is directly connected, Serial1/1
i L2 192.168.1.8/30 [115/10] via 192.168.1.5, Serial1/1
P#
P#

No comments:

Post a Comment