Tuesday, December 15, 2009

Implementing Internet Access via Central Site VRF providing Rdundancy Failover for Internet Traffic LAB



Config Guidelines
****************************************************************************************
ISP AS 64513
VRF used CEA
rd 6413:1
rt 64513:100
IGP in ISP AS is ISIS. Loopbacks in Level-1 and PE1,PE2 & PE3 in Area 1 with Level-2 Core Links
PE-CE Routing Protocol EBGP
Internet Access Is connected vis CE2A (Secondary) and CE1A(Primary).
CE1A has IGP OSPF which has a default route from Internet_2 and Injecting a Default-Route towards ISP.
CE1A is sending default-route via default-originate to PE1 which is further redistributed via MP-iBGP to
PE2 & PE3 and in turn CE2A & CE3A.
CE2A has a defaut route from Internet_1 and Injecting a default-route towards ISP.
CE2A is sending default-route via redistribution to PE2. CE2A is sending routes with community
string 64514:90 receiving which provider is setting Local Pref for the routes to 90 and hence making the
default-route via CE2A less preferrale as compared to CE1A. The default-route is further redistributed via MP-iBGP
to PE1 & PE3 and in turn CE1A & CE3A.
Preferred Internet Path is via CE1A Normally and via CE2A when PE1-CE1A Link down.
172.16.100.1/24 is configured on both Internet_1 & Internet_2 Lo0 to simulate Internet Traffic Effect.
Internet_1 AS 64516
Internet_2 AS 64515
Customer AS 64514
****************************************************************************************
Internet_2#sh running-config
Building configuration...
Current configuration : 1463 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet_2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.100.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 172.16.1.1 remote-as 64514
neighbor 172.16.1.1 description <>
neighbor 172.16.1.1 default-originate
neighbor 172.16.1.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Internet_2#
Internet_2#
CE11A#sh running-config
Building configuration...
Current configuration : 1617 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE11A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.11.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute bgp 64514 subnets
network 10.0.1.0 0.0.0.255 area 0
default-information originate always
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute ospf 100 match internal external 2
neighbor 172.16.1.2 remote-as 64515
neighbor 172.16.1.2 description <>
neighbor 172.16.1.2 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE11A#
CE1A#sh running-config
Building configuration...
Current configuration : 1668 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.10.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 192.168.1.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute bgp 64514 subnets
network 10.0.1.0 0.0.0.255 area 0
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute ospf 100 match internal external 2
neighbor 192.168.1.2 remote-as 64513
neighbor 192.168.1.2 default-originate
neighbor 192.168.1.2 allowas-in 5
neighbor 192.168.1.2 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1A#
PE1#sh running-config
Building configuration...
Current configuration : 2945 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.100.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description <>
ip address 192.168.10.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip address 192.168.10.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 64514
neighbor 192.168.1.1 description <>
neighbor 192.168.100.2 remote-as 64513
neighbor 192.168.100.2 description <>
neighbor 192.168.100.2 update-source Loopback0
neighbor 192.168.100.3 remote-as 64513
neighbor 192.168.100.3 description <>
neighbor 192.168.100.3 update-source Loopback0
!
address-family ipv4
neighbor 192.168.1.1 activate
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 next-hop-self
neighbor 192.168.100.2 soft-reconfiguration inbound
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 next-hop-self
neighbor 192.168.100.3 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 send-community extended
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.1 remote-as 64514
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 send-community extended
neighbor 192.168.1.1 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
PE1#
PE3#sh running-config
Building configuration...
Current configuration : 2884 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.100.3 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 182.168.10.10 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.10.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip vrf forwarding CEA
ip address 192.168.1.9 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router isis
net 49.0001.3333.2222.1111.00
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.1.10 remote-as 64514
neighbor 192.168.1.10 description <>
neighbor 192.168.100.1 remote-as 64513
neighbor 192.168.100.1 description <>
neighbor 192.168.100.1 update-source Loopback0
neighbor 192.168.100.2 remote-as 64513
neighbor 192.168.100.2 description <>
neighbor 192.168.100.2 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.1 activate
neighbor 192.168.100.1 next-hop-self
neighbor 192.168.100.1 soft-reconfiguration inbound
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 next-hop-self
neighbor 192.168.100.2 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.1 activate
neighbor 192.168.100.1 send-community extended
neighbor 192.168.100.2 activate
neighbor 192.168.100.2 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.10 remote-as 64514
neighbor 192.168.1.10 activate
neighbor 192.168.1.10 send-community extended
neighbor 192.168.1.10 soft-reconfiguration inbound
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
PE3#
CE3A#sh running-config
Building configuration...
Current configuration : 1449 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.30.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 192.168.1.10 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 192.168.1.9 remote-as 64513
neighbor 192.168.1.9 description <>
neighbor 192.168.1.9 allowas-in 5
neighbor 192.168.1.9 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE3A#
CE3A#
CE3A#
PE2#sh running-config
Building configuration...
Current configuration : 2990 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 192.168.100.2 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 192.168.10.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.10.9 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
no dce-terminal-timing-enable
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip vrf forwarding CEA
ip address 192.168.1.5 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router isis
net 49.0001.2222.3333.1111.00
!
router bgp 64513
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.100.1 remote-as 64513
neighbor 192.168.100.1 description <>
neighbor 192.168.100.1 update-source Loopback0
neighbor 192.168.100.3 remote-as 64513
neighbor 192.168.100.3 description <>
neighbor 192.168.100.3 update-source Loopback0
!
address-family ipv4
neighbor 192.168.100.1 activate
neighbor 192.168.100.1 next-hop-self
neighbor 192.168.100.1 soft-reconfiguration inbound
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 next-hop-self
neighbor 192.168.100.3 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.100.1 activate
neighbor 192.168.100.1 send-community extended
neighbor 192.168.100.3 activate
neighbor 192.168.100.3 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.6 remote-as 64514
neighbor 192.168.1.6 activate
neighbor 192.168.1.6 send-community extended
neighbor 192.168.1.6 soft-reconfiguration inbound
neighbor 192.168.1.6 route-map CE2A_Local_Pref in
no synchronization
exit-address-family
!
ip http server
!
!
ip bgp-community new-format
ip community-list 14 permit 64514:90
!
!
route-map CE2A_Local_Pref permit 10
match community 14
set local-preference 90
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
PE2#
PE2#
PE2#
PE2#
CE2A#sh running-config
Building configuration...
Current configuration : 1948 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.20.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 192.168.1.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/1
description <>
ip address 172.16.10.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 172.16.10.2 remote-as 64516
neighbor 172.16.10.2 description <>
neighbor 172.16.10.2 soft-reconfiguration inbound
neighbor 192.168.1.5 remote-as 64513
neighbor 192.168.1.5 description <>
neighbor 192.168.1.5 send-community
neighbor 192.168.1.5 allowas-in 5
neighbor 192.168.1.5 soft-reconfiguration inbound
neighbor 192.168.1.5 route-map PE2_Out out
no auto-summary
!
ip http server
!
!
ip bgp-community new-format
ip as-path access-list 16 permit _64516$
!
!
ip prefix-list PE2_Out seq 10 permit 10.0.20.1/32
ip prefix-list PE2_Out seq 20 permit 0.0.0.0/0
!
route-map PE2_Out permit 10
set community 64514:90
!
route-map Local permit 10
match interface Loopback0 Serial1/1
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE2A#
Internet_1#sh running-config
Building configuration...
Current configuration : 1481 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet_1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.100.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.10.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router bgp 64516
no synchronization
bgp log-neighbor-changes
redistribute connected route-map Local
neighbor 172.16.10.1 remote-as 64514
neighbor 172.16.10.1 description <>
neighbor 172.16.10.1 default-originate
neighbor 172.16.10.1 soft-reconfiguration inbound
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Internet_1#
Internet_1#
Internet_1#
**********************************************************************
OUTPUT
**********************************************************************
Before PE1-CE1A Link Shutdown Internet Traffic Moving via CE1A
**********************************************************************
PE3#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.100.1 to network 0.0.0.0
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.10.0 [200/0] via 192.168.100.2, 00:56:41
B 172.16.1.0 [200/20] via 192.168.100.1, 00:00:06
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.11.1/32 [200/20] via 192.168.100.1, 00:00:06
B 10.0.1.0/24 [200/0] via 192.168.100.1, 00:00:06
B 10.0.30.1/32 [20/0] via 192.168.1.10, 01:41:07
B 10.0.20.1/32 [200/0] via 192.168.100.2, 00:56:42
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial1/2
B 192.168.1.0 [200/0] via 192.168.100.1, 00:00:21
B 192.168.1.4 [200/0] via 192.168.100.2, 01:37:47
B* 0.0.0.0/0 [200/0] via 192.168.100.1, 00:00:09
PE3#
PE3#
PE2#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.100.1 to network 0.0.0.0
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.10.0 [20/0] via 192.168.1.6, 00:57:17
B 172.16.1.0 [200/20] via 192.168.100.1, 00:00:37
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.11.1/32 [200/20] via 192.168.100.1, 00:00:37
B 10.0.1.0/24 [200/0] via 192.168.100.1, 00:00:37
B 10.0.30.1/32 [200/0] via 192.168.100.3, 01:41:17
B 10.0.20.1/32 [20/0] via 192.168.1.6, 00:57:17
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [200/0] via 192.168.100.3, 01:44:03
B 192.168.1.0 [200/0] via 192.168.100.1, 00:00:52
C 192.168.1.4 is directly connected, Serial1/2
B* 0.0.0.0/0 [200/0] via 192.168.100.1, 00:00:38
PE2#
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.10.0 [200/0] via 192.168.100.2, 00:57:13
B 172.16.1.0 [20/20] via 192.168.1.1, 00:01:08
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.11.1/32 [20/20] via 192.168.1.1, 00:01:08
B 10.0.1.0/24 [20/0] via 192.168.1.1, 00:01:08
B 10.0.30.1/32 [200/0] via 192.168.100.3, 01:41:31
B 10.0.20.1/32 [200/0] via 192.168.100.2, 00:57:13
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [200/0] via 192.168.100.3, 01:44:16
C 192.168.1.0 is directly connected, Serial1/0
B 192.168.1.4 [200/0] via 192.168.100.2, 01:38:33
B* 0.0.0.0/0 [20/0] via 192.168.1.1, 00:01:09
PE1#
PE1#
PE1#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.10.2 to network 0.0.0.0
172.16.0.0/30 is subnetted, 2 subnets
C 172.16.10.0 is directly connected, Serial1/1
B 172.16.1.0 [20/0] via 192.168.1.5, 00:01:37
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.11.1/32 [20/0] via 192.168.1.5, 00:01:37
B 10.0.1.0/24 [20/0] via 192.168.1.5, 00:01:37
B 10.0.30.1/32 [20/0] via 192.168.1.5, 01:02:37
C 10.0.20.1/32 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [20/0] via 192.168.1.5, 01:02:37
B 192.168.1.0 [20/0] via 192.168.1.5, 00:01:51
C 192.168.1.4 is directly connected, Serial1/0
B* 0.0.0.0/0 [20/0] via 172.16.10.2, 00:56:52
CE2A#
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.1.2 to network 0.0.0.0
172.16.0.0/30 is subnetted, 2 subnets
B 172.16.10.0 [20/0] via 192.168.1.2, 00:02:10
O E2 172.16.1.0 [110/20] via 10.0.1.2, 00:37:23, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E2 10.0.11.1/32 [110/20] via 10.0.1.2, 00:44:23, FastEthernet0/0
C 10.0.10.1/32 is directly connected, Loopback0
C 10.0.1.0/24 is directly connected, FastEthernet0/0
B 10.0.30.1/32 [20/0] via 192.168.1.2, 00:02:10
B 10.0.20.1/32 [20/0] via 192.168.1.2, 00:02:10
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [20/0] via 192.168.1.2, 00:02:10
C 192.168.1.0 is directly connected, Serial1/0
B 192.168.1.4 [20/0] via 192.168.1.2, 00:02:10
O*E2 0.0.0.0/0 [110/1] via 10.0.1.2, 00:34:48, FastEthernet0/0
CE1A#
Internet_1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.10.0/30 is directly connected, Serial1/0
B 172.16.1.0/30 [20/0] via 172.16.10.1, 00:02:14
C 172.16.100.0/24 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
B 10.0.11.1/32 [20/0] via 172.16.10.1, 00:02:14
B 10.0.1.0/24 [20/0] via 172.16.10.1, 00:02:14
B 10.0.30.1/32 [20/0] via 172.16.10.1, 01:03:02
B 10.0.20.1/32 [20/0] via 172.16.10.1, 01:34:53
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [20/0] via 172.16.10.1, 01:03:02
B 192.168.1.0 [20/0] via 172.16.10.1, 00:02:44
B 192.168.1.4 [20/0] via 172.16.10.1, 01:03:02
Internet_1#
Internet_1#ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 736/1231/1600 ms
Internet_1#
CE1A#ping 10.0.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 628/910/1232 ms
CE1A#
CE3A#traceroute 172.16.100.1
Type escape sequence to abort.
Tracing the route to 172.16.100.1
1 192.168.1.9 168 msec 288 msec 100 msec
2 192.168.1.2 [AS 64513] 756 msec 928 msec 548 msec
3 192.168.1.1 [AS 64513] 712 msec 580 msec 172 msec
4 10.0.1.2 [AS 64514] 332 msec 1440 msec 448 msec
5 172.16.1.2 [AS 64514] 1488 msec 1448 msec 976 msec
CE3A#
CE1A#sh ip int brief
Interface IP-Address OK? Method Status Prot
ocol
FastEthernet0/0 10.0.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial1/0 192.168.1.1 YES manual up up
Serial1/1 unassigned YES unset administratively down down
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 10.0.10.1 YES manual up up
CE1A#sh ip bgp summary
BGP router identifier 10.0.10.1, local AS number 64514
BGP table version is 30, main routing table version 30
9 network entries using 1053 bytes of memory
9 path entries using 468 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2337 total bytes of memory
BGP activity 18/9 prefixes, 18/9 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
192.168.1.2 4 64513 67 62 30 0 0 00:05:54 6
CE1A#
CE11A#ping 172.16.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 380/693/1312 ms
CE11A#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 632/899/1136 ms
CE11A#
CE11A#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 588/684/900 ms
CE11A#
Internet_2#ping 10.0.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 372/672/1416 ms
Internet_2#
*********************************************************************************
After PE1-CE1A Link Shutdown Internet Traffic Moving via CE2A
CE3A#ping 172.16.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 228/852/1120 ms
CE3A#tra
CE3A#traceroute 172.16.100.1
Type escape sequence to abort.
Tracing the route to 172.16.100.1
1 192.168.1.9 304 msec 392 msec 140 msec
2 192.168.10.5 [AS 64516] 356 msec 352 msec 328 msec
3 192.168.1.5 [AS 64513] 256 msec 1008 msec 548 msec
4 192.168.1.6 [AS 64513] 640 msec 720 msec 644 msec
5 172.16.10.2 [AS 64514] 560 msec 1156 msec 1244 msec
CE3A#sh ip rou
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.9 to network 0.0.0.0
172.16.0.0/30 is subnetted, 1 subnets
B 172.16.10.0 [20/0] via 192.168.1.9, 00:47:54
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.30.1 is directly connected, Loopback0
B 10.0.20.1 [20/0] via 192.168.1.9, 00:47:54
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.8 is directly connected, Serial1/0
B 192.168.1.4 [20/0] via 192.168.1.9, 01:28:57
B* 0.0.0.0/0 [20/0] via 192.168.1.9, 00:02:44
CE3A#
PE3#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.100.2 to network 0.0.0.0
172.16.0.0/30 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 192.168.100.2, 00:49:35
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.30.1 [20/0] via 192.168.1.10, 01:34:01
B 10.0.20.1 [200/0] via 192.168.100.2, 00:49:35
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.8 is directly connected, Serial1/2
B 192.168.1.4 [200/0] via 192.168.100.2, 01:30:38
B* 0.0.0.0/0 [200/0] via 192.168.100.2, 00:04:15
PE3#
CE1A#sh ip int brief
Interface IP-Address OK? Method Status Pro
ocol
FastEthernet0/0 10.0.1.1 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down dow
Serial1/0 192.168.1.1 YES manual administratively down dow
Serial1/1 unassigned YES unset administratively down dow
Serial1/2 unassigned YES unset administratively down dow
Serial1/3 unassigned YES unset administratively down dow
Loopback0 10.0.10.1 YES manual up up
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.0.1.2 to network 0.0.0.0
172.16.0.0/30 is subnetted, 1 subnets
O E2 172.16.1.0 [110/20] via 10.0.1.2, 00:28:45, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O E2 10.0.11.1/32 [110/20] via 10.0.1.2, 00:35:44, FastEthernet0/0
C 10.0.10.1/32 is directly connected, Loopback0
C 10.0.1.0/24 is directly connected, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 10.0.1.2, 00:26:08, FastEthernet0/0
CE1A#sh ip bgp summary
BGP router identifier 10.0.10.1, local AS number 64514
BGP table version is 23, main routing table version 23
3 network entries using 351 bytes of memory
3 path entries using 156 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 879 total bytes of memory
BGP activity 12/9 prefixes, 12/9 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRc
192.168.1.2 4 64513 54 50 0 0 0 00:05:38 Idle
CE1A#
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.100.2 to network 0.0.0.0
172.16.0.0/30 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 192.168.100.2, 00:50:35
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.30.1 [200/0] via 192.168.100.3, 01:34:52
B 10.0.20.1 [200/0] via 192.168.100.2, 00:50:35
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.8 [200/0] via 192.168.100.3, 01:37:38
B 192.168.1.4 [200/0] via 192.168.100.2, 01:31:53
B* 0.0.0.0/0 [200/0] via 192.168.100.2, 00:05:45
PE1#
PE2#sh ip route vrf CEA
Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.1.6 to network 0.0.0.0
172.16.0.0/30 is subnetted, 1 subnets
B 172.16.10.0 [20/0] via 192.168.1.6, 00:51:30
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.30.1 [200/0] via 192.168.100.3, 01:35:31
B 10.0.20.1 [20/0] via 192.168.1.6, 00:51:30
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.8 [200/0] via 192.168.100.3, 01:38:16
C 192.168.1.4 is directly connected, Serial1/2
B* 0.0.0.0/0 [20/0] via 192.168.1.6, 00:06:20
PE2#
CE2A#traceroute 172.16.100.1
Type escape sequence to abort.
Tracing the route to 172.16.100.1
1 172.16.10.2 304 msec 316 msec *
CE2A#

No comments:

Post a Comment