Saturday, December 5, 2009

Implementing Internet Access through Route Leaking in IPv6 MPLS L3 VPN LAB



Configuration Guidelines
********************************************************************************
Internet Router which has IPv6 Internet Routes has IPv6 Peering with ISP and uses EBGP
AS 64515
ISP AS 64513 and has MP-iBGP ipv6 peering between PEs to transport IPv6 Internet Routes
and vpnv6 peering between PEs to transport VPN routes
VRF used CEA
rd 64513:1
rt 64514:100
CEs have dedicated IPv6 Subnets for Internet Acess which are advertised to Internet Router via ipv6 ISP Peering
At the PE a Default Route in the VRF for the CE is created pointing to the Global IPv6 Routing Table
At the PE the Subnets which are to be used for Intetnet Access by CEs are configured as Static in the IPv6 routing
table with next hop pointing to their VRF
IGP used ISIS for ISP and PE1/PE2 in different areas with their loopbacks in Level-1
PE-CE Routing Protocol used EBGP
**************************************************************************************
Internet_Router#sh running-config
Building configuration...
Current configuration : 1255 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet_Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:1610:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64515
bgp router-id 172.16.1.3
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1610:FFFF:1::1 remote-as 64513
neighbor 2001:1610:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:1610:FFFF:1::1 activate
neighbor 2001:1610:FFFF:1::1 send-community extended
neighbor 2001:1610:FFFF:1::1 default-originate
neighbor 2001:1610:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Internet_Router#
Internet_Router#
CE2A#sh running-config
Building configuration...
Current configuration : 1179 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:1210:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
bgp router-id 172.16.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 allowas-in 5
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE2A#
CE2A#
CE2A#
CE1A#sh running-config
Building configuration...
Current configuration : 1279 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface Loopback1
description <>
no ip address
ipv6 address FEC0:0:0:9::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:810:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
bgp router-id 172.16.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 allowas-in 5
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1A#
PE1#sh running-config
Building configuration...
Current configuration : 3225 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
vrf forwarding CEA
no ip address
speed auto
duplex auto
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6
redistribute static
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 send-label
exit-address-family
!
address-family vpnv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 send-community extended
neighbor 2001:810:FFFF:1::2 next-hop-self
neighbor 2001:810:FFFF:1::2 default-originate
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
ipv6 route FEC0:0:0:9::1/128 2001:810:FFFF:1::2 nexthop-vrf CEA
ipv6 route FEC0:0:0:9::1/128 FastEthernet1/0 2001:810:FFFF:1::2
ipv6 route FEC0:0:0:9::1/128 FastEthernet1/0
ipv6 route vrf CEA ::/0 2001:1610:FFFF:1::1 nexthop-vrf default
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE1#
PE1#
P#sh running-config
Building configuration...
Current configuration : 1623 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.4444.5555.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
P#
PE2#sh running-config
Building configuration...
Current configuration : 3245 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
ipv6 address 2001:1610:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
vrf forwarding CEA
no ip address
speed auto
duplex auto
ipv6 address 2001:1210:FFFF:1::1/64
!
interface Serial2/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.9999.8888.7777.00
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1610:FFFF:1::2 remote-as 64515
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6
no synchronization
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.1.1 send-label
neighbor 2001:1610:FFFF:1::2 activate
neighbor 2001:1610:FFFF:1::2 send-community extended
neighbor 2001:1610:FFFF:1::2 next-hop-self
neighbor 2001:1610:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
address-family vpnv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 send-community extended
neighbor 2001:1210:FFFF:1::2 next-hop-self
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE2#
OUTPUT
*********************************************************
Internet_Router#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:1610:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:1610:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:9::1/128 [20/0]
via FE80::C803:12FF:FEB8:1C, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
Internet_Router#ping FEC0:0:0:9::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:9::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 244/368/472 ms
Internet_Router#tra
Internet_Router#traceroute FEC0:0:0:9::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:9::1
1 2001:1610:FFFF:1::1 100 msec 212 msec 108 msec
2 ::FFFF:192.168.1.5 348 msec 368 msec 612 msec
3 ::FFFF:192.168.1.1 448 msec 384 msec 220 msec
4 FEC0:0:0:9::1 252 msec 260 msec 232 msec
Internet_Router#
CE1A#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B ::/0 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:2::1/128 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
LC FEC0:0:0:9::1/128 [0/0]
via ::, Loopback1
L FF00::/8 [0/0]
via ::, Null0
CE1A#ping FEC0:0:0:5::1 sou
CE1A#ping FEC0:0:0:5::1 source lo1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
Packet sent with a source address of FEC0:0:0:9::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 236/260/292 ms
CE1A#ping FEC0:0:0:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE1A#tra
CE1A#traceroute
Protocol [ip]: ipv6
Target IPv6 address: FEC0:0:0:5::1
Source address: FEC0:0:0:9::1
Insert source routing header? [no]:
Numeric display? [no]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Priority [0]:
Port Number [33434]:
Type escape sequence to abort.
Tracing the route to FEC0:0:0:5::1
1 2001:810:FFFF:1::1 96 msec 348 msec 140 msec
2 ::FFFF:192.168.1.2 360 msec 340 msec 172 msec
3 2001:1610:FFFF:1::1 172 msec 268 msec 304 msec
4 FEC0:0:0:5::1 248 msec 208 msec 232 msec
CE1A#ping FEC0:0:0:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 184/234/276 ms
CE1A#traceroute FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 2001:810:FFFF:1::1 184 msec 212 msec 80 msec
2 ::FFFF:192.168.1.2 184 msec 308 msec 140 msec
3 2001:1210:FFFF:1::1 416 msec 296 msec 140 msec
4 FEC0:0:0:2::1 172 msec 228 msec 216 msec
CE1A#
CE2A#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:9::1/128 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping FEC0:0:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/183/248 ms
CE2A#tra
CE2A#traceroute FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 2001:1210:FFFF:1::1 96 msec 104 msec 32 msec
2 ::FFFF:192.168.1.5 236 msec 120 msec 96 msec
3 2001:810:FFFF:1::1 316 msec 204 msec 144 msec
4 FEC0:0:0:1::1 216 msec 120 msec 168 msec
CE2A#ping FEC0:0:0:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE2A#ping FEC0:0:0:5::1 sou
CE2A#ping FEC0:0:0:5::1 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
Packet sent with a source address of FEC0:0:0:2::1
.....
Success rate is 0 percent (0/5)
CE2A#
PE1#show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [200/0]
via 10.0.3.1%default, indirectly connected
B 2001:1610:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:5::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
S FEC0:0:0:9::1/128 [1/0]
via 2001:810:FFFF:1::2%CEA
L FF00::/8 [0/0]
via Null0, receive
PE1#sho
PE1#show ipv6
PE1#show ipv6 rou
PE1#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S ::/0 [1/0]
via 2001:1610:FFFF:1::1%default
C 2001:810:FFFF:1::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:810:FFFF:1::1/128 [0/0]
via FastEthernet1/0, receive
B 2001:1210:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:1::1/128 [20/0]
via FE80::CE00:10FF:FE1C:0, FastEthernet1/0
B FEC0:0:0:2::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:9::1/128 [20/0]
via FE80::CE00:10FF:FE1C:0, FastEthernet1/0
L FF00::/8 [0/0]
via Null0, receive
PE1#
PE2#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
via FE80::CE04:10FF:FE1C:0, FastEthernet1/0
C 2001:1610:FFFF:1::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:1610:FFFF:1::1/128 [0/0]
via FastEthernet1/0, receive
B FEC0:0:0:5::1/128 [20/0]
via FE80::CE04:10FF:FE1C:0, FastEthernet1/0
B FEC0:0:0:9::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE2#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:810:FFFF:1::/64 [200/0]
via 10.0.1.1%default, indirectly connected
C 2001:1210:FFFF:1::/64 [0/0]
via FastEthernet1/1, directly connected
L 2001:1210:FFFF:1::1/128 [0/0]
via FastEthernet1/1, receive
B FEC0:0:0:1::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
B FEC0:0:0:2::1/128 [20/0]
via FE80::CE05:11FF:FEA4:0, FastEthernet1/1
B FEC0:0:0:9::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE2#

Configuration Guidelines
********************************************************************************
Internet Router which has IPv6 Internet Routes has IPv6 Peering with ISP and uses EBGP
AS 64515
ISP AS 64513 and has MP-iBGP ipv6 peering between PEs to transport IPv6 Internet Routes
and vpnv6 peering between PEs to transport VPN routes
VRF used CEA
rd 64513:1
rt 64514:100
CEs have dedicated IPv6 Subnets for Internet Acess which are advertised to Internet Router via ipv6 ISP Peering
At the PE a Default Route in the VRF for the CE is created pointing to the Global IPv6 Routing Table
At the PE the Subnets which are to be used for Intetnet Access by CEs are configured as Static in the IPv6 routing
table with next hop pointing to their VRF
IGP used ISIS for ISP and PE1/PE2 in different areas with their loopbacks in Level-1
PE-CE Routing Protocol used EBGP
**************************************************************************************
Internet_Router#sh running-config
Building configuration...
Current configuration : 1255 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Internet_Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:1610:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64515
bgp router-id 172.16.1.3
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1610:FFFF:1::1 remote-as 64513
neighbor 2001:1610:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:1610:FFFF:1::1 activate
neighbor 2001:1610:FFFF:1::1 send-community extended
neighbor 2001:1610:FFFF:1::1 default-originate
neighbor 2001:1610:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
Internet_Router#
Internet_Router#
CE2A#sh running-config
Building configuration...
Current configuration : 1179 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:1210:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
bgp router-id 172.16.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 allowas-in 5
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
CE2A#
CE2A#
CE2A#
CE1A#sh running-config
Building configuration...
Current configuration : 1279 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface Loopback1
description <>
no ip address
ipv6 address FEC0:0:0:9::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
ipv6 address 2001:810:FFFF:1::2/64
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
router bgp 64514
bgp router-id 172.16.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 allowas-in 5
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1A#
PE1#sh running-config
Building configuration...
Current configuration : 3225 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
vrf forwarding CEA
no ip address
speed auto
duplex auto
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6
redistribute static
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 send-label
exit-address-family
!
address-family vpnv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 send-community extended
neighbor 2001:810:FFFF:1::2 next-hop-self
neighbor 2001:810:FFFF:1::2 default-originate
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
ipv6 route FEC0:0:0:9::1/128 2001:810:FFFF:1::2 nexthop-vrf CEA
ipv6 route FEC0:0:0:9::1/128 FastEthernet1/0 2001:810:FFFF:1::2
ipv6 route FEC0:0:0:9::1/128 FastEthernet1/0
ipv6 route vrf CEA ::/0 2001:1610:FFFF:1::1 nexthop-vrf default
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE1#
PE1#
P#sh running-config
Building configuration...
Current configuration : 1623 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.4444.5555.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
P#
PE2#sh running-config
Building configuration...
Current configuration : 3245 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
ipv6 address 2001:1610:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
vrf forwarding CEA
no ip address
speed auto
duplex auto
ipv6 address 2001:1210:FFFF:1::1/64
!
interface Serial2/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.9999.8888.7777.00
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1610:FFFF:1::2 remote-as 64515
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family ipv6
no synchronization
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.1.1 send-label
neighbor 2001:1610:FFFF:1::2 activate
neighbor 2001:1610:FFFF:1::2 send-community extended
neighbor 2001:1610:FFFF:1::2 next-hop-self
neighbor 2001:1610:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
address-family vpnv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 send-community extended
neighbor 2001:1210:FFFF:1::2 next-hop-self
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE2#
OUTPUT
*********************************************************
Internet_Router#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:1610:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:1610:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:9::1/128 [20/0]
via FE80::C803:12FF:FEB8:1C, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
Internet_Router#ping FEC0:0:0:9::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:9::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 244/368/472 ms
Internet_Router#tra
Internet_Router#traceroute FEC0:0:0:9::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:9::1
1 2001:1610:FFFF:1::1 100 msec 212 msec 108 msec
2 ::FFFF:192.168.1.5 348 msec 368 msec 612 msec
3 ::FFFF:192.168.1.1 448 msec 384 msec 220 msec
4 FEC0:0:0:9::1 252 msec 260 msec 232 msec
Internet_Router#
CE1A#show ipv6 route
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B ::/0 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:2::1/128 [20/0]
via FE80::C801:10FF:FE1C:1C, FastEthernet0/0
LC FEC0:0:0:9::1/128 [0/0]
via ::, Loopback1
L FF00::/8 [0/0]
via ::, Null0
CE1A#ping FEC0:0:0:5::1 sou
CE1A#ping FEC0:0:0:5::1 source lo1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
Packet sent with a source address of FEC0:0:0:9::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 236/260/292 ms
CE1A#ping FEC0:0:0:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE1A#tra
CE1A#traceroute
Protocol [ip]: ipv6
Target IPv6 address: FEC0:0:0:5::1
Source address: FEC0:0:0:9::1
Insert source routing header? [no]:
Numeric display? [no]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Priority [0]:
Port Number [33434]:
Type escape sequence to abort.
Tracing the route to FEC0:0:0:5::1
1 2001:810:FFFF:1::1 96 msec 348 msec 140 msec
2 ::FFFF:192.168.1.2 360 msec 340 msec 172 msec
3 2001:1610:FFFF:1::1 172 msec 268 msec 304 msec
4 FEC0:0:0:5::1 248 msec 208 msec 232 msec
CE1A#ping FEC0:0:0:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 184/234/276 ms
CE1A#traceroute FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 2001:810:FFFF:1::1 184 msec 212 msec 80 msec
2 ::FFFF:192.168.1.2 184 msec 308 msec 140 msec
3 2001:1210:FFFF:1::1 416 msec 296 msec 140 msec
4 FEC0:0:0:2::1 172 msec 228 msec 216 msec
CE1A#
CE2A#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:9::1/128 [20/0]
via FE80::C803:12FF:FEB8:1D, FastEthernet0/0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping FEC0:0:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/183/248 ms
CE2A#tra
CE2A#traceroute FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 2001:1210:FFFF:1::1 96 msec 104 msec 32 msec
2 ::FFFF:192.168.1.5 236 msec 120 msec 96 msec
3 2001:810:FFFF:1::1 316 msec 204 msec 144 msec
4 FEC0:0:0:1::1 216 msec 120 msec 168 msec
CE2A#ping FEC0:0:0:5::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
CE2A#ping FEC0:0:0:5::1 sou
CE2A#ping FEC0:0:0:5::1 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
Packet sent with a source address of FEC0:0:0:2::1
.....
Success rate is 0 percent (0/5)
CE2A#
PE1#show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [200/0]
via 10.0.3.1%default, indirectly connected
B 2001:1610:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:5::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
S FEC0:0:0:9::1/128 [1/0]
via 2001:810:FFFF:1::2%CEA
L FF00::/8 [0/0]
via Null0, receive
PE1#sho
PE1#show ipv6
PE1#show ipv6 rou
PE1#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S ::/0 [1/0]
via 2001:1610:FFFF:1::1%default
C 2001:810:FFFF:1::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:810:FFFF:1::1/128 [0/0]
via FastEthernet1/0, receive
B 2001:1210:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:1::1/128 [20/0]
via FE80::CE00:10FF:FE1C:0, FastEthernet1/0
B FEC0:0:0:2::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:9::1/128 [20/0]
via FE80::CE00:10FF:FE1C:0, FastEthernet1/0
L FF00::/8 [0/0]
via Null0, receive
PE1#
PE2#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
via FE80::CE04:10FF:FE1C:0, FastEthernet1/0
C 2001:1610:FFFF:1::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:1610:FFFF:1::1/128 [0/0]
via FastEthernet1/0, receive
B FEC0:0:0:5::1/128 [20/0]
via FE80::CE04:10FF:FE1C:0, FastEthernet1/0
B FEC0:0:0:9::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE2#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 7 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:810:FFFF:1::/64 [200/0]
via 10.0.1.1%default, indirectly connected
C 2001:1210:FFFF:1::/64 [0/0]
via FastEthernet1/1, directly connected
L 2001:1210:FFFF:1::1/128 [0/0]
via FastEthernet1/1, receive
B FEC0:0:0:1::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
B FEC0:0:0:2::1/128 [20/0]
via FE80::CE05:11FF:FEA4:0, FastEthernet1/1
B FEC0:0:0:9::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE2#

No comments:

Post a Comment