Tuesday, December 22, 2009

Implementing EIGRP SoO Feature to Improving Routing Convergence in MPLS L3 VPN with Backdoor EIGRP Links LAB



COnfig Guide Lines
***************************************************************************************
ISP AS 64513
IGP is ISP used ISIS with Loopbacks in Level-1 and Backbone Links in Level-2
To avoid MP-iBGP Full Mesh PE2 forms CLuster ID 10.0.2.1 with PE1 and PE2 is the
Route-Reflector for this Cluster
PE2 has normal MP-iBGP Peering with PE3
VRF Used CEA
rd 64513:1
rt 64513:100
IGP is Cusomer Domain used EIGRP
PE-CE Routing Protocol EIGRP
Backdoor Links have bnadwidth set to Lower than MPLS Links for Low Preference
Site-Map used SoO with extcommunities:
'
64513:1000 for CE1A & PE1
64513:2000 for CE2A & PE2
64513:3000 for CE3A & PE3
******************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1543 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.50.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
bandwidth 100
ip vrf sitemap SoO
ip address 172.16.1.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
description <>
ip address 192.168.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected metric 1544 2000 255 100 1500 route-map Local
network 172.16.1.0 0.0.0.3
network 192.168.1.0 0.0.0.3
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
route-map SoO permit 10
set extcommunity soo 64513:1000
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE1A#
CE1A#
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1594 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.60.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
bandwidth 100
ip vrf sitemap SoO
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
description <>
bandwidth 100
ip vrf sitemap SoO
ip address 172.16.1.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
description <>
ip address 192.168.1.6 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected metric 1544 2000 255 100 1500 route-map Local
network 172.16.1.0 0.0.0.3
network 172.16.1.4 0.0.0.3
network 192.168.1.4 0.0.0.3
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
route-map SoO permit 10
set extcommunity soo 64513:2000
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
CE2A#
CE2A#
CE3A#sh running-config
Building configuration...
Current configuration : 1551 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE3A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.70.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.20.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
bandwidth 100
ip vrf sitemap SoO
ip address 172.16.1.5 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
description <>
ip address 192.168.1.10 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected metric 1544 2000 255 100 1500 route-map Local
network 172.16.1.4 0.0.0.3
network 192.168.1.8 0.0.0.3
no auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
route-map SoO permit 10
set extcommunity soo 64513:3000
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
CE3A#
PE1#sh running-config
Building configuration...
Current configuration : 2502 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip vrf sitemap SoO
ip address 192.168.1.1 255.255.255.252
!
interface Serial1/1
description <>
ip address 10.0.10.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
!
address-family ipv4 vrf CEA
autonomous-system 100
network 192.168.1.0 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 100 1500
exit-address-family
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map SoO permit 10
set extcommunity soo 64513:1000
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE1#
PE2#sh running-config
Building configuration...
Current configuration : 3093 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip vrf sitemap SoO
ip address 192.168.1.5 255.255.255.252
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 10.0.10.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip address 10.0.10.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
!
address-family ipv4 vrf CEA
autonomous-system 100
network 192.168.1.4 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 100 1500
exit-address-family
!
router isis
net 49.0002.2222.1111.3333.00
!
router bgp 64513
no synchronization
bgp cluster-id 10.0.2.1
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 route-reflector-client
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 route-reflector-client
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map SoO permit 10
set extcommunity soo 64513:2000
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2#
PE2#
PE2#
PE3#sh running-config
Building configuration...
Current configuration : 2590 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 10.0.10.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip vrf forwarding CEA
ip vrf sitemap SoO
ip address 192.168.1.9 255.255.255.252
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router eigrp 100
!
address-family ipv4 vrf CEA
autonomous-system 100
network 192.168.1.4 0.0.0.3
network 192.168.1.8 0.0.0.3
no auto-summary
redistribute bgp 64513 metric 1544 2000 255 100 1500
exit-address-family
!
router isis
net 49.0002.3333.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.2.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEA
no synchronization
redistribute connected
redistribute eigrp 100
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map SoO permit 10
set extcommunity soo 64513:3000
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE3#
*************************************************************************
OUTPUT
**************************************************************************
EIGRP With Leased Lines between CEs and No MPLS VPN Sites
*******************************************************
CE1A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.1.2 Se1/0 13 00:02:24 168 1008 0 11
CE1A#sh ip rou
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/2681856] via 172.16.1.2, 00:02:22, Serial1/0
C 172.16.50.1/32 is directly connected, Loopback0
D EX 172.16.20.0/24 [170/3193856] via 172.16.1.2, 00:02:00, Serial1/0
C 172.16.10.0/24 is directly connected, FastEthernet0/0
D 172.16.1.4/30 [90/2681856] via 172.16.1.2, 00:02:09, Serial1/0
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/3193856] via 172.16.1.2, 00:02:00, Serial1/0
CE1A#
CE1A#ping 172.16.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/93/216 ms
CE1A#tra
CE1A#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 172.16.1.2 92 msec 48 msec 64 msec
2 172.16.1.5 124 msec 160 msec *
CE1A#
CE2A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 172.16.1.5 Se1/1 13 00:02:42 130 780 0 2
0 172.16.1.1 Se1/0 13 00:03:04 292 1752 0 4
CE2A#sh ip rou
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
C 172.16.60.1/32 is directly connected, Loopback0
D EX 172.16.50.1/32 [170/2681856] via 172.16.1.1, 00:03:06, Serial1/0
D EX 172.16.20.0/24 [170/2681856] via 172.16.1.5, 00:02:44, Serial1/1
D EX 172.16.10.0/24 [170/2681856] via 172.16.1.1, 00:03:06, Serial1/0
C 172.16.1.4/30 is directly connected, Serial1/1
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/2681856] via 172.16.1.5, 00:02:44, Serial1/1
CE2A#
CE3A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.1.6 Se1/0 11 00:03:14 155 930 0 10
CE3A#sh iprou
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/2681856] via 172.16.1.6, 00:03:20, Serial1/0
D EX 172.16.50.1/32 [170/3193856] via 172.16.1.6, 00:03:20, Serial1/0
C 172.16.20.0/24 is directly connected, FastEthernet0/0
D EX 172.16.10.0/24 [170/3193856] via 172.16.1.6, 00:03:20, Serial1/0
C 172.16.1.4/30 is directly connected, Serial1/0
D 172.16.1.0/30 [90/2681856] via 172.16.1.6, 00:03:20, Serial1/0
C 172.16.70.1/32 is directly connected, Loopback0
CE3A#
CE3A#ping 172.16.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/96/140 ms
CE3A#tra
CE3A#traceroute 172.16.10.1
Type escape sequence to abort.
Tracing the route to 172.16.10.1
1 172.16.1.6 212 msec 64 msec 20 msec
2 172.16.1.1 108 msec 784 msec *
CE3A#wr
CE3A#write
Building configuration...
[OK]
CE3A#
EIGRP With Leased Lines between CEs and MPLS VPN Sites
and Backdoor links Preferred
*******************************************************
CE2A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
2 192.168.1.5 Se1/2 11 00:30:44 308 1848 0 22
1 172.16.1.5 Se1/1 14 00:54:41 170 1020 0 23
0 172.16.1.1 Se1/0 13 00:55:03 166 996 0 32
CE2A#
CE1A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.1.1 Se1/1 10 00:45:47 347 2082 0 21
0 172.16.1.2 Se1/0 13 00:57:23 259 1554 0 49
CE1A#
CE3A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.1.9 Se1/1 12 00:40:15 640 3840 0 17
0 172.16.1.6 Se1/0 11 00:57:11 497 2982 0 47
CE3A#
CE1A#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 192.168.1.1 112 msec
172.16.1.2 188 msec
192.168.1.1 48 msec
2 172.16.1.5 208 msec
10.0.10.2 496 msec
172.16.1.5 372 msec
CE1A#
CE3A#traceroute 172.16.10.1
Type escape sequence to abort.
Tracing the route to 172.16.10.1
1 192.168.1.9 256 msec
172.16.1.6 156 msec
192.168.1.9 196 msec
2 172.16.1.1 300 msec
10.0.10.6 296 msec
172.16.1.1 256 msec
CE3A#
PE2#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.5) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 21, Stats m(436)M(808)A(622
)c(2)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 42, Stats m(24)M(804)A(344)
c(5)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 2
via Connected, Serial1/0
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 5
via 192.168.1.6 (2681856/2169856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 41, Stats m(20)M(244)A(152)
c(3)
via VPNv4 Sourced (2681856/0)
via 192.168.1.6 (3193856/2681856), Serial1/0
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 28, Stats m(172)M(172)A(172
)c(1)
via VPNv4 Sourced (2681856/0)
via 192.168.1.6 (3193856/2681856), Serial1/0
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 40, Stats m(20)M(240)A(149)
c(3)
via VPNv4 Sourced (2681856/0)
via 192.168.1.6 (3193856/2681856), Serial1/0
P 172.16.1.4/30, 1 successors, FD is 2681856, serno 8
via 192.168.1.6 (2681856/2169856), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 2681856, serno 4
via 192.168.1.6 (2681856/2169856), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 29, Stats m(176)M(176)A(176
)c(1)
via VPNv4 Sourced (2681856/0)
via 192.168.1.6 (3193856/2681856), Serial1/0
PE2#
PE1#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.1) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 46, Stats m(828)M(828)A(828
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/0
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 45, Stats m(40)M(828)A(507)
c(5)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 43, Stats m(20)M(820)A(293)
c(3)
via VPNv4 Sourced (2681856/0)
via 192.168.1.2 (3193856/2681856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 2
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 42, Stats m(16)M(824)A(336)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 3
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.1.4/30, 1 successors, FD is 2681856, serno 41, Stats m(16)M(820)A(290)c
-3
via VPNv4 Sourced (2681856/0)
via 192.168.1.2 (3193856/2681856), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 2681856, serno 4
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 44, Stats m(24)M(824)A(338)
c(3)
via VPNv4 Sourced (2681856/0)
PE1#
PE3#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.9) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/1
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 27, Stats m(192)M(192)A(192
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 14, Stats m(172)M(212)A(192
)c(2)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 18, Stats m(324)M(324)A(324
)c(1)
via VPNv4 Sourced (2681856/0)
via 192.168.1.10 (3193856/2681856), Serial1/1
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 26, Stats m(168)M(168)A(168
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 2
via 192.168.1.10 (2681856/2169856), Serial1/1
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 25, Stats m(164)M(164)A(164
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.1.4/30, 1 successors, FD is 2681856, serno 4
via 192.168.1.10 (2681856/2169856), Serial1/1
P 172.16.1.0/30, 1 successors, FD is 2681856, serno 17, Stats m(324)M(324)A(324)
c(1)
via VPNv4 Sourced (2681856/0)
via 192.168.1.10 (3193856/2681856), Serial1/1
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 3
via 192.168.1.10 (2681856/2169856), Serial1/1
PE3#
PE3#
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D 172.16.1.0/30 [90/2681856] via 192.168.1.2, 00:40:57, Serial1/0
B 172.16.1.4/30 [200/2681856] via 10.0.2.1, 00:06:44
D EX 172.16.10.0/24 [170/2681856] via 192.168.1.2, 00:40:57, Serial1/0
B 172.16.20.0/24 [200/2681856] via 10.0.3.1, 00:06:44
D EX 172.16.50.1/32 [170/2681856] via 192.168.1.2, 00:40:57, Serial1/0
B 172.16.60.1/32 [200/2681856] via 10.0.2.1, 00:06:44
B 172.16.70.1/32 [200/2681856] via 10.0.3.1, 00:06:44
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial1/0
L 192.168.1.1/32 is directly connected, Serial1/0
B 192.168.1.4/30 [200/0] via 10.0.2.1, 00:06:45
B 192.168.1.8/30 [200/0] via 10.0.3.1, 00:06:45
PE1#
PE1#
PE3#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
B 172.16.1.0/30 [200/2681856] via 10.0.2.1, 00:19:58
D 172.16.1.4/30 [90/2681856] via 192.168.1.10, 00:35:32, Serial1/1
B 172.16.10.0/24 [200/2681856] via 10.0.1.1, 00:08:07
D EX 172.16.20.0/24 [170/2681856] via 192.168.1.10, 00:35:32, Serial1/1
B 172.16.50.1/32 [200/2681856] via 10.0.1.1, 00:08:07
B 172.16.60.1/32 [200/2681856] via 10.0.2.1, 00:19:58
D EX 172.16.70.1/32 [170/2681856] via 192.168.1.10, 00:35:32, Serial1/1
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
B 192.168.1.0/30 [200/0] via 10.0.1.1, 00:08:07
B 192.168.1.4/30 [200/0] via 10.0.2.1, 00:25:13
C 192.168.1.8/30 is directly connected, Serial1/1
L 192.168.1.9/32 is directly connected, Serial1/1
PE3#
PE3#
PE2#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D 172.16.1.0/30 [90/2681856] via 192.168.1.6, 00:28:47, Serial1/0
D 172.16.1.4/30 [90/2681856] via 192.168.1.6, 00:28:47, Serial1/0
B 172.16.10.0/24 [200/2681856] via 10.0.1.1, 00:06:42
B 172.16.20.0/24 [200/2681856] via 10.0.3.1, 00:20:01
B 172.16.50.1/32 [200/2681856] via 10.0.1.1, 00:06:42
D EX 172.16.60.1/32 [170/2681856] via 192.168.1.6, 00:28:47, Serial1/0
B 172.16.70.1/32 [200/2681856] via 10.0.3.1, 00:20:01
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
B 192.168.1.0/30 [200/0] via 10.0.1.1, 00:06:42
C 192.168.1.4/30 is directly connected, Serial1/0
L 192.168.1.5/32 is directly connected, Serial1/0
B 192.168.1.8/30 [200/0] via 10.0.3.1, 00:25:33
PE2#
PE2#
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/2681856] via 172.16.1.2, 00:08:48, Serial1/0
C 172.16.50.1/32 is directly connected, Loopback0
D EX 172.16.20.0/24 [170/3193856] via 192.168.1.1, 00:08:48, Serial1/1
[170/3193856] via 172.16.1.2, 00:08:48, Serial1/0
C 172.16.10.0/24 is directly connected, FastEthernet0/0
D 172.16.1.4/30 [90/2681856] via 172.16.1.2, 00:08:48, Serial1/0
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/3193856] via 192.168.1.1, 00:08:48, Serial1/1
[170/3193856] via 172.16.1.2, 00:08:48, Serial1/0
192.168.1.0/30 is subnetted, 3 subnets
D 192.168.1.8 [90/2681856] via 192.168.1.1, 00:08:48, Serial1/1
C 192.168.1.0 is directly connected, Serial1/1
D 192.168.1.4 [90/2681856] via 192.168.1.1, 00:08:48, Serial1/1
[90/2681856] via 172.16.1.2, 00:08:48, Serial1/0
CE1A#
CE1A#
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/2681856] via 172.16.1.6, 00:20:55, Serial1/0
D EX 172.16.50.1/32 [170/3193856] via 192.168.1.9, 00:09:13, Serial1/1
[170/3193856] via 172.16.1.6, 00:09:13, Serial1/0
C 172.16.20.0/24 is directly connected, FastEthernet0/0
D EX 172.16.10.0/24 [170/3193856] via 192.168.1.9, 00:09:13, Serial1/1
[170/3193856] via 172.16.1.6, 00:09:13, Serial1/0
C 172.16.1.4/30 is directly connected, Serial1/0
D 172.16.1.0/30 [90/2681856] via 172.16.1.6, 00:20:56, Serial1/0
C 172.16.70.1/32 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial1/1
D 192.168.1.0 [90/2681856] via 192.168.1.9, 00:09:13, Serial1/1
D 192.168.1.4 [90/2681856] via 192.168.1.9, 00:26:16, Serial1/1
[90/2681856] via 172.16.1.6, 00:26:16, Serial1/0
CE3A#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
C 172.16.60.1/32 is directly connected, Loopback0
D EX 172.16.50.1/32 [170/2681856] via 172.16.1.1, 00:09:33, Serial1/0
D EX 172.16.20.0/24 [170/2681856] via 172.16.1.5, 00:21:08, Serial1/1
D EX 172.16.10.0/24 [170/2681856] via 172.16.1.1, 00:09:33, Serial1/0
C 172.16.1.4/30 is directly connected, Serial1/1
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/2681856] via 172.16.1.5, 00:21:08, Serial1/1
192.168.1.0/30 is subnetted, 3 subnets
D 192.168.1.8 [90/2681856] via 192.168.1.5, 00:09:33, Serial1/2
[90/2681856] via 172.16.1.5, 00:09:33, Serial1/1
D 192.168.1.0 [90/2681856] via 192.168.1.5, 00:09:33, Serial1/2
[90/2681856] via 172.16.1.1, 00:09:33, Serial1/0
C 192.168.1.4 is directly connected, Serial1/2
CE2A#
CE2A#
CE2A#
EIGRP With Leased Lines between CEs and MPLS VPN Sites
and Backdoor links Not-Preferred
*******************************************************
CE1A#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 192.168.1.1 148 msec 516 msec 516 msec
2 10.0.10.2 720 msec 420 msec 536 msec
3 192.168.1.9 288 msec 456 msec 372 msec
4 192.168.1.10 388 msec 488 msec *
CE1A#
CE3A#traceroute 172.16.10.1
Type escape sequence to abort.
Tracing the route to 172.16.10.1
1 192.168.1.9 244 msec 128 msec 144 msec
2 10.0.10.6 304 msec 432 msec 188 msec
3 192.168.1.1 624 msec 220 msec 200 msec
4 192.168.1.2 236 msec 404 msec *
CE3A#
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/3193856] via 192.168.1.1, 00:00:20, Serial1/1
C 172.16.50.1/32 is directly connected, Loopback0
D EX 172.16.20.0/24 [170/3193856] via 192.168.1.1, 00:00:20, Serial1/1
C 172.16.10.0/24 is directly connected, FastEthernet0/0
D 172.16.1.4/30 [90/4096000] via 192.168.1.1, 00:00:39, Serial1/1
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/3193856] via 192.168.1.1, 00:00:20, Serial1/1
192.168.1.0/30 is subnetted, 3 subnets
D 192.168.1.8 [90/2681856] via 192.168.1.1, 00:00:21, Serial1/1
C 192.168.1.0 is directly connected, Serial1/1
D 192.168.1.4 [90/2681856] via 192.168.1.1, 00:00:21, Serial1/1
CE1A#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
C 172.16.60.1/32 is directly connected, Loopback0
D EX 172.16.50.1/32 [170/3193856] via 192.168.1.5, 00:01:01, Serial1/2
D EX 172.16.20.0/24 [170/3193856] via 192.168.1.5, 00:01:23, Serial1/2
D EX 172.16.10.0/24 [170/3193856] via 192.168.1.5, 00:01:01, Serial1/2
C 172.16.1.4/30 is directly connected, Serial1/1
C 172.16.1.0/30 is directly connected, Serial1/0
D EX 172.16.70.1/32 [170/3193856] via 192.168.1.5, 00:01:23, Serial1/2
192.168.1.0/30 is subnetted, 3 subnets
D 192.168.1.8 [90/2681856] via 192.168.1.5, 00:01:12, Serial1/2
D 192.168.1.0 [90/2681856] via 192.168.1.5, 00:01:01, Serial1/2
C 192.168.1.4 is directly connected, Serial1/2
CE2A#
CE3A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.16.60.1/32 [170/3193856] via 192.168.1.9, 00:00:00, Serial1/1
D EX 172.16.50.1/32 [170/3193856] via 192.168.1.9, 00:00:00, Serial1/1
C 172.16.20.0/24 is directly connected, FastEthernet0/0
D EX 172.16.10.0/24 [170/3193856] via 192.168.1.9, 00:00:00, Serial1/1
C 172.16.1.4/30 is directly connected, Serial1/0
D 172.16.1.0/30 [90/26624000] via 172.16.1.6, 00:01:59, Serial1/0
C 172.16.70.1/32 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial1/1
D 192.168.1.0 [90/2681856] via 192.168.1.9, 00:00:00, Serial1/1
D 192.168.1.4 [90/2681856] via 192.168.1.9, 00:00:00, Serial1/1
CE3A#
PE1#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D 172.16.1.0/30 [90/26624000] via 192.168.1.2, 00:02:15, Serial1/0
B 172.16.1.4/30 [200/26624000] via 10.0.2.1, 00:00:14
D EX 172.16.10.0/24 [170/2681856] via 192.168.1.2, 01:01:11, Serial1/0
B 172.16.20.0/24 [200/2681856] via 10.0.3.1, 00:26:58
D EX 172.16.50.1/32 [170/2681856] via 192.168.1.2, 01:01:11, Serial1/0
B 172.16.60.1/32 [200/2681856] via 10.0.2.1, 00:26:58
B 172.16.70.1/32 [200/2681856] via 10.0.3.1, 00:26:58
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial1/0
L 192.168.1.1/32 is directly connected, Serial1/0
B 192.168.1.4/30 [200/0] via 10.0.2.1, 00:26:58
B 192.168.1.8/30 [200/0] via 10.0.3.1, 00:26:58
PE1#
PE1#
PE1#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.1) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 46, Stats m(828)M(828)A(828
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/0
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 45, Stats m(40)M(828)A(507)
c(5)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 43, Stats m(20)M(820)A(293)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 2
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 42, Stats m(16)M(824)A(336)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 3
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.1.4/30, 1 successors, FD is 2681856, serno 53, Stats m(16)M(820)A(290)c
-3
via VPNv4 Sourced (26624000/0)
via 192.168.1.2 (27136000/26624000), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 26624000, serno 52, Stats m(24)M(184)A(104)
c(2)
via 192.168.1.2 (26624000/26112000), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 44, Stats m(24)M(824)A(338)
c(3)
via VPNv4 Sourced (2681856/0)
PE1#
PE3#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
B 172.16.1.0/30 [200/26624000] via 10.0.2.1, 00:02:45
D 172.16.1.4/30 [90/26624000] via 192.168.1.10, 00:01:03, Serial1/1
B 172.16.10.0/24 [200/2681856] via 10.0.1.1, 00:28:44
D EX 172.16.20.0/24 [170/2681856] via 192.168.1.10, 00:56:09, Serial1/1
B 172.16.50.1/32 [200/2681856] via 10.0.1.1, 00:28:44
B 172.16.60.1/32 [200/2681856] via 10.0.2.1, 00:40:35
D EX 172.16.70.1/32 [170/2681856] via 192.168.1.10, 00:56:09, Serial1/1
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
B 192.168.1.0/30 [200/0] via 10.0.1.1, 00:28:44
B 192.168.1.4/30 [200/0] via 10.0.2.1, 00:45:50
C 192.168.1.8/30 is directly connected, Serial1/1
L 192.168.1.9/32 is directly connected, Serial1/1
PE3#
PE3#
PE3#
PE3#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.9) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/1
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 27, Stats m(192)M(192)A(192
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 14, Stats m(172)M(212)A(192
)c(2)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 18, Stats m(324)M(324)A(324
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 26, Stats m(168)M(168)A(168
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 2
via 192.168.1.10 (2681856/2169856), Serial1/1
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 25, Stats m(164)M(164)A(164
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.1.4/30, 1 successors, FD is 26624000, serno 39, Stats m(128)M(176)A(152
)c(2)
via 192.168.1.10 (26624000/26112000), Serial1/1
P 172.16.1.0/30, 1 successors, FD is 2681856, serno 33, Stats m(324)M(324)A(324)
c(1)
via VPNv4 Sourced (26624000/0)
via 192.168.1.10 (27136000/26624000), Serial1/1
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 3
via 192.168.1.10 (2681856/2169856), Serial1/1
PE3#
PE3#
PE2#sh ip route vrf CEA
Routing Table: CEA
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 7 subnets, 3 masks
D 172.16.1.0/30 [90/26624000] via 192.168.1.6, 00:05:07, Serial1/0
D 172.16.1.4/30 [90/26624000] via 192.168.1.6, 00:03:11, Serial1/0
B 172.16.10.0/24 [200/2681856] via 10.0.1.1, 00:29:09
B 172.16.20.0/24 [200/2681856] via 10.0.3.1, 00:42:28
B 172.16.50.1/32 [200/2681856] via 10.0.1.1, 00:29:09
D EX 172.16.60.1/32 [170/2681856] via 192.168.1.6, 00:51:14, Serial1/0
B 172.16.70.1/32 [200/2681856] via 10.0.3.1, 00:42:28
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
B 192.168.1.0/30 [200/0] via 10.0.1.1, 00:29:09
C 192.168.1.4/30 is directly connected, Serial1/0
L 192.168.1.5/32 is directly connected, Serial1/0
B 192.168.1.8/30 [200/0] via 10.0.3.1, 00:48:00
PE2#
PE2#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.5) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 21, Stats m(436)M(808)A(622
)c(2)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 42, Stats m(24)M(804)A(344)
c(5)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 2
via Connected, Serial1/0
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 5
via 192.168.1.6 (2681856/2169856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 41, Stats m(20)M(244)A(152)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 28, Stats m(172)M(172)A(172
)c(1)
via VPNv4 Sourced (2681856/0)
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 40, Stats m(20)M(240)A(149)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.1.4/30, 1 successors, FD is 26624000, serno 70, Stats m(20)M(300)A(136)
c(6)
via 192.168.1.6 (26624000/26112000), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 26624000, serno 67, Stats m(40)M(580)A(239)
c(6)
via 192.168.1.6 (26624000/26112000), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 29, Stats m(176)M(176)A(176
)c(1)
via VPNv4 Sourced (2681856/0)
PE2#
PE2#
PE2#
PE2#
EIGRP With Leased Lines between CEs and MPLS VPN Sites
and Backdoor links Not-Preferred with SoO Implemented
*******************************************************
CE1A#traceroute 172.16.20.1
Type escape sequence to abort.
Tracing the route to 172.16.20.1
1 192.168.1.1 68 msec 52 msec 68 msec
2 10.0.10.2 256 msec 440 msec 356 msec
3 192.168.1.9 192 msec 244 msec 220 msec
4 192.168.1.10 220 msec 332 msec *
CE1A#
CE3A#traceroute 172.16.10.1
Type escape sequence to abort.
Tracing the route to 172.16.10.1
1 192.168.1.9 752 msec 100 msec 216 msec
2 10.0.10.6 688 msec 564 msec 236 msec
3 192.168.1.1 248 msec 412 msec 188 msec
4 192.168.1.2 232 msec 236 msec *
CE3A#
PE1#show ip bgp vpnv4 all 172.16.20.0
BGP routing table entry for 64513:1:172.16.20.0/24, version 99
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.3.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2681856, localpref 100, valid, internal, best
Extended Community: SoO:64513:3000 RT:64513:100
Cost:pre-bestpath:129:2681856 (default-2144801791) 0x8800:0:0
0x8801:100:1024000 0x8802:65281:1657856 0x8803:65380:1500
0x8804:0:2886747649 0x8805:11:0
Originator: 10.0.3.1, Cluster list: 10.0.2.1
mpls labels in/out nolabel/23
PE1#
PE3#show ip bgp vpnv4 all 172.16.10.0
GP routing table entry for 64513:1:172.16.10.0/24, version 70
aths: (1 available, best #1, table CEA)
lag: 0x820
Not advertised to any peer
Local
10.0.1.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2681856, localpref 100, valid, internal, best
Extended Community: SoO:64513:1000 RT:64513:100
Cost:pre-bestpath:129:2681856 (default-2144801791) 0x8800:0:0
0x8801:100:1024000 0x8802:65281:1657856 0x8803:65380:1500
0x8804:0:2886742529 0x8805:11:0
Originator: 10.0.1.1, Cluster list: 10.0.2.1
mpls labels in/out nolabel/22
PE3#
PE2#show ip bgp vpnv4 all 172.16.10.0
BGP routing table entry for 64513:1:172.16.10.0/24, version 98
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Advertised to update-groups:
1
Local, (Received from a RR-client)
10.0.1.1 (metric 20) from 10.0.1.1 (10.0.1.1)
Origin incomplete, metric 2681856, localpref 100, valid, internal, best
Extended Community: SoO:64513:1000 RT:64513:100
Cost:pre-bestpath:129:2681856 (default-2144801791) 0x8800:0:0
0x8801:100:1024000 0x8802:65281:1657856 0x8803:65380:1500
0x8804:0:2886742529 0x8805:11:0
mpls labels in/out nolabel/22
PE2#show ip bgp vpnv4 all 172.16.20.0
BGP routing table entry for 64513:1:172.16.20.0/24, version 108
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Advertised to update-groups:
2
Local
10.0.3.1 (metric 20) from 10.0.3.1 (10.0.3.1)
Origin incomplete, metric 2681856, localpref 100, valid, internal, best
Extended Community: SoO:64513:3000 RT:64513:100
Cost:pre-bestpath:129:2681856 (default-2144801791) 0x8800:0:0
0x8801:100:1024000 0x8802:65281:1657856 0x8803:65380:1500
0x8804:0:2886747649 0x8805:11:0
mpls labels in/out nolabel/23
PE2#
PE1#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.1) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 75, Stats m(828)M(828)A(828
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/0
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 82, Stats m(40)M(828)A(507)
c(5)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 81, Stats m(16)M(820)A(228)
c(5)
via VPNv4 Sourced (2681856/0)
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 60
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 73, Stats m(16)M(1880)A(519
)c(6)
via VPNv4 Sourced (2681856/0)
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 61
via 192.168.1.2 (2681856/2169856), Serial1/0
P 172.16.1.4/30, 1 successors, FD is 2681856, serno 79, Stats m(16)M(820)A(290)c
-3
via VPNv4 Sourced (26624000/0)
via 192.168.1.2 (27136000/26624000), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 26624000, serno 62
via 192.168.1.2 (26624000/26112000), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 74, Stats m(24)M(1884)A(521
)c(6)
via VPNv4 Sourced (2681856/0)
PE1#
PE2#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.5) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 88, Stats m(436)M(808)A(622
)c(2)
via VPNv4 Sourced (2169856/0)
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 87, Stats m(24)M(804)A(344)
c(5)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 2
via Connected, Serial1/0
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 91
via 192.168.1.6 (2681856/2169856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 78, Stats m(20)M(320)A(164)
c(5)
via VPNv4 Sourced (2681856/0)
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 85, Stats m(172)M(700)A(356
)c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 77, Stats m(20)M(320)A(161)
c(5)
via VPNv4 Sourced (2681856/0)
P 172.16.1.4/30, 1 successors, FD is 26624000, serno 93
via 192.168.1.6 (26624000/26112000), Serial1/0
P 172.16.1.0/30, 1 successors, FD is 26624000, serno 92
via 192.168.1.6 (26624000/26112000), Serial1/0
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 86, Stats m(176)M(704)A(357
)c(3)
via VPNv4 Sourced (2681856/0)
PE2#
PE3#sh ip eigrp vrf CEA topology detail-links
EIGRP-IPv4 Topology Table for AS(100)/ID(192.168.1.9) Routing Table: CEA
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 1
via Connected, Serial1/1
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 60, Stats m(192)M(192)A(192
)c(1)
via VPNv4 Sourced (2169856/0)
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 67, Stats m(172)M(212)A(192
)c(2)
via VPNv4 Sourced (2169856/0)
P 172.16.60.1/32, 1 successors, FD is 2681856, serno 66, Stats m(20)M(324)A(200)
c(3)
via VPNv4 Sourced (2681856/0)
P 172.16.50.1/32, 1 successors, FD is 2681856, serno 53, Stats m(168)M(380)A(274
)c(2)
via VPNv4 Sourced (2681856/0)
P 172.16.20.0/24, 1 successors, FD is 2681856, serno 57
via 192.168.1.10 (2681856/2169856), Serial1/1
P 172.16.10.0/24, 1 successors, FD is 2681856, serno 52, Stats m(164)M(376)A(270
)c(2)
via VPNv4 Sourced (2681856/0)
P 172.16.1.4/30, 1 successors, FD is 26624000, serno 59
via 192.168.1.10 (26624000/26112000), Serial1/1
P 172.16.1.0/30, 1 successors, FD is 2681856, serno 65, Stats m(324)M(324)A(324)
c(1)
via VPNv4 Sourced (26624000/0)
via 192.168.1.10 (27136000/26624000), Serial1/1
P 172.16.70.1/32, 1 successors, FD is 2681856, serno 58
via 192.168.1.10 (2681856/2169856), Serial1/1
PE3#
CE2A#sh ip eigrp topology detail-links
IP-EIGRP Topology Table for AS(100)/ID(172.16.60.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2681856, serno 114
via 192.168.1.5 (2681856/2169856), Serial1/2
via 172.16.1.5 (26624000/2169856), Serial1/1
via 172.16.1.1 (27136000/2681856), Serial1/0
P 192.168.1.0/30, 1 successors, FD is 2681856, serno 113
via 192.168.1.5 (2681856/2169856), Serial1/2
via 172.16.1.1 (26624000/2169856), Serial1/0
via 172.16.1.5 (27136000/2681856), Serial1/1
P 192.168.1.4/30, 1 successors, FD is 2169856, serno 11, Stats m(236)M(236)A(236
)c(1)
via Connected, Serial1/2
P 172.16.60.1/32, 1 successors, FD is 2169856, serno 2
via Rconnected (2169856/0)
P 172.16.50.1/32, 1 successors, FD is 3193856, serno 110, Stats m(36)M(36)A(36)c
-1
via 192.168.1.5 (3193856/2681856), Serial1/2
via 172.16.1.1 (26624000/2169856), Serial1/0
via 172.16.1.5 (27648000/3193856), Serial1/1
P 172.16.20.0/24, 1 successors, FD is 3193856, serno 111, Stats m(568)M(568)A(56
8)c(1)
via 192.168.1.5 (3193856/2681856), Serial1/2
via 172.16.1.5 (26624000/2169856), Serial1/1
via 172.16.1.1 (27648000/3193856), Serial1/0
P 172.16.10.0/24, 1 successors, FD is 3193856, serno 109, Stats m(36)M(36)A(36)c
-1
via 192.168.1.5 (3193856/2681856), Serial1/2
via 172.16.1.1 (26624000/2169856), Serial1/0
via 172.16.1.5 (27648000/3193856), Serial1/1
P 172.16.1.4/30, 1 successors, FD is 26112000, serno 63
via Connected, Serial1/1
via 192.168.1.5 (27136000/26624000), Serial1/2
P 172.16.1.0/30, 1 successors, FD is 26112000, serno 59
via Connected, Serial1/0
via 192.168.1.5 (27136000/26624000), Serial1/2
P 172.16.70.1/32, 1 successors, FD is 3193856, serno 112, Stats m(572)M(572)A(57
2)c(1)
via 192.168.1.5 (3193856/2681856), Serial1/2
via 172.16.1.5 (26624000/2169856), Serial1/1
via 172.16.1.1 (27648000/3193856), Serial1/0
CE2A#
CE1A#sh ip eigrp topology detail-links
IP-EIGRP Topology Table for AS(100)/ID(172.16.50.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2681856, serno 98, Stats m(168)M(168)A(168
)c(1)
via 192.168.1.1 (2681856/2169856), Serial1/1
via 172.16.1.2 (27136000/2681856), Serial1/0
P 192.168.1.0/30, 1 successors, FD is 2169856, serno 9
via Connected, Serial1/1
P 192.168.1.4/30, 1 successors, FD is 2681856, serno 103
via 192.168.1.1 (2681856/2169856), Serial1/1
via 172.16.1.2 (26624000/2169856), Serial1/0
P 172.16.60.1/32, 1 successors, FD is 3193856, serno 102, Stats m(340)M(340)A(34
0)c(1)
via 192.168.1.1 (3193856/2681856), Serial1/1
via 172.16.1.2 (26624000/2169856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 2169856, serno 2
via Rconnected (2169856/0)
P 172.16.20.0/24, 1 successors, FD is 3193856, serno 96, Stats m(172)M(532)A(352
)c(2)
via 192.168.1.1 (3193856/2681856), Serial1/1
via 172.16.1.2 (27648000/3193856), Serial1/0
P 172.16.10.0/24, 1 successors, FD is 2169856, serno 3
via Rconnected (2169856/0)
P 172.16.1.4/30, 1 successors, FD is 26624000, serno 70, Stats m(112)M(532)A(286
)c(7)
via 172.16.1.2 (26624000/26112000), Serial1/0
via 192.168.1.1 (27136000/26624000), Serial1/1
P 172.16.1.0/30, 1 successors, FD is 26112000, serno 55
via Connected, Serial1/0
P 172.16.70.1/32, 1 successors, FD is 3193856, serno 97, Stats m(176)M(536)A(356
)c(2)
via 192.168.1.1 (3193856/2681856), Serial1/1
via 172.16.1.2 (27648000/3193856), Serial1/0
CE1A#
CE3A#sh ip eigrp topology detail-links
IP-EIGRP Topology Table for AS(100)/ID(172.16.70.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 192.168.1.8/30, 1 successors, FD is 2169856, serno 54, Stats m(220)M(220)A(220
)c(1)
via Connected, Serial1/1
P 192.168.1.0/30, 1 successors, FD is 2681856, serno 101, Stats m(172)M(268)A(22
0)c(2)
via 192.168.1.9 (2681856/2169856), Serial1/1
via 172.16.1.6 (27136000/2681856), Serial1/0
P 192.168.1.4/30, 1 successors, FD is 2681856, serno 106
via 192.168.1.9 (2681856/2169856), Serial1/1
via 172.16.1.6 (26624000/2169856), Serial1/0
P 172.16.60.1/32, 1 successors, FD is 3193856, serno 105, Stats m(540)M(540)A(54
0)c(1)
via 192.168.1.9 (3193856/2681856), Serial1/1
via 172.16.1.6 (26624000/2169856), Serial1/0
P 172.16.50.1/32, 1 successors, FD is 3193856, serno 100, Stats m(176)M(1812)A(7
65)c(3)
via 192.168.1.9 (3193856/2681856), Serial1/1
via 172.16.1.6 (27648000/3193856), Serial1/0
P 172.16.20.0/24, 1 successors, FD is 2169856, serno 1
via Rconnected (2169856/0)
P 172.16.10.0/24, 1 successors, FD is 3193856, serno 99, Stats m(180)M(1812)A(76
6)c(3)
via 192.168.1.9 (3193856/2681856), Serial1/1
via 172.16.1.6 (27648000/3193856), Serial1/0
P 172.16.1.4/30, 1 successors, FD is 26112000, serno 55
via Connected, Serial1/0
P 172.16.1.0/30, 1 successors, FD is 26624000, serno 79, Stats m(156)M(856)A(370
)c(9)
via 172.16.1.6 (26624000/26112000), Serial1/0
via 192.168.1.9 (27136000/26624000), Serial1/1
P 172.16.70.1/32, 1 successors, FD is 2169856, serno 3
via Rconnected (2169856/0)
CE3A#

No comments:

Post a Comment