Thursday, December 24, 2009

Implementing MPLS L3 VPN over MPLS L2 VPN with Failover Redundancy LAB



COnfig Guidelines
***********************************************************************************************
Scenario : ISP 1 is a Tier 1 ISP which has deep geographic presence.
ISP A is a Tier 3 ISP which has less geographic presence and wants to offer MPLS L3 VPN Services
to its Customer B
ISP Takes MPLS L2 VPN Services from ISP 1 and overlays its own MPLS L3 VPN Services on top of it
for Customer B
ISP 1 being Tier 1 also provides redundancy in MPLS L2 VPN Services to ISP A using backup peer between
PEs IGP in ISP 1 is ISIS with Loopbacks in Level 1 and Backbone Links in Level-2
Pseudowire Used CE1A
VCID used 100 as Primary between PE1-PE2
VCID used 101 as Secondary betwen PE1-PE3
ISP1-ISPA Links are Ethernet
IGP in ISPA used OSPF
AS Used in ISPA 64514
VRF used CEB
rd 64514:1
rt 64514:100
PE-CE ROuting PRotocol Used EIGRP between ISPA and Customer B
********************************************************************************************************
CE1B#sh running-config
Building configuration...
Current configuration : 1336 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1B
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.50.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.16.100.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 10.0.10.2 255.255.255.252
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected metric 1544 2000 255 200 1500 route-map Local
network 10.0.10.0 0.0.0.3
auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE1B#
CE1B#
CE2B#sh running-config
Building configuration...
Current configuration : 1375 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2B
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.60.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.16.200.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 10.0.20.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
redistribute connected metric 1544 2000 255 200 1500 route-map Local
network 10.0.20.0 0.0.0.3
auto-summary
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE2B#
CE1A#sh running-config
Building configuration...
Current configuration : 2547 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEB
description <>
rd 64514:1
route-target export 64514:100
route-target import 64514:100
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.10.1 255.255.255.255
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 172.16.1.1 255.255.255.252
no snmp trap link-status
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip vrf forwarding CEB
ip address 10.0.10.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
no redistribute eigrp 100
auto-summary
!
address-family ipv4 vrf CEB
redistribute bgp 64514 metric 1544 2000 255 100 1500
no redistribute eigrp
network 10.0.10.0 0.0.0.3
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.1.0 0.0.0.3 area 0
!
router bgp 64514
bgp log-neighbor-changes
neighbor 172.16.20.1 remote-as 64514
neighbor 172.16.20.1 description <>
neighbor 172.16.20.1 update-source Loopback0
!
address-family ipv4
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 172.16.20.1 activate
neighbor 172.16.20.1 send-community extended
neighbor 172.16.20.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEB
redistribute connected
redistribute eigrp 100
redistribute eigrp
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 2477 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CEB
description <>
rd 64514:1
route-target export 64514:100
route-target import 64514:100
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.20.1 255.255.255.255
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 172.16.1.2 255.255.255.252
no snmp trap link-status
mpls label protocol ldp
mpls ip
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip vrf forwarding CEB
ip address 10.0.20.1 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router eigrp 100
auto-summary
!
address-family ipv4 vrf CEB
redistribute bgp 64514 metric 1544 2000 255 200 1500
network 10.0.20.0 0.0.0.3
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.1.0 0.0.0.3 area 0
!
router bgp 64514
bgp log-neighbor-changes
neighbor 172.16.10.1 remote-as 64514
neighbor 172.16.10.1 description <>
neighbor 172.16.10.1 update-source Loopback0
!
address-family ipv4
neighbor 172.16.10.1 activate
neighbor 172.16.10.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 172.16.10.1 activate
neighbor 172.16.10.1 send-community extended
neighbor 172.16.10.1 next-hop-self
exit-address-family
!
address-family ipv4 vrf CEB
redistribute connected
redistribute eigrp 100
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
!
!
end
CE2A#
CE2A#
PE1#sh running-config
Building configuration...
Current configuration : 2011 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CE1A
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
shutdown
no fair-queue
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 100
xconnect 10.0.2.1 100 encapsulation mpls pw-class CE1A
backup peer 10.0.3.1 101 pw-class CE1A
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
router isis
net 49.0001.1111.2222.3333.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE1#
PE1#
PE1#
PE1#
PE2#sh running-config
Building configuration...
Current configuration : 1833 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CE1A
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet1/0.100
encapsulation dot1Q 100
xconnect 10.0.1.1 100 encapsulation mpls pw-class CE1A
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.2222.1111.3333.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE2#
PE2#
PE3#sh running-config
Building configuration...
Current configuration : 1833 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CE1A
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet1/0.101
encapsulation dot1Q 100
xconnect 10.0.1.1 101 encapsulation mpls pw-class CE1A
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial2/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.1111.2222.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE3#
PE3#
PE3#
***************************************************************************************
OUTPUT
***************************************************************************************
Traffic going via VCID 100 PE1-PE2
**************************************************************************************
CE1B#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
D EX 172.16.200.0 [170/3193856] via 10.0.10.1, 00:03:01, Serial1/0
D EX 172.16.60.0 [170/3193856] via 10.0.10.1, 00:03:01, Serial1/0
C 172.16.50.0 is directly connected, Loopback0
C 172.16.100.0 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 2 subnets
C 10.0.10.0 is directly connected, Serial1/0
D 10.0.20.0 [90/2681856] via 10.0.10.1, 00:03:01, Serial1/0
CE1B#
CE1B#ping 172.16.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 388/524/668 ms
CE1B#tra
CE1B#traceroute 172.16.200.1
Type escape sequence to abort.
Tracing the route to 172.16.200.1
1 10.0.10.1 100 msec 300 msec 252 msec
2 10.0.20.1 432 msec 376 msec 228 msec
3 10.0.20.2 144 msec 316 msec *
CE1B#
CE2B#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
C 172.16.200.0 is directly connected, FastEthernet0/0
C 172.16.60.0 is directly connected, Loopback0
D EX 172.16.50.0 [170/3193856] via 10.0.20.1, 00:02:19, Serial1/0
D EX 172.16.100.0 [170/3193856] via 10.0.20.1, 00:02:19, Serial1/0
10.0.0.0/30 is subnetted, 2 subnets
D 10.0.10.0 [90/2681856] via 10.0.20.1, 00:02:19, Serial1/0
C 10.0.20.0 is directly connected, Serial1/0
CE2B#
CE2B#ping 172.16.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 196/291/444 ms
CE2B#tra
CE2B#traceroute 172.16.100.1
Type escape sequence to abort.
Tracing the route to 172.16.100.1
1 10.0.20.1 108 msec 84 msec 108 msec
2 10.0.10.1 444 msec 244 msec 184 msec
3 10.0.10.2 224 msec 384 msec 748 msec
CE2B#
CE1A#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.20.1 1 FULL/BDR 00:00:38 172.16.1.2 FastEthernet0/
0.1
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O E2 172.16.20.1/32 [110/20] via 172.16.1.2, 00:31:05, FastEthernet0/0.100
C 172.16.10.1/32 is directly connected, Loopback0
C 172.16.1.0/30 is directly connected, FastEthernet0/0.100
CE1A#show ip rou
CE1A#show ip route vrf CEB
Routing Table: CEB
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
B 172.16.200.0 [200/2681856] via 172.16.20.1, 00:03:52
B 172.16.60.0 [200/2681856] via 172.16.20.1, 00:03:52
D EX 172.16.50.0 [170/2681856] via 10.0.10.2, 00:11:39, Serial1/0
D EX 172.16.100.0 [170/2681856] via 10.0.10.2, 00:11:39, Serial1/0
10.0.0.0/30 is subnetted, 2 subnets
C 10.0.10.0 is directly connected, Serial1/0
B 10.0.20.0 [200/0] via 172.16.20.1, 00:03:52
CE1A#
CE2A#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.10.1 1 FULL/DR 00:00:31 172.16.1.1 FastEthernet0/
0.1
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 172.16.20.1/32 is directly connected, Loopback0
O E2 172.16.10.1/32 [110/20] via 172.16.1.1, 00:31:53, FastEthernet0/0.100
C 172.16.1.0/30 is directly connected, FastEthernet0/0.100
CE2A#sh ip route vrf CEB
Routing Table: CEB
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 4 subnets
D EX 172.16.200.0 [170/2681856] via 10.0.20.2, 00:11:34, Serial1/0
D EX 172.16.60.0 [170/2681856] via 10.0.20.2, 00:11:34, Serial1/0
B 172.16.50.0 [200/2681856] via 172.16.10.1, 00:03:40
B 172.16.100.0 [200/2681856] via 172.16.10.1, 00:03:40
10.0.0.0/30 is subnetted, 2 subnets
B 10.0.10.0 [200/0] via 172.16.10.1, 00:03:40
C 10.0.20.0 is directly connected, Serial1/0
CE2A#
PE1#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0.100 Eth VLAN 100 10.0.2.1 100 UP
Fa2/0.100 Eth VLAN 100 10.0.3.1 101 DOWN
PE1#
PE2#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.100 Eth VLAN 100 10.0.1.1 100 UP
PE2#
PE3#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.101 Eth VLAN 100 10.0.1.1 101 DOWN
PE3#
***************************************************************************************
Traffic going via VCID 101 PE1-PE3
**************************************************************************************
PE1#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0.100 Eth VLAN 100 10.0.2.1 100 UP
Fa2/0.100 Eth VLAN 100 10.0.3.1 101 DOWN
PE1#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0.100 Eth VLAN 100 10.0.2.1 100 DOWN
Fa2/0.100 Eth VLAN 100 10.0.3.1 101 UP
PE1#
PE2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset up up
FastEthernet1/0.100 unassigned YES unset up up
FastEthernet1/1 unassigned YES unset administratively down down
Serial2/0 192.168.1.2 YES manual administratively down down
Serial2/1 unassigned YES unset administratively down down
Serial2/2 unassigned YES unset administratively down down
Serial2/3 unassigned YES unset administratively down down
Serial2/4 unassigned YES unset administratively down down
Serial2/5 unassigned YES unset administratively down down
Serial2/6 unassigned YES unset administratively down down
Serial2/7 unassigned YES unset administratively down down
Loopback0 10.0.2.1 YES manual up up
PE2#
PE2#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.100 Eth VLAN 100 10.0.1.1 100 DOWN
PE2#
PE3#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.101 Eth VLAN 100 10.0.1.1 101 UP
PE3#
CE2B#ping
Protocol [ip]:
Target IP address: 172.16.100.1
Repeat count [5]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.......!!!!!!!!!...!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
PE2#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.100 Eth VLAN 100 10.0.1.1 100 DOWN
PE2#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.100 Eth VLAN 100 10.0.1.1 100 UP
PE2#sh ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset up up
FastEthernet1/0.100 unassigned YES unset up up
FastEthernet1/1 unassigned YES unset administratively down down
Serial2/0 192.168.1.2 YES manual up up
Serial2/1 unassigned YES unset administratively down down
Serial2/2 unassigned YES unset administratively down down
Serial2/3 unassigned YES unset administratively down down
Serial2/4 unassigned YES unset administratively down down
Serial2/5 unassigned YES unset administratively down down
Serial2/6 unassigned YES unset administratively down down
Serial2/7 unassigned YES unset administratively down down
Loopback0 10.0.2.1 YES manual up up
PE2#
PE3#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa1/0.101 Eth VLAN 100 10.0.1.1 101 DOWN
PE3#
CE2B#ping
Protocol [ip]:
Target IP address: 172.16.100.1
Repeat count [5]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.......!!!!!!!!!...!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

No comments:

Post a Comment