Thursday, December 3, 2009

IPv6 MPLS L2VPN using Like Circuits-Ethernet VLAN Links LAB



Configuration Guidelines::
Dual Stack Router with Separate Links for running IPv4 and IPv6 over Provider L2 MPLS AToM
IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.
Psuedowire Class used CEA for IPv6
VCID used 100
VLAN used 100
Psuedowire Class used CEB for IPv4
VCID used 101
VLAN used 101

IGP for CE Domain is IBGP for IPv6
IGP for CE Domain is EIGRP for IPv4
VLAN Ethernet Link used between PE-CE
VLAN used 100
*************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1595 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
!
interface Loopback1
description <>
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
no snmp trap link-status
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet0/1
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 172.16.1.1 255.255.255.252
no snmp trap link-status
!
!
router eigrp 100
redistribute connected route-map Local
network 172.16.1.0 0.0.0.3
auto-summary
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::2 remote-as 64513
neighbor 2001:810:FFFF:1::2 description <>
no auto-summary
!
address-family ipv6
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 send-community extended
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1A#
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1594 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.255
!
interface Loopback1
description <>
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
description >
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
no snmp trap link-status
ipv6 address 2001:810:FFFF:1::2/64
!
interface FastEthernet0/1
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 172.16.1.2 255.255.255.252
no snmp trap link-status
!
!
router eigrp 100
redistribute connected route-map Local
network 172.16.1.0 0.0.0.3
auto-summary
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
no auto-summary
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
redistribute connected
no synchronization
exit-address-family
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE2A#
PE1#sh running-config
Building configuration...
Current configuration : 2019 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEB
encapsulation mpls
!
pseudowire-class CEA
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet1/0.101
encapsulation dot1Q 101
xconnect 10.0.3.1 101 encapsulation mpls pw-class CEA
!
interface FastEthernet1/1
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.100
encapsulation dot1Q 100
xconnect 10.0.3.1 100 encapsulation mpls pw-class CEB
!
interface Serial2/0
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE1#
PE1#
P#sh running-config
Building configuration...
Current configuration : 1598 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname P
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.2222.3333.4444.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
P#
PE2#sh running-config
Building configuration...
Current configuration : 2033 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEB
encapsulation mpls
!
pseudowire-class CEA
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
speed auto
duplex auto
!
interface FastEthernet1/0.101
encapsulation dot1Q 101
xconnect 10.0.1.1 101 encapsulation mpls pw-class CEA
!
interface FastEthernet1/1
description <
no ip address
speed auto
duplex auto
!
interface FastEthernet1/1.100
encapsulation dot1Q 100
xconnect 10.0.1.1 100 encapsulation mpls pw-class CEB
!
interface Serial2/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.5555.6666.7777.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
line vty 0 4
!
end
PE2#
OUTPUT
**************************************************************************
CE1A#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0.101
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet0/0.101
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback1
B FEC0:0:0:2::1/128 [200/0]
via 2001:810:FFFF:1::2
L FF00::/8 [0/0]
via ::, Null0
CE1A#sho
CE1A#show ip rou
CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/1.100
10.0.0.0/32 is subnetted, 2 subnets
D EX 10.0.5.1 [170/156160] via 172.16.1.2, 00:28:35, FastEthernet0/1.100
C 10.0.4.1 is directly connected, Loopback0
CE1A#sho
CE1A#show bg
CE1A#show bgp ipv
CE1A#show bgp ipv6
CE1A#show bgp ipv6 uni
CE1A#show bgp ipv6 unicast sum
CE1A#show bgp ipv6 unicast summary
BGP router identifier 10.0.4.1, local AS number 64513
BGP table version is 4, main routing table version 4
3 network entries using 447 bytes of memory
4 path entries using 304 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1123 total bytes of memory
BGP activity 3/0 prefixes, 4/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:810:FFFF:1::2
4 64513 25 25 4 0 0 00:20:22 2
CE1A#show ip eig
CE1A#show ip eigrp nei
CE1A#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.1.2 Fa0/1.100 10 00:28:49 177 1062 0 2
CE1A#
CE1A#
CE1A#ping FEC0:0:0:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/171/256 ms
CE1A#tra
CE1A#traceroute FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 FEC0:0:0:2::1 160 msec 220 msec 344 msec
CE1A#ping 10.0.5.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/171/264 ms
CE1A#tra
CE1A#traceroute 10.0.5.1
Type escape sequence to abort.
Tracing the route to 10.0.5.1
1 172.16.1.2 272 msec 296 msec *
CE1A#
CE2A#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet0/0.101
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet0/0.101
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [200/0]
via 2001:810:FFFF:1::1
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback1
L FF00::/8 [0/0]
via ::, Null0
CE2A#sho
CE2A#show bg
CE2A#show bgp ipv6 unicast summary
BGP router identifier 10.0.5.1, local AS number 64513
BGP table version is 4, main routing table version 4
3 network entries using 447 bytes of memory
4 path entries using 304 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1123 total bytes of memory
BGP activity 3/0 prefixes, 4/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:810:FFFF:1::1
4 64513 26 26 4 0 0 00:21:24 2
CE2A#show ip rou
CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/30 is subnetted, 1 subnets
C 172.16.1.0 is directly connected, FastEthernet0/1.100
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.5.1 is directly connected, Loopback0
D EX 10.0.4.1 [170/156160] via 172.16.1.1, 00:29:41, FastEthernet0/1.100
CE2A#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.1.1 Fa0/1.100 11 00:30:01 226 2034 0 4
CE2A#
CE2A#ping FEC0:0:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 132/250/384 ms
CE2A#tra
CE2A#traceroute FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 FEC0:0:0:1::1 424 msec 272 msec 156 msec
CE2A#
CE2A#ping 10.0.4.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/124/200 ms
CE2A#tra
CE2A#traceroute 10.0.4.1
Type escape sequence to abort.
Tracing the route to 10.0.4.1
1 172.16.1.1 120 msec 380 msec *
CE2A#
PE1#show mpls l2transport vc detail
Local interface: Fa1/1.100 up, line protocol up, Eth VLAN 100 up
Destination address: 10.0.3.1, VC ID: 100, VC status: up
Output interface: Se2/0, imposed label stack {16 22}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:43:52, last status change time: 00:43:51
Signaling protocol: LDP, peer 10.0.3.1:0 up
Targeted Hello: 10.0.1.1(LDP Id) -> 10.0.3.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 22, remote 22
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 500, send 496
byte totals: receive 41003, send 47732
packet drops: receive 0, seq error 0, send 41
Local interface: Fa1/0.101 up, line protocol up, Eth VLAN 101 up
Destination address: 10.0.3.1, VC ID: 101, VC status: up
Output interface: Se2/0, imposed label stack {16 16}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:25:53, last status change time: 00:25:01
Signaling protocol: LDP, peer 10.0.3.1:0 up
Targeted Hello: 10.0.1.1(LDP Id) -> 10.0.3.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 16, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 92, send 65
byte totals: receive 8956, send 7938
packet drops: receive 0, seq error 0, send 0
PE1#
PE1#
PE2#show mpls l2transport vc detail
Local interface: Fa1/1.100 up, line protocol up, Eth VLAN 100 up
Destination address: 10.0.1.1, VC ID: 100, VC status: up
Output interface: Se2/0, imposed label stack {17 22}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:44:58, last status change time: 00:44:23
Signaling protocol: LDP, peer 10.0.1.1:0 up
Targeted Hello: 10.0.3.1(LDP Id) -> 10.0.1.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 22, remote 22
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 504, send 509
byte totals: receive 40416, send 49821
packet drops: receive 0, seq error 0, send 34
Local interface: Fa1/0.101 up, line protocol up, Eth VLAN 101 up
Destination address: 10.0.1.1, VC ID: 101, VC status: up
Output interface: Se2/0, imposed label stack {17 16}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:25:34, last status change time: 00:25:34
Signaling protocol: LDP, peer 10.0.1.1:0 up
Targeted Hello: 10.0.3.1(LDP Id) -> 10.0.1.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 16, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 67, send 94
byte totals: receive 7117, send 10635
packet drops: receive 0, seq error 0, send 0
PE2#
PE2#

No comments:

Post a Comment