Design Considerations for Carrier Supporting Carrier with Customer Carrier and Backbone Carrier both runing MPLS-
Ipv6 and IPv4 Link between ISPs
*******************************************************************************************************************
Peering between Customer Carrier and Backbone carrier is IPv4
MP-eBGP vpnv6 Peering established between ISPs
Backbone Carrier does not runs IPv6 and provides a transport for IPv6 Traffic across its core to Customer Carrier
Using next-hop-self feature for address-family vpnv6 BGP sessions in Customer Carrier and address-family ipv6
between customer carrier and backbone carrier.
Using redistribute connected at all ISP Peering points for reachability.
Backbone Carrier-Customer Carrier Links are IPv4
Using Route-Map with Community-List and As-path Access-List in Backbone Carrier to allow only Customer VPN ROutes
to Customer Carrier.
Using Route-Map with As-path Access-List in Customer Carrier to allow only Customer VPN ROutes to Customer .
Data Flow
**************
CE1A-PE1C over IPv6 EBGP
PE1c-PE2c over vpnv6 MP-iBGP
PE2C-PE1B over vpnv6 MP-eBGP
PE1B-PE2B over vpnv6 MP-iBGP
PE2B-PE3C over vpnv6 MP-eBGP
PE3c-PE4c over vpnv6 MP-iBGP
PE4C-CE2A over IPv6 EBGP
*****************************************
Configuration Guidelines
Customer Carrier VRF used for CEA is CEA
rd 64513:1
rt 64513:100
Backbone Carrier VRF used for Customer Carrier is ISPA
rd used 64515:1
rt 64515:100
PE-CE for Customer Carrier is EBGP
IGP for Customer Carrier is ISIS. PE1C & PE2C and PE3C & PE4C in different area and loopbacks in level-1.
PE-CE for Backbone carrier is EBGP
IGP for Backbone Carrier is ISIS.PE1B & PE2B in different area and loopbacks in level-1
CE AS 64514
Backbone Carrier Community-List used
Community standard list 14
permit 64515:14
Backbone Carrier AS-Path Access-List used
AS path access list 13
permit 10 _64513_
AS path access list 14
permit _64514$
Customer Carrier AS-Path Access-List used
AS path access list 13
deny ^$
AS path access list 14
permit _64514_
Route-Map Used in Backbone Carrier to Customer Carrier
CEA Inbound
CEA_OUT Outbound
Route-Map Used in Customer Carrier to CEs
CEA_OUT Outbound
************************************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1605 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
no ip address
ipv6 address 2001:810:FFFF:1::2/64
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 64514
bgp router-id 172.16.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 allowas-in 5
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
ip classless
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1578 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
no ip address
ipv6 address 2001:1210:FFFF:1::2/64
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 64514
bgp router-id 172.16.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
neighbor 2001:1210:FFFF:1::1 description
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
ip classless
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end
CE2A#
PE1C#sh running-config
Building configuration...
Current configuration : 2992 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
vrf forwarding CEA
no ip address
ipv6 address 2001:810:FFFF:1::1/64
serial restart-delay 0
!
interface Serial1/1
description
ip address 172.16.10.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description
neighbor 10.0.2.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description
!
address-family ipv4
no synchronization
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 next-hop-self
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:810:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip as-path access-list 13 deny ^$
ip as-path access-list 14 permit _64514_
!
no ip http server
no ip http secure-server
!
!
route-map CEA_OUT permit 10
match as-path 14
!
route-map CEA_OUT permit 20
match as-path 13
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1C#
PE1C#
PE1C#
PE2C#sh running-config
Building configuration...
Current configuration : 3085 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding CEA
no ip address
ipv6 address FEC0:0:0:3::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 172.16.10.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
ip address 192.168.1.6 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.2222.1111.00
redistribute connected route-map Local
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description
neighbor 10.0.1.1 update-source Loopback0
neighbor 192.168.1.5 remote-as 64515
neighbor 192.168.1.5 description
!
address-family ipv4
no synchronization
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 192.168.1.5 activate
neighbor 192.168.1.5 send-community extended
neighbor 192.168.1.5 allowas-in 5
neighbor 192.168.1.5 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 192.168.1.5 activate
neighbor 192.168.1.5 send-community extended
neighbor 192.168.1.5 allowas-in 5
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Serial1/1
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2C#
PE3C#sh running-config
Building configuration...
Current configuration : 3086 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding CEA
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.10 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
description
ip address 172.16.10.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.9999.8888.7777.00
redistribute connected route-map Local
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description
neighbor 10.0.4.1 update-source Loopback0
neighbor 192.168.1.9 remote-as 64515
neighbor 192.168.1.9 description
!
address-family ipv4
no synchronization
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 next-hop-self
neighbor 10.0.4.1 soft-reconfiguration inbound
neighbor 192.168.1.9 activate
neighbor 192.168.1.9 send-community extended
neighbor 192.168.1.9 allowas-in 5
neighbor 192.168.1.9 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
neighbor 192.168.1.9 activate
neighbor 192.168.1.9 send-community extended
neighbor 192.168.1.9 allowas-in 5
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Serial1/0
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE3C#
PE4C#sh running-config
Building configuration...
Current configuration : 3044 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE4C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 172.16.10.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
vrf forwarding CEA
no ip address
ipv6 address 2001:1210:FFFF:1::1/64
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0004.7777.6666.5555.00
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description
!
address-family ipv4
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 next-hop-self
neighbor 2001:1210:FFFF:1::2 as-override
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1210:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip as-path access-list 13 deny ^$
ip as-path access-list 14 permit _64514_
!
no ip http server
no ip http secure-server
!
!
route-map CEA_OUT permit 10
match as-path 14
!
route-map CEA_OUT permit 20
match as-path 13
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE4C#
PE1B#sh running-config
Building configuration...
Current configuration : 3201 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1B
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 192.168.10.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.5 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
description
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Local
!
router bgp 64515
bgp router-id 192.168.10.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 192.168.1.6 remote-as 64513
neighbor 192.168.1.6 description
neighbor 192.168.20.1 remote-as 64515
neighbor 192.168.20.1 description
neighbor 192.168.20.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 192.168.1.6 activate
neighbor 192.168.1.6 next-hop-self
neighbor 192.168.1.6 default-originate
neighbor 192.168.1.6 soft-reconfiguration inbound
neighbor 192.168.1.6 route-map CEA in
neighbor 192.168.1.6 route-map CEA_OUT out
neighbor 192.168.20.1 activate
neighbor 192.168.20.1 send-community
neighbor 192.168.20.1 next-hop-self
neighbor 192.168.20.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 192.168.1.6 activate
neighbor 192.168.1.6 send-community extended
neighbor 192.168.20.1 activate
neighbor 192.168.20.1 send-community both
exit-address-family
!
ip classless
!
ip bgp-community new-format
ip community-list 14 permit 64515:14
ip as-path access-list 13 permit 10 _64513_
ip as-path access-list 14 permit _64514$
!
no ip http server
no ip http secure-server
!
!
route-map CEA permit 10
match as-path 14
set community 64515:14
set extcommunity rt 64515:14
!
route-map CEA permit 20
match as-path 13
!
route-map CEA permit 30
!
route-map Local permit 10
match interface Serial1/0
!
route-map CEA_OUT permit 10
match community 14
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1B#
PE2B#sh running-config
Building configuration...
Current configuration : 3178 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2B
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 192.168.20.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
ip address 192.168.1.9 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.2222.1111.00
redistribute connected route-map Local
!
router bgp 64515
bgp router-id 192.168.20.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 192.168.1.10 remote-as 64513
neighbor 192.168.1.10 description
neighbor 192.168.10.1 remote-as 64515
neighbor 192.168.10.1 description
neighbor 192.168.10.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 192.168.1.10 activate
neighbor 192.168.1.10 send-community extended
neighbor 192.168.1.10 next-hop-self
neighbor 192.168.1.10 default-originate
neighbor 192.168.1.10 route-map CEA in
neighbor 192.168.1.10 route-map CEA_OUT out
neighbor 192.168.10.1 activate
neighbor 192.168.10.1 send-community
neighbor 192.168.10.1 next-hop-self
neighbor 192.168.10.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 192.168.1.10 activate
neighbor 192.168.1.10 send-community extended
neighbor 192.168.10.1 activate
neighbor 192.168.10.1 send-community both
exit-address-family
!
ip classless
!
ip bgp-community new-format
ip community-list 14 permit 64515:14
ip as-path access-list 13 permit _64513_
ip as-path access-list 14 permit _64514$
!
no ip http server
no ip http secure-server
!
!
route-map CEA permit 10
match as-path 14
set community 64515:14
set extcommunity rt 64515:14
!
route-map CEA permit 20
match as-path 13
!
route-map Local permit 10
match interface Serial1/0 Serial1/1
!
route-map CEA_OUT permit 10
match community 14
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2B#
PE2B#
PE2B#
*********************************************
OUTPUT
CE1A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
C 2001:810:FFFF:1::/64 [0/0]
via ::, Serial1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, Serial1/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C801:11FF:FEB8:0, Serial1/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:2::1/128 [20/0]
via FE80::C801:11FF:FEB8:0, Serial1/0
L FF00::/8 [0/0]
via ::, Null0
CE1A#ping FEC0:0:0:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/368/564 ms
CE1A#tra
CE1A#traceroute FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 2001:810:FFFF:1::1 192 msec 96 msec 92 msec
2 ::FFFF:172.16.10.1 532 msec 500 msec 436 msec
3 ::FFFF:192.168.1.5 364 msec 412 msec 328 msec
4 ::FFFF:192.168.1.2 484 msec 168 msec 364 msec
5 FEC0:0:0:4::1 408 msec 368 msec 216 msec
6 2001:1210:FFFF:1::1 384 msec 552 msec 260 msec
7 2001:1210:FFFF:1::2 588 msec 312 msec 308 msec
CE1A#
CE2A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C806:12FF:FE84:0, Serial1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, Serial1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, Serial1/0
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [20/0]
via FE80::C806:12FF:FE84:0, Serial1/0
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping FEC0:0:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 232/316/448 ms
CE2A#r
CE2A#tr
CE2A#traceroute FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 2001:1210:FFFF:1::1 96 msec 124 msec 136 msec
2 ::FFFF:172.16.10.5 380 msec 452 msec 456 msec
3 ::FFFF:192.168.1.9 508 msec 616 msec 764 msec
4 ::FFFF:192.168.1.1 496 msec 260 msec 320 msec
5 FEC0:0:0:3::1 336 msec 228 msec 420 msec
6 2001:810:FFFF:1::1 328 msec 432 msec 548 msec
7 2001:810:FFFF:1::2 452 msec 496 msec 376 msec
CE2A#
PE1C#traceroute vrf CEA FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 ::FFFF:172.16.10.1 [MPLS: Labels 17/21 Exp 0] 648 msec 488 msec 872 msec
2 ::FFFF:192.168.1.5 [MPLS: Label 21 Exp 0] 532 msec 644 msec 632 msec
3 ::FFFF:192.168.1.2 [MPLS: Labels 19/19 Exp 0] 572 msec 716 msec 644 msec
4 FEC0:0:0:4::1 [AS 64513] [MPLS: Label 19 Exp 0] 380 msec 500 msec 340 msec
5 2001:1210:FFFF:1::1 [AS 64514] [MPLS: Label 20 Exp 0] 592 msec 1160 msec 180
0 msec
6 2001:1210:FFFF:1::2 [AS 64514] 884 msec 528 msec 476 msec
PE1C#
PE4C#traceroute vrf CEA ipv6 FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 ::FFFF:172.16.10.5 [MPLS: Labels 16/20 Exp 0] 1328 msec * *
2 ::FFFF:192.168.1.9 [MPLS: Label 20 Exp 0] 1524 msec 904 msec 588 msec
3 ::FFFF:192.168.1.1 [MPLS: Labels 16/18 Exp 0] 936 msec 376 msec 796 msec
4 FEC0:0:0:3::1 [AS 64513] [MPLS: Label 18 Exp 0] 520 msec 476 msec 424 msec
5 2001:810:FFFF:1::1 [AS 64514] [MPLS: Label 17 Exp 0] 596 msec 576 msec 628 m
sec
6 2001:810:FFFF:1::2 [AS 64514] 628 msec 536 msec 572 msec
PE4C#
No comments:
Post a Comment