Design Considerations for Carrier Supporting Carrier with Customer Carrier and Backbone Carrier both runing MPLS-
Ipv6 and IPv6 Link between ISPs
*******************************************************************************************************************
*
Customer Carrier should create a dedicated VRF for peering with Backbone Carrier and should import/export the CE's
RTs as needed in the backbone provider VRF
Backbone Carrier should create a dedicated VRF for peering with Customer Carrier and RT is independent of Customer
Carrier For backbone carrier Customer Carrier is just a CE.
Peering between Customer Carrier and Backbone carrier is IPv6
Using next-hop-self feature for address-family vpnv6 BGP sessions in Customer Carrier and address-family ipv6
between customer carrier and backbone carrier.
Using redistribute connected at all ISP Peering points for reachability.
Backbone Carrier-Customer Carrier Links are IPv6
Using Route-Map with Community-List and As-path Access-List in Backbone Carrier to allow only Customer VPN ROutes to Customer Carrier.
Using Route-Map with As-path Access-List in Customer Carrier to allow only Customer VPN ROutes to Customer .
Data Flow
**************
CE1A-PE1C over IPv6 EBGP
PE1c-PE2c over vpnv6 MP-iBGP
PE2C-PE1B over any relevant Ipv6 PE-CE Routing Protocol (Static/EBGP)
PE1B-PE2B over vpnv6 MP-iBGP
PE2B-PE3C over any relevant Ipv6 PE-CE Routing Protocol (Static/EBGP)
PE3c-PE4c over vpnv6 MP-iBGP
PE4C-CE2A over IPv6 EBGP
*****************************************
Configuration Guidelines
Customer Carrier VRF used for CEA is CEA
rd 64513:1
rt 64513:100
Backbone Carrier VRF used for Customer Carrier is ISPA
rd used 64515:1
rt 64515:100
PE-CE for Customer Carrier is EBGP
IGP for Customer Carrier is ISIS. PE1C & PE2C and PE3C & PE4C in different area and loopbacks in level-1.
PE-CE for Backbone carrier is EBGP
IGP for Backbone Carrier is ISIS.PE1B & PE2B in different area and loopbacks in level-1
CE AS 64514
Backbone Carrier Community-List used
Community standard list 14
permit 64515:14
Backbone Carrier AS-Path Access-List used
AS path access list 13
permit 10 _64513_
AS path access list 14
permit _64514$
Customer Carrier AS-Path Access-List used
AS path access list 13
deny ^$
AS path access list 14
permit _64514_
Route-Map Used in Backbone Carrier to Customer Carrier
CEA Inbound
CEA_OUT Outbound
Route-Map Used in Customer Carrier to CEs
CEA_OUT Outbound
************************************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1605 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:1::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
no ip address
ipv6 address 2001:810:FFFF:1::2/64
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 64514
bgp router-id 172.16.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 allowas-in 5
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
ip classless
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1578 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:2::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
no ip address
ipv6 address 2001:1210:FFFF:1::2/64
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 64514
bgp router-id 172.16.2.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
neighbor 2001:1210:FFFF:1::1 description
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
redistribute connected route-map Local
no synchronization
exit-address-family
!
ip http server
ip classless
!
!
!
!
route-map Local permit 10
match interface Loopback0 Serial1/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
!
end
CE2A#
PE1C#sh running-config
Building configuration...
Current configuration : 2992 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
vrf forwarding CEA
no ip address
ipv6 address 2001:810:FFFF:1::1/64
serial restart-delay 0
!
interface Serial1/1
description
ip address 172.16.10.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description
neighbor 10.0.2.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description
!
address-family ipv4
no synchronization
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 next-hop-self
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:810:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip as-path access-list 13 deny ^$
ip as-path access-list 14 permit _64514_
!
no ip http server
no ip http secure-server
!
!
route-map CEA_OUT permit 10
match as-path 14
!
route-map CEA_OUT permit 20
match as-path 13
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1C#
PE2C#sh running-config
Building configuration...
Current configuration : 2947 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding CEA
no ip address
ipv6 address FEC0:0:0:3::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 172.16.10.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
vrf forwarding CEA
no ip address
ipv6 address 2001:1610:FFFF:1::2/64
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.2222.1111.00
!
router bgp 64513
bgp router-id 10.0.2.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description
neighbor 10.0.1.1 update-source Loopback0
neighbor 2001:1610:FFFF:1::1 remote-as 64515
neighbor 2001:1610:FFFF:1::1 description
!
address-family ipv4
no synchronization
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
neighbor 2001:1610:FFFF:1::1 remote-as 64515
neighbor 2001:1610:FFFF:1::1 activate
neighbor 2001:1610:FFFF:1::1 send-community extended
neighbor 2001:1610:FFFF:1::1 allowas-in 5
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map CEA permit 30
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2C#
PE4C#sh running-config
Building configuration...
Current configuration : 3044 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE4C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 172.16.10.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
vrf forwarding CEA
no ip address
ipv6 address 2001:1210:FFFF:1::1/64
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0004.7777.6666.5555.00
!
router bgp 64513
bgp router-id 10.0.4.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description
!
address-family ipv4
no synchronization
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
no synchronization
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 next-hop-self
neighbor 2001:1210:FFFF:1::2 as-override
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1210:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip as-path access-list 13 deny ^$
ip as-path access-list 14 permit _64514_
!
no ip http server
no ip http secure-server
!
!
route-map CEA_OUT permit 10
match as-path 14
!
route-map CEA_OUT permit 20
match as-path 13
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE4C#
PE3C#sh running-config
Building configuration...
Current configuration : 2981 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE3C
!
boot-start-marker
boot-end-marker
!
vrf definition CEA
description
rd 64513:1
!
address-family ipv6
route-target export 64513:100
route-target import 64513:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding CEA
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
vrf forwarding CEA
no ip address
ipv6 address 2001:2010:FFFF:1::2/64
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
description
ip address 172.16.10.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0003.9999.8888.7777.00
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description
neighbor 10.0.4.1 update-source Loopback0
neighbor 2001:2010:FFFF:1::1 remote-as 64515
neighbor 2001:2010:FFFF:1::1 description
!
address-family ipv4
no synchronization
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 next-hop-self
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv6 vrf CEA
redistribute connected
no synchronization
neighbor 2001:2010:FFFF:1::1 remote-as 64515
neighbor 2001:2010:FFFF:1::1 activate
neighbor 2001:2010:FFFF:1::1 send-community extended
neighbor 2001:2010:FFFF:1::1 allowas-in 5
neighbor 2001:2010:FFFF:1::1 soft-reconfiguration inbound
exit-address-family
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE3C#
PE2B#sh running-config
Building configuration...
Current configuration : 3447 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2B
!
boot-start-marker
boot-end-marker
!
vrf definition ISPA
description
rd 64515:1
!
address-family ipv6
route-target export 64515:100
route-target import 64515:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 192.168.20.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding ISPA
no ip address
ipv6 address FEC0:0:0:6::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description
vrf forwarding ISPA
no ip address
ipv6 address 2001:2010:FFFF:1::1/64
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.3333.2222.1111.00
!
router bgp 64515
bgp router-id 192.168.20.1
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 2001:2010:FFFF:1::2 remote-as 64513
neighbor 2001:2010:FFFF:1::2 description
neighbor 192.168.10.1 remote-as 64515
neighbor 192.168.10.1 description
neighbor 192.168.10.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 192.168.10.1 activate
neighbor 192.168.10.1 send-community
neighbor 192.168.10.1 next-hop-self
neighbor 192.168.10.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 192.168.10.1 activate
neighbor 192.168.10.1 send-community both
exit-address-family
!
address-family ipv6 vrf ISPA
redistribute connected
no synchronization
neighbor 2001:2010:FFFF:1::2 remote-as 64513
neighbor 2001:2010:FFFF:1::2 activate
neighbor 2001:2010:FFFF:1::2 send-community extended
neighbor 2001:2010:FFFF:1::2 default-originate
neighbor 2001:2010:FFFF:1::2 route-map CEA in
neighbor 2001:2010:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip bgp-community new-format
ip community-list 14 permit 64515:14
ip as-path access-list 13 permit _64513_
ip as-path access-list 14 permit _64514$
!
no ip http server
no ip http secure-server
!
!
route-map CEA permit 10
match as-path 14
set community 64515:14
set extcommunity rt 64515:14
!
route-map CEA permit 20
match as-path 13
!
route-map CEA_OUT permit 10
match community 14
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE2B#
PE1B#sh running-config
Building configuration...
Current configuration : 3606 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1B
!
boot-start-marker
boot-end-marker
!
vrf definition ISPA
description
rd 64515:1
!
address-family ipv6
route-target export 64515:100
route-target import 64515:100
exit-address-family
!
no logging console
!
no aaa new-model
ip subnet-zero
ip source-route
!
!
!
!
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description
ip address 192.168.10.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback1
description
vrf forwarding ISPA
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description
vrf forwarding ISPA
no ip address
ipv6 address 2001:1610:FFFF:1::1/64
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
description
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64515
bgp router-id 192.168.10.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1610:FFFF:1::2 remote-as 64513
neighbor 2001:1610:FFFF:1::2 description
neighbor 192.168.20.1 remote-as 64515
neighbor 192.168.20.1 description
neighbor 192.168.20.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 192.168.20.1 activate
neighbor 192.168.20.1 send-community
neighbor 192.168.20.1 next-hop-self
neighbor 192.168.20.1 soft-reconfiguration inbound
no auto-summary
exit-address-family
!
address-family vpnv6
neighbor 192.168.20.1 activate
neighbor 192.168.20.1 send-community both
exit-address-family
!
address-family ipv6 vrf ISPA
redistribute connected
no synchronization
neighbor 2001:1610:FFFF:1::2 remote-as 64513
neighbor 2001:1610:FFFF:1::2 description
neighbor 2001:1610:FFFF:1::2 activate
neighbor 2001:1610:FFFF:1::2 next-hop-self
neighbor 2001:1610:FFFF:1::2 default-originate
neighbor 2001:1610:FFFF:1::2 soft-reconfiguration inbound
neighbor 2001:1610:FFFF:1::2 route-map CEA in
neighbor 2001:1610:FFFF:1::2 route-map CEA_OUT out
exit-address-family
!
ip classless
!
ip bgp-community new-format
ip community-list 14 permit 64515:14
ip as-path access-list 13 permit 10 _64513_
ip as-path access-list 14 permit _64514$
!
no ip http server
no ip http secure-server
!
!
route-map CEA permit 10
match as-path 14
set community 64515:14
set extcommunity rt 64515:14
!
route-map CEA permit 20
match as-path 13
!
route-map CEA permit 30
!
route-map CEA_OUT permit 10
match community 14
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE1B#
OUTPUT
*******************************************************************
CE1A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
C 2001:810:FFFF:1::/64 [0/0]
via ::, Serial1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, Serial1/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C803:1FF:FE28:0, Serial1/0
L FE80::/10 [0/0]
via ::, Null0
LC FEC0:0:0:1::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:2::1/128 [20/0]
via FE80::C803:1FF:FE28:0, Serial1/0
L FF00::/8 [0/0]
via ::, Null0
CE1A#ping FEC0:0:0:2::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:2::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 652/719/760 ms
CE1A#
CE2A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C808:EFF:FE84:0, Serial1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, Serial1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, Serial1/0
L FE80::/10 [0/0]
via ::, Null0
B FEC0:0:0:1::1/128 [20/0]
via FE80::C808:EFF:FE84:0, Serial1/0
LC FEC0:0:0:2::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping FEC0:0:0:1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 264/430/576 ms
CE2A#
PE1C#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [200/0]
via 10.0.2.1%default, indirectly connected
C 2001:810:FFFF:1::/64 [0/0]
via Serial1/0, directly connected
L 2001:810:FFFF:1::1/128 [0/0]
via Serial1/0, receive
B 2001:1210:FFFF:1::/64 [200/0]
via 10.0.2.1%default, indirectly connected
B 2001:1610:FFFF:1::/64 [200/0]
via 10.0.2.1%default, indirectly connected
B FEC0:0:0:1::1/128 [20/0]
via FE80::CE02:1FF:FE28:0, Serial1/0
B FEC0:0:0:2::1/128 [200/0]
via 10.0.2.1%default, indirectly connected
B FEC0:0:0:3::1/128 [200/0]
via 10.0.2.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE1C#
PE1C#sho
PE1C#show rou
PE1C#show route-map
route-map CEA_OUT, permit, sequence 10
Match clauses:
as-path (as-path filter): 14
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map CEA_OUT, permit, sequence 20
Match clauses:
as-path (as-path filter): 13
Set clauses:
Policy routing matches: 0 packets, 0 bytes
PE1C#shp
PE1C#sho
PE1C#show ip as
PE1C#show ip as-path-access-list
AS path access list 13
deny ^$
AS path access list 14
permit _64514_
PE1C#
PE2C#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
via FE80::C805:AFF:FE10:0, Serial1/1
B 2001:810:FFFF:1::/64 [200/0]
via 10.0.1.1%default, indirectly connected
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C805:AFF:FE10:0, Serial1/1
C 2001:1610:FFFF:1::/64 [0/0]
via Serial1/1, directly connected
L 2001:1610:FFFF:1::2/128 [0/0]
via Serial1/1, receive
B FEC0:0:0:1::1/128 [200/0]
via 10.0.1.1%default, indirectly connected
B FEC0:0:0:2::1/128 [20/0]
via FE80::C805:AFF:FE10:0, Serial1/1
LC FEC0:0:0:3::1/128 [0/0]
via Loopback1, receive
L FF00::/8 [0/0]
via Null0, receive
PE2C#
PE4C#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [200/0]
via 10.0.3.1%default, indirectly connected
B 2001:810:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
C 2001:1210:FFFF:1::/64 [0/0]
via Serial1/1, directly connected
L 2001:1210:FFFF:1::1/128 [0/0]
via Serial1/1, receive
B 2001:2010:FFFF:1::/64 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:1::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
B FEC0:0:0:2::1/128 [20/0]
via FE80::CE09:1FF:FE28:0, Serial1/1
B FEC0:0:0:4::1/128 [200/0]
via 10.0.3.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE4C#show
PE4C#show rou
PE4C#show route-map
route-map CEA_OUT, permit, sequence 10
Match clauses:
as-path (as-path filter): 14
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map CEA_OUT, permit, sequence 20
Match clauses:
as-path (as-path filter): 13
Set clauses:
Policy routing matches: 0 packets, 0 bytes
PE4C#sho
PE4C#show ip as
PE4C#show ip as-path-access-list
AS path access list 13
deny ^$
AS path access list 14
permit _64514_
PE4C#
PE3C#show ipv6 route vrf CEA
IPv6 Routing Table - CEA - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B ::/0 [20/0]
via FE80::C806:11FF:FEB8:0, Serial1/0
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C806:11FF:FEB8:0, Serial1/0
B 2001:1210:FFFF:1::/64 [200/0]
via 10.0.4.1%default, indirectly connected
C 2001:2010:FFFF:1::/64 [0/0]
via Serial1/0, directly connected
L 2001:2010:FFFF:1::2/128 [0/0]
via Serial1/0, receive
B FEC0:0:0:1::1/128 [20/0]
via FE80::C806:11FF:FEB8:0, Serial1/0
B FEC0:0:0:2::1/128 [200/0]
via 10.0.4.1%default, indirectly connected
LC FEC0:0:0:4::1/128 [0/0]
via Loopback1, receive
L FF00::/8 [0/0]
via Null0, receive
PE3C#
PE2B#show route-map
route-map CEA, permit, sequence 10
Match clauses:
as-path (as-path filter): 14
Set clauses:
community 64515:14
extended community RT:64515:14
Policy routing matches: 0 packets, 0 bytes
route-map CEA, permit, sequence 20
Match clauses:
as-path (as-path filter): 13
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map CEA_OUT, permit, sequence 10
Match clauses:
community (community-list filter): 14
Set clauses:
Policy routing matches: 0 packets, 0 bytes
PE2B#sho
PE2B#show ip com
PE2B#show ip community-list
Community standard list 14
permit 64515:14
PE2B#shp
PE2B#shp
PE2B#sho
PE2B#show ip as
PE2B#show ip as-path-access-list
AS path access list 13
permit _64513_
AS path access list 14
permit _64514$
PE2B#
PE1B#show ipv6 route vrf ISPA
IPv6 Routing Table - ISPA - 12 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C804:AFF:FE10:0, Serial1/0
B 2001:1210:FFFF:1::/64 [200/0]
via 192.168.20.1%default, indirectly connected
C 2001:1610:FFFF:1::/64 [0/0]
via Serial1/0, directly connected
L 2001:1610:FFFF:1::1/128 [0/0]
via Serial1/0, receive
B 2001:2010:FFFF:1::/64 [200/0]
via 192.168.20.1%default, indirectly connected
B FEC0:0:0:1::1/128 [20/0]
via FE80::C804:AFF:FE10:0, Serial1/0
B FEC0:0:0:2::1/128 [200/0]
via 192.168.20.1%default, indirectly connected
B FEC0:0:0:3::1/128 [20/0]
via FE80::C804:AFF:FE10:0, Serial1/0
B FEC0:0:0:4::1/128 [200/0]
via 192.168.20.1%default, indirectly connected
LC FEC0:0:0:5::1/128 [0/0]
via Loopback1, receive
B FEC0:0:0:6::1/128 [200/0]
via 192.168.20.1%default, indirectly connected
L FF00::/8 [0/0]
via Null0, receive
PE1B#
PE1B#sho
PE1B#show rou
PE1B#show route-map
route-map CEA, permit, sequence 10
Match clauses:
as-path (as-path filter): 14
Set clauses:
community 64515:14
extended community RT:64515:14
Policy routing matches: 0 packets, 0 bytes
route-map CEA, permit, sequence 20
Match clauses:
as-path (as-path filter): 13
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map CEA, permit, sequence 30
Match clauses:
Set clauses:
Policy routing matches: 0 packets, 0 bytes
route-map CEA_OUT, permit, sequence 10
Match clauses:
community (community-list filter): 14
Set clauses:
Policy routing matches: 0 packets, 0 bytes
PE1B#sho
PE1B#show ip co
PE1B#show ip community-list
Community standard list 14
permit 64515:14
PE1B#show ip as-path-access-list
AS path access list 13
permit 10 _64513_
AS path access list 14
permit _64514$
PE1B#
CE1A#traceroute FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 2001:810:FFFF:1::1 136 msec 168 msec 52 msec
2 2001:1610:FFFF:1::2 228 msec 176 msec 104 msec
3 2001:1610:FFFF:1::1 256 msec 328 msec 288 msec
4 2001:2010:FFFF:1::1 416 msec 320 msec 368 msec
5 2001:2010:FFFF:1::2 776 msec 532 msec 1236 msec
6 2001:1210:FFFF:1::1 484 msec 1300 msec 768 msec
7 2001:1210:FFFF:1::2 824 msec 1052 msec 952 msec
CE1A#
CE2A#traceroute FEC0:0:0:1::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:1::1
1 2001:1210:FFFF:1::1 152 msec 124 msec 92 msec
2 2001:2010:FFFF:1::2 128 msec 148 msec 88 msec
3 2001:2010:FFFF:1::1 136 msec 156 msec 128 msec
4 2001:1610:FFFF:1::1 216 msec 252 msec 360 msec
5 2001:1610:FFFF:1::2 404 msec 312 msec 280 msec
6 2001:810:FFFF:1::1 276 msec 660 msec 236 msec
7 2001:810:FFFF:1::2 344 msec 496 msec 440 msec
CE2A#
PE1C#traceroute vrf CEA ipv6 FEC0:0:0:2::1
Type escape sequence to abort.
Tracing the route to FEC0:0:0:2::1
1 2001:1610:FFFF:1::2 [MPLS: Label 24 Exp 0] 208 msec 188 msec 164 msec
2 2001:1610:FFFF:1::1 376 msec 240 msec 140 msec
3 2001:2010:FFFF:1::1 [AS 64515] [MPLS: Label 16 Exp 0] 492 msec 260 msec 652
msec
4 2001:2010:FFFF:1::2 [AS 64515] 464 msec 260 msec 432 msec
5 2001:1210:FFFF:1::1 [AS 64514] [MPLS: Label 18 Exp 0] 388 msec 536 msec 516
msec
6 2001:1210:FFFF:1::2 [AS 64514] 588 msec 476 msec 668 msec
PE1C#
No comments:
Post a Comment