Thursday, December 24, 2009

Implementing Inter-AS AToM L2 MPLS VPN LAB



Config Gudelines
******************************************************************************************
Scenario: ISP 64513 is Offering L2 VPN Services to Customer A by Provisioning an Inter-AS
AToM MPLS L2 VPN using VFI
IGP used in ISP 64513 is ISIS with Loopbacks in level-1 and Backbone Links in Level-2
IGP used in 64515 OSPF
Psuedowire Used CEA with VCID 101 within the AS PEs and VCID 200 VFI used between AS
IGP In customer dowain used OSPF
******************************************************************************************
CE1A#sh running-config
Building configuration...
Current configuration : 1340 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE1A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.30.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.100.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.1 255.255.255.252
no dce-terminal-timing-enable
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.1.0 0.0.0.3 area 0
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
CE1A#
CE2A#sh running-config
Building configuration...
Current configuration : 1379 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CE2A
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.16.40.1 255.255.255.255
!
interface FastEthernet0/0
description <>
ip address 172.16.200.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description <>
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
no dce-terminal-timing-enable
no fair-queue
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
no dce-terminal-timing-enable
!
!
router ospf 100
log-adjacency-changes
redistribute connected subnets route-map Local
network 172.16.1.0 0.0.0.3 area 0
!
ip http server
!
!
!
!
route-map Local permit 10
match interface Loopback0 FastEthernet0/0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
!
end
CE2A#
PE11#sh running-config
Building configuration...
Current configuration : 1709 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE11
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEA
encapsulation mpls
!
l2 vfi CEA point-to-point
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
no ip address
serial restart-delay 0
xconnect 10.0.1.2 101 encapsulation mpls pw-class CEA
!
interface Serial1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0001.1111.2222.3333.00
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE11#
PE11#
PE12#sh running-config
Building configuration...
Current configuration : 2150 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE12
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEA
encapsulation mpls
!
l2 vfi CEA point-to-point
neighbor 10.0.1.1 101 pw-class CEA
neighbor 10.0.2.2 200 pw-class CEA
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.1.2 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
serial restart-delay 0
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 10.0.20.1 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router isis
net 49.0002.2222.3333.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.2 remote-as 64515
neighbor 10.0.2.2 description <>
neighbor 10.0.2.2 ebgp-multihop 2
neighbor 10.0.2.2 update-source Loopback0
neighbor 10.0.2.2 soft-reconfiguration inbound
neighbor 10.0.2.2 send-label
no auto-summary
!
ip classless
ip route 10.0.2.2 255.255.255.255 10.0.20.2
!
!
no ip http server
no ip http secure-server
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE12#
PE12#
PE21#sh running-config
Building configuration...
Current configuration : 1664 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE21
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEA
encapsulation mpls
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 10.0.10.1 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/1
description <>
no ip address
serial restart-delay 0
xconnect 10.0.2.2 101 encapsulation mpls pw-class CEA
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.10.0 0.0.0.3 area 0
!
ip classless
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Loopback0
!
!
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE21#
PE22#sh running-config
Building configuration...
Current configuration : 2225 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE22
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
ip subnet-zero
!
!
!
!
ip cef
!
!
multilink bundle-name authenticated
mpls ldp discovery targeted-hello accept
mpls label protocol ldp
call rsvp-sync
!
!
!
!
!
!
!
!
pseudowire-class CEA
encapsulation mpls
!
l2 vfi CEA point-to-point
neighbor 10.0.2.1 101 pw-class CEA
neighbor 10.0.1.2 200 pw-class CEA
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
description <>
ip address 10.0.20.2 255.255.255.252
mpls bgp forwarding
mpls label protocol ldp
mpls ip
no fair-queue
serial restart-delay 0
!
interface Serial1/1
description <>
ip address 10.0.10.2 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/4
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/5
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/6
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/7
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map Local
network 10.0.10.0 0.0.0.3 area 0
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.2 remote-as 64513
neighbor 10.0.1.2 description <>
neighbor 10.0.1.2 ebgp-multihop 2
neighbor 10.0.1.2 update-source Loopback0
neighbor 10.0.1.2 soft-reconfiguration inbound
neighbor 10.0.1.2 send-label
no auto-summary
!
ip classless
ip route 10.0.1.2 255.255.255.255 10.0.20.1
!
!
no ip http server
no ip http secure-server
!
!
route-map Local permit 10
match interface Loopback0
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
dial-peer cor custom
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
PE22#
**********************************************************************
OUTPUT
**********************************************************************
CE1A#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.40.1 0 FULL/ - 00:00:38 172.16.1.2 Serial1/0
CE1A#sh ip rou
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
O E2 172.16.200.0/24 [110/20] via 172.16.1.2, 00:05:27, Serial1/0
O E2 172.16.40.1/32 [110/20] via 172.16.1.2, 00:06:07, Serial1/0
C 172.16.30.1/32 is directly connected, Loopback0
C 172.16.1.0/30 is directly connected, Serial1/0
C 172.16.100.0/24 is directly connected, FastEthernet0/0
CE1A#ping 172.16.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/124/196 ms
CE1A#tra
CE1A#traceroute 172.16.40.1
Type escape sequence to abort.
Tracing the route to 172.16.40.1
1 172.16.1.2 176 msec 256 msec *
CE1A#
CE2A#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
172.16.30.1 0 FULL/ - 00:00:36 172.16.1.1 Serial1/0
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 5 subnets, 3 masks
C 172.16.200.0/24 is directly connected, FastEthernet0/0
C 172.16.40.1/32 is directly connected, Loopback0
O E2 172.16.30.1/32 [110/20] via 172.16.1.1, 00:06:40, Serial1/0
C 172.16.1.0/30 is directly connected, Serial1/0
O E2 172.16.100.0/24 [110/20] via 172.16.1.1, 00:06:40, Serial1/0
CE2A#ping 172.16.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/196/276 ms
CE2A#tra
CE2A#traceroute 172.16.30.1
Type escape sequence to abort.
Tracing the route to 172.16.30.1
1 172.16.1.1 544 msec 252 msec *
CE2A#
PE11#show mpls l2transport vc detail
Local interface: Se1/0 up, line protocol up, HDLC up
Destination address: 10.0.1.2, VC ID: 101, VC status: up
Output interface: Se1/1, imposed label stack {19}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:27:33, last status change time: 00:13:21
Signaling protocol: LDP, peer 10.0.1.2:0 up
Targeted Hello: 10.0.1.1(LDP Id) -> 10.0.1.2
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 16, remote 19
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 235, send 225
byte totals: receive 18549, send 20641
packet drops: receive 0, seq error 0, send 0
PE11#
PE12#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
MPLS PW 10.0.2.2:200 10.0.1.1 101 UP
MPLS PW 10.0.1.1:101 10.0.2.2 200 UP
PE12#sho
PE12#show vfi
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
VFI name: CEA, type: point-to-point
Neighbors connected via pseudowires:
Peer Address VC ID
10.0.1.1 101
10.0.2.2 200
PE12#show mpls l2transport vc det
PE12#show mpls l2transport vc detail
Local interface: MPLS PW 10.0.2.2:200 up
Destination address: 10.0.1.1, VC ID: 101, VC status: up
Output interface: Se1/0, imposed label stack {16}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:26:19, last status change time: 00:12:30
Signaling protocol: LDP, peer 10.0.1.1:0 up
Targeted Hello: 10.0.1.2(LDP Id) -> 10.0.1.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 19, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: <>
Sequencing: receive transparent, send transparent
Sequencing resync disabled
VC statistics:
packet totals: receive 240, send 500
byte totals: receive 21882, send 45220
packet drops: receive 0, seq error 0, send 0
Local interface: MPLS PW 10.0.1.1:101 up
Destination address: 10.0.2.2, VC ID: 200, VC status: up
Output interface: Se1/1, imposed label stack {19}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:26:21, last status change time: 00:14:32
Signaling protocol: LDP, peer 10.0.2.2:0 up
Targeted Hello: 10.0.1.2(LDP Id) -> 10.0.2.2
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 18, remote 19
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive transparent, send transparent
Sequencing resync disabled
VC statistics:
packet totals: receive 250, send 480
byte totals: receive 22610, send 43764
packet drops: receive 0, seq error 0, send 0
PE21#show mpls l2transport vc detail
Local interface: Se1/1 up, line protocol up, HDLC up
Destination address: 10.0.2.2, VC ID: 101, VC status: up
Output interface: Se1/0, imposed label stack {17}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:28:27, last status change time: 00:15:41
Signaling protocol: LDP, peer 10.0.2.2:0 up
Targeted Hello: 10.0.2.1(LDP Id) -> 10.0.2.2
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 16, remote 17
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 255, send 265
byte totals: receive 20063, send 23851
packet drops: receive 0, seq error 0, send 0
PE21#
PE12#
PE22#show mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
MPLS PW 10.0.2.1:101 10.0.1.2 200 UP
MPLS PW 10.0.1.2:200 10.0.2.1 101 UP
PE22#show vfi
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
VFI name: CEA, type: point-to-point
Neighbors connected via pseudowires:
Peer Address VC ID
10.0.2.1 101
10.0.1.2 200
PE22#show mpls l2transport vc detail
Local interface: MPLS PW 10.0.2.1:101 up
Destination address: 10.0.1.2, VC ID: 200, VC status: up
Output interface: Se1/0, imposed label stack {18}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:26:16, last status change time: 00:17:03
Signaling protocol: LDP, peer 10.0.1.2:0 up
Targeted Hello: 10.0.2.2(LDP Id) -> 10.0.1.2
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 19, remote 18
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive transparent, send transparent
Sequencing resync disabled
VC statistics:
packet totals: receive 273, send 566
byte totals: receive 24596, send 50608
packet drops: receive 0, seq error 0, send 0
Local interface: MPLS PW 10.0.1.2:200 up
Destination address: 10.0.2.1, VC ID: 101, VC status: up
Output interface: Se1/1, imposed label stack {16}
Preferred path: not configured
Default path: active
Next hop: point2point
Create time: 00:26:18, last status change time: 00:15:05
Signaling protocol: LDP, peer 10.0.2.1:0 up
Targeted Hello: 10.0.2.2(LDP Id) -> 10.0.2.1
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 17, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: <>
Sequencing: receive transparent, send transparent
Sequencing resync disabled
VC statistics:
packet totals: receive 283, send 546
byte totals: receive 25304, send 49192
packet drops: receive 0, seq error 0, send 0
PE22#

No comments:

Post a Comment