Tuesday, July 14, 2009

Implementing Multicast Auto-RP in MPLS L3 VPN LAB


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
PIM Sparse-Dense Mode Used in Provider Backbone and CE Domain with Auto-RP
IGMP-Group used for CE2A 224.2.2.2
Default MDT used 239.1.1.1
MDT Data used 238.2.2.0/24 for CE1A and 239.2.2.0/24 for CE2A with Threshold 1

***********************************************************************************

CE1A#sh running-config
ip cef
!
ip multicast-routing
!
interface Loopback0
description <>
ip address 172.16.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.15.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.1 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.15.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback0
!

CE1A#


PE1#show running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
mdt default 239.1.1.1
mdt data 238.2.2.0 0.0.0.255 threshold 1
!
ip multicast-routing
ip multicast-routing vrf CEA
!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.1.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
interface FastEthernet1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0002.8888.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!
ip pim bidir-enable
ip pim vrf CEA send-rp-announce Loopback1 scope 100
ip pim vrf CEA send-rp-discovery Loopback1 scope 100
!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.4.1
!
mpls ldp router-id Loopback0
!

PE1#








P1#show running-config
ip cef
!
ip multicast-routing
!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
!
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!
ip pim bidir-enable
ip pim send-rp-announce Loopback0 scope 100
ip pim send-rp-discovery Loopback0 scope 100
!
mpls ldp router-id Loopback0
!
P1#



PE2#show running-config

ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
mdt default 239.1.1.1
mdt data 239.2.2.0 0.0.0.255 threshold 1
!
ip multicast-routing
ip multicast-routing vrf CEA
!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
ip pim sparse-dense-mode
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.4.1 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet1/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
ip pim sparse-dense-mode
duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
ip pim sparse-dense-mode
duplex auto
speed auto
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.12 0.0.0.3 area 0
!
router isis
net 49.0002.5555.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!
ip pim bidir-enable
!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.2.1
!
mpls ldp router-id Loopback0

PE2#









CE2A#show running-config
ip cef
!
ip multicast-routing
!
!
interface Loopback0
description <>
ip address 172.16.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.25.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.14 255.255.255.252
ip pim sparse-dense-mode
ip igmp join-group 224.2.2.2
duplex auto
speed auto
!

router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.25.0 0.0.0.255 area 2
network 192.168.1.12 0.0.0.3 area 0
!

ip pim bidir-enable
!
route-map Only_Local permit 10
match interface Loopback0
!

CE2A#











OUTPUT VERIFICATION

PE1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.6 FastEthernet1/1 00:27:23/00:01:32 v2 1 / DR B S

PE1#show ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.1 FastEthernet1/0 00:14:04/00:01:30 v2 1 / B S
10.0.4.1 Tunnel0 00:08:53/00:01:42 v2 1 / DR B S
PE1#






PE2#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.9 FastEthernet1/0 00:24:50/00:01:33 v2 1 / B S


PE2#show ip pim vrf CEA neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.14 FastEthernet1/1 00:17:09/00:01:20 v2 1 / DR B S
10.0.2.1 Tunnel0 00:09:31/00:01:34 v2 1 / B S
PE2#







CE1A#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.2 FastEthernet1/0 00:15:24/00:01:37 v2 1 / DR B S
CE1A#




CE2A#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
192.168.1.13 FastEthernet1/0 00:18:09/00:01:22 v2 1 / B S
CE2A#



CE1A#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.39), 00:32:51/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:32:51/00:00:00

(10.0.1.1, 224.0.1.39), 00:00:46/00:02:14, flags:
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:00:46/00:00:00

(*, 224.0.1.40), 00:36:50/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:36:50/00:00:00

(10.0.1.1, 224.0.1.40), 00:01:04/00:01:56, flags: L
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:01:04/00:00:00

CE1A#



CE2A#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:19:52/00:02:53, RP 10.0.1.1, flags: SJPCL
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.13
Outgoing interface list: Null

(*, 224.0.1.39), 00:12:13/stopped, RP 0.0.0.0, flags: D
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:12:13/00:00:00

(10.0.1.1, 224.0.1.39), 00:00:13/00:02:47, flags: PT
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.13
Outgoing interface list: Null

(*, 224.0.1.40), 00:19:52/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:19:52/00:00:00

(10.0.1.1, 224.0.1.40), 00:11:25/00:02:27, flags: PLTX
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.13
Outgoing interface list: Null

CE2A#


CE2A#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
224.2.2.2 FastEthernet1/0 00:20:07 00:02:38 192.168.1.14
224.0.1.40 FastEthernet1/0 00:20:08 00:02:33 192.168.1.14
CE2A#
CE1A#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
224.0.1.39 FastEthernet1/0 00:33:47 00:02:20 192.168.1.2
224.0.1.40 FastEthernet1/0 00:37:46 00:02:15 192.168.1.1
CE1A#


CE2A#show ip igmp groups detail

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: FastEthernet1/0
Group: 224.2.2.2
Flags: L U
Uptime: 00:20:41
Group mode: EXCLUDE (Expires: 00:02:04)
Last reporter: 192.168.1.14
Source list is empty

Interface: FastEthernet1/0
Group: 224.0.1.40
Flags: L U
Uptime: 00:20:42
Group mode: EXCLUDE (Expires: 00:02:58)
Last reporter: 192.168.1.14
Source list is empty
CE2A#

CE1A#show ip igmp groups detail

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: FastEthernet1/0
Group: 224.0.1.39
Flags:
Uptime: 00:34:26
Group mode: EXCLUDE (Expires: 00:02:41)
Last reporter: 192.168.1.2
Source list is empty

Interface: FastEthernet1/0
Group: 224.0.1.40
Flags: L U
Uptime: 00:38:25
Group mode: EXCLUDE (Expires: 00:02:40)
Last reporter: 192.168.1.1
Source list is empty
CE1A#


PE1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:31:34/stopped, RP 10.0.3.1, flags: SJCFZ
Incoming interface: FastEthernet1/1, RPF nbr 192.168.1.6
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:31:34/00:02:04

(10.0.2.1, 239.1.1.1), 00:31:26/00:03:25, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/1, Forward/Sparse-Dense, 00:14:02/00:02:48

(10.0.4.1, 239.1.1.1), 00:13:36/00:02:46, flags: JTZ
Incoming interface: FastEthernet1/1, RPF nbr 192.168.1.6
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:13:36/00:01:31

(*, 224.0.1.39), 00:32:25/00:02:50, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/1, Forward/Sparse-Dense, 00:32:25/00:00:00

(*, 224.0.1.40), 00:36:41/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:36:41/00:00:00
FastEthernet1/1, Forward/Sparse-Dense, 00:32:28/00:00:00

(10.0.3.1, 224.0.1.40), 00:32:26/00:02:59, flags: LT
Incoming interface: FastEthernet1/1, RPF nbr 192.168.1.6
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:32:26/00:00:00


PE1#show ip mroute vrf CEA
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:12:52/00:02:33, RP 10.0.1.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:12:52/00:02:33

(*, 224.0.1.39), 00:34:46/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:34:46/00:00:00
FastEthernet1/0, Forward/Sparse-Dense, 00:34:46/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:31:41/00:00:00

(10.0.1.1, 224.0.1.39), 00:34:46/00:02:18, flags: LT
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:34:46/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:31:41/00:00:00

(*, 224.0.1.40), 00:36:46/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:36:46/00:00:00
FastEthernet1/0, Forward/Sparse-Dense, 00:36:43/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:13:43/00:00:00

(10.0.1.1, 224.0.1.40), 00:34:47/00:02:57, flags: LT
Incoming interface: Loopback1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:34:47/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:13:43/00:00:00

PE1#

PE2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:14:33/stopped, RP 10.0.3.1, flags: SJCFZ
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.9
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:14:33/00:00:35

(10.0.2.1, 239.1.1.1), 00:14:12/00:02:54, flags: JTZ
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.9
Outgoing interface list:
MVRF CEA, Forward/Sparse-Dense, 00:14:12/00:00:56

(10.0.4.1, 239.1.1.1), 00:14:26/00:03:14, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:14:26/00:02:57

(*, 224.0.1.39), 00:29:26/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/0, Forward/Sparse-Dense, 00:29:26/00:00:00

(10.0.3.1, 224.0.1.39), 00:02:09/00:00:51, flags: PTX
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.9
Outgoing interface list: Null

(*, 224.0.1.40), 00:29:35/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:29:35/00:00:00
FastEthernet1/0, Forward/Sparse-Dense, 00:29:30/00:00:00

(10.0.3.1, 224.0.1.40), 00:29:17/00:02:42, flags: LT
Incoming interface: FastEthernet1/0, RPF nbr 192.168.1.9
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 00:29:17/00:00:00

PE2#show ip mroute vrf CEA
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:21:45/00:02:59, RP 10.0.1.1, flags: SJC
Incoming interface: Tunnel0, RPF nbr 10.0.2.1
Outgoing interface list:
FastEthernet1/1, Forward/Sparse-Dense, 00:21:45/00:03:06

(*, 224.0.1.39), 00:14:07/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/1, Forward/Sparse-Dense, 00:14:07/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:14:07/00:00:00

(10.0.1.1, 224.0.1.39), 00:02:07/00:00:57, flags: PTX
Incoming interface: Tunnel0, RPF nbr 10.0.2.1
Outgoing interface list:
FastEthernet1/1, Prune/Sparse-Dense, 00:02:06/00:00:54

(*, 224.0.1.40), 00:29:38/stopped, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet1/1, Forward/Sparse-Dense, 00:21:46/00:00:00
Loopback1, Forward/Sparse-Dense, 00:29:39/00:00:00
Tunnel0, Forward/Sparse-Dense, 00:14:08/00:00:00

(10.0.1.1, 224.0.1.40), 00:14:18/00:02:36, flags: LT
Incoming interface: Tunnel0, RPF nbr 10.0.2.1
Outgoing interface list:
Loopback1, Forward/Sparse-Dense, 00:14:18/00:00:00
FastEthernet1/1, Forward/Sparse-Dense, 00:14:18/00:00:00

PE2#



PE1#show ip pim mdt bgp
Peer (Route Distinguisher + IPv4) Next Hop
MDT group 239.1.1.1
2:64513:1:10.0.4.1 10.0.4.1
PE1#



PE2#show ip pim mdt
MDT Group Interface Source VRF
* 239.1.1.1 Tunnel0 Loopback0 CEA
PE2#show ip pim mdt bg
PE2#show ip pim mdt bgp
Peer (Route Distinguisher + IPv4) Next Hop
MDT group 239.1.1.1
2:64513:1:10.0.2.1 10.0.2.1
PE2#
PE1#show ip pim mdt
MDT Group Interface Source VRF
* 239.1.1.1 Tunnel0 Loopback0 CEA
PE1#


PE1#show ip mroute vrf CEA 224.2.2.2
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:19:11/00:03:11, RP 10.0.1.1, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:19:11/00:03:11

PE1#

CE1A#ping 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 192.168.1.14, 692 ms
CE1A#

CE1A#ping 172.16.25.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 392/488/612 ms


CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O IA 172.16.25.0 [110/3] via 192.168.1.2, 00:15:07, FastEthernet1/0
C 172.16.15.0 is directly connected, Loopback1
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/2] via 192.168.1.2, 00:21:57, FastEthernet1/0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.4.1 [110/1] via 192.168.1.2, 00:21:57, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
O IA 192.168.1.12 [110/2] via 192.168.1.2, 00:15:07, FastEthernet1/0
C 192.168.1.0 is directly connected, FastEthernet1/0
CE1A#
CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.25.0 is directly connected, Loopback1
O IA 172.16.15.0 [110/3] via 192.168.1.13, 00:15:47, FastEthernet1/0
O E2 172.16.1.0 [110/2] via 192.168.1.13, 00:22:21, FastEthernet1/0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.1.1 [110/1] via 192.168.1.13, 00:22:21, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/0
O IA 192.168.1.0 [110/2] via 192.168.1.13, 00:15:47, FastEthernet1/0
CE2A#ping 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 192.168.1.14, 20 ms
CE2A#

Implementing OSPF Domain-ID in MPLS L3 VPN LAB


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
OSPF Domain-id ::
Before”PE1 -172.16.10.1 & PE2 – 172.16.20.1”
After “PE1 -172.16.10.1 PE2- 172.16.10.1”
***********************************************************************************

CE1A#sh running-config
ip cef
!
interface Loopback0
description <>
ip address 172.16.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.15.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.15.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback0
!

CE1A#







PE1#show running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.5.1 255.255.255.255
!

!
interface FastEthernet1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0002.8888.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!

!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.4.1
!
mpls ldp router-id Loopback0
!

PE1#








P1#show running-config
ip cef
!

!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
!
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.255
ip router isis

isis circuit-type level-1
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!
mpls ldp router-id Loopback0
!
P1#



PE2#show running-config

ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!

mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis

isis circuit-type level-1
!
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.1.1 255.255.255.255
!

!
interface FastEthernet1/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252

duplex auto
speed auto
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.12 0.0.0.3 area 0
!
router isis
net 49.0002.5555.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!

!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.2.1
!
mpls ldp router-id Loopback0

PE2#













CE2A#show running-config
ip cef
!
interface Loopback0
description <>
ip address 172.16.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.25.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.14 255.255.255.252

ip igmp join-group 224.2.2.2
duplex auto
speed auto
!

router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.25.0 0.0.0.255 area 2
network 192.168.1.12 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback0
!

CE2A#












OUTPUT VERIFICATION
BEFORE WHEN DOMAIN_ID DIFFERENT FOR PE1 & PE2
CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O E2 172.16.25.0 [110/2] via 192.168.1.2, 00:01:04, FastEthernet1/0
C 172.16.15.0 is directly connected, Loopback1
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/2] via 192.168.1.2, 00:01:04, FastEthernet1/0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.4.1 [110/1] via 192.168.1.2, 00:01:04, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
O E2 192.168.1.12 [110/1] via 192.168.1.2, 00:01:04, FastEthernet1/0
C 192.168.1.0 is directly connected, FastEthernet1/0
CE1A#ping 172.16.25.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/343/484 ms
CE1A#


CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.25.0 is directly connected, Loopback1
O E2 172.16.15.0 [110/2] via 192.168.1.13, 00:00:09, FastEthernet1/0
O E2 172.16.1.0 [110/2] via 192.168.1.13, 00:00:09, FastEthernet1/0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.1.1 [110/1] via 192.168.1.13, 00:00:09, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/0
O E2 192.168.1.0 [110/1] via 192.168.1.13, 00:00:09, FastEthernet1/0
CE2A#ping 172.16.15.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.15.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 440/527/616 ms
CE2A#

PE2#show ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O IA 172.16.25.0 [110/2] via 192.168.1.14, 00:09:36, FastEthernet1/1
B 172.16.15.0 [200/2] via 10.0.2.1, 00:02:11
B 172.16.1.0 [200/2] via 10.0.2.1, 00:02:11
O E2 172.16.2.0 [110/20] via 192.168.1.14, 00:09:16, FastEthernet1/1
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.1.1 [200/0] via 10.0.2.1, 00:02:11
C 10.0.4.1 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/1
B 192.168.1.0 [200/0] via 10.0.2.1, 00:02:11
PE2#

PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#

PE1#show ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
B 172.16.25.0 [200/2] via 10.0.4.1, 00:00:52
O IA 172.16.15.0 [110/2] via 192.168.1.1, 00:05:38, FastEthernet1/0
O E2 172.16.1.0 [110/20] via 192.168.1.1, 00:05:38, FastEthernet1/0
B 172.16.2.0 [200/2] via 10.0.4.1, 00:00:52
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.1.1 is directly connected, Loopback1
B 10.0.4.1 [200/0] via 10.0.4.1, 00:00:52
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.12 [200/0] via 10.0.4.1, 00:00:52
C 192.168.1.0 is directly connected, FastEthernet1/0
PE1#

PE1#show ip bgp vpnv4 vrf CEA 172.16.25.0
BGP routing table entry for 64513:1:172.16.25.0/24, version 21
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Not advertised to any peer
Local
10.0.4.1 (metric 30) from 10.0.4.1 (10.0.4.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC1014020200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.4.1:768
mpls labels in/out nolabel/20
PE1#













AFTER WHEN DOMAIN ID SAME FOR PE1 & PE2



CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O IA 172.16.25.0 [110/3] via 192.168.1.2, 00:00:13, FastEthernet1/0
C 172.16.15.0 is directly connected, Loopback1
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/2] via 192.168.1.2, 00:07:03, FastEthernet1/0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.4.1 [110/1] via 192.168.1.2, 00:07:03, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
O IA 192.168.1.12 [110/2] via 192.168.1.2, 00:00:13, FastEthernet1/0
C 192.168.1.0 is directly connected, FastEthernet1/0
CE1A#

PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#

PE1#show ip bgp vpnv4 vrf CEA 172.16.25.0
BGP routing table entry for 64513:1:172.16.25.0/24, version 23
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.4.1 (metric 30) from 10.0.4.1 (10.0.4.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.4.1:768
mpls labels in/out nolabel/20
PE1#

CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.25.0 is directly connected, Loopback1
O IA 172.16.15.0 [110/3] via 192.168.1.13, 00:00:58, FastEthernet1/0
O E2 172.16.1.0 [110/2] via 192.168.1.13, 00:07:32, FastEthernet1/0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.1.1 [110/1] via 192.168.1.13, 00:07:33, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/0
O IA 192.168.1.0 [110/2] via 192.168.1.13, 00:00:58, FastEthernet1/0
CE2A#

Monday, July 13, 2009

Implementing IPv6 Over MPLS 6PE with PE-CE BGP LAB


Configuration Guidelines::
PE-CE Routing Used "BGP"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
MP_iBGP established between PE1 & PE2 over Loopback Interface 10
********************************************************************************
CE1A#show running-config
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
router bgp 64514
bgp router-id 172.16.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
network 2001:810:FFFF:1::/64
no synchronization
exit-address-family
!

CE1A#











PE1#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description <>
!
address-family ipv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 send-label
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 send-community extended
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
route-map Local permit 10
match interface FastEthernet1/0 FastEthernet1/1
!
mpls ldp router-id Loopback0
!

PE1#



P1#show running-config
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
mpls ip
mpls label protocol ldp
mpls router-id loopback0
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1

!
interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.2 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
duplex full
speed 100
ip address 192.168.1.5 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!


P1#

PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description <>
!
address-family ipv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.1.1 send-label
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 send-community extended
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
!
route-map Local permit 10
match interface FastEthernet1/1
!
mpls ldp router-id Loopback0
!

PE2#




CE2A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!
router bgp 64514
bgp router-id 172.16.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
neighbor 2001:1210:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
network 2001:1210:FFFF:1::/64
no synchronization
exit-address-family
!

CE2A#



OUTPUT VERIFICATION

CE2A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:EFF:FEC8:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C800:EFF:FEC8:0
FEC0:0:0:4::1


CE2A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:1210:FFFF:1::1, FastEthernet1/0
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C804:9FF:FED4:1D, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:5::1/128 [20/0]
via FE80::C804:9FF:FED4:1D, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0

CE2A#show bgp ipv6 unicast summary
BGP router identifier 172.16.1.2, local AS number 64514
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1540 total bytes of memory
BGP activity 5/1 prefixes, 6/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:1210:FFFF:1::1
4 64513 21 19 5 0 0 00:14:39 4
CE2A#show bgp ipv6 unicast lab
CE2A#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:1210:FFFF:1::1
nolabel/nolabel
2001:1210:FFFF:1::/64
2001:1210:FFFF:1::1
nolabel/nolabel
:: nolabel/nolabel
FEC0:0:0:4::1/128
2001:1210:FFFF:1::1
nolabel/nolabel
FEC0:0:0:5::1/128
2001:1210:FFFF:1::1
nolabel/nolabel







CE2A#ping fec0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/5/8 ms
CE2A#
CE2A#ping fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 328/454/756 ms
CE2A#
PE2#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FastEthernet1/1 [up/up]
FE80::C804:9FF:FED4:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]
PE2#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:810:FFFF:1::/64 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
B FEC0:0:0:5::1/128 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
L FF00::/8 [0/0]
via ::, Null0
PE2#show bgp ipv6 unicast summary
BGP router identifier 10.0.3.1, local AS number 64513
BGP table version is 9, main routing table version 9
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP using 1572 total bytes of memory
BGP activity 6/2 prefixes, 7/2 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 36 40 9 0 0 00:07:16 2
2001:1210:FFFF:1::2
4 64514 21 31 9 0 0 00:16:18 1
PE2#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
::FFFF:10.0.1.1 nolabel/20
2001:1210:FFFF:1::/64
2001:1210:FFFF:1::2
20/nolabel
:: 20/nolabel
FEC0:0:0:4::1/128
2001:1210:FFFF:1::2
19/nolabel
FEC0:0:0:5::1/128
::FFFF:10.0.1.1 nolabel/19

PE2#

P1#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
unassigned
FastEthernet1/1 [up/up]
Loopback0 [up/up]






P1#show ipv6 route
IPv6 Routing Table - 0 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
P1#

PE1#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:BFF:FE44:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]
PE1#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
B 2001:1210:FFFF:1::/64 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
B FEC0:0:0:4::1/128 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0
PE1#show bgp ipv6 unicast summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 9, main routing table version 9
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP using 1572 total bytes of memory
BGP activity 6/2 prefixes, 7/2 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.3.1 4 64513 37 41 9 0 0 00:08:26 2
2001:810:FFFF:1::2
4 64514 19 22 9 0 0 00:14:38 1
PE1#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:810:FFFF:1::2
20/nolabel
:: 20/nolabel
2001:1210:FFFF:1::/64
::FFFF:10.0.3.1 nolabel/20
FEC0:0:0:4::1/128
::FFFF:10.0.3.1 nolabel/19
FEC0:0:0:5::1/128
2001:810:FFFF:1::2
19/nolabel

PE1#

CE1A#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:BFF:FE44:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C801:BFF:FE44:0
FEC0:0:0:5::1
CE1A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:810:FFFF:1::1, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C802:BFF:FE44:1C, FastEthernet1/0
B FEC0:0:0:4::1/128 [20/0]
via FE80::C802:BFF:FE44:1C, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE1A#show bgp ipv6 unicast summary
BGP router identifier 172.16.1.1, local AS number 64514
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1540 total bytes of memory
BGP activity 5/1 prefixes, 6/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:810:FFFF:1::1
4 64513 22 20 5 0 0 00:15:19 4
CE1A#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:810:FFFF:1::1
nolabel/nolabel
:: nolabel/nolabel
2001:1210:FFFF:1::/64
2001:810:FFFF:1::1
nolabel/nolabel
FEC0:0:0:4::1/128
2001:810:FFFF:1::1
nolabel/nolabel
FEC0:0:0:5::1/128
2001:810:FFFF:1::1
nolabel/nolabel

CE1A#ping fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/8 ms
CE1A#ping fec0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 248/322/424 ms
CE1A#

Implementing IPv6 Over MPLS 6PE with Static PE-C LAB


Configuration Guidelines::
PE-CE Routing Used "Static"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
MP_iBGP established between PE1 & PE2 over Loopback Interface 10
********************************************************************************

CE1A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:810:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!

CE1A#



PE1#show running-config

ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 send-label
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
ipv6 route FEC0:0:0:5::1/128 FastEthernet1/0 2001:810:FFFF:1::2
!
!
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
route-map Local permit 10
match interface FastEthernet1/0
!
mpls ldp router-id Loopback0
!
PE1#



P1#sh running-config
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
mpls ip
mpls label protocol ldp
mpls router-id loopback0
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1

!
interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.2 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
duplex full
speed 100
ip address 192.168.1.5 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!

P1#




PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
!
address-family ipv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.1.1 send-label
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
ipv6 route FEC0:0:0:4::1/128 FastEthernet1/1 2001:1210:FFFF:1::2
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
!
route-map Local permit 10
match interface FastEthernet1/1
!
!
!
mpls ldp router-id Loopback0
!
PE2#




CE2A#show running-config

ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:1210:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!
CE2A#




OUTPUT VERIFICATION

CE1A#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:BFF:FE44:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C801:BFF:FE44:0
FEC0:0:0:5::1

CE1A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:810:FFFF:1::1, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0

CE1A#ping FEC0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
!...!
Success rate is 40 percent (2/5), round-trip min/avg/max = 296/324/352 ms
CE1A#


PE1#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:BFF:FE44:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]

PE1#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
B 2001:1210:FFFF:1::/64 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
B FEC0:0:0:4::1/128 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0





PE1#show bgp ipv6 unicast summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
4 path entries using 304 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1316 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.3.1 4 64513 16 16 5 0 0 00:11:27 2


PE1#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
:: 20/nolabel
2001:1210:FFFF:1::/64
::FFFF:10.0.3.1 nolabel/20
FEC0:0:0:4::1/128
::FFFF:10.0.3.1 nolabel/19
FEC0:0:0:5::1/128
2001:810:FFFF:1::2
19/nolabel


PE1#show ipv6 cef
::/127
Receive
2001:810:FFFF:1::1/128
Receive
2001:810:FFFF:1::2/128
attached to FastEthernet1/0
2001:810:FFFF:1::/64
attached to FastEthernet1/0
tag information
local tag: aggregate(20)
2001:1210:FFFF:1::/64
nexthop ::FFFF:10.0.3.1
fast tag rewrite with Fa1/1, 192.168.1.2, tags imposed: {17 20}
FE80::/10
Receive
FEC0:0:0:4::1/128
nexthop ::FFFF:10.0.3.1
fast tag rewrite with Fa1/1, 192.168.1.2, tags imposed: {17 19}
FEC0:0:0:5::1/128
nexthop 2001:810:FFFF:1::2 FastEthernet1/0
tag information
local tag: 19
FF00::/8
Receive
PE1#

P1#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C803:9FF:FED4:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]
P1#sho
P1#show ipv
P1#show ipv6 rou
P1#show ipv6 route
IPv6 Routing Table - 3 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0
P1#





PE2#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FastEthernet1/1 [up/up]
FE80::C804:9FF:FED4:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]


PE2#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:810:FFFF:1::/64 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
B FEC0:0:0:5::1/128 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
L FF00::/8 [0/0]
via ::, Null0



PE2#show bgp ipv6 unicast summary
BGP router identifier 10.0.3.1, local AS number 64513
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
4 path entries using 304 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1316 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 18 18 5 0 0 00:13:54 2


PE2#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
::FFFF:10.0.1.1 nolabel/20
2001:1210:FFFF:1::/64
:: 20/nolabel
FEC0:0:0:4::1/128
2001:1210:FFFF:1::2
19/nolabel
FEC0:0:0:5::1/128
::FFFF:10.0.1.1 nolabel/19

PE2#sho
PE2#show ip
PE2#show ipv
PE2#show ipv6 ce
PE2#show ipv6 cef
::/127
Receive
2001:810:FFFF:1::/64
nexthop ::FFFF:10.0.1.1
fast tag rewrite with Fa1/0, 192.168.1.5, tags imposed: {16 20}
2001:1210:FFFF:1::1/128
Receive
2001:1210:FFFF:1::2/128
attached to FastEthernet1/1
2001:1210:FFFF:1::/64
attached to FastEthernet1/1
tag information
local tag: aggregate(20)
FE80::/10
Receive
FEC0:0:0:4::1/128
nexthop 2001:1210:FFFF:1::2 FastEthernet1/1
tag information
local tag: 19
FEC0:0:0:5::1/128
nexthop ::FFFF:10.0.1.1
fast tag rewrite with Fa1/0, 192.168.1.5, tags imposed: {16 19}
FF00::/8
Receive
PE2#


CE2A#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:EFF:FEC8:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C800:EFF:FEC8:0
FEC0:0:0:4::1
CE2A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:1210:FFFF:1::1, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping ipv6 fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
...!.
Success rate is 20 percent (1/5), round-trip min/avg/max = 424/424/424 ms
CE2A#

Implementing IPv6 Tunneling over IPv4 using Manual Tunnel Lab


Configuration Guidelines::
PE-CE Routing Used "Static"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
IPv6 Tunnel established between PE1 & PE2 over Tunnel Interface 10
********************************************************************************

CE1A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:810:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!

CE1A#




PE1#sh running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Tunnel10
description <>
ipv6 address 2001:0DB8:1111:2222::1/64

tunnel source loopback 0

tunnel destination 10.0.3.1

tunnel mode ipv6ip

!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
ip address 192.168.1.1 255.255.255.252
duplex full
speed 100
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Local
!
ipv6 route FEC0:0:0:5::1/128 FastEthernet1/0 2001:810:FFFF:1::2
ipv6 route 2001:1210:FFFF:1::/64 Tunnel 10
ipv6 route FEC0:0:0:4::1/128 Tunnel 10

!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
PE1#




P1#sh running-config
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1

!

interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.2 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
duplex full
speed 100
ip address 192.168.1.5 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!

P1#


PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Tunnel10
description <>
ipv6 address 2001:0DB8:1111:2222::2/64
tunnel source loopback 0

tunnel destination 10.0.1.1

tunnel mode ipv6ip

!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.6 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
redistribute connected route-map Only_Local
!
ipv6 route FEC0:0:0:4::1/128 FastEthernet1/1 2001:1210:FFFF:1::2
ipv6 route 2001:810:FFFF:1::/64 Tunnel 10
ipv6 route FEC0:0:0:5::1/128 Tunnel 10
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
!

PE2#




CE2A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!

ipv6 route ::/0 FastEthernet1/0 2001:1210:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!
CE2A#



OUTPUT VERIFICATION

CE1A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:BFF:FE44:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C801:BFF:FE44:0
FEC0:0:0:5::1




CE1A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via 2001:810:FFFF:1::1, FastEthernet1/0
via ::, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE1A#

CE1A#ping ipv6 FEC0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
.!...
Success rate is 20 percent (1/5), round-trip min/avg/max = 88/88/88 ms
CE1A#


PE1#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:BFF:FE44:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]
Tunnel10 [up/up]
FE80::C802:BFF:FE44:0
2001:DB8:1111:2222::1


PE1#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
C 2001:DB8:1111:2222::/64 [0/0]
via ::, Tunnel10
L 2001:DB8:1111:2222::1/128 [0/0]
via ::, Tunnel10
S 2001:1210:FFFF:1::/64 [1/0]
via ::, Tunnel10
S FEC0:0:0:4::1/128 [1/0]
via ::, Tunnel10
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0


PE1#show interfaces tunnel 10
Tunnel10 is up, line protocol is up
Hardware is Tunnel
Description: <>
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 10.0.1.1 (Loopback0), destination 10.0.3.1
Tunnel protocol/transport IPv6/IP
Tunnel TTL 255
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input 00:02:35, output 00:05:42, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
13 packets input, 1464 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
14 packets output, 1356 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
PE1#

PE1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
i L2 10.0.3.1 [115/20] via 192.168.1.2, FastEthernet1/1
i L2 10.0.2.1 [115/20] via 192.168.1.2, FastEthernet1/1
C 10.0.1.1 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, FastEthernet1/1
i L2 192.168.1.4 [115/20] via 192.168.1.2, FastEthernet1/1
PE1#

P1#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
PE2 L2 Fa1/1 192.168.1.6 UP 7 PE2.01
PE1 L2 Fa1/0 192.168.1.1 UP 28 P1.02




P1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
i L2 10.0.3.1 [115/10] via 192.168.1.6, FastEthernet1/1
C 10.0.2.1 is directly connected, Loopback0
i L2 10.0.1.1 [115/10] via 192.168.1.1, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, FastEthernet1/0
C 192.168.1.4 is directly connected, FastEthernet1/1
P1#





PE2#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FastEthernet1/1 [up/up]
FE80::C804:9FF:FED4:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]
Tunnel10 [up/up]
FE80::C804:9FF:FED4:0
2001:DB8:1111:2222::2


PE2#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S 2001:810:FFFF:1::/64 [1/0]
via ::, Tunnel10
C 2001:DB8:1111:2222::/64 [0/0]
via ::, Tunnel10
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
S FEC0:0:0:5::1/128 [1/0]
via ::, Tunnel10
L FF00::/8 [0/0]
via ::, Null0


PE2#show interfaces tunnel 10
Tunnel10 is up, line protocol is up
Hardware is Tunnel
Description: <>
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 10.0.3.1 (Loopback0), destination 10.0.1.1
Tunnel protocol/transport IPv6/IP
Tunnel TTL 255
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input 00:07:53, output 00:07:52, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4 packets input, 404 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
13 packets output, 1284 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets



PE2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
C 10.0.3.1 is directly connected, Loopback0
i L2 10.0.2.1 [115/20] via 192.168.1.5, FastEthernet1/0
i L2 10.0.1.1 [115/20] via 192.168.1.5, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
i L2 192.168.1.0 [115/20] via 192.168.1.5, FastEthernet1/0
C 192.168.1.4 is directly connected, FastEthernet1/0
PE2#



CE2A#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:EFF:FEC8:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C800:EFF:FEC8:0
FEC0:0:0:4::1
CE2A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via 2001:1210:FFFF:1::1, FastEthernet1/0
via ::, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#
CE2A#ping ipv6 FEC0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
...!.
Success rate is 20 percent (1/5), round-trip min/avg/max = 420/420/420 ms
CE2A#