Saturday, July 4, 2009

Implementing OSPF Sham Link in MPLS L3 VPN LAB






















Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:1"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
Backdoor Link used between CE1A & CE2A in same area.

***********************************************************************

CE1A#sh run
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.168.15.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
!
interface Serial0/1
description <>
ip address 172.168.22.2 255.255.255.252
ip ospf cost 20000
!
router ospf 10
log-adjacency-changes
redistribute connected route-map Only_Local
network 10.0.1.0 0.0.0.255 area 0
network 172.168.22.0 0.0.0.3 area 0
network 172.168.15.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback1 Loopback0

CE1A#











PE1#sh running-config
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:1
route-target import 64513:1
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback101
description <>
ip vrf forwarding CEA
ip address 10.11.12.1 255.255.255.255
!
interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
!
router ospf 10 vrf CEA
domain-id 1.1.1.1
log-adjacency-changes
area 0 sham-link 10.11.12.1 10.11.13.1
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Customer
redistribute static ip
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route 10.0.1.0 255.255.255.0 192.168.1.1
ip route 172.168.15.0 255.255.255.0 192.168.1.1
!
!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.4.0 0.0.0.255
access-list 20 permit 10.0.3.0 0.0.0.255
!
route-map Only_Customer permit 10
match interface Serial0/0
!
PE1#














P#sh running-config
!
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!

P#















PE2#sh running-config
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:1
route-target import 64513:1
!
ip vrf forwarding
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Loopback101
description <>
ip vrf forwarding CEA
ip address 10.11.13.1 255.255.255.255
!

interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
fair-queue 64 256 16
clockrate 2000000
ip rsvp bandwidth 512 512
!
!
router ospf 10 vrf CEA
domain-id 2.2.2.2
log-adjacency-changes
area 0 sham-link 10.11.13.1 10.11.12.1
redistribute bgp 64513 subnets
network 192.168.1.12 0.0.0.3 area 0
!
router isis
net 49.0002.8888.2222.1111.00
redistribute connected route-map Only_Customer
redistribute static ip
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf forwarding
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route 10.0.5.0 255.255.255.0 192.168.1.14
ip route 172.168.25.0 255.255.255.0 192.168.1.14
!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.0 0.0.0.255
access-list 20 permit 10.0.2.0 0.0.0.255
!
route-map Only_Customer permit 10
match interface Serial0/1
!

PE2#


CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.168.25.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
!
interface Serial0/1
description <>
ip address 172.168.22.1 255.255.255.252
ip ospf cost 20000
!

router ospf 10
log-adjacency-changes
redistribute connected route-map Only_Local
network 10.0.5.0 0.0.0.255 area 0
network 172.168.22.0 0.0.0.3 area 0
network 192.168.1.12 0.0.0.3 area 0
network 172.168.25.0 0.0.0.255 area 0
!
route-map Only_Local permit 10
match interface Loopback0 Loopback1
!
CE2A#

OUTPUT VERIFICATION
PE1#sh ip bgp vpnv4 all
BGP table version is 15, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
* i10.0.1.0/24 10.0.4.1 129 100 0 ?
*> 192.168.1.1 65 32768 ?
* i10.0.5.0/24 10.0.4.1 65 100 0 ?
*> 192.168.1.1 129 32768 ?
* i172.168.22.0/30 10.0.4.1 128 100 0 ?
*> 192.168.1.1 128 32768 ?
* i172.168.15.0/24 10.0.4.1 129 100 0 ?
*> 192.168.1.1 65 32768 ?
* i192.168.1.0/30 10.0.4.1 192 100 0 ?
*> 0.0.0.0 0 32768 ?
* i192.168.1.12/30 10.0.4.1 0 100 0 ?
*> 192.168.1.1 192 32768 ?
* i172.168.25.0 10.0.4.1 65 100 0 ?
*> 192.168.1.1 129 32768 ?

PE1#

PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

64.0.0.0/24 is subnetted, 1 subnets
O 172.168.15.0 [110/65] via 192.168.1.1, 00:02:47, Serial0/0
20.0.0.0/30 is subnetted, 1 subnets
O 172.168.22.0 [110/128] via 192.168.1.1, 00:02:47, Serial0/0
O 172.168.25.0/24 [110/129] via 192.168.1.1, 00:02:47, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
O 10.0.1.0 [110/65] via 192.168.1.1, 00:02:47, Serial0/0
O 10.0.5.0 [110/129] via 192.168.1.1, 00:02:47, Serial0/0
192.168.1.0/30 is subnetted, 2 subnets
O 192.168.1.12 [110/192] via 192.168.1.1, 00:02:47, Serial0/0
C 192.168.1.0 is directly connected, Serial0/0
PE1#

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

64.0.0.0/24 is subnetted, 1 subnets
C 172.168.15.0 is directly connected, Loopback1
20.0.0.0/30 is subnetted, 1 subnets
C 172.168.22.0 is directly connected, Serial0/1
O 172.168.25.0/24 [110/65] via 172.168.22.1, 00:02:15, Serial0/1
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
O 10.0.5.0 [110/65] via 172.168.22.1, 00:02:15, Serial0/1
192.168.1.0/30 is subnetted, 2 subnets
O 192.168.1.12 [110/128] via 172.168.22.1, 00:02:15, Serial0/1
C 192.168.1.0 is directly connected, Serial0/0
CE1A#

PE1#sh ip route vrf CEA 172.168.25.1
Routing entry for 172.168.25.0/24
Known via "ospf 10", distance 110, metric 129, type intra area
Redistributing via bgp 64513
Advertised by bgp 64513
Last update from 192.168.1.1 on Serial0/0, 00:03:57 ago
Routing Descriptor Blocks:
* 192.168.1.1, from 172.168.25.1, 00:03:57 ago, via Serial0/0
Route metric is 129, traffic share count is 1

PE1#

CE1A#traceroute 172.168.25.1

Type escape sequence to abort.
Tracing the route to 172.168.25.1

1 172.168.22.1 36 msec 20 msec *
CE1A#

CE2A#traceroute 172.168.15.1

Type escape sequence to abort.
Tracing the route to 172.168.15.1

1 172.168.22.2 32 msec 44 msec *
CE2A#

PE1#traceroute vrf CEA 172.168.25.1

Type escape sequence to abort.
Tracing the route to 172.168.25.1

1 192.168.1.1 108 msec 76 msec 56 msec
2 172.168.22.1 160 msec 128 msec *
PE1#


CE1A# traceroute 172.168.25.1

Type escape sequence to abort.
Tracing the route to 172.168.25.1

1 192.168.1.2 24 msec 48 msec 48 msec
2 192.168.1.14 276 msec 100 msec *
CE1A#

CE2A# traceroute 172.168.15.1

Type escape sequence to abort.
Tracing the route to 172.168.15.1

1 192.168.1.13 196 msec 252 msec 336 msec
2 192.168.1.1 260 msec 108 msec *
CE2A#
PE1# traceroute vrf CEA 172.168.25.1

Type escape sequence to abort.
Tracing the route to 172.168.25.1

1 192.168.1.6 [MPLS: Labels 17/33 Exp 0] 356 msec 300 msec 200 msec
2 192.168.1.13 [MPLS: Label 33 Exp 0] 380 msec 52 msec 52 msec
3 192.168.1.14 68 msec 172 msec *
PE1#

No comments:

Post a Comment