Saturday, July 4, 2009

Implementing L2 IPVPN using L2TPv3 LAB



Configuration Guidelines::
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.

Pseudo Wire-Class used CEA
*******************************************************************************
CE1A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.25.1 255.255.255.0
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
encapsulation ppp
!
router eigrp 10
network 10.0.1.0 0.0.0.255
network 192.168.1.0 0.0.0.3
network 172.168.25.0
no auto-summary
CE1A#
PE1# sh running-config
ip cef
!
pseudowire-class CEA
encapsulation l2tpv3
ip local interface Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!

interface Serial0/0
description <<>>
no ip address
encapsulation ppp
clockrate 2000000
no cdp enable
xconnect 10.0.4.1 1001 encapsulation l2tpv3 pw-class CEA
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!

router isis
net 49.0001.1111.2222.3333.00
!
PE1#



P# sh running-config
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!
ip classless
!
P#











PE2#sh running-config
pseudowire-class CEA
encapsulation l2tpv3
ip local interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <>
no ip address
encapsulation ppp
clockrate 2000000
no cdp enable
xconnect 10.0.2.1 1001 encapsulation l2tpv3 pw-class CEA
!
router isis
net 49.0002.8888.2222.1111.00
!
PE2#


CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.15.1 255.255.255.0
!
!
interface Serial0/0
description <>
ip address 192.168.1.2 255.255.255.252
encapsulation ppp
!
router eigrp 10
network 10.0.5.0 0.0.0.255
network 172.168.15.0 0.0.0.255
network 192.168.1.0
auto-summary
no eigrp log-neighbor-changes

CE2A#

OUTPUT VERIFICATION

CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.168.0.0/16 is a summary, 00:04:20, Null0
C 172.168.15.0/24 is directly connected, Loopback1
D 172.168.25.0/24 [90/2297856] via 192.168.1.1, 00:04:35, Serial0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:04:33, Null0
D 10.0.1.0/24 [90/2297856] via 192.168.1.1, 00:04:35, Serial0/0
C 10.0.5.0/24 is directly connected, Loopback0
192.168.1.0/24 is variably subnetted, 3 subnets, 3 masks
C 192.168.1.1/32 is directly connected, Serial0/0
D 192.168.1.0/24 is a summary, 00:04:33, Null0
C 192.168.1.0/30 is directly connected, Serial0/0
CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/121/208 ms
CE2A#

PE2#show l2tun session packets

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
54745 37129 15763 229 206 12831 13618

%No active PPTP tunnels
PE2#show l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
54745 37129 15763 1001, Se0/1 est 00:13:43 2

%No active PPTP tunnels
PE2#
PE1#show l2tun session

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
37129 54745 28003 1001, Se0/0 est 00:14:02 3

%No active PPTP tunnels
PE1#show l2tun session pa
PE1#show l2tun session packets

%No active L2F tunnels

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
37129 54745 28003 213 237 13956 13231

%No active PPTP tunnels
PE1#

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

D 172.168.0.0.0/16 [90/2297856] via 192.168.1.2, 00:05:24, Serial0/0
C 172.168.25.0/24 is directly connected, Loopback1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 [90/2297856] via 192.168.1.2, 00:05:36, Serial0/0
C 10.0.1.0/24 is directly connected, Loopback0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/30 is directly connected, Serial0/0
C 192.168.1.2/32 is directly connected, Serial0/0
CE1A#ping 10.0.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/126/284 ms
CE1A#

No comments:

Post a Comment