Sunday, July 5, 2009

Implementing MPLS L3 VPN with Different PE-CE Routing Protocol RIP & EIGRP LAB




Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "RIP" for CE1A & PE1 & "EIGRP" for CE2A & PE2
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
*********************************************************************************


CE1A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.15.1 255.255.255.0
!
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 172.168.15.0
no auto-summary
!
CE1A#



PE1#sh running-config

ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 10
network 192.168.1.0
no auto-summary
version 2
exit-address-family
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute rip
no auto-summary
no synchronization
exit-address-family
!
!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.4.0 0.0.0.255
access-list 20 permit 10.0.3.0 0.0.0.255
!
route-map Only_Customer permit 10
match interface Serial0/0
!
PE1#










P#sh running-config
ip cef
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!
P#


PE2#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
clockrate 2000000
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 1544 100 255 200 1500
network 192.168.1.12 0.0.0.3
no auto-summary
autonomous-system 10
exit-address-family
!
router isis
net 49.0002.8888.2222.1111.00
!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute eigrp 10
no auto-summary
no synchronization
exit-address-family
!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.0 0.0.0.255
access-list 20 permit 10.0.2.0 0.0.0.255
!
route-map Only_Customer permit 10
match interface Serial0/1
!

PE2#








CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.25.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
router eigrp 10
network 10.0.5.0 0.0.0.255
network 192.168.1.0
network 172.168.25.0
no auto-summary
no eigrp log-neighbor-changes
!

CE2A#

CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

D EX 172.168.15.0/24 [170/2195456] via 192.168.1.13, 00:06:14, Serial0/0
C 172.168.25.0/24 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.0.1.0 [170/2195456] via 192.168.1.13, 00:06:14, Serial0/0
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, Serial0/0
D EX 192.168.1.0 [170/2195456] via 192.168.1.13, 00:06:14, Serial0/0





CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 92/163/228 ms
CE2A#


CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.168.15.0/24 is directly connected, Loopback1
R 172.168.25.0/24 [120/10] via 192.168.1.2, 00:00:13, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
R 10.0.5.0 [120/10] via 192.168.1.2, 00:00:13, Serial0/0
192.168.1.0/30 is subnetted, 2 subnets
R 192.168.1.12 [120/10] via 192.168.1.2, 00:00:13, Serial0/0
C 192.168.1.0 is directly connected, Serial0/0


CE1A#ping 10.0.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/69/116 ms
CE1A#

No comments:

Post a Comment