Saturday, July 4, 2009

Implementing Internet Access through Dedicated VPN in MPLS L3 VPN LAB


Configuration Guidelines::

For AS 64513
VRF Used "Internet"
RD Used "64513:1"
RT Used "64513:100" For Normal Traffic
RT Used "64513:101" For Internet Traffic
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
EBGP between PE2 and Internet Router

**********************************************************************
CEA#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.168.46.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
!
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 10.0.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.3 area 0
!
!
route-map Only_Local permit 10
match interface Loopback1

CEA#


PE1#sh running-config
!
ip vrf Internet
description <>
rd 64513:1
route-target export 64513:101
route-target export 64513:100
route-target import 64513:100
route-target import 64513:101
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip vrf forwarding Internet
ip address 192.168.1.2 255.255.255.252
clockrate 2000000

!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.0
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router ospf 10 vrf Internet
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
default-information originate
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf Internet
redistribute ospf 10 vrf Internet match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route vrf Internet 0.0.0.0 0.0.0.0 192.168.1.9
!

PE1#





P#sh running-config
!
ip vrf Internet
rd 64513:1
route-target export 64513:101
route-target import 64513:101
route-target import 64513:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <>
ip vrf forwarding Internet
ip address 192.168.1.9 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!
router ospf 10 vrf Internet
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.8 0.0.0.3 area 0
default-information originate
!
router isis
net 49.0002.3333.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 default-originate
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 next-hop-self
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf Internet
redistribute ospf 10 vrf Internet match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!

P#



64513_Internet_Router#sh running-config
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback2
description <>
ip address 172.168.54.102 255.255.255.255
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
!

!
interface Serial0/1
description <>
ip address 172.168.54.98 255.255.255.252
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
redistribute static subnets
redistribute bgp 64513 subnets
network 10.0.4.0 0.0.0.255 area 0
network 192.168.1.8 0.0.0.3 area 0
default-information originate
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
network 10.0.1.0 mask 255.255.255.0
network 10.0.4.0 mask 255.255.255.0
network 192.168.1.0 mask 255.255.255.252
network 192.168.1.8 mask 255.255.255.252
aggregate-address 10.0.0.0 255.255.248.0
aggregate-address 192.168.1.0 255.255.255.128
neighbor 172.168.54.97 remote-as 64514
neighbor 172.168.54.97 description <>
neighbor 172.168.54.97 ebgp-multihop 2
neighbor 172.168.54.97 update-source Loopback2
neighbor 172.168.54.97 soft-reconfiguration inbound
no auto-summary
!
ip route 172.168.54.101 255.255.255.255 172.168.54.97
!
route-map Only_Local permit 10
match interface Serial0/1
!
end

64513_Internet_Router#


64514_Internet_Router#sh running-config
!
interface Loopback0
ip address 172.168.54.101 255.255.255.255
!
interface Loopback1
description <<64514_traffic_emulator>>
ip address 172.168.212.1 255.255.255.0
!
interface Loopback2
description <<64514_traffic_emulator>>
ip address 172.168.72.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 172.168.54.97 255.255.255.252
!

router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.168.72.0 mask 255.255.255.0
network 172.168.212.0 mask 255.255.255.0
neighbor 172.168.54.102 remote-as 64513
neighbor 172.168.54.102 description <<64513_internet_link>>
neighbor 172.168.54.102 ebgp-multihop 2
neighbor 172.168.54.102 update-source Loopback0
neighbor 172.168.54.102 default-originate
neighbor 172.168.54.102 soft-reconfiguration inbound
neighbor 172.168.54.102 route-map Customer out
no auto-summary
!
ip route 172.168.54.102 255.255.255.255 172.168.54.98
!
ip prefix-list Customer seq 10 permit 172.168.212.0/24
ip prefix-list Customer seq 20 deny 0.0.0.0/0 le 32
!
route-map Customer permit 10
match ip address prefix-list Customer
!
end

64514_Internet_Router#

No comments:

Post a Comment