Friday, July 3, 2009

Implementing AToM for Like Circuts using Frame-Relay



Configuration Guidelines::


IGP Used “ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.

ATM Backbone in Provider Network

End User Connected with to CE1A Router using Microsoft Loopback Adapter through the Cloud.

Psuedowire Class used CEA

VCID used 1001

IGP for CE Domain is EIGRP

Frame-Relay Link DLCI Mode used between PE-CE



CE1A#sh running-config
hostname CE1A
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface Serial0/0
description <>
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/0.100 point-to-point
ip address 192.168.1.1 255.255.255.252
frame-relay interface-dlci 101
!
interface FastEthernet0/1
description <>
ip address 172.168.1.1 255.255.255.0
!
router eigrp 10
redistribute connected route-map Only_Local
network 192.168.1.0 0.0.0.3
no auto-summary
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet0/1
!
CE1A#
PE1#sh running-config
hostname PE1
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
frame-relay switching
!
pseudowire-class CEA
encapsulation mpls
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 101 switched
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface ATM3/0
description <>
no ip address
no snmp trap link-status
no atm ilmi-keepalive
!
interface ATM3/0.10 mpls
ip address 192.168.1.5 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
!
connect FR_AToM_CE1A_CE Serial1/0 101 l2transport
xconnect 10.0.4.1 1001 encapsulation mpls
!
mpls ldp router-id Loopback0
!

PE1#







P#sh running-config
hostname P
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.6 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface ATM2/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM2/0.20 mpls
ip address 192.168.1.9 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.2222.1111.3333.00
!
mpls ldp router-id Loopback0
!

P#











PE2#sh running-config
Building configuration...

hostname PE2
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
frame-relay switching
!
pseudowire-class CEA
encapsulation mpls
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 201 switched
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface ATM3/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM3/0.20 mpls
ip address 192.168.1.10 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.2222.1111.00
!
connect FR_CE1A_CE2A Serial1/0 201 l2transport
xconnect 10.0.2.1 1001 encapsulation mpls
!
mpls ldp router-id Loopback0
!

PE2#




CE2A#sh running-config
hostname CE2A
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Serial0/0
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/0.100 point-to-point
description <>
ip address 192.168.1.2 255.255.255.252
frame-relay interface-dlci 201
router eigrp 10
redistribute connected route-map Only_Local
network 192.168.1.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
route-map Only_Local permit 10
match interface Loopback0
!

CE2A#



OUTPUT VERIFICATION
CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
D EX 172.168.1.0 [170/2172416] via 192.168.1.1, 00:03:01, Serial0/0.100
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.0.1.0 [170/2297856] via 192.168.1.1, 00:04:01, Serial0/0.100
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0.100

CE2A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq Type
(sec) (ms) Cnt Num
0 192.168.1.1 Se0/0.100 12 00:04:07 1265 5000 0 3




CE2A#ping 172.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/142/296 ms
CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/125/196 ms
CE2A#
PE2#show mpls l2transport vc 1001 detail
Local interface: Se1/0 up, line protocol up, FR DLCI 201 up
Destination address: 10.0.2.1, VC ID: 1001, VC status: up
Next hop: point2point
Output interface: AT3/0.20, imposed label stack {1/37 16}
Create time: 00:14:18, last status change time: 00:06:56
Signaling protocol: LDP, peer 10.0.2.1:0 up
MPLS VC labels: local 20, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: <>
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 141, send 105
byte totals: receive 14190, send 11174
packet drops: receive 0, seq error 0, send 0
PE1#show mpls l2transport vc 1001 detail
Local interface: Se1/0 up, line protocol up, FR DLCI 101 up
Destination address: 10.0.4.1, VC ID: 1001, VC status: up
Next hop: point2point
Output interface: AT3/0.10, imposed label stack {1/34 20}
Create time: 00:21:35, last status change time: 00:07:18
Signaling protocol: LDP, peer 10.0.4.1:0 up
MPLS VC labels: local 16, remote 20
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: <>
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 110, send 145
byte totals: receive 11804, send 14470
packet drops: receive 0, seq error 0, send 0

PE1#











CE1A#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
C 172.168.1.0 is directly connected, FastEthernet0/1
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
D EX 10.0.5.0 [170/2297856] via 192.168.1.2, 00:05:23, Serial0/0.100
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0.100











CE1A#ping
Protocol [ip]:
Target IP address: 10.0.5.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.168.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 208/386/508 ms
CE1A#

No comments:

Post a Comment