Saturday, July 4, 2009

Implementing_QoS_in_Unfiform_Mode_for Frame-Mode MPLS_L3_VPN


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF" & "EIGRP"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
C1A Customer A Site 1 Core Router
CE1A Customer A Site 1 CPE Router
C2A Customer A Site 2 Core Router
CE2A Customer A Site 2 CPE Router
Implementing QoS on IPPREC 5 (Expedited Forwarding) for Fa0/0 & lo0 and IPPREC 3 for fa0/1 & lo1 (Assured Forwarding) by Emulating Traffic through the respective CE Routers on Fa0/0 & Fa0/1 Interface
***************************************************************************************


CE1A#sh running-config
!
interface Loopback0
description <>
ip address 172.16.11.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.15.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
description <<>>
ip address 172.16.2.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description <<>>
ip address 172.16.2.5 255.255.255.252
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.2.0 0.0.0.3 area 1
network 172.16.2.4 0.0.0.3 area 1
!
route-map Only_Local permit 10
match interface Loopback0 Loopback1
!


CE1A#












C1A#sh running-config
!
class-map match-all ipprec5
match access-group 10
class-map match-all ipprec3
match access-group 20
!
!
policy-map ipprecout
class ipprec5
set ip precedence 5
class ipprec3
set ip precedence 3
bandwidth percent 30
random-detect
!
interface Loopback0
description <>
ip address 172.16.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
description <<>>
ip address 172.16.2.2 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
interface FastEthernet0/1
description <<>>
ip address 172.16.2.6 255.255.255.252
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.2.0 0.0.0.3 area 1
network 172.16.2.4 0.0.0.3 area 1
network 192.168.1.0 0.0.0.3 area 0
!
access-list 10 permit 172.16.2.0 0.0.0.3
access-list 10 permit 172.16.11.0 0.0.0.255
access-list 20 permit 172.16.2.4 0.0.0.3
access-list 20 permit 172.16.15.0 0.0.0.255
!
!
route-map Only_Local permit 10
match interface Loopback0
!

C1A#



PE1#sh running-config
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
mpls ldp explicit-null
!
class-map match-all qosgroup30
match qos-group 30
class-map match-all qosgroup50
match qos-group 50
class-map match-all qosgroup3
match qos-group 3
class-map match-all qosgroup5
match qos-group 5
class-map match-any ipprec5
match access-group 10
class-map match-any ipprec3
match access-group 20
class-map match-all mplsexp5
match mpls experimental topmost 5
class-map match-all mplsexp3
match mpls experimental topmost 3
!
!
policy-map ipprecin
class ipprec5
set qos-group 5
set ip precedence 5
class ipprec3
set qos-group 3
set ip precedence 3
policy-map mpls_ipprecout
class qosgroup50
set ip precedence 5
class qosgroup30
set ip precedence 3
policy-map mpls_ipprecin
class mplsexp5
set qos-group 50
class mplsexp3
set qos-group 30
policy-map ipprecout
class qosgroup5
set mpls experimental topmost 5
class qosgroup3
set mpls experimental topmost 3
!
!
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
!
interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
service-policy input ipprecin
service-policy output mpls_ipprecout
clockrate 2000000
!
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
service-policy input mpls_ipprecin
service-policy output ipprecout
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!
access-list 10 permit 172.16.2.0 0.0.0.3
access-list 10 permit 172.16.11.0 0.0.0.255
access-list 20 permit 172.16.2.4 0.0.0.3
access-list 20 permit 172.16.15.0 0.0.0.255
!

PE1#



PE2#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
mpls ldp explicit-null
!
class-map match-all qosgroup30
match qos-group 30
class-map match-all qosgroup50
match qos-group 50
class-map match-all qosgroup3
match qos-group 3
class-map match-all qosgroup5
match qos-group 5
class-map match-any ipprec5
match access-group 10
class-map match-any ipprec3
match access-group 20
class-map match-all mplsexp5
match mpls experimental topmost 5
class-map match-all mplsexp3
match mpls experimental topmost 3
!
!
policy-map ipprecin
class ipprec5
set qos-group 5
set ip precedence 5
class ipprec3
set qos-group 3
set ip precedence 3
policy-map mpls_ipprecout
class qosgroup50
set ip precedence 5
class qosgroup30
set ip precedence 3
policy-map mpls_ipprecin
class mplsexp5
set qos-group 50
class mplsexp3
set qos-group 30
policy-map ipprecout
class qosgroup5
set mpls experimental topmost 5
class qosgroup3
set mpls experimental topmost 3
!
!
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
service-policy input mpls_ipprecin
service-policy output ipprecout
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
service-policy input ipprecin
service-policy output mpls_ipprecout
clockrate 2000000
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 2 100 255 100 1500
network 192.168.1.12 0.0.0.3
no auto-summary
autonomous-system 100
exit-address-family
!
router isis
net 49.0002.8888.2222.1111.00
redistribute connected route-map Only_Customer
redistribute static ip
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute eigrp 100
no auto-summary
no synchronization
exit-address-family
!
PE2#








P#sh running-config
ip cef
!
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
class-map match-all qosgroup3
match qos-group 3
class-map match-all qosgroup5
match qos-group 5
class-map match-all mplsexp5
match mpls experimental topmost 5
class-map match-all mplsexp3
match mpls experimental topmost 3
!
!
policy-map ipprecin
class mplsexp5
set qos-group 5
class mplsexp3
set qos-group 3
policy-map ipprecout
class qosgroup5
set mpls experimental topmost 5
class qosgroup3
set mpls experimental topmost 3
!
!
!
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!

interface Serial0/0
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
service-policy input ipprecin
service-policy output ipprecout
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
service-policy input ipprecin
service-policy output ipprecout
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!

P#



C2A#sh running-config
!
class-map match-all ipprec5
match access-group 10
class-map match-all ipprec3
match access-group 20
!
!
policy-map ipprecout
class ipprec5
set ip precedence 5
class ipprec3
set ip precedence 3
bandwidth percent 30
random-detect
!
!
!
interface Loopback0
description <>
ip address 172.16.4.1 255.255.255.0
!
interface FastEthernet0/0
description <<>>
ip address 172.16.3.2 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
description <<>>
ip address 192.168.1.14 255.255.255.252
!
interface FastEthernet0/1
description <<>>
ip address 172.16.3.6 255.255.255.252
duplex auto
speed auto
!

router eigrp 100
redistribute connected route-map Only_Local
network 172.16.3.0 0.0.0.3
network 172.16.3.4 0.0.0.3
network 192.168.1.12 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
access-list 10 permit 172.16.3.0 0.0.0.3
access-list 10 permit 172.16.14.0 0.0.0.255
access-list 20 permit 172.16.3.4 0.0.0.3
access-list 20 permit 172.16.16.0 0.0.0.255
!
route-map Only_Local permit 10
match interface Loopback0

C2A#


CE2A#sh running-config
!
interface Loopback0
description <>
ip address 172.16.14.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.16.16.1 255.255.255.0
!
interface FastEthernet0/0
description <<>>
ip address 172.16.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
description <<>>
ip address 172.16.3.5 255.255.255.252
duplex auto
speed auto
!
router eigrp 100
redistribute connected route-map Only_Local
network 172.16.3.0 0.0.0.3
network 172.16.3.4 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
route-map Only_Local permit 10
match interface Loopback0 Loopback1
!


OUTPUT VERIFICATION

CE2A#ping 172.16.11.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/251/428 ms





CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
C 172.16.16.0/24 is directly connected, Loopback1
C 172.16.14.0/24 is directly connected, Loopback0
D EX 172.16.15.0/24
[170/1280540160] via 172.16.3.2, 00:00:33, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:00:33, FastEthernet0/1
D EX 172.16.11.0/24
[170/1280540160] via 172.16.3.2, 00:00:33, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:00:33, FastEthernet0/1
D EX 172.16.4.0/24 [170/156160] via 172.16.3.2, 00:05:25, FastEthernet0/0
[170/156160] via 172.16.3.6, 00:05:25, FastEthernet0/1
D EX 172.16.2.4/30
[170/1280540160] via 172.16.3.2, 00:00:35, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:00:35, FastEthernet0/1
C 172.16.3.4/30 is directly connected, FastEthernet0/1
D EX 172.16.1.0/24
[170/1280540160] via 172.16.3.2, 00:00:34, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:00:34, FastEthernet0/1
D EX 172.16.2.0/30
[170/1280540160] via 172.16.3.2, 00:00:36, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:00:36, FastEthernet0/1
C 172.16.3.0/30 is directly connected, FastEthernet0/0
192.168.1.0/30 is subnetted, 2 subnets
D 192.168.1.12 [90/2172416] via 172.16.3.2, 00:05:25, FastEthernet0/0
[90/2172416] via 172.16.3.6, 00:05:25, FastEthernet0/1
D EX 192.168.1.0 [170/1280540160] via 172.16.3.2, 00:05:25, FastEthernet0/0
[170/1280540160] via 172.16.3.6, 00:05:25, FastEthernet0/1
CE2A#

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/16 is variably subnetted, 10 subnets, 2 masks
O E2 172.16.16.0/24 [110/2300416] via 172.16.2.2, 00:04:59, FastEthernet0/0
[110/2300416] via 172.16.2.6, 00:04:59, FastEthernet0/1
O E2 172.16.14.0/24 [110/2300416] via 172.16.2.2, 00:04:59, FastEthernet0/0
[110/2300416] via 172.16.2.6, 00:04:59, FastEthernet0/1
C 172.16.15.0/24 is directly connected, Loopback1
C 172.16.11.0/24 is directly connected, Loopback0
O E2 172.16.4.0/24 [110/2297856] via 172.16.2.2, 00:04:59, FastEthernet0/0
[110/2297856] via 172.16.2.6, 00:04:59, FastEthernet0/1
C 172.16.2.4/30 is directly connected, FastEthernet0/1
O E2 172.16.3.4/30 [110/2172416] via 172.16.2.2, 00:04:59, FastEthernet0/0
[110/2172416] via 172.16.2.6, 00:04:59, FastEthernet0/1
O E2 172.16.1.0/24 [110/20] via 172.16.2.6, 00:27:34, FastEthernet0/1
[110/20] via 172.16.2.2, 00:27:34, FastEthernet0/0
C 172.16.2.0/30 is directly connected, FastEthernet0/0
O E2 172.16.3.0/30 [110/2172416] via 172.16.2.2, 00:05:00, FastEthernet0/0
[110/2172416] via 172.16.2.6, 00:05:00, FastEthernet0/1
192.168.1.0/30 is subnetted, 2 subnets
O E2 192.168.1.12 [110/1] via 172.16.2.2, 00:05:00, FastEthernet0/0
[110/1] via 172.16.2.6, 00:05:00, FastEthernet0/1
O IA 192.168.1.0 [110/65] via 172.16.2.6, 00:27:34, FastEthernet0/1
[110/65] via 172.16.2.2, 00:27:34, FastEthernet0/0
CE1A# ping 172.16.16.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.16.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 100/160/236 ms
CE1A#








PE1#show policy-map interface s0/0
Serial0/0

Service-policy input: ipprecin

Class-map: ipprec5 (match-any)
11 packets, 1144 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 10
11 packets, 1144 bytes
5 minute rate 0 bps
QoS Set
qos-group 5
Packets marked 11
precedence 5
Packets marked 11

Class-map: ipprec3 (match-any)
9 packets, 936 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 20
9 packets, 936 bytes
5 minute rate 0 bps
QoS Set
qos-group 3
Packets marked 9
precedence 3
Packets marked 9

Class-map: class-default (match-any)
270 packets, 19712 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: mpls_ipprecout

Class-map: qosgroup50 (match-all)
6 packets, 624 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 50
QoS Set
precedence 5
Packets marked 6

Class-map: qosgroup30 (match-all)
4 packets, 416 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 30
QoS Set
precedence 3
Packets marked 4

Class-map: class-default (match-any)
686 packets, 51772 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any



PE1#show policy-map interface s0/1
Serial0/1

Service-policy input: mpls_ipprecin

Class-map: mplsexp5 (match-all)
6 packets, 648 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 50
Packets marked 6

Class-map: mplsexp3 (match-all)
4 packets, 432 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 30
Packets marked 4

Class-map: class-default (match-any)
701 packets, 46021 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: ipprecout

Class-map: qosgroup5 (match-all)
11 packets, 1232 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
QoS Set
mpls experimental topmost 5
Packets marked 11

Class-map: qosgroup3 (match-all)
9 packets, 1008 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
mpls experimental topmost 3
Packets marked 9

Class-map: class-default (match-any)
1384 packets, 482363 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any
PE1#











P#show policy-map interface s0/0
Serial0/0

Service-policy input: ipprecin

Class-map: mplsexp5 (match-all)
6 packets, 672 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 6

Class-map: mplsexp3 (match-all)
4 packets, 448 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 4

Class-map: class-default (match-any)
611 packets, 40328 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: ipprecout

Class-map: qosgroup5 (match-all)
11 packets, 1188 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
QoS Set
mpls experimental topmost 5
Packets marked 11

Class-map: qosgroup3 (match-all)
9 packets, 972 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
mpls experimental topmost 3
Packets marked 9

Class-map: class-default (match-any)
1180 packets, 418164 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any
P#show policy-map interface s0/1
Serial0/1

Service-policy input: ipprecin

Class-map: mplsexp5 (match-all)
11 packets, 1232 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 5
Packets marked 11

Class-map: mplsexp3 (match-all)
9 packets, 1008 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 3
Packets marked 9

Class-map: class-default (match-any)
699 packets, 45671 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: ipprecout

Class-map: qosgroup5 (match-all)
6 packets, 648 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
QoS Set
mpls experimental topmost 5
Packets marked 6

Class-map: qosgroup3 (match-all)
4 packets, 432 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
mpls experimental topmost 3
Packets marked 4

Class-map: class-default (match-any)
1321 packets, 476745 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any
P#


PE2#show policy-map interface s0/0
Serial0/0

Service-policy input: mpls_ipprecin

Class-map: mplsexp5 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 5
QoS Set
qos-group 50
Packets marked 0

Class-map: mplsexp3 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: mpls experimental topmost 3
QoS Set
qos-group 30
Packets marked 0

Class-map: class-default (match-any)
251 packets, 15923 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: ipprecout

Class-map: qosgroup5 (match-all)
3 packets, 336 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 5
QoS Set
mpls experimental topmost 5
Packets marked 3

Class-map: qosgroup3 (match-all)
2 packets, 224 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 3
QoS Set
mpls experimental topmost 3
Packets marked 2

Class-map: class-default (match-any)
1142 packets, 406589 bytes
5 minute offered rate 1000 bps, drop rate 0 bps
Match: any
PE2#show policy-map interface s0/1
Serial0/1

Service-policy input: ipprecin

Class-map: ipprec5 (match-any)
3 packets, 312 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 10
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
qos-group 5
Packets marked 3
precedence 5
Packets marked 0

Class-map: ipprec3 (match-any)
2 packets, 208 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 20
0 packets, 0 bytes
5 minute rate 0 bps
QoS Set
qos-group 3
Packets marked 2
precedence 3
Packets marked 0

Class-map: class-default (match-any)
462 packets, 30751 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

Service-policy output: mpls_ipprecout

Class-map: qosgroup50 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 50
QoS Set
precedence 5
Packets marked 0

Class-map: qosgroup30 (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: qos-group 30
QoS Set
precedence 3
Packets marked 0

Class-map: class-default (match-any)
705 packets, 47073 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
PE2#






P#show mpls ldp bindings
tib entry: 10.0.2.1/32, rev 6
local binding: tag: 16
remote binding: tsr: 10.0.4.1:0, tag: 18
remote binding: tsr: 10.0.2.1:0, tag: exp-null
tib entry: 10.0.3.1/32, rev 2
local binding: tag: imp-null
remote binding: tsr: 10.0.2.1:0, tag: 19
remote binding: tsr: 10.0.4.1:0, tag: 16
tib entry: 10.0.4.1/32, rev 10
local binding: tag: 17
remote binding: tsr: 10.0.2.1:0, tag: 21
remote binding: tsr: 10.0.4.1:0, tag: exp-null
tib entry: 192.168.1.4/30, rev 4
local binding: tag: imp-null
remote binding: tsr: 10.0.4.1:0, tag: 17
remote binding: tsr: 10.0.2.1:0, tag: exp-null
tib entry: 192.168.1.8/30, rev 8
local binding: tag: imp-null
remote binding: tsr: 10.0.2.1:0, tag: 20
remote binding: tsr: 10.0.4.1:0, tag: exp-null
P#






CE2A#traceroute 172.16.1.1

Type escape sequence to abort.
Tracing the route to 172.16.1.1

1 172.16.3.2 4 msec
172.16.3.6 12 msec
172.16.3.2 100 msec
2 192.168.1.13 324 msec 804 msec 400 msec
3 192.168.1.1 444 msec 756 msec 736 msec
CE2A#

No comments:

Post a Comment