Saturday, July 4, 2009

Implementing MPLS Cell-Mode L3 VPN Using EIGRP-RIP PE-CE Routing Protocol














Configuration Guidelines::

IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.

ATM Backbone in Provider Network

End User Connected with to CE1A Router using Microsoft Loopback Adapter through the Cloud.


IGP for CE1A is EIGRP & IGP for CE2A Domain is RIP

PPP Link used between PE-CE

VRF used CEA with rd "64513:1" & rt "64513:100"

CE1A#sh running-config
Building configuration...
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.168.1.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
encapsulation ppp
!
router eigrp 10
redistribute connected route-map Only_Local
network 192.168.1.0 0.0.0.3
no auto-summary
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet0/0
CE1A#

PE1#sh running-config
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
no cdp enable
!
interface ATM2/0
description <>
no ip address
no snmp trap link-status
no atm ilmi-keepalive
!
interface ATM2/0.10 mpls
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 1544 100 255 200 1500
network 192.168.1.0 0.0.0.3
no auto-summary
autonomous-system 10
exit-address-family
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute eigrp 10
no synchronization
exit-address-family
!
mpls ldp router-id Loopback0
!
PE1#

P#sh running-config
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface ATM3/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM3/0.20 mpls
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.2222.1111.3333.00
!
mpls ldp router-id Loopback0
P#

PE2#sh running-config
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
encapsulation ppp
serial restart-delay 0
no cdp enable
!
interface ATM2/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM2/0.20 mpls
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.2222.1111.00
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 4
network 192.168.1.0
no auto-summary
version 2
exit-address-family
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute rip
no synchronization
exit-address-family
!
mpls ldp router-id Loopback0
PE2#


CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
encapsulation ppp
!
router rip
version 2
redistribute connected route-map Only_Local
network 192.168.1.0
no auto-summary
!
!
route-map Only_Local permit 10
match interface Loopback0

CE2A#



OUTPUT VERIFICATION

CE2A#ping 172.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 104/175/236 ms
CE2A#sh ip rou
CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
R 172.168.1.0 [120/4] via 192.168.1.13, 00:00:25, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
R 10.0.1.0 [120/4] via 192.168.1.13, 00:00:25, Serial0/0
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C 192.168.1.13/32 is directly connected, Serial0/0
C 192.168.1.12/30 is directly connected, Serial0/0
R 192.168.1.1/32 [120/4] via 192.168.1.13, 00:00:25, Serial0/0
R 192.168.1.0/30 [120/4] via 192.168.1.13, 00:00:25, Serial0/0
CE2A#

PE2#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
B 172.168.1.0 [200/2172416] via 10.0.2.1, 00:09:12
10.0.0.0/24 is subnetted, 2 subnets
B 10.0.1.0 [200/2297856] via 10.0.2.1, 00:09:12
R 10.0.5.0 [120/1] via 192.168.1.14, 00:00:08, Serial1/0
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
C 192.168.1.12/30 is directly connected, Serial1/0
C 192.168.1.14/32 is directly connected, Serial1/0
B 192.168.1.1/32 [200/0] via 10.0.2.1, 00:09:12
B 192.168.1.0/30 [200/0] via 10.0.2.1, 00:09:12
PE2#sh ip bg
PE2#sh ip bgp v
PE2#sh ip bgp vpnv4 al
PE2#sh ip bgp vpnv4 all
BGP table version is 24, local router ID is 10.0.4.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*>i10.0.1.0/24 10.0.2.1 2297856 100 0 ?
*> 10.0.5.0/24 192.168.1.14 1 32768 ?
*>i172.168.1.0/24 10.0.2.1 2172416 100 0 ?
*>i192.168.1.0/30 10.0.2.1 0 100 0 ?
*>i192.168.1.1/32 10.0.2.1 0 100 0 ?
*> 192.168.1.12/30 0.0.0.0 0 32768 ?
*> 192.168.1.14/32 0.0.0.0 0 32768 ?
PE2#

PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
D EX 172.168.1.0 [170/2172416] via 192.168.1.1, 00:14:32, Serial1/0
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.0.1.0 [170/2297856] via 192.168.1.1, 00:14:32, Serial1/0
B 10.0.5.0 [200/1] via 10.0.4.1, 00:00:32
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
B 192.168.1.12/30 [200/0] via 10.0.4.1, 00:00:32
B 192.168.1.14/32 [200/0] via 10.0.4.1, 00:00:32
C 192.168.1.1/32 is directly connected, Serial1/0
C 192.168.1.0/30 is directly connected, Serial1/0

PE1#sh ip bgp vpnv4 all
BGP table version is 25, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*> 10.0.1.0/24 192.168.1.1 2297856 32768 ?
*>i10.0.5.0/24 10.0.4.1 1 100 0 ?
*> 172.168.1.0/24 192.168.1.1 2172416 32768 ?
*> 192.168.1.0/30 0.0.0.0 0 32768 ?
*> 192.168.1.1/32 0.0.0.0 0 32768 ?
*>i192.168.1.12/30 10.0.4.1 0 100 0 ?
*>i192.168.1.14/32 10.0.4.1 0 100 0 ?
PE1#

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/24 is subnetted, 1 subnets
C 172.168.1.0 is directly connected, FastEthernet0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
D EX 10.0.5.0 [170/2195456] via 192.168.1.2, 00:01:05, Serial0/0
192.168.1.0/24 is variably subnetted, 4 subnets, 2 masks
D EX 192.168.1.12/30 [170/2195456] via 192.168.1.2, 00:01:05, Serial0/0
D EX 192.168.1.14/32 [170/2195456] via 192.168.1.2, 00:01:05, Serial0/0
C 192.168.1.0/30 is directly connected, Serial0/0
C 192.168.1.2/32 is directly connected, Serial0/0
CE1A#ping 10.0.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/200/356 ms
CE1A#

No comments:

Post a Comment