Saturday, July 4, 2009

Implementing Inter-AS VPN using MP-eBGP LAB



Configuration Guidelines::

For AS 64513
VRF Used "CEA" for AS 64513
RD Used "64513:1"
RT Used "64513:1"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE11 & PE12 .Loopbacks in Level 1 and PE21 & PE22 in different area.

For AS 64514
VRF Used "CEA" for AS 64514
RD Used "64514:1"
RT Used "64514:1"
AS Used "64514"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE21 & PE22 .Loopbacks in Level 1 and PE11 & PE12 in different area.

*****************************************************************************


PE1&CE1A#sh running-config
ip cef
!
!
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target export 64514:100
route-target import 64513:100
route-target import 64514:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 172.168.66.1 255.255.255.0
ip ospf network point-to-point
!
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.168.66.0 0.0.0.255 area 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!

PE1&CE1A#





P1#sh running-config
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target export 64514:100
route-target import 64513:100
route-target import 64514:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
no ftp-server write-enable
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 172.168.92.1 255.255.255.0
ip ospf network point-to-point
!
!
interface Serial0/0
description <>
ip address 192.168.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 172.16.1.13 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!

router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64513 subnets
network 172.168.92.0 0.0.0.255 area 0
!
router isis
net 49.0002.2222.3333.1111.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.3.1 remote-as 64514
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 ebgp-multihop 2
neighbor 10.0.3.1 update-source Loopback0
!
address-family ipv4
no neighbor 10.0.1.1 activate
no neighbor 10.0.3.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 next-hop-self
neighbor 10.0.1.1 send-community extended
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!
ip route 10.0.3.0 255.255.255.0 172.16.1.14
!

route-map Only_Local permit 10
match interface Serial0/1
!

P1#



PE2&CE2A#sh running-config
!
ip vrf CEA
description <>
rd 64514:1
route-target export 64514:100
route-target export 64513:100
route-target import 64514:100
route-target import 64513:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 172.168.212.1 255.255.255.0
ip ospf network point-to-point
!

interface Serial0/0
description <>
ip address 172.16.1.2 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.168.212.0 0.0.0.255 area 0
!
router isis
net 49.0001.6666.7777.8888.00
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64514
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!

PE2&CE2A#












P2#sh running-config
!
ip vrf CEA
rd 64514:1
route-target export 64514:100
route-target export 64513:100
route-target import 64514:100
route-target import 64513:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 172.168.82.1 255.255.255.0
ip ospf network point-to-point
!
!
interface Serial0/0
description <>
ip address 172.16.1.14 255.255.255.252
mpls label protocol ldp
tag-switching ip
!
interface Serial0/1
description <>
ip address 172.16.1.1 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute bgp 64514 subnets
network 172.168.82.0 0.0.0.255 area 0
!
router isis
net 49.0002.9999.8888.7777.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64514
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 ebgp-multihop 2
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.4.1 remote-as 64514
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
!
address-family ipv4
no neighbor 10.0.2.1 activate
no neighbor 10.0.4.1 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 next-hop-self
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute ospf 10 vrf CEA
no auto-summary
no synchronization
exit-address-family
!
ip route 10.0.2.0 255.255.255.0 172.16.1.13
!
route-map Only_Local permit 10
match interface Serial0/0
!
P2#

OUTPUT VERIFICATION

PE1&CE1A#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.66.0/24 is subnetted, 1 subnets
C 172.168.66.0 is directly connected, Loopback1
172.168.82.0/24 is subnetted, 1 subnets
B 172.168.82.0 [200/0] via 10.0.2.1, 00:19:51
B 172.168.212.0/24 [200/0] via 10.0.2.1, 01:00:53
172.168.92.0/24 is subnetted, 1 subnets
B 172.168.92.0 [200/0] via 10.0.2.1, 00:05:20
PE1&CE1A#





P1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.66.0/24is subnetted, 1 subnets
B 172.168.66.0 [200/0] via 10.0.1.1, 00:17:19
172.168.82.0/24 is subnetted, 1 subnets
B 172.168.82.0 [20/0] via 10.0.3.1, 00:17:19
B 172.168.212.0/24 [20/0] via 10.0.3.1, 00:17:19
172.168.92.0/24 is subnetted, 1 subnets
C 172.168.92.0 is directly connected, Loopback1
P1#








P2#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.66.0/24is subnetted, 1 subnets
B 172.168.66.0 [20/0] via 10.0.2.1, 00:28:49
172.168.82.0/24 is subnetted, 1 subnets
C 172.168.82.0 is directly connected, Loopback1
B 172.168.212.0/24 [200/0] via 10.0.4.1, 00:28:49
172.168.92.0/24 is subnetted, 1 subnets
B 172.168.92.0 [20/0] via 10.0.2.1, 00:07:03
P2#









PE2&CE2A#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.66.0/24is subnetted, 1 subnets
B 172.168.66.0 [200/0] via 10.0.3.1, 00:59:40
172.168.82.0/24 is subnetted, 1 subnets
B 172.168.82.0 [200/0] via 10.0.3.1, 00:18:54
C 172.168.212.0/24 is directly connected, Loopback1
172.168.92.0/24 is subnetted, 1 subnets
B 172.168.92.0 [200/0] via 10.0.3.1, 00:04:08
PE2&CE2A#

No comments:

Post a Comment