Sunday, July 5, 2009

Implementing MPLS L3 VPN with BGP as PE-CE Rouring Protocol LAB


Configuration Guidelines::


IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.


BGP Routing Protocol used between CE & PE

VRF used CEA with rd "64513:1" & rt "64513:100"
Customer AS 64514 (Local AS Feature used using 64515 on CE2A)

********************************************************************

CE1A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.16.15.1 255.255.255.0
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
router bgp 64514
bgp log-neighbor-changes
network 10.0.1.0 mask 255.255.255.0
network 172.16.15.0 mask 255.255.255.0
neighbor 192.168.1.2 remote-as 64513
neighbor 192.168.1.2 description <>
neighbor 192.168.1.2 allowas-in
neighbor 192.168.1.2 soft-reconfiguration inbound
!

CE1A#


PE1#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.1 remote-as 64514
neighbor 192.168.1.1 description <>
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
ip classless
!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.4.0 0.0.0.255
access-list 20 permit 10.0.3.0 0.0.0.255
route-map Only_Customer permit 10
match interface Serial0/0
!

PE1#



P#sh running-config

ip cef
!
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!

P#





PE2#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
clockrate 2000000
!

router isis
net 49.0002.8888.2222.1111.00
!
router bgp 64513
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.14 remote-as 64514
neighbor 192.168.1.14 description <>
neighbor 192.168.1.14 activate
neighbor 192.168.1.14 as-override
neighbor 192.168.1.14 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.0 0.0.0.255
access-list 20 permit 10.0.2.0 0.0.0.255
route-map Only_Customer permit 10
match interface Serial0/1

PE2#
CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.25.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router bgp 64515
bgp log-neighbor-changes
network 10.0.5.0 mask 255.255.255.0
network 172.168.25.0
neighbor 192.168.1.13 remote-as 64513
neighbor 192.168.1.13 local-as 64514
neighbor 192.168.1.13 description <>
neighbor 192.168.1.13 soft-reconfiguration inbound
!
CE2A#












CE1A#sh ip bgp
BGP table version is 7, local router ID is 201.202.203.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.1.0/24 0.0.0.0 0 32768 i
*> 10.0.5.0/24 192.168.1.2 0 64513 64514 64515 i
*> 192.168.1.0/30 192.168.1.2 0 0 64513 ?
*> 192.168.1.12/30 192.168.1.2 0 64513 ?
*> 172.16.15.0 0.0.0.0 0 32768 i
*> 172.168.25.0 192.168.1.2 0 64513 64514 64515 i
CE1A#ping 10.0.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/101/168 ms
CE1A#




CE2A#sh ip bgp
BGP table version is 15, local router ID is 210.211.212.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.1.0/24 192.168.1.13 0 64514 64513 64513 i
*> 10.0.5.0/24 0.0.0.0 0 32768 i
*> 192.168.1.0/30 192.168.1.13 0 64514 64513 ?
*> 192.168.1.12/30 192.168.1.13 0 0 64514 64513 ?
*> 172.16.15.0 192.168.1.13 0 64514 64513 64513 i
*> 172.168.25.0 0.0.0.0 0 32768 i
CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/84/164 ms
CE2A#

No comments:

Post a Comment