Tuesday, July 14, 2009

Implementing OSPF Domain-ID in MPLS L3 VPN LAB


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
OSPF Domain-id ::
Before”PE1 -172.16.10.1 & PE2 – 172.16.20.1”
After “PE1 -172.16.10.1 PE2- 172.16.10.1”
***********************************************************************************

CE1A#sh running-config
ip cef
!
interface Loopback0
description <>
ip address 172.16.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.15.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.15.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback0
!

CE1A#







PE1#show running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.5.1 255.255.255.255
!

!
interface FastEthernet1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252

duplex auto
speed auto
!
interface FastEthernet1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0002.8888.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!

!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.4.1
!
mpls ldp router-id Loopback0
!

PE1#








P1#show running-config
ip cef
!

!
mpls label protocol ldp
no mpls ip propagate-ttl forwarded
!
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.255
ip router isis

isis circuit-type level-1
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!
mpls ldp router-id Loopback0
!
P1#



PE2#show running-config

ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!

mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls ldp explicit-null for 10 to 20
!
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis

isis circuit-type level-1
!
!
interface Loopback1
description <>
ip vrf forwarding CEA
ip address 10.0.1.1 255.255.255.255
!

!
interface FastEthernet1/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis

duplex auto
speed auto
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252

duplex auto
speed auto
!
router ospf 10 vrf CEA
domain-id 172.16.10.1
log-adjacency-changes
redistribute bgp 64513 subnets
network 192.168.1.12 0.0.0.3 area 0
!
router isis
net 49.0002.5555.2222.1111.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
no synchronization
exit-address-family
!

!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.1
access-list 20 permit 10.0.2.1
!
mpls ldp router-id Loopback0

PE2#













CE2A#show running-config
ip cef
!
interface Loopback0
description <>
ip address 172.16.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.16.25.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet1/0
description <<>>
ip address 192.168.1.14 255.255.255.252

ip igmp join-group 224.2.2.2
duplex auto
speed auto
!

router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.16.25.0 0.0.0.255 area 2
network 192.168.1.12 0.0.0.3 area 0
!
route-map Only_Local permit 10
match interface Loopback0
!

CE2A#












OUTPUT VERIFICATION
BEFORE WHEN DOMAIN_ID DIFFERENT FOR PE1 & PE2
CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O E2 172.16.25.0 [110/2] via 192.168.1.2, 00:01:04, FastEthernet1/0
C 172.16.15.0 is directly connected, Loopback1
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/2] via 192.168.1.2, 00:01:04, FastEthernet1/0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.4.1 [110/1] via 192.168.1.2, 00:01:04, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
O E2 192.168.1.12 [110/1] via 192.168.1.2, 00:01:04, FastEthernet1/0
C 192.168.1.0 is directly connected, FastEthernet1/0
CE1A#ping 172.16.25.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.25.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 224/343/484 ms
CE1A#


CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.25.0 is directly connected, Loopback1
O E2 172.16.15.0 [110/2] via 192.168.1.13, 00:00:09, FastEthernet1/0
O E2 172.16.1.0 [110/2] via 192.168.1.13, 00:00:09, FastEthernet1/0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.1.1 [110/1] via 192.168.1.13, 00:00:09, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/0
O E2 192.168.1.0 [110/1] via 192.168.1.13, 00:00:09, FastEthernet1/0
CE2A#ping 172.16.15.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.15.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 440/527/616 ms
CE2A#

PE2#show ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O IA 172.16.25.0 [110/2] via 192.168.1.14, 00:09:36, FastEthernet1/1
B 172.16.15.0 [200/2] via 10.0.2.1, 00:02:11
B 172.16.1.0 [200/2] via 10.0.2.1, 00:02:11
O E2 172.16.2.0 [110/20] via 192.168.1.14, 00:09:16, FastEthernet1/1
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.1.1 [200/0] via 10.0.2.1, 00:02:11
C 10.0.4.1 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/1
B 192.168.1.0 [200/0] via 10.0.2.1, 00:02:11
PE2#

PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#

PE1#show ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
B 172.16.25.0 [200/2] via 10.0.4.1, 00:00:52
O IA 172.16.15.0 [110/2] via 192.168.1.1, 00:05:38, FastEthernet1/0
O E2 172.16.1.0 [110/20] via 192.168.1.1, 00:05:38, FastEthernet1/0
B 172.16.2.0 [200/2] via 10.0.4.1, 00:00:52
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.1.1 is directly connected, Loopback1
B 10.0.4.1 [200/0] via 10.0.4.1, 00:00:52
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.12 [200/0] via 10.0.4.1, 00:00:52
C 192.168.1.0 is directly connected, FastEthernet1/0
PE1#

PE1#show ip bgp vpnv4 vrf CEA 172.16.25.0
BGP routing table entry for 64513:1:172.16.25.0/24, version 21
Paths: (1 available, best #1, table CEA)
Flag: 0x820
Not advertised to any peer
Local
10.0.4.1 (metric 30) from 10.0.4.1 (10.0.4.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC1014020200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.4.1:768
mpls labels in/out nolabel/20
PE1#













AFTER WHEN DOMAIN ID SAME FOR PE1 & PE2



CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
O IA 172.16.25.0 [110/3] via 192.168.1.2, 00:00:13, FastEthernet1/0
C 172.16.15.0 is directly connected, Loopback1
C 172.16.1.0 is directly connected, Loopback0
O E2 172.16.2.0 [110/2] via 192.168.1.2, 00:07:03, FastEthernet1/0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.4.1 [110/1] via 192.168.1.2, 00:07:03, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
O IA 192.168.1.12 [110/2] via 192.168.1.2, 00:00:13, FastEthernet1/0
C 192.168.1.0 is directly connected, FastEthernet1/0
CE1A#

PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#show ip bgp vpnv4 vrf CEA 172.16.15.0
BGP routing table entry for 64513:1:172.16.15.0/24, version 19
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.2.1 (metric 30) from 10.0.2.1 (10.0.2.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.1.1:768
mpls labels in/out nolabel/20
PE2#

PE1#show ip bgp vpnv4 vrf CEA 172.16.25.0
BGP routing table entry for 64513:1:172.16.25.0/24, version 23
Paths: (1 available, best #1, table CEA)
Not advertised to any peer
Local
10.0.4.1 (metric 30) from 10.0.4.1 (10.0.4.1)
Origin incomplete, metric 2, localpref 100, valid, internal, best
Extended Community: RT:64513:100 OSPF DOMAIN ID:0x0005:0xAC100A010200
OSPF RT:0.0.0.0:3:0 OSPF ROUTER ID:10.0.4.1:768
mpls labels in/out nolabel/20
PE1#

CE2A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.25.0 is directly connected, Loopback1
O IA 172.16.15.0 [110/3] via 192.168.1.13, 00:00:58, FastEthernet1/0
O E2 172.16.1.0 [110/2] via 192.168.1.13, 00:07:32, FastEthernet1/0
C 172.16.2.0 is directly connected, Loopback0
10.0.0.0/32 is subnetted, 1 subnets
O E2 10.0.1.1 [110/1] via 192.168.1.13, 00:07:33, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, FastEthernet1/0
O IA 192.168.1.0 [110/2] via 192.168.1.13, 00:00:58, FastEthernet1/0
CE2A#

No comments:

Post a Comment