Saturday, July 4, 2009

Implementing Overlapping MPLS L3 VPN with PE-CE Routing Protcol BGP LAB





Configuration Guidelines::


IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.


BGP Routing Protocol used between CE & PE

VRF used CEA with rd "64513:1" & rt "64513:100"

VRF used CEB for Loopback 1 on PE2 with rd "64513:2" & rt "64513:200"


***********************************************************************

CE1A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Loopback1
description <>
ip address 172.168.15.1 255.255.255.0
ip ospf network point-to-point
!
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
router bgp 6395
bgp log-neighbor-changes
network 10.0.1.0 mask 255.255.255.0
network 172.168.15.0 mask 255.255.255.0
neighbor 192.168.1.2 remote-as 64513
neighbor 192.168.1.2 description <>
neighbor 192.168.1.2 allowas-in
neighbor 192.168.1.2 soft-reconfiguration inbound
!
CE1A#



PE1#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:200
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.1 remote-as 6395
neighbor 192.168.1.1 description <>
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
!
access-list 10 permit 192.168.1.0 0.0.0.3
access-list 20 permit 10.0.4.0 0.0.0.255
access-list 20 permit 10.0.3.0 0.0.0.255

PE1#




P#sh running-config
ip cef
mpls label protocol ldp
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router isis
net 49.0002.9999.7777.6666.00
!

P#

PE2#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
route-target import 64513:200
!
ip vrf CEB
description <>
rd 64513:2
route-target export 64513:200
route-target import 64513:200
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp explicit-null for 10 to 20
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip vrf forwarding CEB
ip address 172.16.29.1255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
clockrate 2000000
!
router isis
net 49.0002.8888.2222.1111.00

!
router bgp 64513
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
!
address-family ipv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEB
redistribute connected
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
neighbor 192.168.1.14 remote-as 6395
neighbor 192.168.1.14 description <>
neighbor 192.168.1.14 activate
neighbor 192.168.1.14 as-override
neighbor 192.168.1.14 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
!
access-list 10 permit 192.168.1.12 0.0.0.3
access-list 20 permit 10.0.3.0 0.0.0.255
access-list 20 permit 10.0.2.0 0.0.0.255
!
route-map Only_Customer permit 10
match interface Serial0/1
!

PE2#




CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.16.25.1255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
!
router bgp 7911
bgp log-neighbor-changes
network 10.0.5.0 mask 255.255.255.0
network 172.16.25.0 mask 255.255.255.0
neighbor 192.168.1.13 remote-as 64513
neighbor 192.168.1.13 local-as 6395
neighbor 192.168.1.13 description <>
neighbor 192.168.1.13 soft-reconfiguration inbound
!
CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.168.15.0/24 is directly connected, Loopback1
B 172.16.25.0/24 [20/0] via 192.168.1.2, 00:12:12
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
B 10.0.5.0 [20/0] via 192.168.1.2, 00:12:12
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.12 [20/0] via 192.168.1.2, 00:18:17
C 192.168.1.0 is directly connected, Serial0/0
172.168.0.0/24 is subnetted, 1 subnets
B 172.168.46.0 [20/0] via 192.168.1.2, 00:04:23




CE1A#ping 172.168.46.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.46.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/74/156 ms
CE1A#


CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

B 172.168.15.0/24 [20/0] via 192.168.1.13, 00:11:30
C 172.16.25.0/24 is directly connected, Loopback1
10.0.0.0/24 is subnetted, 2 subnets
B 10.0.1.0 [20/0] via 192.168.1.13, 00:11:30
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, Serial0/0
B 192.168.1.0 [20/0] via 192.168.1.13, 00:11:30
172.168.0.0/24 is subnetted, 1 subnets
B 172.168.46.0 [20/0] via 192.168.1.13, 00:03:42
CE2A#ping 172.168.46.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.46.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/81/180 ms
CE2A#

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.168.15.0/24 is directly connected, Loopback1
B 172.16.25.0/24 [20/0] via 192.168.1.2, 00:09:26
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
B 10.0.5.0 [20/0] via 192.168.1.2, 00:09:26
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.12 [20/0] via 192.168.1.2, 00:15:31
C 192.168.1.0 is directly connected, Serial0/0
172.168.0.0/24 is subnetted, 1 subnets
B 172.168.46.0 [20/0] via 192.168.1.2, 00:01:37
CE1A#ping 172.168.46.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.46.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/108/160 ms
CE1A#

No comments:

Post a Comment