Saturday, July 4, 2009

Implementing TE in MPLS Cell-Mode L3 VPN Using EIGRP-RIP PE-CE Routing Protocol





Configuration Guidelines::


IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.

ATM Backbone in Provider Network

End User Connected with to CE1A Router using Microsoft Loopback Adapter through the Cloud.


IGP for CE Domain is EIGRP between CE1A and PE1 & RIP between CE2A and PE2

PPP Link used between PE-CE

TE Tunnel 100 between PE1 & P


CE1A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.168.1.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
encapsulation ppp
!
!
router eigrp 10
redistribute connected route-map Only_Local
network 192.168.1.0 0.0.0.3
no auto-summary

!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet0/0

CE1A#






PE1#sh running-config
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
mpls traffic-eng tunnels
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Tunnel100
ip unnumbered Loopback0
tunnel destination 10.0.3.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 512
tunnel mpls traffic-eng path-option 1 explicit name Static
no routing dynamic
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
no cdp enable
!
!
interface ATM2/0
description <>
no ip address
no snmp trap link-status
no atm ilmi-keepalive
!
interface ATM2/0.10 mpls
ip address 192.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 256
!
interface ATM3/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM3/0.30 mpls
ip address 172.16.3.1 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 3 32
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 512
!
router eigrp 1
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 1544 100 255 200 1500
network 192.168.1.0 0.0.0.3
no auto-summary
autonomous-system 10
exit-address-family
!
router isis
net 49.0001.1111.2222.3333.00
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 64513
neighbor 10.0.4.1 description <>
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute eigrp 10
no synchronization
exit-address-family
!
ip explicit-path name Static enable
next-address 172.16.3.2
!
!
mpls ldp router-id Loopback0

PE1#



P#sh running-config
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
mpls traffic-eng tunnels
!
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Tunnel100
ip unnumbered Loopback0
tunnel destination 10.0.2.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 512
tunnel mpls traffic-eng path-option 1 explicit name Static
no routing dynamic
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface ATM2/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM2/0.30 mpls
ip address 172.16.3.2 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 3 32
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 512
!
interface ATM3/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM3/0.20 mpls
ip address 192.168.1.9 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
mpls traffic-eng tunnels
isis circuit-type level-2-only
ip rsvp bandwidth 256
!
router isis
net 49.0002.2222.1111.3333.00
metric-style wide
mpls traffic-eng router-id Loopback0
mpls traffic-eng level-2
!
!
ip explicit-path name Static enable
next-address 172.16.3.1
!
mpls ldp router-id Loopback0
!

P#








PE2#sh running-config
!
ip cef
!
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
encapsulation ppp
serial restart-delay 0
no cdp enable
!
!
interface ATM2/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM2/0.20 mpls
ip address 192.168.1.10 255.255.255.252
ip router isis
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.2222.1111.00
!
router rip
version 2
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64513 metric 4
network 192.168.1.0
no auto-summary
version 2
exit-address-family
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 64513
neighbor 10.0.2.1 description <>
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute rip
no synchronization
exit-address-family
!
mpls ldp router-id Loopback0
!

PE2#













CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
encapsulation ppp
!

!
router rip
version 2
redistribute connected route-map Only_Local
network 192.168.1.0
no auto-summary
!
route-map Only_Local permit 10
match interface Loopback0
!
CE2A#







PE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.3.0 is directly connected, ATM3/0.30
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
i L2 10.0.3.0/24 [115/20] via 10.0.3.1, Tunnel100
C 10.0.2.1/32 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
i L2 192.168.1.8 [115/20] via 10.0.3.1, Tunnel100
C 192.168.1.4 is directly connected, ATM2/0.10


PE1#show mpls traffic-eng tunnels

Name: PE1_t100 (Tunnel100) Destination: 10.0.3.1
Status:
Admin: up Oper: up Path: valid Signalling: connected

path option 1, type explicit Static (Basis for Setup, path weight 10)

Config Parameters:
Bandwidth: 512 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 512 bw-based
auto-bw: disabled

InLabel : -
OutLabel : ATM3/0.30, VC 1/39 (vcd 10)
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.3.1, Tun_Id 100, Tun_Instance 6
RSVP Path Info:
My Address: 10.0.2.1
Explicit Route: 172.16.3.2 10.0.3.1
Record Route: NONE
Tspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
History:
Tunnel:
Time since created: 21 minutes, 32 seconds
Time since path change: 5 minutes, 58 seconds
Current LSP:
Uptime: 5 minutes, 49 seconds
Selection: reoptimation
Prior LSP:
ID: path option 1 [5]
Removal Trigger: configuration changed

LSP Tunnel P_t100 is signalled, connection is up
InLabel : ATM3/0.30, VC 1/36 (vcd 6)
OutLabel : -
RSVP Signalling Info:
Src 10.0.3.1, Dst 10.0.2.1, Tun_Id 100, Tun_Instance 6
RSVP Path Info:
My Address: 10.0.2.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
PE1#



PE1#show mpls traffic-eng tunnels statistics
Tunnel100 (Destination 10.0.3.1; Name PE1_t100)
Management statistics:
Path: 4 no path, 0 path no longer valid, 0 missing ip exp path
1 path changes
State: 1 transitions, 0 admin down, 0 oper down
Signalling statistics:
Opens: 2 succeeded, 0 timed out, 0 bad path spec
0 other aborts
Errors: 0 no b/w, 0 no route, 0 admin
0 bad exp route, 0 rec route loop, 0 other
LSP 10.0.3.1 100 (Destination 10.0.2.1; Name P_t100)
No statistics available for this LSP







P#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.3.0 is directly connected, ATM2/0.30
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.3.0/24 is directly connected, Loopback0
i L2 10.0.2.1/32 [115/20] via 10.0.2.1, Tunnel100
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.8 is directly connected, ATM3/0.20
C 192.168.1.4 is directly connected, ATM1/0.10












P#show mpls traffic-eng tunnels

Name: P_t100 (Tunnel100) Destination: 10.0.2.1
Status:
Admin: up Oper: up Path: valid Signalling: connected

path option 1, type explicit Static (Basis for Setup, path weight 10)

Config Parameters:
Bandwidth: 512 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 512 bw-based
auto-bw: disabled

InLabel : -
OutLabel : ATM2/0.30, VC 1/36 (vcd 5)
RSVP Signalling Info:
Src 10.0.3.1, Dst 10.0.2.1, Tun_Id 100, Tun_Instance 6
RSVP Path Info:
My Address: 10.0.3.1
Explicit Route: 172.16.3.1 10.0.2.1
Record Route: NONE
Tspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
History:
Tunnel:
Time since created: 18 minutes, 22 seconds
Time since path change: 7 minutes, 4 seconds
Current LSP:
Uptime: 6 minutes, 57 seconds
Selection: reoptimation
Prior LSP:
ID: path option 1 [5]
Removal Trigger: configuration changed

LSP Tunnel PE1_t100 is signalled, connection is up
InLabel : ATM2/0.30, VC 1/39 (vcd 10)
OutLabel : -
RSVP Signalling Info:
Src 10.0.2.1, Dst 10.0.3.1, Tun_Id 100, Tun_Instance 6
RSVP Path Info:
My Address: 10.0.3.1
Explicit Route: NONE
Record Route: NONE
Tspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
RSVP Resv Info:
Record Route: NONE
Fspec: ave rate=512 kbits, burst=1000 bytes, peak rate=512 kbits
P#
P#show mpls traffic-eng tunnels statistics
Tunnel100 (Destination 10.0.2.1; Name P_t100)
Management statistics:
Path: 4 no path, 0 path no longer valid, 0 missing ip exp path
1 path changes
State: 1 transitions, 0 admin down, 0 oper down
Signalling statistics:
Opens: 2 succeeded, 0 timed out, 0 bad path spec
0 other aborts
Errors: 0 no b/w, 0 no route, 0 admin
0 bad exp route, 0 rec route loop, 0 other
LSP 10.0.2.1 100 (Destination 10.0.3.1; Name PE1_t100)
No statistics available for this LSP

No comments:

Post a Comment