Sunday, July 5, 2009

Implementing MPLS L3 VPN with PE-CE Routing Protocol Static LAB



Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:1"
AS Used "64513"
PE-CE Routing Used "Static"
IGP Used OSPF

***********************************************************************************
CE1A#sh running-config
!
interface Loopback0
ip address 10.0.1.1 255.255.255.0
description <>
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.1.2

CE1A#

PE1#sh running-config

ip cef
!
ip vrf CEA
rd 64513:1
route-target export 64513:1
route-target import 64513:1
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.0
ip ospf network point-to-point
!

interface Serial0/0
ip vrf forwarding CEA
description <>
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!

interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!
router ospf 10
log-adjacency-changes
network 10.0.2.0 0.0.0.255 area 0
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 5000
no synchronization
bgp log-neighbor-changes
neighbor 10.0.4.1 remote-as 5000
neighbor 10.0.4.1 update-source Loopback0
neighbor 10.0.4.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.4.1 activate
neighbor 10.0.4.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route vrf CEA 10.0.1.0 255.255.255.0 Serial0/0
!

PE1#













P#sh running-config
ip cef
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!

interface Serial0/1
description <>
ip address 192.168.1.9 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!
router ospf 10
log-adjacency-changes
network 10.0.3.0 0.0.0.255 area 0
network 192.168.1.4 0.0.0.3 area 0
network 192.168.1.8 0.0.0.3 area 0
!

P#



PE2#sh running-config
ip cef
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
ip vrf CEA
rd 64513:1
route-target export 64513:1
route-target import 64513:1
!
!
interface Loopback0
description <>

ip address 10.0.4.1 255.255.255.0
ip ospf network point-to-point
!

interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
mpls label protocol ldp
tag-switching ip
clockrate 2000000
!
interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
clockrate 2000000
!
!
router ospf 10
log-adjacency-changes
network 10.0.4.0 0.0.0.255 area 0
network 192.168.1.8 0.0.0.3 area 0
!
router bgp 5000
no synchronization
bgp log-neighbor-changes
neighbor 10.0.2.1 remote-as 5000
neighbor 10.0.2.1 update-source Loopback0
neighbor 10.0.2.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 10.0.2.1 activate
neighbor 10.0.2.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip route vrf CEA 10.0.5.0 255.255.255.0 Serial0/1
!
PE2#




CE2A#sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.13
CE2A#










CE2A#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/124/204 ms
CE2A#tra
CE2A#traceroute 10.0.1.1

Type escape sequence to abort.
Tracing the route to 10.0.1.1

1 192.168.1.13 84 msec 32 msec 8 msec
2 192.168.1.9 192 msec 184 msec 188 msec
3 192.168.1.2 128 msec 156 msec 96 msec
4 192.168.1.1 204 msec 188 msec *
CE2A#

No comments:

Post a Comment