Saturday, July 4, 2009

Implenenting Carrier Supporting Carrier with Customer Carrier not running MPLS


Configuration Guidelines::

Backbone Carrier AS64515
Customer Carrier AS64513
Customer AS64514
VRF Used "CEA" between Backbone Carrier and Customer Carrier
RD Used "64515:1"
RT Used "64515:100"
AS Used "64515"
PE-CE Routing Used "EIGRP"
For Backbone Carrier IGP Used "ISIS" Level 2 between PE1B & PE2B .Loopbacks in Level 1 and PE1B & PE2B in different area.
For Customer Carrier IGP Used "OSPF" between PE1C,PE2C,PE3C & PE4C .
EBGP used as PE-CE Routing Protocol between Customer Carrier and Customer.
MP-iBGP used between PE1B & PE2B
IBGP Used between PE1C & PE2C
IBGP Used between PE3C & PE4C
IBGP Used between PE1C & PE3C

******************************************************************



CE1A#sh running-config
!
interface Loopback0
description <>
ip address 172.16.10.1 255.255.255.0
!
interface Serial0/0
description <<>>
ip address 192.168.1.1 255.255.255.252
!
!
router bgp 64514
bgp log-neighbor-changes
network 192.168.1.0 mask 255.255.255.252
redistribute connected route-map Only_Local
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 ebgp-multihop 2
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 soft-reconfiguration inbound
no auto-summary
!
ip route 10.0.1.0 255.255.255.0 192.168.1.2
!
route-map Only_Local permit 10
match interface Loopback0
!

CE1A#











PE1C#sh running-config
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!

interface Serial0/0
description <<>>
ip address 192.168.1.2 255.255.255.252
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 192.168.1.4 0.0.0.3 area 0
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 172.16.10.1 remote-as 64514
neighbor 172.16.10.1 description <>
neighbor 172.16.10.1 ebgp-multihop 2
neighbor 172.16.10.1 update-source Loopback0
neighbor 172.16.10.1 default-originate
neighbor 172.16.10.1 soft-reconfiguration inbound
no auto-summary
!
ip route 172.16.10.0 255.255.255.0 192.168.1.1
route-map Only_Local permit 10
match interface Loopback0 Serial0/0
!

PE1C#







PE2C#sh running-config
Building configuration...

!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.0
!
interface Serial0/0
description <<>>
ip address 192.168.1.6 255.255.255.252
!
!
interface Serial0/1
description <>
ip address 172.168.1.1 255.255.255.252
!
router eigrp 10
redistribute connected route-map Only_Local
redistribute ospf 10 metric 1544 200 255 100 1500
network 172.168.1.0 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
redistribute eigrp 10 subnets
network 192.168.1.4 0.0.0.3 area 0
default-information originate
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.5.1 remote-as 64513
neighbor 10.0.5.1 description <>
neighbor 10.0.5.1 update-source Loopback0
neighbor 10.0.5.1 route-reflector-client
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.5.1 soft-reconfiguration inbound
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.168.1.2
route-map Only_Local permit 10
!
match interface Loopback0 Serial0/0
CE2A#sh running-config
!
interface Loopback0
description <>
ip address 172.16.20.1 255.255.255.0
!
interface Serial0/0
description <<>>
ip address 192.168.1.14 255.255.255.252
!
router bgp 64514
bgp log-neighbor-changes
network 192.168.1.12 mask 255.255.255.252
redistribute connected route-map Only_Local
neighbor 10.0.6.1 remote-as 64513
neighbor 10.0.6.1 description <>
neighbor 10.0.6.1 ebgp-multihop 2
neighbor 10.0.6.1 update-source Loopback0
neighbor 10.0.6.1 soft-reconfiguration inbound
no auto-summary
!
ip route 10.0.6.0 255.255.255.0 192.168.1.13
!
route-map Only_Local permit 10
match interface Loopback0

PE4C#sh running-config
!
interface Loopback0
description <>
ip address 10.0.6.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
!
interface Serial0/1
description <<>>
ip address 192.168.1.13 255.255.255.252
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 192.168.1.8 0.0.0.3 area 0
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.5.1 remote-as 64513
neighbor 10.0.5.1 description <>
neighbor 10.0.5.1 update-source Loopback0
neighbor 10.0.5.1 next-hop-self
neighbor 10.0.5.1 soft-reconfiguration inbound
neighbor 172.16.20.1 remote-as 64514
neighbor 172.16.20.1 description <>
neighbor 172.16.20.1 ebgp-multihop 2
neighbor 172.16.20.1 update-source Loopback0
neighbor 172.16.20.1 default-originate
neighbor 172.16.20.1 soft-reconfiguration inbound
no auto-summary
!
ip route 172.16.20.0 255.255.255.0 192.168.1.14
!
route-map Only_Local permit 10
match interface Loopback0 Serial0/0
!
PE4C#









PE3C# sh running-config
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 172.168.1.10 255.255.255.252
!
interface Serial0/1
description <<>>
ip address 192.168.1.9 255.255.255.252
!
router eigrp 20
redistribute connected route-map Only_Local
redistribute ospf 10 metric 1544 200 255 100 1500
network 172.168.1.8 0.0.0.3
no auto-summary
no eigrp log-neighbor-changes
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
redistribute eigrp 20 subnets
network 192.168.1.8 0.0.0.3 area 0
default-information originate
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 route-reflector-client
neighbor 10.0.3.1 next-hop-self
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.6.1 remote-as 64513
neighbor 10.0.6.1 description <>
neighbor 10.0.6.1 update-source Loopback0
neighbor 10.0.6.1 soft-reconfiguration inbound
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.168.1.9
!
route-map Only_Local permit 10
match interface Loopback0 Serial0/1
!

PE1B#sh running-config
ip cef
!
ip vrf CEA
description <>
rd 64515:1
route-target export 64515:100
route-target import 64515:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
description <>
ip address 172.168.10.1 255.255.255.0
ip router isis
isis circuit-type level-2-only
!

interface Serial0/0
description <<>>
ip vrf forwarding CEA
ip address 172.168.1.2 255.255.255.252
clockrate 2000000
!

interface Serial0/1
description <>
ip address 172.168.1.5 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!
router eigrp 1
redistribute isis level-2 route-map Only_Local
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64515 metric 1544 200 255 100 1500
network 172.168.1.0 0.0.0.3
no auto-summary
autonomous-system 10
exit-address-family
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
neighbor 172.168.20.1 remote-as 64515
neighbor 172.168.20.1 description <>
neighbor 172.168.20.1 update-source Loopback0
neighbor 172.168.20.1 next-hop-self
neighbor 172.168.20.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 172.168.20.1 activate
neighbor 172.168.20.1 next-hop-self
neighbor 172.168.20.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute eigrp
redistribute eigrp 10
no auto-summary
no synchronization
exit-address-family
!
!
ip prefix-list Local seq 10 permit 172.168.1.4/30
ip prefix-list Local seq 20 deny 0.0.0.0/0 le 32
route-map Only_Local permit 10
match ip address prefix-list Local
!





PE2B#sh running-config
!
ip vrf CEA
description <>
rd 64515:1
route-target export 64515:100
route-target import 64515:100
!
mpls label protocol ldp
tag-switching tdp router-id Loopback0
!
interface Loopback0
description <>
ip address 172.168.20.1 255.255.255.0
ip router isis
isis circuit-type level-2-only
!

interface Serial0/0
description <>
ip address 172.168.1.6 255.255.255.252
ip router isis
mpls label protocol ldp
tag-switching ip
clockrate 2000000
isis circuit-type level-2-only
!

interface Serial0/1
description <<>>
ip vrf forwarding CEA
ip address 172.168.1.9 255.255.255.252
clockrate 2000000
!
router eigrp 1
redistribute isis level-2 route-map Only_Local
no auto-summary
!
address-family ipv4 vrf CEA
redistribute bgp 64515 metric 1544 200 255 100 1500
network 172.168.1.8 0.0.0.3
no auto-summary
autonomous-system 20
exit-address-family
!
router isis
net 49.0002.3333.2222.1111.00
!
router bgp 64515
no synchronization
bgp log-neighbor-changes
neighbor 172.168.10.1 remote-as 64515
neighbor 172.168.10.1 description <>
neighbor 172.168.10.1 update-source Loopback0
neighbor 172.168.10.1 next-hop-self
neighbor 172.168.10.1 soft-reconfiguration inbound
no auto-summary
!
address-family vpnv4
neighbor 172.168.10.1 activate
neighbor 172.168.10.1 next-hop-self
neighbor 172.168.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CEA
redistribute eigrp 20
no auto-summary
no synchronization
exit-address-family
!
ip prefix-list Local seq 10 permit 172.168.1.4/30
ip prefix-list Local seq 20 deny 0.0.0.0/0 le 32
route-map Only_Local permit 10
match ip address prefix-list Local
OUTPUT VERIFICATION
PE1B#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/30 is subnetted, 1 subnets
C 172.168.1.0 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
D EX 10.0.3.0 [170/2297856] via 172.168.1.1, 00:00:44, Serial0/0
D EX 10.0.1.0 [170/2221056] via 172.168.1.1, 00:24:43, Serial0/0
192.168.1.0/30 is subnetted, 1 subnets
D EX 192.168.1.0 [170/2221056] via 172.168.1.1, 00:24:43, Serial0/0
PE1B#




CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 10.0.1.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.10.0 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
S 10.0.1.0 [1/0] via 192.168.1.2
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0
B* 0.0.0.0/0 [20/0] via 10.0.1.1, 00:35:35
CE1A#ping 172.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 84/134/280 ms

PE1B#ping vrf CEA 10.0.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/40/76 ms
PE1B#ping vrf CEA 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/78/100 ms
PE1B#

PE3C#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 172.168.1.9 to network 0.0.0.0

172.168.0.0/30 is subnetted, 2 subnets
D EX 172.168.1.0 [170/2221056] via 172.168.1.9, 00:04:22, Serial0/0
C 172.168.1.8 is directly connected, Serial0/0
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 10.0.3.1, 00:04:17
10.0.0.0/24 is subnetted, 3 subnets
D EX 10.0.3.0 [170/2221056] via 172.168.1.9, 00:04:22, Serial0/0
D EX 10.0.1.0 [170/2221056] via 172.168.1.9, 00:04:22, Serial0/0
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
D EX 192.168.1.0 [170/2221056] via 172.168.1.9, 00:04:22, Serial0/0
S* 0.0.0.0/0 [1/0] via 172.168.1.9

PE3C#traceroute 192.168.1.1

Type escape sequence to abort.
Tracing the route to 192.168.1.1

1 172.168.1.9 44 msec 48 msec 48 msec
2 172.168.1.2 60 msec 72 msec 36 msec
3 172.168.1.1 104 msec 124 msec 88 msec
4 192.168.1.5 52 msec 244 msec 172 msec
5 192.168.1.1 [AS 64514] 96 msec 112 msec *
PE3C#

PE4C#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.1.9 to network 0.0.0.0

172.168.0.0/30 is subnetted, 1 subnets
O E2 172.168.1.0 [110/20] via 192.168.1.9, 00:16:37, Serial0/0
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 10.0.3.1, 00:17:40
10.0.0.0/24 is subnetted, 4 subnets
O E2 10.0.3.0 [110/20] via 192.168.1.9, 00:16:37, Serial0/0
O E2 10.0.1.0 [110/20] via 192.168.1.9, 00:16:37, Serial0/0
C 10.0.6.0 is directly connected, Loopback0
O E2 10.0.5.0 [110/20] via 192.168.1.9, 00:18:35, Serial0/0
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial0/0
O E2 192.168.1.0 [110/20] via 192.168.1.9, 00:16:37, Serial0/0
O E2 192.168.1.4 [110/20] via 192.168.1.9, 00:03:46, Serial0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.1.9, 00:18:35, Serial0/0


PE3C#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 172.168.1.9 to network 0.0.0.0

172.168.0.0/30 is subnetted, 2 subnets
D EX 172.168.1.0 [170/2221056] via 172.168.1.9, 00:27:59, Serial0/0
C 172.168.1.8 is directly connected, Serial0/0
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 10.0.3.1, 00:27:10
10.0.0.0/24 is subnetted, 4 subnets
D EX 10.0.3.0 [170/2221056] via 172.168.1.9, 00:27:59, Serial0/0
D EX 10.0.1.0 [170/2221056] via 172.168.1.9, 00:27:59, Serial0/0
O E2 10.0.6.0 [110/20] via 192.168.1.10, 00:18:59, Serial0/1
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 3 subnets
C 192.168.1.8 is directly connected, Serial0/1
D EX 192.168.1.0 [170/2221056] via 172.168.1.9, 00:27:59, Serial0/0
D EX 192.168.1.4 [170/2221056] via 172.168.1.9, 00:04:18, Serial0/0
S* 0.0.0.0/0 [1/0] via 172.168.1.9
PE3C#

PE2B#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/30 is subnetted, 2 subnets
B 172.168.1.0 [200/0] via 172.168.10.1, 00:30:12
C 172.168.1.8 is directly connected, Serial0/1
10.0.0.0/24 is subnetted, 4 subnets
B 10.0.3.0 [200/2297856] via 172.168.10.1, 00:30:12
B 10.0.1.0 [200/2221056] via 172.168.10.1, 00:30:12
D EX 10.0.6.0 [170/2221056] via 172.168.1.10, 00:19:22, Serial0/1
D EX 10.0.5.0 [170/2297856] via 172.168.1.10, 00:28:25, Serial0/1
192.168.1.0/30 is subnetted, 3 subnets
D EX 192.168.1.8 [170/2681856] via 172.168.1.10, 00:07:12, Serial0/1
B 192.168.1.0 [200/2221056] via 172.168.10.1, 00:30:12
B 192.168.1.4 [200/2681856] via 172.168.10.1, 00:04:39
PE2B#

PE1B#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/30 is subnetted, 2 subnets
C 172.168.1.0 is directly connected, Serial0/0
B 172.168.1.8 [200/0] via 172.168.20.1, 00:30:48
10.0.0.0/24 is subnetted, 4 subnets
D EX 10.0.3.0 [170/2297856] via 172.168.1.1, 00:33:08, Serial0/0
D EX 10.0.1.0 [170/2221056] via 172.168.1.1, 00:33:08, Serial0/0
B 10.0.6.0 [200/2221056] via 172.168.20.1, 00:19:47
B 10.0.5.0 [200/2297856] via 172.168.20.1, 00:28:48
192.168.1.0/30 is subnetted, 3 subnets
B 192.168.1.8 [200/2681856] via 172.168.20.1, 00:07:32
D EX 192.168.1.0 [170/2221056] via 172.168.1.1, 00:33:08, Serial0/0
D EX 192.168.1.4 [170/2681856] via 172.168.1.1, 00:05:24, Serial0/0
PE1B#

PE2C#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 172.168.1.2 to network 0.0.0.0

172.168.0.0/30 is subnetted, 2 subnets
C 172.168.1.0 is directly connected, Serial0/1
D EX 172.168.1.8 [170/2221056] via 172.168.1.2, 00:31:00, Serial0/1
172.16.0.0/24 is subnetted, 1 subnets
B 172.16.10.0 [200/0] via 10.0.1.1, 00:34:38
10.0.0.0/24 is subnetted, 4 subnets
C 10.0.3.0 is directly connected, Loopback0
O E2 10.0.1.0 [110/20] via 192.168.1.5, 00:35:13, Serial0/0
D EX 10.0.6.0 [170/2221056] via 172.168.1.2, 00:20:01, Serial0/1
D EX 10.0.5.0 [170/2221056] via 172.168.1.2, 00:29:01, Serial0/1
192.168.1.0/30 is subnetted, 3 subnets
D EX 192.168.1.8 [170/2221056] via 172.168.1.2, 00:07:47, Serial0/1
O E2 192.168.1.0 [110/20] via 192.168.1.5, 00:35:13, Serial0/0
C 192.168.1.4 is directly connected, Serial0/0
S* 0.0.0.0/0 [1/0] via 172.168.1.2
PE2C#

PE1C#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.1.6 to network 0.0.0.0

172.168.0.0/30 is subnetted, 1 subnets
O E2 172.168.1.8 [110/20] via 192.168.1.6, 00:31:20, Serial0/1
172.16.0.0/24 is subnetted, 1 subnets
S 172.16.10.0 [1/0] via 192.168.1.1
10.0.0.0/24 is subnetted, 4 subnets
O E2 10.0.3.0 [110/20] via 192.168.1.6, 00:35:34, Serial0/1
C 10.0.1.0 is directly connected, Loopback0
O E2 10.0.6.0 [110/20] via 192.168.1.6, 00:20:21, Serial0/1
O E2 10.0.5.0 [110/20] via 192.168.1.6, 00:29:20, Serial0/1
192.168.1.0/30 is subnetted, 3 subnets
O E2 192.168.1.8 [110/20] via 192.168.1.6, 00:08:07, Serial0/1
C 192.168.1.0 is directly connected, Serial0/0
C 192.168.1.4 is directly connected, Serial0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.1.6, 00:33:38, Serial0/1
PE1C#
PE1C# ping 10.0.6.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.6.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 136/205/356 ms
PE1C#

CE1A#ping 10.0.6.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.6.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 176/228/280 ms
CE1A#
PE4C#ping 10.0.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/178/364 ms
PE4C#

PE4C#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 380/920/1812 ms
PE4C#

PE3C#sh ip bgp
BGP table version is 5, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*>i172.16.10.0/24 10.0.3.1 0 100 0 64514 ?
*>i172.16.20.0/24 10.0.6.1 0 100 0 64514 ?
*>i192.168.1.0/30 10.0.3.1 0 100 0 64514 i
*>i192.168.1.12/30 10.0.6.1 0 100 0 64514 i
PE3C#

No comments:

Post a Comment