Saturday, July 4, 2009

Implementing Internet Access through Route Leaking in MPLS L3 VPN LAB


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:1"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
EBGP between PE2 and Internet Router

****************************************************************************

CEA#sh running-config
!
interface Loopback0
description <>
ip address 172.168.46.1 255.255.255.0
!
interface Loopback1
description <>
ip address 10.0.1.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
!
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 192.168.1.0 0.0.0.3 area 0
!

route-map Only_Local permit 10
match interface Loopback1
!

CEA#



PE1#sh running-config
!
ip vrf CEA
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
clockrate 2000000
!
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
!
router ospf 10 vrf CEA
log-adjacency-changes
redistribute static
network 192.168.1.0 0.0.0.3 area 0
default-information originate
!
router isis
net 49.0001.1111.2222.3333.00
redistribute static ip
!
ip route 0.0.0.0 0.0.0.0 192.168.1.6
ip route 172.168.46.0 255.255.255.0 Serial0/0
ip route vrf CEA 0.0.0.0 0.0.0.0 172.16.1.1 global
!

PE1#







PE2#sh running-config
!
interface Loopback0
ip address 10.0.3.1 255.255.255.0
!

interface Serial0/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
clockrate 2000000
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip address 172.16.1.2 255.255.255.252
clockrate 2000000
!
router isis
net 49.0002.1111.3333.2222.00
redistribute connected route-map Only_Local
redistribute bgp 64513
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
network 10.0.2.0 mask 255.255.255.0
network 172.168.46.0 mask 255.255.255.0
network 192.168.1.4 mask 255.255.255.252
neighbor 10.1.1.1 remote-as 64514
neighbor 10.1.1.1 ebgp-multihop 2
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.1 soft-reconfiguration inbound
no auto-summary
!
ip route 10.1.1.0 255.255.255.0 172.16.1.1
!
route-map Only_Local permit 10
match interface Loopback0 Serial0/1
!

PE2#

















Internet_Router#sh running-config
!
interface Loopback0
description <>
ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
description <>
ip address 172.168.25.1 255.255.255.0
!
interface Loopback2
description <>
ip address 172.168.72.1 255.255.255.0
!
interface Serial0/0
description <>
ip address 172.16.1.1 255.255.255.252
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
network 172.168.72.0 mask 255.255.255.0
network 172.168.25.0 mask 255.255.255.0
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 ebgp-multihop 2
neighbor 10.0.3.1 update-source Loopback0
neighbor 10.0.3.1 default-originate
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 route-map Customer out
no auto-summary
!
ip route 10.0.3.0 255.255.255.0 172.16.1.2

!
ip prefix-list Customer seq 10 permit 172.168.25.0/24
ip prefix-list Customer seq 20 deny 0.0.0.0/0 le 32
!
!
route-map Customer permit 10
match ip address prefix-list Customer

Internet_Router#

No comments:

Post a Comment